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1  Safety and regulatory information
The product documentation helps you use the product safely and efficiently. Follow the
instructions provided here and in the following sections.

Intended use

The product generates radio frequency (RF) signals for the development, production
and verification of electronic components, modules or devices. The product is intended
for industrial use, for example for production and conformance testing, maintenance
and engineering laboratories.

Use the product only for its designated purpose. Any other use is considered improper
use. Observe the operating conditions and performance limits stated in the specifica-
tions document.

Target audience

This document targets at all users, including technicians, operators, administrators and
maintenance personnel. The required skills and experience of the users depend on the
test setup and application of the product.

Where do I find safety information?

Safety information is part of the product documentation. It warns you of potential dan-
gers and gives instructions on how to prevent personal injury or damage caused by
dangerous situations. Safety information is provided as follows:
● In Chapter 1.1, "Safety instructions", on page 9. The same information is provi-

ded in many languages in printed format. The printed "Safety Instructions" for
"Mains-Powered Products, Not Heavy" (document number 1171.1771.99) are deliv-
ered with the product.

● Throughout the documentation, safety instructions are provided when you need to
take care during setup or operation.

1.1  Safety instructions

Products from the Rohde & Schwarz group of companies are manufactured according
to the highest technical standards. To use the products safely, follow the instructions
provided here and in the product documentation. Keep the product documentation
nearby and offer it to other users.

Use the product only for its intended use and within its performance limits. Intended
use and limits are described in the product documentation such as the specifications
document, manuals and the printed "Safety Instructions" document. If you are unsure
about the appropriate use, contact Rohde & Schwarz customer support.

Using the product requires specialists or specially trained personnel. These users also
need sound knowledge of at least one of the languages in which the user interfaces
and the product documentation are available.

Safety instructions
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Reconfigure or adjust the product only as described in the product documentation or
the specifications document. Any other modifications can affect safety and are not per-
mitted.

Never open the casing of the product. Only service personnel authorized by
Rohde & Schwarz are allowed to repair the product. If any part of the product is dam-
aged or broken, stop using the product. Contact Rohde & Schwarz customer support at
https://www.rohde-schwarz.com/support.

Lifting and carrying the product

The maximum weight of the product is provided in the specifications document. You
can lift or carry the product by yourself, if you can manage the weight on your own.
Alternatively, you can use lifting or transporting equipment. Follow the instructions pro-
vided by the equipment manufacturer.

Choosing the operating site

Only use the product indoors. The product casing is not waterproof. Water that enters
can electrically connect the casing with live parts, which can lead to electric shock,
serious personal injury or death if you touch the casing.

If Rohde & Schwarz provides accessories designed for outdoor use of your product,
e.g. a protective cover, you can use the product outdoors.

You can operate the product up to an altitude of 2000 m above sea level. If a higher
altitude is permissible, the value is provided in the specifications document. The prod-
uct is suitable for pollution degree 2 environments where nonconductive contamination
can occur. For more information on environmental conditions such as ambient temper-
ature and humidity, see the specifications document.

Setting up the product

Always place the product on a stable, flat and level surface with the bottom of the prod-
uct facing down. If the product is designed for different positions, secure the product so
that it cannot fall over.

If the product has foldable feet, always fold the feet completely in or out to ensure sta-
bility. The feet can collapse if they are not folded out completely or if the product is
moved without lifting it. The foldable feet are designed to carry the weight of the prod-
uct, but not an extra load.

If stacking is possible, keep in mind that a stack of products can fall over and cause
injury.

If you mount products in a rack, ensure that the rack has sufficient load capacity and
stability. Observe the specifications of the rack manufacturer. Always install the prod-
ucts from the bottom shelf to the top shelf so that the rack stands securely. Secure the
product so that it cannot fall off the rack.

Connecting the product

Before connecting the interfaces and measuring inputs of the product to other products
or electrical circuits, make sure that the other products or electrical circuits provide

Safety instructions
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special protection against electric shock. This protection principle is referred to as
SELV (safety extra-low voltage) and is based on a low voltage level and increased
insulation. Exceptions are indicated by a measurement category on the product and
given in the specifications document.

Connecting to power

The product is an overvoltage category II product. Connect the product to a fixed
installation used to supply energy-consuming equipment such as household applian-
ces and similar loads. Keep in mind that electrically powered products have risks, such
as electric shock, fire, personal injury or even death. Replace parts that are relevant to
safety only by original parts, e.g. power cables or fuses.

Take the following measures for your safety:
● Before switching on the product, ensure that the voltage and frequency indicated

on the product match the available power source. If the power adapter does not
adjust automatically, set the correct value and check the rating of the fuse.

● If a product has an exchangeable fuse, its type and characteristics are indicated
next to the fuse holder. Before changing the fuse, switch off the product and dis-
connect it from the power source. How to change the fuse is described in the prod-
uct documentation.

● Only use the power cable delivered with the product. It complies with country-spe-
cific safety requirements. Only insert the plug into an outlet with protective conduc-
tor terminal.

● Only use intact cables and route them carefully so that they cannot be damaged.
Check the power cables regularly to ensure that they are undamaged. Also ensure
that nobody can trip over loose cables.

● Only connect the product to a power source with a fuse protection of maximum
20 A.

● Ensure that you can disconnect the product from the power source at any time.
Pull the power plug to disconnect the product. The power plug must be easily
accessible. If the product is integrated into a system that does not meet these
requirements, provide an easily accessible circuit breaker at the system level.

Cleaning the product

Use a dry, lint-free cloth to clean the product. When cleaning, keep in mind that the
casing is not waterproof. Do not use liquid cleaning agents.

Meaning of safety labels

Safety labels on the product warn against potential hazards.

Potential hazard

Read the product documentation to avoid personal injury or product damage.

Electrical hazard

Indicates live parts. Risk of electric shock, fire, personal injury or even death.

Safety instructions
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Hot surface

Do not touch. Risk of skin burns. Risk of fire.

Protective conductor terminal

Connect this terminal to a grounded external conductor or to protective ground. This connec-
tion protects you against electric shock if an electric problem occurs.

1.2  Labels on R&S SFI100A

Labels on the casing inform about:
● Personal safety, see "Connecting to power" on page 11.
● Product and environment safety, see Table 1-1.
● Identification of the product, see the serial number on the rear panel.
Table 1-1: Labels regarding R&S SFI100A and environment safety

Labeling in line with EN 50419 for disposal of electrical and electronic equipment after the prod-
uct has come to the end of its service life. For more information, see Chapter 16.5, "Disposal",
on page 641.

1.3  Warning messages in the documentation

A warning message points out a risk or danger that you need to be aware of. The sig-
nal word indicates the severity of the safety hazard and how likely it will occur if you do
not follow the safety precautions.

WARNING

Potentially hazardous situation. Could result in death or serious injury if not avoided.

CAUTION

Potentially hazardous situation. Could result in minor or moderate injury if not avoided.

NOTICE

Potential risks of damage. Could result in damage to the supported product or to other
property.

Warning messages in the documentation
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1.4  Where to find key documents on Rohde & Schwarz

Certificates issued to Rohde & Schwarz that are relevant for your country are provided
at www.rohde-schwarz.com/key-documents, e.g. concerning:
● Quality management
● Environmental management
● Information security management
● Accreditations

1.5  Korea certification class A

이 기기는 업무용(A급) 전자파 적합기기로서 판매자 또는 사용자는 이 점을 주의하시기
바라며, 가정외의 지역에서 사용하는 것을 목적으로 합니다.

Korea certification class A

https://www.rohde-schwarz.com/key-documents
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2  Welcome to the R&S SFI100A
The R&S SFI100A is a wideband IF vector signal generator in the high-end range
developed to meet demanding customer requirements for wideband I/Q and RF testing
up to the sub-THz frequency range. Offering excellent signal characteristics and
straightforward and intuitive operation, the R&S SFI100A makes signal generation fast
and easy.

2.1  Key features

Outstanding key features of the R&S SFI100A are:
● IF signal generation from 11 GHz to 21 GHz
● IF output power of up to 0 dBm
● Perfect IF source for external frontends and frequency converters
● Up to 10 GHz RF modulation bandwidth in a compact form factor
● Wideband analog I/Q output signals with Vpp up to 2 V:

– Differential direct DAC output with up to 5 GHz bandwidth
– Amplified differential output with up to 2 GHz bandwidth
– Single-ended output with up to 5 GHz bandwidth

● Fully software-defined option concept to extend the instrument easily with software
options

● Internal baseband generator including ARB with maximum sample rate of
16 Gsample/s, maximum ARB memory of 8 Gsample

● Support of waveforms for generation of 5G NR, IEEE 802.11ad/ay, OFDM, custom
digital modulation and multicarrier continuous wave signals

● Intuitive operation via 5'' touchscreen with block diagram as key element
● Graphical signal monitoring at practically every point in the signal flow
● SCPI macro recorder and code generator for generating executable remote control

code from manual operating steps (for MATLAB®, CVI, etc.)

For more information, refer to the specifications document.

2.2  Documentation overview

This section provides an overview of the R&S SFI100A user documentation. Unless
specified otherwise, you find the documents at:

www.rohde-schwarz.com/manual/sfi100a

Documentation overview

https://www.rohde-schwarz.com/manual/sfi100a
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2.2.1  Getting started manual

Introduces the R&S SFI100A and describes how to set up and start working with the
product. Includes basic operations, typical measurement examples, and general infor-
mation, e.g. safety instructions, etc. A printed version is delivered with the instrument.

2.2.2  Printed safety instructions

Provides safety information in many languages. The printed document is delivered with
the product.

2.2.3  Videos

Find various videos on Rohde & Schwarz products and test and measurement topics
on YouTube: https://www.youtube.com/@RohdeundSchwarz

Documentation overview

https://www.youtube.com/@RohdeundSchwarz
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3  Getting started
This chapter contains the same information as the getting started manual.

3.1  Preparing for use

Here, you can find basic information about setting up the product for the first time.

3.1.1  Lifting and carrying

For safety information, see "Lifting and carrying the product" on page 10.

3.1.2  Unpacking and checking

1. Unpack the R&S SFI100A carefully.

2. Retain the original packing material. Use it to protect the control elements and con-
nectors when transporting or shipping the R&S SFI100A later.
See also Chapter 15, "Transporting", on page 627.

3. Using the delivery notes, check the equipment for completeness. In particular,
check that the delivery includes the two QSFP+ cables.
See "Cable selection and electromagnetic interference (EMI)" on page 18.

4. Check the equipment for damage.

If the delivery is incomplete or equipment is damaged, contact Rohde & Schwarz.

3.1.3  Choosing the operating site

Specific operating conditions ensure proper operation and avoid damage to the prod-
uct and connected devices. For information on environmental conditions such as ambi-
ent temperature and humidity, see the specifications document.

For safety information, see "Choosing the operating site" on page 10.

Electromagnetic compatibility classes

The electromagnetic compatibility (EMC) class indicates where you can operate the
product. The EMC class of the product is given in the specifications document.
● Class B equipment is suitable for use in:

– Residential environments
– Environments that are directly connected to a low-voltage supply network that

supplies residential buildings

Preparing for use
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● Class A equipment is intended for use in industrial environments. It can cause
radio disturbances in residential environments due to possible conducted and radi-
ated disturbances. It is therefore not suitable for class B environments.
If class A equipment causes radio disturbances, take appropriate measures to
eliminate them.

3.1.4  Setting up the R&S SFI100A

For safety information, see:
● "Setting up the product" on page 10
● "Intended use" on page 9

3.1.4.1  Placing the R&S SFI100A on a bench top

To place the product on a bench top

1. Place the product on a stable, flat and level surface. Ensure that the surface can
support the weight of the product. For information on the weight, see the specifica-
tions document.

2. CAUTION! Foldable feet can collapse. For safety information, see "Setting up the
product" on page 10.
Always fold the feet completely in or out. With folded-out feet, do not place any-
thing on top or underneath the product.

3. WARNING! A stack of products can fall over and cause injury. Never stack more
than three products on top of each other. Instead, mount them in a rack.
Stack as follows:

● If the products have foldable feet, fold them in completely.
● All products must have the same dimensions (width and length).
● Do not exceed a total load of 50 kg placed on the product at the bottom of the

stack.

Left = Stacked correctly
Middle left = Stacked incorrectly, too many products
Middle right = Stacked incorrectly, different dimensions
Right = Stacked incorrectly, folded-out feet

4. NOTICE! Overheating can damage the product.

Preparing for use
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Prevent overheating as follows:

● Keep a minimum distance of 10 cm between the fan openings of the product
and any object in the vicinity to provide sufficient airflow and ventilation.

● Do not place the product next to heat-generating equipment such as radiators
or other products.

3.1.4.2  Mounting the R&S SFI100A in a rack

To prepare the rack

1. Observe the requirements and instructions in "Setting up the product" on page 10.

2. NOTICE! Insufficient airflow can cause overheating and damage the product.
Design and implement an efficient ventilation concept for the rack.

To mount the R&S SFI100A in a rack

1. Use an adapter kit that fits the dimensions of the R&S SFI100A to prepare the
instrument for rack mounting.

a) Order the rack adapter kit designed for the R&S SFI100A. For the order num-
ber of the kit, see the specifications document.

b) Mount the adapter kit. Follow the assembly instructions provided with the
adapter kit.

2. Lift the R&S SFI100A to shelf height.

3. Push the R&S SFI100A onto the shelf until the rack brackets fit closely to the rack.

4. Tighten all screws at the rack brackets with a tightening torque of 1.2 Nm to secure
the R&S SFI100A in the rack.

To unmount the R&S SFI100A from a rack

1. Loosen the screws at the rack brackets.

2. Bring the lifting equipment to shelf height.

3. Remove the R&S SFI100A from the rack.

4. If placing the R&S SFI100A on a bench top again, unmount the adapter kit from the
R&S SFI100A. Follow the instructions provided with the adapter kit.

3.1.5  Considerations for test setup

Cable selection and electromagnetic interference (EMI)

Electromagnetic interference (EMI) can affect the measurement results.

Preparing for use
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To suppress electromagnetic radiation during operation:
● Use the two cables 100G QSFP28 Passive Direct Attach Copper Twinax for con-

necting the Dig. IQ HS interfaces of the instrument. The cables are included in the
delivery of the instrument and are available under order number 3708.5920.00.
How to: Chapter 3.1.10, "Establishing the high-speed digital crosslink",
on page 22

● Use high-quality shielded cables, for example, double-shielded RF, LAN and USB
cables.

● Always terminate open cable ends.
● Ensure that connected external devices comply with EMC regulations.
● Use cables of the same type and equal length for connection to the I/Q interfaces

of the instrument.

Signal input and output levels

The specifications document provides information on signal levels. Keep the signal lev-
els within the specified ranges to avoid damage to the R&S SFI100A and connected
devices.

Over-the-air (OTA) tests

For over-the-air (OTA) tests, operate the instrument in a shielded environment.

For more information, refer to the specifications document.

3.1.6  Connecting to power

For safety information, see "Connecting to power" on page 11.

1. Plug the AC power cable into the AC power connector on the rear panel. Only use
the AC power cable delivered with the R&S SFI100A.

2. Plug the AC power cable into a power outlet with ground contact.

The required ratings are listed next to the AC power connector.

For more information, refer to the specifications document.

3.1.7  Connecting to LAN

Network environment

Before connecting the product to a local area network (LAN), consider the following:
● Install the latest firmware to reduce security risks.
● For internet or remote access, use secured connections if applicable.

Preparing for use
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● Ensure that the network settings comply with the security policies of your company.
Contact your local system administrator or IT department before connecting your
product to your company LAN.

● When connected to the LAN, the product may potentially be accessed from the
internet, which may be a security risk. For example, attackers might misuse or
damage the product.

To connect to LAN

► Connect the LAN socket on the rear panel via an RJ-45 cable to the LAN.

Using DHCP (dynamic host configuration protocol), the R&S SFI100A assigns the
IP address automatically.

If connected to the LAN, the R&S SFI100A displays the IP address and the host-
name at the left bottom of the block diagram.

1 2

1 = IP address
2 = Hostname

If disconnected from the LAN, the R&S SFI100A displays the IP address 0.0.0.0.

See also Chapter 12.8, "Setting up remote control", on page 374.

3.1.8  Connecting a monitor

This section describes how to connect a monitor for direct operation of the
R&S SFI100A. You can skip the following procedure, if you only operate the
R&S SFI100A remotely.

1. Connect the monitor to the "Display Port" socket of the R&S SFI100A on the rear
panel.
The "Display Port" socket does not support a dual-mode Display Port (DP++). Use
an active adapter if you connect to HDMI cables, for example.

2. At the monitor, connect the cable to one of the following sockets:
● Display Port: Connect it to the Display Port socket of the monitor.
● HDMI: You need an active adapter Display Port to HDMI. Passive adapters do

not work.
● VGA: You need an active adapter, Display Port to VGA. Passive adapters do

not work.

If the monitor provides touch functionality, an additional connection can be required, for
example, a USB connection. Refer to the documentation of your monitor.

Preparing for use
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3.1.9  Connecting USB devices

You can connect or disconnect all USB devices from the R&S SFI100A during opera-
tion.

To connect USB storage devices

USB storage devices, such as memory sticks, allow data transfer from or to the
R&S SFI100A. You can also use them for firmware updates.

1. Connect the USB storage device to the USB type A connector on the front panel.

2. Connect the device directly, without a connecting cable.
Connecting cables can cause electromagnetic radiation and impair a measurement
result.

To connect USB devices with an external power supply

1. NOTICE! Connected devices with external power supply can feed back current into
the 5 V power supply of the USB interface and thus damage the R&S SFI100A.
Ensure that there is no connection between the positive pole of the power supply
and the +5 V power pin of the USB interface (VBUS).

2. Connect the USB storage device to a USB connector on the rear panel.

To connect a keyboard

► Connect the USB storage device to a USB connector on the rear panel.

When connected, the R&S SFI100A detects the keyboard automatically. A detected
keyboard has the default layout English – US.

To connect a mouse

► Connect the USB storage device to a USB connector on the rear panel.

When connected, the R&S SFI100A detects the mouse automatically.

To connect power sensors

Connect power sensors of the R&S NRP families to a USB connector on the rear
panel.

See Chapter 7.5, "Using power sensors", on page 212.
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3.1.10  Establishing the high-speed digital crosslink

For correct operation, always connect the "Dig. IQ HS x" connectors to establish the
high-speed I/Q data crosslink between the two baseband signal boards BBCV. Con-
nect the connectors as follows:

1. For connection, use the two cables 100G QSFP28 Passive Direct Attach Copper
Twinax.
See "Cable selection and electromagnetic interference (EMI)" on page 18.

2. To connect the cable and the interface, proceed as follows:

a) Hold the QSFP+ plug of the cable by its panes.
b) Turn the QSFP+ cable, so that the release tab shows upwards.

See also (5) in Figure 3-1.
c) Insert and push the QSFP+ plug into the QSFP+ cage.

If you hear a clicking sound, the plug engaged correctly with the cage and the
cable is connected to the interface.

3. For the I component of the I/Q data crosslink, connect "Dig. IQ HS 1" and "Dig. IQ
HS 3".

See also (1) and (3) in Figure 3-1.

4. For the Q component of the I/Q data crosslink, connect "Dig. IQ HS 2" and "Dig. IQ
HS 4".

See also (2) and (4) in Figure 3-1.

Figure 3-1: QSFP+ connections for I/Q data crosslink
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1, 3 = I components crosslink with connectors "Dig. IQ HS 1" and "Dig. IQ HS 3"
2, 4 = Q components crosslink with connectors "Dig. IQ HS 2" and "Dig. IQ HS 4"
5 = Release tab (pull-strap) of the QSFP+ cable

To disconnect from the QSFP+ interface

1. NOTICE! If you pull the cable, you can damage the cable and the Dig. IQ HS con-
nector.
Pull the release tab.

2. Pull the QSFP+ plug out of the QSFP+ cage.

About the QSFP+ interface

The "Dig. IQ HS" connector is a QSFP+ (quad small form factor pluggable) interface or
QSFP28 interface. The connector socket has two components: a QSFP+ cage and a
QSFP+ connector. The QSFP+ cable is equipped with the QSFP+ plug. The interface
supports a maximum bandwidth of up to 50 Gsample/s with active optical cables.

1
2

3

1 = QSFP+ plug
2 = QSFP+ cage
3 = QSFP+ connector

3.1.11  Connecting to RF coaxial connectors

Here, you find information on how to prepare and to connect to RF coaxial connectors
of the R&S SFI100A. Use these RF connectors, for example, for output of the RF sig-
nal or for input of an external reference signal.

To prepare for connecting

1. NOTICE! Damaged or not clean connections can lead to RF insertion loss and mis-
match, and even premature wear of the connectors.
Before connecting to the port, inspect the RF connector visually. Check that it is
clean, undamaged and mechanically compatible.
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2. NOTICE! DC voltage at the RF connector can damage the instrument. Never apply
DC voltage to the RF input connectors.
Make sure that the values are within the DC limits given in the specifications docu-
ment.

3. If your test setup has a DC component at the RF input, insert a DC blocker.

4. Use a high-quality RF cable that matches the RF connector type. See also "Cable
selection and electromagnetic interference (EMI)" on page 18.

5. You can connect to two kinds of connectors:
● "To connect to screwable connectors" on page 24
● "To connect to pluggable connectors" on page 24

To connect to screwable connectors

► NOTICE! Excessive tightening can damage the connectors.
To connect the cable with the connector, proceed as follows:

a) Carefully align the connector of the cable and the connector along a common
axis.

b) Mate the connectors along the common axis until the male pin of the inner con-
nector engages with the female socket of the outer connector.

c) Turn the nut of the outer connector until the connectors are firmly coupled.
d) Using a calibrated torque wrench torque the nut to the limit as in the table

below. Hold the opposite connector part stationary with a spanner.

The R&S SFI100A provides screwable RF connectors as in Table 3-1.

Table 3-1: Connector name, type, size, torque limit and nut opening

Connector  Torque limit  Nut opening  

Type Name lb-Inch Nm Inch mm

SMA I/Q / I/Q bar

Ref In 2

Ref Out 2/3

User 1/2/3

5 0.56 5/16 8

2.92 mm RF Out*) 8 0.9 5/16 8

To connect to pluggable connectors

The R&S SFI100A provides pluggable Bayonet Neill-Concelman (BNC) connectors.

► To connect the RF cable with the BNC connector, proceed as follows:

a) Carefully align the connector of the cable and the BNC connector along a com-
mon axis.

b) Mate the connectors along the common axis until the male pin of the connector
of the cable engages with the female socket of the BNC connector.
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For more information on handling and maintaining coaxial RF connectors, see the
application note 1MA99.

For information on mounting test port adapters onto the RF connector, see the applica-
tion note 1MA100.

3.1.12  Connecting to RF Out

1. Before connecting, disable the RF output:
In the block diagram, switch off the RF block.

2. For connection, use the connector "RF Out" on the front panel.
See "To connect to screwable connectors" on page 24.

To prevent RF output switch-off

► NOTICE! If you set a too high output level without a load connected to the instru-
ment, the reverse power can exceed a limit forcing the R&S SFI100A to switch off
the RF output.
Connect a load with sufficient return loss.
For more information, refer to the specifications document.

3.1.13  Connecting to Ref In/Ref Out

For connection, the R&S SFI100A provides BNC connectors or SMA connectors on the
rear panel. See "To connect to pluggable connectors" on page 24 and "To connect to
screwable connectors" on page 24.

3.1.14  Switching on or off

The following table provides an overview of power states, LEDs and positions of the
power switch.
Table 3-2: Overview of power states

State LED Position of power switch

Off  gray [0]

Standby  orange [I]

Ready  green [I]

To switch on the R&S SFI100A

The R&S SFI100A is off but connected to power. See Chapter 3.1.6, "Connecting to
power", on page 19.

1. Set the switch on the power supply to position [I] on the rear panel.
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The LED of the [On/Standby] key on the front panel is orange.

2. Press the [On/Standby] key on the front panel.

The LED changes to green. The R&S SFI100A boots.

After booting, the R&S SFI100A starts up displaying the block diagram on the
screen on the front panel.

To check startup functions

When starting for the first time, the R&S SFI100A starts with the default settings. When
restarting, the R&S SFI100A recalls the instrument configuration before shut-down.

See Chapter 10.4.2, "Saving and recalling instrument settings", on page 281.

When switched on, the R&S SFI100A monitors the main functions and logs erroneous
functions. See the following:

See Chapter 14.4, "Querying notifications", on page 617.

To shut down the product

The product is in the ready state.

► Press the [On/Standby] key.

The operating system shuts down. The LED changes to orange.

To disconnect from power

The R&S SFI100A is in the standby state.

1. NOTICE! Risk of data loss. If you disconnect the product from power when it is in
the ready state, you can lose settings and data. Shut it down first.
Set the toggle switch on the power supply to position [0].

The LED of the [On/Standby] key is switched off.

2. Disconnect the R&S SFI100A from the power source.

3.2  Instrument tour

This chapter explains the control elements and the connectors of the R&S SFI100A.
The views of the front panel and the rear panel help you to get familiar with the instru-
ment and to perform the first steps. For specifications of the interfaces, see the specifi-
cations document.

The meanings of the labels on the R&S SFI100A are described in Chapter 1.2, "Labels
on R&S SFI100A", on page 12.
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3.2.1  Front panel tour

This section provides an overview of the control elements and connectors of the front
panel of the R&S SFI100A. On the rear panel, you find all further connectors.

13 11 10 9 8 7 6 5

1

12

42 3

Figure 3-2: Front panel view

1 = Utility keys
2 = Touchscreen
3 = Rotary knob
4 = Function keys
5 = Sync In/Sync Out
6 = User x
7 = LO In
8 = RF Out
9 = Single connectors
10 = Diff connectors
11 = DAC connectors
12 = USB
13 = On/Standby key

3.2.1.1  Touchscreen

The screen on the front panel displays the block diagram and the most important set-
tings. Also, the screen display provides status and setting information and allows you
to quickly reconfigure the signal flow. The screen is touch-sensitive, offering an alterna-
tive means of user interaction for quick and easy handling of the instrument.

Any user interface elements that react to a click by a mouse pointer also react to a tap
on the screen, and vice versa. Using the touchscreen, you can perform the following
tasks (among others) by the tap of your finger:
● Changing a setting
● Selecting new settings
● Scrolling through a list or a table of parameters
● Saving or recalling settings
● Opening and closing dialogs

See also:
● Chapter 16.1, "Cleaning", on page 628, for instructions on cleaning the screen.
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3.2.1.2  Keys

On/Standby key

The [On/Standby] key switches the instrument from the standby to the ready state or
vice versa.

The LED below the [On/Standby] key indicates the instrument state, see Chap-
ter 3.1.14, "Switching on or off", on page 25.

Utility keys

The utility keys set the instrument to a defined state, provide information on the instru-
ment and provide access to the instrument help.
Table 3-3: Utility keys

Utility key Assigned functions

[Preset] Sets the instrument to a defined state.

[Save/Recall] Opens the file manager to save or load an instrument configuration.

Accesses the file manager

[Help] Opens the "Help" dialog and displays the description for a context-sensitive help topic.

Function keys

Function keys provide access to the most common generator settings and functions.
Table 3-4: Function keys

Function key Assigned functions

[Home] Brings the block diagram to the foreground and minimizes opened dialogs.

[Freq/Level] Pressing once: Enables frequency entry. Pressing twice: Enables level entry.

Toggles between frequency and level entry.

[★] User key with a customizable function.

[RF On/Off] Switches the RF output on and off. The status bar above the block diagram displays the
current RF output state.

[Esc] For non-edit mode, closes all kinds of dialog boxes analogous to tapping the "Cancel"
button.

In edit mode, quits this mode and keeps the last entry during editing.

Rotary knob

The rotary knob has several functions:
● Increments (clockwise direction) or decrements (counterclockwise direction)

numeric instrument parameters at a defined step size.
● Moves the selection, e.g. to a function block in the block diagram.
● Shifts the selection bar within focused areas (e.g. lists).
● Activates editing of entries or confirms and terminates entries.
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● Opens a context-sensitive menu, if you press and hold the knob.

3.2.1.3  Connectors

There are SMA connectors, a USB connector and "Sync" connectors on the front
panel.

USB
Female USB (universal serial bus) 2.0 connector of type A (host USB). You can con-
nect, for example, a keyboard, a mouse or a USB memory stick.
How to: Chapter 3.1.9, "Connecting USB devices", on page 21

Single connectors
Two female SMA connectors for single-ended I/Q output signals.
How to: "To connect to screwable connectors" on page 24

Diff connectors
Four female SMA connectors for amplified differential I/Q signal output.
"I/Q" Two connectors for the positive differential I/Q output signal.
"I/Q bar" Two connectors for the negative differential I/Q output signal.
How to: "To connect to screwable connectors" on page 24

DAC connectors
Four female SMA connectors for differential I/Q signal output direct from the D/A con-
verter (DAC) board.
"I/Q" Connectors for the positive differential I/Q output signal.
"I/Q bar" Connectors for the negative differential I/Q output signal.
How to: "To connect to screwable connectors" on page 24

RF Out
Female 2.92 mm connector for output (50Ω) of the RF signal.
How to: "To connect to screwable connectors" on page 24

LO In
Female 2.92 mm connector for input (50Ω) of a local oscillator (LO) signal. The con-
nector is for future use.

User x
Four female SMA multipurpose connectors for user-configurable input and output sig-
nals.
Table 3-5 lists available User x connectors and their description.
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Table 3-5: User x front panel connectors

Connector Description

User 1 Trigger signal input or output, high-level and low-level control signal output.

User 2 Trigger signal input or output, high-level and low-level control signal output.

User 3

User 3 bar

Differential trigger signal output, high-level and low-level control signal output.

A dedicated LED indicates the connector status:
●  green: an input connector
●  yellow: an output connector
●  no light / gray: the connector is not active
See also Chapter 4.5, "Configuring global connectors", on page 121.
How to: "To connect to screwable connectors" on page 24

Sync In/Sync Out
Connector for multi-Instrument setups to synchronize input signals and output signals.
For future use.

3.2.2  Rear panel tour

This section provides an overview of the connectors on the rear panel of the instru-
ment. For technical data of the connectors, refer to the specifications document.

1 2 3 4 5 6

7891011121314

Figure 3-3: Rear panel

1 = AC power supply connector and switch
2 = Serial number (six digits in the string 1444.4001.02-<serial number>-<checksum>)
3 = Ref In/Ref Out
4 = Display Port
5 = LAN
6 = USB
7, 11 = Dig. IQ HS x
8, 12 = IP Data
9, 13 = User x
10, 14 = X x
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3.2.2.1  Connectors

AC power supply connector and switch
Mains power switch for performing the following tasks:
● Connecting the internal power supply to the power source
● Disconnecting the internal power supply from the power source
The required ratings are listed next to the AC power connector and in the specifications
document.
How to:
● Chapter 3.1.6, "Connecting to power", on page 19
● Chapter 3.1.14, "Switching on or off", on page 25
● Chapter 16.2, "Changing fuses", on page 628

Ref In/Ref Out
Input or output for an external reference signal.
For reference signals with frequency fref of 250 MHz and lower, connect to the BNC
female connectors "Ref In 1" and "Ref Out 1".
For reference signals with frequency fref higher than 250 MHz, connect to the SMA
female connectors "Ref In 2", "Ref Out 2" and "Ref Out 3".
How to:
● fref ≤ 250 MHz: "To connect to pluggable connectors" on page 24
● fref > 250 MHz: "To connect to screwable connectors" on page 24

Display Port
Display Port monitor connector.
How to:Chapter 3.1.8, "Connecting a monitor", on page 20

LAN
RJ-45 connector to connect the R&S SFI100A to a LAN for remote control, remote
operation and data transfer.
How to: Chapter 3.1.7, "Connecting to LAN", on page 19

USB
Two female USB (universal serial bus) 3.1 connectors of type A (host USB). They have
the same functionality as the USB connector on the front panel, but provide higher data
rates. See "USB" on page 29.
How to: Chapter 3.1.9, "Connecting USB devices", on page 21

Dig. IQ HS x
QSFP+ or QSFP28 interface connectors that provide the high-speed I/Q data link
between the two baseband signaling boards BBCV.
For correct operation, always connect the "Dig. IQ HS x" connectors to establish the
high-speed I/Q data crosslink between the two baseband signal boards BBCV. Con-
nect the connectors as follows:
● I component of the I/Q link:

Connect "Dig. IQ HS 1" and "Dig. IQ HS 3".
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● Q component of the I/Q link:
Connect "Dig. IQ HS 2" and "Dig. IQ HS 4".

How to: Chapter 3.1.10, "Establishing the high-speed digital crosslink", on page 22

IP Data
"IP Data 1" and "IP Data 2" connectors with an SFP+ (small form factor pluggable)
interface. The connectors are for future use.

User x
Four BNC connectors with fixed marker output signal routing.
Table 3-6 lists available User x connectors and their description.
Table 3-6: User x rear panel connectors

Connector Description

User 4 "Marker 4" output signal

User 5 "Marker 3" output signal

User 6 "Marker 2" output signal

User 7 "Marker 1" output signal

How to: "To connect to pluggable connectors" on page 24

X x
Four BNC multipurpose connectors for future use.
How to: "To connect to pluggable connectors" on page 24

3.3  Trying out the instrument

This chapter provides step-by-step instructions to introduce the most important func-
tions and settings of the R&S SFI100A.

Prerequisites

● The R&S SFI100A is equipped with its base unit configuration.
● The R&S SFI100A is connected to the power supply and started up.

See Chapter 3.1.6, "Connecting to power", on page 19.
● The R&S SFI100A has its default configuration after an instrument preset.

See also "Overview of the characteristics of the preset functions" on page 273.

Base unit

The R&S SFI100A has the following options when equipped as a base unit:
● Frequency option R&S SFI-B1016
● ARB option R&S SFI-K510 with 4 GHz RF bandwidth and 2 Gsample memory
● Frontend control option R&S SFI-K553
● Reference input and output option R&S SFI-K703

Trying out the instrument
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Instrument equipment and screenshots

In this description, the screenshots show a fully equipped instrument. Consider that
some settings in the block diagram or in the configuration dialogs can differ from the
settings of your instrument.

For the first signal generation tasks, you use the internal baseband and reference sig-
nal, so you do not need any additional signal source. More complex signal generation
tasks require an instrument equipped with additional options or external signals.

The following sections provide introductory step-by-step instructions using the touch-
screen. Each instruction lists the prerequisites to execute the instruction.

● Generating an unmodulated RF signal................................................................... 33
● Generating a modulated RF signal......................................................................... 34
● Generating a wideband RF signal...........................................................................36

3.3.1  Generating an unmodulated RF signal

This step-by-step instruction explains how to generate an unmodulated RF continuous
wave signal. This signal is an IF signal in the frequency range of 11 GHz to 21 GHz.
The signal is sufficient for generic IF receiver testing, for example for testing chipsets.

1. Connect the RF Out connector of the R&S SFI100A to the RF input connector of
the DUT.
See "To connect to screwable connectors" on page 24.

2. Configure the IF signal:

a) In the status bar, select the "Frequency" field to enter a frequency value.
For example, enter 16g to set an IF frequency value of 16 GHz.

b) Select the "Level" field to enter a level value.
For example, enter -20 to set an IF level value of -20 dBm.

3. In the block diagram, select "RF" > "On" to enable IF signal generation.
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The status bar displays the set frequency and the level of the IF signal. The
R&S SFI100A outputs this IF signal at the "RF Out" connector on the front panel.

3.3.2  Generating a modulated RF signal

This step-by-step instruction explains how to generate a modulated RF signal. This sig-
nal is an IF signal in the frequency range of 11 GHz to 21 GHz. The signal is sufficient
for generic IF receiver testing, for example for testing chipsets.

1. Connect the "RF Out" connector of the R&S SFI100A to the RF input connector of
the DUT.
See "To connect to screwable connectors" on page 24.

2. In the block diagram, select "Baseband" > "Misc" > "ARB".

The ARB dialog opens.

3. Load a waveform file. For example, load the file 5GNR_test.wv that resembles
the default configuration of a 5G NR baseband signal.
See section Chapter 4.3.4.2, "Loading and playing waveform files", on page 84.

4. Optionally, to check the waveform file properties, select "Waveform Info".
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The dialog provides detailed information on the waveform file including the file size
and the clock frequency.

5. Select "State" > "On".

The R&S SFI100A loads the waveform file and starts signal processing.

6. In the status bar, configure the frequency and the level of the IF signal.
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7. In the block diagram, select "RF" > "On" to enable IF signal generation.

The R&S SFI100A outputs this IF signal at the "RF Out" connector on the front
panel.

3.3.3  Generating a wideband RF signal

When operating the R&S SFI100A with a connected external frontend, you can gener-
ate upconverted wideband RF signals. For example, with a connected R&S FE170ST,
R&S SFI100A generates RF signals in the D band.

This section provides step-by-step descriptions for connecting, controlling and generat-
ing RF signals with external frontends. Connecting instructions use the R&S FE170ST
as an example. Connecting other external frontend is analogous. The instructions
cover the following topics:
● "To connect an external frontend" on page 36
● "To configure the R&S SFI100A for frontend control" on page 37
● "To output a generated wideband RF signal" on page 39

To connect an external frontend

This step-by-step instruction describes how to connect the R&S SFI100A to an
R&S FE170ST. The instruments are switched on and connected to power.

1. NOTICE! Cable selection. Use all cables delivered with the external frontend.
Other connections can require additional cables.
For the IF connection, use the IF cable (order number 1348.3850.00). For the ref-
erence signal connection, use the reference cable (order number 1347.7569) deliv-
ered with the external frontend. For the LAN connection, use a high-quality cable.
See also Chapter 3.1.5, "Considerations for test setup", on page 18.

2. Connect the "RF Out" connector of the R&S SFI100A with the "IF In" connector of
the R&S FE170ST.
See also "To connect to screwable connectors" on page 24.
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3. Connect the "LAN" connector with the "LAN" connector of the R&S FE170ST.
See also Chapter 3.1.7, "Connecting to LAN", on page 19.

4. Check if the host name (1), IP address (2), subnet mask (3) and gateway address
(4) of the R&S FE170ST are correct.
Once connected to LAN, the electronic label on the right side panel of the
R&S FE170ST displays these network parameters:

For more information, see section "Electronic label" in the manual of the external
frontend.

5. Connect the "Ref Out 2" connector of the R&S SFI100A with the "Ref In" connector
of the R&S FE170ST.
See also "To connect to screwable connectors" on page 24.

Table 3-7 and Figure 3-4 provide an overview on connections and a test setup.
Table 3-7: R&S SFI100A and R&S FE170ST connections

Signal R&S SFI100A R&S FE170ST

Reference Connector: "Ref Out 2"

Frequency: 1 GHz, 8 GHz

"Ref In"

LAN (Control) "LAN" "LAN"

IF In "RF Out" "IF In"

RF Out - "RF Out"

DUT

RF shield box
Vector signal
generator

RF

Ref Out Ref

LAN

IF In RF Out

Ref In

LAN RF Out

R&S
FE170STLAN

IF In

Figure 3-4: Test setup: R&S SFI100A, R&S FE170ST and RF shield box

To configure the R&S SFI100A for frontend control

The following procedure describes how to configure the R&S SFI100A to establish a
control connection between R&S SFI100A and an external frontend. The
R&S SFI100A is connected to the external frontend.

See "To connect an external frontend" on page 36.

1. In the taskbar, select "System Config" > "System Configuration" > "External RF".
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2. Select "RF Out" > "External Instrument" > "Config".

The "Remote Instrument" dialog opens.

3. Select the connected external frontend from "External Instrument" selection.
The selection displays available instruments in format
<product>-<serial_number>, for example "FE170ST-123456".

4. In the field "Hostname or IP Address", check if the host name or IP address of the
connected external frontend is correct.
If read out correctly, the host name or IP address match with the information dis-
played on the electronic label of the external frontend.
See step 4) in the section "To connect an external frontend" on page 36.

5. Select "Apply and Connect".

A message displays if the remote connection to the external frontend is established
or not.

Figure 3-5: Message displaying an established remote connection

If connected successfully, you can configure dedicated frontend settings in the
"Frontend Configuration" dialog.
See "To configure external frontend settings" on page 180.

6. Select "System Config" > "System Configuration" > "External RF".
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The dialog displays the settings and state of the connected external instrument.
The "RF" > "Rem Conn" field displays an active control connection:

The control connection is established, the LAN LED on the external frontend
switches from green to orange.

If you change the network configuration, e.g. the IP address, the connection to the
R&S SFI100A is aborted. Re-establish a connection to the frontend as in step 3).

If you have connection issues, see the following section:
● Chapter 7.1.4, "Troubleshooting external frontends", on page 197

To output a generated wideband RF signal

The procedure assumes that a remote control connection between R&S SFI100A and
R&S FE170ST is established, the frontend settings are configured and a test signal is
loaded.

See also Chapter 3.3.2, "Generating a modulated RF signal", on page 34.

1. Return to the block diagram.

2. Configure the RF output signal.
Once you connect the external frontend, the R&S SFI100A sets the "Frequency" in
the status bar automatically. In particular, the R&S SFI100A and the R&S FE170ST
set the lower frequency of the frequency band that is 110 GHz.

a) In the status bar of the R&S SFI100A, set the frequency of the RF signal, for
example to 140 GHz.

b) In the status bar of the R&S SFI100A, set the level of the RF signal, for exam-
ple to -25 dBm.

Trying out the instrument
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3. In the block diagram, select "RF" > "On".

The RF signal is output at the external frontend.

3.4  Operating the instrument

This chapter provides an overview on basic operating tasks. There are three ways to
operate the R&S SFI100A.

Manual operation

Use the touchscreen, keys and rotary knobs, or an optional mouse and/or keyboard.
The principles of manual operation are explained in this section.

Remote control

Create programs to automatize repeating settings, tests, and measurements. The
instrument is connected to a computer that runs the program.

This way of operation is described in Chapter 12.1, "Overview of remote access
modes", on page 346.

Remote operation

For remote monitoring and operation of the instrument, a VNC server is installed on the
R&S SFI100A. You need a LAN connection to the computer, and a VNC client or
browser to connect to the instrument.

This way of operation is described in Chapter 12.1, "Overview of remote access
modes", on page 346.

The following sections show how to operate the instrument manually.

● Means of manual interaction...................................................................................41
● Understanding the display information....................................................................41
● Accessing the functionality......................................................................................46
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● Entering data...........................................................................................................47
● Undo and redo actions............................................................................................48
● Getting information and help...................................................................................48

3.4.1  Means of manual interaction

For the manual interaction with the R&S SFI100A, you have several methods that you
can use as an alternative to perform a task:
● Touchscreen:

Touchscreen operation is the most direct way to interact. Almost all control ele-
ments and actions on the screen are based on the standard operating system con-
cept. You can tap any user interface element to set parameters in dialog boxes,
enter data, scroll within a dialog etc., as if you work with a mouse pointer.
Tapping the screen works like clicking mouse buttons:
– Touch quickly = click: Selects a parameter or provokes an action.
– Touch and hold = right-click: Opens a context-sensitive menu.
– Touch and swipe = drag: Scrolls through the contents of a display element

larger than the screen, e.g. a list or a table.
● Function keys and rotary knob:

The front panel provides nearly all functions and controls to operate the instrument
in the classic way, without touchscreen.

● Optional mouse and/or keyboard:
These devices work like known from PCs. The navigation keys on the front panel
correspond to the keys on the keyboard.

This manual describes the manual interaction with the instrument via the touchscreen.
It mentions the alternative methods using the keys on the instrument or the on-screen
keypads if it deviates from the standard operating procedures. The usage of the touch-
screen and navigation keys is described in Chapter 3.4.3, "Accessing the functionality",
on page 46.

Throughout the manual, the term "select" refers to any of the following methods:
● Using a finger on the touchscreen
● Using a mouse pointer in the display
● Using a key on the instrument or on a keyboard

3.4.2  Understanding the display information

The block diagram of the R&S SFI100A displays all main settings and generator
states, divided into main operation areas.

Operating the instrument
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Figure 3-6: Block diagram

1 = Status bar
2 = Block diagram
3 = Taskbar

● Status bar................................................................................................................42
● Block diagram......................................................................................................... 43
● Taskbar....................................................................................................................44
● Additional display characteristics............................................................................ 45

3.4.2.1  Status bar

The status bar at the top of the screen indicates the RF frequency and the level of the
output signal provided to the DUT. You can set both parameters directly here.

1 2 3

1 = Frequency display
2 = Status buttons
3 = Level display

The status buttons indicate key parameters that are set for the output signal. Most of
the status buttons are virtual keys that you can use to open a corresponding menu or
dialog.

Operating the instrument
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3.4.2.2  Block diagram

The block diagram shows the current configuration and the signal flow in the generator
with the aid of function blocks, connected by signal lines. The following figure displays
the most common elements that can appear in the block diagram. However, it does not
necessarily represent a useful configuration.

1
12

3 4 5 107

2
11

986

Baseband domain, digital RF domain, analog

1 = Control signal block
2 = Status indicator
3, 6, 8, 10 = Functional block
4, 5 = Graphics indicator
7, 9 = Signal line
11, 12 = Connector icons (RF, I/Q analog)

Starting from the left up to the "I/Q Mod" functional block, you can see the functional
blocks provided in the baseband domain. After the I/Q modulation on the analog RF
carrier, the analog section implies the routing to the "RF" functional block.

Legend Item Description

1 Control signal block Indicates information on the control signals like signal content, input or
output and provides quick access to the corresponding configuration
dialog.

A dedicated control block is displayed to the left of the baseband block.

2 Status indicator Indicates whether the signal is running or waiting for a trigger.

3, 6, 8, 10 Functional block Represents a basic task in signal generation.

The push button provides access to any number of associated actions to
accomplish the task. A checkbox and the block label quickly enable the
basic task.

4, 5 Graphics indicator Denotes that the signal is displayed graphically:
● Baseband signal after the baseband block (4)
● Stream signal before mapping (5)
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Legend Item Description

7, 9 Signal line Shows the currently configured signal flow.

11, 12 Connector icon Represents the interfaces for signal output.
● RF signal connector output (11)
● I/Q analog signal connector output (12)

3.4.2.3  Taskbar

The "Taskbar" contains labeled softkeys and minimized views (thumbnails) of active
graphics and dialogs.

Initially, it shows the permanently assigned softkeys. The softkey with the sine wave
denotes that no signal is enabled for graphical representation.

Figure 3-7: Taskbar in default state

Whenever you open a settings or graphics dialog, it is automatically assigned to the
"Taskbar". The softkeys shown in the following figure represent the variants.

1 2 3 54

Figure 3-8: Taskbar fully assigned

1 = System configuration and setup
2 = Remote control connections
3 = Graphics
4 = Dialogs
5 = Show block diagram / more

1 System Config Provides access to general system configurations like
setup, display, or remote.

2 Remote control connections Shows the established remote connections when the
instrument is remotely controlled.

Tip: An indicator in the status bar shows the current
remote control status.

3 Graphics Shows that a signal is represented graphically.
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4 Dialogs Shows a dialog as a thumbnail, the dialog name, and the
name of the signal channel.

5 Show block diagram / more The show block diagram icon as in Figure 3-7 minimizes
all dialogs indicated on the screen. The block diagram is in
the foreground.

The "More" softkey indicates that more dialogs are open
than can be displayed in the taskbar. Use this softkey to
open a selection list with the remaining active dialogs, and
the "Diagram" function.

3.4.2.4  Additional display characteristics

The following section provides a short insight on the indication of the screen in general,
and significant elements that you see under specific modes, in dialogs or settings.

● Appearance of active elements
– Active elements like On/Off switches, state buttons have a blue background.
– Selected elements are framed or highlighted orange.
– Inactive elements are gray.

● On-screen keypads
As an additional means of interacting with the instrument either a numerical or
alphanumerical on-screen keypad appears when you enable an entry field, see
Chapter 3.4.4, "Entering data", on page 47.

● Info line
The "Info line" shows brief status information and error messages. It appears when
an event generates a message. If selected, the R&S SFI100A shows information
on static errors and the error history.

● Key parameters indicated in tab labels
Most dialogs are divided into tabs with logically grouped parameters. The tab label
expresses the content and can also contain status indicators or the set value of a
key parameter.

1 2

4 3

1, 2 = Status indicators
3, 4 = Key parameter values

● Scrollbar handle
An arrow icon that appears when you touch a scrollbar helps you to scroll in a dia-
log or list.

● Progress indicators
A busy icon indicates a currently running process. If a process takes some time, a
progress bar shows the current state.
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● Context-sensitive menus
Within the entire screen display, including single parameters, you can access con-
text-sensitive menus that provide some additional functions.

3.4.3  Accessing the functionality

All functionalities are provided in dialog boxes as known from computer programs. You
can control the instrument intuitively with the touchscreen. This section provides an
overview of the accessing methods.

The instrument's functions and settings can be accessed by selecting one of the follow-
ing elements:
● System and function keys on the front panel of the instrument
● Taskbar/softkeys on the touchscreen
● Context-sensitive menus for specific elements on the touchscreen, or with the

rotary knob (press and hold).
● Elements on the status bar in the touchscreen
● Displayed setting on the touchscreen that means block diagram and all settings

available in dialogs.

To open a dialog box

► Perform one of the following actions:

● Select the required block, and then the menu entry.

Operating the instrument
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● Select the minimized view (thumbnail) on the taskbar.

Some of the utility keys access a dedicated dialog, too.

To minimize a dialog box

► To return to the block diagram, select the "Home" button.

To close a dialog box

To close a dialog box, you have the same controls as you know from computers or
devices with touchscreen.

► Perform one of the following actions:

● Select the "Close" icon in the upper right corner.
● Select the [Esc] key on the front panel.
● Drag and drop a minimized dialog from the taskbar to the block diagram.

To select an option in a dialog box

► Select the required option.

To select an option in a list

If you can select many options, these options are provided in a list. The current selec-
tion is shown on the list button.

1. Select in the list.

2. To navigate through the list, try out the following:
● Using a mouse, scroll in the list to select the required option.
● Use the rotary knob.

3.4.4  Entering data

Some parameters have their own key on the front panel. For data input in dialog
boxes, the instrument provides on-screen keypads for entering numeric and alphanu-
meric values. You can always set the parameters via the touchscreen, the front panel
or an external keyboard.

To enter numeric values with the on-screen keypad

For numeric settings, the instrument displays the numeric keypad. The units specified
correspond to the units of the parameter.

1. Enter the numeric value.

Tip: For a quick entry, you can enter a value in an exponential representation, for
example 1e7 for 10000000.

2. Tap the unit button to complete the entry.

The unit is added to the entry.
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Tip: For a quick unit change, you can enter shortcuts, for example for a frequency
value 1e8h for 100 MHz.
For an overview of shortcuts supported by the R&S SFI100A, see Chapter B, "Unit
shortcuts", on page 643.

3. If the parameter does not require a unit, confirm the entered value by pressing
"Enter".

If you edit numeric data in tables, enable edit mode first. Press the rotary knob to
enable the edit mode.

To enter alphanumeric values

If a field requires alphanumeric input, you can use the on-screen keyboard to enter let-
ters and characters including special characters.

To complete an entry

► On the on-screen keyboard, press "Enter" .

To correct an entry

1. Using the arrow keys, move the cursor to the right of the entry you want to delete.

2. On the on-screen keyboard, press "Clear".

3. Enter your correction.

To abort an entry

► Press the [Esc] key.
The dialog box closes without changing the settings.

3.4.5  Undo and redo actions

Accessed via the context-sensitive menus, "Undo" allows you to restore one or more
actions on the instrument. Depending on the available memory, the "Undo" steps can
restore all actions.

"Redo" restores a previously undone action.

3.4.6  Getting information and help

In some dialog boxes, graphics are included to explain the way a setting works.

For further information, you can use the following sources:
● Tooltips give the value range of the parameter.

Operating the instrument



Getting startedR&S®SFI100A

49User Manual 1179.6789.02 ─ 02

● The context help provides a functional description on a setting.
● The general help explains a dialog box, provides instructions, and general informa-

tion.

To display context help

► To access a help topic, perform one of the following:

a) Tap and hold the parameter for which you need information and tap "Help" in
the context menu.

b) Tap the parameter and press the [Help] key.

The "Help" dialog opens. You can browse the help for further information.

Contents of the help dialog box

The help dialog box covers two main areas:
● "Contents" - contains a table of help contents
● "Topic" - contains a specific help topic

The help system also provides an "Index" and a "Find" area, and "Zoom" functions that
are accessed via the corresponding buttons.

To open general help

► Press the yellow [Help] key on the front panel.

If a dialog box is opened, the help topic for the current tab is shown. Otherwise the
"Contents" page appears.

Navigating in the table of contents and in the help topics

1. To move through the displayed contents entries, tap on an entry and scroll or use a
connected mouse.
Entries with a plus sign contain further entries.
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2. To display a help topic, tap on the topic name or double-click the topic name.

3. To follow a cross-reference, tap on the link text.

4. To return to the previous page, select "Back".
This function scrolls back all steps that you have performed before.

5. Use the "scroll bars" to shift the visible section of content shown.

6. To maximize the "Topics" area, tap the "Hide Contents Tree" button to hide the con-
tents tree.

Using the index

1. Select the "Index" button.

2. Enter the first characters of the topic that you are interested in.

The entries starting with these characters are displayed.

3. Tap on the index entry.

The corresponding help topic is displayed.
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4  Generating baseband signals
This section provides information to configure and generate baseband signals. It cov-
ers the following topics:

● Accessing the functions in the baseband domain...................................................51
● Common characteristics of the baseband domain..................................................52
● Using the arbitrary waveform generator (ARB).......................................................64
● Generating multicarrier waveform signals.............................................................103
● Configuring global connectors...............................................................................121
● Reducing crest factors.......................................................................................... 130
● Shifting the baseband signal.................................................................................136

4.1  Accessing the functions in the baseband domain

1. In the block diagram, select the "Baseband" block.

2. Navigate through the context menu.

The "Baseband" block provides all functions and settings concerning the baseband
signal.

3. By default, baseband signal generation is off.

Accessing the functions in the baseband domain
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To enable the baseband generator, select the "Baseband" block and set "Base-
band" > "On".

A short designation indicates the current baseband signal generation source, for
example "ARB".
For information on related settings of the selection list, see the following sections:
● Chapter 4.3, "Using the arbitrary waveform generator (ARB)", on page 64
● Chapter 4.5, "Configuring global connectors", on page 121
● Chapter 4.7, "Shifting the baseband signal", on page 136

4.2  Common characteristics of the baseband domain

This section provides information on common baseband signals. It covers the following
topics:

● About trigger signals............................................................................................... 52
● About trigger modes................................................................................................53
● Impact of additional trigger settings........................................................................ 56
● About marker signals.............................................................................................. 59
● About clock signals................................................................................................. 61
● Methods for optimizing the crest factor................................................................... 61
● Receiving and providing trigger signals.................................................................. 64

4.2.1  About trigger signals

The R&S SFI100A provides several trigger modes, different trigger sources, and some
additional trigger settings to suppress or delay the trigger events. This section provides
an overview of the provided baseband trigger settings and the impact of the trigger set-
tings on the signal generation.

The current signal generation status ("Running" or "Stopped") is continuously dis-
played in the corresponding dialog, indicated in the header of the tab and in the block
diagram of the instrument. This indication is important when an external trigger is
applied.

Trigger signal

The trigger signals are internally generated or externally supplied signals which start
signal generation at a particular point in time. However, signal generation can also take
place without triggering. In this case, the signal generation starts immediately after the
modulation is enabled.

Trigger event

Trigger events occur when receiving external trigger signals. Also, you can trigger sig-
nal generation manually. The "Arm" function stops the signal generation until a trigger
event occurs.
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Trigger source

There are two sources for trigger signals:
● Internal: The instrument generates the internal trigger signal.
● External: The instrument receives an external trigger signal at one of the User x

connectors.

Related settings:
● "Source" on page 78
● Chapter 4.5, "Configuring global connectors", on page 121

4.2.2  About trigger modes

A trigger event defines the signal generation and depends on the trigger mode. The
Table 4-1 provides an overview of the trigger modes and their impact on the signal
generation start.

Table 4-1: Impact of the trigger events on the generated signal

"Trigger Mode" Signal generation
mode1)

1st Trigger event
"Exec. Trigger" or
"External" trigger signal

Subsequent trigger event
"Exec. Trigger" or
"External" trigger signal

Trigger event
"Arm"

"Auto"

See Figure 4-2

Continuous - - -

"Retrigger"

See Figure 4-3

Continuous Initial start Restart -

"Armed_auto"

See Figure 4-4

Continuous Initial start Restart

(only after previous "Arm")

Stop

"Armed_retrigger"

See Figure 4-5

Continuous Initial start Restart Stop

"Single"

See Figure 4-1

Single

length determined by
"Trigger Signal Duration"

Initial start Restart -

1) the instrument generates a continuous signal or a single signal.
● Single signal generation means that the signal generation stops after one cycle.

That is, after the signal with signal length determined by the "Trigger Signal Dura-
tion" has been generated.

● Continuous transmission means that the signal is generated repeatedly without
delay and until the data generation is stopped explicitly.
However, any parameter change within the processing chain (baseband, fading
simulator, or stream mapping) causes a signal generation restart.

The following is a list of the trigger modes together with their short description. An
example of their impact on the generated signal is given. The provided examples are
intended to show the triggering mechanism in principle. To simplify the description, an
internal trigger event ("Execute Trigger") is used. An external trigger event has the
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same effect on the signal generation. In the examples on the figures bellow, the instru-
ment's processing time is ignored.
● Single

The instrument starts the signal generation only when a trigger event occurs. The
signal is generated once. Its signal length is set with the parameter "Trigger Signal
Duration".
Every subsequent trigger event causes a restart.

Figure 4-1: Trigger mode single

* = Internal trigger event (to simplify the description)
** = The signal is generated once to the length specified with "Trigger Signal Duration"

● Auto
In auto trigger mode, the instrument generates a continuous signal.

Figure 4-2: Trigger mode auto

● Retrigger
The instrument generates a continuous signal. With enabled retrigger, a new trig-
ger event aborts the current generation cycle and restarts the signal generation
from the beginning.
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Figure 4-3: Trigger mode retrigger

* = Internal trigger event (to simplify the description)

Compare the shape and the length of the red curve in single mode and in retrigger
mode. The first part of the curve in retrigger mode is shorter. The signal generation
is interrupted due to the subsequent trigger event.

● Armed auto
The instrument starts the signal generation only when a trigger event occurs and
then generates a continuous signal. An "Arm" stops signal generation. A subse-
quent trigger event causes a restart of the signal generation.

Figure 4-4: Trigger mode armed auto

* = Internal trigger event (to simplify the description)

● Armed retrigger
The instrument starts the signal generation only when a trigger event occurs and
then generates a continuous signal. Every subsequent trigger event causes a
restart of the signal generation.
An "Arm" stops the signal generation. A subsequent trigger event causes a restart.
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Figure 4-5: Trigger mode armed retrigger

* = Internal trigger event (to simplify the description)

4.2.3  Impact of additional trigger settings

The R&S SFI100A provides a set of settings to configure the behavior upon receiving
of a trigger signal. For example:
● Suppressing trigger events
● Delaying the instrument's response on trigger events
● Adjusting the signal calculation start time in relation to the trigger event.

Avoiding accidental trigger events

The following trigger settings enhance the flexibility of the trigger system and can help
to avoid accidental trigger events.
● "Threshold Trigger Input"

Defines the voltage level of the trigger signal where the R&S SFI100A generates a
trigger event. Trigger signals below the trigger threshold are ignored.

● "Trigger Input Slope"
Specifies the edge (rising or falling edge) of the trigger signal that is to provide the
trigger event.

● "Impedance Trigger Input"
Specifies the input impedance of the trigger signal.

Starting the signal generation with the first sample

By default, the instrument starts the signal calculation simultaneously with the receiving
of the external trigger event. Because of the signal propagation time and the instru-
ment’s processing time, the first samples are cut off and no signal is output.

This default behavior, however, can cause problems if short signal sequences are gen-
erated. To overcome this problem, the instrument provides the special parameter
"Sync. Output to (External) Trigger". If this parameter is disabled, the signal output
begins after elapsing of the processing time and starts with sample 0. That is, the com-
plete signal is output (compare both figures in Table 4-2).
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Table 4-2: Impact of the parameter Sync. Output to (External) Trigger

"Sync. Output to (External) Trigger = On" "Sync. Output to (External) Trigger = Off"

Suitable for long signal sequences

The output signal is synchronous to the trigger event
after elapsing of the internal processing time.

Suitable for triggering of short signal sequences with
signal duration comparable with the processing time
of the instrument

Suppressing and delaying trigger events

The main focus of the following features is the mobile communication standards.

● "(External) Trigger Delay"
You can apply a definable number of symbols to delay the start trigger event of an
externally supplied trigger signal
This feature is useful to:
– Simulate the time delay between a base station signal and a user equipment

signal, for example during base station tests
– Compensate for known propagation delays or a timing offset in the test setups

● "(External) Trigger Inhibit"
You can suppress the effect of a restarted trigger signal in the "Retrigger" trigger
mode for a definable number of symbols.
During base station tests, for example, this feature enables the trigger suppression
for a definable number of frames and yet the signal can still be generated synchro-
nously. In each frame, the base station generates a trigger event that restarts the
signal generation every time but for the suppression.

Example: 
A trigger delay of 1000 samples means that after a trigger event, any subsequent trig-
ger signal is ignored for the space of 1000 samples.
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Figure 4-6: Trigger delay and trigger inhibit in trigger mode retrigger

To set delay and inhibit values

Trigger delay and inhibit values are expressed in the units of the generated signal, e.g.
in samples or symbols. You can also define the exact delay or inhibit period as a time
value, e.g. in seconds.

Trigger delay values tdelay depend on the instrument hardware. The table illustrates an
exemplary instrument configuration and related tdelay values in samples (or symbols)
and in seconds.

Option Max. rs / MHz tdelay / samples tdelay / s

Base unit 16000 0 to depends on sample rate 0 to depends on sample rate

For more information, refer to the specifications document.

Example: ARB clock frequency and trigger delay
This example describes an ARB signal with 1 MHz clock frequency. It illustrates the
relation between the ARB clock frequency and the configurable trigger delay.

1. Select "Baseband" > "ARB" > "Clock Frequency" = "1 MHz".

2. Configure an external, for example, for an armed auto trigger mode.

a) Select "ARB" > "Trigger In" > "Mode" > "Armed Auto"
b) Select "Source" > "External Global Trigger 1".
c) Select "External Delay Unit" > "Samples".
d) Set "External Delay" = "100 Samples".

The parameter "Actual External Delay" = "100 us" displays the actual delay in time
units.
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3. Set the delay in time units.

a) Select "External Delay Unit" > "Time".
b) Select "Specified External Delay" > "10 µs".

The "Actual External Delay" changes to 10 us.

4. To check again the delay in samples, select "External Delay Unit" > "Samples".

The external dealy and actual delay is 10 samples.

4.2.4  About marker signals

The R&S SFI100A can add additional signals to the generated signal. Marker signals
(or markers) are digital signals to synchronize external devices to the generated data
stream. For example, with suitable marker settings, you can select a slot clock or frame
clock, or mark the start of a particular modulation symbol.

Four marker output signals are available. Output these signals at the User x connec-
tors.

Related settings:
● Chapter 4.3.3.6, "Marker settings", on page 80
● Chapter 4.5, "Configuring global connectors", on page 121

4.2.4.1  Marker modes

Marker mode restart

The generated marker signal is a single "On" pulse. The rising edge of this pulse is
generated at the signal generation start and at each subsequent signal restart time.
This marker can be used to monitor the effects of the selected trigger, e.g. trigger caus-
ing restarts of the signal generation.

Marker mode pulse

Periodic marker with consecutive on periods and off periods of equal length. The first
on period starts at the beginning of the first generated sample/symbol. The marker fre-
quency is defined by a "Divider". The frequency is derived as follows:

<Frequency> = "Symbol Rate"/"Sample Rate" / "Divider", respectively.

<Frequency> = "Sampling Frequency" / "Divider".
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Example: 
"Symbol Rate" = "1 Msym/s", "Divider" = "2"
The marker frequency is 500 kHz, corresponding to a marker period of 2 us. Each on
and off period has a length of 1 us, corresponding to one symbol period. With a divider
of 4 (6, 8 ...), the length of each on and off period is increased to 2 (3, 4, ...) symbol
periods.

Marker mode pattern

Periodic marker where each period is defined by a bit pattern with a maximum length
of 64 bits. A "1" ("0") in the pattern denotes an on (off) signal segment with a duration
of one sample/symbol period.

Example: 
In the following example, the marker signal is defined by a pattern 100100....

Marker mode On/Off Ratio

Similar to "Pulse" but with independent lengths of the on periods and off periods. The
length of the periods is entered as several symbols/sample periods.
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Example: 
In the following example, the marker signal is defined by an "On Time" = "1 sym" and
"Off Time" = "2 sym".

4.2.4.2  Delaying marker signals

In all the examples listed in Chapter 4.2.4.1, "Marker modes", on page 59, the marker
starts at the beginning of the first generated sample/symbol (sample/symbol no. 1). It is
possible though to delay the start of the marker by an integer number of symbols/
sample periods.

4.2.5  About clock signals

The instrument uses its internal clock reference to generate the timing pulse. You can-
not output this internal signal, for example, as an external symbol clock signal to syn-
chronize instruments.

Synchronizing baseband signal and clock signal

The instrument uses the positive edge of the internal clock signal for signal synchroni-
zation. For related settings, see Chapter 4.3.3.7, "Clock settings", on page 81.

4.2.6  Methods for optimizing the crest factor

Communication standards utilizing higher-order modulation techniques or using multi-
ple carriers and complex signals consisting of the signals of more than one digital stan-
dard can feature a high crest factor. The signals of some digital standards can have
high crest factors also particularly with many channels and long sequences.

About the crest factor

The crest factor represents the ratio of the peak voltage value to the RMS voltage
value, i.e. the peak to average ratio (PAR). The higher the crest factor and the resulting
dynamics of a signal, the greater the requirement for a power amplifier fed by the sig-
nal to be linear.

A high crest factor arises, for example, when in a multicarrier signal the carriers feature
an identical start phase. Multicarrier signals imply periodically superimposed signals
with high peak voltages in relation to the RMS voltage values.
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High crest factors entail two basic problems:
● The nonlinearity of the power amplifier (compression) causes intermodulation

which expands the spectrum (spectral regrowth).
● Since the level of the D/A converter is relative to the maximum value, the average

value is converted with a relatively low resolution. This low resolution leads to a
high quantization noise.

Both effects increase the adjacent-channel power.

Direct crest factor reduction

At the individual signal generation stages, the R&S SFI100A offers different direct
approaches to reduce the crest factor. While the corresponding parameters are
enabled, the implemented algorithms ensure minimizing the crest factor or achieving of
predefined target crest factor by applying of automatic settings. Methods of reducing
the crest factor differ regarding both the optimization achievable and the time required
for computation.

The provided crest factor reduction methods include:
● Internal calculation of optimized carrier phases for the individual carriers in a multi-

carrier signal
● Automatic calculation of the carrier start phases in a multi-carrier continuous wave

signal

Applying clipping and filtering

Another common and simple approach for achieving a lower PAR is the combination of
clipping and filtering. In several of the firmware options, like 3GPP FDD or CDMA2000,
the instrument provides baseband clipping. Also, you can select the baseband filter
and adjust the filter characteristics.
● Clipping is a method that applies a wanted distortion to the signal, see Example

"Vector clipping and crest factor" on page 63.
This method includes specifying a level limit, finding out the signal peaks and clip-
ping off the peaks that exceed the limit. The level limit is a percentage of the high-
est peak value. Clipping does not influence the spectrum but the error vector mag-
nitude (EVM) increases.
The instrument offers two clipping modes:
– Vector clipping: | I + q |

The clipping limit is related to the amplitude | I + q |. This mode maps the I and
Q components together and retains the angle between the vectors.

– Scalar clipping | I | + | q |
The clipping limit is related to the absolute maximum of all the I and Q values | I
| + | q | . This mode maps the I and Q components separately, the angle
changes between the vectors.

Signal clipping not only changes the peak value but also the average value and the
effect on the crest factor is unpredictable.

● Filtering is a method after clipping. The filters are able to filter out the distortion.
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Example: Vector clipping and crest factor
The following figures display constellation diagrams that demonstrate the effect of the
clipping on the crest factor for typical scenarios.

Figure 4-7: I/Q constellation without clipping

The clipping mode in figure Figure 4-8 is vector | I + q | mode and the I/Q signal config-
uration has two active channels. The circle visualizes the changed constellation points.

Figure 4-8: I/Q constellation with vector clipping and clipping level 80 %

Common characteristics of the baseband domain



Generating baseband signalsR&S®SFI100A

64User Manual 1179.6789.02 ─ 02

4.2.7  Receiving and providing trigger signals

In test setups that combine the signal of two or more instruments it is often required
that:
● The signal generation starts at a defined moment
● The signal generation starts simultaneously (or with an exactly defined delay) in all

involved instruments.

4.3  Using the arbitrary waveform generator (ARB)

The arbitrary waveform generator (ARB) is an I/Q modulation source of the
R&S SFI100A. The ARB allows the playback and output of any externally calculated
modulation signals in the form of waveform files. The ARB can also generate multicar-
rier or multi-segment signals from the waveform files.

● Required options.....................................................................................................64
● About ARB.............................................................................................................. 64
● ARB settings........................................................................................................... 69
● Playing waveform files............................................................................................ 83
● Tags for waveforms, data and control lists..............................................................94

4.3.1  Required options

The equipment layout for processing waveform files includes:
● Base unit, including arbitrary waveform generator (2 Gsample ARB memory, 2 GHz

RF bandwidth)
● Digital standard waveform option (R&S SFI-K2xy/-K4xy) to play a waveform file

generated by the signal generation software R&S WinIQSIM2.
For example, if you purchase option Digital Standard EUTRA/LTE R&S SFI-K255,
you can process an EUTRA/LTE waveform file generated by R&S WinIQSIM2.

● Optional ARB memory extension 8 Gsample (R&S SFI-K517)
● Optional RF modulation bandwidth extension to 8 GHz (R&S SFI-K529) or 10 GHz

(R&S SFI-K530) for wideband waveform files above 2 GHz.

You can output waveform signals at several connectors:
● For output at the RF connector the base unit is sufficient.
● For output at the analog I/Q connectors install option R&S SFI-K17.

For more information, refer to the specifications document.

4.3.2  About ARB

This section provides background information on the ARB functionality and the impact
of the provided settings.

Using the arbitrary waveform generator (ARB)
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For more complex waveform signals, see the following sections:
● Chapter 4.4, "Generating multicarrier waveform signals", on page 103

Related settings

See Chapter 4.3.3, "ARB settings", on page 69.

Related step-by-step descriptions

See the following sections:
● Chapter 4.3.4, "Playing waveform files", on page 83
● Chapter 4.3.4.5, "Defining periodically repeating traces", on page 92
● Chapter 4.3.4.4, "Creating waveforms with tag file format", on page 88
● Chapter 4.3.4.6, "Editing waveform files, data and control lists", on page 94

4.3.2.1  About waveform files

The R&S SFI100A uses waveform files to obtain the digital I/Q data of the baseband
signal. The R&S SFI100A can play back a waveform file from the internal storage
medium but it can also generate and play back simple waveforms for test purposes.

What is a waveform?

A waveform is a file with a specified file format containing raw I/Q samples. Waveform
files have the file extension *.wv and contain calculated I/Q values.

When creating waveforms, the instrument inserts a waveform header at the beginning
of each created ARB file. The header of the generated I/Q data files consists of tags in
braces "{ }". For a detailed description, see Chapter 4.3.5, "Tags for waveforms, data
and control lists", on page 94.

Waveform file sources

The following waveform file sources are available:
● Internally generated waveforms

The ARB enables the calculation and the generation of waveform files. The ARB
also provides a built-in function to create a test waveform and keep it as a file or in
the RAM.

● Externally generated or created waveforms
The ARB processes externally created waveform files, for example:
– The waveform files generated by software R&S WinIQSIM2, the

R&S ARB Toolbox or the R&S Pulse Sequencer
– A mathematical program, for example, MATLAB calculates the waveform sig-

nals. See Chapter 4.3.5, "Tags for waveforms, data and control lists",
on page 94.

You can load the externally generated waveform files into the instrument via one of
the available interfaces, for example, USB or LAN. Usually, the waveform file is
saved on one of the network drives which are accessible for the operating system.
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4.3.2.2  ARB test signals

The following test signals are available:
● "Sine" test signal: Two sine-wave signals with a selectable (but equal) number of

samples per period and equal frequencies. When the generation is triggered, the
number of samples per period, together with the frequency of the test signal, deter-
mine the ARB clock frequency: "Clock Frequency" = "Frequency" * "Samples per
Period".
Note: Because the resulting clock rate must not exceed the maximum ARB clock
rate, the number of sample values is automatically restricted depending on the
selected frequency.
The first sine signal is mapped on the I samples, the second on the Q samples.
The two signals differ by a selectable phase offset. For a –90 deg offset, the result
is a unit vector in the I/Q plane, rotating counterclockwise and starting at I = 0, Q =
–1. For a 0 deg offset, the I and Q samples are on the diagonal of a unit square (I(t)
= Q(t)).

In general, the I/Q samples are located on a deformed circle which is confined to
the dashed square in the upper diagrams.

● "Rect" test signal: Rectangle signal with selectable but equal on and off periods
and amplitude. The period is defined by the selected frequency: <Period> = 1 /
"Frequency".
The signal is mapped on both the I and Q samples. The mapping results in two dis-
tinct points in the I/Q plane. The "Offset DC" shifts both points along the diagonal
I(t) = Q(t).
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● "Const I/Q" test signal: Continuous test signal with constant I/Q and constant
clock frequency of 10 kHz. The values for each I and Q components are selectable
but constant. They are defined as a decimal number, which is decimal-to-binary
converted internally. The signal is provided as a 16-bit wide digital signal for both I
and Q channels.
You can output the signal directly at the BNC connectors I and Q outputs of the
instrument.

For more information, refer to the specifications document.

4.3.2.3  Waveform sample rate

The Arbitrary Waveform Generator includes a resampling unit that interpolates the
input samples to target a certain digital output I/Q sample rate. The input sample rate
finput is retrieved from the waveform (the default sample rate tag) or is defined by the
corresponding parameter in the ARB user interface.

The Figure 4-9 depicts the stages involved in the processing and resampling of a
waveform in the ARB.

Figure 4-9: Processing of the waveform files in the ARB

finput = Waveform sample rate
b = Usable bandwidth factor
fSysClk_max = SystemClockmax = SampleRatemax 

Where:
● fSysClk_max = SystemClockmax = SampleRatemax = 16 GHz
● b = 0.4165

Impact of the resampling filter

As illustrated in Figure 4-9, the filter in the resampling stage is distortion-free for sig-
nals with the following maximum baseband bandwidth:

Usable_Bandwidthmax [MHz]  = b* finput.

The usable bandwidth factor b equals b = 0.4165.

An externally created waveform file has to provide a sample rate finput that is high
enough for perfect signal reconstruction. For distortion-free resampling the lower
bound of the required sample rate finput is then calculated as follows:

finput ≥ Usable_Bandwidth / b

Using the arbitrary waveform generator (ARB)



Generating baseband signalsR&S®SFI100A

68User Manual 1179.6789.02 ─ 02

Thus, a modulation signal with a sample rate finput = 16 GHz fed in the baseband gen-
erator ensures the Usable_Bandwidthmax. After the DAC, this signal features a
RF_Bandwidthmax = 2*b*finput = 2*b*16 GHz = 10 GHz.

Impact of the oversampling factor

Waveforms generated by the R&S WinIQSIM2 software can be optimized by choosing
a suitable integer oversampling factor.

Conventional ARB often assumes an oversampling factor of 4. The ARB of the
R&S SFI100A requires low oversampling factors and still provides excellent signal
quality in terms of EVM and ACP.

A reduced sample rate saves significantly the amount of memory or allows an
increased signal cycle time, and vice versa.

4.3.2.4  Marker signals and waveform length

The R&S SFI100A provides the possibility to define marker signals that are sent to the
marker outputs in synchronicity with the I/Q output signals. Marker signals can be
either predefined or later defined.

The I/Q data and marker data are located in separate memory areas of the SDRAM
and can be independently configured. Each marker signal requires 1 bit of the availa-
ble memory size. Sometimes, it is useful to generate a modulation signal without extra
marker signals to increase the maximum waveform length.

The following example explains the dependency between the number of enabled
marker signals, the available memory size, and the resulting waveform length.

Example: Calculating the maximum waveform length
The calculation assumes a R&S SFI100A base unit with an ARB memory of 2 Gsam-
ple, see Chapter 4.3.1, "Required options", on page 64.
● Total memory size = 512 Gbyte
● Required memory size (per complex sample) = 32 bit + 4 bit = 36 bit = 4.5 byte,

where:
– The raw I/Q samples are saved as 16-bit values. For the length of the I/Q data

that is:
2 x 16 bit = 32 bit (16 bit per I/Q channel)

– Each marker requires one bit. Four enabled markers require 4 bit.
● Maximum waveform length with 3 markers = 512 Gbyte / 4.5 byte =

113,000 Msample
● Theoretical maximum waveform length (no markers) = 512 Gbyte / 4 byte =

128,000 Msample
A memory size of 512 Mbyte yields a maximum waveform length of 113 Gsample, if
three markers are enabled. The maximum waveform length increases to 128 MGsam-
ple, if the internal hardware markers are used, and the complete memory is available
for I/Q data.
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4.3.3  ARB settings

Access:

► Select "Baseband" > "ARB".

The "ARB" dialog provides settings to play waveform files and access to settings to
create waveform test signals and multicarrier waveform signals.

The remote commands required to define these settings are described in Chap-
ter 13.16.2, "SOURce:BB:ARBitrary subsystem", on page 531.

Settings:

● ARB general settings.............................................................................................. 69
● Sine test signal settings.......................................................................................... 72
● Rectangular test signal settings.............................................................................. 73
● Constant IQ test signal settings.............................................................................. 75
● Trigger settings....................................................................................................... 76
● Marker settings........................................................................................................80
● Clock settings..........................................................................................................81
● Global connector settings........................................................................................82

4.3.3.1  ARB general settings

Access:

► Select "Baseband" > "ARB".

This tab provides general settings to select and create a waveform file and enable
the ARB.
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Settings:

State..............................................................................................................................70
Set To Default................................................................................................................70
Load Waveform.............................................................................................................70
Waveform Info...............................................................................................................71
Clock Frequency........................................................................................................... 71
Create Multi Carrier.......................................................................................................71
Test Signal Form........................................................................................................... 71
Create Test Signal.........................................................................................................72

State
Enables ARB modulation. Switching on the ARB turns off all the other digital standards
and digital modulation types in the same signal path.
The output is based on the waveform file that is loaded. The name of the waveform file
is displayed next to "Load Waveform". When a multi-segment waveform is loaded, the
display expands and lists more settings, grouped in the "Multi Segment Waveform
Options" section.
Note: ARB stays disabled.
You cannot enable the ARB in the following cases:
● No or empty waveform file

By default, no waveform file is loaded. The "Load Waveform" button displays
"None".
Remedy: Select a waveform file, before activating the ARB.

Remote command: 
[:SOURce<hw>]:BB:ARBitrary:STATe on page 535

Set To Default
Calls default settings, see Table 4-3.
Table 4-3: ARB default settings

Parameter Value

State Off

Clock Frequency 1 MHz

Trigger Mode Auto

Trigger Source Internal

Marker State Off

Marker Mode Unchanged

Clock Source Internal

Remote command: 
[:SOURce<hw>]:BB:ARBitrary:PRESet on page 535

Load Waveform
Opens the standard "File Select" function of the instrument. The provided navigation
possibilities in the dialog are self-explanatory.
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The waveform files have a predefined file extension *.wv. If you select a file, the dia-
log displays short information about the selected waveform.
Enable the ARB to trigger the instrument to load and process the selected waveform
file.
Remote command: 
[:SOURce<hw>]:BB:ARBitrary:WAVeform:SELect on page 540

Waveform Info
Opens a dialog with detailed information about the currently selected waveform. The
display depends on whether the selected waveform file is a multisegment one or not.
All parameters are read only.

Remote command: 
n.a.
For non-multi-segment waveform files, use the Tag commands. See Chapter 4.3.5,
"Tags for waveforms, data and control lists", on page 94.

Clock Frequency
Displays or sets the ARB output clock rate.
The value of this parameter is set to the clock rate defined in the loaded waveform file
({CLOCK} tag). The value can be changed afterwards.

Note: The clock frequency must match the value of the externally applied clock source.
Remote command: 
[:SOURce<hw>]:BB:ARBitrary:CLOCk on page 542

Create Multi Carrier
Opens the dialog for creating multicarrier waveforms, see Chapter 4.4, "Generating
multicarrier waveform signals", on page 103.

Test Signal Form
Selects the form of the test signal. A choice between a sinusoidal, rectangular, AWGN
or test signal with constant I/Q is provided.
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To access further settings, select Create Test Signal.
Remote command: 
[:SOURce<hw>]:BB:ARBitrary:SIGNal:TYPE on page 536

Create Test Signal
Opens a dialog with further test signal settings. Provided are the following test signals:
● Chapter 4.3.3.2, "Sine test signal settings", on page 72
● Chapter 4.3.3.3, "Rectangular test signal settings", on page 73
● Chapter 4.3.3.4, "Constant IQ test signal settings", on page 75

4.3.3.2  Sine test signal settings

Access:

1. Select "Baseband" > "ARB" > "General".

2. Select "Test Signal Form" > "Sine".

3. Select "Create Test Signal".

This dialog provides settings to configure a sinusoidal test signal. A sine wave is
generated on the I path, and a sine wave of the same frequency but phase-shifted
is generated on the Q path. For more information, refer to Chapter 4.3.2.2, "ARB
test signals", on page 66.
The dialog displays the characteristic of the currently selected signal.

Settings:

Frequency..................................................................................................................... 73
Samples per Period.......................................................................................................73
Phase Offset Q..............................................................................................................73
Generate Signal File..................................................................................................... 73
Generate Signal RAM................................................................................................... 73
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Frequency
Enters the frequency of the test signal.
Remote command: 
[:SOURce<hw>]:BB:ARBitrary:TSIGnal:SINE:FREQuency on page 537

Samples per Period
Enters the number of sample values required from the sine wave per period.
The maximum allowed value is determined by the maximum ARB clock rate and the
selected frequency.
For more information, refer to the specifications document.
Remote command: 
[:SOURce<hw>]:BB:ARBitrary:TSIGnal:SINE:SAMPles on page 538

Phase Offset Q
Enters the phase offset of the sine-wave signal on the Q channel relative to the sine-
wave signal on the I channel.
Remote command: 
[:SOURce<hw>]:BB:ARBitrary:TSIGnal:SINE:PHASe on page 538

Generate Signal File
Generates a signal and saves it as a waveform file on the hard disk. Use the standard
"File Select" function to save the file.
Remote command: 
[:SOURce<hw>]:BB:ARBitrary:TSIGnal:SINE:CREate:NAMed on page 538

Generate Signal RAM
Generates a signal and uses this signal as output straight away. The instrument saves
the file using a predefined filename.
Remote command: 
[:SOURce<hw>]:BB:ARBitrary:TSIGnal:SINE:CREate on page 539

4.3.3.3  Rectangular test signal settings

Access:

1. Select "Baseband" > "ARB" > "General".

2. Select "Test Signal Form" > "Rect".
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3. Select "Create Test Signal".

This dialog provides settings to configure a rectangular test signal. A rectangular
test signal with a duty factor of 0.5 is created. Amplitude and offset are adjustable.
Both paths, I and Q, use the same signal.
For more information, refer to Chapter 4.3.2.2, "ARB test signals", on page 66.

Settings:

Frequency..................................................................................................................... 74
Samples per Period.......................................................................................................74
Amplitude...................................................................................................................... 74
Offset DC.......................................................................................................................75
Generate Signal File..................................................................................................... 75
Generate Signal RAM................................................................................................... 75

Frequency
Enters the frequency of the test signal.
Remote command: 
[:SOURce<hw>]:BB:ARBitrary:TSIGnal:RECTangle:FREQuency on page 536

Samples per Period
Enters the number of sample values required for the rectangular signal per period.
The maximum allowed value is determined by the maximum ARB clock rate and the
selected frequency.
For more information, refer to the specifications document.
Remote command: 
[:SOURce<hw>]:BB:ARBitrary:TSIGnal:RECTangle:SAMPles on page 537

Amplitude
Enters the digital amplitude of the rectangular wave. The abbreviation FS means full-
scale.
Remote command: 
[:SOURce<hw>]:BB:ARBitrary:TSIGnal:RECTangle:AMPLitude on page 536
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Offset DC
Enters a DC component.
Remote command: 
[:SOURce<hw>]:BB:ARBitrary:TSIGnal:RECTangle:OFFSet on page 537

Generate Signal File
Generates a signal and saves it as a waveform file on the hard disk. Use the standard
"File Select" function to save the file.
Remote command: 
[:SOURce<hw>]:BB:ARBitrary:TSIGnal:RECTangle:CREate:NAMed
on page 538

Generate Signal RAM
Generates a signal and outputs it straight away. The instrument saves the file using a
predefined filename.
Remote command: 
[:SOURce<hw>]:BB:ARBitrary:TSIGnal:SINE:CREate on page 539

4.3.3.4  Constant IQ test signal settings

Access:

1. Select "Baseband" > "ARB" > "General".

2. Select "Test Signal Form" > "Const IQ".

3. Select "Create Test Signal".

This dialog provides settings to configure a continuous test signal with constant IQ.
The I and Q values for each path are adjustable but constant. For more informa-
tion, refer to Chapter 4.3.2.2, "ARB test signals", on page 66.

Settings:

I ValueIQ Value..............................................................................................................76
Generate Signal File..................................................................................................... 76
Generate Signal RAM................................................................................................... 76
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I ValueIQ Value
Sets the value for the I component and Q component of the test signal.
Remote command: 
[:SOURce<hw>]:BB:ARBitrary:TSIGnal:CIQ:I on page 536
[:SOURce<hw>]:BB:ARBitrary:TSIGnal:CIQ:Q on page 536

Generate Signal File
Generates a signal and saves it as a waveform file on the hard disk. Use the standard
"File Select" function to save the file.
Remote command: 
[:SOURce<hw>]:BB:ARBitrary:TSIGnal:CIQ:CREate:NAMed on page 538

Generate Signal RAM
Generates a signal and uses this signal as output straight away. The instrument saves
the file using a predefined filename.
Remote command: 
[:SOURce<hw>]:BB:ARBitrary:TSIGnal:CIQ:CREate on page 539

4.3.3.5  Trigger settings

Access:

► Select "Baseband" > "ARB" > "Trigger In".

The tab provides settings to select and configure the trigger, like trigger source,
trigger mode and trigger delays, and to arm or trigger an internal trigger manually.

The header of the tab displays the status of the trigger signal and trigger mode. As in
the tabs "Marker" and "Clock", this tab also provides access to the settings of the rela-
ted connectors.

Routing and activating a trigger signal

1. Define the effect of a trigger event and the trigger signal source.

a) Select "Trigger In" > "Mode".
b) Select "Trigger In" > "Source".

2. For external trigger signals, define the connector for signal input. See Chap-
ter 4.3.3.8, "Global connector settings", on page 82.
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Global connector settings allow you to configure the signal mapping, the polarity,
the trigger threshold and the input impedance of the input connectors.

3. Activate baseband signal generation. In the block diagram, set "Baseband" > "On".

The R&S SFI100A starts baseband signal generation after the configured trigger
event.

About baseband trigger signals

This section focuses on the available settings.

For detailed information, see Chapter 4.2, "Common characteristics of the baseband
domain", on page 52.

Settings:

Mode............................................................................................................................. 77
Signal Duration Unit...................................................................................................... 78
Signal Duration..............................................................................................................78
Running/Stopped.......................................................................................................... 78
Arm................................................................................................................................78
Execute Trigger.............................................................................................................78
Source...........................................................................................................................78
Sync. Output to External Trigger/Sync. Output to Trigger.............................................79
External Inhibit/Trigger Inhibit........................................................................................79
(External) Delay Unit..................................................................................................... 79
Processing Time............................................................................................................79
(Specified) External Delay/(Specified) Trigger Delay....................................................79
Actual Trigger Delay/Actual External Delay.................................................................. 80

Mode
Sets the trigger mode.
See also Chapter 4.2.2, "About trigger modes", on page 53.
"Auto" Generates the signal continuously.
"Retrigger" Generates the signal continuously. A trigger event restarts the signal

generation.
"Armed Auto" Generates the signal only if a trigger event occurs. After the event,

signal generation is continuous.
Arming the trigger stops the signal generation. If armed, a following
trigger event restarts the signal generation.

"Armed Retrigger"
Generates the signal only if a trigger event occurs. After the event,
signal generation is continuous. Every following trigger event restarts
the signal generation.
Arming the trigger stops the signal generation. If armed, a following
trigger event restarts the signal generation.

"Single" Generates the signal once, if a trigger event occurs. You can set the
signal duration that equals the length of the generated signal. A fol-
lowing trigger event restarts the signal generation.
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Remote command: 
[:SOURce<hw>]:BB:ARBitrary[:TRIGger]:SEQuence on page 556

Signal Duration Unit
Requires trigger mode "Single".
Selects the unit the sequence length of the generated signal.
Remote command: 
[:SOURce<hw>]:BB:ARBitrary:TRIGger:SLUNit on page 558

Signal Duration
Requires trigger mode "Single".
Enters the sequence length of the generated signal after a single trigger event. To set
the unit of the sequence length, see "Signal Duration Unit" on page 78.
Remote command: 
[:SOURce<hw>]:BB:ARBitrary:TRIGger:SLENgth on page 557

Running/Stopped
With enabled modulation, displays the status of signal generation for all trigger modes.
● "Running"

The signal is generated; a trigger was (internally or externally) initiated in triggered
mode.

● "Stopped"
The signal is not generated and the instrument waits for a trigger event.

Remote command: 
[:SOURce<hw>]:BB:ARBitrary:TRIGger:RMODe? on page 557

Arm
Stops the signal generation until subsequent trigger event occurs.
Remote command: 
[:SOURce<hw>]:BB:ARBitrary:TRIGger:ARM:EXECute on page 558

Execute Trigger
For internal trigger source, executes the trigger manually.
Remote command: 
[:SOURce<hw>]:BB:ARBitrary:TRIGger:EXECute on page 558

Source
Selects the trigger source.
The following sources of the trigger signal are available:
● "Internal"

The trigger event is internal. Tap "Execute Trigger" to trigger signal generation
manually.

● "External Global Trigger"
The trigger event is the active edge of an external trigger signal provided and con-
figured at the User x connectors.
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The polarity, the trigger threshold and the input impedance of the input connectors can
be configured in the connector settings dialog.
How to: "Routing and activating a trigger signal" on page 76
Remote command: 
[:SOURce<hw>]:BB:ARBitrary:TRIGger:SOURce on page 557

Sync. Output to External Trigger/Sync. Output to Trigger
Enables signal output synchronous to the trigger event.
See also Chapter 4.2.3, "Impact of additional trigger settings", on page 56.
Remote command: 
[:SOURce<hw>]:BB:ARBitrary:TRIGger[:EXTernal]:SYNChronize:OUTPut
on page 558

External Inhibit/Trigger Inhibit
Applies for an external trigger signal.
Sets the duration with that any following trigger event is suppressed. In "Retrigger"
mode, for example, a new trigger event does not cause a restart of the signal genera-
tion until the specified inhibit duration does not expire.
Remote command: 
[:SOURce<hw>]:BB:ARBitrary:TRIGger[:EXTernal]:INHibit on page 560

(External) Delay Unit
Determine whether the trigger delay is expressed in samples or directly defined as a
time period (seconds).
To specify the delay, use the (Specified) External Delay/(Specified) Trigger Delay
The parameter Actual Trigger Delay/Actual External Delay displays the delay conver-
ted in time.
Remote command: 
[:SOURce<hw>]:BB:ARBitrary:TRIGger:DELay:UNIT on page 559

Processing Time
Displays the internal processing time.
The processing time is the elapsed time between the input of the external trigger event
and the output of the baseband signal. An additional delay applies to the RF signal with
respect to the baseband signal depending on the RF frequency.
For more information, see "Starting the signal generation with the first sample"
on page 56.
Remote command: 
[:SOURce<hw>]:BB:ARBitrary:TRIGger:PTIMe? on page 559

(Specified) External Delay/(Specified) Trigger Delay
The name of the parameter and the units the delay is expressed in, changes depend-
ing on the parameter (External) Delay Unit.
Delays the trigger event provided by:
● The external trigger source
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Use the settings to:
● Synchronize the instrument with the device under test (DUT) or other external devi-

ces
The parameter Actual Trigger Delay/Actual External Delay displays the delay conver-
ted in time.
For more information, see Chapter 4.2.3, "Impact of additional trigger settings",
on page 56.
Remote command: 
[:SOURce<hw>]:BB:ARBitrary:TRIGger[:EXTernal]:DELay on page 559
[:SOURce<hw>]:BB:ARBitrary:TRIGger[:EXTernal]:TDELay on page 560

Actual Trigger Delay/Actual External Delay
Displays the time (in seconds) an external trigger event or a trigger event form the
other path is delayed with.
See also Chapter 4.2.3, "Impact of additional trigger settings", on page 56.
Remote command: 
[:SOURce<hw>]:BB:ARBitrary:TRIGger[:EXTernal]:RDELay? on page 560

4.3.3.6  Marker settings

Access:

► Select "Baseband" > "ARB" > "Marker".

This tab provides settings to select and configure the marker output signal includ-
ing marker mode and marker delay.

Routing and activating a marker signal

1. To define the signal shape of an individual marker signal "x", select "Marker" >
"Marker x" > "Mode".

2. Optionally, define the connector for signal output. See Chapter 4.3.3.8, "Global
connector settings", on page 82.
You can map marker signals to one or more User x connectors.

3. Enable baseband signal generation. In the block diagram, set "Baseband" > "On".

The R&S SFI100A adds the marker signal to the baseband signal. Also,
R&S SFI100A outputs this signal at the configured User x connector.

About marker output signals

This section focuses on the available settings.

For detailed information, see Chapter 4.2, "Common characteristics of the baseband
domain", on page 52.

Mode............................................................................................................................. 81
Delay............................................................................................................................. 81
Delay (Time)..................................................................................................................81
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Mode
Sets the marker mode that defines the shape and periodicity of the marker signal.
You can configure individual marker modes for each marker signal. The number of
available markers is 4. The marker configuration changes with the selected marker
mode.
For more information on marker modes, see Chapter 4.2.4, "About marker signals",
on page 59.
Note: Setting an ARB marker mode that is different than "Unchanged" does not
change the marker trace in the loaded waveform file. But, when playing the waveform
file the instrument uses the configured ARB marker mode.
The instrument routes the generated marker signals to the selected output connectors.
See also Chapter 4.5, "Configuring global connectors", on page 121.
"Unchanged" The waveform file with its configured marker traces defines the

marker signal of the ARB baseband signal.
Remote command: 
[:SOURce<hw>]:BB:ARBitrary:TRIGger:OUTPut<ch>:MODE on page 561
[:SOURce<hw>]:BB:ARBitrary:TRIGger:OUTPut<ch>:PULSe:DIVider
on page 562
[:SOURce<hw>]:BB:ARBitrary:TRIGger:OUTPut<ch>:PULSe:FREQuency?
on page 562
[:SOURce<hw>]:BB:ARBitrary:TRIGger:OUTPut<ch>:PATTern on page 561
[:SOURce<hw>]:BB:ARBitrary:TRIGger:OUTPut<ch>:OFFTime on page 561
[:SOURce<hw>]:BB:ARBitrary:TRIGger:OUTPut<ch>:ONTime on page 561

Delay
Delays the marker signal at the marker output relative to the signal generation start.
Variation of the parameter "Marker x" > "Delay" causes signal recalculation.
Remote command: 
[:SOURce<hw>]:BB:ARBitrary:TRIGger:OUTPut<ch>:DELay on page 562

Delay (Time)
Shows the marker delay time in microseconds, milliseconds or seconds depending on
the marker delay.
Remote command: 
[:SOURce<hw>]:BB:ARBitrary:TRIGger:OUTPut<ch>:DINSec? on page 563

4.3.3.7  Clock settings

Access:

► Select "Baseband" > "ARB" > "Clock".

This tab provides settings to select and configure the clock signal, like the clock
source and clock mode.
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Defining the clock

1. Select "Clock" > "Source" to define the source of the clock signal.

2. For external clock signals, define the connector for the signal input. See Chap-
ter 4.3.3.8, "Global connector settings", on page 82.

Global connector settings allow you to configure the signal mapping, the polarity,
the trigger threshold and the input impedance of the input connectors.

3. Activate baseband signal generation. In the block diagram, set "Baseband" > "On".

The R&S SFI100A starts baseband signal generation with a symbol rate that
equals the clock rate.

About clock signals

This section focuses on the available settings.

For detailed information, see Chapter 4.2, "Common characteristics of the baseband
domain", on page 52.

Clock Source.................................................................................................................82

Clock Source
Selects the clock source.
● "Internal"

The instrument uses its internal clock reference.
Remote command: 
[:SOURce<hw>]:BB:ARBitrary:CLOCk:SOURce on page 563

4.3.3.8  Global connector settings

Opens a dialog to configure global connectors.

The button is available in the following dialogs or tabs:
● "Trigger / Marker / Clock" dialog that is accessible via the "TM" block in the block

diagram.
● "Trigger In", "Marker" and "Clock" tabs of baseband signal configuration dialogs

that you can open via the "Baseband" block in the block diagram. These tabs are
available, for example, for "ARB" baseband signals.

See also Chapter 4.5, "Configuring global connectors", on page 121.
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4.3.4  Playing waveform files

This section provides step-by-step instructions to create, generate and play waveform
files on the R&S SFI100A. Provided the R&S SFI100A is equipped with the required
option, you can load this waveform file and process it with the instrument.

For details on individual functions and settings, see Chapter 4.3.3, "ARB settings",
on page 69.

Some test cases do not require a real-time signal generation according to a digital
standard. For these test cases, the replay of a previously generated waveform is suffi-
cient. Generate these waveform files as follows:
● Internal generation with the "Create Test Signal" function, see Chapter 4.3.4.1,

"Generating ARB test signals", on page 83.
● External waveform generation with Rohde & Schwarz software products:

– For R&S WinIQSIM2, see Chapter 4.3.4.3, "Working with R&S WinIQSIM2",
on page 84.

– For R&S ARB Toolbox, see 1GP88.
● External waveform generation with MATLAB, see Chapter 4.3.4.4, "Creating wave-

forms with tag file format", on page 88 and 1GP60.

This section provides examples on the internal waveform file generation and on the
external generation with R&S WinIQSIM2.

● Generating ARB test signals...................................................................................83
● Loading and playing waveform files........................................................................84
● Working with R&S WinIQSIM2................................................................................84
● Creating waveforms with tag file format..................................................................88
● Defining periodically repeating traces..................................................................... 92
● Editing waveform files, data and control lists.......................................................... 94

4.3.4.1  Generating ARB test signals

If your test case requires a simple sine signal or square signal, use the ARB test sig-
nals.

To generate a sine test signal

1. Select "Baseband" > "ARB"

2. Select "Create Test Signal" > "Sine".

3. Adjust the "Sine Test Signal" settings as required.

4. Select "Generate Signal File".
A standard file select dialog opens.

a) Navigate to the directory in that you want to save the file, for example /var/
user/.

b) Enter a filename, for example sine_waveform.
c) Click "Save".
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The R&S SFI100A saves the generated waveform file and automatically loads it in
the ARB.

5. Select "ARB" > "State" > "On".

The R&S SFI100A processes the waveform file.

4.3.4.2  Loading and playing waveform files

Irrespectively on how you generate a waveform, you can transfer it to the instrument,
load it in the ARB and play it.

To load and play a waveform file

1. Transfer an externally created waveform file to the instrument.
See Chapter 10.8, "Transferring files from and to the instrument", on page 289.

2. Select "Baseband" > "ARB".

3. Select "Load Waveform".
A standard file select dialog opens.

a) Navigate to the directory that the waveform file contains.
b) Select the waveform file, for example /var/user/lte_waveform.
c) Click "Select".

The "ARB" dialog confirms that the waveform file is loaded.

4. Select "ARB" > "State" > "On".

The R&S SFI100A processes the waveform file.

4.3.4.3  Working with R&S WinIQSIM2

The following example illustrates how to use R&S WinIQSIM2 simulation software to
generate an EUTRA/LTE waveform and load it in the ARB of the R&S SFI100A.

The workflow consists of three main steps, each described in a separate step-by-step
instruction:
● Configuring the connection between the R&S WinIQSIM2 and the R&S SFI100A
● Generating of a waveform file with the required settings
● Transferring the waveform file to and playing it with the R&S SFI100A.

This section does not describe the R&S WinIQSIM2 simulation software but focuses on
the task-related settings. For a description of the simulation software, see the
R&S WinIQSIM2 user manual.

To define the R&S SFI100A as destination instrument

In this example, we assume that the R&S WinIQSIM2 is installed on a remote control-
ler. This remote controller is connected over LAN to the R&S SFI100A.
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The general instrument settings of the destination instrument affect various functions,
for example, the maximum size of the file the waveform is saved in. We recommend
that you configure the destination instrument before you generate the waveform with
the R&S WinIQSIM2.

1. In the R&S WinIQSIM2, select "File" > "New" to preset the software.

2. In the block diagram, select "Vector Sig Gen" > "Instruments".

The "Configure Instruments" dialog opens. The list of configured instruments is
empty.

3. Select "Configure Instruments" > "Scan".

The software scans the network for connected and active instruments.
Alternatively, use the "New" function to add the R&S SFI100A manually to the list
of instruments.

4. Close the dialog.

5. In the block diagram, select "Vector Sig Gen" block and select the R&S SFI100A
form the list.

6. In the block diagram, select "ARB Sig Gen" block and select the R&S SFI100A
form the list.

The two lines to the "Vector Sig Gen" and "ARB Sig Gen" blocks on the block dia-
gram confirm that a remote connection to the R&S SFI100A is established.

To generate a waveform file with R&S  WinIQSIM2

1. In the block diagram of R&S WinIQSIM2, select "Baseband" > "EUTRA/LTE/IoT".

2. Adjust the settings as required, for example:

a) Select "Link Direction" > "Downlink (OFDMA)"
b) Select a predefined test model, for example, "Test Models" > "E-

TM1_1__10MHz".

3. Select "EUTRA/LTE/IoT" > "State" > "On".

Using the arbitrary waveform generator (ARB)



Generating baseband signalsR&S®SFI100A

86User Manual 1179.6789.02 ─ 02

R&S WinIQSIM2 calculates the signal and displays important signal parameters,
for example, number of samples "Samples" and "Sample Rate".

Select "Graphics" > "Graphic 1 (Complete)" to check for more information on the gen-
erated signal.

The display confirms the expected EUTRA/LTE 10 MHz spectrum.
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To transfer the waveform file to the R&S SFI100A

1. At R&S WinIQSIM2, select "Transmission" > "Transmit".

2. In the "Waveform Transmission to Arbitrary Waveform Generator" dialog, proceed
as follows:

a) "Transmit from" > "Internal (WinIQSIM2)".
b) "Transmit to" > "Instrument".
c) Select "File".
d) Define the filename of the transmitted file.
e) Activate "Automatically Load and Start Waveform".
f) Select the required baseband, for example "Path A".
g) Add a comment to the waveform, for example as follows:

"User Comment for File/Waveform" > "LTE_TM_1-10_WinIQSIM2_WV"
h) Select "Transmit".

R&S WinIQSIM2 transmits the waveform to the default directory of the
R&S SFI100A.

3. In the R&S SFI100A, select "Baseband" > "ARB".

Using the arbitrary waveform generator (ARB)



Generating baseband signalsR&S®SFI100A

88User Manual 1179.6789.02 ─ 02

The dialog confirms that the ARB is active and plays the transmitted waveform.

4.3.4.4  Creating waveforms with tag file format

The provided example uses a sine function in the I channel and a cosine function in the
Q channel, each with 20 points. The example uses a short program written in the pro-
gramming language C to calculate the sine and cosine values (see Example "C-pro-
gram for creating a waveform file" on page 91). They are saved in the file SICO.txt.
The decimal values in SICO.txt are normalized such that they are between –1.0 and
+1.0. The data is converted into binary format. The appropriate mandatory tags are
added and the data is packed into the WAVEFORM tag. As result, the waveform file
SICO.wv is generated.

This example follows the general principle of creating of a waveform manually, using
the tag file format. The Figure 4-10 illustrates this general workflow.

Figure 4-10: Principle of creating a waveform manually

The following steps outline how to create the waveform file SICO.wv:

1. Calculate the sine and cosine values. For example, use the SICO.cpp program.

The result is saved in the file SICO.txt.
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Figure 4-11: Contents of SICO.txt: first column Sine (I), second column Cosine (Q)

2. Convert the values from the file SICO.txt into binary format consisting of 16-bit
signed integer numbers. The numeric range between –1.0 and +1.0 corresponds to
the modulation range of the waveform 16-bit D/A converter of -32767 to +32767.

+1.0 -> 32767 -> = 0x7FFF

0.0 -> 0 -> = 0x0000

-1.0 -> -32767 -> = 0x8001

The Figure 4-12 shows the calculation and conversion steps. The highlighted col-
umns contain the resulting I and Q values represented in Little endian format.
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Figure 4-12: I and Q values calculation and conversion

3. Use an ASCII editor which is able to handle binary data. Create and add the follow-
ing mandatory tags before this binary data set can be further processed:
● CLOCK
● LEVEL OFFS
An example of the SICO.wv file contents could be:

{TYPE: SMU-WV, 0}{CLOCK: 10e6}{LEVEL OFFS: 3.010300,0.000000}
0000FF7F8E27BB79 ... 72D8BB79
To simplify the example, the checksum is set to 0, i.e. the instrument does not eval-
uate a checksum.

Tip: The tags TYPE, CLOCK, LEVEL OFFS and WAVEFORM are mandatory for each
waveform. All other tags are optional and can be inserted after the TYPE tag in
arbitrary order.

4. Pack the binary data into a WAVEFORM tag with the described structure.

{WAVEFORM-Length: #I0Q0I1Q1I2Q2 ... InQn}
● Calculate the Length

Length = Number of I/Q pairs * 4 + 1 = 20*4 + 1 = 81 bytes
● Place the string {WAVEFORM-81:# at the beginning of the data set
● Place the symbol } at the end of the data set

The contents of the waveform file SICO.wv for 20 I/Q pairs is now ready for opera-
tion and reads:
{TYPE: SMU-WV,0}
{CLOCK: 10e6}
{LEVEL OFFS: 3.010300,0.000000}
{WAVEFORM-81:#I0Q0I1Q1...InQn}
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There is no readable representation for binary values in this document. This exam-
ple uses the sequence I0Q0I1Q1...InQn to characterize the binary code. The
following figure shows this waveform in a data editor.

Example: C-program for creating a waveform file
C-program SICO.cpp for creating the file SICO.txt containing 20 sine and cosine
pairs, converting them into binary data and creating the waveform file SICO.wv.

// SICO.cpp 
// Defines the entry point for the console application

#include "stdafx.h"
#include <stdlib.h>
#include <stdio.h>
#include <math.h>

int _tmain(int argc, _TCHAR* argv[])
{
    const unsigned int samples = 20;
    const float pi = 3.141592654f;
    int i;

// SICO.txt
// Creating the file SICO.txt containing 20 sine and cosine pairs
    float grad, rad;
    FILE *fp;
    fp = fopen("SICO.txt", "w");
    if (fp == 0)
        return;
    for (i=0; i<samples; i++)
    {
        grad = (360.0f / (float)samples) * (float)i;
        rad = grad * (pi / 180.0f);
        fprintf(fp, "%f %f\n", sin(rad), cos(rad));
    }
    fclose(fp);
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// SICO.wv
// Generating a binary data set from the I/Q pairs in the file SICO.txt
// and storing the result to file SICO.wv
    FILE *fp_sour, *fp_dest;
    float i_float, q_float;
    unsigned short i_usint, q_usint;
    fp_sour = fopen("SICO.TXT", "rt");
    if (fp_sour == 0)
        return -1;
    fp_dest = fopen("SICO.WV", "wb");
    if (fp_dest == 0)
    {
        fclose(fp_sour);
        return -1;
    }
    // Write required tags to waveform file
    fprintf(fp_dest, "{TYPE: SMU-WV,0}");
    fprintf(fp_dest, "{CLOCK: 10e6}");
    fprintf(fp_dest, "{SAMPLES: %d}", samples);
    // RMS, Peak
    fprintf(fp_dest, "{LEVEL OFFS: %f,%f}", -1.0f * 20.0f * log10(1.0f/sqrt(2.0f)), 0.0f);
    fprintf(fp_dest, "{WAVEFORM-%d:#", (samples * 4) + 1);
    for (i=0; i<samples; i++)
    {
      // Read I/Q pair from ASCII file
         if (fscanf(fp_sour, "%f %f", &i_float, &q_float) == EOF)
            break;
        // Convert I/Q pair to unsigned short
        i_usint = (unsigned short)floor((i_float * 32767.0) + 0.5);
        q_usint = (unsigned short)floor((q_float * 32767.0) + 0.5);
        // Write converted I/Q pair to waveform file
        fwrite(&i_usint, 2, 1, fp_dest);
        fwrite(&q_usint, 2, 1, fp_dest);
    }
    fprintf(fp_dest, "}");
    fclose(fp_dest);
    fclose(fp_sour);
return 0;
}

4.3.4.5  Defining periodically repeating traces

If you test setup requires marking an event, for example, each frame start, it is suffi-
cient to define the trace ones and repeat it over the length of a waveform. Repeating is
useful for long waveforms with periodical marker signals.

The following examples use marker traces. You can use control lists analogously.
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To define periodical marker trace

The waveform in the example below consists of three frames, each frame has a length
of 100 samples. Waveform processing is continuous via "Trigger Mode" > "Auto".

Figure 4-13: Example: Defining marker traces without CONTROL LENGTH tag

To define a restart marker and a frame start marker, use the following tags:

1. The waveform is 300 samples long, i.e. set {SAMPLES: 300}.

2. Set two [TRACE] LIST tags:
● For Marker 1 that acts as a restart marker:

{MARKER LIST 1: 0:1; 10:0; 299:0}
● For Marker 2 that marks each frame start:

{MARKER LIST 2: 0:1; 10:0; 99:0}

3. Do not use the CONTROL LENGTH tag.

The length of the repeated patterns is determined by the last sample number in the
[TRACE] LIST that is the last {Pos:State}.

Example: CONTROL LENGTH tag and trace processing
In the example below, use the same marker traces and set the CONTROL LENGTH tag,
for example {CONTROL LENGTH: 150}.

Figure 4-14: Example: Processing control signals with CONTROL LENGTH tag

The length of all control signals is determined by the CONTROL LENGTH. Observe how
the marker traces are processed. In this example, both marker traces are repeated
every 150 samples.
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4.3.4.6  Editing waveform files, data and control lists

You can edit the internally and externally crated waveform files, data and control lists.
The waveform, data and control lists files contain binary and ASCII data.

Consider the following rules while editing files with binary data.

Rules for editing binary data

● Use hex data editor
Always use a hex data editor to edit files containing binary data.
Editing of binary data file with a text editor, even if you only change the ASCII part
of the file, corrupts the file.

● Adapt the length information in the {EMPTYTAG}
If you change the content of a waveform file, change also the
{EMPTYTAG-Length} value.
For example, change this value, if you add a tag or add bytes to an existing tag.
Reduce the value by the number of newly introduced bytes.

4.3.5  Tags for waveforms, data and control lists

The instrument uses a simple tag-oriented format for externally or internally generated
waveforms, data and control lists. Files with this format can be transmitted from an
external computer to the instrument and vice versa.

The instrument transmits these files as a binary data block, using the following SCPI
command:
● [:SOURce<hw>]:BB:ARBitrary:WAVeform:DATA

Tag general format

Tags are self-contained information units, enclosed in braces { }. Their general format
is {Name: Data} or {Name-Length: Data}. The colon separates the name part
and the data part. The colon can be followed by a space for the sake of readability.
● The Name identifies the tag. It is always expressed in capital letters.
● The Data is tag-specific, and usually it is in ASCII plain text.
● The Length specifies the number of bytes in a WAVEFORM tag, DATA LIST tag, or

EMPTYTAG
Length is an ASCII integer value, defining the number of bytes from the colon : to
the end brace }

Rules

Each waveform file must begin with the TYPE tag. The sequence of the remaining tags
is arbitrary. For each tag, an indication shows whether it must be included in the file
concerned (mandatory) or can be included (optional).

Unknown tags are not analyzed by the R&S SFI100A; they are left unchanged and
saved without an error message for a possible further read back.
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R&S SMU waveforms can also be loaded on the instrument, where they are converted
internally into an R&S SFI100A waveform.

In all examples of file contents listed in this section, the tags have been separated by
line breaks for better reading.

Tag description

This section describes the mandatory TYPE tag followed by a description of all other
tags, grouped per file type and listed in an alphabetical order. Some tags are valid for
all three file types. If a tag is valid only for a single file type, e.g. only for a waveform,
this fact is indicated in the description.

Related step-by-step descriptions

See:
● Chapter 4.3.4.5, "Defining periodically repeating traces", on page 92
● Chapter 4.3.4.4, "Creating waveforms with tag file format", on page 88
● Chapter 4.3.4.6, "Editing waveform files, data and control lists", on page 94

Supported tags:

● Common tags..........................................................................................................95
● Tags for waveforms.................................................................................................97

4.3.5.1  Common tags

The following tags are common to all file types. For all tags, see "Supported tags:"
on page 95.

Common tags

{TYPE: magic, xxxxxxxx}.................................................................................................. 95
{COMMENT: string}..........................................................................................................96
{COPYRIGHT: string}....................................................................................................... 97
{DATE: yyyy-mm-dd;hh:mm:ss}......................................................................................... 97

{TYPE: magic, xxxxxxxx}

(mandatory, must be the first tag in the file)

Identifies the file as a valid R&S SFI100A file. It must be present and must be the first
in the waveform. If a file of the same name exists on the target medium, it is overwrit-
ten.

Setting parameters: 
magic Designates the file type and has the following values:

SMU-WV
A valid R&S SFI100A waveform.
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SMU-MWV
A valid R&S SFI100A multi-segment waveform.
SMU-DL
A valid R&S SFI100A data list.
SMU-CL
A valid R&S SFI100A control list.

xxxxxxxx Is an ASCII-coded checksum of the data part of the WAVEFORM
tag in the file. This value is always 0 for data lists and control
lists.
The checksum for waveforms is used for detecting transmission
errors. If the TYPE tag contains 0 or a non-numeric value for the
checksum, it is ignored.
It is calculated in accordance with the algorithm given bellow,
where:
start is a pointer to the first byte after the # character in the
WAVEFORM tag
length is the number of bytes between start and the closing
curly bracket (excluding the latter; length'must be divisible by 4
without a remainder.
UINT32 checksum(void *start, UINT32 length)
{
UINT32 i, result = 0xA50F74FF;
for(i=0; i < length/4; i++)
result = result ^ ((UINT32 *)start)[i];
return(result);
}
The checksum is currently not verified when waveforms are loa-
ded.

Example: {TYPE: SMU-WV,106656}
BB:ARB:WAV:TAG? 'TYPE'
Queries the content of the TYPE tag.
Response: 'SMU-WV,106656'
This is a valid waveform.

{COMMENT: string}

The tag contains a plain text ASCII string of arbitrary length. The string is not analyzed
in the R&S SFI100A. It is used to describe the file. The string is allowed to contain all
printable ASCII characters except the closing curly bracket.
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Example: {COMMENT: File with data for 3GPP enhanced
channels}
BB:ARB:WAV:TAG? 'COMMENT'
Queries the content of the COMMENT tag of the selected wave-
form file.
Response: 'File with data for 3GPP enhanced
channels'
The comment on the waveform reads "File with data for 3GPP
enhanced channels".

Usage: Setting only

{COPYRIGHT: string}

The tag contains an ASCII string of arbitrary length. The string is not analyzed in the
R&S SFI100A. It is used to save copyright information about the file content.

Example: {COPYRIGHT: Rohde&Schwarz}
BB:ARB:WAV:TAG? 'COPYRIGHT'
Queries the content of the COPYRIGHT tag of the selected wave-
form file.
Response: 'Rohde&Schwarz'
Copyright resides with Rohde & Schwarz.

Usage: Setting only

{DATE: yyyy-mm-dd;hh:mm:ss}

(optional)

The tag contains the date and time at which the file was created. Enter the year as four
digits. The instrument does not analyze this tag.

Example: {DATE: 2009-04-02;14:32:12}
BB:ARB:WAV:TAG? 'DATE'
Queries the content of the DATE tag of the selected waveform
file.
Response: '2009-04-02;14:32:12'
The waveform was created on April 2, 2009 at 14 hrs 32 min.

Usage: Setting only

4.3.5.2  Tags for waveforms

The following tags apply to waveforms exclusively. For all tags, see "Supported tags:"
on page 95.

Waveform tags

{CLOCK: frequency}.........................................................................................................98
{CONTROL LENGTH: ControlLength}................................................................................ 98
{EMPTYTAG-Length: #EmptySequence}............................................................................ 99
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{LEVEL OFFS: RMSOffset_dB,PeakOffset_dB}................................................................ 100
{MARKER MODE [#]: GENERATOR}............................................................................... 101
{SAMPLES: Samples}.................................................................................................... 101
{BURST LIST [#]: Pos0:State0; Pos1:State1; ...PosN-1:StateN-1}....................................... 102
{CW MODE LIST [#]: Pos0:State0; Pos1:State1; ...PosN-1:StateN-1}..................................102
{HOP LIST [#]: Pos0:State0; Pos1:State1; ...PosN-1:StateN-1}...........................................102
{LEVATT LIST [#]: Pos0:State0; Pos1:State1; ...PosN-1:StateN-1}...................................... 102
{MAP LIST [#]: Pos0:State0; Pos1:State1; ...PosN-1:StateN-1}...........................................102
{MARKER LIST [#]: Pos0:State0; Pos1:State1; ...PosN-1:StateN-1}.................................... 102
{[TRACE] LIST [#]: Pos0:State0; Pos1:State1; ...PosN-1:StateN-1}..................................... 102
{WAVEFORM-Length: #I0Q0I1Q1...IxQx...IN-1QN-1…}......................................................103

{CLOCK: frequency}

(mandatory for waveforms)

The tag specifies the clock frequency at which the waveform has to be output, in Hz
(on multi-segment waveforms this tag contains the maximal clock of all segments).

A query of ARB:CLOCk? after loading the waveform returns the value set using the
CLOCK tag. This value can later be altered with the command ARB:CLOCk?.

Example: {CLOCK: 54000000}
BB:ARB:WAV:TAG? 'CLOCK'
Queries the content of the CLOCK tag.
Response: 54000000
The clock frequency is set to 54 MHz.

Usage: Setting only

{CONTROL LENGTH: ControlLength}

(optional / recommended for marker and control lists)

The tag specifies the length of all control or marker list in ASCII format.

The control length influences the way the marker and control lists are processed, in
particular the way traces are repeated; see Figure 4-15.

Figure 4-15: Example: Processing of MARKER TRACE if CONTROL LENGHT is specified

If the CONTROL LENGTH tag is not used, the marker and control list length are deter-
mined by the last position, that is the last {Pos:State} couple, defined in the particular
[TRACE] LIST tag; see Figure 4-16.
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Figure 4-16: Example: Processing of MARKER TRACE if CONTROL LENGHT is not used

To maintain marker signals and waveform data synchronized, set the CONTROL
LENGTH to be equal to the number of samples specified with the tag SAMPLES.

See also Chapter 4.3.4.5, "Defining periodically repeating traces", on page 92.

Example: {CONTROL LENGTH: 500}
SOURce:BB:ARBitary:CLISt:TAG? 'CONTROL LENGTH'
Queries the length of the control list.
Response: 500

{EMPTYTAG-Length: #EmptySequence}

(mandatory in automatically generated one and multi-segment waveforms)

This tag is empty, i.e. contains no data, and is used as placeholder.

Setting parameters: 
Length An ASCII integer value that specifies the number of bytes in the

EMPTYTAG, i.e. defines the number of bytes from the colon : to
the end brace }
Note: If you change the content of a waveform file, change also
the {EMPTYTAG-Length} value. For example, if you add a tag
or add bytes to a tag, reduce the length by the number of newly
introduced bytes.

EmptySequence An empty sequence containing blanks only. The number of used
blanks is calculated as the difference between the hex
addresses of the {WAVEFORM} tag and the hash sign # in the
{EMPTYTAG}.
The {WAVEFORM} tag always starts at hex address #4000.
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Example: {TYPE:SMU-WV, 837236424}
{COPYRIGHT:2003 Rohde&Schwarz SMU}
{DATE:2012-07-11;14:38:01}
{SAMPLES:80000}
{CLOCK:8666666.666666666}
{VECTOR MAX:1.000000038569158}
{LEVEL OFFS:3.333553817875577e-07,0}
{MARKER LIST 1:0:1;1:0;1249:0}
{MARKER LIST 2:0:1;1:0;1249:0}
{MARKER LIST 3:0:1;1:0;1249:0}
{MARKER LIST 4:0:1;1:0;1249:0}
{EMPTYTAG-15947:# ...}
{WAVEFORM-320017:#IQIQIQ...}

The example waveform file contains 436 (0x1b4) bytes before
the # sign in the EMPTYTAG; the hex address of the # sign is
0x1b5. The {WAVEFORM} starts at 0x4000. The EMPTYTAG con-
tains 15946 blanks and has a length of (15946+1) bytes.

Usage: Setting only

{LEVEL OFFS: RMSOffset_dB,PeakOffset_dB}

(recommended for waveforms)

The tag determines the level of the ARB signal in the waveform file. The offset levels
define the offset of RMS and peak value relative to the 16-bit full scale modulation
(-32767 to + 32767) = 0 dB.

Setting parameters: 
RMSOffset_dB Defines the RMS level offset of the signal relative to full scale

ARB signal in the WAVEFORM tag. The offset is defined in ASCII
float format. The value is always positive.
A 3 dB value indicates that the RMS level of the signal is 3 dBs
below the full scale.
full scale = max. amplitude of vector of I/Q samples = |SIQ|max =
sqrt(I2+Q2)max = 0 dB

PeakOffset_dB Defines the peak level offset of the signal relative to full scale for
the ARB signal in the WAVEFORM tag. The offset is defined in
ASCII float format.
The value usually equals 0 dB as usually the I/Q samples
(signed 16-bit integer values) are modulated to full scale: Full
scale = 0 dB = max. amplitude of vector of I/Q samples = |SIQ|
max = sqrt(I2+Q2)max = (215)-1 = 32767.
A positive PeakOffset_dB value indicates that a headroom to
full scale is provided when generating the waveform. A negative
PeakOffset_dB value indicates that overrange is likely for some
samples, i.e. clipping might occur.
The crest factor can be calculated from the two values as fol-
lows:
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Crest Factor = |PeakOffset_dB - RMSOffset_dB|
Example: {LEVEL OFFS: 3.45,2}

BB:ARB:WAV:TAG? 'LEVEL OFFS'
Queries the content of the LEVEL OFFS tag of the selected
waveform file.
Response: 3.45,2
The level of the waveform is below full scale, clipping does not
occur.

Usage: Setting only

{MARKER MODE [#]: GENERATOR}

(Optional for waveforms)

The tag defines how the marker signals are generated. The tag is included in the
waveforms, created by the R&S WinIQSIM2 software.

● Tag not used
The marker signals defined with the tag MARKER LIST are converted into a sepa-
rate binary control list. When the waveform is loaded into the ARB, this control list
is also loaded automatically and processed synchronous with the waveform.
Note: This method reduces the maximum waveform length (given as number of
samples). The number of available samples is limited, because each marker
requires 4 bits per I/Q sample, additionally to the 32 bits required to describe an I/Q
sample.

● Tag is used
The marker signals defined with the tag MARKER LIST are processed internally;
additional control list is not created. If the tag is used for all 4 markers, the whole
ARB memory is available for the I/Q samples.
Note: If this tag is used, the maximum number of marker states defined with the
tag MARKER LIST is 64, i.e. Pos63:State63

Setting parameters: 
[#] 1 to 4

Sets the marker number.

Example: {MARKER MODE 1: GENERATOR}
{MARKER MODE 2: GENERATOR}
{MARKER MODE 3: GENERATOR}

Usage: Setting only

{SAMPLES: Samples}

(recommended for waveforms)

The tag contains the number of I/Q samples in the waveform in ASCII format.

On multi-segment waveforms, this tag contains the total I/Q samples of all segments.
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Example: {SAMPLES: 1000}
BB:ARB:WAV:TAG? 'SAMPLES'
Queries the content of the SAMPLES tag of the selected wave-
form file.
Response: 1000
The waveform contains 1000 I/Q samples.

Usage: Setting only

See also Chapter 4.3.4.5, "Defining periodically repeating traces", on page 92.

{BURST LIST [#]: Pos0:State0; Pos1:State1; ...PosN-1:StateN-1}
{CW MODE LIST [#]: Pos0:State0; Pos1:State1; ...PosN-1:StateN-1}
{HOP LIST [#]: Pos0:State0; Pos1:State1; ...PosN-1:StateN-1}
{LEVATT LIST [#]: Pos0:State0; Pos1:State1; ...PosN-1:StateN-1}
{MAP LIST [#]: Pos0:State0; Pos1:State1; ...PosN-1:StateN-1}
{MARKER LIST [#]: Pos0:State0; Pos1:State1; ...PosN-1:StateN-1}
{[TRACE] LIST [#]: Pos0:State0; Pos1:State1; ...PosN-1:StateN-1}
(mandatory for control lists / optional for waveforms)

The tag contains the data for the marker and control signals in the control list or the
marker signals of ARB waveforms.

Depending on the control length, the instrument processes traces differently, see
{CONTROL LENGTH: ControlLength} on page 98.

How to: Chapter 4.3.4.5, "Defining periodically repeating traces", on page 92

Also, the processing of the marker traces (MARKER LIST) depends on the presence of
the marker mode tag. See {MARKER MODE [#]: GENERATOR} on page 101.

Setting parameters: 
[TRACE] MARKER | BURST | LEVATT | CW MODE | HOP | MAP

Name of the marker or control signal.
For ARB waveforms, it is only meaningful to define marker sig-
nals; in the ARB multi-segment waveforms these tags are
ignored.

[#] 1 to 4
Sets the marker or control trace number; supported is only
LEVATT LIST 1.

Pos Specifies in ASCII format the position (i.e. sample number or
data value), with the effect from which the binary State of the
marker or of the control signal changes.
If you use the marker mode tag, the maximum number of marker
states is 64, i.e. Pos63:State63. See {MARKER MODE [#]:
GENERATOR} on page 101.

State 0 | 1
Specifies the binary state of the marker or of the control signal
from PosN to PosN+1 exclusive in ASCII format.
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Example: {MARKER LIST 1: 0:0;10:1;20:0;30:1}
BB:DM:CLIS:TAG? 'MARKER LIST 1'
Queries the content of the MARKER LIST 1 tag of the selected
control list file.
Response: '0:0;10:1;20:0;30:1'
The marker setting for samples 0 to 9 = 0 (low), for 10 to 19 = 1
(high) and for 20 to 29 = 0. From sample 30 onward, the marker
setting is 1 (high).

Example: {LEVATT LIST 1: 0:0;10:1;20:0;30:1}
BB:DM:CLIS:TAG? 'LEVATT LIST 1'
Queries the content of the LEVATT LIST 1 tag of the selected
control list file.
Response: '0:0;10:1;20:0;30:1'
Level attenuation applies to data values 10 to 19 (high) and from
data value 30 onward.

Usage: Setting only

{WAVEFORM-Length: #I0Q0I1Q1...IxQx...IN-1QN-1…}

(mandatory for waveforms)

Setting parameters: 
Length Sets the number of bytes in a WAVEFORM tag and is calculated

as follows:
Length = Number of I/Q pairs * 4 (2 bytes per I and 2
bytes per Q value) + 1 byte (the length of the #)

IxQx IxQx… represents binary data (16-bit signed integer in 2's com-
plement notation) containing the I and Q component alternately
and starting with the I component. Each component consists of 2
bytes in little endian format representation, i.e the least signifi-
cant byte (LSB) first.
The values of the 2 bytes in an I component and a Q component
are in the range 0x0 to 0xFFFF (-32767 to +32767). This value
is transferred to the D/A converter.

Example: One segment waveform
{WAVEFORM-401:#I0,Q0,I1,Q1,I2,Q2,...I99, Q99}
100 I/Q pairs with 4 bytes each are transmitted - none multi-seg-
ment.

Usage: Setting only

4.4  Generating multicarrier waveform signals

To simulate complex multicarrier scenarios with different baseband signals, the
R&S SFI100A provides the possibility to generate multicarrier waveforms. These wave-
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forms can consist of up to 512 carriers, each modulated by the same or by different
user-selectable baseband signal.

The multicarrier waveform is a practical solution for the generation of a complex broad-
band signal, for example:
● Multicarrier waveforms build from signals of different communication standards

(e.g. CDMA2000 or 3GPP FDD)
● Multicarrier waveforms composed of several signals from the same communication

standard as in LTE Advanced.

4.4.1  Required options

See Chapter 4.3.1, "Required options", on page 64.

Multicarrier waveform files require the corresponding digital standard options
(R&S SFI-K2xx) of all included standards.

4.4.2  About the multicarrier waveforms

This chapter provides background information on the ARB functionality for generating
of multicarrier signals and the impact of the provided settings. See Chapter 4.4.4,
"Using the multicarrier function", on page 119 for information on how to use the provi-
ded settings to configure a multicarrier signal.

The multicarrier waveforms are a convenient way to configure the broadband test sig-
nals required for transmitter or receiver tests. Even complex multicarrier scenarios
composed of signals from different digital standards can be created and used for these
tests.

Because the multicarrier files are processed by the ARB, the composed waveform file
must be created before it is loaded to and played by the ARB. The R&S SFI100A
saves the created multicarrier waveform file under a user-definable name; as with the
single carrier waveforms, the used file extension is *.wv. The instrument appends
additional information to the header of the composed waveform file. When the created
waveform is loaded, the graphical interface displays information on clock rate, number
of samples and creation day.

General principle for composing the multicarrier signal

The following is a list of the general steps used for composing the multicarrier signal:
● In the default mode, the up to 512 carriers are equally spaced and centered toward

the RF frequency or the baseband DC line.
The carrier spacing is adjustable within the total available bandwidth. Make sure
that the total RF bandwidth of the composed multicarrier signal does not exceed
the available RF bandwidth.

● Another possibility is to define the center frequency of each of the carrier individu-
ally, see also Chapter 4.4.2.1, "Defining the carrier frequency", on page 105.

● Define each carrier separately in terms of power, phase and modulated input sig-
nal.
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To define the leveling of the composed multicarrier signal, use the parameter
"Power Reference", see "Power Reference" on page 110.

● Optionally, optimize the crest factor of the multicarrier output signal, see Chap-
ter 4.4.2.2, "Optimizing the crest factor", on page 106.

● After all multicarrier processing steps are completed, the instrument calculates the
resulting peak and RMS power over the total signal. This value is then written in
the waveform file.

For more information, refer to the specifications document.

4.4.2.1  Defining the carrier frequency

There are two ways to define the carrier frequency of the individual carriers in the mul-
ticarrier signal:
● Enable the arbitrary carrier frequency distribution and specify the carrier frequency

of each carrier individually.
● Use the built-in equidistant carrier spacing distribution function.

About equidistant carrier spacing

Equidistant carrier spacing implies a uniform distribution around the RF frequency. This
method derives the carrier frequencies automatically from the selected number of carri-
ers and the carrier spacing.

The maximum carrier spacing Δfmax is a function of the available total bandwidth ftot and
the selected number of carriers n. Calculate Δfmax as follows:

The method rounds the value of the carrier spacing Δfround so that the carrier that is
closest to the center RF frequency shows no phase jump. Also, this method holds for
unmodulated carriers only. Rounding includes the output signal duration toutput and the
actual carrier spacing Δf as follows:
● For an odd number of carriers:

● For an even number of carriers:

To avoid wrap-around problems, you can slightly modify the effective applied carrier
spacing. See also "Mode" on page 108.
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4.4.2.2  Optimizing the crest factor

An introduction to the topic is provided in Chapter 4.2.6, "Methods for optimizing the
crest factor", on page 61. This section focuses on the settings provided for and related
to the multicarrier signals.

The R&S SFI100A provides a crest factor reduction by an automatic optimization upon
selected values for the following parameters:
● "Crest Factor Mode":

This mode offers multicarrier output signals with minimized or maximized target
crest factor values via internal phase corrections of the single carriers. For a dis-
abled mode ("Off"), there are no phase corrections.

● "Clipping":
Clipping reduces the peak power of the output multicarrier signal. The clipped peak
power level is the sum of the RMS level of the unclipped multicarrier signal and the
parameter "Target Crest Factor".
Because clipping also reduces the RMS level, the resulting crest factor of the clip-
ped signal is slightly above the "Target Crest Factor".

● "Target Crest Factor":
Sets the target crest factor. A value above the crest factor of the unclipped multi-
carrier signal has no effect.

● "Filter Cut Off Frequency":
This frequency is the lowpass filter frequency. If the cutoff frequency equals half of
the output sample rate, a final lowpass filter improves the spectrum of the clipped
multicarrier signal. But lowpass filtering can also increase the resulting crest factor.

4.4.3  Multicarrier settings

Access:

► Select "Baseband" > "ARB" > "General" > "Create Multi Carrier".

The "ARB: Multi Carrier" dialog opens. It provides general settings to configure the
carrier distribution around the center frequency and to improve the output signal
characteristics.
The tab "Carrier Table" allows selecting a waveform file per carrier. Use the "Car-
rier Graph" to visualize the configured signal.

The remote commands to define these settings are described in Chapter 13.16.2.5,
"Multicarrier commands", on page 543.

Settings:

● General settings....................................................................................................107
● Output settings...................................................................................................... 112
● Carrier table settings............................................................................................. 113
● Carrier table assistant........................................................................................... 115
● Carrier graph......................................................................................................... 118
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4.4.3.1  General settings

Access:

► Select "Create Multi Carrier" > "General" > "General Settings".

This tab provides settings to select the output waveform file, to enable signal gen-
eration and to configure the distribution of the carriers.

Settings:

Set to Default.............................................................................................................. 107
Save/Recall................................................................................................................. 108
Mode........................................................................................................................... 108
Number of Carriers......................................................................................................108
Carrier Spacing........................................................................................................... 108
Crest Factor Mode...................................................................................................... 109
Clipping....................................................................................................................... 109
Target Crest Factor..................................................................................................... 109
Filter Cut Off Frequency..............................................................................................109
Signal Period Mode..................................................................................................... 110
Signal Period Mode..................................................................................................... 110
Power Reference.........................................................................................................110
Create/Create and Load..............................................................................................112

Set to Default
Calls the default settings.
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Parameter Value

"Number of Carriers" "1"

"Carrier Spacing" "0.00 Hz"

"Crest Factor Mode" "Off"

"Signal Period Mode" "Longest File Wins"

Remote command: 
[:SOURce<hw>]:BB:ARBitrary:MCARrier:PRESet on page 544

Save/Recall
Opens the standard "Save"/"Recall" dialog that is the standard instrument function for
saving and recalling the complete dialog-related settings.
Save multicarrier settings in files with file extension *.arb_multcarr. Define the file-
name and the directory of the file.
Remote command: 
[:SOURce<hw>]:BB:ARBitrary:MCARrier:SETTing:CATalog? on page 544
[:SOURce<hw>]:BB:ARBitrary:MCARrier:SETTing:LOAD on page 544
[:SOURce<hw>]:BB:ARBitrary:MCARrier:SETTing:STORe on page 545

Mode
Selects the way that the carriers are distributed within the available bandwidth.
"Equidistant Carrier Spacing"

Sets an equidistant carrier spacing distribution, i.e. the carriers are
equally spaced and centered toward the RF frequency. The carrier
frequencies are automatically calculated depending on the selected
number of carriers and the carrier spacing.

"Arbitrary Carrier Frequency"
Set the carrier frequency of each carrier individually.

Remote command: 
[:SOURce<hw>]:BB:ARBitrary:MCARrier:CARRier:MODE on page 545

Number of Carriers
Sets the number of carriers for the multicarrier waveform. By default the multicarrier
table lists one carrier. A maximum of 512 carriers can be configured and activated.
When the number of carriers is increased, new lines are added at the end of the table.
If these carriers already have been defined before, the settings are preset according to
the former settings. Otherwise the parameters are preset with the default values.
See also Chapter 4.4.2.1, "Defining the carrier frequency", on page 105.
Remote command: 
[:SOURce<hw>]:BB:ARBitrary:MCARrier:CARRier:COUNt on page 545

Carrier Spacing
Sets the frequency spacing between adjacent carriers of the multicarrier waveform.
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The distribution of the carriers is symmetric around the RF carrier. See also Chap-
ter 4.4.2.1, "Defining the carrier frequency", on page 105.
For more information, refer to the specifications document.
Remote command: 
[:SOURce<hw>]:BB:ARBitrary:MCARrier:CARRier:SPACing on page 545

Crest Factor Mode
Selects the mode for optimizing the crest factor by calculating the carrier phases. See
also Chapter 4.4.2.2, "Optimizing the crest factor", on page 106.
The following modes are available:
"Off" There is no automatic setting for minimizing or maximizing the crest

factor. The "Phase" setting as defined in the carrier table is in use.
"Minimize" The crest factor is minimized by internally calculating optimized car-

rier phases. The phase setting displayed in the carrier table is invalid.
"Maximize" The crest factor is maximized by internally calculating optimized car-

rier phases. The phase setting displayed in the carrier table is invalid.
Remote command: 
[:SOURce<hw>]:BB:ARBitrary:MCARrier:CFACtor:MODE on page 546

Clipping
Enables baseband signal clipping.
Clipping reduces the peak power of the resulting multicarrier signal according to the
input parameter "Target Crest Factor". See also, Chapter 4.4.2.2, "Optimizing the crest
factor", on page 106.
Remote command: 
[:SOURce<hw>]:BB:ARBitrary:MCARrier:CLIPping[:STATe] on page 547

Target Crest Factor
Requires "Clipping" > "On".
Sets the value of the target crest factor. A "Target Crest Factor" above the crest factor
of the unclipped multicarrier signal has no effect. See also Chapter 4.4.2.2, "Optimizing
the crest factor", on page 106.
Remote command: 
[:SOURce<hw>]:BB:ARBitrary:MCARrier:CLIPping:CFACtor on page 547

Filter Cut Off Frequency
Requires "Clipping" > "On".
Sets the cutoff frequency of the lowpass filter before the output of the multicarrier sig-
nal.
See also Chapter 4.4.2.2, "Optimizing the crest factor", on page 106.
Remote command: 
[:SOURce<hw>]:BB:ARBitrary:MCARrier:CLIPping:CUToff on page 547
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Signal Period Mode
Defines the way the resulting signal period of the multicarrier waveform is calculated.
The resulting period is always calculated for all carriers in the carrier table irrespective
of their state (ON/OFF). Use the "Carrier Table" > "Info" function to obtain information
on the sample rate and file length data of each carrier.
Note: Wrap-around and timing problems can occur when I/Q signals of different length
are used. Thus, demodulation of a carrier can be difficult or even impossible.
We recommend that you proceed as follows:
● Consider the timing when creating the input I/Q files.
● Adjust the signal duration to the carrier which is then demodulated.

Other carriers interfere with the signal.
These problems do not arise with signals of the same standard, for example, 3GPP
signals.
The following modes are available:
"Longest File Wins"

The longest I/Q file in the carrier table defines the resulting signal
period. Shorter I/Q files are periodically repeated.

"Shortest File Wins"
The shortest I/Q file in the carrier table defines the resulting signal
period. Longer I/Q files only use the first part.

"User" Sets the signal period manually, see "Signal Period Mode"
on page 110. Repeats shorter I/Q files periodically and uses only the
first part of longer I/Q files.

"Least Common Multiple"
The output file duration is the least common multiple of all input file
durations.

Remote command: 
[:SOURce<hw>]:BB:ARBitrary:MCARrier:TIME:MODE on page 548

Signal Period Mode
Sets the signal period in signal duration mode "User". Repeats shorter I/Q files periodi-
cally and for longer I/Q files, uses only the first part.
Remote command: 
[:SOURce<hw>]:BB:ARBitrary:MCARrier:TIME on page 546

Power Reference
Sets the method of leveling individual carriers in a composed multicarrier signal. The
difference between the provided modes is especially important if signals with different
crest factors are composed together into a multicarrier signal.
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"RMS" The individual carriers are leveled based on their RMS power and the
configured "Carrier Gain".

Example: 
A multicarrier signal is composed from two waveform files.
First carrier "Gain" = 0 dB
Second carrier "Gain" = -3 dB
In the resulting multicarrier signal, the RMS power of the second car-
rier signal is 3 dB lower than the RMS power of the first carrier signal.

"Peak" The individual carriers are leveled based on their peak power and the
configured "Carrier Gain".

Example: 
A multicarrier signal is composed from two waveform files.
First carrier "Gain" = 0 dB
Second carrier "Gain" = -3 dB
In the resulting multicarrier signal, the peak power of the second car-
rier signal is 3 dB lower than the peak power of the first carrier signal.

Example: Multicarrier signal composed of waveforms with differ-
ent crest factor
A multicarrier signal is composed from two waveform files with the fol-
lowing characteristics:
3GPP FDD signals with the same "Sample Rate" but different "Crest
Factors".
"Peak" = 0 dBFS
"Carrier Gain" = 0 dB

The peak values of the carrier signals are equal, but the RMS values
are different.
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Remote command: 
[:SOURce<hw>]:BB:ARBitrary:MCARrier:POWer:REFerence on page 548

Create/Create and Load
Creates a multicarrier waveform defined by the multicarrier table and general setting
entries.
If you start the calculation with the "Create and Load" function, the instrument creates
the waveform and loads it in the ARB.
Also, saves this multicarrier waveform with filename as set in "Output File". Depending
on the configuration of the multicarrier waveform, calculation can take some time. To
stop the calculation, use the "Abort" function.
Remote command: 
[:SOURce<hw>]:BB:ARBitrary:MCARrier:CREate on page 549
[:SOURce<hw>]:BB:ARBitrary:MCARrier:CLOad on page 548

4.4.3.2  Output settings

Access:

► Select "Create Multi Carrier" > "General Settings" > "Output Settings"

This tab displays settings of the output file and related output multicarrier signal.
These settings include the output filename, the clock rate and the file size.

Settings:

Output File...................................................................................................................112
Clock Rate...................................................................................................................113
File Size.......................................................................................................................113

Output File
Opens a standard "File Select" dialog to set the output filename of the multicarrier
waveform to be calculated. As with normal waveforms, the file extension is *.wv.

To trigger the calculation and storage of this multicarrier waveform, select "Create" or
"Create and Load".
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Remote command: 
[:SOURce<hw>]:BB:ARBitrary:MCARrier:OFILe on page 548

Clock Rate
Displays the resulting sample rate during the output of the multicarrier waveform is out-
put at the ARB.
The output clock rate depends on the following:
● Number of carriers
● Carrier spacing
● Input sample rate of the leftmost or rightmost carriers.
Remote command: 
[:SOURce<hw>]:BB:ARBitrary:MCARrier:CLOCk? on page 549

File Size
Displays the resulting number of samples of the multicarrier waveform.
Remote command: 
[:SOURce<hw>]:BB:ARBitrary:MCARrier:SAMPles? on page 546

4.4.3.3  Carrier table settings

Access:

► Select "Create Multi Carrier" > "Carrier Table"

This tab provides the settings to configure the number of carriers and set individual
carrier characteristics in a table. The number of lines equals the number of carriers.
Note that valid phase settings "Phase ( deg)" require disabled crest factor optimiza-
tion: "Crest Factor Mode" > "Off".

Optionally, use the "Carrier Table Assistant" for simplified configuration of the individual
carriers, see Chapter 4.4.3.4, "Carrier table assistant", on page 115. Use the "Carrier
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Graph" tab to visualize the configured multicarrier signal including its individual carri-
ers, see Chapter 4.4.3.5, "Carrier graph", on page 118.

Settings:

Number of Carriers......................................................................................................114
Carrier number............................................................................................................ 114
State............................................................................................................................ 114
Carrier Freq. Offs. (MHz).............................................................................................114
Gain (dB)..................................................................................................................... 114
Phase (deg).................................................................................................................114
Delay (ns).................................................................................................................... 115
File...............................................................................................................................115
Info...............................................................................................................................115
!!!..................................................................................................................................115

Number of Carriers
Defines the number of carriers of the multicarrier waveform, see "Number of Carriers"
on page 108.
Remote command: 
[:SOURce<hw>]:BB:ARBitrary:MCARrier:CARRier:COUNt on page 545

Carrier number
Displays the number of an individual carrier. The numbering of these carriers ranges
from 0 to the number of carriers - 1.
Remote command: 
Set via suffix CARRier<ch>.

State
Enables an individual carrier.
Remote command: 
[:SOURce<hw>]:BB:ARBitrary:MCARrier:CARRier<ch>:STATe on page 549

Carrier Freq. Offs. (MHz)
Displays the carrier frequency offset. This offset indicates
Note: The carrier frequency can only be set in "Arbitrary Carrier frequency" mode. For
"Equidistant Carrier Spacing", the carrier spacing is determined automatically.
Remote command: 
[:SOURce<hw>]:BB:ARBitrary:MCARrier:CARRier<ch>:FREQuency
on page 550

Gain (dB)
Sets the gain of a carrier.
Remote command: 
[:SOURce<hw>]:BB:ARBitrary:MCARrier:CARRier<ch>:POWer on page 550

Phase (deg)
Sets the starting phase of a carrier.
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Remote command: 
[:SOURce<hw>]:BB:ARBitrary:MCARrier:CARRier<ch>:PHASe on page 550

Delay (ns)
Sets the starting delay of a carrier.
Remote command: 
[:SOURce<hw>]:BB:ARBitrary:MCARrier:CARRier<ch>:DELay on page 551

File
Opens the standard "File Select" function for selecting the input file. The input file con-
tains the I/Q signal that is modulated onto the carrier.
Remote command: 
[:SOURce<hw>]:BB:ARBitrary:MCARrier:CARRier<ch>:FILE on page 551

Info
Opens a waveform information dialog. This dialog lists the sample rate, the number of
I/Q value pairs (number of samples) and the signal period.
Remote command: 
n.a.

!!!
Indicates a conflict with a warning triangle. A conflict arises when the carriers overlap
and is also indicated in the header of the "Carrier Table" tab.
Remote command: 
[:SOURce<hw>]:BB:ARBitrary:MCARrier:CARRier<ch>:CONFlict?
on page 551

4.4.3.4  Carrier table assistant

Access:

1. Select "Create Multi Carrier" > "Carrier Table"
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2. Select "Carrier Table Assistant".

The "Carrier Table Assistant" dialog enables the configuration of a selectable sub-
set of carrier. The provided settings are an optional way to create a multicarrier
scenario within a specified carrier range.

Settings:

Carrier State................................................................................................................ 116
Carrier Start.................................................................................................................116
Carrier Stop................................................................................................................. 117
Gain Start.................................................................................................................... 117
Gain Step.....................................................................................................................117
Phase Start..................................................................................................................117
Phase Step..................................................................................................................117
Delay Start...................................................................................................................117
Delay Step...................................................................................................................118
Input Waveform File.................................................................................................... 118
Apply Assistant Settings..............................................................................................118

Carrier State
Enables the carriers in the range "Carrier Start" to "Carrier Stop".
Remote command: 
[:SOURce<hw>]:BB:ARBitrary:MCARrier:EDIT:CARRier:STATe on page 551

Carrier Start
Sets the carrier start that is the first individual carrier for which the carrier assistant set-
tings apply.
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Remote command: 
[:SOURce<hw>]:BB:ARBitrary:MCARrier:EDIT:CARRier:STARt on page 552
[:SOURce<hw>]:BB:ARBitrary:MCARrier:EDIT:CARRier:STOP on page 552

Carrier Stop
Sets the carrier stop that is the last individual carrier for which the carrier assistant set-
tings apply.
Remote command: 
[:SOURce<hw>]:BB:ARBitrary:MCARrier:EDIT:CARRier:STARt on page 552
[:SOURce<hw>]:BB:ARBitrary:MCARrier:EDIT:CARRier:STOP on page 552

Gain Start
Sets the gain of the carrier marked by "Carrier Start".
Remote command: 
[:SOURce<hw>]:BB:ARBitrary:MCARrier:EDIT:CARRier:POWer[:STARt]
on page 552

Gain Step
Sets the step size that is used to increment the gain.
The resulting carrier gain in the carrier table equals:
Gain = "Gain Start" + n*"Gain Step".
n is a value between 0 and the difference of "Carrier Stop" and "Carrier Start".
Remote command: 
[:SOURce<hw>]:BB:ARBitrary:MCARrier:EDIT:CARRier:POWer:STEP
on page 552

Phase Start
Sets the phase of the carrier marked by "Carrier Start".
Remote command: 
[:SOURce<hw>]:BB:ARBitrary:MCARrier:EDIT:CARRier:PHASe[:STARt]
on page 553

Phase Step
Sets the step size that is used to increment the phase.
The resulting phase in the carrier table equals:
Phase = "Phase Start" + n*"Phase Step"

n is a value between 0 and the difference of "Carrier Stop" and "Carrier Start".
Remote command: 
[:SOURce<hw>]:BB:ARBitrary:MCARrier:EDIT:CARRier:PHASe:STEP
on page 553

Delay Start
Sets the delay of the carrier marked by "Carrier Start".
Remote command: 
[:SOURce<hw>]:BB:ARBitrary:MCARrier:EDIT:CARRier:DELay[:STARt]
on page 554
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Delay Step
Sets the step size that is used to increment the delay.
The resulting delay in the carrier table equals:
Delay = "Delay Start" + n*"Delay Step",
n is a value between 0 and the difference of "Carrier Stop" and "Carrier Start".
Remote command: 
[:SOURce<hw>]:BB:ARBitrary:MCARrier:EDIT:CARRier:DELay:STEP
on page 553

Input Waveform File
Opens the standard "File Select" function for selecting the input file. The input file con-
tains the I/Q modulation signal for all carriers of the selected carrier range.
Remote command: 
[:SOURce<hw>]:BB:ARBitrary:MCARrier:EDIT:CARRier:FILE on page 554

Apply Assistant Settings
Transfers the assistant settings to the carrier table.
Remote command: 
[:SOURce<hw>]:BB:ARBitrary:MCARrier:EDIT:CARRier:EXECute
on page 554

4.4.3.5  Carrier graph

Access:

► Select "Create Multi Carrier" > "Carrier Graph".

The carrier graph is a graphical representation of the current multicarrier configura-
tion in the frequency domain.
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The height of the bars corresponds to the gain of each individual carrier. The bars
width indicates the bandwidth of the carriers signals.

4.4.4  Using the multicarrier function

This section provides step-by-step instructions on how to configure and use the multi-
carrier settings.

To create a multicarrier waveform file

1. To configure the general settings, select "Baseband" > "ARB" > "General".

2. To configure the carrier table, select "ARB" > "Multi Carrier" > "Carrier Table"

3. To enter the filename of the multicarrier waveform, select "ARB" > "Multi Carrier" >
"Output File"

4. To save or load a multicarrier waveform, select "ARB" > "Multi Carrier" > "Create"
or "Create and Load".

To generate a multicarrier signal for standard transmitter tests

High-power amplifiers of multicarrier base stations face increased requirements in
terms of linearity and acceptable intermodulation performance.

To set up a standard transmitter test, proceed as follows:

1. Open the "Baseband" > "3GPP FDD" dialog. Proceed as follows:

a) Select "3GPP FDD" > "Basestations" > "Test Setups/Models".
b) Select "3GPP FDD: Downlink/Test Model" > "Test_Model_1_16channels".
c) To confirm, tap "Select".

2. To enable signal generation, select "3GPP FDD" > "General" > "On".

3. To create a 3GPP ARB file, select "3GPP FDD" > "Generate Waveform".
Enter the name of the waveform that you want to generate, for example:
3gpp_1_16.

4. Confirm with "Save"

5. To set up a multicarrier scenario with 4 carriers and a carrier spacing of 5 MHz,
select "Baseband" > "ARB" > "Create Multi Carrier".
Perform the following:

a) In the "General" dialog, select "Number of Carriers" = "4" and "Carrier Spacing"
= "5 MHz".

b) To load the generated waveform file to all 4 carriers, select "Carrier Table" >
"Carrier Table Assistant".

c) Select "Carrier Start" = "0" and "Carrier Stop" = "3".
d) To load the generated waveform file to all 4 carriers, select "ARB Multi Carrier

Table" > "Input Waveform File".
e) Select the generated waveform file 3gpp_1_16.
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f) Select "ARB Multi Carrier Table" > "Carrier State" > "On".

g) Select "ARB Multi Carrier Table" > "Apply Assistant Settings".
h) Close the dialog.

The "ARB: Multi Carrier" > "Carrier Table" dialog confirms the configuration.

6. Select "ARB: Multi Carrier" > "Carrier Graph" to visualize the configuration.
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7. Select "ARB: Multi Carrier" > "General" > "Output Settings" > "Output File".

8. Enter the name of the output file, for example 4x5MHz_3gpp_1_16.

9. To load the waveform in the ARB, select "ARB: Multi Carrier" > "General" > "Cre-
ate" or "Create and Load".

10. Select "ARB" > "General" > "Load Waveform", to select the multicarrier output file.

11. Select "ARB" > "State" > "On" to enable the ARB.

4.5  Configuring global connectors

The R&S SFI100A is equipped with four "User" multipurpose bidirectional connectors
that require no options.

This section provides background information on signal mapping and related settings.
Also, it describes how to configure and work with these connectors. It covers the fol-
lowing topics:

● About global connectors........................................................................................121
● Trigger / Marker / Clock settings........................................................................... 123
● RF connectors settings......................................................................................... 125
● Global connectors settings....................................................................................126
● Routing signals to the connectors.........................................................................129

4.5.1  About global connectors

Signal to connector mapping

As described in Chapter 4.2, "Common characteristics of the baseband domain",
on page 52, the R&S SFI100A can generate control signals internally and process
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external control signals. To handle these signals, the R&S SFI100A introduces the con-
cept of signal to connector mapping.

The available signals are not dedicated to a particular connector but can be mapped to
several "User" connectors. The signal mapping and the polarity, the trigger threshold
and the input impedance of the input connectors are configurable parameters.

How to: "To map the signal to a connector" on page 129

Related settings: Global connectors settings.

4.5.1.1  Global connectors

The R&S SFI100A is equipped with "User x" connectors that you can assign freely to a
selection of input signals or output signal.

You can configure threshold, and input impedance is effective for all trigger and clock
signal inputs provided at the "User" connectors. The settings influence the custom digi-
tal modulations, the generation of waveforms or multicarrier signals, and all digital
standards.

The table Table 4-4 provides an overview of the available input signals and output sig-
nals that you can map with the User connectors.
Table 4-4: Mapping control signals to the User x connectors

Connector Direction Signal Remark

"User 1" to "User 2" "Input" "Global Trigger" Use the connectors "User 1" to "User 2"
for a global trigger input signal. You
cannot use "User 3" as an input signal
connector.

"User 1" to "User 3" "Output" "Triggered"

"Always 0"

"Always 1"

Use the connectors "User 1" to "User 3"
for non-marker output signals. Per
default, the signal is an output signal
"Always 0".

"User 1" to "User 3" "Not Used" "None" No signal is input or output. The setting
implies a switched-off connector.

"User 4" to "User 7" "Output" "Baseband Marker" Use the connectors "User 4" to "User 7"
for marker output signals. The signal
routing is fixed:
● "Marker 1" to "User 7"
● "Marker 2" to "User 6"
● "Marker 3" to "User 5"
● "Marker 4" to "User 4"

4.5.1.2  Trigger, marker, clock and RF connectors

The Trigger / Marker / Clock settings and RF connectors settings dialogs provide an
overview of the current mapping of the logical signals to the corresponding connectors.
The dialogs are summary representation of related settings, as configured with the
Global connectors settings settings.
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4.5.1.3  Status indicators

Connector status LEDs

A dedicated LED indicates the connector status:
●  green: an input connector
●  yellow: an output connector
●  no light / gray: the connector is not active

TM block

For a quick overview of the control signal sources, the block diagram provides the "TM"
block on the left side of the "Baseband" block.

If the baseband generator is enabled, a dedicated LED indicates the status of the con-
trol signal:
●  Green: Uses an external signal.
●  Yellow: Uses the signal as an output signal.

4.5.2  Trigger / Marker / Clock settings

Access:

1. In the block diagram, select the "TM" block to the left side of the "Baseband" block.

The "Trigger / Marker / Clock" dialog opens. It provides an overview of the current
mapping of the logical signals to the connectors, as configured in the Global Con-
nectors dialog. Clicking the connector name directly accesses the related connec-
tor settings.

2. Use the built-in "Show Connector" function to display the physical location of the
selected connector. See "Show Connector" on page 124.
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A blinking LED on the rear panel indicates the selected connector:

The eye icon  in the tab header indicates the location of the connector on the
panel (front, rear or both).

4.5.2.1  Overview table

Logical Signal
Displays the logical signal, as configured in the "Trigger In", "Marker" or "Clock" tab of
the active baseband signal. Only the signals as configured in the "Baseband" > "ARB"
tabs are applied. See for example Chapter 4.3.3, "ARB settings", on page 69.

Connector
Displays the assigned connector.

Show Connector
Accesses a dialog that displays the physical location of the selected connector on the
front/rear panel of the instrument.

4.5.2.2  Global connector settings

Opens a dialog to configure global connectors.

The button is available in the following dialogs or tabs:
● "Trigger / Marker / Clock" dialog that is accessible via the "TM" block in the block

diagram.
● "Trigger In", "Marker" and "Clock" tabs of baseband signal configuration dialogs

that you can open via the "Baseband" block in the block diagram. These tabs are
available, for example, for "ARB" baseband signals.
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See also Chapter 4.5, "Configuring global connectors", on page 121.

4.5.3  RF connectors settings

Access:

1. In the control signal block next to the "RF" block, select "T E V".

The "RF Connectors" dialog gives an overview of the mapping of the logical signals
to the connectors; the displayed connectors depend on the installed options.

2. Select the signal type ("Signal") to open the dialog with related signal settings.

3. Use the built-in Show Connector function to display the physical location of the
selected connector.
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The eye icon  in the tab header indicates, if the connector is on the front panel or
rear panel. A blinking blue rectangle marks the connector or multiple connectors, if
supported.

Settings:

Signal.......................................................................................................................... 126
Connector....................................................................................................................126
Show Connector..........................................................................................................126

Signal
Opens the dialog with the corresponding settings.

Connector
Displays the assigned connector.

Show Connector
Accesses a dialog that displays the physical location of the selected connector on the
front/rear panel of the instrument.

4.5.4  Global connectors settings

Access:

1. In the block diagram, select the TM block.

2. Select "Global Connectors".

Alternatively, select for example "Baseband" > "ARB" > "Trigger In" > "Global Con-
nectors".

The "Global Connectors" dialog provides settings to configure the signal to connec-
tor routing and the physical characteristics of the input connectors for trigger, clock
and control signals.
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Settings:

4.5.4.1  Signal routing settings

Access:

► Select "Global Connectors" > "Routing".

The tab provides settings to configure the signal to connector routing.

Use the built-in Show Connector function to display the physical location of the
selected connector. Also, a blinking LED on the rear panel indicates the selected con-
nector.

Settings:

Show Connector..........................................................................................................127
Direction...................................................................................................................... 127
Signal.......................................................................................................................... 127

Show Connector
Accesses a dialog that displays the physical location of the selected connector on the
front/rear panel of the instrument.

Direction
Sets the direction of the signal at the connector that can be an input or an output.
If you do not use the connector, select "Not Used".
Remote command: 
[:SOURce]:INPut:USER<ch>:DIRection on page 470
:OUTPut:USER<ch>:DIRection on page 470

Signal
Sets the control signal type for input or output at the selected connector.
To define the signal direction at the connector, see "Direction" on page 127. For an
overview on available control signals, see Table 4-4.
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"Global Trigger"
Input of an external trigger signal to start the ARB baseband signal
generation.
The ARB trigger source is an external global trigger event, see Chap-
ter 4.3.3, "ARB settings", on page 69.

"Triggered" Output of the internal trigger signal or output of a received external
trigger signal.

"Always 0"/"Always 1"
Control signal with a constant low level or high level.

"None" No input signal or output signal at the connector.
Remote command: 
:OUTPut:USER<ch>:SIGNal on page 470

4.5.4.2  Signal characteristics settings

Access:

► Select "Global Connectors" > "Characteristics".

The tab provides settings to configure the physical characteristics of the input con-
nectors for trigger and clock signals.

Settings:

Threshold User 1 Input/Threshold User 2 Input.......................................................... 128
Logic Level User 1/Logic Level User 2........................................................................129
Impedance User 1/Impedance User 2........................................................................ 129
Trigger Input Slope......................................................................................................129

Threshold User 1 Input/Threshold User 2 Input
Sets the high threshold or low threshold for the input signal at the User 1 connector or
User 2 connector.
Remote command: 
[:SOURce]:INPut:USER:TRIGger:LEVel on page 471
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Logic Level User 1/Logic Level User 2
Sets the logic level for the output signal at the User 1 connector or User 2 connector.
Remote command: 
[:SOURce]:INPut:USER<ch>:CLOCk:LLEVel on page 471

Impedance User 1/Impedance User 2
Selects the input impedance for the input signal.
Set "100 kΩ / GND" for high-frequency input signals.
Remote command: 
[:SOURce]:INPut:TRIGger:IMPedance on page 471

Trigger Input Slope
Sets the polarity of the active slope of an applied external trigger signal at the User 1
connector.
Remote command: 
[:SOURce]:INPut:USER:TRIGger:SLOPe on page 472

4.5.5  Routing signals to the connectors

This chapter provides step-by-step instructions to route control signals from input con-
nectors or to output connectors of these signals. It covers the following topics:
● "General workflow" on page 129
● "To map the signal to a connector" on page 129
● "To find out the input connector location" on page 130

General workflow

The table Table 4-5 shows the main configuration steps and related settings.
Table 4-5: Mapping signal to connector workflow

Workflow task Related settings

Checking the signal to connector mapping "Trigger Marker Clock"

"Global Connectors" > "Routing"

Configuring and enabling the control signal "Trigger In", "Marker" or "Clock" tabs of the base-
band signal dialog

Cabling the connector and the source or sink of the
control signal

-

To map the signal to a connector

To map the signal to the connector, proceed as follows:

1. Check the current connector configuration.

2. If necessary, change the signal direction and the signal type.

3. Configure the control signal, for example a trigger signal or a marker signal.
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4. Enable the control signal.

5. Connect a suitable external instrument or device to the connector of the control sig-
nal.

To find out the input connector location

Proceed as follows:

1. In the block diagram, select the "TM" block to open the "Trigger / Marker / Clock"
dialog.

2. For the corresponding connector, select the "Show Connector" icon.

The "Show Connectors" dialog opens and displays the location of the selected con-
nector on the front panel or rear panel of the instrument.

If enabled, the LED next to the connector is green or yellow, see Chapter 4.5.1.3, "Sta-
tus indicators", on page 123.

4.6  Reducing crest factors

Option R&S SFI-K548 is a software option that allows you to generate baseband sig-
nals with reduced crest factor.

R&S SFI-K548 key features

● Reduces crest factors of baseband signals by clipping the high signal peaks and
filtering the waveform afterwards.

● Reduces crest factors of waveform files played at the arbitrary waveform generator.
● Uses an iterative process to reach a desired crest factor delta.
● Provides simple and enhanced filtering:

– Simple filtering allows you to configure channel spacing and signal bandwidth.
– Enhanced filtering allows you to configure lowpass filter parameters stopband

frequency, passband frequency and maximum filter order.

4.6.1  About the crest factor reduction

Communication standards utilizing higher order modulation techniques or using multi-
ple carrier and complex signals consisting of the signals of more than one digital stan-
dard can feature a high crest factor. The signals of some digital standards can have
high crest factors also particularly with many channels and long sequences.

About crest factors

The crest factor represents the ratio of the peak voltage value to the RMS voltage
value, i.e. the peak to average ratio (PAR). The higher the crest factor and the resulting
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dynamics of a signal, the greater the requirement for a power amplifier fed by the sig-
nal to be linear.

A high crest factor arises, for example, for a multi carrier signal that has carriers with
an identical start phase. The carriers are periodically superposed that leads to high
peak voltages in relation to the RMS voltage values.

High crest factors entail two basic problems:
● The nonlinearity of the power amplifier (compression) causes intermodulation

which expands the spectrum (spectral regrowth).
● Since the level of the digital to analog (D/A) converter is relative to the maximum

value, the average value is converted with a relatively low resolution. This low res-
olution leads to a high quantization noise.

Both effects increase the adjacent-channel power.

Clipping and filtering algorithm

A common and simple approach for achieving a lower PAR is the combination of clip-
ping and filtering.
● Clipping is a technique that applies a wanted distortion to the signal.

The principle includes specifying a threshold, finding out the signal peaks once the
defined limits are exceeded and clipping them off. The level limit is specified as a
percentage of the highest peak value. Because clipping is done before filtering, the
procedure does not influence the spectrum. The error vector magnitude (EVM)
however increases.
However, signal clipping not only changes the peak value but also the average
value and the effect on the crest factor is unpredictable.

● Filtering is applied after clipping. The used filters are specially designed so that
they filter out the distortion.

Peak cancellation algorithm

The peak cancellation algorithm uses Blackman windowed sinc pulses and subtracts
them from the original baseband signal wherever the signal amplitude exceeds a
defined threshold. This threshold equals maximum peak of the baseband signal minus
a user-definable crest factor difference ("Desired Crest Factor Delta").

This algorithm often provides better EVM results of the output signal versus out of
band noise introduced by the pulses, compared to the clipping and filtering method.
The cancellation pulse bandwidth is configurable and the cancellation pulse transition
bandwidth. The achieved resulting crest factor can be higher than expected, because
of filters in the signal processing chain increasing the crest factor again after a previous
crest factor reduction.

Reducing crest factors
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4.6.2  Crest factor reduction settings

Access:

► Select "Baseband" > "ARB" > "Crest Factor Reduction".

The dialog provides settings to configure and enable crest factor reduction.

Enabling crest factor reduction

Crest factor reduction requires an enabled "ARB" state and a valid waveform file loa-
ded to the ARB application.

1. Load a waveform file.

a) Select "ARB" > "General" > "Load Waveform".
b) In the file-select dialog, select the waveform file from the directory.

See also chapter "Loading and playing waveform files" in the R&S SFI100A user
manual.

2. Select "General" > "State" > "On".

3. Select "Crest Factor Reduction" > "State" > "On".

The remote commands required to define these settings are described in Chap-
ter 13.16.2.9, "Crest factor reduction commands", on page 563.

Settings:

State............................................................................................................................133
Generate Waveform....................................................................................................133
Algorithm..................................................................................................................... 133
Desired Crest Factor Delta..........................................................................................133
Max Iterations..............................................................................................................133
Original Crest Factor................................................................................................... 134
Resulting Crest Factor................................................................................................ 134
Filter Mode.................................................................................................................. 134
Channel Spacing.........................................................................................................135

Reducing crest factors
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Signal Bandwidth........................................................................................................ 135
Stopband Frequency...................................................................................................135
Passband Frequency.................................................................................................. 135
Maximum Filter Order................................................................................................. 136
Cancellation Pulse Bandwidth.....................................................................................136
Transition Bandwidth...................................................................................................136

State
Requires an active "ARB" state, see "Enabling crest factor reduction" on page 132.
Activates crest factor reduction calculation.
Note: You cannot activate the crest factor reduction and the notch filter simultaneously.
Enabling the notched filter automatically disables the crest factor reduction.
Remote command: 
[:SOURce<hw>]:BB:ARBitrary:CFR[:STATe] on page 565

Generate Waveform
With enabled signal generation, triggers the instrument to save the current settings of
an arbitrary waveform signal in a waveform file with predefined extension *.wv. You
can define the filename and the directory, in that you want to save the file.
Using the ARB modulation source, you can play back waveform files and/or process
the file to generate multi-carrier or multi-segment signals.
Remote command: 
[:SOURce<hw>]:BB:ARBitrary:CFR:WAVeform:CREate on page 569

Algorithm
Defines the algorithm for crest factor reduction.
"Clipping and Filtering"

This algorithm performs a hard clipping. It is followed by a lowpass fil-
tering of the result in an iterative manner until the target crest factor is
reached. You can define the settings of the filter that is used for the
calculation.

"Peak Cancelation"
This algorithm subtracts Blackman windowed sinc pulses from the
signal wherever the amplitude is above a defined threshold.

Remote command: 
[:SOURce<hw>]:BB:ARBitrary:CFR:ALGorithm on page 565

Desired Crest Factor Delta
Sets the value difference by which you want to change your crest factor.
Remote command: 
[:SOURce<hw>]:BB:ARBitrary:CFR:DCFDelta on page 566

Max Iterations
Requires "Algorithm" > "Clipping and Filtering".
Sets the number of iterations that are used for calculating the resulting crest factor. The
iteration process is stopped when the desired crest factor delta is achieved by 0.1 dB.

Reducing crest factors
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Remote command: 
[:SOURce<hw>]:BB:ARBitrary:CFR:ITERations on page 567

Original Crest Factor
Displays the original crest factor of the waveform after the calculation of the resulting
crest factor is completed. The original crest factor is calculated as an average over the
whole waveform, including any idle periods that can be present in TDD waveforms.
Remote command: 
[:SOURce<hw>]:BB:ARBitrary:CFR:OCFactor? on page 567

Resulting Crest Factor
Displays the resulting crest factor of the waveform after the calculations are completed.
The resulting crest factor is calculated as an average over the whole waveform, includ-
ing any idle periods that can be present in TDD waveforms.
Remote command: 
[:SOURce<hw>]:BB:ARBitrary:CFR:RCFactor? on page 568

Filter Mode
Requires "Algorithm" > "Clipping and Filtering".
Selects which filter mode is used for the filtering.
"Simple" You can specify the RF bandwidth and channel spacing of the signal.

The lowpass filter is designed to pass through frequency components
inside the signal bandwidth and suppress components in the adjacent
channel.

Figure 4-17: Simple filter mode

Reducing crest factors
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"Enhanced" In the enhanced filter mode, you can specify the passband and stop-
band frequencies of the lowpass filter.

Figure 4-18: Enhanced filter mode

Remote command: 
[:SOURce<hw>]:BB:ARBitrary:CFR:FILTer on page 566

Channel Spacing
Requires "Algorithm" > "Clipping and Filtering" and "Filter Mode" > "Simple".
Sets the channel spacing.
Remote command: 
[:SOURce<hw>]:BB:ARBitrary:CFR:CSPacing on page 566

Signal Bandwidth
Requires "Algorithm" > "Clipping and Filtering" and "Filter Mode" > "Simple".
Sets the signal bandwidth. Set a value that is lower than the value of the "Channel
Spacing".
Remote command: 
[:SOURce<hw>]:BB:ARBitrary:CFR:SBANdwidth on page 568

Stopband Frequency
Requires "Algorithm" > "Clipping and Filtering" and "Filter Mode" > "Enhanced".
Sets the stopband frequency of the filter. Frequency components higher than the stop-
band frequency are filtered out by the lowpass filter.
Remote command: 
[:SOURce<hw>]:BB:ARBitrary:CFR:SFReq on page 569

Passband Frequency
Requires "Algorithm" > "Clipping and Filtering" and "Filter Mode" > "Enhanced".
Sets the passband frequency. Frequency components lower than the passband fre-
quency are passed through unfiltered.
Remote command: 
[:SOURce<hw>]:BB:ARBitrary:CFR:PFReq on page 568

Reducing crest factors
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Maximum Filter Order
Requires "Algorithm" > "Clipping and Filtering" and "Filter Mode" > "Enhanced".
Sets the maximum filter order.
Remote command: 
[:SOURce<hw>]:BB:ARBitrary:CFR:FORDer on page 566

Cancellation Pulse Bandwidth
Requires "Algorithm" > "Peak Cancellation".
Sets the bandwidth of the cancellation pulse.
Remote command: 
[:SOURce<hw>]:BB:ARBitrary:CFR:CPBandwidth on page 565

Transition Bandwidth
Requires "Algorithm" > "Peak Cancellation".
Sets the transition bandwidth of the cancellation pulse.
Remote command: 
[:SOURce<hw>]:BB:ARBitrary:CFR:TBANdwidth on page 569

4.7  Shifting the baseband signal

The R&S SFI100A provides settings to apply a frequency offset or a phase offset to the
baseband signal.

4.7.1  About baseband offsets

The applied baseband frequency offset and phase offset affect the signal on the output
of the "Baseband" block. The shifting of the central frequency of the baseband signal is
one of the tasks of the resampler.

4.7.1.1  Impact of the frequency offset

For some applications, it is helpful to shift the baseband signal with a user-defined
baseband frequency offset to a different center frequency to improve signal character-
istics.

The frequency-offset function shifts the center frequency of the wanted baseband sig-
nal. The function also provides a quick way to shift the used frequency band in the RF
frequency domain without modifying the RF settings.

See Chapter 4.7.3, "Improving signal characteristics by shifting the baseband signal",
on page 139.

Shifting the baseband signal
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Limitations

The complex I/Q bandwidth of the shifted signal cannot exceed the total available
baseband bandwidth. The setting range of the frequency offset is then calculated as
follows:

-(TotalBasebandBandwidth/2) + fuse/2 ≤ foffset ≤ (TotalBasebandBandwidth/2) - fuse/2,
where the following applies:

fuse is the complex useful bandwidth of the I/Q signal before the offset

foffset is the frequency offset

The Figure 4-19 illustrates the setting range of the frequency offset.

Figure 4-19: Setting range of frequency offset

For more information, refer to the specifications document.

To observe the effect of offsetting the frequency

Use the built-in real-time graphical display. Select "System Config" > "Graphics" >
"Power Spectrum" and observe the power spectrum of the signal with and without fre-
quency offset.

4.7.1.2  Impact of the phase offset

The "Phase Offset" determines the phase offset between the different baseband sig-
nals. A phase offset rotates each point of an I/Q constellation diagram by the specified
phase offset.

Shifting the baseband signal
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Figure 4-20: I/Q constellation diagram: Effect after offsetting the phase by an angle of 45 °

To observe the effect of offsetting the phase

Use the built-in real-time graphical display. Select "System Config" > "Graphics" >
"Constellation" and observe that the points on the I/Q constellation diagram are turning
counterclockwise.

4.7.2  Baseband offset settings

Access:

► Select "Baseband" > "Baseband Offsets".

The "Baseband Offsets" dialog provides settings to offset the frequency or phase of
the baseband signal.

The block diagram shows an icon Δf on the signal path. This icon indicates an enabled
frequency offset.

Settings:

Frequency Offset
Sets the frequency offset of the baseband signal and shifts the useful baseband signal
in the center frequency.
Use this function, for example, to shift the baseband signal relative to an AWGN signal.

Shifting the baseband signal
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See also the following sections:
● Chapter 4.7.3, "Improving signal characteristics by shifting the baseband signal",

on page 139
● Chapter 4.7.3, "Improving signal characteristics by shifting the baseband signal",

on page 139
Remote command: 
[:SOURce<hw>]:BB:FOFFset on page 529

Phase Offset
Sets the phase offset for a baseband signal. This phase offset affects the signal after
the "Baseband" block.
Use this parameter, for example, to change the start phase of the baseband signal.
See also Chapter 4.7.1.2, "Impact of the phase offset", on page 137.
Remote command: 
[:SOURce<hw>]:BB:POFFset on page 530

4.7.3  Improving signal characteristics by shifting the baseband signal

Shifting of the generated baseband signal is useful in the following cases:
● You analyze the generated signal with a signal analyzer and the displayed signal

spectrum indicates a carrier leakage (a signal drop) at the current RF frequency.

Shifting the baseband signal to a different center frequency can eliminate the car-
rier leakage problem.

In the following examples, we assume that:
● The R&S SFI100A generates a baseband signal
● A spectrum analyzer is connected to the R&S SFI100A, the analyzed is configured

and measures the required signal characteristics.

To shift the generated baseband signal

1. Select "Baseband" > "Baseband Offsets".

2. To apply an offset to the baseband signal, select for example "Frequency Offset" =
"10 MHz".

To verify characteristics of the generated signal

► Use the built-in real-time graphical display.

Shifting the baseband signal
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To observe the effect of applied frequency offset and gain

► Use the built-in real-time graphical display.

Shifting the baseband signal
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5  Signal routing and system configuration
The settings in this dialog comprise the I/Q stream mapping and the processing of the
generated I/Q streams. Form this dialog, you can control and configure the connec-
tions to external instruments connected to the RF connector.

Prerequisites for connections to external instruments

Connecting external instruments to the R&S SFI100A requires the following signals
and connections.

Signal Interface Remark

Control LAN or USB The control connection is enabled.

Input

Output

Analog I/Q or digital I/Q

Analog I/Q, digital I/Q or RF

The physical input signal or output signal is present
at the interface.

Reference Reference input or output The external instrument and the R&S SFI100A have
a common reference frequency signal.

Required options

The signal routing settings and system configuraton settings require a base unit config-
uration, see "Base unit" on page 32.

Settings:

● I/Q stream mapper settings...................................................................................141
● External RF settings..............................................................................................142
● External instrument settings..................................................................................146
● Overview............................................................................................................... 149

5.1  I/Q stream mapper settings

Access:

► In the block diagram, select "I/Q Stream Mapper".

The dialog provides the settings for routing of the signal streams to the available
output connectors.

I/Q stream mapper settings
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Settings:

Frequency Offset.........................................................................................................142
Phase Offset................................................................................................................142
Map stream x to connector..........................................................................................142

Frequency Offset
Sets an absolute frequency offset foffset.

Tip: Use this parameter to shift the used frequency band in the RF frequency section
without modifying the RF settings.
Remote command: 
:SCONfiguration:OUTPut:MAPPing:STReam<st>:FOFFset on page 462

Phase Offset
Sets the phase offset of the corresponding stream.
Remote command: 
:SCONfiguration:OUTPut:MAPPing:STReam<st>:POFFset on page 462

Map stream x to connector
The mapping of the generated stream to the output connectors is represented as a
stream matrix. A blue circle at a matrix element routes the stream to the selected con-
nector.
Remote command: 
:SCONfiguration:OUTPut:MAPPing:RF:STReam<st>:STATe on page 461

5.2  External RF settings

Access:

► On the taskbar, select "System Config" > "System Configuration" > "External RF".

External RF settings
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The tab provides settings to configure and establish the connection to external RF
instruments. an overview of all available RF input and output connectors and com-
prises the settings necessary to establish the connection to the external instru-
ments.
Displayed is an overview of the currently connected external instruments together
with relevant information like the connection status and the RF level and frequency
that these external instruments use.

For step-by-step instructions to connect and control external frontends, see Chap-
ter 7.1.2, "Operating external frontends", on page 179.

Settings:

Display........................................................................................................................ 143
Auto Connect.............................................................................................................. 143
Connect/Disconnect All Remote................................................................................. 144
Preset behavior: Keep connections to external instruments....................................... 144
Connector Name......................................................................................................... 144
Direction...................................................................................................................... 144
External Instrument..................................................................................................... 145
I/Q Conn......................................................................................................................145
Rem Conn................................................................................................................... 145
Instrument Name.........................................................................................................146
RF Coup......................................................................................................................146
(Delta) RF Frequency/ RF Level................................................................................. 146
RF State...................................................................................................................... 146

Display
Filters the displayed connectors upon one of the following criteria:
"All Connectors"

Displays all available connectors. No filter is applied.
"Mapped Connectors"

Displays the connectors to which a stream is mapped.
See "Map stream x to connector" on page 142.
Note: To prevent faults, use this filter before you further configure the
external instruments.

"Input Connectors/Output Connectors"
Displays the connectors according to connector direction.

Remote command: 
:SCONfiguration:EXTernal:DISPlay on page 463

Auto Connect
"Auto Connect > On": The instrument automatically detects connected external instru-
ments and establishes the required connection.
"Auto Connect > Off": After a R&S SFI100A startup you have to revise the test setup
and perform the following:
● Check whether the necessary connections between the R&S SFI100A and the

external instruments are still existing.

External RF settings
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● Prove that the remote control of the particular instruments is required.
● Trigger the "Connect All Remote" function.
Remote command: 
:SCONfiguration:EXTernal:ACONnect on page 463

Connect/Disconnect All Remote
Triggers the instrument to:
● Establish the remote connections to all configured external instruments.
● Terminate all existing remote connections.

The external instruments are not removed from the list of external instruments.
Only the remote connection status changes.

You can toggle the remote connection status with the parameter "Rem Conn".
Note:
External instruments connected to the R&S SFI100A are preset (:DEVice:PRESet)
whenever:
● The connection to the external instrument is established or terminated ("Connect/

Disconnect All Remote" or "Rem. Conn > On/Off")
● The R&S SFI100A is preset ([Preset]).
To ensure that the remote connections to the external instruments will be automatically
established after instrument's start-up or a reboot, enable "Auto Connect > On".
Remote command: 
:SCONfiguration:EXTernal:REMote:CONNect[:ALL] on page 463
:SCONfiguration:EXTernal:REMote:DISConnect[:ALL] on page 463

Preset behavior: Keep connections to external instruments
Sets the effect of R&S SFI100A preset ([Preset] or *RST) on the following:
● The connection status between the instrument and the connected external instru-

ments.
● The connected instruments.

"Preset behavior..." Off On

R&S SFI100A and preset val-
ues

Standard R&S SFI100A preset

See Table 10-1.

Depends on the connected external frontend:
● RF "Frequency"

– R&S FE170ST: 110 GHz
– R&S FE110ST: 75 GHz

● RF "Level" = -30 dBm
● "RF > Off"

Connection status Terminated ("Disconnect All Remote") Unchanged

Connected instruments External instrument preset (:DEVice:PRESet) External instrument preset

Remote command: 
:SCONfiguration:EXTernal:PBEHaviour on page 463

Connector Name
Displays the connector name.

Direction
Displays the connector direction as a color coded field.

External RF settings
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The color is determined by the configuration in the "I/Q Stream Mapping" dialog.

Connector Direction/Color Enabled in the "I/Q Stream Mapping"

RF Yes

 -

Remote command: 
:SCONfiguration:EXTernal:RF<ch>:DIRection? on page 464

External Instrument
Opens a dialog with settings to establish the connection to the external instrument for
the selected signal path.
See Chapter 5.3, "External instrument settings", on page 146.
See also "Prerequisites for connections to external instruments" on page 141.

I/Q Conn
Not applicable for R&S SFI100A.
Remote command: 
n.a.

Rem Conn
Indicates the status of the remote connection. Click the status indicator to toggle the
remote connection status.
To connect or disconnect all external instruments, use the functions "Connect All
Remote" or "Disconnect All Remote".
Note:
External instruments connected to the R&S SFI100A are preset (:DEVice:PRESet)
whenever:
● The connection to the external instrument is established or terminated ("Connect/

Disconnect All Remote" or "Rem. Conn > On/Off")
● The R&S SFI100A is preset ([Preset]).
Note: An active "Rem. Conn." and an "RF State > On" do not mean that an I/Q stream
is mapped to this connector.
Use the "System Configuration" > "External RF and I/Q" > "Display" > "Mapped Con-
nectors" filter to list only the connectors with a mapped I/Q stream.
See also "Prerequisites for connections to external instruments" on page 141.
Remote command: 
:SCONfiguration:EXTernal:RF<ch>:RCONnection:STATe? on page 464
:SCONfiguration:EXTernal:RF<ch>:REMote:DISConnect on page 467
:SCONfiguration:EXTernal:RF<ch>:REMote:INFO? on page 466

External RF settings
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Instrument Name
Displays useful information on the connected external instrument, like the instrument
designation and the RF path the RF settings are coupled to.
See also "Prerequisites for connections to external instruments" on page 141.
Remote command: 
:SCONfiguration:EXTernal:RF<ch>:INAMe? on page 464
:SCONfiguration:EXTernal:RF<ch>:REMote:INFO? on page 466

RF Coup
Not applicable for R&S SFI100A.
Remote command: 
n/a

(Delta) RF Frequency/ RF Level
Not applicable for R&S SFI100A.
Remote command: 
n/a

RF State
Displays the RF output state of the R&S SFI100A.
Remote command: 
:SCONfiguration:EXTernal:RF<ch>:RF:STATe on page 464

5.3  External instrument settings

Access:

1. In the taskbar, select "System Config" > "System Configuration".

2. Select "External RF" > "External Instrument" > "Config...".

The dialog provides settings to configure the connection to the external instrument
and to control to the external instrument. Also you can find out the related connec-
tor at the R&S SFI100A.

Settings:

● Remote Instrument settings.................................................................................. 146
● Show connector.................................................................................................... 149

5.3.1  Remote Instrument settings

Access:

1. Select "External Instrument" > "Config...".

External instrument settings
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2. Select "Remote Instrument".

Settings:

Scan............................................................................................................................ 147
Clean Unused/Clean All.............................................................................................. 147
External Instrument..................................................................................................... 147
Set Symbolic Name.....................................................................................................147
Remote Channel......................................................................................................... 148
Hostname or IP Address............................................................................................. 148
Device ID.....................................................................................................................148
Apply........................................................................................................................... 148
Apply and Connect......................................................................................................148
Frontend Configuration............................................................................................... 149

Scan
Not applicable for R&S SFI100A.
Remote command: 
n/a

Clean Unused/Clean All
Removes partly or fully the configuration of external instruments the R&S SFI100A
controls via the LAN interface.
"Clean Unused"

Removes external instrument configurations from unused LAN con-
nections. The configurations for used LAN connections remain.
These connections are the enabled and configured control connec-
tions. Also, this function allows you to update the external instruments
list for a new pool of valid instruments.
Remote command: 
:SCONfiguration:EXTernal:REMote:PURGe on page 467

"Clean All" Disconnects and removes all connections of configured external
instruments. Also removes all instruments from the list of external
instruments.
Remote command: 
:SCONfiguration:EXTernal:REMote:CLEan on page 468

External Instrument
Lists all available instruments, found by the "Scan" function.
See also "To configure the R&S SFI100A for frontend control" on page 37.
Remote command: 
:SCONfiguration:EXTernal:REMote:LIST? on page 465
:SCONfiguration:EXTernal:REMote:ADD on page 465
:SCONfiguration:EXTernal:RF<ch>:REMote:ISELect on page 466

Set Symbolic Name
Sets the alias name of the instrument.

External instrument settings
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Remote command: 
:SCONfiguration:EXTernal:REMote:ADD on page 465
:SCONfiguration:EXTernal:RF<ch>:REMote:INFO? on page 466

Remote Channel
Displays or selects the remote or hardware channel for control of the external instru-
ment.
"Frontend Connection"

Fixed remote channel for control of external frontends via the LAN
interface.

Remote command: 
:SCONfiguration:EXTernal:REMote:ADD on page 465
:SCONfiguration:EXTernal:RF<ch>:REMote:INFO? on page 466

Hostname or IP Address
Displays or sets the hostname or IP address of the connected external instrument.
See also "Prerequisites for connections to external instruments" on page 141.
Remote command: 
:SCONfiguration:EXTernal:REMote:ADD on page 465
:SCONfiguration:EXTernal:RF<ch>:REMote:INFO? on page 466

Device ID
Sets/displays the device identifier that is a unique string with the following structure:
<frontend type>-<serial number>
For a defined "External Instrument", the information is read out automatically.
Remote command: 
:SCONfiguration:EXTernal:REMote:ADD on page 465
:SCONfiguration:EXTernal:RF<ch>:REMote:INFO? on page 466

Apply
Confirms the settings and displays the external instrument in the "External RF" dialog.
Also, connection is established for a short period of time to retrieve identification data
from the external instrument.
Remote command: 
:SCONfiguration:EXTernal:RF<ch>:REMote:ISELect on page 466

Apply and Connect
Confirms the settings and triggers the connection establishment. In the connected
instruments, the status of this active remote connection is displayed by the "Remote"
indication.
Remote command: 
:SCONfiguration:EXTernal:RF<ch>:REMote:ISELect on page 466
:SCONfiguration:EXTernal:RF<ch>:REMote:ICONnect on page 466

External instrument settings
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Frontend Configuration
Accesses the "RF Frontend" dialog to configure settings of the connected external
frontend.
See Chapter 7.1.3, "RF frontend settings", on page 185.

5.3.2  Show connector

Access:

1. Select "Taskbar > System Config > System Configuration > External RF".

2. Navigate to the required connector.
Select "External Instruments > Config ...".

3. Select the "Show Connector" tab.

The dialog displays the location of the selected connector.
The "Show Connector" function triggers the instrument to identify the connector on
the rear panel.

5.4  Overview

You can check current connections, interfaces, input signals and output signals of the
R&S SFI100A in the "Overview" tab.

Access:

► Select "System Configuration" > "Overview".

The overview tab shows information on the following:
● Input signals and output signals: Type (RF, reference, I/Q) and state (active,

inactive)

Overview
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● Input and output interfaces
● Current stream mapping to the output interfaces.

See Chapter 5.1, "I/Q stream mapper settings", on page 141.
● Connected controller ("System Controller") and connection ("SCPI").

See Chapter 5.2, "External RF settings", on page 142.
● Connections for remote control of connected external devices

Hotspots for fast access to the required settings

Several of the displayed elements are hotspots, for example the "A" on the green back-
ground. Select an element to access the related dialog.

Overview
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6  Applying I/Q vector modulation
The R&S SFI100A offers I/Q modulation with the internally generated digital signal.
You can add digital impairments to this internal signal before the I/Q modulator. Also,
you can correct the frequency response of the I/Q modulation signal.

Required options

The equipment layout for I/Q modulation includes the base unit with the frequency
option R&S SFI-B1016.

Impairing I/Q samples

For a description on applying digital impairments, see Chapter 6.4, "Impairing the sig-
nal", on page 156.

Correcting the frequency response

For a description on correcting the frequency response, see Chapter 6.5, "Correcting
the frequency response", on page 161.

● About the I/Q modulator........................................................................................151
● I/Q modulator settings...........................................................................................151
● Optimizing I/Q modulation performance................................................................154
● Impairing the signal...............................................................................................156
● Correcting the frequency response.......................................................................161

6.1  About the I/Q modulator

The R&S SFI100A offers I/Q modulation with internal baseband signals.

Input signal of the I/Q modulator

The input signal for the I/Q modulator is the internal baseband signal.
Table 6-1: Physical input signals of the I/Q modulator

Input signal GUI parameter

Internal baseband signal "Baseband" > "On"

6.2  I/Q modulator settings

Access:

► Select "I/Q Mod" > "I/Q Settings" > "I/Q Modulator".

I/Q modulator settings
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The "I/Q Modulator" dialog opens.

The dialog provides the I/Q modulator settings and settings for applying digital
impairments.

The remote commands required to define these settings are described in Chap-
ter 13.15.6, "SOURce:IQ subsystem", on page 493.

For a description on applying digital impairments and correcting the frequency
response, see the following sections:
● Chapter 6.4, "Impairing the signal", on page 156
● Chapter 6.5, "Correcting the frequency response", on page 161

Settings:

State............................................................................................................................152
Source.........................................................................................................................153
Baseband Gain........................................................................................................... 153
Optimization Mode...................................................................................................... 153
Optimize EVM............................................................................................................. 154

State
Enables I/Q modulation.

I/Q modulator settings
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If you use the internal baseband signal as the input signal and enable baseband signal
generation, the I/Q modulator is enabled automatically. You can disable I/Q modulation,
for example, if you want to route the baseband signal directly to the I/Q output connec-
tors.
Remote command: 
[:SOURce<hw>]:IQ:STATe on page 494

Source
Selects the input signal for the I/Q modulator.
"Internal Baseband"

Selects the internal baseband signal.
Remote command: 
[:SOURce<hw>]:IQ:SOURce on page 493

Baseband Gain
Sets the baseband gain for a wide dynamic range.
You can attenuate this level (negative gain) to optimize the I/Q modulation perfor-
mance. The optimization is a trade-off between signal distortion and signal-to-noise
ratio (SNR).
"-12 dB"/"-9 dB"/"-6 dB"/"-3 dB"

Attenuates the baseband signal internally to minimize signal distor-
tions and optimize the intermodulation characteristics of the modula-
ted signal. But the SNR decreases, the signal noise increases.

"0 dB"
No changes on the baseband signal, applies no optimization.

"Auto" The R&S SFI100A automatically sets an optimized gain value. The
configured sample rate, the crest factor and the PEP value of the
modulated signal affect this gain value.

Remote command: 
[:SOURce<hw>]:BB:IQGain on page 494

Optimization Mode
Selects the optimization mode for I/Q modulation of the internal baseband signal.
How to: Chapter 6.3, "Optimizing I/Q modulation performance", on page 154
If equipped with option R&S SFI-K544, the optimization mode applies for the I/Q modu-
lation performance and for the user-defined frequency response corrections.
See the user manual "R&S SFI-K544 User-Defined Frequency Response Correction".
For more information, refer to the specifications document.
"High Quality Table"

This mode further improves the frequency response while maintaining
setting time. There is no signal interruption. Select this mode in set-
ups to generate phase coherent signals with an RF modulation band-
width of up to 10 GHz.

"Fast" Fast optimization by compensating for I/Q skew. This mode is suita-
ble in time sensitive environments and for narrowband signals.

I/Q modulator settings
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Remote command: 
[:SOURce<hw>]:BB:IMPairment:OPTimization:MODE on page 576

Optimize EVM
Enables further optimization of the EVM performance of I/Q modulated RF signals.
Enable "Optimize EVM", if your test setup requires the lowest EVM values. For exam-
ple, if you need to generate 5G NR signals, LTE signals or IEEE 802.11 signals that
require optimized EVM performance.
How to: "To optimize the EVM value" on page 155
Remote command: 
[:SOURce<hw>]:CORRection:OPTimize:EVM on page 478

6.3  Optimizing I/Q modulation performance

The following step-by-step instructions help you to execute general I/Q modulation
tasks with dedicated I/Q modulator settings:
● "To apply predefined frequency response correction" on page 154
● "To improve RF signal flatness" on page 154
● "To optimize the EVM value" on page 155

To apply predefined frequency response correction

For RF signals with larger I/Q modulation bandwidth, the R&S SFI100A provides a pre-
defined frequency response correction. This correction helps you to improve the signal
flatness of the RF signal over the whole I/Q modulation bandwidth.

The R&S SFI100A provides the optimization mode "High Quality Table" for I/Q modula-
tion. To improve signal quality, this mode features the following:
● Frequency response correction for larger modulation bandwidth signals
● Correction of internally generated baseband signals by predefined correction val-

ues
● Absolute level correction at center frequency
● Correction in real time, no signal interruption

To improve RF signal flatness

In the following step-by-step instruction, we assume that:
● The R&S SFI100A generates an RF signal. The I/Q modulator modulates a base-

band signal onto the RF carrier.
● A spectrum analyzer is connected to the R&S SFI100A. The analyzer is configured

and measures the required signal characteristics.

In the following step-by-step instruction, we assume that you configured signal param-
eters of your baseband signal and RF signal. Also,

1. In the block diagram, enable baseband and RF signal generation:

Optimizing I/Q modulation performance
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a) "Baseband" > "On".
b) Select "RF" > "On"

2. Select "I/Q Mod" > "On".

The I/Q modulator is enabled and modulates the internal baseband signal onto the
RF carrier.

3. Select "I/Q Mod" > "I/Q Mod" > "I/Q Modulator".
The general settings dialog of the I/Q modulator opens. By default, the
R&S SFI100A uses fast optimized I/Q modulation ("Optimization Mode" > "Fast") to
compensate for I/Q skew.

4. Select "Optimization Mode" > "High Quality Table".

The R&S SFI100A uses predefined values from the instrument calibration to cor-
rect the frequency response. This correction results in a flat signal over the whole
I/Q modulation bandwidth.

5. On a connected signal analyzer, monitor the signal characteristics.

To optimize the EVM value

Use the function "Optimize EVM", if your test setup requires the lowest EVM values.
For example, if you need to generate 5G NR signals, LTE signals or IEEE 802.11 sig-
nals that require optimized EVM performance.

1. Select "I/Q Mod" > "I/Q Mod" > "I/Q Modulator".

2. Select "Optimize EVM" > "On".

If enabled, the frequency section of the status bar displays the enabled EVM opti-
mization state as in Figure 6-1.

Optimizing I/Q modulation performance
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Figure 6-1: Optimize EVM enabled

3. Select "I/Q Mod" > "On".

4. Select "RF" > "On".

5. On a connected signal analyzer, monitor the signal characteristics.

6.4  Impairing the signal

In the R&S SFI100A, you can add digital linear impairments to the signal, for example
an I/Q imbalance and a quadrature error.

6.4.1  Required options

The base unit is sufficient for impairing I/Q signals. Impairing these signals does not
require additional options.

6.4.2  About the digital I/Q impairments

I/Q signal impairments are well-defined arithmetic modifications of the data. The
impairment method is to modify every data sample in the same way by impairing the
I/Q samples linearly.

These linear impairments simulate frequent sources of distortions in a real signal pro-
cessing chain. Add impairments, for example, to simulate dirty transmitter conditions
for receiver tests.

I/Q streams

The R&S SFI100A offers to impair the internal I/Q signal, the baseband signal for the
following I/Q streams:
● Impair I/Q samples before the I/Q modulator
● Impair I/Q samples to the analog I/Q output signal

I/Q impairments

● Gain and gain imbalance...................................................................................... 157
● I and Q offset.........................................................................................................157
● Quadrature offset.................................................................................................. 158
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6.4.2.1  Gain and gain imbalance

An I/Q gain is a multiplication of all I/Q amplitudes by a common factor. The effect is
equivalent to two identical I and Q gain factors. The effect of an increased gain factor
in the I/Q constellation diagram is shown on Figure 6-2.

Figure 6-2: Effect of an increased amplitude in the I/Q constellation diagram

An I gain multiplies the I amplitudes by a factor, leaving the Q amplitudes unchanged.
A Q gain has the opposite effect. Different I and Q gain factors result in an I/Q imbal-
ance, which is due to different gains of the amplifiers in the I and Q channels of the I/Q
modulator. The effect of a positive and negative gain imbalance is shown on Fig-
ure 6-3.

Figure 6-3: Negative gain imbalance (left) and positive gain imbalance (right) in the I/Q constellation
diagram

6.4.2.2  I and Q offset

An I offset adds a constant value to all I amplitudes, leaving the Q amplitudes
unchanged. A Q offset has the opposite effect. A combination of I and Q values results
in an I/Q offset, which is due to carrier feedthrough in the I/Q modulator. Possible rea-
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sons are interfering signals at the RF carrier frequency, e.g. an unsuppressed RF car-
rier subchannel. The effect of a positive I and Q offset in the I/Q constellation diagram
is shown on Figure 6-4.

Figure 6-4: I offset (left) and Q offset (right) in the I/Q constellation diagram

6.4.2.3  Quadrature offset

Changes the phase angle between the I and the Q vectors from the ideal 90 degrees,
while the amplitudes are maintained. A positive quadrature offset results in a phase
angle greater than 90 degrees. The effect of a positive quadrature offset in the I/Q con-
stellation diagram is shown on Figure 6-5.

Figure 6-5: Positive quadrature offset in the I/Q constellation diagram

6.4.3  Digital impairments settings

You can add digital impairments to each internal generated I/Q stream.

See also Chapter 6.4.2, "About the digital I/Q impairments", on page 156.
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Access:

► Select "I/Q Mod" > "I/Q Settings" > "Digital Impairments".

The tab provides settings for I/Q impairment, like leakage, imbalance and offset.

The remote commands required to define these settings are described in Chap-
ter 13.16.4, "SOURce:BB:IMPairment subsystem", on page 572.

Settings:

State............................................................................................................................159
I Offset/Q Offset.......................................................................................................... 159
Gain Imbalance........................................................................................................... 160
Quadrature Offset........................................................................................................160
Skew........................................................................................................................... 160
IQ Delay...................................................................................................................... 160
Phase Offset................................................................................................................160

State
Enables the impairment of the I/Q signal.
If enabled, the settings for the I/Q offset, the I/Q imbalance and the quadrature offset
become effective.
Remote command: 
[:SOURce]:BB:IMPairment:RF<ch>:STATe on page 573
[:SOURce]:BB:IMPairment:IQOutput<ch>:STATe on page 573

I Offset/Q Offset
Sets a carrier offset (in percent) of the amplitudes (scaled to the peak envelope power
(PEP)) for the I and/or Q signal component. An ideal I/Q modulator suppresses the car-
rier offset completely (offset = 0 percent).
For more information, see Chapter 6.4.2.2, "I and Q offset", on page 157.
Remote command: 
[:SOURce]:BB:IMPairment:RF<ch>:LEAKage:I on page 575
[:SOURce]:BB:IMPairment:RF<ch>:LEAKage:Q on page 575
[:SOURce]:BB:IMPairment:IQOutput<ch>:LEAKage:I on page 575
[:SOURce]:BB:IMPairment:IQOutput<ch>:LEAKage:Q on page 575
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Gain Imbalance
Sets the imbalance of the I and Q vector.
The entry is made in dB (default) or %, where 1 dB offset is roughly 12% according to
the following:
Imbalance [dB] = 20log ( | GainQ | / | GainI |)

Positive values mean that the Q vector is amplified more than the I vector by the corre-
sponding percentage. Negative values have the opposite effect.
For more information, see Chapter 6.4.2.1, "Gain and gain imbalance", on page 157.
Remote command: 
[:SOURce]:BB:IMPairment:RF<ch>:IQRatio[:MAGNitude] on page 574
[:SOURce]:BB:IMPairment:IQOutput<ch>:IQRatio[:MAGNitude]
on page 574

Quadrature Offset
Sets the quadrature offset.
For more information, see Chapter 6.4.2.3, "Quadrature offset", on page 158.
Remote command: 
[:SOURce]:BB:IMPairment:RF<ch>:QUADrature[:ANGLe] on page 575
[:SOURce]:BB:IMPairment:IQOutput<ch>:QUADrature[:ANGLe]
on page 575

Skew
Sets the delay between the Q vector and the I vector of the corresponding signal
stream.
Set this delay in the I/Q modulator or at the I/Q analog output.
Remote command: 
[:SOURce]:BB:IMPairment:RF<ch>:SKEW on page 575
[:SOURce]:BB:IMPairment:IQOutput<ch>:SKEW on page 575

IQ Delay
Sets or displays the time delay of both I and Q vectors relative to the selected trigger
and marker. A positive value means that the I and Q vectors delay relative to the
marker or trigger. A negative delay implies the other way around.
Set this time delay in the I/Q modulator or at the I/Q analog output.
Remote command: 
[:SOURce]:BB:IMPairment:RF<ch>:DELay on page 574
[:SOURce]:BB:IMPairment:IQOutput<ch>:DELay on page 574

Phase Offset
Adds a phase offset after the stream mapper.
You can shift the signal phase at the different stages in the signal generation flow:
● For "Baseband Offsets" > "Phase Offset", see "Phase Offset" on page 139.
● For "I/Q Stream Mapper" > "Phase Offset", see "Phase Offset" on page 142.
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Remote command: 
[:SOURce]:BB:IMPairment:RF<ch>:POFFset on page 576
[:SOURce]:BB:IMPairment:IQOutput<ch>:POFFset on page 576

6.5  Correcting the frequency response

● About frequency response correction................................................................... 161
● Applying user-defined FRC...................................................................................165
● User-defined FRC configuration and settings....................................................... 169

6.5.1  About frequency response correction

The I/Q modulation frequency response or the I/Q flatness is an important signal qual-
ity parameter for any vector signal generator, in particular when signals with large
bandwidth are generated. The I/Q modulation frequency response affects for example:
● Error vector magnitude (EVM) of digitally modulated signals
● Relative carrier power of multicarrier signals distributed over a large bandwidth

Without any additional option, the R&S SFI100A is equipped with a high-performance
I/Q modulator that, if configured to, generates an optimized flat signal. With activated
high-quality optimization mode, the instrument uses an internal correction method and
digital baseband filters to compensate for frequency response variations and I/Q skew
within its signal processing chain. Signal correction is performed in real time.

Components and system flatness

The signal at the RF output and the analog I/Q outputs of the R&S SFI100A is flat.
However, the DUT is rarely connected directly to the outputs of the generator. You are
likely to use connecting cables between the R&S SFI100A and the DUT as it is likely
that the test setup includes further measurement equipment, connected at the DUT's
outputs. Especially at microwave frequencies and with complex test setups, compo-
nents like cables, power combiners, switches or mixers can severely affect the I/Q flat-
ness.

Principle of user-defined frequency response correction

If equipped with the option R&S SFI-K544, you can load scattering parameters (S-
parameters) files and frequency response (FR) files to compensate for output signal
deviations. These deviations stem from components in the signal chain. see "Compo-
nents and system flatness" on page 161.

The R&S SFI100A retrieves correction values from these files to pre-process the sig-
nal. During pre-processing, the R&S SFI100A compensates signal magnitude varia-
tions and signal phase variations for the resulting frequency response.

You can obtain S-parameters files by measuring the components with a vector network
analyzer (VNA). If S-parameters files are unavailable, you can also retrieve correction
values from FR files. Obtain these files with R&S NRP power sensors or by converting
an equalizer file.
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Real-time compensation

The compensation filters are implemented in hardware. Thus, corrections are applied
in real time, irrespectively of the baseband signal. If the baseband signal is reconfig-
ured, the compensation is applied on that signal, too. Logically though, if parts of the
setup like components or cables are changed, these newly introduced parts have to be
measured and their S-parameter files included in the compensation.

Difference between the S-parameters and FR files

The S-parameters files contain transmission S-parameters (S-parameters) that char-
acterize the component's frequency response. They compensate the frequency
response of the S-parameters network, regarding magnitude and phase, while taking
reflections into consideration.

FR files with file extension *.fres contain magnitude and phase corrections but do
not contain reflection corrections. Use user correction files with file extension *.uco to
compensate the signal magnitude at the center frequency. If you load a frequency
response (FR) list that contains several files, these files also compensate the magni-
tude frequency response over the modulation frequency. User correction files do not
contain phase corrections or reflection corrections.

6.5.1.1  Required options

The equipment layout includes:
● Base unit
● Option user-defined frequency response correction (R&S SFI-K544)

6.5.1.2  Supported file formats

The following file formats are supported:

Extension File type Description

*.s<n>p Touchstone S-parameters files See "S-parameters (touchstone) files"
on page 162.

*.uco User correction files See "Frequency response (FR) files"
on page 164.

*.fres Frequency and phase of the trans-
mission path in a touchstone format

See "Frequency response (FR) files"
on page 164.

*.freqresp Save or recall a file that contains the
configuration in the dialog

See "Save/Recall" on page 172.

*.freqresp

S-parameters (touchstone) files

The R&S SFI100A can extract and apply scattering matrix corrections from S-parame-
ters data files. These data files are also known as touchstone files and exist in two for-
mat versions, V1.0 and V2.0.
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R&S SFI-K544 supports the touchstone file format in version V1.0.

File extension

S-parameters files are files with predefined structure and file extension *.s<n>p,
where the following applies :
● <n> is an integer value that is equal or higher than 1
● <n> is the number of measured ports
● <n>2 = number of S-parameters that the file contains

An *.s1p file, for example, contains a one-port measurement and one S-parameter
while the file *.s3p contains a three-port measurement and nine S-parameters.

For the frequency response compensation, the most meaningful S-parameter is S21. It
characterizes the frequency response of a component. Measure S-parameters with a
vector network analyzer, for example, the R&S ZNB.

File format

Touchstone files contain a header, a comment section, and the actual trace data.
The following is an extract of the file content of file created by the R&S ZNB.

#  HZ   S   RI   R     50.00 
! Rohde & Schwarz Vector Network Analyzer 
! Rohde-Schwarz,ZNB8-4Port,1311601044100005,1.93.1.42
! Created: UTC 9/17/2013, 9:13:56 AM
! freq[Hz]                re:S11                  im:S11
 1.000000000000000E5    -4.897128641605377E-1    3.767784312367439E-2
 4.259950000000000E7    -5.450598597526550E-1    3.608805686235428E-2
 ...

# indicates the beginning of the header line. The top of the file requires this header
line that consists of the following data elements:
● <Frequency unit>: HZ / KHZ / MHZ / GHZ, Rohde & Schwarz analyzers usually

use Hz.
● <Data file type>: S for S-parameter files
● <Data format>:

– RI = Re/Im
– MA = linear magnitude-phase
– DB = Mag-Phase in decibels

● <Reference resistance>: specifies the impedance system underlying the trace
data, given as a real, positive resistance (default 50 Ω)

Comment lines start with the exclamation mark (!) and can contain any text used for
documentation of the trace data file. Any number of comment lines can be inserted
before or after the header line.

The following information is displayed in the comments section:
● VNA identification (comment line 2 in the above example)
● Timestamp (comment line 3)
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● Port-specific renormalization information (comment lines 4ff, if applied)
● Headings for included data tables (comment lines right above the data tables, start-

ing with ! freq)

The trace data section corresponds to a set of single-ended S-parameters. It depends
on the number of ports and the data format.

For real and imaginary values (<Data format> = RI) the trace data for each stimulus
frequency is arranged as indicated in the lowermost comment lines:
● 1-port files (*.s1p)

! freq[Hz] re:S11 im:S11
You can replace S11 by any S-parameter. The *.s1p file format can contain an
arbitrary data trace representing an S-parameter. The file lists all values arranged
in one line.

● 2-port files (*.s2p)
! freq[Hz] re:S11 im:S11 re:S21 im:S21 re:S12 im:S12 re:
S22 im:S22
The file lists all values arranged in one line.

● n-port files (*.snp), 2 < n ≤ 4
! freq[Hz] re:S11 im:S11 re:S12 im:S12 ... re:S1n im:S1n
! re:S21 im:S21 re:S22 im:S22 ... re:S2n im:S2n
! ...
! re:Sn1 im:Sn1 re:Sn2 im:Sn2 ... re:Snn im:Snn
The file lists all values arranged in n lines.

● n-port files (*.snp), n > 4
! freq[Hz] re:S11 im:S11 ... re:S14 im:S14
! re:S15 im:S15 ...
! ...
! ... re:Snn im:Snn
The file lists all values arranged in m lines, where m = n2/4. The first m-1 data lines
contain exactly four value pairs.

The stimulus frequencies are in ascending order. For linear magnitude-phase and
magnitude-phase in decibels values (<Data format> = MA or DB), the trace data the
real and imaginary S-parameter values re:Sij  im:Sij are replaced by
mag:Sij  ang:Sij or db:Sij  ang:Sij, respectively.

Cascading files

If you load several S-parameter files, the R&S SFI100A processes these files in a cas-
cading manner. Each S-parameters file defines the S-parameter origin and the destina-
tion ports. You can configure or reverse the orientation of the signal chain. The first
entry in the signal chain is the R&S SFI100A, the last entry is the DUT.

Frequency response (FR) files

This description provides information on frequency response (FR) files.
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FR file extensions

The R&S SFI100A can extract and apply frequency response and level corrections
from the following FR file types:
● *.uco files
● *.fres files.

These files types contain transmission parameters, in magnitude and phase. The order
of the files in the file list is not relevant but the file processing assumes a perfect
matching of the single files.

*.fres files

These files contain user-defined transmission frequency response values and are cre-
ated manually, in one of the following ways:
● From existing user data describing the transmission characteristics of the channel

or the device, like, for example, the S21 S-parameter set. The *.fres file format is
the same as the file format of the one port S-parameter files; merely changed is the
file extension.
See "S-parameters (touchstone) files" on page 162.

● Obtained through conversion of an equalizer file.
Equalizers are special filters in spectrum analyzers like, for example, the
R&S®FSW. The analyzer uses these filters to compensate for the frequency
response of the received signal. You can query the equalizer characteristics or filter
tabs with remote control commands.
For more information, see R&S®FSW user manual.

*.uco files

User correction files can be created manually or obtained by a power sensor for exam-
ple R&S NRP.

These types of files can also be used with the user correction functionality in the RF
block. Corrections affect one or a sequence of discrete frequencies. For narrowband
signals, this approach can achieve sufficient results but it is not effective for wideband
signals.

The user-defined frequency response corrections are applied digitally and on the cur-
rent baseband signal, thus compensating the magnitude of the signal in the modulation
frequency range.

For information on the user correction function, file format and on how to acquire the
frequency response characteristics of the transmission channel by R&S NRP power
sensor, see the following:
● Chapter 7.6, "Applying user correction", on page 228

6.5.2  Applying user-defined FRC

This chapter describes how to use the R&S SFI-K544 functionality and load S-parame-
ters files for compensating for the frequency response of a test setup.
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We assume that you have characterized the components (cable, combiners, DUT), for
example with vector network analyzer, and have created the required S-parameters
files. We also assume that the frequency response files are created.

To generate the baseband and RF signal

Configure the baseband signal and enable signal generation, for example as follows:

1. In the block diagram, select "Baseband" > "ARB" > "State" > "On".

2. In the status bar, set the frequency and level, for example, "Frequency" = "5 GHz"
and "Level" = "-15 dB".

3. In the block diagram, select "RF" > "On".

To apply S-parameters file corrections

We assume that you have characterized the components (cable, combiners, DUT), for
example with vector network analyzer, and have created the required S-parameters
files. We also assume that the frequency response files are created.

1. Use any of the file transfer methods to save the S-parameters files in the /var/user/
directory of the R&S SFI100A.

2. Select "I/Q Mod" > "Frequency Response".

3. Select "General" > "Optimization Mode" > "High Quality".

4. Select "User Defined Correction" > "User Data S-parameter".

a) In the S-parameter table, select "S1" > "S-Paramater Filename".
b) Navigate to the S-parameter file.

5. If you use several files, select "Append".

6. Load these files in the same manner.

7. For each of the files, select "State" > "On".

8. Select "Apply".
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9. Select "User Defined Correction" > "Data Overview" to observe the frequency
range covered by the loaded files.

The dialog also shows an overview of the aggregated correction data of all active
files.

10. Select "User Defined Correction" > "Common" > "State" > "On".

11. Optionally, select "Compensate Absolute Level" > "On".

To use additional frequency correction data

1. Select "User Defined Correction" > "Common" > "Additional FR" > "On".

2. Select "User Defined Correction" > "User Data Additional FR":

a) In the frequency response table, select "F1" > "Frequency Response File-
name".

b) Navigate to the *.uco file.
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3. If you use several files, select "Append".

4. Load the files in the same manner.

5. For each of the files, select "Magnitude" > "On" and "Phase" > "On".

6. Select "Apply".

7. Select "User Defined Correction" > "Data Overview" to observe the frequency
range covered by all loaded files.

The dialog also shows an overview of the aggregated correction data of all active
files.
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6.5.3  User-defined FRC configuration and settings

Access:

► In the block diagram of the R&S SFI100A, select "I/Q Mod" > "Frequency
Response".

The dialog provides settings to configure the frequency responses.

The remote commands to define these settings are described in Chapter 13.15.3,
"SOURce:CORRection:FRES subsystem", on page 482.

For step-by-step instructions, see Chapter 6.5.2, "Applying user-defined FRC",
on page 165.

● General settings....................................................................................................169
● User-defined correction settings........................................................................... 171

6.5.3.1  General settings

Access:

► Select "I/Q Mod" > "Frequency Response" > "General".

Settings:

Optimization Mode...................................................................................................... 170
Optimization Bandwidth.............................................................................................. 170
Bandwidth................................................................................................................... 170
Hold Filter....................................................................................................................170
Optimize for current setting......................................................................................... 171
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Optimization Mode
Selects the optimization mode for I/Q modulation of the internal baseband signal.
How to: Chapter 6.5.2, "Applying user-defined FRC", on page 165
For more information, refer to the specifications document.
"Fast" Fast optimization by compensating for I/Q skew. This mode is suita-

ble in time sensitive environments and for narrowband signals.
"High Quality Table"

This mode further improves the frequency response while maintaining
setting time. There is no signal interruption. Select this mode in set-
ups to generate phase coherent signals with an RF modulation band-
width of up to 10 GHz.

Remote command: 
[:SOURce<hw>]:CORRection:FRESponse:RF:OPTimization:MODE
on page 484

Optimization Bandwidth
Requires "Optimization Mode" > "High Quality Table".
Sets the method to determine the signal bandwidth. The instrument uses this signal
bandwidth to compensate for the frequency response.
"Auto" Automatic signal bandwidth setting that is based on the sample rate

of the baseband signal.
"Manual" Manual signal bandwidth setting via "Bandwidth". See "Bandwidth"

on page 170.
Remote command: 
[:SOURce<hw>]:CORRection:FRESponse:RF:OPTimization:BANDwidth:
MODE on page 485

Bandwidth
Displays or sets the signal bandwidth to compensate for the frequency response.
Setting requires "Optimization Mode" > "High Quality Table" and "Optimization Band-
width" > "Manual".
For "Optimization Bandwidth" > "Auto", displays the automatically derived signal band-
width.
See "Optimization Bandwidth" on page 170.
Remote command: 
[:SOURce<hw>]:CORRection:FRESponse:RF:OPTimization:BANDwidth[:
VALue] on page 485

Hold Filter
Requires "Optimization Mode" > "High Quality Table".
Retains the last calculated correction values as long as one of the following holds:
● Select "Optimize for current setting".
● Select "Hold Filter" > "Off".
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Remote command: 
[:SOURce<hw>]:CORRection:FRESponse:RF:OPTimization:HOLD[:STATe]
on page 486

Optimize for current setting
Requires "Optimization Mode" > "High Quality Table".
Optimizes correction for the current frequency and bandwidth. Use this function to trig-
ger recalculation of the compensation values for the enabled hold filter ("Hold Filter" >
"On").
Remote command: 
[:SOURce<hw>]:CORRection:FRESponse:RF:OPTimization:LOCal
on page 486

6.5.3.2  User-defined correction settings

Access:

► Select "I/Q Mod" > "Frequency Response" > "User Defined Correction".

● Common settings.................................................................................................. 171
● User data S-parameter settings............................................................................ 173
● User data additional FR settings...........................................................................175
● Data overview....................................................................................................... 177

Common settings

Access:

► Select "User Defined Correction" > "Common".

This dialog provides default settings, "Save"/"Recall" settings and settings that are
common for the particular FRC setup.

Correcting the frequency response
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Settings:

State............................................................................................................................172
Set To Default..............................................................................................................172
Save/Recall................................................................................................................. 172
Compensate Absolute Level....................................................................................... 172
Absolute Level Correction........................................................................................... 173
Additional FR...............................................................................................................173

State
Enables the user-defined frequency response correction. Enabling requires "Optimiza-
tion Mode" > "High Quality".
See "Optimization Mode" on page 170.
Remote command: 
[:SOURce<hw>]:CORRection:FRESponse:RF:USER[:STATe] on page 487

Set To Default
Calls the default settings. The values of the main parameters are listed in the following
table.

Parameter Value

State Off

Compensate absolute level Off

Additional FR Off

Remote command: 
[:SOURce<hw>]:CORRection:FRESponse:RF:USER:PRESet on page 487

Save/Recall
Accesses the "Save/Recall" dialog, that is the standard instrument function for saving
and recalling the complete dialog-related settings in a file. The provided navigation
possibilities in the dialog are self-explanatory.
The settings are saved in a file with predefined extension. You can define the filename
and the directory, in that you want to save the file.
Remote command: 
[:SOURce<hw>]:CORRection:FRESponse:RF:USER:STORe on page 487
[:SOURce<hw>]:CORRection:FRESponse:RF:USER:LOAD on page 487

Compensate Absolute Level
If S-parameters files are loaded, absolute level compensation at the current center fre-
quency can also be enabled. Current correction value is indicated.
If enabled, the absolute level is compensated for the signal until the DUT inputs. Level
compensation in the transmission channel, i.e. if FR files are used, is not supported.
You recognize active absolute level correction by the "Lev Fcor" icon in the status bar.
To apply corrections from S-parameters files, select User Data S-Parameter, load suit-
able files, activate them and select "Apply".
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You cannot enable absolute level compensation and user correction simultaneously.
These functions exclude each other.
See also "About UCOR" on page 229.
Remote command: 
[:SOURce<hw>]:CORRection:FRESponse:RF:USER:ALEVel[:STATe]
on page 488

Absolute Level Correction
Indicates the current level correction value, if absolute level correction is enabled.
Remote command: 
[:SOURce<hw>]:CORRection:FRESponse:RF:USER:ALEVel:VALue?
on page 488

Additional FR
Enables user-defined corrections. The instrument uses FR files to apply these correc-
tions to compensate for the channel response of the transmission channel.
To apply such corrections, select the "User Data Additional FR" tab, load RF files,
enable them and select "Apply". See "User data additional FR settings" on page 175.
Observe the shift of the compensation plane in the illustration in the dialog.
Remote command: 
[:SOURce<hw>]:CORRection:FRESponse:RF:USER:FLISt[:STATe]
on page 489

User data S-parameter settings

Access:

► Select "I/Q Mod > Frequency Response > User Defined Correction > User Data S-
Parameter".

Correcting the frequency response
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In this dialog, you can load S-parameters files. If activated, the transmission S-
parameter values are extracted from the file and used to pre-process the gener-
ated signal. At the DUT, the signal is as if the DUT is directly connected to the out-
put of the R&S SFI100A. The frequency response of the related components is
compensated.
Also to or instead of S-parameters files if the latter are for example unavailable for
particular components, you can also load frequency response RF files, see "User
data additional FR settings" on page 175.

To activate loaded files, enable them ("State" > "On") and select "Apply". A warning
icon appears if you change any setting in the dialog but "Apply" is not executed.

Settings:

S1 to S10.................................................................................................................... 174
S-Parameter Filename................................................................................................ 174
Ports to/Ports from...................................................................................................... 174
State............................................................................................................................175
Append / Delete/Up/Down...........................................................................................175
Apply........................................................................................................................... 175

S1 to S10
S-parameter file number indicating the loaded files. You can load up to 10 files.
Remote command: 
Via SLISt<ch> suffix

S-Parameter Filename
Access the standard "File Select" dialog for loading S-parameters (Touchstone) files.
S-parameters files are files with predefined extension (*.s<n>p) and file format.

See "S-parameters (touchstone) files" on page 162.
Use the standard "File Manager" function to transfer external data lists to the instru-
ment.
Remote command: 
[:SOURce<hw>]:CORRection:FRESponse:RF:USER:SLISt<ch>:SELect
on page 489

Ports to/Ports from
Sets the origin and destination ports, i.e. the port number from that the signal is coming
and the port to that it is going. Use this parameter to change the orientation of the sig-
nal chain.
Remote command: 
[:SOURce<hw>]:CORRection:FRESponse:RF:USER:SLISt<ch>:PORTs:FROM
on page 490
[:SOURce<hw>]:CORRection:FRESponse:RF:USER:SLISt<ch>:PORTs:TO
on page 490
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State
If activated, the file is used for frequency response compensation. Thus, you can load
files that are excluded from the current frequency response compensation scenario,
exchange files or temporarily deactivate files.
Note: However, files are of the S-parameter used until you execute "Apply".
Observe the indication in the side tab. A warning icon appears if you change any set-
ting in the "Use Data S-Parameter" dialog but "Apply" is not executed.
Remote command: 
[:SOURce<hw>]:CORRection:FRESponse:RF:USER:SLISt<ch>[:STATe]
on page 490

Append / Delete/Up/Down
Standard functions for handling the table rows.

Apply
Applies the values from the active S-parameters files and uses them to pre-process the
signal.
Remote command: 
[:SOURce<hw>]:CORRection:FRESponse:RF:USER:APPLy on page 489

User data additional FR settings

Access:

1. Select "I/Q Mod > Frequency Response > User Defined Correction > Common".

2. Select "Additional Frequency Response (FR) > On".

3. Select "User Data Additional FR".

In this dialog, you can load user-defined frequency response (FR) files. If activated,
the frequency response values are extracted from the file and used to pre-process
the generated signal.
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You can use FR files or S-parameters files. To activate loaded files, enable them
and select "Apply". A warning icon appears if you change any setting in the dialog
but "Apply" is not executed.

Settings:

F1 to F5.......................................................................................................................176
Frequency Response Filename.................................................................................. 176
Magnitude/Phase........................................................................................................ 176
Append/Delete............................................................................................................ 176
Apply........................................................................................................................... 176

F1 to F5
FR file number indicating the loaded files. You can load up to five files.
Remote command: 
Via FLISt<ch> suffix

Frequency Response Filename
Access the standard "File Select" dialog for loading FR files. FR files are files with pre-
defined extension (*.uco or *.fres) and file format.

See "Frequency response (FR) files" on page 164.
Use the standard "File Manager" function to transfer external data lists to the instru-
ment.
Remote command: 
[:SOURce<hw>]:CORRection:FRESponse:RF:USER:FLISt<ch>:SELect
on page 490
[:SOURce<hw>]:CORRection:FRESponse:RF:USER:FLISt:CATalog?
on page 490

Magnitude/Phase
Enables using the phase and magnitude information from the loaded FR file.
Note: However, files are of the FR used until you execute "Apply".
Observe the indication in the side tab. A warning icon appears if you change any set-
ting in the "Use Data Additional RF" dialog but "Apply" is not executed.
Remote command: 
[:SOURce<hw>]:CORRection:FRESponse:RF:USER:FLISt<ch>:MAGNitude[:
STATe] on page 490
[:SOURce<hw>]:CORRection:FRESponse:RF:USER:FLISt<ch>:PHASe[:
STATe] on page 490

Append/Delete
Standard functions for handling the table rows.

Apply
Retrieves the values from the active FR files and pre-processes the signal with them.
Remote command: 
[:SOURce<hw>]:CORRection:FRESponse:RF:USER:APPLy on page 489
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Data overview

Access:

► Select "I/Q Mod > Frequency Response > User Defined Correction > Data Over-
view".

This dialog provides a graphical overview of the combined user-defined frequency
response corrections.
The first graph represents the frequency range covered by each of the files and
highlights the common frequency region. The graphs on the right indicate the
aggregated frequency response corrections for both the magnitude and phase cor-
rections over the common frequency range.
In both cases, considered are the active ("State > On") rather than all loaded files.

Correcting the frequency response
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7  Generating RF signals
The wideband IF vector signal generator R&S SFI100A generates RF signals within
the frequency range from 11 GHz up to 21 GHz. These signals can have up to 10 dBm
output power and an adjustable signal level over a wide range.

In addition to real-time CW signals, you can generate RF signals from externally cre-
ated waveform files which you can load into the R&S SFI100A.

The main application field of the R&S SFI100A is the use as an IF source for external
frontends and frequency converters. The RF output signal of the R&S SFI100A is
therefore referred to as the IF input signal for the connected external instruments.

The R&S SFI100A also provides functions to improve the RF output signal perfor-
mance:
● User correction (UCOR)

The user correction function allows you to compensate frequency responses of
external setups (e.g. losses of cables) and achieve a stable input signal over fre-
quency directly at the DUT.
See "About UCOR" on page 229.

● Power sensors
The R&S SFI100A supports R&S NRP power sensors, e.g. to monitor the output
level of the generator. The sensor readings enable you to determine level correc-
tion values. Thus you can adjust the RF output power of the generator until you
reach the target level at the DUT.
See Chapter 7.5, "Using power sensors", on page 212.

● Generating upconverted RF signals......................................................................178
● Configuring RF signals..........................................................................................199
● RF settings............................................................................................................200
● Generating reference signals................................................................................205
● Using power sensors.............................................................................................212
● Applying user correction........................................................................................228
● Improving the RF signal performance...................................................................239

7.1  Generating upconverted RF signals

To expand the frequency range of the R&S SFI100A, you can add external frontends to
your test setup. External frontends can upconvert the output frequency of the
R&S SFI100A for wideband signal generation, for example D band signals (110 GHz to
170 GHz).

7.1.1  About external frontends

Working with external frontends for upconversion is supported via the frontend control
option R&S SFI-K553 integrated in the base unit of the R&S SFI100A.

Generating upconverted RF signals



Generating RF signalsR&S®SFI100A

179User Manual 1179.6789.02 ─ 02

Supported external frontends

The R&S SFI100A supports the following external frontends:
● R&S FE110ST
● R&S FE170ST

External frontend basics

When using a signal generator in complex test setups, long RF cables between the
DUT and the signal generator are often necessary. When measuring high-frequency
signals, long RF cables can lead to unwanted loss. Using an external frontend with
smaller physical dimensions in your test setup allows for testing closer to the DUT,
which reduces the effect of the loss on the measurement.

The test signal is transferred (TX mode) from the R&S SFI100A to the external fron-
tend on a lower intermediate frequency (IF). The external frontend upconverts the IF
signal to the higher frequency RF signal, which is transferred for processing at the
DUT. For upconversion, the external frontend uses either its internal local oscillator
(LO) or you can apply an external LO signal.

Using an external frontend for upconversion has the following advantages:
● Extended frequency range

The external frontend can process RF data in a higher frequency range than the
R&S SFI100A itself supports. For example, using an R&S FE110ST external fron-
tend in your test setup, you can generate RF signals in a range of 70 GHz to 110
GHz.

● Minimized RF cable loss
You can place the external frontend as close as possible to the DUT using shorter
RF cables. Therefore, the cabling between the R&S SFI100A and the external fron-
tend is not as vulnerable to distortion effects and power loss. Since the IF cable is
usually part of the fixed setup, any existing frequency response can be calculated
in advance. The R&S SFI100A can then adapt signal generation automatically.
See also Chapter 7.1.3.4, "Cable correction settings", on page 190.

A typical application is a test setup involving a DUT placed in an RF shield box. The
external frontend is connected directly to the RF shield box, while the R&S SFI100A is
placed in a measurement rack elsewhere in the laboratory.

7.1.2  Operating external frontends

This chapter provides an overview on step-by-step instructions related to connecting
and configuring external frontends.

It includes the following:

● Connecting external frontends.............................................................................. 180
● Controlling external frontends............................................................................... 180
● Adding external devices to the external frontend..................................................181
● Test setups with multiple external frontends......................................................... 183
● Generating RF output signals............................................................................... 184
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7.1.2.1  Connecting external frontends

For a step-by-step description of how to connect an external frontend, see "To connect
an external frontend" on page 36.

7.1.2.2  Controlling external frontends

This chapter provides step-by-step descriptions for controlling and operating external
frontends with the R&S SFI100A. Configuring procedures are summarized for the
R&S FE170ST as an example. The configuration procedure is analogous for all other
external frontends.

For the following procedures, it is assumed that a network connection is established.
● For information on how to configure the R&S SFI100A for frontend control, see "To

configure the R&S SFI100A for frontend control" on page 37
● "To configure external frontend settings" on page 180
● "To configure frequency band settings for the external frontend" on page 181

To configure external frontend settings

The following procedure describes how to configure external frontend settings at the
R&S SFI100A.

See also Chapter 7.1.3.1, "General settings", on page 186.

The R&S SFI100A is connected to an external frontend and a remote control connec-
tion between R&S SFI100A and the external frontend is established.

See "To configure the R&S SFI100A for frontend control" on page 37.

1. Select one of the following in the block diagram:
● Select the icon of the connected external frontend to the right of the "RF Out"

block.
● Select "RF Out" > "RF Frontend" > "Frontend Device".

2. Set the frequency of the reference signal between R&S SFI100A and external fron-
tend, e.g., "1 GHz".

3. Optionally, change the "Connection Mode".
For "Connection Mode" > "Auto", the R&S SFI100A reads out the frontend informa-
tion automatically, for example intermediate frequency (IF) and frequency band
configuration.

4. Set the "Frequency Band Configuration".
See "To configure frequency band settings for the external frontend" on page 181.

Also, the R&S SFI100A sets and reads out the following parameters automatically
at the external frontend:
● "Intermediate Frequency / Sideband": Frequency of the IF input signal input
● "Active RF Connector": RF output connector
● "Frequency Band x": Frequency ranges of the RF output signal
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For more information, refer to the specifications document.

To configure frequency band settings for the external frontend

Test setups typically require a defined setting of the frequency band configuration.
Configure this setting in the "RF Frontend" dialog of the R&S SFI100A.

Note: This procedure describes configuring the R&S FE170ST as an example. Config-
uring the R&S FE110ST is analogous.

► Set the "Mode" for the "Frequency Band Configuration".

a) Select "Mode > Auto" to use the internal "Frequency band config" of the
R&S SFI100A.

b) Select "Mode > Manual" to configure, for example, a test setup with multiple
external frontends.

"Frequency Band Config > SFI" uses the internally defined frequency band configu-
ration of the R&S SFI100A.

Figure 7-1: Example: Frontend configuration FE170ST

7.1.2.3  Adding external devices to the external frontend

You can add accessories, for example a bandpass filter or an amplifier, as external
devices to a test setup with R&S SFI100A and an external frontend. The external devi-
ces transmit the RF input via their waveguide connector. Power and device data is
transmitted via an IX type B connector with an SPI interface.

The IX type B connector allows you to connect external devices to the external fron-
tend. External devices can amplify or filter the upconverted RF signal. Using an IX
cable, correction data and device information for the external device is transferred to
the external frontend and to the connected R&S SFI100A. Thus, the R&S SFI100A
cannot only detect the external devices, but also consider their correction data in the
RF measurement.

See also the installation instructions and specifications document of the external fron-
tend.

Generating upconverted RF signals
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Figure 7-2: Test setup: Vector signal generator with R&S FE170ST and external devices
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Figure 7-3: Test setup: Vector signal generator with R&S FE110ST and external device

Choosing an external filter

The supported frequency ranges of the available external filters overlap. For best
results regarding image suppression and LO feedthrough, see the specifications docu-
ment of the external device.

See the R&S FE170-Zxx or R&S FE110-Zxx accessories specifications document:
● www.rohde-schwarz.com/brochure-datasheet/fe170st
● www.rohde-schwarz.com/brochure-datasheet/fe110st

To connect an external device

1. Connect the RF output of the external frontend to the RF input of the external
device.

2. Connect the IX connector of the external frontend with the cable provided with the
device to the IX type B connector on the external device.
To connect two external devices, connect the IX Y-cable provided with the external
frontend to both external devices.

Note: You can add only one external device of the respective type to the test
setup.

3. Connect the RF output of the external device to the DUT.

4. Connect the external frontend to the R&S SFI100A.
See "To connect an external frontend" on page 36.

To check for external devices

You can check which external devices are connected in the signal path between the
DUT and the external frontend.

1. Select one of the following in the block diagram:
● Select the "FE..." icon to the right of the "RF Out" block.
● Select "RF Out" > "RF Frontend" > "Frontend Device".

Generating upconverted RF signals
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2. Select the "External Devices" tab.

The devices that are connected to the external frontend via the IX type B connector
and which were detected by the R&S SFI100A are indicated.

Figure 7-4: Example: External devices connected to an R&S FE170ST

3. If necessary, update the display by selecting "Refresh External Devices".
Alternatively:

a) Select "I/Q Stream Mapper" in the block diagram.
b) Select "External RF and I/Q" > "External Instrument" > "Config".
c) Select "Clean All".

This step removes all connected external Instruments.
d) Select "External Instrument".
e) Select a device from the list.
f) Click "Apply and Connect".

See Chapter 7.1.3.6, "External devices settings", on page 194.

7.1.2.4  Test setups with multiple external frontends

In a test setup with more than one external frontend, you can build a phase coherent
test setup when using the same LO signal for all connected frontends.

See also Chapter 7.1.3.7, "LO config settings", on page 196.

To configure LO settings with multiple external frontends

1. Select one of the following in the block diagram:
● Select the icon of the external frontend to the right of the "RF Out" block.
● Select "RF Out" > "RF Frontend" > "Frontend Device".

2. Select the "LO Config" tab.
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3. Select the "Mode".

a) If the external frontend connected to the vector signal generator provides the
LO signal in your test setup, select "Internal".

b) If the external frontend connected to the vector signal generator receives the
LO signal in your test setup, select "External".
The "Mandatory LO IN Frequency" is displayed.

4. Select the "Out State".

a) If the external frontend connected to the vector signal generator provides the
LO signal in your test setup, select "On".
The "LO OUT Frequency" is displayed.

b) If the external frontend connected to the vector signal generator receives the
LO signal in your test setup, select "Off".

7.1.2.5  Generating RF output signals

With the R&S FE170ST connected to the R&S SFI100A, you can generate RF signals
with frequencies in the high D band.

The procedure assumes that a remote control connection between R&S SFI100A and
R&S FE170ST is established and the frontend settings are configured.

In this example, you generate an ARB signal from a waveform file stored on the
R&S SFI100A, with RF frequency = 140 GHz and RF level = -25 dBm.

1. Select "Baseband > ARB".

2. In the "General" tab, select "Load Waveform".

3. Select the waveform file with file extension *.wv from the respective directory, for
example /var/user/testsignal.

4. Click "Select".

The waveform file is loaded.

5. Select "ARB" > "State" > "On".

When loading a modulated test signal, the I/Q modulation is automatically switched
on.

6. Return to the block diagram.

7. Configure the RF output signal.
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Once you connect the external frontend, the R&S SFI100A sets the "Frequency" in
the status bar automatically. In particular, the R&S SFI100A + R&S FE170ST sets
the lower frequency of the frequency band, i.e. 110 GHz.

a) In the status bar of the R&S SFI100A, adjust the frequency of the RF signal.
b) In the status bar of the R&S SFI100A, adjust the level of the RF signal.

8. In the block diagram, select "RF > On".

The RF signal is output at the external frontend.

7.1.3  RF frontend settings

Access:

► Select one of the following in the block diagram:
● Click the "FE ..." icon to the right of the "RF Out" block.

For example, the icon displays "FE170ST" for an R&S FE170ST connected to
the R&S SFI100A.

● Select "RF Out" > "RF Frontend" > "Frontend Device".

The remote commands required to define the settings are described in Chap-
ter 13.15.10, "SOURce:EFRontend subsystem", on page 514 in the chapter "Remote
commands".

For information on how to connect external frontends, see Chapter 5.2, "External RF
settings", on page 142.

To operate an external frontend with the R&S SFI100A

See Chapter 7.1.2, "Operating external frontends", on page 179.
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Settings:

7.1.3.1  General settings

Access:

1. Select "RF Out" > "RF Frontend" > "Frontend Device".

2. Select "Settings".

The "Settings" tab provides settings to configure reference frequency and connec-
tion settings for the connected external frontend.

Settings:

Reference Frequency..................................................................................................186
Connection Mode........................................................................................................ 186
Intermediate Frequency / Sideband............................................................................ 187
Active RF Connector................................................................................................... 187
Mode........................................................................................................................... 187
Frequency Band Config.............................................................................................. 187
Frequency Band x....................................................................................................... 188

Reference Frequency
Sets the frequency of the reference signal between R&S SFI100A and frontend.
The R&S SFI100A provides reference frequencies of 10 MHz and 1 GHz.
Remote command: 
[:SOURce<hw>]:EFRontend:FREQuency:REFerence on page 522
[:SOURce<hw>]:EFRontend:FREQuency:REFerence:LIST? on page 522

Connection Mode
Sets the mode of the SSL control connection between R&S SFI100A and external fron-
tend.
There is one communication channel to control the external frontend meaning that one
instrument controls the external frontend exclusively.
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Once the external frontend is locked, the R&S SFI100A firmware reads out external
frontend characteristics such as intermediate frequency (IF) and frequency bands.
"Auto" The R&S SFI100A locks the external frontend, when activating the

RF output at the R&S SFI100A ("RF" > "On") for output of the IF sig-
nal.
The R&S SFI100A unlocks the external frontend, when deactivating
the RF output at the R&S SFI100A ("RF" > "Off").

"Lock" The external frontend is locked permanently. No other instrument can
take over control.

"Simultaneous RX/TX"
Not available for R&S SFI100A (grayed out).

Remote command: 
[:SOURce<hw>]:EFRontend:CMODe on page 520

Intermediate Frequency / Sideband
Displays the frequency of the IF signal that is the frequency at the "RF Out" connector
of the R&S SFI100A.
Also, the sideband of the IF signal is displayed after the frequency. "USB" means upper
sideband, "LSB" means lower sideband.
If the lock of the communication channel is missing, the intermediate frequency dis-
plays "Unavailable due to missing lock".
Remote command: 
[:SOURce<hw>]:EFRontend[:FREQuency]:IFRequency[:VALue]?
on page 522
[:SOURce<hw>]:EFRontend:FREQuency:IFRequency:SIDeband? on page 523

Active RF Connector
Displays the RF output connector that is active at the connected external frontend. The
RF output signal is the up-converted RF signal.
"RF A" RF output connector at the R&S FE170ST or R&S FE110ST.
Remote command: 
[:SOURce<hw>]:EFRontend:RFConnector on page 525

Mode
Sets the mode for frequency band configuration of the external frontend.
See also "Frequency Band Config" on page 187.
"Auto" Configures the frequency band automatically.
"Manual" Configures the frequency band configuration manually as defined

with the parameter "Frequency Band Config".
Remote command: 
[:SOURce<hw>]:EFRontend:FREQuency:BAND:CONFig:MODE on page 521

Frequency Band Config
Define the intermediate frequency (input) range of the external frontend.
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The used "Intermediade Frequency / Sideband" and the resulting "Frequency Band x"
are indicated for reference.
"SFI"

The external frontend uses the R&S SFI100A specific intermediate
frequency of 16 GHz.
For available options, see the specifications document.

Remote command: 
[:SOURce<hw>]:EFRontend:FREQuency:BAND:CONFig:CATalog? on page 520
[:SOURce<hw>]:EFRontend:FREQuency:BAND:CONFig:SELect on page 521

Frequency Band x
Displays the ranges of the frequency bands of the upconverted frequency depending
on the connected external frontend.
For supported frequency ranges, see the specification document.
Remote command: 
[:SOURce<hw>]:EFRontend:FREQuency:BAND:COUNt? on page 520
[:SOURce<hw>]:EFRontend:FREQuency:BAND<ch>:LOWer? on page 521
[:SOURce<hw>]:EFRontend:FREQuency:BAND<ch>:UPPer? on page 521

7.1.3.2  Versions and options information

Access:

1. Select "RF Out" > "RF Frontend" > "Frontend Device".

2. Select "Version / Options".

The "Versions / Options" tab displays information on the firmware and hardware of
the connected external frontend.
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Settings:

Firmware..................................................................................................................... 189
Hardware Config......................................................................................................... 189

Firmware
Displays firmware information on the control server and control library of the external
frontend. The information is displayed in a table and consists of installed packages and
versions.
"Package" Comprises the frontend control server and frontend control library.
"Version" Denotes the version of the installed package.
Remote command: 
n.a.

Hardware Config
Displays hardware information of the hardware components of the external frontend.
The information is displayed in a table and consists of component name, its part num-
ber and serial number, and revision version.
"Assembly" Displays the assembly part name for hardware component.
"Part Number" Displays the part number for each hardware component.
"Serial Number"

Displays the serial number for each hardware component.
"Revision" Displays the revision version for each hardware component.
Remote command: 
[:SOURce<hw>]:EFRontend:IDN? on page 522

7.1.3.3  Attenuator settings

Access:

1. Select "RF Out" > "RF Frontend" > "Frontend Device".

2. Select "Attenuator".

The "Attenuator" tab provides settings to configure attenuation.

Settings:

Mode........................................................................................................................... 190
Attenuation.................................................................................................................. 190
Offset...........................................................................................................................190
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Mode
Sets the attenuator mode of the external frontend.
"Auto" Sets the attenuation value automatically.

The frontend control connection provides this attenuation value from
the connected external frontend.

"Auto & Offset"
Requires frontend R&S FE170ST or R&S FE110ST.
You can define an offset value which adds to the attenuation value
provided from the connected external frontend.

"Manual" Sets an attenuation value manually.
Remote command: 
[:SOURce<hw>]:EFRontend:AMODe on page 519

Attenuation
Requires "Mode > Manual".
Sets the attenuation of the external frontend.
Remote command: 
[:SOURce<hw>]:EFRontend:POWer:ATTenuation on page 524

Offset
Requires frontend R&S FE170ST or R&S FE110ST.
Requires "Mode > Auto & Offset".
Adds an offset value to the attenuation value provided from the external frontend.
Remote command: 
[:SOURce<hw>]:EFRontend:POWer:OFFSet on page 525

7.1.3.4  Cable correction settings

Access:

1. Select "RF" > "RF Frontend" > "Frontend Device".

Generating upconverted RF signals



Generating RF signalsR&S®SFI100A

191User Manual 1179.6789.02 ─ 02

2. Select "Cable Correction".

The "Cable Correction" tab provides settings necessary to configure the frequency
response correction of the IF signal path.

You can load correction data to compensate for signal losses in the cable occurring at
different IF signal frequencies. Files containing correction data have the extension
*.s2p or *.uco. The following descriptions are exemplary with *.s2p files. Working
with *.uco files is analogous.

Settings:

State............................................................................................................................191
Load Cable Correction File......................................................................................... 191
Recommended Frequency Range.............................................................................. 192

State
Activates correction of the IF signal for different IF signal frequencies.
Activation requires loading of a valid cable correction file, see "Load Cable Correction
File" on page 191.
Remote command: 
[:SOURce<hw>]:EFRontend:ALIGnment[:STATe] on page 519

Load Cable Correction File
Accesses a standard file-select dialog to load correction data to compensate for signal
losses in the cable occurring at different IF signal frequencies.
If a correction file with a file extension *.s2p is loaded, the button also displays the
filename.
By default, the file if_default_cable_1347_7552_00.s2p is loaded. This file con-
tains correction data for the standard R&S IF cable with order number 1347.7552.00.
Also, the correction data uses the S-parameter S21.
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Example: Displaying file correction data
The example for the *.s2p file below comprises correction data for frequencies from
0 GHz to 7.5 GHz.
# HZ S DB R 50.00
! Date: 2020-06-12;11:48:28
! freq[Hz] db:S11 ang:S11 db:S21 ang:S21 db:S12 ang:S12 db:S22 ang:S22
100000.0 0.001 0 -0.018267469344920073 0 -0.018267469344920073 0 0.001 0
50000000.0 0.001 0 -0.10438567392872056 0 -0.10438567392872056 0 0.001 0
100000000.0 0.001 0 -0.1402532552881901 0 -0.1402532552881901 0 0.001 0
500000000.0 0.001 0 -0.37850173705964973 0 -0.37850173705964973 0 0.001 0
1000000000.0 0.001 0 -0.5387899823157998 0 -0.5387899823157998 0 0.001 0
2500000000.0 0.001 0 -0.8994010660064706 0 -0.8994010660064706 0 0.001 0
5000000000.0 0.001 0 -1.3888357992535698 0 -1.3888357992535698 0 0.001 0
7500000000.0 0.001 0 -1.8624967962088599 0 -1.8624967962088599 0 0.001 0

Remote command: 
[:SOURce<hw>]:EFRontend:ALIGnment:FILE:CATalog? on page 518
[:SOURce<hw>]:EFRontend:ALIGnment:FILE[:SELect] on page 518

Recommended Frequency Range
Displays the recommended frequency range of the IF signal that the external frontend
requires.
We recommend that you cover this range in the cable correction file. See Example
"Displaying file correction data" on page 192.
Remote command: 
[:SOURce<hw>]:EFRontend:ALIGnment:FILE:FREQuency:RANGe:LOWer?
on page 518
[:SOURce<hw>]:EFRontend:ALIGnment:FILE:FREQuency:RANGe:UPPer?
on page 518

7.1.3.5  Network settings

Access:

1. Select "RF Out" > "RF Frontend" > "Frontend Device".

Generating upconverted RF signals



Generating RF signalsR&S®SFI100A

193User Manual 1179.6789.02 ─ 02

2. Select the "Network" tab.

The tab provides settings to configure network settings of the external frontend.

Settings:

Address Mode............................................................................................................. 193
IP Address...................................................................................................................193
Subnet Mask............................................................................................................... 193
Apply........................................................................................................................... 194

Address Mode
Selects the mode for assigning the IP address of the external frontend.
"Auto (DHCP)"

Assigns the IP address automatically, provided the network supports
DHCP (Dynamic Host Configuration Protocol).

"Static" Enables you to assign the IP address manually.
Remote command: 
n.a.

IP Address
Displays the IP address of the external frontend in the network.
To assign an IP address manually, select "Address Mode" > "Static".
By default, the external frontend is configured to use dynamic TCP/IP configuration
and to obtain the whole address information automatically.
If the network does not support DHCP or the attempt does not succeed, the external
frontend tries to obtain the IP address via Zeroconf (APIPA) protocol. IP addresses
assigned via Zeroconf start with the number blocks 169.254.*.*.
Note: An IP address that is assigned via the Zeroconf protocol although the network
requires an IP address assigned via the DHCP server can cause network connection
failures.
Remote command: 
[:SOURce<hw>]:EFRontend:IPADdress? on page 523

Subnet Mask
Displays the bit group of the subnet in the host identifier.
To assign the subnet mask manually, select "Address Mode" > "Static".
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Remote command: 
n.a.

Apply
Applies any changes to the network configuration of the external frontend.
Beware that if you change the network configuration, the connection is aborted and
you must re-establish a connection to the frontend.
See "To configure the R&S SFI100A for frontend control" on page 37.
Remote command: 
[:SOURce<hw>]:EFRontend:NETWork on page 524

7.1.3.6  External devices settings

External devices are available for the following external frontends:
● R&S FE170ST
● R&S FE110ST

Access:

1. Select "RF Out" > "RF Frontend" > "Frontend Device".

2. Select "External Devices".

The tab provides information about connected external devices.

Refresh External Devices............................................................................................195
External Device 1 / External Device 2.........................................................................195

└ Connected Device.........................................................................................195
└ Type.............................................................................................................. 195
└ Frequency Range......................................................................................... 195
└ Gain.............................................................................................................. 195
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Additional External Device Correction.........................................................................195
└ State..............................................................................................................196
└ Load Correction File......................................................................................196

Refresh External Devices
Updates the display of external devices connected to the external frontend.
Remote command: 
[:SOURce<hw>]:EFRontend:EXTDevice:REFResh on page 525

External Device 1 / External Device 2
You can connect up to two external devices to the external frontend.

Connected Device ← External Device 1 / External Device 2
Queries the name of the connected external device.
Remote command: 
[:SOURce<hw>]:EFRontend:EXTDevice<id>:NAME? on page 526

Type ← External Device 1 / External Device 2
Queries the type of the connected external device.
FILTer A filter is connected to the frontend as an external device.
AMPLifier An amplifier is connected to the frontend as an external device.
ATTenuator An attenuator is connected to the frontend as an external device.
NONE No external device is connected to the frontend.
Remote command: 
[:SOURce<hw>]:EFRontend:EXTDevice<id>:TYPE? on page 526
[:SOURce<hw>]:EFRontend:EXTDevice:LIST? on page 526

Frequency Range ← External Device 1 / External Device 2
Queries the minimum and maximum value of the frequency of the connected external
device.
Remote command: 
[:SOURce<hw>]:EFRontend:EXTDevice<id>:FREQuency:MINimum?
on page 527
[:SOURce<hw>]:EFRontend:EXTDevice<id>:FREQuency:MAXimum?
on page 527

Gain ← External Device 1 / External Device 2
Queries the gain of the amplifier connected as external device.
Remote command: 
[:SOURce<hw>]:EFRontend:EXTDevice<id>:GAIN? on page 527

Additional External Device Correction
You can load user-defined correction files for the connected external devices, e.g. to
compensate for signal losses.
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State ← Additional External Device Correction
Activates correction of the RF signal for different RF signal frequencies for the connec-
ted external devices.
Activation requires loading of a valid correction file, see "Load Correction File"
on page 196.
Remote command: 
[:SOURce<hw>]:EFRontend:EXTDevice:CORRection:STATe on page 527

Load Correction File ← Additional External Device Correction
Accesses a standard file-select dialog to load correction data, e.g. to compensate for
signal losses in the external device occurring at different RF signal frequencies.
If a correction file with a file extension *.s2p is loaded, the button also displays the
filename.
Remote command: 
[:SOURce<hw>]:EFRontend:EXTDevice:CORRection:FILE on page 527

7.1.3.7  LO config settings

Access:

1. Select "RF Out" > "RF Frontend" > "Frontend Device".

2. Select "LO Config".

The tab provides settings for configuring the local oscillator when using more than
one external frontend in a test setup.

Settings:

Mode........................................................................................................................... 196
Out State..................................................................................................................... 197
Mandatory LO IN Frequency.......................................................................................197
LO OUT Frequency.....................................................................................................197

Mode
Selects the LO input source for the connected external frontend.
INTernal Uses the internally generated LO signal.
EXTernal Uses an externally supplied LO signal.
Remote command: 
[:SOURce<hw>]:EFRontend:LOSCillator:MODE on page 528
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Out State
Activates or deactivates the LO output of the connected external frontend.
Remote command: 
[:SOURce<hw>]:EFRontend:LOSCillator:OUTPut:STATe on page 528

Mandatory LO IN Frequency
Requires "Mode > External".
Displays the required frequency on the "LO In" connector of the connected external
frontend.
Set the displayed frequency value for the externally supplied LO signal correctly on the
external frequency source.
Remote command: 
[:SOURce<hw>]:EFRontend:LOSCillator:INPut:FREQuency? on page 528

LO OUT Frequency
Requires "Out State > On".
Displays the current frequency on the "LO Out" connector of the connected external
frontend.
Remote command: 
[:SOURce<hw>]:EFRontend:LOSCillator:OUTPut:FREQuency? on page 528

7.1.4  Troubleshooting external frontends

If problems arise during external frontend control, try the following measures to opti-
mize the connection.

Resolving network connection errors

If you cannot connect to the external frontend, check the status bar or error queue of
the R&S SFI100A for error messages. See Table 7-1.

If no messages are available, check the "LAN" and "Power" status LEDs on the exter-
nal frontend. Permanent red lights indicate an error, usually hardware problems, e.g. if
the fans are off. In this case, the instrument is automatically put in a safe (error) state
to avoid damage. A LAN connection is no longer possible. Try switching the external
frontend off and on again.

Handling touchstone file errors

Some errors concerning .s2p correction files do not cause warnings in the status bar.
Also, they do not provide results in the system error queue, but do display messages
or return errors in remote control.

Error messages

If errors occur, status messages in the external frontend configuration dialog box and in
the status bar of the display inform you about them.
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Query the error message queue using the remote command SYST:ERR? to determine
if any or which errors occurred during operation.

If any errors occur that are not described here, contact the Rohde & Schwarz customer
support.

Table 7-1: Status and error messages

Status bar message Dialog status SYST:ERR? result Description/Remedy

External Frontend [x]:
Connecting...

Connecting...  Connection to the external frontend is being estab-
lished.

It can take up to 10 seconds to determine that LAN
connection failed.

Connected Connected  Connection established, ready for operation.

No External Frontend
Connected

Not connected  No external frontend detected.

Connect an external frontend to the R&S SFI100A.

External Frontend [x]:
Invalid Host IP

Invalid Host IP 300, "Invalid Host
IP"

Verify the specified IP address of the external fron-
tend.

External Frontend [x]:
LAN Connection Failed

Not connected 301, "LAN Connection
Failed"

Verify if the external frontend is connected to the
same network as the R&S SFI100A.

Verify the specified IP address of the external fron-
tend.

Make sure that no other instrument is accessing
the external frontend at the moment.

External Frontend [x]:
Incompatible Signal
Generator Firmware

Incompatible Signal
Generator Firmware

302, "Incompatible
Signal Generator
Firmware"

The frontend hardware is not compatible with the
installed signal generator firmware.

Update the signal generator firmware, see the
R&S SFI100A service manual.

External Frontend [x]:
Incompatible Frontend
Firmware

Incompatible Fron-
tend Firmware

303, "Incompatible
Frontend Firmware"

The firmware of the external frontend is not up to
date.

Perform a firmware update of the external frontend.

External Frontend [x]:
Device Locked

Device Locked 304, "Device Locked" The external frontend is accessible via ping, but no
SSL-connection could be established.

Disconnect all other devices that are currently
accessing the external frontend and try reconnect-
ing.

External Frontend [x]:
Wrong Device Type

Wrong Device Type 306, "Wrong Device
Type"

The connected external frontend is not of the
specified type.

Disconnect the device, select the correct external
frontend type in the configuration dialog box, and
reconnect.

External Frontend [x]:
LAN Connection Lost

LAN Connection Lost 314, "LAN Connection
Lost"

The connection to the external frontend has been
lost.

The signal generator attempts to reconnect periodi-
cally. Wait for the "Connecting…" message.

External Frontend [x]:
Firmware Update Failed

Firmware Update
Failed

315, "Firmware
Update Failed"

The firmware of the external frontend was not
updated successfully.

 <filename>.s2p has
wrong file format

-150, "String data
error"

The .s2p file does not have the correct syntax.

Correct the file.
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Status bar message Dialog status SYST:ERR? result Description/Remedy

  -256, "File name not
found"

The specified .s2p file does not exist.

Correct the path and filename and make sure that
the file is stored on the instrument
under /var/user//external_frontends/
<frontend_type>/touchstonefiles.

External Frontend [x]:
Touchstone file insuffi-
cient frequency range

 350, "Touchstone
file frequency range
insufficient"

The .s2p file does not cover the used frequency.

Correct the file or select a different correction file.

If you still have connection problems, contact Rohde & Schwarz, see Chapter 14.10,
"Contacting customer support", on page 626.

7.2  Configuring RF signals

This chapter provides information on how to define the settings for your RF signal.

See also Chapter 7.3, "RF settings", on page 200.

To access the RF settings

1. In the block diagram, select the block "RF > RF".

2. Select the required function from the list.
The RF block comprises all functions and settings concerning the RF signal. The
settings include the RF frequency and level settings, enhanced functions for
improving the signal characteristics, frontend device settings, connector assign-
ments and measurement functions of the RF signal.

To set the frequency and level

The simplest form of the RF signal is a continuous wave (CW) of constant frequency
and amplitude. The RF signal is defined by its frequency and level.

1. In the status bar, enter the "Frequency" value.

2. If you want to add a frequency offset:

a) Select "RF > RF Frequency > Frequency".
b) Enter the "Offset" value.

3. In the status bar, enter the "Level" value.

4. If you want to add a level offset:

a) Select "RF > RF Level > Level".
b) Enter the "Offset" value.
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To activate the RF output

By default, the RF output signal is disabled. When you activate the RF output, the
instrument restores the previously set signal configuration.

► Activate the RF output in one of the following ways:

a) Select "Level > RF ON > On".
b) At the front panel, press the [RF on/off] key.

The blue color of the "RF On" icon and the RF block indicate that the RF signal out-
put is enabled.

RF State/RF ON..........................................................................................................200
PEP............................................................................................................................. 200
RF output impedance..................................................................................................200

RF State/RF ON
Activates or deactivates the RF output.
Acts as the [RF On/Off] key.
Remote command: 
:OUTPut<hw>[:STATe] on page 443

PEP
Displays the PEP (Peak Envelope Power) in the status bar. This value corresponds to
the level specification of a digital modulation or of a digital standard signal at the RF
output.
Remote command: 
[:SOURce<hw>]:POWer:PEP? on page 508

RF output impedance
You can query the impedance of the RF output.
Remote command: 
:OUTPut<hw>:IMPedance? on page 444

7.3  RF settings

7.3.1  RF frequency settings

Access:

► Select "RF" > "RF Frequency" > "Frequency".
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In the "RF Frequency" dialog, you can configure the RF frequency and an offset.
The remote commands required to define the settings are described in Chap-
ter 13.15.4, "SOURce:FREQuency subsystem", on page 491.

Settings:

Frequency................................................................................................................... 201
Offset...........................................................................................................................201

Frequency
Sets the RF frequency.
This frequency is output at the RF Out connector.
It does not consider any parameter that affect the frequency, as e.g., a frequency off-
set.
Note: Suppressed values in the status bar
For security concerns or certain operating modes, you can hide the frequency and
level display in the status bar.
●

The display has been disabled for security reasons.
See:
– Annotation Frequency

●

Remote command: 
[:SOURce<hw>]:FREQuency[:CW|FIXed] on page 491

Offset
Sets the frequency offset.
This value represents the frequency shift of a downstream instrument, like for example
a mixer.
The "Frequency" value displayed in the status bar is the resulting frequency, as it is at
the output of the downstream instrument. The frequency at the R&S SFI100A RF out-
put is not changed.
Remote command: 
[:SOURce<hw>]:FREQuency:OFFSet on page 492
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7.3.2  RF level settings

Access:

1. Select "RF" > "RF Level" > "Level".

In the "RF Level" dialog, you can configure the offset-free level, the level limit, and
the step width for varying the level with the rotary knob.

2. Select "User Variation" to set the step width to be used when setting the RF level
using the rotary knob.

The remote commands required to define the settings are described in Chap-
ter 13.15.9, "SOURce:POWer subsystem", on page 505.

Settings:

RF State/RF ON..........................................................................................................203
Amplitude.................................................................................................................... 203
Limit.............................................................................................................................203
Offset...........................................................................................................................203
Setting Characteristics................................................................................................ 204
Level Range................................................................................................................ 204
User Variation..............................................................................................................204

└ Variation Active............................................................................................. 204
└ Variation Step................................................................................................204
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RF State/RF ON
Activates or deactivates the RF output.
Acts as the [RF On/Off] key.
Remote command: 
:OUTPut<hw>[:STATe] on page 443

Amplitude
Sets the level of the RF signal.
The value is offset-free and corresponds to the level at the RF Out connector.
Note: Suppressed values in the status bar
For security concerns or certain operating modes, you can hide the frequency and
level display in the status bar.
●

The display has been disabled for security reasons.
See:
– Annotation Frequency

●

Remote command: 
[:SOURce<hw>]:POWer:POWer on page 508
Note: The SCPI command [:SOURce<hw>]:POWer[:LEVel][:IMMediate][:
AMPLitude] sets the level of the "Level" display.
This means, the level containing offset.

Limit
Sets an upper limit for the output power.
Note: The parameter "RF level" > "Limit" and "NRP power control" > "RF Amplitude
Limit" are identical.
You can use this value to protect your DUT from damage due to high input power. If
you enter an RF level above this value, the instrument limits the output power to this
specified value, and generates the warning message:
"Pep value greater than the defined limit." However, the level indication in the status
bar is not affected.
The setting is not affected by an instrument preset ([Preset] key or *RST) and the
"Save/Recall" function. It is reset only by factory preset.
Remote command: 
[:SOURce<hw>]:POWer:LIMit[:AMPLitude] on page 507

Offset
Sets a level offset.
This value represents the level shift of a downstream instrument, like, for example, an
attenuator or an amplifier.
The "Level" value displayed in the status bar is the resulting level, as it is at the output
of the downstream instrument. The level at the R&S SFI100A RF output is not
changed.
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Remote command: 
[:SOURce<hw>]:POWer[:LEVel][:IMMediate]:OFFSet on page 512

Setting Characteristics
Selects additional quality characteristics to optimize the behavior of the RF signal level
for the specific application.
"Auto" Sets the RF output level automatically according to the selected

mode.
In this mode, the instrument provides the highest dynamic range and
fastest setting times.
The RF signal is shortly blanked when the step attenuator is switch-
ing.
For more information, refer to the specifications document.

"Uninterrupted"
Suppresses blanking at level transitions. Frequency transitions can
lead to an RF level blanking due to hardware-specific switching
points.
This mode reduces the dynamic range of the instrument. The step
attenuator is fixed.

Remote command: 
[:SOURce<hw>]:POWer:LBEHaviour on page 507

Level Range
Shows the interruption-free range of the level that you can use in the currently selected
mode.
Remote command: 
[:SOURce<hw>]:POWer:RANGe:LOWer? on page 514
[:SOURce<hw>]:POWer:RANGe:UPPer? on page 514

User Variation
Defines and activates a user-defined step width for varying the RF frequency or RF
level with the rotary knob.
If disabled, the step width varies in steps of one unit at the cursor position.

Variation Active ← User Variation
Activates the set user-defined step width.
Remote command: 
[:SOURce<hw>]:FREQuency:STEP:MODE on page 492
[:SOURce<hw>]:POWer:STEP:MODE on page 511

Variation Step ← User Variation
Sets the user-defined step width.
Remote command: 
[:SOURce<hw>]:FREQuency:STEP[:INCRement] on page 493
[:SOURce<hw>]:POWer:STEP[:INCRement] on page 512
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7.4  Generating reference signals

This chapter provides information on reference input signals and reference output sig-
nals. It covers the following topics:

● Required options...................................................................................................205
● RF connector settings........................................................................................... 205
● Reference frequency settings............................................................................... 206
● Reference output settings..................................................................................... 209
● Adjustment settings...............................................................................................211

7.4.1  Required options

R&S SFI100A base unit equipped with the following options:
● 100 MHz, 1 GHz ultra-low-noise reference input and output (R&S SFI-K703)
● 1 MHz to 100 MHz flexible reference input (R&S SFI-K704)
● 8 GHz ultra-low-noise reference input and output (R&S SFI-K708)

For more information, refer to the specifications document.

7.4.2  RF connector settings

The "RF Connectors" dialog gives an overview of the mapping of the logical signals to
the connectors. The displayed connectors depend on the installed options.

Selecting a signal name accesses directly the related connector settings.

Access:

1. Select "RF" > "RF Frequency" > "RF Connectors".

The dialog shows the assignment of the logical signals to the connectors.

Generating reference signals
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2. Select a "Signal" to open the corresponding settings dialog.

3. Use the built-in Show Connector function to display the physical location of the
selected connector.

The eye icon  in the tab header indicates the panel (front, rear or both) the
selected connector is at.

Settings:

Signal.......................................................................................................................... 206
Connector....................................................................................................................206
Show Connector..........................................................................................................206

Signal
Opens the dialog for configuring the selected signal.

Connector
Displays the assigned connector.

Show Connector
Accesses a dialog that displays the physical location of the selected connector on the
front/rear panel of the instrument.

7.4.3  Reference frequency settings

Access:

► Select "RF" > "RF Frequency" > "Reference Frequency".

Generating reference signals
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In the "Reference Frequency" tab, you can select the reference frequency signal
source and the frequency and synchronization bandwidth mode of an external ref-
erence signal.

The symbol in the status bar indicates the current oscillator configuration.

The remote commands required to define these settings are described in Chap-
ter 13.15.8, "SOURce:ROSCillator subsystem", on page 499.

Settings:

Set to Default.............................................................................................................. 207
Source.........................................................................................................................207
Show Connector..........................................................................................................208
Deactivate RF Output (if external reference is missing)..............................................208
External Reference Frequency................................................................................... 208
Variable Reference Frequency....................................................................................208
Synchronization Bandwidth.........................................................................................209
Nominal Synchronization Bandwidth...........................................................................209
Minimum Locking Range.............................................................................................209

Set to Default
Resets the reference oscillator settings to default.
Remote command: 
[:SOURce]:ROSCillator:PRESet on page 503

Source
Selects the reference frequency source.

Generating reference signals
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"Internal" Uses the internal reference oscillator, either with calibrated or a user-
defined Adjustment Value.
Note: The internal reference frequency automatically uses Synchroni-
zation Bandwidth > Narrow. Thus, if you preset this parameter, or set
the reference source from "External" to "Internal" manually, the
R&S SFI100A sets the bandwidth to "Narrow".

"External" Uses an external reference signal.
Note: If the external reference is missing, the R&S SFI100A issues a
warning message and indicates the icon  (external reference miss-
ing).
To set the frequency of the external reference, see "External Refer-
ence Frequency".

Remote command: 
[:SOURce]:ROSCillator:SOURce on page 504

Show Connector
Accesses a dialog that displays the physical location of the selected connector on the
front/rear panel of the instrument.

Deactivate RF Output (if external reference is missing)
Turns off the RF output when the external reference signal is selected, but no signal is
supplied.
This function prevents that no improper RF signal due to the missing external refer-
ence signal is used for measurements. A message indicates that the RF output is
deactivated.
Remote command: 
[:SOURce]:ROSCillator:EXTernal:RFOFf[:STATe] on page 502

External Reference Frequency
Selects the frequency of the external reference input signal.
"10 MHz" Selects an external reference frequency of 10 MHz.

"100 MHz"/"640 MHz"/"1 GHz"
Requires R&S SFI-K703.
Selects an external reference frequency of 100 MHz, 640 MHz or
1 GHz.

"Variable" Requires R&S SFI-K704.
The external reference signal has an arbitrary frequency, within the
range from 1 MHz to 250 MHz.

"8 GHz" Requires R&S SFI-K708.
Selects an external reference frequency of 8 GHz.

Remote command: 
[:SOURce]:ROSCillator:EXTernal:FREQuency on page 500

Variable Reference Frequency
Option: R&S SFI-K704
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Sets the variably settable external reference frequency.
Remote command: 
[:SOURce]:ROSCillator:EXTernal:FREQuency:VARiable on page 501

Synchronization Bandwidth
Selects the synchronization bandwidth for an external reference signal, set with
"Source > External".
The resulting bandwidth is indicated by the parameter Nominal Synchronization Band-
width.
Note: If you preset or set the reference source from "External" to "Internal", the
R&S SFI100A resets the synchronization bandwidth to "Narrow".

"Narrow" The internal reference oscillator is synchronized to the external signal
with narrow bandwidth.
This setting is recommended if the phase noise of the external signal
is worse than the phase noise of the internal OCXO.

"Wide" Synchronizes the internal oscillator to the external signal with the
maximum possible bandwidth.
This mode is the recommended standard mode and for precise refer-
ence sources of high spectral purity.
Note: If the frequency of the external reference signal is outside the
locking range of the internal reference oscillator, spurs due to the dif-
ference of the internal and external reference frequency are gener-
ated in the reference PLL.
The R&S SFI100A issues an error message.
For more information, refer to the specifications document.

Remote command: 
[:SOURce]:ROSCillator:EXTernal:SBANdwidth on page 502

Nominal Synchronization Bandwidth
Indicates the nominal synchronization bandwidth for the selected external reference
frequency and the synchronization bandwidth.
Remote command: 
[:SOURce]:ROSCillator:EXTernal:NSBandwidth? on page 501

Minimum Locking Range
Indicates the minimum locking range for the selected external reference frequency and
the synchronization bandwidth.
Remote command: 
[:SOURce]:ROSCillator:EXTernal:MLRange? on page 501

7.4.4  Reference output settings

Access:

1. Select "RF" > "RF Frequency" > "Reference Frequency".
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2. Select "Reference Output".

In the "Reference Output" tab, you can set the reference frequency value at the
output connectors.
As a result of parameter dependencies, "Preset This Parameter" sometimes does
not affect output dialogs.

The remote commands required to define these settings are described in Chap-
ter 13.15.8, "SOURce:ROSCillator subsystem", on page 499.

Settings:

Reference Output........................................................................................................210
Show Connector..........................................................................................................211

Reference Output
Selects the frequency of the reference output signal for downstream instruments.
The R&S SFI100A derives a reference signal from the internal reference oscillator, or
loops through an externally applied reference signal for output. The R&S SFI100A pro-
vides three output connectors for a reference signal.
The settings at "Reference Output 1" and "Reference Output 2" also depend on the set
external reference frequency.
The reference input and output signals require the corresponding frequency options,
see Chapter 7.4.1, "Required options", on page 205.
"Off" Disables the reference signal output.
"10 MHz"/"100 MHz"

Derives the selected frequency from the internal reference oscillator
and provides this signal at reference output 1.

"1 GHz"/"8 GHz"
Derives the selected frequency from the internal reference oscillator
and provides this signal at reference output 2.

"16 GHz" Provides 16 GHz reference frequency at reference output 3.

"Signal from Ref Input <n> (loop through)"
<n> = 1 to 2
Passes the external reference frequency to the output directly. You
can pass through frequencies of 10 MHz or 100 MHz.
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Remote command: 
[:SOURce]:ROSCillator:OUTPut:FREQuency:MODE on page 502
[:SOURce]:ROSCillator:OUTPut2:FREQuency:MODE on page 503
[:SOURce]:ROSCillator:OUTPut3:FREQuency:MODE on page 503

Show Connector
Accesses a dialog that displays the physical location of the selected connector on the
front/rear panel of the instrument.

7.4.5  Adjustment settings

Access:

1. Select "RF" > "RF Frequency" > "Reference Frequency".

2. Select "Adjustment".

Settings:

Adjustment Active........................................................................................................211
Adjustment Value.........................................................................................................211

Adjustment Active
Selects the adjustment mode.
"Off" Uses the calibrated internal reference frequency.
"On" Allows you to apply a deviation to the internal reference frequency,

according to your requirements.
Enter the value in the Adjustment Value field.

Remote command: 
[:SOURce]:ROSCillator[:INTernal]:ADJust[:STATe] on page 504

Adjustment Value
Sets a user-defined adjustment value for the internal reference frequency. This value
takes effect when it is activated with Adjustment Active.
● "0" represents the calibrated state.
● The setting range depends on the reference oscillator type and its factory calibra-

tion value.
Note:
The setting is not affected by an instrument preset ([Preset] key or *RST) and the
"Save/Recall" function. It is reset only by factory preset.
Remote command: 
[:SOURce]:ROSCillator[:INTernal]:ADJust:VALue on page 504
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7.5  Using power sensors

The R&S SFI100A works with any of the R&S NRP power sensors and thus supports
various application tasks. Using power sensors, you can for example determine attenu-
ation characteristics of downstream equipment or cables. You can use the measured
values to compensate the losses with internal control functions or with an external con-
trol circuit in real time.

For information on the various possibilities of interoperability between
Rohde & Schwarz power sensors and Rohde & Schwarz signal generators, see the
application note 1GP141.

R&S NRP power sensors are highly accurate standalone measuring devices, suitable
for a wide range of applications. The power sensors communicate directly with the sig-
nal generator, calculate the average or peak power internally, include S-parameter cor-
rection and return the measurement results to the generator.

The R&S SFI100A supports up to four power sensors, allowing up to four power mea-
surements simultaneously.

Check the firmware version of the R&S NRP sensors regularly. Update the firmware, if
necessary.
For updates, see the Rohde & Schwarz website www.rohde-schwarz.com in section
"Power Meters & Voltmeters".

For information on working with power sensors, see the following topics:
● Chapter 7.5.2, "Connecting R&S NRP power sensors to the R&S SFI100A",

on page 214
Overview on the supported connectors, connection options and the required acces-
sories.

● Chapter 7.5.3, "NRP power viewer settings", on page 215
A function for measuring and monitoring the RF output power or a user-defined sig-
nal source.

● Chapter 7.5.4, "NRP power control", on page 216
Controls a downstream closed loop power control circuit, to compensate frequency
response characteristics.

● Chapter 7.5.5, "NRP sensor configuration", on page 221
Parameter settings of the specific R&S NRP power sensor.

● Chapter 7.5.6, "NRP sensor mapping", on page 225
Shows all R&S NRP sensors connected to the instrument, or in the LAN.

7.5.1  About

The R&S SFI100A can perform up to four power measurements simultaneously.

Depending on the signal characteristic (CW, AM, pulsed, etc.) or the parameter to be
measured (average, peak, etc.) a suitable R&S power sensor must be used.

Using power sensors
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About the measuring principle, averaging filter, filter length, and achieving stable
results

A sensor measures the average or peak RF power of the source continuously. The
measurement results are displayed in the "NRP Power Viewer" dialog.

The power viewer function uses averaging filters for getting a stable readout.

Measurement results could be interfered, for instance, by too much noise in your
setup, by a bad suppression of harmonics or non-harmonics or when you reach the
sensitivity level of your power sensor.

Measurements are continuously repeated in a predefined time window. The measure-
ment result is obtained by averaging the measured values for the last 2N time win-
dows. This approach is referred as a two-step averaging process.

The factor of 2 in the formula arises because the output signals from the microwave
detector are chopped at the same rate as the time windows to suppress low-frequency
noise. An independent measured value can only be obtained from two consecutive val-
ues.

The variable N in the formula indicates the filter length. The filter length then directly
influences the measurement time. The filter length can be selected automatically or it
can be manually set to a fixed value.

Follow the following general recommendation to find out the optimum filter length:
● Always start a measurement in auto mode ("Filter > Auto").

Check if the measurement results are sufficient.
● If the power is not constant, select the filter length manually ("Filter > User").

Trigger the "Auto Once" function to search for the optimum filter length for the cur-
rent measurement conditions.
The estimated value is indicated as filter length.

● If the target measurement accuracy value is known, select "Filter > Fixed Noise".
The averaging factor is selected automatically and so that the sensor's intrinsic
noise (two standard deviations) does not exceed the specified noise content.

● Depending on the R&S NRP power sensor type, the manual setting of the filter
length varies in resolution.

● Different sensor types achieve the same filtering result with different filter and time
window lengths.
For most sensors, the time window length is fixed to 20 ms, whereas, e.g., for the
R&S NRP-Z81 sensor, the time window length is 10 μs.

For more information, refer to the specifications document.

About zeroing

Activates the auto zero function.
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Zeroing calibrates the external power sensor by adjusting its reading at zero signal
power. For this purpose, the RF power source must be switched off or disconnected
from the sensor. If a Rohde & Schwarz power sensor receives an input power during
the zeroing process, it aborts zeroing and generates an error message. Zeroing takes
a few seconds, depending on the sensor model. Refer to the documentation of your
power sensor for more information.

Tips for zeroing

When to perform zeroing:
● During warm up after switching on or connecting the instrument
● After a substantial change of the ambient temperature
● After fastening the power sensor module to an RF connector at high temperature
● After several hours of operation
● When low-power signals are to be measured, e.g. less than 10 dB above the lower

measurement limit.
● Switch off the RF power source for zeroing, but do not disconnect it from the power

sensor. This proceeding keeps the thermal equilibrium, and the zeroing process
also compensates the noise that superimposes the measured signal (e.g. from a
broadband amplifier).

Related settings and functions

● Measurements-related settings, like results, filter, filter length:
Chapter 7.5.5, "NRP sensor configuration", on page 221

● Closed loop power control of the output level:
Chapter 7.5.4, "NRP power control", on page 216.

● Software version of the connected power sensor:
:SENSe<ch>[:POWer]:TYPE? on page 459

● Acquisition of level correction data:
Chapter 7.6, "Applying user correction", on page 228

Additional information

See the Rohde & Schwarz website www.rohde-schwarz.com, section "Power Meters &
Voltmeters" for:
● R&S NRP power sensor manual.
● Information on the R&S NRP-Z5 sensor hub and the available accessories.
● Sensor software updates.

7.5.2  Connecting R&S NRP power sensors to the R&S SFI100A

Connection Sensor type (incl. USB hub) Cables/Acessories Characteristics

USB type A R&S NRPxx R&S NRP-ZKU USB interface cable

 R&S NRP-Zxx R&S NRP-Z3

R&S NRP-Z4

USB adapter cables

Using power sensors
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Connection Sensor type (incl. USB hub) Cables/Acessories Characteristics

 R&S NRP-Z5 USB sensor
hub (high-speed USB 2.0)

Standard USB cable (USB
type A to USB type B)

This connection does
not support external
triggering.

 Standard USB hub with exter-
nal power supply unit

R&S NRPxx

R&S NRP-ZKU USB interface cable

 Standard USB hub with exter-
nal power supply unit

R&S NRP-Zxx

R&S NRP-Z3

R&S NRP-Z4

USB adapter cables

LAN R&S NRPxxxSN/xxxTN/
xxxAN

● A PoE Ethernet switch,
e.g. R&S NRP-ZAP1 and
an RJ-45 Ethernet cable.

● A PoE injector and an
RJ-45 Ethernet cable.

Using the Ethernet
interface requires
PoE (Power over
Ethernet) to provide
the electrical power.

For details, see the description R&S®NRP Power Sensors getting started.

Detection and mapping

The R&S SFI100A either detects a R&S NRP power sensor automatically or you can
scan for available power sensors manually. The "NRP Sensor Mapping" dialog lists all
detected R&S NRP power sensors, see Chapter 7.5.6, "NRP sensor mapping",
on page 225. The dialog enables you to add, remove and map the sensors manually.

Depending on the connection interface, the R&S SFI100A detects and maps connec-
ted R&S NRP power sensors differently:
● USB interface

Detects a sensor automatically and maps it with index "1" to index "4" according to
the sequence of connection.

● LAN interface
To detect sensors that are connected in the LAN, the instrument provides a scan
function. When you start the function, scan searches in the LAN for available R&S
NRP power sensors and adds all detected sensors to list. Assigning a mapping
index activates the sensor for the measurement.

On connection, the R&S SFI100A immediately starts the measurement of the R&S
NRP power sensor. If you preset the instrument ([Preset] key or *RST), the
R&S SFI100A stops the measurement. The connection and the mapping of the power
sensors remain.

7.5.3  NRP power viewer settings

The R&S SFI100A features the power viewer function for measuring or monitoring sig-
nals with R&S NRP power sensors.
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Access:

► Select "RF" > "RF Measurement" > "NRP Power Viewer".

The "Power Viewer" tab lists the mapped R&S NRP power sensors with the mea-
sured parameter mode and the current readings. The "Config" button leads you to
the configuration dialog to set the parameters for each sensor.

The remote commands required to define these settings are described in Chap-
ter 13.13, "SENSe, READ, INITiate and SLISt subsystems", on page 445, including
the triggering of the measurement and the retrieval of measurement results.

Settings:

Config..........................................................................................................................216

Config
Opens the "Sensor Configuration" dialog.
See also Chapter 7.5.5, "NRP sensor configuration", on page 221.

7.5.4  NRP power control

The NRP power control function enables you to apply stable and accurate RF power to
the DUT. For example, you can set up a downstream closed loop power control circuit
to compensate spurious effects or losses caused by power amplifiers or cables.
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Example: How to set up a closed loop power control

DUT

Power 
sensor

Signal generator
Amplifier x dB 

Coupler

Measured level

RF  level Input level

Figure 7-5: Example of a test setup with NRP power control

The signal generator applies the RF output signal to an amplifier and to the DUT. An
intermediately connected coupler derivates the output power from the output signal
and forwards it to the power sensor. Thus, the power sensor measures a proportional
power in defined time intervals, and returns the results to the signal generator. If sup-
ported, the power sensor also includes given S-parameters. The signal generator com-
pares the measured power with the set level value and adjusts the level of the output
signal accordingly.
This closed loop power control enables you to control the external signal level continu-
ously and reliably achieve a constant input power at the DUT in real time.

Impact of NRP power control and operating modes
Since the frequency and level of the RF output signal are continuously adjusted during
"NRP Power Control", this operating mode interferes signal generation modes with
varying frequency and level values. In addition, the setting time increases. The reason
is the interaction between the signal generator and the R&S NRP power sensor in the
control loop.
The operating modes impact each other as follows:
● Enabling the RF frequency sweep, RF level sweep or the list mode disables a run-

ning "NRP Power Control".
● A running list or RF sweep mode blocks "NRP Power Control".
● Modulated signals can deviate from the CW signal in mean power and peak power,

and thus affect the "NRP Power Control".

7.5.4.1  NRP power control settings

Access:

► Select "RF" > "RF Measurement" > "NRP Power Control".
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In this dialog you can configure the parameters of the power control setup for the
selected power sensor.
The remote commands required to define these settings are described in Chap-
ter 13.15.9, "SOURce:POWer subsystem", on page 505.

Settings

State............................................................................................................................218
Sensor.........................................................................................................................218
Measured Level...........................................................................................................219
Target Level.................................................................................................................219
Take Measurement as Target Level............................................................................ 219
Mode........................................................................................................................... 219
Execute Single............................................................................................................ 219
Catch Range +/-..........................................................................................................219
Delay Time.................................................................................................................. 220
Limit.............................................................................................................................220
Setting Characteristics................................................................................................ 220

State
Enables power control with the selected sensor.
The control loop periodically adjusts the generator output. After switching off, the run-
ning loop is completed.
Note: If you want to use another sensor, you must disable power control before. It is
not possible to switch between sensors when power control is active.
Remote command: 
[:SOURce<hw>]:POWer:SPC:STATe on page 510

Sensor
Indicates the R&S NRP power sensor that is selected for power control.
To configure the power sensor parameters, see Chapter 7.5.5, "NRP sensor configura-
tion", on page 221.
Remote command: 
[:SOURce<hw>]:POWer:SPC:SELect on page 510
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Measured Level
Indicates the current reading of the selected power sensor.
Remote command: 
:READ<ch>[:POWer]? on page 451
:SENSe<ch>:UNIT[:POWer] on page 452

Target Level
Specifies the nominal level expected at the input of the sensor. The signal generator
adjusts the output power accordingly, to meet the target value at the sensor input, and
thus the power required at the DUT.
Remote command: 
[:SOURce<hw>]:POWer:SPC:TARGet on page 511

Take Measurement as Target Level
Uses the currently measured level as reference and applies the value as target level,
see "Target Level" on page 219.
This feature simplifies setting up the control loop after manual adjustment of the mea-
surement configuration. To assign the measured level as reference level, you must
switch off "NRP Power Control". It is not possible when the control loop is running.
Remote command: 
[:SOURce<hw>]:POWer:SPC:MEASure on page 509

Mode
Selects the measurement mode for acquiring the power values measured by the sen-
sor.
"Auto" Immediately starts and measures the power continuously.
"Single" Starts when you manually select Execute Single, and executes one

power measurement cycle.
Note, that you can achieve the expected target power level at the
DUT only with linear test setups. Non-linear test setups, for example,
setups including an amplifier do not work.

Remote command: 
[:SOURce<hw>]:POWer:SPC:MODE on page 509

Execute Single
In mode "Single", starts one measurement cycle manually.
Remote command: 
[:SOURce<hw>]:POWer:SPC:SINGle on page 510

Catch Range +/-
Sets the capture range of the control system.
Within the range:
Target Level +/- Catch Range

the power control locks and tries to achieve the target level. Readings outside the
range are not considered.
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Remote command: 
[:SOURce<hw>]:POWer:SPC:CRANge on page 509

Delay Time
Sets a waiting period between the level adjustment of the generator and the next mea-
surement of the power sensor.
With this parameter, you can bypass idle times in the controlled system.
Remote command: 
[:SOURce<hw>]:POWer:SPC:DELay on page 509

Limit
Sets an upper limit for the output power.
Note: The parameter "RF level" > "Limit" and "NRP power control" > "RF Amplitude
Limit" are identical.
You can use this value to protect your DUT from damage due to high input power. If
you enter an RF level above this value, the instrument limits the output power to this
specified value, and generates the warning message:
"Pep value greater than the defined limit." However, the level indication in the status
bar is not affected.
The setting is not affected by an instrument preset ([Preset] key or *RST) and the
"Save/Recall" function. It is reset only by factory preset.
Remote command: 
[:SOURce<hw>]:POWer:LIMit[:AMPLitude] on page 507

Setting Characteristics
Selects additional quality characteristics to optimize the behavior of the RF signal level
for the specific application.
"Auto" Sets the RF output level automatically according to the selected

mode.
In this mode, the instrument provides the highest dynamic range and
fastest setting times.
The RF signal is shortly blanked when the step attenuator is switch-
ing.
For more information, refer to the specifications document.

"Uninterrupted"
Suppresses blanking at level transitions. Frequency transitions can
lead to an RF level blanking due to hardware-specific switching
points.
This mode reduces the dynamic range of the instrument. The step
attenuator is fixed.

Remote command: 
[:SOURce<hw>]:POWer:LBEHaviour on page 507
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7.5.5  NRP sensor configuration

Access:

► Select "RF" > "RF Measurement" > "NRP Sensor Configuration".

In this dialog you can configure the parameters for each mapped R&S NRP power
sensor in separate tabs.

The remote commands required to define these settings are described in Chap-
ter 13.13, "SENSe, READ, INITiate and SLISt subsystems", on page 445, including
the triggering of the measurement and the retrieval of measurement results.

Settings:

Sensor type and serial number................................................................................... 222
Level (Peak) / Level (Average)....................................................................................222
State............................................................................................................................222
Zero.............................................................................................................................222
Display........................................................................................................................ 222
Display Permanent......................................................................................................222
Use Frequency Of....................................................................................................... 223
Frequency................................................................................................................... 223
Level Offset State,Level Offset....................................................................................223
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Filter............................................................................................................................ 223
Filter Length................................................................................................................ 224
Auto Once................................................................................................................... 224
Noise/Signal Ratio.......................................................................................................224
Timeout....................................................................................................................... 224
Default Aperture Time................................................................................................. 224
Aperture Time..............................................................................................................225
S-Parameter................................................................................................................225
Enable Logging........................................................................................................... 225

Sensor type and serial number
The side tab label indicates type and serial number of an R&S NRP power sensor and
its mapping index.
The Level (Peak) / Level (Average) values display the current readings of the sensor.
Remote command: 
:SENSe<ch>[:POWer]:TYPE? on page 459
:SENSe<ch>[:POWer]:SNUMber? on page 458

Level (Peak) / Level (Average)
Indicates the measured peak or average level value.
You can also change the unit for the results display: Watt, dBm or dBμV.

Note: Peak level measurements are provided if the power sensor supports this feature.
Remote command: 
:READ<ch>[:POWer]? on page 451
:SENSe<ch>:UNIT[:POWer] on page 452

State
Enables level measurement of the R&S NRP power sensor.
Remote command: 
:INITiate<hw>[:POWer]:CONTinuous on page 450
To query the availability of a sensor at a given connector, use the command :
SENSe<ch>[:POWer]:STATus[:DEVice]? on page 458.

Zero
Activates the auto zeroing.
For details, see "About zeroing" on page 213.
Remote command: 
:SENSe<ch>[:POWer]:ZERO on page 459

Display
Sets the display of results on mean or peak power.
Remote command: 
:SENSe<ch>[:POWer]:DISPlay:PERManent:PRIority on page 453

Display Permanent
Enables the display of the power sensor with the currently measured value in the task
bar.
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You can activate the permanent display for several sensors.
Remote command: 
:SENSe<ch>[:POWer]:DISPlay:PERManent:STATe on page 454

Use Frequency Of
Selects the source for measurement.
"RF" The R&S SFI100A transfers the RF frequency and level settings to

the R&S power sensor automatically. Thus you achieve power read-
ings of high accuracy, irrespective from the connected sensor type.

"User" Sets a user defined frequency.

Example: 
If you have a frequency converting device between the generator and
the DUT. If the frequency converter doubles the frequency, you can
set twice the frequency in the R&S SFI100A. The R&S power sensor
considers this RF frequency setting.

Set the parameter Frequency to the measurement's frequency.
Remote command: 
:SENSe<ch>[:POWer]:SOURce on page 458

Frequency
Defines the frequency value if "Source > User" is used.
Remote command: 
:SENSe<ch>[:POWer]:FREQuency on page 456

Level Offset State,Level Offset
Activates and defines a level offset which is considered in the power measurement
result. The level offset value is always expressed in dB, irrespective of the display of
the measurement result.
This function allows you to consider, for example, an attenuator in the signal path.
Remote command: 
:SENSe<ch>[:POWer]:OFFSet on page 457
:SENSe<ch>[:POWer]:OFFSet:STATe on page 457

Filter
Selects the way the length of the used filter is defined.
See also "About the measuring principle, averaging filter, filter length, and achieving
stable results" on page 213.
"Auto" Selects the filter length automatically and adjusts it to the measured

value. The value is indicated with the parameter Filter Length.
When high output power is applied, the filter length and therefore the
measurement time can be short.
When low output power is applied, the filter length and therefore the
measurement time is increased which reduces the considered noise
content in your measurement.
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"User" The filter length is defined manually, with the parameter Filter Length.
As the filter length works as a multiplier for the time window, constant
filter length results in a constant measurement time.
Values 1 and 2N are allowed.

"Fixed Noise" The averaging factor is taken automatically in accordance to the
value Noise/Signal Ratio. Thus, the sensor's intrinsic noise (2 stan-
dard deviations) does not exceed the specified noise content.
To avoid long measurement times when the power is too low, set a
Timeout.
Timeout is the maximum acceptable measurement time which limits
the averaging factor and therefore leads to a more unstable readout.

Remote command: 
:SENSe<ch>[:POWer]:FILTer:TYPE on page 456

Filter Length
Sets or indicates the filter length, depending on the selected filter mode.
● "Filter > Auto" indicates the automatically adjusted filter length.
● "Filter > User" enables you to set the filter length manually.
● "Filter > Fixed Noise" hides the setting parameter.
Remote command: 
:SENSe<ch>[:POWer]:FILTer:LENGth:AUTO? on page 454
:SENSe<ch>[:POWer]:FILTer:LENGth[:USER] on page 454

Auto Once
Searches the optimum filter length for the current measurement conditions. The result
is indicated with the parameter Filter Length.
See also "About the measuring principle, averaging filter, filter length, and achieving
stable results" on page 213.
Remote command: 
:SENSe<ch>[:POWer]:FILTer:SONCe on page 455

Noise/Signal Ratio
For Filter > Fixed Noise, sets the noise content.
Remote command: 
:SENSe<ch>[:POWer]:FILTer:NSRatio on page 455

Timeout
Sets a time limit for the averaging process.
The setting is bound to the timeout of the connected sensor.
Remote command: 
:SENSe<ch>[:POWer]:FILTer:NSRatio:MTIMe on page 455

Default Aperture Time
The sensor default setting is sufficient. Disable this parameter to specify a user-defined
aperture time per sensor, if, for example, the readings vary.
To obtain stable readings, set the Aperture Time exactly to one modulation period.
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Remote command: 
:SENSe<ch>[:POWer]:APERture:DEFault:STATe on page 452

Aperture Time
If "Use Default Aperture Time > Off", defines the acquisition time per sensor.
For example, to obtain a sufficient low average value, set the aperture time exactly to
one modulation period.
Remote command: 
:SENSe<ch>[:POWer]:APERture:TIMe on page 452

S-Parameter
S-Parameter correction is used to mathematically shift the reference plane to the DUT
by considering the S-parameters for any components connected upstream of the sen-
sor.
The S-Parameter table can be changed with the S-Parameters tool, provided as part of
the free R&S NRP Toolkit software. For more information, refer to the manual of the
connected R&S NRP power sensor.
Remote command: 
:SENSe<ch>[:POWer]:CORRection:SPDevice:STATe on page 453
:SENSe<ch>[:POWer]:CORRection:SPDevice:LIST? on page 453
:SENSe<ch>[:POWer]:CORRection:SPDevice:SELect on page 453

Enable Logging
Activates recording of R&S NRP power sensor readings in a log file.
There is 1 log file per sensor. The log files are created automatically and filled in con-
tinuously. They are text files with predefined filename SensLog<n>.txt, where <n>
indicates the connected sensor. Log files are stored on the internal memory, in the
directory /var/user/SensorLogging.

Each log file contains the measured value (2 readings when you work with peak sen-
sors), the sensor type, and the measurement time (timestamp). Logged data is not
overwritten. When a new measurement is started, the collected logging data is appen-
ded in the log file.
Check the used disc space regularly and remove log files to maintain storage capacity.
Note: The logging function is intended for measurements with long time intervals. It is
suitable source for data reconstructions if the connection to the sensor was interrupted.
Remote command: 
:SENSe<ch>[:POWer]:LOGGing:STATe on page 457

7.5.6  NRP sensor mapping

The "NRP Sensor Mapping" lists the sensors detected by the instrument.

Any R&S NRP sensor that supports the USB legacy protocol and is connected to one
of the USB interfaces, is detected automatically and added to the list. When you dis-
connect a power sensor, the R&S SFI100A removes it from the list accordingly.
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R&S NRP power sensors that are connected in the LAN or use the USBTMC protocol
are only detected by the scan search function.

Access:

► Select "RF" > "RF Measurement" > "NRP Sensor Mapping".

The dialog lists all detected R&S NRP sensors for selection and mapping. You can
also browse the network for sensors.
For each sensor, you find the used protocol and the connector icon of the interface.
In the "Mapping" column, you can assign a mapping index to enable the sensor for
use. The list can contain several entries but the R&S SFI100A can only use up to
four sensors simultaneously.

Settings

Sensor Mapping List................................................................................................... 226
Scan............................................................................................................................ 227
Clear............................................................................................................................227
Add Sensor................................................................................................................. 227
Add LAN Sensor......................................................................................................... 227
Add USBTMC Sensor................................................................................................. 227

Sensor Mapping List
Shows the sensors that are connected to the R&S SFI100A.
The table informs on the sensor type, specific features and the installed sensor firm-
ware. It also shows the interface the sensor is connected to, including the communica-
tion protocol and the mapping index.
Remote command: 
:SLISt[:LIST]? on page 448
:SLISt:ELEMent<ch>:MAPPing on page 450
:SLISt:SENSor:MAP on page 450
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Scan
Scans the network and the USB connections for sensors connected using the VISA
communication protocol, i.e. sensors that are addressed over LAN or USBTMC.
The instrument detects sensors communicating over the USB legacy protocol automat-
ically.
Remote command: 
:SLISt:SCAN[:STATe] on page 448

Clear
Removes the selected sensor from the sensor mapping list.
Remote command: 
:SLISt:CLEar:LAN on page 449
:SLISt:CLEar:USB on page 449
:SLISt:CLEar[:ALL] on page 450

Add Sensor
Shows or hides the "Add Sensor" dialog to configure power sensors connected to the
R&S SFI100A over USB or LAN.

Add LAN Sensor
Configures settings to add sensors connected to the R&S SFI100A over LAN.

"IP Address or Host Name"
Displays the host name or the IP address of a R&S NRP power sen-
sor.
If the R&S SFI100A does not detect a connected R&S NRP sensor,
you can assign the address information manually.

"Add LAN Sensor"
Adds a detected R&S NRP sensor connected in the LAN to the list of
sensors, including its device ID or name and its serial number.

Remote command: 
:SLISt:SCAN:LSENsor on page 448

Add USBTMC Sensor
Configures settings to add sensors connected to the R&S SFI100A over USB.
If the R&S SFI100A does not detect a connected R&S NRP sensor, you can assign the
device ID manually.
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"Sensor"
Selects the name of the R&S NRP power sensor.
If the R&S SFI100A does not contain the R&S NRP power sensor
you use, select "<from Device ID". The "Device ID" entry field
switches in edit mode where you can enter the ID of your product
manually.

"Device ID"
Displays the device identifier of a selected R&S NRP power sensor.
If you want to assign the device ID manually, get the information in
the user documentation of your power sensor.

"Serial Number"
Displays the serial number of the R&S NRP power sensor.
If the R&S SFI100A does not detect a connected R&S NRP sensor,
you can assign the serial number manually.

"Add USBTMC Sensor"
Adds a detected R&S NRP sensor connected at the USB interface to
the list of sensors, including its device ID or name and its serial num-
ber.

Remote command: 
:SLISt:SCAN:USENsor on page 449

7.6  Applying user correction

The R&S SFI100A supports a correction function to compensate external losses,
caused, for example, by the RF cable, to achieve a precise target input level at the
DUT.

The signal at the RF outputs of the R&S SFI100A is flat. However, the DUT is usually
not connected directly to the outputs of the instrument but rather via connecting cables.
Components like cables, power combiners, switches or mixers can affect the signal
flatness at the DUT input.

Figure 7-6: Effect of external losses on the signal flatness at the DUT input
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DUT = Device under test
Components = Designation of all components between the measurement equipment and the DUT, e.g.

cables
1 = Flat signal at the outputs of the R&S SFI100A
2 = Signal received at the DUT, incl. the external losses

About UCOR

User correction (UCOR) is a method that determines the external level loss of the RF
output signal over a frequency range in advance, see Figure 7-7.

User correction relates to the RF center frequency only. It does not affect the baseband
bandwidth.

The difference between the generator output level and the level at the DUT determines
the correction value at the respective frequency. Alternatively, the attenuation charac-
teristics over a certain frequency range of, for example, RF cables are also specified in
the associated specifications document.

For more information, refer to the specifications document.

Figure 7-7: Understanding the principle of user correction

DUT = Device under test
Compo-
nents

= Designation of all components between the measurement equipment and the DUT, e.g.
cables

PS = Power sensor, e.g. R&S NRP, connected at the DUT's input and the USB connector of the
R&S SFI100A

1 = Power sensor measures the level over a frequency range, where the collected values corre-
spond to the losses caused by the components between the R&S SFI100A and the DUT

2 = Obtain the correction data by inverting the collected data; load the correction parameters in
the R&S SFI100A

3 = In the R&S SFI100A, the RF signal is pre-processed with the correction values so that the sig-
nal at the outputs is the inverted version of the external losses

4 = Received at the DUT input, the pre-processed signal if flat

With active UCOR, the generator adds the correction value internally and thus increa-
ses the output level by exactly the amount of the loss between its output and the DUT.
For frequencies which are not contained in the list, the level correction is calculated by
interpolation of the closest correction values.

Applying user correction



Generating RF signalsR&S®SFI100A

230User Manual 1179.6789.02 ─ 02

Possible ways for configuring the user correction values

You can configure correction values in the following ways:
● Internally

– Use the built-in table editor in the "UCOR > Edit User Correction Data" dialog.
Once defined, user correction values can be saved in a file.
Files with correction data can be exported, for example, to exchange configura-
tion between instruments or to modify the file content with an external program
and reload them again.

– Using the corresponding remote-control commands.
Note that you have to create a user correction file first.

● Externally
Create a file with correction values as a CSV file with Microsoft Excel, with a Note-
pad or a similar tool and save it with the predefined extension. Transfer the file to
and load it into the instrument.

UCOR file format

Files containing correction data are simple files in text or comma-separated value
(CSV) file format. The filename is user-definable; the file extension is *.ucor.

The file contains a list of correction values, one row per frequency and correction value
pair; a new line indicator separates the correction values.

For file handling, use the standard functions in the "File Manager", see Chapter 10.7,
"Using the file manager", on page 284.

Collecting correction data

To fill the frequency and power values in the correction table, use one of the following
options:
● Manually, row by row.
● Fill the table automatically with linearly interpolated values, calculated from value

range and step size.
● Acquire the real frequency response characteristics of the used component with

the R&S NRP power sensor, see Understanding the principle of user correction.

Using a power sensor for frequency response measurements

Consider the following when using R&S NRP power sensors to measure the correction
values:
● Measure the level directly at the input of the DUT.
● Use the internal correction functions of an R&S NRP power sensor to increase the

measurement accuracy.
● Use S-parameter to consider the impact of any two-port device like an adapter

between the signal generator and the sensor input.

For information on the various possibilities of interoperability between
Rohde & Schwarz power sensors and Rohde & Schwarz signal generators, see the
application note 1GP141.
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Interactions and characteristics
You can enable user correction in all operating modes.
The RF output level (LevelRF) is the sum of the level value and the correction for the
particular frequency:
LevelRF = "Status bar > Level" + "UCOR"

If enabled, the R&S SFI100A indicates user correction by the "Lev Ucor" icon in the
status bar.

7.6.1  User correction data settings

Access:

1. Select "RF" > "RF Level" > "User Correction".

2. If you already have created a file with user correction data:

a) Select "UCOR Data" > navigate to the file "*.uco" > "Select".
b) Proceed with step 4.

3. If you need to create a file:

a) Select "UCOR Data" > "New".
b) Enter the filename UCOR_Data and confirm with "Ok".
c) Choose the file and confirm with "Select".
d) Select "Edit UCOR Data".
e) To fill the user correction data table, see Chapter 7.6.3, "UCOR data editor",

on page 235.

4. Select "UCOR" > "State" > "On".

5. Select block diagram > RF > "On".
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The "UCOR" dialog contains all settings for creating and handling files with user-
defined level correction values.

The remote commands required to define these settings are described in Chap-
ter 13.15.2, "SOURce:CORRection subsystem", on page 472.

Settings:

State............................................................................................................................232
User Correction........................................................................................................... 232
UCOR Data................................................................................................................. 232
Edit UCOR Data..........................................................................................................232
UCOR Info ..................................................................................................................232

State
Activates user correction.
See the user manual "R&S SFI-K544 User-Defined Frequency Response Correction".
Remote command: 
[:SOURce<hw>]:CORRection[:STATe] on page 477

User Correction
Indicates the corrected level value for a specific frequency point.
Remote command: 
[:SOURce<hw>]:CORRection:VALue? on page 476

UCOR Data
Accesses the standard "File Select" function of the instrument. The provided navigation
possibilities in the dialog are self-explanatory.
Files with user correction values are files with predefined file extension *.uco. When a
file is selected, the dialog indicates the filename.
You can create the file internally in the table editor or externally.
● To select an existing file, select "Select List > navigate to the file *.uco > Select"
● Use the general editor function to create a file or to edit an existing one.
● Use the standard file manager function to load externally created files to the instru-

ment.
Remote command: 
[:SOURce]:CORRection:CSET:CATalog? on page 477
[:SOURce<hw>]:CORRection:CSET[:SELect] on page 476
[:SOURce]:CORRection:CSET:DELete on page 477

Edit UCOR Data
Opens the build-in table editor to define a new correction table or edit an existing one.
See also:
● "Fill..." on page 236
● Chapter 7.6.4, "Fill with sensor", on page 237

UCOR Info ...
Opens a window with information on the user correction file.
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The window shows the metadata of the file and the output level parameters that are
relevant for user correction.
Remote command: 
n.a.

7.6.2  Im-/Export settings

Access:

1. Select "RF" > "RF Level" > "User Correction".

2. Select "Import/Export".

Figure 7-8: Im-/Export dialog (example with UCOR settings)

The "Import/Export" dialog contains all functions and settings to import externally
created user correction data or to export it accordingly. You can process and store
a list in the formats *.txt (ASCII), or *.csv (plain text with identical sequence of
fields). The table separators and the decimal floating point numbers are customiza-
ble.

The remote commands required to define these settings are described in Chap-
ter 13.15.2, "SOURce:CORRection subsystem", on page 472.

Settings:

Mode........................................................................................................................... 233
ASCII File Settings...................................................................................................... 234
Select ASCII Source/Select Destination..................................................................... 234
Select Source/Select ASCII Destination..................................................................... 234
Import / Export.............................................................................................................234

Mode
Selects import or export of a data list file. The provided parameters vary according to
the selected mode.
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Remote command: 
[:SOURce<hw>]:CORRection:DEXChange:MODE on page 480

ASCII File Settings
Defines the format and the separators of the associated data file.
"Extension" Selects *.csv or *.txt format.

"Decimal
Point"

Sets "Point" (dot) or "Comma" as the decimal separator used in the
ASCII data with floating-point numerals.

"Column Separator"
Sets the separator between the columns in an ASCII table.
Available are: "Tab", "Semicolon", "Comma" or "Space".

Remote command: 
[:SOURce<hw>]:CORRection:DEXChange:AFILe:EXTension on page 478
[:SOURce<hw>]:CORRection:DEXChange:AFILe:SEParator:DECimal
on page 479
[:SOURce<hw>]:CORRection:DEXChange:AFILe:SEParator:COLumn
on page 479

Select ASCII Source/Select Destination
In "Mode > Import", opens the common file dialog with standard file handling functions.
"Select ASCII Source"

Opens the "Select ASCII Source" tab of the file dialog for file import.
"Select Destination"

Opens the "Select ASCII Source" file dialog to select the file path and
filename.

Remote command: 
[:SOURce<hw>]:CORRection:DEXChange:AFILe:CATalog? on page 478
[:SOURce<hw>]:CORRection:DEXChange:AFILe:SELect on page 479

Select Source/Select ASCII Destination
In "Mode > Export", opens the common file dialog with standard file handling functions.
"Select Source"

Opens the "Select Source" tab of the file dialog for file export.
"Select ASCII Destination"

Opens the "Select ASCII Source" file dialog to define the filename
and the file path.

Remote command: 
[:SOURce<hw>]:CORRection:DEXChange:SELect on page 480

Import / Export
Imports or exports the selected user correction file.
Remote command: 
[:SOURce<hw>]:CORRection:DEXChange:EXECute on page 479
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7.6.3  UCOR data editor

The "User Correction" dialog provides a build-in list editor for defining the correspond-
ing value pairs. Prerequisite to define correction values, is that you have selected a file.

How to: see Chapter 7.6.1, "User correction data settings", on page 231, step 1 to
step 3.

Access:

1. "RF" > "RF Level" > "User Correction" > "Edit User Cor. Data".

2. Select "Edit".

The editor provides a table with RF frequency and level correction values and stan-
dard navigation functions.
The remote commands required to define the user correction data are described in
Chapter 13.15.2, "SOURce:CORRection subsystem", on page 472.

All columns in a row must contain values. Cells with missing values are therefore filled
with preset values automatically.

Since the table and navigation functions can be assumed to be known, the following
description contains a brief overview, shown by the example of the "Edit List Mode
Data" dialog. If a function relates to a particular dialog, it is explicitly stated.

Settings

Edit UCOR Data..........................................................................................................236
Frequency (Hz)........................................................................................................... 236
Correction Value (dB)..................................................................................................236
Data handling keys......................................................................................................236

└ Go To............................................................................................................ 236
└ Edit................................................................................................................236
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└ Fill with Sensor..............................................................................................236
└ Save As/Save............................................................................................... 236

Fill................................................................................................................................236

Edit UCOR Data
Opens the build-in table editor to define a new correction table or edit an existing one.
See also:
● "Fill..." on page 236
● Chapter 7.6.4, "Fill with sensor", on page 237

Frequency (Hz)
Sets the frequency for level correction.
Remote command: 
[:SOURce<hw>]:CORRection:CSET:DATA:FREQuency on page 475

Correction Value (dB)
Sets the level value.
Remote command: 
[:SOURce<hw>]:CORRection:CSET:DATA:POWer on page 475

Data handling keys
Standard functions for file and data handling.

Go To ← Data handling keys
Selects a row for editing.

Edit ← Data handling keys
Enables you to insert, or delete a row or ranges within the table, and provides access
to a dialog for automatic filling, see "Fill..." on page 236.

Fill with Sensor ← Data handling keys
Opens a dialog to configure the automatic filling of user correction data with an R&S
NRP power sensor.
See Chapter 7.6.4, "Fill with sensor", on page 237

Save As/Save ← Data handling keys
Saves the table in a file with a user-defined name and predefined file extension. To
save a copy or create a file, use the "Save as" function.

Fill...
Provides parameters for filling a table automatically with user-defined values.
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To fill the table, select "Fill".
Note: Once you fill one column only, the editor automatically adds preset values in the
other columns. This functionality protects against data loss, otherwise incomplete rows
are when saving. You can simply overwrite these values.
"From / Range"

Defines the start line and number of lines to be filled.
"Column To Fill"

Selects, if the column is filled up with frequencies in Hz or correction
values in dB.

"Start Value / End Value"
Sets the start value for frequency or correction values. The end value
is read only and depends on the increment value and the range.

"Increment Value"
Determines the step size.

"Fill" Fills the column specified in "Column To fill".

7.6.4  Fill with sensor

The fill with sensor function requires that you have connected a power sensor and also
selected a file for user correction data before.

See:
● Chapter 7.5, "Using power sensors", on page 212
● "To create user correction data with an R&S NRP and the R&S SFI100A"

on page 241

Access:

1. Select "RF" > "RF Level" > "User Correction".

2. Select "UCOR Data > navigate to the file *.ucor > Select".
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3. Select "Edit UCOR Data > Fill With Sensor...".

This dialog contains parameters for filling a table automatically with sensor read-
ings.

To fill the table, select "Execute".
For information on power sensors and how to use them, see Chapter 7.7, "Improving
the RF signal performance", on page 239.

Settings:

Fill User Correction Data with Sensor......................................................................... 238
Generator Settings used for Measurement................................................................. 239

Fill User Correction Data with Sensor
The "Execute" button is only enabled if a sensor is detected and the user correction list
contains at least one frequency value.
"Sensor" Displays connected sensors for selection.
"List To Fill" Indicates the used list.
"Config" Opens the sensor configuration dialog to set the parameters for the

selected power sensor.
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"Include Zeroing"
Performs a zeroing procedure before acquiring the user correction
data to improve precision.
No signal is applied to the sensor during zeroing. RF output is tempo-
rarily switched off during that time.
When unchecked, the zeroing procedure is skipped. However, the RF
signal level can be blanked shortly. This setting is useful if blanking of
RF is undesirable or the absence of power at the sensor cannot be
guaranteed.
Remote command: 
[:SOURce<hw>]:CORRection:ZERoing:STATe on page 476

"Execute" Triggers the sensor to measure and to return the data for user corr-
rection.
The "Execute" button is only enabled if a sensor is detected and the
user correction list contains at least one frequency value.
Remote command: 
[:SOURce<hw>]:CORRection:CSET:DATA[:SENSor<ch>][:
POWer]:SONCe on page 475

Generator Settings used for Measurement
Displays the settings relevant for the measurement.
"Modulation" Indicates that modulation is off.

The R&S SFI100A disables modulation for the "Fill with sensor" proc-
ess, even if you have enabled a modulation and if you have started
"Fill with sensor".

"Amplitude" Displays the currently set level.
Remote command: 
[:SOURce<hw>]:POWer:POWer on page 508

"Offset" Displays the level offset, set with "Offset" on page 203.
Remote command: 
[:SOURce<hw>]:POWer[:LEVel][:IMMediate]:OFFSet
on page 512

"UCOR Reference Level"
Displays the reference value for user correction.
The user correction reference level is the set Amplitude plus the set
Offset.
Remote command: 
[:SOURce<hw>]:POWer[:LEVel][:IMMediate]:REFLevel
on page 514

7.7  Improving the RF signal performance

To achieve an accurate input level at the DUT, you can compensate losses, e.g.
caused by cables between the RF output and the DUT over a frequency range.
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Using the user correction function and e.g., a R&S NRP power sensor, the
R&S SFI100A utilizes the readings of the power sensor and creates a correction value
table for controlling the output level during operation.

See also Chapter 7, "Generating RF signals", on page 178.

To connect the R&S NRP to the R&S SFI100A

1. Connect the power sensor.
See Chapter 7.5.2, "Connecting R&S NRP power sensors to the R&S SFI100A",
on page 214.

2. Select "RF" > "RF Measurement" > "NRP Sensor Mapping".

3. If the sensor is not detected automatically, select "Scan > Start".

The instrument scans the network and the USB connections for connected sensors
and lists all detected R&S NRP sensors in the mapping table.

4. In the "Mapping" column, assign the sensor to a sensor channel, see Chap-
ter 7.5.6, "NRP sensor mapping", on page 225.

5. Close the dialog.

To configure and calibrate the R&S NRP in the R&S SFI100A

Provided the power sensor is connected to the R&S SFI100A and is assigned to a sen-
sor channel, we recommend that you calibrate and configure the power sensor.

1. In the block diagram > RF, turn off the RF output signal.

2. Select "RF" > "RF Measurement" > "NRP Power Viewer".

3. To configure a sensor, select "Config".

4. Select "Zero" to start zeroing of the sensor.
Note: Always turn the RF power off or disconnect the sensor from RF before zero-
ing, since the function calibrates the power sensor at zero signal power.

The zeroing process takes a few seconds, depending on the power sensor type.

5. Configure additional parameters for the selected sensor as required.

Improving the RF signal performance
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6. Select "State > On".

7. Close the dialog.

To create user correction data with an R&S NRP and the R&S SFI100A

We assume, that the power sensor is connected, assigned and ready for operation.

1. Select "RF" > "RF Level" > "User Correction".

2. Select "UCOR Data" > "UCOR Data...."

3. Create a file: "New" > Filename and confirm with "OK".

4. Select the new file with "Select".

5. Select "Edit UCOR Data...".

6. Select "Edit" > "Fill".

The "Fill Table" dialog enables you to fill in the values of the columns automatically.

7. To fill in the frequency column:

a) Select "Select Column To Fill > Frequency / Hz".
b) Select "Range > e.g. 15" to determine the number of values.
c) Select "Start Value > e.g. 1.56 GHz".
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d) Select "Increment Value > e.g. 1 MHz", to determine the frequency steps.
e) Select "Fill", to insert the frequency values.

The "Fill" function also fills the column of the "Correction Value / dB" values with a
predefined value, since empty cells lead to the data loss of the entire line. If you
need different values, you can change them manually, or you can use the auto-
matic function "Fill with Sensor" as described in the next steps.

8. Select "Fill with Sensor".

The "Fill User Correction Data With Sensor" dialog provides an overview of the
sensor configuration.

9. Select "Execute".

The R&S SFI100A successively sets each frequency point, reads the measured
power of the sensor and fills in the value in the correction table.

10. Select "Save" to save the data in the file.

11. Close the dialog.

To perform power leveling calibration with user correction data

We assume that a user correction file is available in the user directory of the
R&S SFI100A or on a memory stick or in a shared directory.

If you have created and saved the file immediately before this step, the file is loaded in
the "User Correction" dialog automatically. Otherwise you can load a previously saved
file.

1. Select "RF" > "RF Level" > "User Correction".
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2. Select "UCOR Data" > "UCOR Data...", if there is no file loaded already.

3. Select the directory and file you want to use.

4. Load the file with "Select".

5. To view the file content, select "Edit UCOR Data...".

6. Select "UCOR Data" > "State" > "On" to apply the user correction values.

When you activate the RF output, the R&S SFI100A considers the user correction
data and adjusts the signal level accordingly to compensate external frequency
responses.

Improving the RF signal performance
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8  Generating I/Q output signals
Option: R&S SFI-K17

● About I/Q analog output signals............................................................................244
● Generating I/Q analog output signals....................................................................245
● I/Q analog output settings..................................................................................... 251

8.1  About I/Q analog output signals

Required options

The equipment layout for output of analog I/Q signal includes:
● Base unit

Sufficient for direct DAC output of the baseband signal at the DAC connectors.
● Option R&S SFI-K17 single-ended/differential analog I/Q outputs

Required for singled-ended and amplified differential output of the baseband signal
at the Single and Diff connectors.

● Optional RF modulation bandwidth extension to 8 GHz (R&S SFI-K529) or 10 GHz
(R&S SFI-K530)
Required for wideband analog I/Q output of up to 5 GHz.

For more information, refer to the specifications document.

I/Q analog output interface and states

The block diagram displays the "I/Q OUT" connector in a folded state. The analog out-
put connectors are inactive (gray LEDs).

21

3

Figure 8-1: Representation of the analog output interface

1 = Analog output interface state: gray = inactive; blue = active
2 = Analog output interface name
3 = "No Stream" indicating no mapped I/Q stream

About I/Q analog output signals
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Maximum overall output voltage

The voltage of the analog output signals is defined as a combination of the output volt-
age of the I and Q signal components and an optional bias voltage. If you use the dif-
ferential output, you can also set an offset.

The values of these parameters are interdependent so that the sum of output voltage
and bias voltage has an upper limit Vmax as follows:
● Single-ended signal: Vp + Vbias ≤ Vmax

● Differential signal: 0.5*Vp + |Vbias| + 0.5*Voffset ≤ Vmax

● DAC signal: 0.5*Vp + |Vbias| + 0.5*Voffset ≤ Vmax

Where:
● Vp is the output voltage, see "I/Q Level Vp (EMF)" on page 253.
● Vbias is the bias voltage, see "Bias (EMF)" on page 253.
● Voffset is the offset between inverting and non-inverting output, see "Offset (EMF)"

on page 254.

For more information, refer to the specifications document.

8.2  Generating I/Q analog output signals

This section provides information on how to generate analog I/Q output signals. It cov-
ers the following topics:
● "To connect to the analog I/Q output interfaces" on page 245
● "To open general analog I/Q output settings" on page 246
● "To generate single-ended analog I/Q signals" on page 247
● "To generate differential analog I/Q signals" on page 248
● "To generate DAC analog I/Q signals" on page 249

To connect to the analog I/Q output interfaces

1. Use the analog I/Q connectors on the front panel:

● "DAC" for differential I/Q signal output directly from the D/A converter (DAC)
board.

● "Diff" for amplified differential I/Q signal output.
● "Single" for single-ended I/Q signal output.

2. Connect to the analog I/Q connectors. See "To connect to screwable connectors"
on page 24.

Table 8-1, Figure 8-2 and Figure 8-3 provide an overview on connections and a
test setup.

Generating I/Q analog output signals
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Table 8-1: Analog I/Q signals and R&S SFI100A connections

Signal Signal type R&S SFI100A

I/Q Single-ended "Single"

I/Q Positive differential "DAC" or "Diff"

I/Q bar Negative differential "DAC" or "Diff"

Generator DUT

Q out

I out I in

Q in

1 3

RF out RF

I

Q

2 4

Figure 8-2: Test setup single-ended I/Q output

1 = R&S SFI100A with "Single" I/Q connectors
2 = Single-ended I/Q output signal components I and Q
3 = DUT as I/Q sink, for example a transmitter chipset
4 = RF output signal of the DUT

Generator DUT

Q bar

Q Q in

Q bar in

1 3

I bar

I I I in

I bar inI bar

RF out RF

Q

Q bar

2 4

Figure 8-3: Test setup differential I/Q output

1 = R&S SFI100A with "DAC" or "Diff" I/Q connectors
2 = Positive and negative differential I/Q output signal components I and Q
3 = DUT as I/Q sink, for example a transmitter chipset
4 = RF output signal of the DUT

To open general analog I/Q output settings

1. In the block diagram, select the "I/Q OUT" symbol to unfold the "I/Q Analog" block.

2. To open analog I/Q output settings, proceed as follows:

a) Select "I/Q Analog" bar of the block.
b) In the opening menu, select "I/Q Analog" > "I/Q Analog Outputs".

Generating I/Q analog output signals
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The general settings tab opens of the I/Q analog output configuration dialog.

To generate single-ended analog I/Q signals

1. Connect to the single-ended I/Q analog output connectors of the R&S SFI100A.
See "To connect to the analog I/Q output interfaces" on page 245.

2. Open general settings of the I/Q analog output signal.
See "To open general analog I/Q output settings" on page 246.

3. Select "Output Type" > "Single Ended".

4. Select "Mode" > "Fixed" for fixed power levels of I/Q output signals.
See also Table 8-2.

5. For individual level settings, proceed for example as follows:

a) Select "Mode" > "Variable".
b) Set "I/Q Level Vp (EMF)" = 1 V.
c) Enable "Couple I/Q Bias" to use the same "Bias (EMF)" value for the I-compo-

nent and the Q-component.
d) Set "Bias (EMF)" = 2 V.

6. To enable single-ended analog I/Q signal output, set "State" > "On".

Generating I/Q analog output signals
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The block diagram automatically adjusts the signal routing to the single-ended ana-
log I/Q outputs "I/Q Out".

To generate differential analog I/Q signals

1. Follow steps (1) and (2) as in section "To generate single-ended analog I/Q sig-
nals" on page 247.

2. Select "Output Type" > "Differential".

3. Select "Mode" > "Fixed" for fixed power levels of I/Q output signals.
See also Table 8-2.

4. For individual level settings, proceed for example as follows:

a) Select "Mode" > "Variable".
b) Set "I/Q Level Vp (EMF)" = 1 V
c) Enable "Couple I/Q Bias" to use the same "Bias (EMF)" value for the I-compo-

nent and the Q-component.
d) Set "Bias (EMF)" = 2 V.

Generating I/Q analog output signals
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e) Set "Offset (EMF)" = 10 mV.

5. To enable differential analog I/Q signal output, set "State" > "On".

The block diagram automatically adjusts the signal routing to the single-ended ana-
log I/Q outputs "I/Q Out".

To generate DAC analog I/Q signals

1. Follow steps (1) and (2) as in section "To generate single-ended analog I/Q sig-
nals" on page 247.

2. Select "Output Type" > "DAC".

3. Select "Mode" > "Fixed" for fixed power levels of I/Q output signals.
See also Table 8-2.

4. For individual level settings, proceed for example as follows:
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a) Select "Mode" > "Variable".
b) Set "I/Q Level Vp (EMF)" = 850 mV
c) Enable "Couple I/Q Bias" to use the same "Bias (EMF)" value for the I-compo-

nent and the Q-component.
d) Set "Bias (EMF)" = 10 mV.
e) Set "Offset (EMF)" = 10 mV.

5. To enable DAC analog I/Q signal output, set "State" > "On".

The block diagram automatically adjusts the signal routing to the single-ended ana-
log I/Q outputs "I/Q Out".

Generating I/Q analog output signals



Generating I/Q output signalsR&S®SFI100A

251User Manual 1179.6789.02 ─ 02

8.3  I/Q analog output settings

Access:

► Open general settings of the I/Q analog output signal.
See "To connect to the analog I/Q output interfaces" on page 245.

The dialog provides the I/Q analog settings to select and configure the analog out-
put signal type and to add digital impairments to the signal.

Settings:

State............................................................................................................................251
Set To Default..............................................................................................................251
Save/Recall................................................................................................................. 252
Show Connector..........................................................................................................252
I/Q Output Type...........................................................................................................252
Mode........................................................................................................................... 252
I/Q Level Vp (EMF)..................................................................................................... 253
Couple I/Q Bias........................................................................................................... 253
Bias (EMF).................................................................................................................. 253
Offset (EMF)................................................................................................................254

State
Enables the analog I/Q signal output at the "I/Q" or "I/Q bar" connectors. By default,
these output connectors are disabled.
Remote command: 
[:SOURce<hw>]:IQ:OUTPut:ANALog:STATe on page 496

Set To Default
Calls the default settings. The values of the main parameters are listed in the following
table.

I/Q analog output settings
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Parameter Value

"State" Not affected by a preset

"I/Q Output Type" Single Ended

Not affected by a preset, if you have connected external instruments and "Pre-
set behavior: Keep connections to external instruments" > "On".

"I/Q Level Vp (EMF)" 1 V

"Bias (EMF)" 0 mV

Remote command: 
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:PRESet on page 496

Save/Recall
Opens the "Save/Recall" dialog that is the standard instrument function for saving and
recalling the complete dialog-related settings in a file. The provided navigation possibil-
ities in the dialog are self-explanatory.
The settings are saved in a file with a predefined extension. You can define the file-
name and the directory, in that you want to save the file.
See also Chapter 10.4, "Saving and recalling settings", on page 278.
Remote command: 
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:SETTing:CATalog? on page 496

Show Connector
Accesses a dialog that displays the physical location of the selected connector on the
front/rear panel of the instrument.

I/Q Output Type
Selects the type of output signal.
The parameters in the "I/Q Analog Out" dialog depend on the selected output mode.
"Single Ended" Requires R&S SFI-K17.

Single-ended output at the "Single" I/Q connectors.
You can define a bias between the output signal and the ground.

"Differential" Requires R&S SFI-K17.
Differential output at the "Diff" I/Q connectors and I/Q bar connectors.

"DAC" Direct D/A converter (DAC) output at the "DAC" I/Q connectors and
I/Q bar connectors.

Remote command: 
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:TYPE on page 497

Mode
Selects fixed mode or variable mode for the power levels at the I/Q outputs.

I/Q analog output settings
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"Fixed" The power levels of the I/Q signal components are fixed, see table
Table 8-2.
Table 8-2: Fixed mode I/Q output power levels

"I/Q Output Type" "I/Q Level Vp (EMF)" "Bias (EMF)" "Offset (EMF)"

Single ended 2.1 V I: 0.0 mV

Q: 0.0 mV

-

Differential 2.9 V I: 0.0 mV

Q: 0.0 mV

I: 0.0 mV

Q: 0.0 mV

DAC 900 mV I: 0.0 mV

Q: 0.0 mV

I: 0.0 mV

Q: 0.0 mV

"Variable" Enables individual power level settings of the I/Q signal components.
For more information, refer to the specifications document.
Remote command: 
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:MODE on page 497

I/Q Level Vp (EMF)
Displays or sets the output voltage for the I and Q signal components. Setting requires
"Mode" > "Variable".
To keep the I/Q analog output power levels below the maximum input power level at
your DUT, see "Maximum overall output voltage" on page 245.
Remote command: 
[:SOURce<hw>]:IQ:OUTPut:LEVel on page 497

Couple I/Q Bias
Requires "Mode" > "Variable".
If enabled, couples the bias setting of the I signal and the Q signal component. The
bias of the I signal component is configurable, the bias of the Q signal component
updates automatically to the same value.
Remote command: 
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:BIAS:COUPling[:STATe] on page 498

Bias (EMF)
Displays or sets the bias DC voltage. This bias is superimposed upon the I or Q signal.
Setting requires "Mode" > "Variable".

Effect of a positive bias Effect of a negative bias

I/Q analog output settings
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In "Single Ended" mode, this parameter is the bias between the I/Q output signal and
the ground. Use this bias, for example, to define the operating point of a DUT.
To keep the I/Q analog output power levels below the maximum input power level at
your DUT, see "Maximum overall output voltage" on page 245.
Remote command: 
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:BIAS:I on page 498
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:BIAS:Q on page 498

Offset (EMF)
Requires "I/Q Output Type" > "Differential"/"DAC".
Displays or sets the offset between the inverting and the non-inverting output. Setting
requires "Mode" > "Variable".
Sets an offset between the inverting and the non-inverting output.
To keep the I/Q analog output power levels below the maximum input power level at
your DUT, see "Maximum overall output voltage" on page 245.
The selected offset is set half in the positive and half in the negative direction.

Effect of a positive offset Effect of a negative offset

A positive offset is set with half of the value in the
positive direction at the non-inverting outputs, in the
negative direction at the inverting outputs.

A negative offset is set with half of the value in the
negative direction at the non-inverting outputs, in the
positive direction at the inverting outputs.

Example: Effect of a positive offset on the I signal component
"I Offset" = 100.0 mV
The offsets applied on the two output connectors are as follows:
● +50.0 mV at the positive signal output
● -50.0 mV at the inverted signal output

Remote command: 
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:OFFSet:I on page 499
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:OFFSet:Q on page 499

I/Q analog output settings
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9  Monitoring baseband signal characteristics
Instead of analyzing the baseband signal characteristics with an external instrument,
the R&S SFI100A can also visualize a subset of these signal characteristics with the
built-in graphical signal display function. Also, this function evaluates signal measure-
ment quantities and displays signal characteristics graphically in real-time.

9.1  Required options

The minimum equipment layout for using this function includes the base unit.

9.2  About the graphical signal display

To ease the setting and routing of baseband signals, R&S SFI100A is able to capture
these signals and display them graphically in different ways: as I/Q, vector, eye or con-
stellation diagram, as power spectrum or as statistical evaluations.

In the digital domain, the measurements are based on recorded I/Q samples. The
sources of these samples are selectable points (acquisition points) in the signal flow.
You can configure and display the signal characteristics simultaneously in up to dia-
grams.

9.2.1  Available diagrams

This section focuses on graphical signal displays, their content and application. See
Table 9-1 for an overview of the signal characteristics that you can monitor.
Table 9-1: Graphics modes overview

Graphics modes Domain Measurement instrument

I/Q diagram Time Oscilloscope (standard mode)

Vector diagram Time Oscilloscope (XY mode)

Constellation diagram Time Oscilloscope (XY mode)

Eye diagram Time Oscilloscope (triggered to symbol clock and
showing repetitive traces)

CCDF display Statistical representation of peaks Peak power analyzer

Power spectrum Frequency Spectrum analyzer

9.2.1.1  I/Q diagram

The I/Q diagram displays the in-phase component (i[t]) and quadrature component
(q[t]) of the I/Q signal over time.

About the graphical signal display
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Figure 9-1: I/Q diagram with markers

= window with two separate coordinate systems with identical x-axis and y-axis
x-axis = time in units number of symbols, chips, samples or seconds depending on the signal
y-axis = amplitude, scaled to the peak envelope power; where minimum scaled amplitude = -1, maximum

scaled amplitude = +1

Application: To analyze impairments, added noise and signals (e.g. from external
baseband input) in the time domain. This mode shows the signal like an oscilloscope.

Signal acquisition points: See Table 9-2.

9.2.1.2  Vector diagram

The vector diagram displays the Q component over the I component. All points in the
complex domain are connected by lines.

About the graphical signal display
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Figure 9-2: Vector diagram (64QAM)

X-axis, Y-axis = amplitudes of the signal components, scaled to the peak envelope power; where minimum
scaled amplitude = -1, maximum scaled amplitude = +1

Application: To analyze the transition between the various states of modulation map-
ping, especially with linear modulations like MSK, QPSK or QAM. This mode shows
the signal like an oscilloscope (X/Y-mode).

Signal acquisition points: See Table 9-2.

9.2.1.3  Constellation diagram

Constellation diagrams display the modulation symbols as discrete points in the I/Q
plane. Unlike the vector diagram, the constellation diagram displays only one sample
per symbol. This sample represents the symbol.

Constellation diagrams are helpful when generating signals using the "Custom Digital
Modulation" settings. Compare the displayed constellation diagram with the diagram
displayed in the "Custom Digital Modulation > Modulation" dialog.

About the graphical signal display
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Figure 9-3: Constellation diagram (64QAM)

X-axis, Y-axis = amplitudes of the signal components, scaled to the peak envelope power; where minimum
scaled amplitude = -1, maximum scaled amplitude = +1

Application: To classify modulation.

Signal acquisition points: See Table 9-2.

9.2.1.4  Eye diagram

The eye diagram displays synchronized and superimposed sections of either the in-
phase or the quadrature components of the signal.

Figure 9-4: Eye diagram with partially closed eye (QPSK)

About the graphical signal display
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X-axis = time in the range of -/+ 1 symbol
Y-axis = amplitude, scaled to the peak envelope power; where minimum scaled amplitude = -1, maximum

scaled amplitude = +1

The display width is normalized for 2 symbols. It uses one-symbol "eye opening" in the
center of the display and 1/2-symbols to the left and right of the center eye for captur-
ing time transitions. Several hundred curve segments are superimposed. The begin-
ning of the recording is synchronous to the symbol and chip clock pulse.

Application: To analyze amplitude and time distortion elements (e.g. jitter) at high-
speed digital data systems. A high quality, unimpaired signal shows a clearly open eye
(horizontally and vertically).

Signal acquisition points: See Table 9-2.

9.2.1.5  CCDF display

The complementary cumulative distribution function (CCDF) displays the probability
with which the output signal exceeds the average power.

Figure 9-5: CCDF diagram of a 5 MHz LTE signal (Level -30 dBm) and two reference curves

X-axis = Level over the average signal power, where the average power (RMS) corresponds to the origin
Y-axis = Probability of exceeding the average power that is the percentage of time the signal spends at or

above the power level specified by the X-axis
Marker 1 = Interpolation: 10.3% of the samples exceed 3.3 dB above average; 1% of the samples exceed

7.5 dB above average (not shown with a marker)
Marker 2 = The point where the trace crosses the x-axis; indicates the highest peak that is found in the sam-

ple block and is 9.6 dB higher than average.

Signal acquisition points: See Table 9-2.

About the graphical signal display
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9.2.1.6  Power spectrum

The power spectrum displays the signal spectrum which is calculated from the I/Q sig-
nal with fast Fourier transform (FFT). The power density over frequency is displayed.

Figure 9-6: Power spectrum diagram of a 5 MHz LTE signal with enabled reference curve (blue)

"FFT points" = indicates the number of I/Q value pairs that are used for calculating a (part-)FFT
"AVG" = indicates the number of subspectra used for averaging
X-axis = frequency plotted symmetrically (- Sampling Rate/2 to +Sampling Rate/2)
Y-axis = power density

Signal acquisition points: See Table 9-2.

9.2.2  Signal acquisition points

Signal characteristics can be displayed using different methods and different acquisi-
tion points, also at the same time. Table 9-2 shows which signal acquisition point is
suitable for which kind of graphics mode. Also, it provides associated graphics sources
and the designation of the access points in the block diagram.
Table 9-2: Signal acquisition points, modes and sources

Signal acquisition points Graphics modes Graphics source Designation

Baseband signals Constellation diagram, eye diagram "Baseband"

Input streams I/Q diagram, vector diagram, CCDF
diagram, power spectrum diagram

"Stream"

Analog outputs I/Q diagram, vector diagram, CCDF
diagram, power spectrum diagram

"IQ Out"

"RF"

Figure 9-7 shows an example for locations of signal acquisition points.

About the graphical signal display
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Figure 9-7: Block diagram with graphical signal display and signal acquisition points

9.2.3  Display functions

The graphical display provides general display functions known from other measure-
ment instruments and offers zoom and markers.

Zooming

You can zoom into the diagram to visualize the measurement results in greater detail.
Using the touchscreen or a mouse pointer you can easily define the area to be
enlarged.

Zooming is merely a visual tool, it does not change the number of samples used for the
calculation. You can increase the number of samples before zooming.

See also "To zoom into a diagram" on page 269.

Using markers

Markers are tools for numerical readout of measured data in diagrams. They help you
analyze the displayed signal characteristics by determining particular values in the dia-
gram.

Often you can use markers to measure the frequency distance of two peaks or to mea-
sure the power decrease of an oscillator at a given frequency offset, dBc value. Note
that markers in the diagram are not related to the markers in the digital standards.

In the graphical display, the markers and their values (for example time or frequency)
are displayed as usual.

About the graphical signal display
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Single marker indication Delta marker indication

1 2

3
● 1 = marker position on the x-axis in the current

units
● 2 = marker value on the y-axis
● 3 = marker number

1 2

● 1 = delta marker
● 2 = result of the marker function, i.e. the delta

values in the current units

See also "To enable markers to read-out measured data" on page 269.

Persistence and color maps

In addition to the standard representation, the vector, the constellation, and the power
spectrum diagrams use a color map.

The color encodes the relative amplitude (in percent) of the probability distribution of
the data points in the diagram. A detailed breakdown of the colors is below diagrams
the colors are relevant for. Data points in areas with high probability are marked in red,
data points in areas with low probability in blue. Thus, for example, you can observe
not only the "level versus frequency" trace but also a third dimension, the probability of
the power level.

Reference trace

Reference traces help you analyze a displayed characteristic, as do the markers. Ref-
erence traces are used to define amplitude curves or spectral distribution boundaries in
the result diagram which are not to be exceeded. They indicate, for example, the upper
power limits which are allowed from a device under test (DUT).

The R&S SFI100A supports up to five reference traces. You can load reference traces
and activate them simultaneously.

9.3  Graphics configuration settings

This section focuses on the graphics configuration dialog, which determines the num-
ber and kind of the graphical signal displays.

Access:

1. Select the sine wave icon.

The "Graphics Configuration" dialog opens.

Graphics configuration settings
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Figure 9-8: Graphics configuration dialog

2. To display a certain characteristic of the signal, use the parameter "Mode".

3. To select suitable signal acquisition points, use the parameter "Source".

4. To enable the graphical signal display, select "Add".

A thumbnail of the graphical signal display is shown in the taskbar.

Figure 9-9: Graphics configuration dialog with active graphical signal displays

5. To enlarge the thumbnail, select it.

Settings:

Graphical Diagrams Table...........................................................................................264
Mode........................................................................................................................... 264
Source.........................................................................................................................264

Graphics configuration settings
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FFT Length..................................................................................................................264
Full Scale (dBFS)........................................................................................................ 264
Trigger Source.............................................................................................................264
Sample Rate Mode..................................................................................................... 265
Sample Rate............................................................................................................... 265
Add..............................................................................................................................265
Apply Changes............................................................................................................265
Remove.......................................................................................................................266

Graphical Diagrams Table
The active graphical signal displays are listed in the table at the top of the dialog.

Mode
Sets the graphics mode, see Chapter 9, "Monitoring baseband signal characteristics",
on page 255.
Remote command: 
[:SOURce<hw>]:BB:GRAPhics:MODE on page 570

Source
Sets the source for the signal acquisition point.
See Chapter 9.2.2, "Signal acquisition points", on page 260.
Remote command: 
[:SOURce]:BB:GRAPhics:SOURce on page 571

FFT Length
In "Mode > Power Spectrum", selects the number of samples to be included in the
graph of the power spectrum.
Remote command: 
[:SOURce]:BB:GRAPhics:FFTLen on page 572

Full Scale (dBFS)
In "Mode > Power Spectrum", determines the normalization of the power values in the
diagram.
Observe the change in the units on the y-axis.
"On" The maximal digital power |I|=|Q|=max is mapped to 0 dB in the

power spectrum diagram.
The y-axis shows the normalized power in dBFS.

"Off" The frequency average of the displayed power (frequency domain)
agrees with the average power in the time domain.
The y-axis shows the power distribution in dB/Hz.

Remote command: 
[:SOURce]:BB:GRAPhics:FFTFscale on page 572

Trigger Source
Defines the trigger for signal recording.

Graphics configuration settings
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"Software" Recording of signals starts automatically in predefined intervals.
This asynchronous method is suitable if a representative display of
the complete signal is required.

"Marker 1" The starting point for recording of signals is determined by the marker
1 setting of the activated digital standard ("Trigger/Marker" dialog).
This synchronous method is suitable if specific signal segments are
to be shown in greater detail. With periodic signals, a static image is
obtained by selecting a period length of marker 1 that is equal to the
signal period.
The displayed signal segment can be shifted by entering a marker
delay in the "Trigger/Marker" dialog of the activated digital standard.

Remote command: 
[:SOURce<hw>]:BB:GRAPhics:TRIGger:SOURce on page 572

Sample Rate Mode
Sets how the time resolution of the signal is determined. Maximum resolution corre-
sponds to a display covering the entire signal bandwidth. The higher the resolution, the
shorter the length of the displayed signal segment.
"Auto" The resolution is set to an optimum value in terms of signal and dis-

play type.
"Full Bandwidth"

The resolution is set so that the display covers the entire signal band-
width.

"User" Activates the "Sample Rate" input field, where you can manually set
the resolution.

Remote command: 
[:SOURce<hw>]:BB:GRAPhics:SRATe:MODE on page 570

Sample Rate
● If "Sample Rate Mode = Auto/Full Bandwidth"

Displays the percentage of the entire signal bandwidth which is used for the graphi-
cal signal display.

● If "Sample Rate Mode = User"
Input for the percentage of signal bandwidth which is used for the graphical signal
display.

Remote command: 
[:SOURce<hw>]:BB:GRAPhics:SRATe:USER on page 570

Add
Adds a graphical signal display (as set in the "Graphics Configuration" dialog) to the
taskbar/graphical diagrams table.
Remote command: 
[:SOURce]:BB:GRAPhics:ADD on page 571

Apply Changes
Enables the current settings for the selected graphical signal display.

Graphics configuration settings
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Remove
Removes the selected graphical signal display from the taskbar/graphical diagrams
table.
Remote command: 
[:SOURce]:BB:GRAPhics:CLOSe on page 571.
The command closes all graphical signal displays.

9.4  Graphical signal display settings

Access:

1. Select "Taskbar > System Config > Graphics > Add".

2. Double-click the thumbnail in the taskbar.

This section focuses on the functions of the enlarged graphical signal displays.

Settings:

Configure.....................................................................................................................266
Stop/Run..................................................................................................................... 266
Zoom Out.................................................................................................................... 266
Reference Curves....................................................................................................... 266
Display Units............................................................................................................... 266
Show / Hide marker.....................................................................................................267
Reference Curve......................................................................................................... 267

Configure
Opens the "Graphics Configuration" dialog, see Chapter 9.3, "Graphics configuration
settings", on page 262.
Note: This function is available for enlarged graphical signal displays and in the con-
text menus of the thumbnails.

Stop/Run
Stops the processing of the displayed signal and freezes it.
"Run" continues a stopped displayed signal.

Zoom Out
Resets a previous zoom, see also "To zoom into a diagram" on page 269.

Reference Curves
Accesses the dialog for defining reference curves, see "Reference Curve"
on page 267.

Display Units
Changes the units of the X-axis. The available values depend on the generated signal.

Graphical signal display settings
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Show / Hide marker
Sets two markers to the displayed signal or hides them.
See also:
● "Using markers" on page 261
● "To enable markers to read-out measured data" on page 269

Reference Curve
Enable the indication of up to five configurable reference curves (traces).

See "Reference trace" on page 262.
"Reference Curves Table"

Lists the configured reference curves and their current state.
To change a curve, select it.

"Name" Enters the name of a new reference curve
"Assign Data" Opens the standard "File Select" function to load a file describing a

reference curve.
"Show Curve" Toggles the show/hide state of the selected curve
"Delete" Removes the curve

9.5  Checking the generated signal graphically

This section shows you how to use the different graphic modes to visualize the signal
characteristics of the generated signal. It also shows how to observe the effect of stan-
dard settings, like an applied filter, an enabled fading or AWGN. The examples use a
simple custom digital modulated signal.

Checking the generated signal graphically
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Configure the graphical signal display

1. Select the wave icon:

The "Graphics Configuration" dialog opens.

2. Select "Mode > Constellation".

3. Select "Source > Baseband".

4. To view the signal, select "Add".

A new thumbnail (minimized view) indicating the constellation diagram appears in
the "Taskbar".

Checking the generated signal graphically
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5. To enlarge the constellation diagram, select it.

The displayed constellation diagram confirms the a QPSK offset modulation.

Figure 9-10: Constellation diagram of a WCDMA-3GPP (QPSK 45° offset) signal

To zoom into a diagram

In an enlarged diagram:

1. Use the one-finger zoom to zoom with a fixed zoom factor.

2. Use the two-finger zoom to do a custom zoom.
This zoom works like the two-finger pinching for magnifying images on your mobile
phone.

If the diagram is zoomed, an overview window appears.

3. Move the visible area in the graphics or in the overview window.

4. For the reverse operation, select "Zoom out".

To enable markers to read-out measured data

In an enlarged diagram:

1. Select "Show Marker".

Two markers appear, one over the other.

2. To position the markers, select and shift them.

"M2-M1" indicates the distance of marker 1 and marker 2 on the x-axis (left value)
and on the y-axis (right value).

3. To hide the markers, select "Hide Marker".

To print the current power spectrum

1. Select "System Config" > "Setup" > "User Interface" > "Hardcopy".

Checking the generated signal graphically
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2. Use the default settings.

3. Select "Save".

The instrument creates a screenshot of the current screen and stores it in a file
with a predefined filename in the default user directory /var/user/.
See Chapter 10.9, "Creating screenshots of current settings", on page 295.

4. Use on of the standard file transfer methods to access the user directory of the
instrument. Transfer the file to a PC.
See Chapter 10.8, "Transferring files from and to the instrument", on page 289.

5. Print the file content.

Checking the generated signal graphically
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10  Managing files and data
The R&S SFI100A uses files to save all instrument data. The instrument allows you to
save and to load instrument settings, and to import and to export user data for process-
ing in another instrument or later. Finally, you can create a screenshot of the current
settings displayed on the screen and save it as a file.

This section focuses on the functions provided for managing of user data files and cov-
ers the topics listed below.

For information on the related remote control commands, refer to Chapter 13.5, "MME-
Mory subsystem", on page 412.

For information on how to save the displayed setting in a file, refer to Chapter 10.9,
"Creating screenshots of current settings", on page 295.

● About the file system.............................................................................................271
● Restoring an instrument configuration.................................................................. 273
● Protecting data......................................................................................................278
● Saving and recalling settings................................................................................ 278
● Managing files with user data................................................................................282
● Exporting and importing remote command lists....................................................284
● Using the file manager.......................................................................................... 284
● Transferring files from and to the instrument........................................................ 289
● Creating screenshots of current settings...............................................................295

10.1  About the file system

Depending on their content, this description distinguishes between system files and
user files. System files and the system directory are protected and not accessible. User
files contain user-defined configurations or data.

This section focuses on user files. It provides an overview of the R&S SFI100A file sys-
tem and covers the following topics:
● "Types of user data" on page 271
● "File storage location" on page 272
● "File handling" on page 272
● "File naming conventions" on page 273
● "File contents" on page 273

Types of user data

The following data types contain user data:
● Settings or configuration files, for example, you save the current instrument set-

tings and load these settings on another instrument.
See Chapter 10.4, "Saving and recalling settings", on page 278.

● SCPI scripts that contain a series of commands. You can run the script to perform
a task.

About the file system
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See Chapter 10.6, "Exporting and importing remote command lists", on page 284.
● Externally generated waveforms. You can load the waveform files at the ARB appli-

cation on the instrument.
See Chapter 4.3, "Using the arbitrary waveform generator (ARB)", on page 64.

Depending on the data storage method, user data can be:
● Persistent, i.e. user files that are recorded on the data storage.

Data is preserved when instrument is powered off and can be accessed and modi-
fied subsequently.

● Temporary, i.e. volatile data that the instrument retains while it is powered on.
Volatile data is immediately lost when the R&S SFI100A is switched off.

File storage location

Both, the user directory /var/user/ on the internal memory or the /usb/ directory
on the memory stick, can be used to preserve user-defined data. Any directory struc-
ture can be created.

The /var/volatile directory serves as a RAM drive and can be used to protect
sensitive information. The data is available temporarily.

Default storage location

The R&S SFI100A stores user data in the user directory.

In the file system, user directory is always indicated as /var/user/.

In manual control, you access this directory via the "File Manager", see Chapter 10.7,
"Using the file manager", on page 284. In remote control, you can query it with the
command :SYSTem:MMEMory:PATH:USER?.

To query and change the default directory used for mass storage, use the command :
MMEMory:CDIRectory.

File handling

To access files and the file system of the instrument or to use the general file manage-
ment functions such as copying and moving data, use the standard "File Manager" dia-
log.

See Chapter 10.7, "Using the file manager", on page 284.

To transfer files from and to the instruments or to exchange files, use one of the follow-
ing alternatives:
● Connect a memory stick to one of the USB interfaces.

The instrument automatically recognizes a connected memory stick and assigns
the /usb/ drive to it.

● Connect the instrument to a LAN.
An instrument connected to a LAN supports two standard file transfer methods
from a remote client:
– FTP (file transfer protocol)
– File sharing according to the SAMBA/SMB (server message block) protocol.

About the file system



Managing files and dataR&S®SFI100A

273User Manual 1179.6789.02 ─ 02

Both file transfer methods open the folder /user that is the /var/user/ folder on
the instrument.
For a step-by-step description, see Chapter 10.8, "Transferring files from and to the
instrument", on page 289.

● Map a network folder or a computer to an instrument connected to a LAN.
A mapped network folder is indicated as /shares/<"Local Folder">.
For a step-by-step description, see Chapter 10.7.4, "Mapping a network folder",
on page 288.

File naming conventions

To enable files to be used in different file systems, consider the following file naming
conventions:
● The filename can be of any length and is case-sensitive, i.e it is distinguished

between uppercase and lowercase letters.
● All letters and numbers are permitted (numbers are, however, not permitted at the

beginning of the filename).
● Avoid using special characters.
● Do not use slashes "\" and "/". These symbols are used in file paths.
● Avoid using the following filenames: CLOCK$, CON, COM1 to COM4,

LPT1 to LPT3, NUL or PRN
They are reserved by the operating system.

File contents

To maintain the file size and to accelerate processing times, the instrument saves set-
tings that deviate from their default values. Considered is also configuration data for
the operating elements and lists with user data, e.g. dialog positions and a list of user
correction data. However, if a list data is part of the instrument settings, a reference to
this list is saved, not the list itself.

This approach ensures that the created files contain only relevant information and
allows you to transfer instrument settings even between different equipped signal gen-
erators. During the recall process, the instrument interprets only the relevant settings;
all non-referenced parameters are set to their preset values. Error messages indicate
the settings which cannot be implemented, like referencing non-existing lists or the
attempt to activate settings which are not supported by the instrument.

10.2  Restoring an instrument configuration

The R&S SFI100A has various options to set default settings. You can preset the
R&S SFI100A to an initial state at any time as a known starting point for configurations.
It is often useful as a first step during troubleshooting when unusual results arise.

Overview of the characteristics of the preset functions

Select the preset option that most fits to your particular application:

Restoring an instrument configuration
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● [Preset]
It is the most frequent function. A preset executes a defined instrument setup to
provide an initial instrument state as a basis for a new configuration.
It resets all parameters and switching states including the states of inactive operat-
ing modes. Also, it resets external instruments connected to the R&S SFI100A.
A preset does not change network settings, remote access settings or system set-
tings.

► To execute a preset, press the [Preset] key at the front panel.

● "Set to Default"
This function relates to individual dialogs or tabs and resets the associated settings
of the corresponding dialog. All other settings are retained.

► To reset the settings, click "Set To Default".

● "Preset this parameter"
Sets a single parameter to its default value.

1. To reset an individual parameter, open its context-sensitive menu.

2. Select "Preset This Parameter".

● "Factory Preset"
A factory preset is the most profound preset function that resets almost all instru-
ment settings, including reference oscillator, network and remote access settings.
A factory preset does not change the following settings:
– Security, password, and settings protected by these passwords
– User-defined data, like setups or data lists
– Settings that relate to an integration of the instrument in a measurement setup.

► NOTICE! Execute a "Factory Preset" only if it is necessary. After a "Factory Pre-
set", the network connection to the instrument no longer exists.
To restore the factory defaults, select "System Config" > "Setup" > "Settings" >
"Factory Preset".
See "Execute Factory Preset" on page 276.

Restoring an instrument configuration
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Presetting the instrument to a user-defined state

The reset functions set the parameters and operating modes to default values prede-
fined by the factory. Alternatively to these default settings, you can:

Alternatively to recalling the instrument default settings, you can preset the instrument
to a user-defined state as follows:
● Restore user-specific settings after a preset, see Chapter 10.2.3, "Presetting the

instrument to a user-defined state", on page 276.
● Save and reload user-defined instrument states, see Chapter 10.4.2, "Saving and

recalling instrument settings", on page 281.

Marking parameters with non-default values

To check the current state of the settings concerning default values, the R&S SFI100A
offers a feature that visually identifies deviations from the default values.

For more information, see Chapter 10.2.2, "Identifying parameters with non-default val-
ues", on page 276.

10.2.1  Preset, set to default and factory preset settings

Preset..........................................................................................................................275
Set To Default..............................................................................................................275
Preset this Parameter................................................................................................. 275
Execute Factory Preset...............................................................................................276

Preset
Resets all parameters and switching states, and closes all opened dialogs.
Note:
In contrast to the [Preset] key, the SCPI commands *RST and :SYSTem:PRESet do
not close open dialogs in the GUI.
Consider also the following possibilities:
● You can define the settings that are restored when you preset the instrument

(see Chapter 10.2.3, "Presetting the instrument to a user-defined state",
on page 276)

● You can reset the instrument to the factory state
(see "Execute Factory Preset" on page 276)

See also Table 10-1 that contains the key parameters that are reset by the correspond-
ing preset functions.
Remote command: 
*RST on page 409

Set To Default
Resets the associated settings of the corresponding dialog or tab.

Preset this Parameter
Restores the default value of a single parameter.
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Execute Factory Preset
Resets the instrument to its factory settings.
Note: "Factory Preset" retains all security settings and does not delete any user files
like setups or user data.
See also Table 10-1 that contains the key parameters that are reset by the correspond-
ing preset functions.
Remote command: 
:SYSTem:FPReset on page 412

10.2.2  Identifying parameters with non-default values

To recognize the current state of the settings related to their default values at the first
glance, enable a function that visually identifies parameters in states different than pre-
set.

To enable this display:

1. To open the context-sensitive menu, touch and hold the screen anywhere in the
GUI of the R&S SFI100A.

2. Select "Mark All Parameters Changed from Preset".

If enabled, marks the parameters that deviate from their default values.

Example: 

Figure 10-1: Marked parameters show that the value deviates from its default

Frequency = changed (default = 1 GHz)
Offset = changed (default = 0 kHz)
Multiplier = unchanged
Variation active = changed (default = disabled)
Variation step = unchanged

10.2.3  Presetting the instrument to a user-defined state

You can define the settings that are restored when you preset the instrument.

1. Configure the settings as required.
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2. Save them as described in Chapter 10.4.2, "Saving and recalling instrument set-
tings", on page 281:

a) Save the settings as a file with the predefined filename
UserPreset.savrcltxt.

b) Save this file in the directory /var/user/.

The filename UserPreset.savrcltxt and the directory /var/user/ are man-
datory.

3. Press the [Preset] key.
When operating the instrument remotely, send the *RST command.

The instrument restores these user-defined settings. An "Info" message appears
and confirms loading of a file with user-defined preset settings.

10.2.4  Reference

See Table 10-1 for an overview of the main generator settings that are affected by the
corresponding preset functions. While the regular [Preset] key primarily resets the sig-
nal relevant parameters of the instrument, the "Factory Preset" affects almost all instru-
ment settings.

For information on the default values of further parameters, see the description of the
corresponding remote commands.
Table 10-1: Key parameters affected by preset and factory preset

Parameter Preset value Preset Factory
Preset

RF frequency 1 GHz x x

RF level (RF output) off x x

Offsets 0 x x

Modulation state off x x

Reference frequency settings - - x

Network settings - - x

Hostname - - x

Start or stop display update - - x

Display and keyboard settings - - x

Password and password-protected settings - - -

Security settings - - -

User files (setups, user correction, etc.) - - -
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10.3  Protecting data

During operation, the R&S SFI100A saves user data permanently in the user directory,
see "File storage location" on page 272.

To protect any classified data and to avoid saving any sensitive data on the
R&S SFI100A permanently, you have the following options:
● Activate the volatile mode. This mode redirects user data to the volatile memory,

see "Volatile Mode" on page 323.
The internal memory is write-protected.
Once you power off the instrument for at least five minutes, all volatile memory
modules lose their contents.
To avoid loosing this data, connect an external memory device, for example, a
USB flash drive.
See also:
– "Default storage location" on page 272
– "Volatile Mode" on page 323
– Chapter 10.8.4, "Using a USB storage device for file transfer", on page 293

● Save user files temporarily in the /var/volatile directory, which remains
available only until the instrument is turned off.
You can access data in the volatile memory just as data that is saved permanently
in the /var/user/.
See also Chapter 10.7.3, "Displaying all saved files", on page 287.

For detailed information on how to protect the instrument and to protect sensitive data
from unauthorized access, refer to the document Instrument Security Procedures.

10.4  Saving and recalling settings

You can save and recall instrument settings, user settings and other related data for
the following use cases:
● Reload or repeat a specific signal generation task on the instrument.
● Transfer a specific configuration of your instrument to another instrument, for

example in multi-intrument setups.
● Save or load complete instrument settings to or from a file.

Save or recall the complete instrument settings

Two different methods are available for managing complete instrument settings:
● Immediate (quick) Save/Recall

A defined set of instrument settings are saved or recalled quickly in just one step,
without defining a filename or storage location. This function enables a fast switch-
ing between different instrument settings.

● Save/Recall in files with user-defined names
The defined set of instrument settings are saved to a definable storage location.
The file extension is *.savrcltxt.

Saving and recalling settings
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Settings files created in this way are visible in the file system and accessible with
the supported methods for file handling.

In the general case, a recall process replaces the instruments settings with the saved
values. An exception is the frequency and level settings. During recall of the instrument
settings, it is possible to retain the current settings or to overwrite them with the saved
values.

10.4.1  Save/Recall settings

Access:

1. Press the [Save/Recall] key.

2. Select "Operation Mode" > "Save" or "Recall" to open the corresponding settings.

The settings for both operation modes are similar and related.

Settings:

Operation Mode.......................................................................................................... 280
Directory, File List and Filename.................................................................................280
Recent files................................................................................................................. 280
Show SCPI List........................................................................................................... 280
SCPI List..................................................................................................................... 280
Save............................................................................................................................ 280
Save Immediate x....................................................................................................... 280
Exclude Frequency..................................................................................................... 281
Exclude Level..............................................................................................................281
Recall.......................................................................................................................... 281
Recall Immediate x......................................................................................................281
File Manager............................................................................................................... 281
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Operation Mode
Accesses the settings for storing ("Save") and loading ("Recall") of the instrument set-
tings. Also, you can import SCPI-Files ("SCPI-Import") or export SCPI files ("SCPI-
Export").
See Chapter 10.6, "Exporting and importing remote command lists", on page 284.

Directory, File List and Filename
Note:
You access this generic standard function each time you perform one of the following:
● Save or load (settings) files
● Define a folder in that these files are saved
● Navigate through the file system.
The dialog name changes depending on the context. The provided functions are self-
explanatory and similar.
Use the settings for example as follows:
● To navigate through the file system, use the directory tree.
● To perform standard file management functions, like create directories, move, copy,

delete files and/or directories, use the standard "File Manager" function (see Chap-
ter 10.7, "Using the file manager", on page 284).

Remote command: 
To list all files in a directory:
:MMEMory:CDIRectory on page 417
:MMEMory:CATalog? on page 417

Recent files
Displays the files last used.

Show SCPI List
Opens the "SCPI List", which lists the current settings of the R&S SFI100A as SCPI
commands.
The R&S SFI100A provides this function for Operation Mode > SCPI-Export.

SCPI List
Provides a list of all SCPI commands corresponding to the current instrument settings.

Save
Saves the current instrument settings under the defined filename.
Remote command: 
:MMEMory:STORe:STATe on page 423

Save Immediate x
Stores the current instrument setting in one of the intermediate memories.
These instrument settings are retained until a different instrument setting is stored in
the intermediate memory. When the instrument is switched off, the contents of the
intermediate memories are retained.
Remote command: 
*SAV on page 410

Saving and recalling settings
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Exclude Frequency
The current frequency is retained when a stored instrument setting is loaded.
Remote command: 
[:SOURce<hw>]:FREQuency[:CW|FIXed]:RCL on page 492

Exclude Level
The current level is retained when a stored instrument setting is loaded.
Remote command: 
[:SOURce<hw>]:POWer[:LEVel][:IMMediate]:RCL on page 512

Recall
Restores the selected configuration.
During recall, the instrument considers all related settings, for example sweeps in
active state or lists. An error message indicates the settings which cannot be imple-
mented.
Remote command: 
:MMEMory:LOAD:STATe on page 421

Recall Immediate x
Loads the selected configuration from one of the intermediate memories. A message
appears if no instrument configuration is stored in this memory.
Remote command: 
*RCL on page 409

File Manager
Accesses the "File Manager" dialog, see Chapter 10.7, "Using the file manager",
on page 284.

10.4.2  Saving and recalling instrument settings

Instrument settings can be saved to a file and loaded again later, so that you can
repeat the tests with the same settings.

To access and recall instrument setups quickly

► Assign the appropriate action to the [★] key.
See Chapter 11.2.4, "How to assign actions to the [★] key", on page 309.

To save and recall instrument settings

1. Select "System Config" > "Setup" > "Settings" > "Save / Recall" > "Operation
Mode" > "Save".

2. Select "Save Immediate 1".

The instrument saves its settings in the intermediate memory 1. The filename and
the storage location cannot be changed.

3. Adapt the instrument settings as required. Select "Save Immediate 2"

Saving and recalling settings
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4. To restore the settings, select the "Operation Mode > Recall"

5. Select "Recall Immediate 1"

The instrument is restored to the previous state.

6. Select "Recall Immediate 2" to switch to the settings saved in the second file.

To save complete instrument settings

1. Select "System Config" > "Setup" > "Settings" > "Save / Recall" > "Operation
Mode" > "Save".

2. In the file selection dialog, select a filename and storage location for the settings
file.

3. Select "Save".

A file with the defined name and path and the extension *.savrcltxt is created.

To restore an instrument configuration

Save the configuration as described in "To save complete instrument settings"
on page 282.

1. To restore settings, select "System Config" > "Setup" > "Settings" > "Save / Recall"
> "Operation Mode > Recall".

2. To retain the current frequency and level settings, enable "Save"/"Recall" >
"Exclude Frequency"/"Exclude Level",

3. In the file select dialog, select the filename and storage location of the settings file.

The settings are restored, but the frequency and level settings are retained. You
can repeat the signal generation with the same settings.
See also Chapter 10.2.3, "Presetting the instrument to a user-defined state",
on page 276.

10.5  Managing files with user data

For loading waveform files or applying user correction values, use dedicated files.
Whenever your setup requires these files, use the standard "File Select" function. This
function enables you to select, create and edit these files.

To use the file-select settings

1. For example, select "Baseband" > "ARB" > "General" > "Load Waveform ...".

A file select dialog opens for loading, creating and modifying a file.

Managing files with user data
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The name of the dialog can be different but the provided functions are equal. See
also Chapter 4.3.4.2, "Loading and playing waveform files", on page 84.

2. To load a file, proceed as follows:

a) Navigate through the file system.
b) Select the file.
c) Confirm with "Select".

3. To create a file, proceed as follows:

a) Navigate through the file system.
b) Select "New".
c) Enter the filename.

The instrument saves the created file into the selected folder.

4. To edit a file, proceed as follows:

a) Navigate through the file system.
b) Select the file.
c) Select "Edit".
d) Edit the file content.
e) Confirm with "Save".

Settings:

Directory, File List and Filename.................................................................................283
Recent files................................................................................................................. 284
File Manager............................................................................................................... 284

Directory, File List and Filename
Note:
You access this generic standard function each time you perform one of the following:
● Save or load (settings) files
● Define a folder in that these files are saved
● Navigate through the file system.

Managing files with user data
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The dialog name changes depending on the context. The provided functions are self-
explanatory and similar.
Use the settings for example as follows:
● To navigate through the file system, use the directory tree.
● To perform standard file management functions, like create directories, move, copy,

delete files and/or directories, use the standard "File Manager" function (see Chap-
ter 10.7, "Using the file manager", on page 284).

Remote command: 
To list all files in a directory:
:MMEMory:CDIRectory on page 417
:MMEMory:CATalog? on page 417

Recent files
Displays the files last used.

File Manager
Accesses the "File Manager" dialog, see Chapter 10.7, "Using the file manager",
on page 284.

10.6  Exporting and importing remote command lists

To set specific instrument settings or perform tasks automatically, you can create
scripts or import scripts that contain the settings in the form of remote control com-
mand sequences.

The R&S SFI100A also offers a SCPI macro recorder with code generator to record
manual settings and create an executable script.

Completed scripts are saved in files and possibly converted to different formats,
depending on the language of the source code.

The R&S SFI100A supports the following commonly used languages:
● Plain SCPI: *.txt
● MATLAB: *.m
● NICVI: *.c
● Python: *.py
It is also possible to convert the SCPI command list to a user-specific language.

How to: Chapter 12.9, "Using remote command scripts", on page 385.

10.7  Using the file manager

The "File Manager" is a tool similar to a standard Windows Explorer. It helps you man-
age mass storage media and files saved on the R&S SFI100A.

Using the file manager
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You can perform the following tasks:
● Copying multiple files from disk to other media

See Chapter 10.8, "Transferring files from and to the instrument", on page 289
● Copying files into another directory

See Cut, Copy&Paste and Delete
● Renaming and deleting files
● Creating directories

See Create New Directory
● Mapping shared network folders

See Chapter 10.7.4, "Mapping a network folder", on page 288
● Displaying saved files

See Chapter 10.7.3, "Displaying all saved files", on page 287

10.7.1  File manager settings

Access:

► Select "System Config" > "Setup" > "Settings" > "Save / Recall" > "File Manager".

Tip: Each "Save/Recall" dialog and each "File Select" dialog provides a quick
access to the "File Manger".

The "File Manager" dialog provides all standard functions required for file manage-
ment. It displays the contents of the selected folder on the R&S SFI100A and pro-
vides functions to rename, delete, copy, or move individual files.

Settings:

Map Network Share.................................................................................................... 285
File Type......................................................................................................................285
Directory and Filename............................................................................................... 285
Cut, Copy&Paste and Delete...................................................................................... 286
Rename.......................................................................................................................286
Create New Directory..................................................................................................286

Map Network Share
Opens a dialog where you can map one or more network folders. See Chapter 10.7.2,
"Map network share settings", on page 286.
See also Chapter 10.7.4, "Mapping a network folder", on page 288.

File Type
Selects the file type to be listed. If a file type with a specific file extension is selected,
only files with this extension are listed.

Directory and Filename
Selects the directory in which the file to be deleted or copied is located. The dialog lists
all files in this directory. Selected files are highlighted. The path is indicated above the
directory tree.

Using the file manager
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Unlike the "Save/Recall" and "File Select" dialogs, the "File Manager" displays the full
filenames including extensions.
Remote command: 
:MMEMory:CDIRectory on page 417

Cut, Copy&Paste and Delete
Standard file management functions.
Before a file is deleted, you have to confirm the delete operation.
Remote command: 
:MMEMory:DELete on page 421
:MMEMory:COPY on page 417

Rename
Renames the selected file or directory.
Remote command: 
:MMEMory:MOVE on page 422

Create New Directory
Creates a folder and opens an edit dialog box to enter name and path (absolute or rel-
ative to the current directory) of the new folder.
Remote command: 
:MMEMory:MDIRectory on page 421

10.7.2  Map network share settings

Access:

► Select "System Config" > "Setup" > "Settings" > "Save / Recall" > "File Manager" >
"Map Network Share".

The "Map Network Share" dialog provides settings that are similar to the standard Win-
dows Explorer function "Map network drive". These settings help you to create up to 10
"shortcuts" to shared folders or computers in the network.

The dialog displays a list of current mapped network folders. The directory tree of the
"File Manager", "Save/Recall", and "File Select" dialogs indicate a mapped network
folder as /shares/<"Local Folder">.

See also Chapter 10.7.4, "Mapping a network folder", on page 288.

Settings:

Network Folder............................................................................................................287
Local Folder................................................................................................................ 287
User Name.................................................................................................................. 287
Password.................................................................................................................... 287
Reconnect at Startup.................................................................................................. 287
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Connect.......................................................................................................................287
Change........................................................................................................................287
Disconnect.................................................................................................................. 287

Network Folder
Enter the path of the folder or computer, e.g. //<IP Address>/user or //<server
name>/user.

Local Folder
Enter a letter or an alias name to describe the folder.
In the directory tree, a mapped network folder is indicated as /shares/
<"Local Folder">.

User Name
Enter a user name of a user that has the permission to access the selected network
folder.

Password
Enter the user password of the selected user.

Reconnect at Startup
Enables reconnecting every time you start up the instrument.

Connect
Triggers the instrument to prove the credential and to map (i.e. connect) the selected
network folder or computer to the instrument.
You can map up to 10 network folders.

Change
Applies the changes.

Disconnect
Disconnects the network drive.

10.7.3  Displaying all saved files

To display all files on the internal memory

1. Select "System Config" > "Setup" > "Settings" > "Save / Recall" > "File Manager".

2. Navigate to /var/user/.

To display all files on a connected USB flash drive

1. Select "System Config" > "Setup" > "Settings" > "Save / Recall" > "File Manager".

2. Navigate to /usb/.

Using the file manager
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To display all files in the volatile memory

1. Select "System Config" > "Setup" > "Settings" > "Save / Recall" > "File Manager".

2. Navigate to /var/volatile/.

10.7.4  Mapping a network folder

Possibly you would like to transfer instrument or user settings to another
R&S SFI100A, distribute waveform files to several instruments or you have to access
frequently the same network drive. In these cases, on a R&S SFI100A connected to a
LAN you can create a shortcut to this network folder or this computer.

How to: Chapter 3.1.7, "Connecting to LAN", on page 19

To map a network folder, proceed as follows:

1. On the computer or the network folder you want to map, enable remote access.
You can specify a list of users allowed for remote access.

Note: The remote access settings depend on the operating system the remote
computer is using. For step-by-step instructions, refer to the documentation of the
particular operating system.

2. On the R&S SFI100A, enable file transfer via SMB (samba).

3. Select "System Config" > "Setup" > "Remote Access" > "Network" to configure the
following network settings:

a) Select "Address Mode" > "Auto (DHCP)".
b) Check that the "DNS Suffix" and "DNS Server" are correct.

4. In the "Save/Recall" dialog, select "File Manager" > "Map Network Share".

5. In the "Map Network Share" dialog, select:

a) In the "Network Folder" field, enter //<IP Address>/user or //
<Server Name>/user.

b) In the "Local Folder" field, enter an alias name, e.g. setups.
c) Enter the "User Name" and "Password" of a user with a remote access permis-

sion to the selected network folder.
d) If necessary, enable "Reconnect at Startup".
e) Select "Connect".

The selected network folder is mapped to your instrument. The list of mapped net-
work folders is updated.

6. Close the "Map Network Share" dialog.

The navigation tree in the "File Manager" dialog displays the mapped network
folder as /shares/Setups.

Using the file manager
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If the connection does not succeed, consider to check the following:
● Is the network folder or computer you try to map turned on?
● Is the network folder or computer enabled for remote access?
● Does the selected user name have the necessary permissions?

See also Chapter 10.8.5, "Using a file server for test files exchange", on page 294.

10.8  Transferring files from and to the instrument

As explained in "File handling" on page 272, you access the file system of the
R&S SFI100A via one of the following ways:
● Via the built-in "File Manager"

See Chapter 10.7, "Using the file manager", on page 284.
● On an instrument connected to a LAN:

– Via one of the standard functions FTP or SMB (samba)
See Chapter 10.8.2, "Accessing the file system using FTP", on page 291 and
Chapter 10.8.3, "Accessing the R&S SFI100A file system using SMB (Samba)",
on page 292

– Via mapped network drives
See Chapter 10.7.4, "Mapping a network folder", on page 288.

● Via a connected USB storage device
See Chapter 10.8.4, "Using a USB storage device for file transfer", on page 293

Mainly because of security reasons, the access to the file system of your
R&S SFI100A can be denied, because one or all these access methods are deliber-
ately disabled. Access to the file system via LAN and/or USB requires that the corre-
sponding service is enabled and a write access to the file system is enabled. Refer to
Chapter 10.8.1, "Removing file system protection", on page 289 for description of the
required steps.

This section provides an introduction to the topic. For comprehensive information, refer
to the application note 1GP72: Connectivity of Rohde&Schwarz Signal Generators.

● Removing file system protection........................................................................... 289
● Accessing the file system using FTP.................................................................... 291
● Accessing the R&S SFI100A file system using SMB (Samba)............................. 292
● Using a USB storage device for file transfer......................................................... 293
● Using a file server for test files exchange............................................................. 294

10.8.1  Removing file system protection

Before you try to access the file system via FTP, SMB (samba) or USB, fulfill the follow-
ing:
● Disable write protection on the file system
● Enable the corresponding service or interface

Transferring files from and to the instrument

https://www.rohde-schwarz.com/appnote/1GP72.html


Managing files and dataR&S®SFI100A

290User Manual 1179.6789.02 ─ 02

To enable write permission on the file system

1. Select "System Config" > "Setup" > "Security" > "Security".

2. Select "General" > "Disk & Memory".

3. Enable "Volatile Mode".

4. Enter the "Security Password".
The default password is 123456. For more information, see Chapter 11.4, "Using
the security settings", on page 319.

The R&S SFI100A requests a reboot.

5. Confirm the request.

The system reboots. The enabled settings are active.

To enable file transfer over FTP

1. Select "System Config" > "Setup" > "Security" > "Security".

2. Select "LAN Services" > "Common Services" > "LAN" > "On".

3. Enable "FTP"

4. Enter the "Security Password".
The default password is 123456. For more information, refer to Chapter 11.4,
"Using the security settings", on page 319.

5. Select "Accept".

To enable file transfer over SMB (samba)

1. Select "System Config > Setup > Security > Security > LAN Services"

2. Enable "LAN Interface"

3. Select "Samba Services".

4. Enable the "SMB 1.0/2.0 Client".

5. Enable the "SMB 1.0/2.0 Server".

6. Enter the "Security Password".
The default password is 123456. For more information, see Chapter 11.4, "Using
the security settings", on page 319.

7. Select "Accept".

To enable file transfer over USB

1. Select "System Config > Setup > Security > Security > General"

2. Select "Disk & Memory".

3. Enable "USB Storage"

4. Enter the "Security Password".

Transferring files from and to the instrument
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The default password is 123456. For more information, see Chapter 11.4, "Using
the security settings", on page 319.

5. Select "Accept".

10.8.2  Accessing the file system using FTP

If the R&S SFI100A is connected to a LAN, you can use file transfer protocol (FTP) to
access the file system and to transfer files from and to the instrument.

How to: Chapter 3.1.7, "Connecting to LAN", on page 19

To access the file system over FTP

We assume that the instrument and the remote PC are connected to a LAN.

1. Enable file transfer via FTP

2. Enable write permission on the file system

3. On the remote PC, start the Windows Explorer.

4. In the address field, enter ftp://<"IP Address" of the Instrument>, e.g.
ftp://10.124.0.166.
Tip: The R&S SFI100A indicates its IP address on the block diagram.

A log-on dialog opens and requests a password.

The default user name and password is instrument.

Tip:
Default password
The FTP and SAMBA file access use the user "instrument" with default password
"instrument".
We recommend that you change this password in the "Setup > Security > Pass-
word Management > Change User Password" dialog before connecting the instru-
ment to the network.
See Chapter 11.4.4, "Password management", on page 330.

5. Enter the password to access the user directory.
The user directory corresponds to the /var/user/ directory of the instrument.

There, you can perform standard functions like creating directory, or saving files.

6. In the user directory, create a directory, e.g. test ftp.

Transferring files from and to the instrument
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7. Select "System Config" > "Setup" > "Settings" > "Save / Recall".
Open the /var/user/ directory.

The dialog displays the /var/user/test ftp directory.

10.8.3  Accessing the R&S SFI100A file system using SMB (Samba)

The SMB (Samba) protocol is an alternative way to access the file system of the instru-
ment from a remote PC. This protocol works if both the instrument and the PC are con-
nected to a LAN.

How to: Chapter 3.1.7, "Connecting to LAN", on page 19

To access the file system over SMB

We assume that the instrument and the remote PC are connected to a LAN.

1. Enable file transfer via FTP

2. Enable write permission on the file system

3. On the remote PC, start the Windows Explorer.

4. In the address field, enter //<"IP Address" of the Instrument>, e.g. ftp://
10.124.0.166.
Tip: The R&S SFI100A indicates its IP address on the block diagram.

Transferring files from and to the instrument



Managing files and dataR&S®SFI100A

293User Manual 1179.6789.02 ─ 02

The user directory corresponds to the /var/user/ directory of the instrument;
the volatile directory - to the /var/volatile directory.

To map the R&S SFI100A as a network drive to the remote PC

We assume that the instrument and the remote PC are connected to a LAN.

1. Enable file transfer via SMB (Samba)

2. Enable write permission on the file system

3. On the remote PC, start the Windows Explorer.
Open the "Map Network Drive" dialog.

a) Select a valid "Drive", e.g. W.
b) In the "Folder" field, enter //<"IP Address" of the Instrument>/user

or //<"Hostname" of the Instrument>/user
For example: //10.124.0.166/user or //SFI100A-102030/user.
Tip: The R&S SFI100A indicates its IP address on the screen.

c) Select "Finish".

A log-on dialog opens and requests a user name and a password.

Tip:
Default password
The FTP and SAMBA file access use the user "instrument" with default password
"instrument".
We recommend that you change this password in the "Setup > Security > Pass-
word Management > Change User Password" dialog before connecting the instru-
ment to the network.
See Chapter 11.4.4, "Password management", on page 330.

4. Enter the user name and the password of your instrument.

The /var/user/ directory of the instrument is mapped to and displayed as a net-
work drive of the remote PC.

You can access the files in the /var/user/ directory, perform standard function
like creating directory, or saving files.

10.8.4  Using a USB storage device for file transfer

Alternatively to the file transfer possibility via LAN, you can use a USB storage device
for direct file transfer from and to the instrument.

We recommend that you transfer files with user data (like lists or instrument setup files)
to the instrument, rather than load and play them from a connected USB storage
device.

Transferring files from and to the instrument
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To transfer a file with user data to the instrument

1. Connect a USB storage device, for example a USB memory stick to one of the
USB interfaces of the instrument.

The R&S SFI100A recognizes the connected USB storage device automatically.

2. Enable file transfer via USB

3. Enable write permission on the file system

4. Select "System Config" > "Setup" > "Settings" > "Save / Recall".

The dialog displays the /var/user/ directory and the /usb/ drive.

5. In the "Save/Recall" dialog, select "File Manager".

6. In the directory tree, navigate to the /usb/ drive.
Select the required file with user data.

7. Select "Copy".

8. In the directory tree, navigate to the /var/user/ directory.
Select "Paste".

The file with user data is transferred to the instrument.

10.8.5  Using a file server for test files exchange

You can use a central file storage location like a file server in your company network to
save setup files, SCPI scripts, application programs, or waveform files on it. Usually,
you would like to distribute the files to several instruments. If the R&S SFI100As are
connected to a LAN, you can create a shortcut on the instruments to the file server.

To access the file server

1. On each R&S SFI100A, map the required directory of the file server to the instru-
ment.
Perform the steps described in Chapter 10.7.4, "Mapping a network folder",
on page 288.

2. On each R&S SFI100A, use the same alias name for the directory of the file server,
i.e. enter the same "Local Folder" (in this example Setups).

On any of the R&S SFI100A, you access the file server directly from the "File Man-
ager" and under the same name, e.g. /shares/Setups.
An extra advantage in remote control is that the same application program would
control the instruments.
For example, use the remote control command MMEMory:CDIRectory
"/shares/Setups" to set the default directory for mass storage.

Transferring files from and to the instrument
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10.9  Creating screenshots of current settings

The save/recall function enables you to save current settings in a file. To document the
most important settings for a performed signal generation, you can also save a hard-
copy of the current display.

● Hardcopy settings................................................................................................. 295
● Creating a hardcopy of the display........................................................................298

10.9.1  Hardcopy settings

Access:

► Select "System Config" > "Setup" > "User Interface" > "Hardcopy".

The remote commands required to define these settings are described in Chap-
ter 13.10, "HCOPy subsystem", on page 436.

Settings:

Automatic Naming.......................................................................................................296
File.............................................................................................................................. 296
Format.........................................................................................................................296
Options........................................................................................................................296
Save............................................................................................................................ 296
Hardcopy Options > Common.....................................................................................296

└ Automatic Naming.........................................................................................297
└ Format...........................................................................................................297
└ Region...........................................................................................................297

Hardcopy Options > Automatic Naming......................................................................297
└ Path...............................................................................................................297
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└ Clear Path.....................................................................................................298
└ Prefix, Year, Month, Day............................................................................... 298
└ Current Auto Number....................................................................................298

Automatic Naming
If enabled, creates the output filenames automatically according to the rules set with
the Hardcopy Options > Automatic Naming settings.
Remote command: 
:HCOPy:FILE[:NAME]:AUTO:STATe on page 440

File...
In "Automatic Naming > Off" mode, accesses the standard file select dialog for select-
ing the filename and folder the hardcopy is stored in.
If you have enabled "Automatic Naming", the instrument displays the automatically
generated filename.
Remote command: 
:HCOPy:FILE[:NAME] on page 438

Format
Selects the output file format, for example *.bmp, *.jpg*.xpm and *.png.

Remote command: 
:HCOPy:IMAGe:FORMat on page 438
:HCOPy:DEVice:LANGuage on page 438

Options...
Accesses Hardcopy Options dialog.

Save
Saves a hardcopy of the current display as a file.
Remote command: 
:HCOPy[:EXECute] on page 439

Hardcopy Options > Common
Access: select "Hardcopy > Options... > Common".
With the provided settings, you can customize the file format and the syntax of the
automatically assigned filename.

Creating screenshots of current settings
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Automatic Naming ← Hardcopy Options > Common
If enabled, creates the output filenames automatically according to the rules set with
the Hardcopy Options > Automatic Naming settings.
Remote command: 
:HCOPy:FILE[:NAME]:AUTO:STATe on page 440

Format ← Hardcopy Options > Common
Selects the output file format, for example *.bmp, *.jpg*.xpm and *.png.

Remote command: 
:HCOPy:IMAGe:FORMat on page 438
:HCOPy:DEVice:LANGuage on page 438

Region ← Hardcopy Options > Common
Displays the snapshot area.
Remote command: 
:HCOPy:REGion on page 438

Hardcopy Options > Automatic Naming
Access: select "Hardcopy > Options... > Automatic Naming".

Provided are the following settings:

Path... ← Hardcopy Options > Automatic Naming
Selects the directory.
Note: To select the destination path, specify also a filename. Otherwise an error mes-
sage is displayed and selection is canceled.
Remote command: 
:HCOPy:FILE[:NAME]:AUTO:DIRectory on page 439
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Clear Path ← Hardcopy Options > Automatic Naming
Deletes all image files with extensions *.bmp, *.jpg, *.png and *.xmp in the direc-
tory set for automatic naming.
Before the command is executed, a warning message prompts you to confirm the dele-
tion of the files.
Remote command: 
:HCOPy:FILE[:NAME]:AUTO:DIRectory:CLEar on page 440

Prefix, Year, Month, Day ← Hardcopy Options > Automatic Naming
Determines the rules for "Automatic Naming".
Per default, the automatically generated filename is composed of:
<Path>/<Prefix><YYYY><MM><DD><Number>.<Format>, where Y, M and D mean
year, month, Day; Number is the Current Auto Number.

You can activate or deactivate each component separately.
The "Resulting filename" indicates the current filename syntax.
Remote command: 
:HCOPy:FILE[:NAME]:AUTO[:FILE]:PREFix on page 441
:HCOPy:FILE[:NAME]:AUTO[:FILE]:PREFix:STATe on page 441
:HCOPy:FILE[:NAME]:AUTO[:FILE]:YEAR:STATe on page 441
:HCOPy:FILE[:NAME]:AUTO[:FILE]:MONTh:STATe on page 441
:HCOPy:FILE[:NAME]:AUTO[:FILE]:DAY:STATe on page 441

Current Auto Number ← Hardcopy Options > Automatic Naming
Indicates the number which is used in the automatically generated filename.
Note: When initially switching on the instrument, the number is reset to the lowest pos-
sible value. Starting with number 0 the output directory is scanned for existing files. As
long as files with the same name are existing, the number is increased by 1. The num-
ber is automatically set so that the resulting filename is unique within the selected path.
The current number is not in the save/recall file but is temporarily stored within the
database. At the following save operation, the number is increased.
Remote command: 
:HCOPy:FILE[:NAME]:AUTO[:FILE]:NUMBer? on page 441

10.9.2  Creating a hardcopy of the display

To create a hardcopy

► Select "System Config" > "Setup" > "User Interface" > "Hardcopy".

Alternatively, you can use the following controls to create a hardcopy quickly:
● On the screen, select context-sensitive menu >  (print).
● On an external keyboard, press the [Print] key.
● Assign the hardcopy function to the [User] key.
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See Chapter 11.2.4, "How to assign actions to the [★] key", on page 309.

The R&S SFI100A creates a snapshot of the screen and opens the "Hardcopy" dia-
log for saving it in a file.

To configure and save the hardcopy

1. To define the output format, select "Format" > "JPG".

2. To enable the instrument to create output filenames, select "Automatic Naming" >
"On".

3. Select "Options ...".

4. In the "Hardcopy Options" dialog:

a) To change the default storage directory, select "Automatic Naming Settings" >
"Path".

b) Define a path and a filename.
For example, select the default directory /var/user.

c) If necessary, modify the parameters in the "Automatic Naming Settings".
d) Close the "Hardcopy Options" dialog.

5. In the "Hardcopy" dialog, select "Save".

The instrument saves a hardcopy of the current instrument display as a *.jpg file.
Also, creates the filename automatically.

To export a hardcopy

1. Connect the instrument to the LAN.

2. Transfer the file to a remote computer
See Chapter 10.8, "Transferring files from and to the instrument", on page 289.

3. On the remote computer, select the file.

Creating screenshots of current settings
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11  General instrument functions
The general instrument functions include basic instrument settings, regardless of the
selected operating mode and measurement. Some of these settings like screen display
and peripherals are initially configured at the setup of the instrument, according to per-
sonal preferences and requirements. However, you can individually adjust the settings
at any time, for example, for specific applications.

11.1  Customizing the user interface

11.1.1  Display and keyboard settings

Access:

1. Select "System Config > Setup > User Interface > Display".

2. Select "Keyboard".

In the "Display" and "Keyboard" dialogs, you can enable the screen saver function
and configure the language for the key assignment of an external keyboard and the
keypad.

Customizing the user interface
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The remote commands required to configure the display and keyboard are described in
Chapter 13.8, "DISPlay subsystem", on page 430 and Chapter 13.11, "KBOard subsys-
tem", on page 442.

Screen Saver.............................................................................................................. 301
Wait Time.................................................................................................................... 301
Display........................................................................................................................ 301
RF Hardkey................................................................................................................. 301
Layout......................................................................................................................... 301

Screen Saver
Activates the screensaver.
If activated, the display including backlight is switched off after the selected Wait Time
elapses and if no entries via touch panel, front panel, external mouse, or external key-
board are made
Remote command: 
:DISPlay:PSAVe[:STATe] on page 432

Wait Time
Enters the idle time that must elapse before the display lamp is shut off when no
entries are made.
Remote command: 
:DISPlay:PSAVe:HOLDoff on page 431

Display
Adjusts the brightness of the display.
Increase the value to turn up the display brightness.
Remote command: 
:DISPlay:BRIGhtness on page 432

RF Hardkey
Adjusts the brightness of the [RF On/Off] key.
Increase the value to change the contrast between the key and the front panel back-
ground color.
Remote command: 
:DISPlay:BUTTon:BRIGhtness on page 432

Layout
Selects the language of an external keyboard connected over USB. The function
assigns the corresponding keys automatically.
Remote command: 
:KBOard:LAYout on page 442

Customizing the user interface
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11.1.2  Display update settings

Access:

► Select "System Config > Setup > User Interface > Start/Stop Display Update".

This dialog enables you, to deactivate updating the display.

The remote command to switch off the display update is described in Chapter 13.8,
"DISPlay subsystem", on page 430.

Display Update is
Disables the automatic refreshing of the displayed values.
Remote command: 
:DISPlay:UPDate[:STATe] on page 432

11.1.3  Power-On/EMF settings

Access:

► Select "RF" > "RF Level" > "Power-On/EMF".

The "Power-On/EMF" dialog contains the setting for configuring the power-on
behavior.

Power-On State...........................................................................................................302

Power-On State
Determines the RF signal output state when the instrument is switched on.
You can disable the RF output signal in general, or start it in the same state as it had
been when it was switched off.
Remote command: 
:OUTPut<hw>[:STATe]:PON on page 443

Customizing the user interface
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11.2  Organizing frequently used settings as favorites

The R&S SFI100A provides two possibilities to define frequently used settings and pro-
cedures for later retrieval individually.

User menu and [★] key

These two functions work similar to the favorites function of a browser or other pro-
grams. They allow you to create a list of frequently used actions or to group frequently
used settings in one dialog.

You can collect the parameters of your configuration in a favorites list, i.e. in the "User
Menu", or define settings and actions with the [★] key:
● "User Menu" to group settings of specific tasks.

Similar to a favorites function, you can use this menu for:
– Grouping the settings required for a task in one dialog.
– Saving and recalling the settings of a task.
– Transferring the settings for use on multiple instruments.

● [★] key, with customizable function.
You can perform the following steps using this key:
– Open the "User Menu" (default functionality).
– Add or remove settings and functions.
– Execute actions and access functions.

Possible applications

The ★ key and the "User Menu" are useful for the following situations:
● There are functions or tasks you have to perform in a defined order but the setting

parameters are distributed across several dialogs.
● There are functions or tasks you have to perform frequently but they are not acces-

sible via the front panel keys.
● The required functions are grouped in a dialog that is not directly accessible from

the block diagram.
● Your task involves loading and executing of SCPI scripts.

See Chapter 12.9, "Using remote command scripts", on page 385.
● A quick access to saved setups is required.
● There are functions and tasks you have to perform on several instruments.

Dialog identification

To identify each dialog, the instrument uses a dedicated dialog ID. The dialog ID con-
tains the dialog position on the display and the current active tab. The action that trig-
gers the instrument to open a dialog uses this identification.

Organizing frequently used settings as favorites
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Save/Recall vs. recall setup

If you need to restore a specific signal generation setup and perform further configura-
tions based on this particular instrument state, the R&S SFI100A provides two options:
● "Save/Recall" function

For a detailed description, refer to Chapter 10.4, "Saving and recalling settings",
on page 278.

● "Recall Setup" function
If the "Recall Setup" is the only user action assigned to the [★] key, pressing this
key triggers the R&S SFI100A to load the user-defined preset file immediately.

11.2.1  User menu settings

The "User Menu" dialog contains function keys to organize, save and load a favorites
list. You can also modify, add or delete list entries directly in the dialog.

Clear User Menu
Removes all entries from the "User Menu" at once.

Save User Menu
Saves the current "User Menu" under the defined filename.

Recall User Menu
Loads the selected "User Menu" file.
This function enables you to use the user specific favorites file on another instrument.
However, if functions or parameters are not provided due to varying configuration of
the instrument, the settings of these particular parameters take no effect.
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11.2.2  How to use the user menu for fast adjustments

Access:

1. Press the [★] key.

The "User Menu" dialog opens.

If you execute this action for the first time, the dialog displays instructions on how
to use the "User Menu".

2. If you already have a saved user menu file on the instrument, you can load with
"Recall User Menu".

Creating a user menu

To create your own user dialog with settings:

1. Open a dialog with settings you frequently use.

2. Select a parameter.

3. Open the context menu and select "Add to User Menu".

A favorites icon  indicates that the parameter is used in the "User Menu".

Organizing frequently used settings as favorites
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The "User Menu" button in the taskbar confirms that you have created a "User
Menu" with at least one entry.

4. Press the [★] key.

The "User Menu" dialog shows all parameters that you have added to the list.

You can modify the parameter settings directly in this dialog, e.g .change a state or
set values, as you do in the particular dialog the parameter originally belongs to.

5. To remove an entry, select the parameter either in the "User Menu" or in the dialog
where it originally belongs to.

a) Open the context menu and select "Remove from User Menu".

6. To remove all entries at once, select "Clear User Menu".

7. To save your individual favorites list, select "Save User Menu", and follow the file
managing instructions.
The file system automatically assigns the file extension *.user_menu.

8. To recall a previously saved user menu, select "Recall User Menu" and proceed
accordingly.

Providing a user menu favorites list for several instruments

To transfer files from or to an instrument:

1. Create the favorites list, as described in "Creating a user menu" on page 305.

2. Save the favorites list.
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3. To tansfer a file from or to an instrument, the R&S SFI100A provides several
options, see "File handling" on page 272.

11.2.3  Define user key actions settings

Access:

► Select "System Configuration > Setup > User Interface > Define User Key".

The dialog displays a list of the currently enabled actions and provides functions to
define new, edit or remove existing actions. If no actions have been defined, the list
is empty.
See Chapter 11.2.4, "How to assign actions to the [★] key", on page 309.

The remote commands required to define these settings are described in Chapter 13.8,
"DISPlay subsystem", on page 430.

Name
Enters a user-defined name for the action.

Wizard
Defines the action to be executed.
"Load SCPI Script"

Selects and executes the SCPI script.
"Recall Setup" Opens the file dialog for selecting a saved setup with user-defined

settings.
"Open Dialog"

Selects an open settings dialog or menu.

Organizing frequently used settings as favorites



General instrument functionsR&S®SFI100A

308User Manual 1179.6789.02 ─ 02

Select
Depending on the selected "Wizard", provides access to:
● the standard "File Select" function for loading an SCPI script or setup file
● a list of all currently opened dialogs.

See SCPI.

SCPI
For the currently selected action, displays the corresponding SCPI command with the
associated parameter for dialog identification (dialog ID). The automatically displayed
SCPIs are enabled for subsequent modification.
Remote command: 
:DISPlay:DIALog:OPEN on page 434
See also :DISPlay:DIALog:ID? on page 434

Add, Change, Remove
Standard functions for managing of the actions.

Back to Execute Mode
Opens the "Select Action to Execute" dialog. Select an Action form the list to execute
it.
To return to the "Define User Key Actions" dialogs, select Select Action to Execute >
Define Actions.

Select Action to Execute > Define Actions

Opens the "Define User Key Actions" settings dialog.
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11.2.4  How to assign actions to the [★] key

The customizable [★] key has no predefined function assigned. You can individually
define actions to be executed or functions to be accessed when pressing this key.

To assign a frequently used dialog to the [★] key:

1. Open the dialog you want to quickly access.

2. Select "System Configuration > Setup > User Interface > Define User Key".

3. To create an action:

a) Specify the "Name".
E.g. Open reference frequency.

b) Select "Wizard > Open Dialog"
c) Select "Select Dialog" and select a settings dialog from the list

The corresponding SCPI command is automatically displayed and can be modified.

4. Select "Add" to save the new action in the list of user key actions.

5. To execute the created action, press ★.
In the list of actions ("Select Action to Execute" dialog), navigate to the required
action.
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The R&S SFI100A executes the action and opens the dialog.

11.3  Managing licenses and license keys

An option is ready to operate after it is enabled with a license keycode supplied with
the option. The license key is delivered as a file or on paper. Unregistered licenses
must be registered for a particular instrument before the corresponding option can be
enabled for operation.

For reliable operation, a software option usually requires the latest firmware version.
The required version is specified in the delivery. If your instrument works with a former
firmware version, update the firmware before enabling the software option.
The firmware update is described in the release notes provided on the product page of
the R&S SFI100A.

11.3.1  Manage license keys settings

The "Manage Licnese Keys" dialog provides all information on the available licenses.
Instrument-related steps guide you through the process of registering or deactivating
licenses.

Access:

1. Select "System Config > Setup > Instrument Assembly > Manage License Keys >
Manage License Keys".

Managing licenses and license keys
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In this tab, you can activate licenses for newly purchased or newly registered
options.

2. Select "Installed License Keys".

This tab lists all active options, with information on the available number of an
option, the license type and registration. You can query inactive or disabled options
also.

3. Select "Open License Server".

The "Manage License Keys" dialog covers all required parameters for activating or
deactivating newly purchased or newly registered options, and provides access to
the onboard license server, see Chapter 11.3.2, "Using the license server",
on page 313.
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Settings

Device ID.....................................................................................................................312
Enter License Key....................................................................................................... 312
Import License Key from File...................................................................................... 312
Export Deactivation Response to File......................................................................... 312
License Installation Info...............................................................................................312
Installed License Keys................................................................................................ 312

└ Show Inactive................................................................................................312
└ Show Deactivated.........................................................................................312
└ Installed License Keys Table.........................................................................313

Open License Server.................................................................................................. 313

Device ID
Displays the instrument-specific identification number. The device ID is a unique string
with the following structure:
<stock number>-<serial number>-<checksum>

Enter License Key
Type here the license key provided with the option.
For license keys delivered as a file, use Import License Key from File....

Import License Key from File...
Opens a dialog for selecting the file with the license key.
Use this function also to import the deactivation key file generated by the R&S License
Manager online tool (see How to move a portable license).

Export Deactivation Response to File...
Exports the generated deactivation response key to a file and opens a file manage-
ment dialog to save the file.
This key is required during the unregistration process, e.g. when you want to deinstall
an option or have a portable option, which you want to register later on another instru-
ment (see How to move a portable license).

License Installation Info
Indicates status information on the performed actions.

Installed License Keys
Access: select "System Config > Setup > Instrument Assembly > Manage License
Keys > Installed License Keys".
Comprises information on the installed options.

Show Inactive ← Installed License Keys
Enables the display of the inactive (expired) licenses in the Installed License Keys
Table.

Show Deactivated ← Installed License Keys
Enables the display of the deactivated licenses in the Installed License Keys Table.
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See How to move a portable license for information on how to activate deactivated
licenses.

Installed License Keys Table ← Installed License Keys
Shows information on the currently installed options.
"Export License Key to File"

Opens a dialog to save the generated license key file. This file is
required during the unregistration process.
If you have a portable unregistered option, you can register it later on
another instrument (see How to move a portable license).

"Option" Displays the short designation of the option.
"License Count"

Displays the number of the licenses for the selected option key.
"License Type" Displays the type of license.

A license type determines the common qualification application dura-
tion and the portability of a license. The following license types are
provided: evaluation, permanent, portable, quantified, time-controlled
with a duration of 1, 3, 6 or 12 months. A license can also be deacti-
vated or expired.
For time limited licenses, the left time of applicability is displayed too.

"Registrations" (reserved for future use)

Open License Server
Opens the R&S License Server of the R&S SFI100A, see Chapter 11.3.2, "Using the
license server", on page 313.

11.3.2  Using the license server

The R&S SFI100A now supports handling of software licenses using the license server
from Rohde & Schwarz.

To open the license server

Access:

1. Select "System Config > Setup > Instrument Assembly > Manage License Keys >
Installed License Keys".
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2. Select "Open License Server".

The license server browser opens in a browser window and starts initially in the
"Configuration" view.

Figure 11-1: R&S license server dialog

The icons in the status bar on the right lead you to information on the license server:
● "About": shows the software version.
● "User Manual": opens the embedded license server user manual.
● "Help": provides the functional description on a specific dialog and its settings.

Short glance at the main views

The section provides a brief insight into the main windows of the license server. For
details and handling of the application, refer to the embedded user documentation.

1. To access a view, select the menu button.

2. Select "Configuration".
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Figure 11-2: Configuration menu

Accesses the license server, access lists and installed product definitions.

a) Select "Local license server".

Figure 11-3: Example of a local license server view

Shows the onboard license server of the instrument. With the column selection,
you can indicate or unhide characteristics of the available server. The task bar
buttons provide access to the corresponding functions and access lists.

b) Select "Product definitions".

Figure 11-4: Example of a product definition view

Shows installed product definitions. To view the available characteristics, use
the column selection.
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3. Select "Licenses".
Provides access to the available license servers.

The "License keys" view lists the license key options that are available on the
selected server. To show additional information, use the column selection.
The task bar functions enable you to activate or deactivate a license, to get details
on an option and export license keys or information on the selected product.

4. Select "Analytics".

Figure 11-5: Analytics menu

Provides access to the license providers, client applications and enables you to
export statistics data for evaluation in external applications.

Shows information on configured client applications, license providers and license
types. To show additional information, use the column selection.

To manage licenses on the R&S SFI100A

To request or return a license, proceed as follows:

1. Access: see "To open the license server" on page 313.

The browser application opens.

2. Select "Licenses"

3. Select a license server in the menu list, e.g. "R&S SFI100A".

The "License keys" view lists the enabled options available on the selected server.

4. Select "Status" > "Select all" to list also options that are currently deactivated.

The "Licenses" view shows all active, inactive and time limited options.

5. To get detailed information on a specific option:

a) Select the option in the list.
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b) In the task bar, select "Details".

Figure 11-6: Example of the license characteristics of an option

6. To enable a discontinued license: , select  in the taskbar.

a) Select the license you want to activate.
b) In the task bar, select .

7. To return a license, proceed the same way:

a) Select the license.
b) Deactivate the license with .

8. Follow the instructions on the screen.

11.3.3  How to move a portable license

This example is intended to explain how to perform the required steps at the instru-
ment.

Use a USB flash drive to transfer the license key files between the instruments and the
browser.

We assume knowledge about the handling of the R&S License Manager online tool
and the description of the whole process.

1. Open your browser. Enter https://extranet.rohde-schwarz.com/service.
Select "Manage Licenses > Move Portable License".

The first step requires the Device IDs of the source and target instruments.

2. To find out the Device IDs, proceed as follows:

Managing licenses and license keys
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a) On the source instrument, select "System Config > Setup > Instrument Assem-
bly > Manage License Keys > Manage License Keys > Device ID".

b) On the target instrument, select "System Config > Setup > Instrument Assem-
bly > Manage License Keys".

c) In the "Mange License Keys" tab, select "Device ID".
d) In the browser, select "Manage Licenses > Move Portable License > Select

Devices".
e) Enter the Device IDs.

3. On the source instrument, select "System Config > Setup > Instrument Assembly >
Installed License Keys > License Keys Table".

a) Navigate to the portable license that you want to move.
b) Select the "Export License to File" column.

A standard file manager dialog opens.

4. Enter a filename.

5. Save the exported license key, e.g. k123_portable_key_to_move.xml.

6. In the browser, select "Manage Licenses > Move Portable License > Select
License (from file)":

a) Select the exported license key.
b) Check the selection.
c) Create the deactivation key.
d) Save it to file.

7. On the source instrument, select "System Config > Setup > Instrument Assembly >
Manage License Keys > Import License Keys from File".
Select the transferred deactivation key.

8. On the source instrument, select "System Config > Setup > Instrument Assembly >
Manage License Keys > Export Deactivation Response to File".

9. In the browser, go to "Manage Licenses > Move Portable License > Install Deacti-
vation Key (from file)".

10. Enter the deactivation response of the instrument.

The license is deactivated for the source instrument.

11. In the "Manage Licenses > Move Portable License", go to step "Create License" to
generate a license key for this portable option and the selected target instrument.

a) Download the license key as a file.
b) Transfer it to the target instrument.
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12. In the target instrument, select "System Config > Setup > Instrument Assembly >
Manage License Keys > New License > Import License Keys from File".

13. Select the created license key file.

The portable option is installed on the target instrument.

11.4  Using the security settings

The protection function of the R&S SFI100A provides several levels to activate particu-
lar functions like self-test or tests for service purposes specifically.

Protection

The five protection levels are automatically active on startup that means all protected
functions are locked.

To unlock a protection level:

► In the "System Config > Setup > Security > Protection" dialog, enter the correct
password.

To lock a protection level:

► Clear the corresponding checkbox.

Protection levels

The following functions are protected in the respective levels:
● Protection level 1

Protects against accidental changes, like, for example, the clock and date, several
internal adjustments functions and the self-test, as well as network settings or the
instrument hostname.
You can access this level with the password 123456.

● Protection level 2
Unlocks protected service functions. It is accessible to authorized personnel of
Rohde & Schwarz service department only.

● Protection level 3 to 5
Are reserved for internal use.

Security

The security concept of the R&S SFI100A helps you to protect your instrument against
uncontrolled access and changes. All provided security services require that you enter
the security password.

Provided security services are:
● General security parameters, such as:

– USB storage that secures controlled access to the mass memory of the instru-
ment
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– Volatile mode that prevents information to be written to the internal memory
permanently.

– Sanitizing that prevents the instrument from leaving a secure environment with
stored user information.

– Annotation frequency and amplitude prevent reading the display.
– Secure Update Policy check that verifies the integrity and origin of the firm-

ware package to be installed.
To access the settings of these topics, see Setting security parameters >
"Secure Update Policy" on page 322.

● Password management secures controlled user access to the instrument
With the two-step password concept, you can assign a user-defined password for
the operating system, and a security password for accessing the mass storage of
the instrument.
See Chapter 11.4.4, "Password management", on page 330.

● LAN services secure controlled network access
You can individually lock and unlock supported LAN interface services, including
the SMB client and SMB server that use versions 1.0 and 2.0 of the SMB protocol.
Remote control over LAN requires you have enabled the interface, but you can dis-
able not needed LAN services individually.
Note: Disabling LAN services needed for remote control over LAN locks the instru-
ment access persistently. You cannot address the instrument any longer.
See Chapter 11.4.3, "Configuring LAN services", on page 326.

● User interface prevents front panel operation and/or reading the display.

For more information, see the document R&S SFI100A Instrument Security Proce-
dures.

11.4.1  Protection level settings

Access:

► Select "System Config > Setup > Security > Protection".

The "Protection" dialog provides access to the unlocking of different protection lev-
els.
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Several functions in the instrument are password-protected to prevent for example
accidental changes, "Protection" on page 319.

The remote commands required to unlock a protected stage are described in Chap-
ter 13.18, "SYSTem subsystem", on page 581.

Protection Level/Password
Unlocks the selected level of protection, if you enter the correct password.
The default protection level 1 password is 123456.
To lock the protection level again, clear the checkbox.
Remote command: 
:SYSTem:PROTect<ch>[:STATe] on page 592

11.4.2  Setting security parameters

Access:

► Select "System Config > Setup > Security > Security > General".

In the "General" tab, you can determine the security level for firmware updates, and
configure the security settings for the mass memory and manual operation.

All modified settings in this dialog are not applied until you enter the Security Password
and confirm with Accept.

11.4.2.1  Update policy security settings

Access:

1. Select "System Config > Setup > Security > Security".
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2. Select "General > SW Update".

The "SW Update" tab enables you to select the security mode for firmware
updates.

The remote commands available to control security settings are described in Chap-
ter 13.18, "SYSTem subsystem", on page 581.

Secure Update Policy
Allows you to configure the automatic signature verification for firmware installation.
To apply the change: enter the security password and confirm with "Accept". Otherwise
the change has no effect.
See also:
● Chapter 11.4, "Using the security settings", on page 319 for more information on

the security concept.
● The release notes for details on signature verification when installing new or former

firmware versions, available at www.rohde-schwarz.com/firmware/sfi100a.
The release notes for details on signature verification when installing new or former
firmware versions, available at www.rohde-schwarz.com/firmware/sma100b.

"Confirm Unsigned"
Performs the signature verification.
If the check detects any discrepancies, the instrument issues a warn-
ing message. You can still update the firmware or reject updating.
This setting also enables you to downgrade the firmware version.

"All Packages" Accepts all packages without signature verification.
"R&S Signed Packages"

Performs the signature check.
If the check detects any discrepancies, the instrument issues a warn-
ing message and locks the update to this firmware.

Remote command: 
:SYSTem:SECurity:SUPolicy on page 602

11.4.2.2  Disk & memory security settings

Access:

1. Select "System Config > Setup > Security > Security".
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2. Select "General > Disk & Memory".

The "Disk & Memory" tab secures controlled access to the mass memory and pre-
vents information from leaving a secure environment.

The remote commands available to control security settings are described in Chap-
ter 13.18, "SYSTem subsystem", on page 581.

USB Storage
Activates the access to external USB storage media.
To apply the change: enter the security password and confirm with "Accept". Otherwise
the change has no effect.
See Chapter 10.8.4, "Using a USB storage device for file transfer", on page 293.
Note: Remove all USB memory devices before disabling the USB storage. If any USB
memory device remains connected, disabling is blocked, and the instrument returns a
warning message.

Volatile Mode
Activates volatile mode, so that no user data can be written on the internal memory
permanently.
In volatile mode:
● Data that the instrument normally stores on the internal memory is redirected to

volatile memory.
● The user directory is mapped to the volatile memory. You access the temporary

data just as data stored in the /var/user/, see Chapter 10.3, "Protecting data",
on page 278.

● Data on the internal memory cannot be changed. It is protected against modifica-
tion or erasure.

● You can only save data:
– Temporarily in the volatile memory
– On a connected external storage device, such as a memory stick

To activate volatile mode: enter the security password, confirm with "Accept" and
reboot the instrument. Otherwise the change has no effect.
Activated volatile mode is indicated by the icon .
Remote command: 
:SYSTem:SECurity:VOLMode[:STATe] on page 602
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Sanitize
Executes the erase procedure that sanitizes the internal memory.
The sanitizing function makes sure that no user information is stored on the instrument
when it leaves the secure environment.
To apply the change: enter the security password and confirm with "Accept". Otherwise
the change has no effect.
Note: If the instrument is subject to high security, and you have disabled volatile mode,
the internal memory holds user-data, and thus poses a security risk.
See also Chapter 11.4, "Using the security settings", on page 319 for more information
on the security concept.
Remote command: 
:SYSTem:SECurity:SANitize[:STATe] on page 601

11.4.2.3  Manual operation security settings

Access:

1. Select "System Config > Setup > Security > Security".

2. Select "General > Manual Operation".

The "SW Update" tab enables you to lock front panel operation and/or reading the
display.

The remote commands available to control security settings are described in:
● Chapter 13.8, "DISPlay subsystem", on page 430
● Chapter 13.18, "SYSTem subsystem", on page 581.

Annotation Frequency
Enables the display of the currently used frequency in the status bar.
How to: see "To disable frequency and level indication in the status bar" on page 335.
Remote command: 
:DISPlay:ANNotation:FREQuency on page 433

Annotation Amplitude
Enables the display of the currently selected level in the status bar.
How to: see "To disable frequency and level indication in the status bar" on page 335.
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Remote command: 
:DISPlay:ANNotation:AMPLitude on page 433

User Interface
Allows you to lock the controls for manual operation and the display individually.
How to: see "To disable the user interface" on page 336.
See also Chapter 11.4, "Using the security settings", on page 319.
"Enabled" Enables the display and all controls for the manual operation of the

instrument.
"Touchscreen Off"

Locks the touch sensitivity of the screen.
This security feature protects the instrument against unintentional
change of settings by accidentally touching of the screen.
Still available controls for manual operation are:
● The keys at the front panel, including the rotary knob
● The external mouse and keyboard
● Remote operation over VNC
The instrument indicates the locked touchscreen by an icon .
Unlocking is possible via VNC, external controls or remote control.

"VNC Only" Locks the keys at the front panel, the touchscreen and externally con-
nected keyboard and mouse.
The display on the screen remains and shows the current settings
and changes.
The instrument indicates the activated "VNC only" feature by the icon

.
Unlocking is possible via VNC or turning off and on again.

"Display Only" Locks the manual operation of the instrument. The display on the
screen remains and shows the current settings and changes.
This security feature protects the instrument against unauthorized
access, but still shows the current settings and processes, for exam-
ple when you operate the instrument via remote control.
The function disables:
● The touchscreen functionality of the display
● The keys at the front panel of the instrument
● The external mouse and keyboard
The instrument indicates the locked controls by a padlock  softkey.
How to unlock: see "Unlocking (reactivating) the user interface for
manual operation" on page 336.
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"Disabled" Locks the display and all controls for the manual operation of the
instrument.
This security feature protects the instrument against unauthorized
reading and access, for example when you operate the instrument via
remote control.
The function disables:
● The display
● The touchscreen
● The keys at the front panel of the instrument
● The external mouse and keyboard
The screen shuts off and displays a padlock symbol  instead.
How to unlock: see "Unlocking (reactivating) the user interface for
manual operation" on page 336.

Remote command: 
:SYSTem:ULOCk on page 590
:SYSTem:DLOCk on page 589
:SYSTem:KLOCk on page 589

Enabling a locked user interface for manual operation
Follow the instructions listed in "Unlocking (reactivating) the user interface for manual
operation" on page 336.
Remote command: 
:SYSTem:ULOCk on page 590
:SYSTem:DLOCk on page 589
:SYSTem:KLOCk on page 589

11.4.3  Configuring LAN services

Access:

1. Select "System Config > Setup > Security > Security > LAN Services > Common
Services".

2. NOTICE! Risk of loosing access over LAN. Disabling the LAN interface or the com-
mon services "SCPI over LAN", "VNC" and "HTTP" locks the remote access to the
instrument.
Do not disable the LAN interface or LAN services needed for remote control while
you operate the instrument remotely.
Proceed with step step 4 for troubleshooting disabled services.
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In the "Common Services" side tab, you can individually disable the supported ser-
vices of the LAN interface.

3. Disable LAN services as needed.

a) Disable the service.
b) To confirm disabling, enter the security password.
c) Select "Accept".

4. If you have locked the access accidentally, you have the following options:
● Update the instrument firmware using ISO image

(<instrument>_<version-number>.iso).
Note: A firmware update with the ISO image resets the instrument. The instru-
ment reset dismisses user-specific configurations and deletes user data.
Contact the Rohde & Schwarz (https://www.rohde-schwarz.com/support) to get
the ISO image.

● Ship the instrument to your local service department. The service center
experts can enable the remote access over LAN without loosing user-specific
settings and data.
See www.services.rohde-schwarz.com.

5. Select "System Config > Setup > Security > Security > LAN Services > Samba Ser-
vices".

Using the security settings
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In the "Samba Services" side tab, you can activate former versions of the SMB cli-
ent and SMB server.

The remote commands available to control security settings are described in Chap-
ter 13.18, "SYSTem subsystem", on page 581.

How to:
● "To disable LAN access in general" on page 333
● "To disable LAN services individually" on page 334
● "To enable SMB version 1.0/2.0 client and server" on page 335

Common Services.......................................................................................................328
└ LAN...............................................................................................................328
└ LAN Services................................................................................................ 328

Samba Services.......................................................................................................... 329
└ SMB 1.0/2.0 Client........................................................................................329
└ SMB 1.0/2.0 Server.......................................................................................330

Security Password...................................................................................................... 330
Accept......................................................................................................................... 330

Common Services
Enables the LAN interface and supported LAN interface services.

LAN ← Common Services
Enables the LAN interface in general, and thus provides remote access over all
unlocked services.
Remote command: 
:SYSTem:SECurity:NETWork[:STATe] on page 601

LAN Services ← Common Services
Enables the supported LAN interface services individually.
"SCPI over LAN"

Access over LAN to control the instrument remotely, by using SCPI
(Standard Commands for Programmable Instruments) commands.
See also "To set up the controller with R&S VISA" on page 378 and
"To start remote control with R&S VISA" on page 381
Remote command: 
:SYSTem:SECurity:NETWork:SOE[:STATe] on page 600

"VNC" Access over VNC (Virtual Network Computing) interface, a graphical
desktop sharing system that uses RFB protocol to control the instru-
ment remotely.
See also Chapter 12.10, "Setting up remote operation over VNC",
on page 394.
Remote command: 
:SYSTem:SECurity:NETWork:VNC[:STATe] on page 601
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"SSH (SCP)" Access over SSH (Secure Shell), a network protocol for secure data
communication.
Remote command: 
:SYSTem:SECurity:NETWork:SSH[:STATe] on page 600

"Remote Support"
Remote support over SSH (SCP).
The service provides communication for service purposes only.
Remote command: 
:SYSTem:SECurity:NETWork:REMSupport[:STATe]
on page 599

"HTTP" Access with HTTP (Hyper Text Transfer Protocol), the application pro-
tocol for hypermedia information systems.
Remote command: 
:SYSTem:SECurity:NETWork:HTTP[:STATe] on page 599

"FTP" Access with FTP (File Transfer Protocol), used to transfer files from a
host to the instrument and vice versa.
See also Chapter 10.8.2, "Accessing the file system using FTP",
on page 291.
Remote command: 
:SYSTem:SECurity:NETWork:FTP[:STATe] on page 598

"SMB (Samba)"
Access to SMB (Server Message Block), used for providing shared
access to files, printers and serial ports of a network.
See also Chapter 10.8.3, "Accessing the R&S SFI100A file system
using SMB (Samba)", on page 292.
Remote command: 
:SYSTem:SECurity:NETWork:SMB[:STATe] on page 600

"Avahi (Zeroconf)"
Avahi, a service for automatic configuration of the instrument in a net-
work environment.
Remote command: 
:SYSTem:SECurity:NETWork:AVAHi[:STATe] on page 598

"Software Update"
Allows updating the software.
Remote command: 
:SYSTem:SECurity:NETWork:SWUPdate[:STATe] on page 601

Samba Services
Enables support of SMB client and SMB server version 1.0 and 2.0 of the SMB proto-
col.
Support of version 1.0 and 2.0 is additional to the current SMB protocol version sup-
ported in the firmware. This firmware supports SMB protocol up to version 3.1.1.

SMB 1.0/2.0 Client ← Samba Services
Enables support of the SMB client compatible with SMB protocol versions 1.0 and 2.0.
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SMB 1.0/2.0 Server ← Samba Services
Enables support of the SMB server compatible with SMB protocol versions 1.0 and 2.0.

Security Password
Enters the password that is required to enable or to disable the settings protected by a
security password. Default is 123456.
How to: "To change the security password" on page 333

Accept
Applies the modified settings, provided the security password is entered and correct.

11.4.4  Password management

Access:

1. Select "System Config > Setup > Security > Security > Password Management >
User Password".

In this tab, you can assign the security and a user-defined password.

2. Select "System Config > Setup > Security > Security > Password Management >
Security Password".
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How to:
● "To change the user password of the instrument" on page 333.
● "To change the security password" on page 333.

User Name
Indicates the user name used for access to the Linux operating system and valid for
VNC, FTP and SMB (Samba) access.

User Password
Access: select "System Config > Setup > Security > Security > Password Management
> User Password".
Allows you to change and confirm the user password.

Old Password ← User Password
Enters the current user password. The default password is "instrument".
Note: We recommend that you change the default password before connecting the
instrument to a network.
How to:
● "To change the user password of the instrument" on page 333.
● "To change the security password" on page 333.
Note: Note that you cannot reset the password to factory state.
If you encounter problems with the password, contact the Rohde & Schwarz customer
support, see Chapter 14.10, "Contacting customer support", on page 626.

New Password ← User Password
Enters the new user password.
The security password can contain decimal characters only.

Confirm Password ← User Password
Confirms the new user password by repeating.
How to:
● "To change the user password of the instrument" on page 333.
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● "To change the security password" on page 333.

Change Password ← User Password
Changes the user password accordingly.

Security Password
Access: select "System Config > Setup > Security > Security > Password Management
> Security Password".
Enables you to change and confirm the security password.

Old Password ← Security Password
Enters the currently used security password. The default password is '123456'.
Note: We recommend that you change the default password before connecting the
instrument to a network.
How to:
● "To change the user password of the instrument" on page 333.
● "To change the security password" on page 333.
The security password is required when changing the status of the USB and LAN inter-
face or other security settings.
Note: Note that you cannot reset the password to factory state.
If you encounter problems with the password, contact the Rohde & Schwarz customer
support, see Chapter 14.10, "Contacting customer support", on page 626.

New Password ← Security Password
Enters the new security password.
The security password can contain decimal characters only.

Confirm Password ← Security Password
Confirms the new security password by repeating.
How to:
● "To change the user password of the instrument" on page 333.
● "To change the security password" on page 333.

Change Password ← Security Password
Changes the password accordingly.

11.4.5  Preventing unauthorized access

The default computer name and user password are instrument. The user password is
the password required for VNC, FTP and SMB (samba) connections. If for example,
the VNC service or FTP are enabled, anyone in the network who knows the computer
name and user password of the instrument can access it.

The default security password is 123456. The security password is required when
changing the status of the USB and LAN interfaces.
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To prevent unauthorized access, use the following configurations exclusively or com-
plementary:
● "To change the user password of the instrument" on page 333
● "To change the security password" on page 333
● "To disable LAN access in general" on page 333
● "To disable LAN services individually" on page 334
● "To enable SMB version 1.0/2.0 client and server" on page 335
● "To disable frequency and level indication in the status bar" on page 335
● "To disable the user interface" on page 336

If security is a concern, see the document instrument security procedures for compre-
hensive description.

To change the user password of the instrument

► Note: We recommend that you change the default password before connecting the
instrument to a network.

How to:
● "To change the user password of the instrument" on page 333.
● "To change the security password" on page 333.

a) Select "System Config > Setup > Security > Security > Password Management
> User Password".

b) Enter the current password in the "Old Password" field.
c) Enter the new password in the "New Password" and "Confirm Password" fields.
d) Select "Change Password".

The user password is changed; the user name is displayed ("Security > Password
Management > User Password > User Name").

To change the security password

► Note: We recommend that you change the default password before connecting the
instrument to a network.

How to:
● "To change the user password of the instrument" on page 333.
● "To change the security password" on page 333.

a) Select "System Config > Setup > Security > Security > Password Management
> Security Password".

b) Enter the current password in the "Old Password" field.
The default password is 123456.

c) Enter the new password in the "New Password" and "Confirm Password" fields.
d) Select "Change Password".

To disable LAN access in general

1. NOTICE! Risk of loosing access over LAN. Disabling the LAN interface or certain
services lock the remote access to the instrument.
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The following services lock the remote access when disabled: "LAN", "SCPI over
LAN", "VNC" and "HTTP".
If you have locked the access accidentally, you have the following options:
● Update the instrument firmware using ISO image

(<instrument>_<version-number>.iso).
Note: A firmware update with the ISO image resets the instrument. The instru-
ment reset dismisses user-specific configurations and deletes user data.
Contact the Rohde & Schwarz (https://www.rohde-schwarz.com/support) to get
the ISO image.

● Ship the instrument to your local service department. The service center
experts can enable the remote access over LAN without loosing user-specific
settings and data.
See www.services.rohde-schwarz.com.

2. Select "System Config > Setup > Security > Security".

3. Select "LAN Services > Common Services".

4. Disable "LAN" state.

5. Enter the Security Password.

6. Select "Accept".

All LAN connections are blocked, including the LAN services. Communication over
LAN is not possible.

To disable LAN services individually

1. Select "System Config > Setup > Security > Security".

2. Select "LAN Services > Common Services".

3. Uncheck all services you want to block, for example "FTP > Off" or "VNC > Off".

4. Uncheck the services you want to block, for example "FTP" and "VNC".
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5. Enable "LAN" state, if disabled.

6. Enter the Security Password.

7. Select "Accept".

Communication over LAN is possible for the enabled services only.

To enable SMB version 1.0/2.0 client and server

By default, support of SMB client and SMB server of the SMB protocol versions 1.0
and 2.0 is disabled.

Activate support only, if needed:

1. Select "System Config > Setup > Security > Security".

2. Select "LAN Services > Samba Services".

3. For example, check "SMB 1.0/2.0 Client".

4. Select "SMB 1.0/2.0 Client > On" and "SMB 1.0/2.0 Server > On".

5. Enter the Security Password.

6. Select "Accept".

Enables the access for the SMB Samba client, the access for the SMB Samba
server remains blocked.

To disable frequency and level indication in the status bar

These settings are useful to prevent unauthorized personnel from reading the display,
when you remotely control the instrument from a different location.

1. Select "System Config > Setup > Security > General > Manual Operation".

2. Select "Annotation Frequency > Off" or "Annotation Amplitude > Off".

3. Enter the Security Password.
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4. Select "Accept".

To disable the user interface

1. Select "System Config > Setup > Security > General > Manual Operation".

2. Select "User Interface > Disabled".

3. Enter the Security Password.

4. Select "Accept".

The screen shuts off and displays a padlock symbol  instead.
There are further possible configurations. For details, see "User Interface"
on page 325.

Unlocking (reactivating) the user interface for manual operation

1. In manual operation:

a) On the instrument's keypad or external keyboard, press any key.
The instrument prompts you to enter the security password for unlocking.

If you press the character of the first key, the input field accepts the character
immediately.

b) Delete the entry before inserting the password.
Enter the security password 123456.

2. In remote control mode:

a) Send the command SYST:ULOC ENABled to release all locks at once.
b) Send the command SYST:KLOC OFF to unlock the keyboard and touchscreen.
c) Send the command SYST:DLOC OFF to release all locks.

Via remote control, there is no password required.

11.5  Password management

Access:

1. Select "System Config > Setup > Security > Security > Password Management >
User Password".

Password management
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In this tab, you can assign the security and a user-defined password.

2. Select "System Config > Setup > Security > Security > Password Management >
Security Password".

How to:
● "To change the user password of the instrument" on page 333.
● "To change the security password" on page 333.

User Name
Indicates the user name used for access to the Linux operating system and valid for
VNC, FTP and SMB (Samba) access.
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User Password
Access: select "System Config > Setup > Security > Security > Password Management
> User Password".
Allows you to change and confirm the user password.

Old Password ← User Password
Enters the current user password. The default password is "instrument".
Note: We recommend that you change the default password before connecting the
instrument to a network.
How to:
● "To change the user password of the instrument" on page 333.
● "To change the security password" on page 333.
Note: Note that you cannot reset the password to factory state.
If you encounter problems with the password, contact the Rohde & Schwarz customer
support, see Chapter 14.10, "Contacting customer support", on page 626.

New Password ← User Password
Enters the new user password.
The security password can contain decimal characters only.

Confirm Password ← User Password
Confirms the new user password by repeating.
How to:
● "To change the user password of the instrument" on page 333.
● "To change the security password" on page 333.

Change Password ← User Password
Changes the user password accordingly.

Security Password
Access: select "System Config > Setup > Security > Security > Password Management
> Security Password".
Enables you to change and confirm the security password.

Old Password ← Security Password
Enters the currently used security password. The default password is '123456'.
Note: We recommend that you change the default password before connecting the
instrument to a network.
How to:
● "To change the user password of the instrument" on page 333.
● "To change the security password" on page 333.
The security password is required when changing the status of the USB and LAN inter-
face or other security settings.
Note: Note that you cannot reset the password to factory state.
If you encounter problems with the password, contact the Rohde & Schwarz customer
support, see Chapter 14.10, "Contacting customer support", on page 626.
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New Password ← Security Password
Enters the new security password.
The security password can contain decimal characters only.

Confirm Password ← Security Password
Confirms the new security password by repeating.
How to:
● "To change the user password of the instrument" on page 333.
● "To change the security password" on page 333.

Change Password ← Security Password
Changes the password accordingly.

11.6  Undoing or restoring actions

"Undo" is a function that removes the effect of the last action on the instrument and
reverts it to an older state. Conversely, "Redo" restores a previously undone action.

You can "Undo/Redo" actions according to two criteria:
● Step by step

Gradually undo/redo the actions in reverse order as previously performed.
Depending on the available memory the "Undo/Redo" steps may restore all
actions.

● Multiple steps at once
Select any specific action in the history list to "Undo/Redo" multiple actions in a sin-
gle step.
Note: This mode requires a system restoration file on the instrument.
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Access:

► Select "Setup > Settings > Undo/Redo".

The dialog contains all functions for enabling the "Undo/Redo" functionality.

Settings:

State............................................................................................................................340
History List.................................................................................................................. 340
Clear History............................................................................................................... 340
Apply........................................................................................................................... 340

State
Enables the recording of the performed actions.

History List
Lists the performed actions, provided "Undo/Redo" state is "On".

Clear History
Deletes the recorded list of the performed steps.

Apply
Performs the "Undo/Redo".
If you select a previously performed action of the list, all subsequent actions are
undone. The list entries remain.
If you select a subsequently executed action, you can restore all the actions undone up
to this state.
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11.7  Shutting down and rebooting the instrument

On the front panel, the [On/Standby] key switches the instrument from the standby to
the ready state or vice versa. In remote operation from a remote computer or in manual
control, there is another possibility to shut down the instrument or to reboot the system.

Access:

► Select "System Config > Setup > Maintenance > Shut down".

Remote control commands:
● :SYSTem:REBoot on page 609
● :SYSTem:SHUTdown on page 609

Shutting down and rebooting the instrument
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11.8  Using the on-screen keypad

1

4

3

2

8

6

5
7

Figure 11-7: Alphanumerical entry

1 = Input field
2, 3, 10, 11 = Function keys
4, 9 = Alphanumeric keys
5, 8 = Non-walkable keys
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Figure 11-8: Numerical entry

1 = Input field
2, 6 = Min/Max limit
3 = Function keys
4 = Non-walkable keys
5 = Special characters and number keys

Table 11-1: Keys on the keypad

Type of key Description

[Question mark] Displays context-sensitive help text.

[Special characters/abc TOGGLE] Switches between number keys and special charac-
ter/alphanumeric keys.

Sign key Changes the sign of a numeric parameter.

Unit keys (GHz, MHz, kHz, Hz) Adds the selected unit to the entered numeric value
and completes the entry.

[Backspace] key Deletes the character to the left of the cursor, if an
alphanumeric entry has already been started.

[Enter] Concludes the entry of dimensionless entries. The
new value is accepted.

[Up/Down] key In a numeric edit dialog box, increase or decrease
the instrument parameter.

[Left/Right] key Moves the cursor.

[CE] key Clears the current entry.

[Max/Min] key Limits the maximal/minimal value.

[Exp] key Enters the exponential representation.

Decimal point Inserts a decimal point "." at the cursor position.

Alphanumeric keys Enter numbers, letters and (special) characters in
edit dialog boxes.
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To open the editor

1. To open directly the large On-Screen-Keyboard with mouse/keyborad operation,
press [Ctrl+Click].

2. To make the On-Screen-Keyboard configurable, open the configuration dialogue
through the [Setting] button.

To overwrite an entry

1. Open the editor.

The whole numeric value is selected.

2. To cancel the selection, move the cursor.

3. Variate the numeric value with the block cursor. The value is transferred with each
variation.

4. To change the selected unit, click the unit key. The numeric value is not converted
into the other unit.

To use the rotary knob

1. Use the rotary knob for one of the following situations:

● For navigation purposes, e.g. cursor movement
● For scalar values
● For the determination of the numeric values through interactive search during a

measurement
Otherwise lock the encoder.

2. Serve the rotary knob to increment or decrement the numeric value at a defined
step width.

3. The numeric value is immediately set, not only after completion with <ENTER> or
similar.

4. By default, the variation for number parameters is always on. To switch off the var-
iation per parameter, start with e.g. "Save -> Filename" in edit mode.

Behavior in the open editor

1. To change between insert and overwrite mode, press the [INSERT] hardkey or
[EINFG]. The numeric value is transferred after completion with <ENTER> and var-
iation is not possible. With insert modus, the line cursor appears.

2. Click the [Up/Down] key to increase/decrease the numeric value by 100 [unit].

3. Entering values outside the valid value range, is signaled to the user. The entered
value is automatically set to min/max and corrected.

4. If you click [ESC] or next to the key or input field, the input is discarded.
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Tipps for quick usage

1. Tolltip/move-over: Get hints on using the keypad efficiently by moving over the key.

2. Exponential representation: Simplify the representation of numeric values with expo-
nents, e.g. "1e6 ENTER" instead of 1 000 000 Hz independent of the current unit. Take
always the basis unit.

Using the on-screen keypad
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12  Network operation and remote control
As an alternative to the interactive operation directly at the instrument, you can operate
the R&S SFI100A also from a remote location.

The LAN interface provides flexible access to the instrument, for example remote con-
trol, remote operation or remote file access. These remote access modes are funda-
mentally different, although they are often considered interchangeable, as described in
Chapter 12.1, "Overview of remote access modes", on page 346.

Figure 12-1 shows the physical connection (interface) for remote access.

Ethernet

HiSLIP
VXI-11
Socket

VNC
SAMBA/
SMB
ftp

R&S Signal GeneratorLAN
Controller

Application 
Program

Figure 12-1: Supported remote connections

The following descriptions provide information required for operating the R&S SFI100A
remotely. The information applies to all applications and operating modes supported by
the instrument. Definitions specified in the SCPI standard are not provided.
For basic knowledge on remote control operation and additional information, see the
following documents, available on the Rohde & Schwarz website:
● Remote control via SCPI
● 1GP72: Connectivity of Rohde&Schwarz Signal Generators
● 1MA208: Fast Remote Instrument Control with HiSLIP
● 1GP98: SCPI Recorder Test Automation on a Fingertip

● Overview of remote access modes.......................................................................346
● Remote control interfaces and protocols...............................................................348
● Remote control programs and libraries.................................................................351
● Status reporting system........................................................................................ 354
● Remote access settings........................................................................................357
● LXI status settings.................................................................................................366
● LXI browser settings..............................................................................................368
● Setting up remote control......................................................................................374
● Using remote command scripts.............................................................................385
● Setting up remote operation over VNC................................................................. 394
● References............................................................................................................401

12.1  Overview of remote access modes

This section outlines the possible access modes and their major characteristics.

Overview of remote access modes

https://www.rohde-schwarz.com/rc-via-scpi
https://www.rohde-schwarz.com/appnote/1GP72.html
https://www.rohde-schwarz.com/appnote/1MA208.html
https://www.rohde-schwarz.com/appnote/1GP98.html
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Remote control (SCPI)

● A remote PC controls the instrument, usually via VISA (Virtual Instrument Software
Architecture) interfaces.

● Remote control disables the manual operation of the instrument; you can set differ-
ent lock states.

● The GUI is not visible.
● Remote control commands (SCPI) perform the settings, either individually or in

sequences (SCPI programs).
● Using SCPI programs is faster than the manual operation, since they automate

repeating applications.

Remote operation (VNC)

● A remote device accesses the instrument via the common platform technology
VNC (Virtual Network Computing).

● The protocol allows simultaneous operation from several remote devices and the
instrument nevertheless remains locally operable.

● The GUI is visible.
● To perform the settings, you can operate the instrument as with the manual control.
● During remote operation via VNC, the direct control of the instrument is not dis-

abled.
You can control the instrument from the front panel and via the remote computer
alternately.

● Clients supporting remote operation depend on the used remote device, see
Table 12-1.

● How To: see Chapter 12.10, "Setting up remote operation over VNC", on page 394
Table 12-1: Supported VNC operation modes

Remote device VNC client Requirements Characteristics

Desktop

(Windows, Linux,
MacTMOS)

● Ultr@VNC
● Other dedicated client soft-

ware

Ultr@VNC or Client Software
must be installed.

Fast, supports several options like
full screen mode or auto-login.

 ● Any web browser Java Runtime must be installed
and activated in the browser set-
tings.

Fast and convenient - only the
instrument address required.

Java runtime is sometimes con-
sidered as security concern.

 ● Web browser with HTML5 Web sockets must be supported. Slower than the other modes.

No additional installation or acti-
vation required.

No security concern.

Smart device

(Tablet/ smartphone)

● Dedicated client App App must be installed. Fast, supports several options like
full screen mode or auto-login.

 ● Web browser with HTML5 Web sockets must be supported. Support of QR code scanning

Slower than a dedicated App.

Overview of remote access modes
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Remote file access (FTP, SAMBA/SMB)

● A remote client accesses the instrument's file system, using the protocols FTP (file
transfer protocol) and SAMBA/SMB (server message block).

● The protocols enable you to transfer files from or to the instrument and to get direct
access to its file sharing directory share.

How to:

Chapter 10.8.2, "Accessing the file system using FTP", on page 291.

Chapter 10.8.3, "Accessing the R&S SFI100A file system using SMB (Samba)",
on page 292

"To enable SMB version 1.0/2.0 client and server" on page 335

12.2  Remote control interfaces and protocols

The LAN interface supports various protocols for remote control. Table 12-2 gives an
overview on the connectivity:

Table 12-2: Remote control interfaces and protocols

Interface Protocols, VISA*) address string and library Remarks

Local area network
(LAN)

● HiSLIP High-Speed LAN Instrument Protocol
(IVI-6.1)
TCPIP::host address::hislip0[::INSTR]
VISA

● VXI-11
TCPIP::host address[::
LAN device name][::INSTR]
VISA

● Socket communication (Raw Ethernet, simple
Telnet)
TCPIP::host address[::
LAN device name]::<port>::SOCKET
VISA or socket controller

The LAN connector is at the rear panel of the
instrument.

The interface is based on TCP/IP, see Chap-
ter 12.2.1, "LAN interface", on page 349 for
details on the address information.

*) VISA (Virtual Instrument Software Architecture) is a standardized software interface library providing input and output functions to
communicate with instruments. A VISA installation on the controller is prerequisite for remote control over LAN (when using VXI-11
or HiSLIP protocol). With socket communication, VISA installation is optional. For basic information, see Remote control via SCPI.

http://www.rohde-schwarz.com/rsvisa provides the standardized I/O software library
R&S VISA for download at the Rohde & Schwarz website http://www.rohde-
schwarz.com/rsvisa.

How to: Chapter 12.8, "Setting up remote control", on page 374

● LAN interface........................................................................................................ 349
● LXI browser interface............................................................................................ 350

Remote control interfaces and protocols

http://www.rohde-schwarz.com/rsvisa
http://www.rohde-schwarz.com/rsvisa
http://www.rohde-schwarz.com/rsvisa
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12.2.1  LAN interface

The LAN interface of the instrument consists of a connector, a network interface card
and protocols.

For remote control, the instrument and the controller PC must be connected to a com-
mon network with TCP/IP network protocol.

There are two methods to establish a LAN connection to the instrument:
● A non-dedicated network (Ethernet) connection from the instrument to an existing

network.
● A dedicated network connection (Point-to-point connection) between the instru-

ment and a single computer.

How to: Chapter 3.1.7, "Connecting to LAN", on page 19

Identifying instruments in a network
If several instruments are connected to the network, each instrument has its own IP
address and associated resource string. The controller identifies these instruments by
the resource string.

VISA resource strings

The VISA resource string is required to establish a communication session between
the controller and the instrument in the LAN. The resource string is a unique identifier,
composed of the specific IP address of the instrument and some network and VISA-
specific keywords.

TCPIP::<host address>[::<LAN device name>][::INSTR]

TCPIP = designates the network protocol
host address = designates the IP address or hostname of the instrument
[::LAN device name] = defines the protocol and the instance number of a subinstrument
[::INSTR] = indicates the instrument resource class (optional)

The IP address (host address/computer name) is used by the programs to identify and
control the instrument. It is automatically assigned by the DHCP server the first time
the device is registered in the network. Optionally, you can also assign its LAN device
name.

If assigned, the IP address is displayed in the block diagram.

The following section lists the characteristics of the VISA resource strings for the corre-
sponding interface protocols. The emphasized characters determine the protocol.

For description of the interface protocols, control commands and messages, refer to
Remote control via SCPI.

Remote control interfaces and protocols
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HiSLIP

TCPIP::<host address>::hislip0[::INSTR]

hislip0 = HiSLIP device name, designates that the interface protocol HiSLIP is used (mandatory)

hislip0 is composed of [::HiSLIP device name[,HiSLIP port]] and must be
assigned.

Example: 
TCPIP::192.1.2.3::hislip0

VXI-11

TCPIP::<host address>[::inst0][::INSTR]

[::inst0] = LAN device name, indicates that the VXI-11 protocol is used (optional)

inst0 currently selects the VXI-11 protocol by default and can be omitted.

Example: 
TCPIP::192.1.2.3::INSTR

Socket communication

TCPIP::<host address>::<port>::SOCKET

port = determines the used port number
SOCKET = indicates the raw network socket resource class

Socket communication requires the specification of the port (commonly referred to as
port number) and of "SOCKET" to complete the resource string.

Basically, instruments from Rohde & Schwarz use port number 5025 for socket com-
munication.

Example: 
TCPIP::192.1.2.3::5025::SOCKET

12.2.2  LXI browser interface

The LXI browser interface allows easy configuration of the LAN and remote control of
the R&S SFI100A without additional installation requirements. The instrument's LXI
browser interface works correctly with all W3C compliant browsers.

See Chapter 12.11.1, "LXI functionality", on page 401 for more about LXI.

The LAN settings are configured using the instrument's LXI browser interface descri-
bed in Chapter 12.7.1, "LAN configuration", on page 369.

Remote control interfaces and protocols
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For LXI status information in the R&S SFI100A, see Chapter 12.6, "LXI status set-
tings", on page 366.

12.3  Remote control programs and libraries

This section shows how the remote-control programs access the instrument, and the
libraries they require for the corresponding interface protocols.

LANInterface

Protocol

Library

Socket VXI-11

VISA

HiSLIP

Application Program

Instrument Driver

Figure 12-2: Overview of remote control interfaces, protocols and libraries

Possible setups and access functions

The following examples give an overview of dependencies between the available libra-
ries, the possible interfaces and protocols, and whether an instrument driver is provi-
ded. For detailed information, see the application note 1GP72.

Remote control programs and libraries
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Example: Remote control (application) program using VISA

LANInterface

Protocol

Library

Socket VXI-11

VISA

HiSLIP

Application Program

Instrument Driver

Figure 12-3: Application program using VISA

Protocol Remote control program

Socket viOpen (..., "TCPIP:SFI100A-102030::5025::SOCKET", ...)
viPrintf (..., "SOUR:FREQ 2GHz\n")

VXI-11 viOpen (..., "TCPIP:SFI100A-102030::inst0::INSTR", ...)
viPrintf (..., "SOUR:FREQ 2GHz\n")

HiSLIP viOpen (..., "TCPIP:SFI100A-102030::hislip0::INSTR", ...)
viPrintf (..., "SOUR:FREQ 2GHz\n")

Remote control programs and libraries
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Example: Remote control program using instrument driver (VISA available)

LANInterface

Protocol

Library

Socket VXI-11

VISA

HiSLIP

Application Program

Instrument Driver

Figure 12-4: Application using instrument driver (VISA available)

Protocol Remote control program

Socket rssfi_init ("TCPIP:SFI100A-102030::5025::SOCKET", ...)
rssfi_SetFrequency (..., 2e9)

VXI-11 rssfi_init ("TCPIP:SFI100A-102030::inst0::INSTR", ...)
rssfi_SetFrequency (..., 2e9)

HiSLIP rssfi_init ("TCPIP:SFI100A-102030::hislip0::INSTR", ...)
rssfi_SetFrequency (..., 2e9)

Remote control programs and libraries
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Example: Remote control program using instrument driver (VISA not available)

LANInterface

Protocol

Library

Socket VXI-11

VISA

HiSLIP

Application Program

Instrument Driver

Figure 12-5: Remote control program using instrument driver (VISA not available)

Protocol Remote control program

Socket rssfi_init ("TCPIP:SFI100A-102030::5025::SOCKET", ...)
rssfi_SetFrequency (..., 2e9)

12.4  Status reporting system

The status reporting system stores all information on the current operating state of the
instrument and on errors which have occurred. This information is stored in the status
registers and in the error queue. You can query the status of the registers with the
remote commands of the Chapter 13.17, "STATus subsystem", on page 577.

12.4.1  Overview of the status registers

The Figure 12-6 shows the hierarchical structure of information in the status registers
(ascending from left to right).

Status reporting system
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Figure 12-6: Graphical overview of the status registers hierarchy

OPER = Operation Status Summary Bit
RQS/MSS = Service Request Generation
ESB = Standard Event Status Summary Bit
MAV = Message Available in Output Queue
QUES = Questionable Status Summary Bit
2 = Error- /Event-Queue
1, 0 = not used

Status reporting system
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The following sections describe the instrument-specific bit assignments of the opera-
tion status and the questionable status registers.
For more information, see:
● Remote control via SCPI: provides general information on the status reporting sys-

tem of Rohde & Schwarz instruments. This document also provides information on
the standard event status register and the error queue.

● SCPI standard documentation for comprehensive information on the standard

12.4.2  Instrument-specific status operation register

The condition part contains information on currently executed actions. The event part
covers information on the actions performed since the last readout of the register.

To read the register, use the query commands :STATus:OPERation:CONDition?
on page 578 and :STATus:OPERation[:EVENt] on page 578.

The remote commands for the status questionable register are described in Chap-
ter 13.17, "STATus subsystem", on page 577.
Table 12-3: Assignment of the bits used in the operation status register

Bit No. Meaning

0 Calibrating

The bit is set during the calibration phase.

1–2 Not used

3 Not Used

4–15 Not used

12.4.3  Instrument-specific status questionable register

This status register contains information on questionable instrument states. Questiona-
ble states occur when the instrument is not operated in compliance with its specifica-
tions.

To read the register, use the query commands :STATus:QUEStionable:
CONDition on page 580 or :STATus:QUEStionable[:EVENt] on page 580.

The remote commands for the status questionable register are described in Chap-
ter 13.17, "STATus subsystem", on page 577.
Table 12-4: Assignment of the bits used in the questionable status register

Bit No. Meaning

0–15 Not used

Status reporting system

https://www.rohde-schwarz.com/rc-via-scpi
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12.4.4  Reset values of the status reporting system

The following table contains the different commands and events causing the status
reporting system to be reset. None of the commands, except for *RST and
SYSTem:PRESet affect the functional instrument settings. In particular, DCL does not
change the instrument settings.
Table 12-5: Resetting the status reporting system

Event Switching on supply
voltage
Power-On-Status-
Clear

DCL,
SDC
(Device
Clear,
Selected
Device
Clear)

*RST or
SYSTem:
PRESet

STATus:
PRESet

*CLS

Effect 0 1

Clear STB, ESR - Yes - - - Yes

Clear SRE, ESE - Yes - - - -

Clear PPE - Yes - - - -

Clear error queue Yes Yes - - - Yes

Clear output buffer Yes Yes Yes 1) 1) 1)

Clear command processing
and input buffer

Yes Yes Yes - - -

1) The first command in a command line that immediately follows a <PROGRAM MESSAGE TERMINA-
TOR> clears the output buffer.

12.5  Remote access settings

This section describes the settings required for accessing and configuring the provided
remote control interfaces. It includes network settings, access addresses, emulation
settings for using the command sets of other generators, and the access with smart
devices.

12.5.1  Network settings

Access:

► Select "System Config" > "Remote Access" > "Network".

Remote access settings
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The "Network" dialog provides settings of the general network environment, and
specific identification parameters of the instrument in the network. If necessary, you
can configure the instrument address settings manually.
How to: "To assign the instrument address manually" on page 375.

The remote commands to define these settings are described in Chapter 13.18, "SYS-
Tem subsystem", on page 581.

Settings:

Network Status............................................................................................................358
Restart Network.......................................................................................................... 358
Hostname....................................................................................................................359
Workgroup...................................................................................................................359
Address Mode............................................................................................................. 359
Show Connector..........................................................................................................359
IP Address...................................................................................................................359
Subnet Mask............................................................................................................... 359
Default Gateway..........................................................................................................360
DNS Suffix...................................................................................................................360
DNS Server................................................................................................................. 360
MAC Address.............................................................................................................. 360

Network Status
Indicates that the instrument is connected to the network.
Remote command: 
:SYSTem:COMMunicate:NETWork:STATus? on page 594

Restart Network
Terminates the network connection of the instrument and sets it up again. You can use
this function to fix network problems.
Note: This function restarts only the connection of the instrument to the network. It
does not impact the network itself.

Remote access settings
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Remote command: 
:SYSTem:COMMunicate:NETWork:RESTart on page 594

Hostname
Displays the hostname.
Each instrument is delivered with an assigned hostname, a logical name which can be
used instead of the IP address. With the default network settings, the IP address is
allocated by the DHCP server. This address can change each time the instrument is
reconnected. Unlike the IP address, the hostname name does not change.
Note:
This function is password-protected. Unlock the protection level 1 to access it.
● We recommend that you do not change the default network settings or the host-

name to avoid problems with the network connection.
If you change the hostname, be sure to use a unique name.

Remote command: 
:SYSTem:COMMunicate:NETWork[:COMMon]:HOSTname on page 594

Workgroup
Sets the individual windows workgroup name of the R&S SFI100A. This parameter is
required in case the instrument is integrated in a windows network.
This function is password-protected. Unlock the protection level 1 to access it.
Remote command: 
:SYSTem:COMMunicate:NETWork[:COMMon]:WORKgroup on page 595

Address Mode
Selects the mode for assigning the IP address.
"Auto (DHCP)"

Assigns the IP address automatically, provided the network supports
DHCP (Dynamic Host Configuration Protocol).

"Static" Enables you to assign the IP address manually.
Remote command: 
:SYSTem:COMMunicate:NETWork:IPADdress:MODE on page 593

Show Connector
Accesses a dialog that displays the physical location of the selected connector on the
front/rear panel of the instrument.

IP Address
Displays the IP address of the instrument in the network.
To assign the IP address manually, see "To assign the instrument address manually"
on page 375.
Remote command: 
:SYSTem:COMMunicate:NETWork:IPADdress on page 593

Subnet Mask
Displays the bit group of the subnet in the host identifier.

Remote access settings
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The TCP/IP protocol is preinstalled with the subnet mask 255.255.255.0. If the DHCP
server is available Address Mode A AUTO (DHCP), the setting is read-only. The sub-
net mask consists of four number blocks separated by dots. Each block contains 3
numbers in maximum (e.g. 100.100.100.100), but also one or two numbers are allowed
in a block (as an example see the preinstalled address).
To assign the subnet mask manually, select Address Mode > Static.
Note: When assigning the subnet mask manually, make sure that the address matches
with the subnet mask of the controlling host interface.
How to: "To assign the instrument address manually" on page 375.
Remote command: 
:SYSTem:COMMunicate:NETWork[:IPADdress]:SUBNet:MASK on page 595

Default Gateway
Displays the gateway address.
This address identifies the router on the same network as the instrument that is used to
forward traffic to destinations beyond the local network.
To assign the gateway address manually, select Address Mode > "Static".
Remote command: 
:SYSTem:COMMunicate:NETWork[:IPADdress]:GATeway on page 595

DNS Suffix
Displays the primary DNS (Domain Name System) suffix, that means the DNS name
without the hostname part.
The DNS system uses the suffix for registration and name resolution for unique identifi-
cation of the instrument in the entire network.
To assign the DNS suffix manually, select Address Mode > "Static".
Remote command: 
:SYSTem:COMMunicate:NETWork[:COMMon]:DOMain on page 594

DNS Server
Determines the preferred server for name resolution. The DNS server contains the
underlying numerical values that are required for name resolution of the hostname as
part of the IP address.
To select the DNS server manually, select Address Mode > "Static".
Remote command: 
:SYSTem:COMMunicate:NETWork[:IPADdress]:DNS on page 595

MAC Address
Indicates the MAC (Media Access Control) address, a unique identifier of the network
adapter in the R&S SFI100A.
Remote command: 
:SYSTem:COMMunicate:NETWork:MACaddress on page 593

Remote access settings
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12.5.2  VISA resource strings settings

Access:

► Select "System Config > Remote Access > Visa Resource Strings".

The "Visa Resource String" dialog displays the VISA resource strings for accessing
the instrument for remote control.

The remote commands required to query the address information remotely are descri-
bed in Chapter 13.18, "SYSTem subsystem", on page 581.

Settings:

HISLIP.........................................................................................................................361
VXI11...........................................................................................................................361
Socket......................................................................................................................... 361

HISLIP
Displays the visa resource string for remote control with HiSLIP protocol.
See also Chapter 12.2.1, "LAN interface", on page 349.
Remote command: 
:SYSTem:COMMunicate:HISLip:RESource? on page 592

VXI11
Displays the visa resource string for remote control over LAN.
See also Chapter 12.2.1, "LAN interface", on page 349.
Remote command: 
:SYSTem:COMMunicate:NETWork:RESource? on page 593

Socket
Displays the visa resource string for remote control over LAN, using the socket com-
munication protocol.
See also Chapter 12.2.1, "LAN interface", on page 349.
Remote command: 
:SYSTem:COMMunicate:SOCKet:RESource? on page 595

Remote access settings
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12.5.3  Instrument emulations

About instrument emulations

You can remotely control the R&S SFI100A using the command set of another signal
generator. With this function you can, for example, replace a signal generator with an
R&S SFI100A in an automated test setup, without adjusting the command scripts used.

The R&S SFI100A also covers command sets of Rohde & Schwarz signal generators.
To achieve optimal compatibility when replacing an instrument, we recommend that
you select the emulation command set for the corresponding signal generator.

You find the remote control command sets supported by the R&S SFI100A in a selec-
tion list.

The selected instrument also defines the identification string that is retrieved with query
*IDN?. If necessary, use the parameter Mode and IDN String to change this string.

As any other parameter, the remote control command set can also be changed
remotely by the command :SYSTem:LANGuage.

While working in an emulation mode, the R&S SFI100A specific command set is dis-
abled and the SCPI command :SYSTem:LANGuage is discarded.

To return to the SCPI command set of the R&S SFI100A, use the corresponding com-
mand of the selected command set.

Access:

► Select "System Config > Remote Access > Instrument Emulations".

The "Instrument Emulations" dialog enables you to emulate a remote control com-
mand set of another signal generator.

Remote access settings
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The remote commands required to configure the emulation settings are described in
Chapter 13.18, "SYSTem subsystem", on page 581.

Settings:

Language.................................................................................................................... 363
Mode........................................................................................................................... 363
Set to Default.............................................................................................................. 363
IDN String....................................................................................................................363
OPT String.................................................................................................................. 363

Language
Selects the instrument whose remote command set is emulated by the R&S SFI100A.
Remote command: 
:SYSTem:LANGuage on page 598

Mode
Selects the way the instrument identification is performed.
"Automatic" Sets the "IDN String" and the "OPT String" automatically for the

instrument selected with the parameter Language.
"User Defined" Enables you to define the "IDN String" and the "OPT String".
Remote command: 
:SYSTem:IDENtification on page 596

Set to Default
In "Mode > User Defined", resets the *IDN and *OPT strings.

Remote command: 
:SYSTem:IDENtification:PRESet on page 597

IDN String
Indicates the identification string of the instrument when queried with the common
command *IDN?.

In addition to the preset values, you can define your own identification string so that
each generator uses an individual identification, like My_SigGen for instance, see
Mode .
Remote command: 
*IDN? on page 408
:SYSTem:IRESponse on page 597

OPT String
Indicates the option string of the instrument as queried with common command *OPT?.

In Mode > "User Defined", you can define your own option string. A query responds
with this option string instead of the automatically created option string.
Remote command: 
*OPT? on page 408
:SYSTem:ORESponse on page 597

Remote access settings
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12.5.4  Remote connections

The "Remote Connections" dialog covers the active SCPI and TCP/IP connections,
and a history list of the connections that have accessed the instrument before.

12.5.4.1  Active connections

Access:

► Select "System Config > Remote Access > Remote Connections > Active".

The "Active" tab shows the currently active remote connections, and you can
enable the display of the active connections in the task bar.

Settings:

Show Remote Connections in Taskbar....................................................................... 364
SCPI Connections.......................................................................................................364
TCP/IP Connections....................................................................................................364

Show Remote Connections in Taskbar
Displays the currently active connections in the taskbar.

SCPI Connections
Displays the VISA resources strings of the remote connections currently controlling the
instrument via the LAN interface.
Remote command: 
n.a.

TCP/IP Connections
Displays the types and client addresses of the remote connections currently controlling
the instrument via the LAN interface.

Remote access settings
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Remote command: 
n.a.

12.5.4.2  Closed connections

Access:

► Select "System Config > Remote Access > Remote Connections > Closed".

The "Closed" tab shows the currently active remote connections, and you can
enable the display of the active connections in the task bar.

Settings:

SCPI Connections.......................................................................................................365
TCP/IP Connections....................................................................................................365

SCPI Connections
Lists the VISA resource strings of the last remote connections that have accessed the
instrument via the LAN interface before.
Remote command: 
n.a.

TCP/IP Connections
Lists the types and client addresses of the last remote connections that had accessed
the instrument via the LAN interface before.
Remote command: 
n.a.

Remote access settings
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12.5.5  QR code

Access:

► Select "System Config > Remote Access > QR Code".

The "QR Code" dialog shows the current instrument address (IP address) in quick
response (QR) format.

This functionality provides fast access to the instrument via VNC with, for example, a
smartphone or a tablet.

See Chapter 12.10.2, "Using a smart device", on page 398.

12.6  LXI status settings

On the R&S SFI100A, an LXI functionality is already installed and enabled. Thus, you
can access he instrument using any web browser.

See Chapter 12.7, "LXI browser settings", on page 368.

Access:

► Select "System Config > Setup > Remote Access > LXI Status".
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The LXI "LAN Status" dialog shows the parameters of the LAN connection.

Alternatively, you can change the LAN settings using the LXI web browser interface,
see Chapter 12.7.1, "LAN configuration", on page 369.

LAN Status
The LED indicates the LXI status.
"green" Normal operation
"green (flashing)"

Device identification
"red" LAN fault

Hostname / MAC Address / IP Address
See "Hostname" on page 359.

LAN Reset
Initiates the network configuration reset mechanism for the instrument and resets the
hostname, MAC address, and IP address.
According to the LXI standard, a LAN reset must set the following network parameters
to a default state:

Parameter Value

TCP/IP mode DHCP + Auto IP address

Dynamic DNS Enabled

ICMP ping Enabled

Password for LAN configuration LxiWebIfc

The LAN reset also resets the following parameters for the R&S SFI100A:

LXI status settings



Network operation and remote controlR&S®SFI100A

368User Manual 1179.6789.02 ─ 02

Parameter  

Hostname Instrument-specific hostname

Description wideband IF vector signal generator

Negotiation Auto detect

VXI-11 discovery Enabled

12.7  LXI browser settings

Accessing the R&S SFI100A over the LXI browser inerface, you can perform the fol-
lowing tasks:
● Modifying network configurations, see Chapter 12.7.1, "LAN configuration",

on page 369.
● Accessing the instrument remotely
● Analyzing SCPI remote diagnostics
● Monitoring the use and status of the instrument

Access:

► In the address field of the browser, enter the URL address, composed of the instru-
ment's IP address or host name, for example http://10.113.1.151.
Note: Do not add the missing zeros in the IP address, while opening the instru-
ment homepage.

The instrument homepage (welcome page) opens.

The navigation pane of the browser interface contains the following elements:
● "LXI"

– "Home" opens the instrument homepage.
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The homepage displays the device information required by the LXI stan-
dard, including the VISA resource string in read-only format.

– "Device Indicator" activates or deactivates the LXI status indication.
When activated, the LXI LED flashes. A green LXI status symbol indicates
that a LAN connection has been established; a red symbol indicates that no
LAN cable is connected.

– "Lan Configuration" allows you to configure LAN parameters and to initiate
a ping, see Chapter 12.7.1.3, "Ping client", on page 371.

– "Status" displays information about the LXI status of the instrument.
– "Utilities" provides access to the LXI event logging functionality required by

the LXI standard.
● "Instrument Control"

"Web Control" provides remote access to the instrument.
See "To start remote control with the LXI browser" on page 377.

● "Diagnostics"
– "SCPI Remote Trace" records messages exchanged via the remote control

interface, see Chapter 12.7.2, "SCPI remote trace", on page 372.
● "Help"

– "Glossary" explains terms related to the LXI standard.
– www.rohde-schwarz.com opens the Rohde & Schwarz homepage.

12.7.1  LAN configuration

The "LAN Configuration" web page displays all mandatory LAN parameters and allows
their modification.

It comprises the following navigation entries.

● IP configuration..................................................................................................... 369
● Advanced config....................................................................................................370
● Ping client..............................................................................................................371

12.7.1.1  IP configuration

The "IP configuration" web page displays all mandatory LAN parameters and allows
their modification.
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The "IP Address Mode" selects a configuration mode for the IP address of the instru-
ment. With static configuration, the entered IP address, subnet mask, and default gate-
way are used. With dynamic configuration, DHCP or dynamic link local addressing
(automatic IP) is used to obtain the instrument IP address.

Changing the LAN configuration
This function is password-protected. Unlock the protection level 1 to access it.
Note: We recommend that you change the default password before connecting the
instrument to a network.
How to:
● "To change the user password of the instrument" on page 333.
● "To change the security password" on page 333.

See Chapter 11.4.4, "Password management", on page 330.

12.7.1.2  Advanced config

The "Advanced Config" web page provides LAN settings that are not declared manda-
tory by the LXI standard.
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The following advanced parameters are available:
● "mDNS and DNS-SD": The additional protocols "multicast DNS" and "DNS service

discovery" are used for device communication in zero configuration networks,
working without DNS and DHCP.

● "ICMP Ping": Must be enabled to use the ping utility.
If you disable this setting, the instrument does not answer ping requests. The set-
ting does not affect the LXI ping client. You can ping other hosts from the instru-
ment, even if the setting is disabled.

● "VXI-11 Discovery": Must be enabled to detect the instrument in the LAN.
If you disable this setting, the instrument cannot be detected by the VXI-11 discov-
ery protocol mechanism. The setting does not affect other detection mechanisms.
Setting up a VXI-11 connection via the IP address or the host name is independent
of this setting.

Changing the LAN configuration
This function is password-protected. Unlock the protection level 1 to access it.
Note: We recommend that you change the default password before connecting the
instrument to a network.
How to:
● "To change the user password of the instrument" on page 333.
● "To change the security password" on page 333.

See Chapter 11.4.4, "Password management", on page 330.

12.7.1.3  Ping client

The "Ping Client" page provides the ping utility to verify the connection between the
LXI-compliant instrument and another device.
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The ping is initiated from the instrument. Using the ICMP echo request and echo reply
packets, this function checks whether the communication with a device via LAN is
working. Ping is useful for the diagnosis of IP network or router failures.

To initiate a ping at the instrument:

1. On the "Ping Client" page, enter the IP address of the host in the "Destination
Address" field (for example 10.113.1.151).

2. Select "Submit".

12.7.2  SCPI remote trace

The remote trace functionality allows you to trace input and output strings at the
remote control interface of the R&S SFI100A.

See "To activate SCPI remote trace" on page 378.

A recorded trace (message log) can be evaluated directly in the dialog. Use the high-
lighting and navigation functions provided by the lower toolbar to locate error mes-
sages and messages containing arbitrary search strings. You can also export the mes-
sage log to a *.csv file and evaluate the file using a suitable program.

To trace and display messages, switch on "logging" and "live mode" in the toolbar.
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Toolbars

The toolbar at the top of the dialog provides basic settings and functions.

● "Live mode" / "logging": If logging is switched on, messages are traced. They are
stored in an internal database and can be displayed upon request, using the
refresh button (live mode off) or they can be displayed automatically (live mode
on).

● "Filter": applies a filter to columns and/or rows when working (live mode off)
● "Refresh": reads the message log from the internal database and displays it
● "Download": stores the SCPI trace log to a *.csv file
● "Clear": deletes all message log entries in the database and at the screen
● "Details": displays details of the selected message, for example an SCPI command

in hex format (also possible by double\-clicking a message)

Columns

The following columns are available if no column filter is applied:

● "Rec": record number of the message within the message log
● "MT": indicates the type of the message. Possible values and related message

contents are:
– > = incoming command
– < = outgoing response to a query
– E = error message, highlighted by red color
– T = execution time, i.e. time required by the instrument to process the com-

mand internally.
● I: number of the subinstrument
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● "message": indicates the type of the message. Possible values and related mes-
sage contents are:
– > = incoming command
– < = outgoing response to a query
– E = error message, denoted in red
– T = execution time, i.e. time required by the instrument to process the com-

mand internally

12.8  Setting up remote control

When you switch on the R&S SFI100A, it is always in manual operation state ("local"
state). You can operate the instrument over the touchscreen, the front panel and an
external keyboard and/or mouse.

Prerequisites

For remote control, make sure that you have fullfilled the following prerequisites:
● The instrument and the controller PC are connected in the same network.

See Chapter 3.1.7, "Connecting to LAN", on page 19.
● The instrument and the controller are switched on.
● The LAN interface and SCPI over LAN are enabled.

See Chapter 11.4.3, "Configuring LAN services", on page 326.
● A remote control program is running on the controller.

If security is a concern, see:
● Document Instrument Security Procedures.
● Chapter 11.4.5, "Preventing unauthorized access", on page 332.

The following sections describe how to start remote control over the available interface
protocols.

● Configuring remote access................................................................................... 374
● Starting remote control with LXI............................................................................377
● Starting remote control with VXI-11.......................................................................378
● Starting remote control with socket communication..............................................383
● Stopping remote control........................................................................................384

12.8.1  Configuring remote access

Depending on the network capacities, the TCP/IP address information for the instru-
ment can be obtained in different ways.
● If the network supports dynamic TCP/IP configuration using the DHCP protocol,

this service assigns all address information automatically (default setting).
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● If the network does not support DHCP or if there is no server available, the instru-
ment tries to obtain the IP address using the Zeroconf(Avahi) protocol.
This protocol enables the instrument to self-configure an IP address and subnet
mask. Zeroconf (Avahi) IP addresses start with the number blocks 169.254.*.*, with
the subnet mask of 255.255.

The automatic address configuration establishes the physical connection to the LAN
without any additional configuration.

● An IP address that is assigned with the Zeroconf protocol although the network
requires an IP address assigned from the DHCP server can cause network con-
nection failures.

● If both services fail to connect, you must set the address information manually.
See "To assign the instrument address manually" on page 375.

To find the VISA resource string

► Select "System Config > Remote Access > VISA Resource Strings".

The dialog shows the VISA resource strings that enable you to access the instru-
ment for remote control.

To assign the instrument address manually

It is assumed that you have connected the instrument in the LAN.

1. Obtain the instrument address information for the R&S SFI100A and the IP
address for the local default gateway from your network administrator. If necessary,
also obtain the name of your DNS domain and the IP addresses of the DNS server
on your network.
Obtain the IP address and subnet mask for the R&S SFI100A and the IP address
for the local default gateway from your network administrator. If necessary, also
obtain the name of your DNS domain and the IP addresses of the DNS server on
your network.

2. On the instrument, select "System Config > Remote Access > Network".

3. Select "Address Mode > Static".

4. Select the "IP Address".
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5. Enter the IP address, for example 192.168.0.1.

The IP address consists of four number blocks separated by dots. Each block con-
tains 3 numbers in maximum.

6. Select the "Subnet Mask" and enter the subnet mask, for example 255.255.255.0.

Note: The subnet mask must be the same for both, the R&S SFI100A and the host
interface, the instrument is connected to.

7. Enter the "Default Gateway", "DNS Suffix", and "DNS Server" if necessary.

Using the hostname

In a LAN that uses a DNS server, each computer or instrument connected in the LAN
can be addressed with an unambiguous Hostname (also referred to as computer
name) instead of the IP address. The DNS server translates the hostname to the IP
address.

Using the hostname is useful in networks with dynamic TCP/IP and DHCP protocol
services, that assign the address information automatically. Thus, it can be that the
services assign a new IP address each time the instruments restarts, but they do not
change the hostname.

Each instrument is delivered with an assigned hostname, that remains constant as
long as it is not explicitly changed.

This function is password-protected. Unlock the protection level 1 to access it.

The default hostname name follows the syntax <INST>-<Serial Number>, where:
● <INST> is the short name of your instrument, as stated on the front panel.
● <Serial Number> is the individual serial number of the instrument.

You can find the serial number at the rear panel of instrument. It is the third part of
the device ID printed on the barcode sticker.

To query and change the hostname

1. Select "System Config > Remote Access > Network".

Section "Instrument Name" displays the assigned "Hostname".

Note: This function is password-protected. Unlock the protection level 1 to access
it.

2. Select "System Config > Setup > Security > Protection".

3. Enable the "Protection Level 1".
The default protection level 1 password is 123456.
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The parameter "Hostname" in the "Network" tab is now enabled for configuration.

4. Change the "Hostname".

Configuring LAN access and services

By default, the LAN interface and the supported LAN interface services are enabled.
For security reasons, for example to protect the instrument against unauthorized
access, you can block either the LAN services individually, or the access over LAN in
general.

For information on how you can specify the LAN access and sevices individually, see
Chapter 11.4.3, "Configuring LAN services", on page 326 and Chapter 11.4.5, "Pre-
venting unauthorized access", on page 332.

For information on how you configure the remote access individually, see the following
sections:
● Chapter 11.4.3, "Configuring LAN services", on page 326
● "To disable LAN access in general" on page 333
● "To disable LAN services individually" on page 334
● "To enable SMB version 1.0/2.0 client and server" on page 335

12.8.2  Starting remote control with LXI

Using the LXI browser interface you can access and control the R&S SFI100A instru-
ment remotely from a controller PC without additional installation. Remote control over
LXI supports file upload and download between the instrument and the controller PC.

It is assumed that the instrument is set up in the LAN, see "Prerequisites" on page 374.

To start remote control with the LXI browser

1. On the controller PC, start a browser that supports HTML5 (W3C compliant).

2. Enter the IP address of the R&S SFI100A in the browser's address bar.

The browser displays the R&S SFI100A's welcome page.

3. In the navigation pane, select "Instrument Control" > "Web Control".

Remote access to the instrument requires the password. The default password is
instrument.

4. Enter the password.

5. Confirm with [Enter].

The current screen of the R&S SFI100A appears in the browser window.

6. Use the mouse cursor and keyboard to access the functionality of the instrument
as if you operate the instrument directly.
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To activate SCPI remote trace

The remote trace functionality allows you to trace SCPI commands and messages
exchanged over the LAN of the R&S SFI100A. To communicate with the instrument
over SCPI, use a suitable remote control application.

1. Set up the remote control session as described under "To start remote control with
the LXI browser" on page 377.

2. In the navigation pane, select "Diagnostics > SCPI Remote Trace".

3. In the toolbar bar of the "SCPI Remote Trace" page, select "live mode > on".

4. Using the remote control program, send your SCPI commands to the
R&S SFI100A.

The "SCPI Remote Trace" tab displays all sent commands and responses.

5. Select "logging > on".
(Live mode and logging exclude each other).

"logging > on" displays all commands and responses, and traces messages also.

The SCPI remote trace function records all sent commands, received responses
and messages, and saves them in an internal database. If "live mode" is disabled,
you can display the recent traces on request, using the "refresh" button. You can
also save the log in a file.
Note: The diagnostics functionality is extended in later releases, e.g. to download
or upload SCPI command files from / to the instrument.

12.8.3  Starting remote control with VXI-11

This connection uses the I/O software library R&S VISA from Rohde & Schwarz to
setup a LAN remote control link to the instrument.

R&S VISA is running on a controller PC with Windows operating system. You can send
commands to the instrument and receive the responses.

For information installing, operating and the utility applications the software provides,
see R&S VISA product page www.rohde-schwarz.com/rsvisa.

The remote control connection requires a VISA installation but no additional hardware
on the controller PC. The LAN I/O channel is selected at initialization time using the
VISA resource string (also referred to as "address string"). A VISA alias (short name)
replaces the complete resource string. The host address is the R&S SFI100A's host-
name or its IP address.

See Chapter 12.2, "Remote control interfaces and protocols", on page 348.

To set up the controller with R&S VISA

To remote control the R&S SFI100A, we use the R&S VISA Tester application. The
application communicates over the TCP/IP protocol.

1. On the controller PC, install the R&S VISA program.
See www.rohde-schwarz.com/rsvisa > "RS VISA release notes".
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2. On the instrument, enable the LAN interface and "SCPI over LAN".

3. On the controller, start, e.g., "R&S VISA > Tester".

4. In the menu bar, select "Choose VISA Implementation > Rohde & Schwarz Visa"

5. Confirm with "OK".

6. In the menu bar, select "Find Resource" to search for the instrument in the LAN.

7. Select "VXI-11".

8. Select the "refresh" button to start the search.

R&S VISA scans the network for connected instruments and lists all detected
instruments in the "Resource" list.
Note: The search can take some time, particularly in large networks.
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9. Select the required instrument.

10. Confirm with "Ok".

The "Find and select resource" dialog closes and R&S VISA indicates the IP
address in the "Resource" field of the main application window.

11. As an alternative to the IP address, you can assign an alias name to the
R&S SFI100A:

a) In the menu bar, select "RsVisaConfig".

b) In the toolbar, select "+" to access the "VISA Resource String Composer".

Setting up remote control



Network operation and remote controlR&S®SFI100A

381User Manual 1179.6789.02 ─ 02

c) Fill in the "Alias" name, the "VISA Resource String" and the "Device IP Address
or hostname" as shown in the figure.

R&S VISA indicates the assigned "Alias" name.

d) Confirm with "OK".
R&S VISA identifies the R&S SFI100A and you can address it either with the
resource string or the alias name.

12. In the main window, select "Connect".

R&S VISA establishes the connection to the R&S SFI100A.

You can send settings to configure the instrument and receive its responses.

Note: If the connection cannot be set up, R&S VISA displays an error in the log
view.
See also Chapter 14.5, "Resolving network connection failures", on page 619.

To start remote control with R&S VISA

To set the instrument to remote control state, you can send any command from the
controller.

1. Start the R&S VISA Tester.
Establish the connection to the R&S SFI100A.
See "To set up the controller with R&S VISA" on page 378.

2. In the R&S VISA "Basics" tab, enter a SCPI command, e.g. *IDN?.
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3. Confirm with "Query".

The instrument switches to remote control when it receives a command from the
controller.

4. Select "Read" to obtain the instrument response.

The instrument returns the response.
Remote control over R&S VISA is enabled.

To check remote control with VISA

You can check the communication by sending a setting command and querying the
response:

1. Set, e.g. the frequency with the command:
SOUR:FREQ 19.5 GHz.

2. Select "Write".

3. Enter the command SOUR:FREQ?.

4. Select "Query".

If the R&S SFI100A responses with the frequency value xyou entered, remote con-
trol works properly.

To monitor the remote control operation

1. Check the "Show Log" checkbox on the top right.

R&S VISA displays each VISA operation in the log-view on the left.

2. Check the "Write Log" checkbox.
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R&S VISA saves all log-view entries to a log file.

You can operate the log-view in two modes:
● "Live Mode": shows only the most recent messages
● "View Mode" allows you to scroll the history

To return to manual operation, see Chapter 12.8.5, "Stopping remote control",
on page 384.

12.8.4  Starting remote control with socket communication

This section provides an example on how to establish a remote control connection over
Telnet client and a simple sockets-based program example that can be further devel-
oped.

The telnet client transmits information unencrypted. Therefore, for sensitive information
we recommend that you use a client which supports secure protocols, like SSH.

To set up a Telnet connection

To control the software, only a Telnet program is required. The Telnet program is part of
each operating system.

The controller PC and the instrument are connected in the same network.

1. On the instrument, enable the LAN interface and "SCPI over LAN".
See Chapter 11.4.3, "Configuring LAN services", on page 326.

2. On the controller PC, start the Telnet program.

3. Enter the socket address.
The socket address is a combination of the IP address or the hostname of the
R&S SFI100A and the number of the port configured for remote-control via Telnet.
Tip: The R&S SFI100A uses the port number 5025 for remote connection via Tel-
net.

The connection to the instrument is set up and you can send remote-control com-
mands.
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4. Telnet does not reflect your first entry.
Insert a command, e.g. *IDN and confirm with "Enter".

5. Observe the screen.

A response on the query confirms that the connection is working. The client dis-
plays all subsequent inputs and responses.

6. Even if the cursor is not visible on the screen, just enter a remote-control com-
mand. Confirm with Enter.

12.8.5  Stopping remote control

Before returning to manual control, command processing must be completed. Other-
wise, the instrument switches back to remote control immediately.

You have the following options to switch from remote control to manual operation:
● Closing the remote control session
● Using remote control commands
● Selecting the remote icon in the status bar directly on the screen
● Selecting the "Local" key on the key emulation pad on the screen

To find out active remote connections

► Check the indication on the taskbar:

A softkey in the taskbar indicates if and what kind of remote connections are cur-
rently set up.
See also Chapter 12.5.4, "Remote connections", on page 364.
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To return to manual operation

Depending on the used remote control state, the transition from remote control to man-
ual operation requires different actions.

► Select the corresponding transition action as shown in the table.

Table 12-6: Remote control status icons

GUI symbol Transition to remote
control state...

Remote control state characteris-
tics

Transition to manual operation...(local state)

&GTR (controller PC) Remote control, but usable front
panel keys.

The parameters are in read-only
mode.

● &GTL (SCPI
If &NREN has been set before &GTL is locked.
Use &GTR instead.

● CALL IBLOC (generator%), (visual basic).
● viGpibControlREN() (VISA function)
● "Remote" icon in the status bar
● "Local" key on the key emulation pad

 The green arows indicate a currently
performed setting.

The setting must be completed (white arrows)
before you can return to manual operation.

&LLO (controller) Remote control with locked front
panel keys to prevent user interac-
tion.

The parameters are in read-only
mode.

You can unlock LLO, and thus return
to manual operation only over remote
control commands.

● &LOCS
● &REMS

Changes from "Remote LLO" to "Remote"
state.

● CALL IBLOC (generator%)
● viGpibControlREN()

12.9  Using remote command scripts

To configue a test setup quickly, or to make complex test setups or repeating measure-
ments reproducible, you can automate the required settings with remote command
scripts. A remote command script contains a sequence of SCPIs which configure the
corresponding settings. When created, it is converted to an executable format, saved
in a file and can be run whenever needed.

The graph shows the main steps required to create and execute a SCPI script.

Figure 12-7: Steps for performing SCPI Scripts
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● SCPI recording settings........................................................................................ 386
● Creating remote command lists............................................................................ 389
● Checking and verifying a remote command list.................................................... 391
● Converting a remote command list to a script.......................................................392
● Running a remote command script....................................................................... 394

12.9.1  SCPI recording settings

The R&S SFI100A provides information on the required SCPI command for the availa-
ble measurement settings, functions, and results in the context-sensitive menu.

Access:

1. Select a parameter.

2. Open the context-sensitive menu (tap and hold).

The context-sensitive menu provides the SCPI recording functions to help you cre-
ate your script.

● Show SCPI command settings..............................................................................386
● SCPI recording list settings...................................................................................387
● SCPI recording export settings............................................................................. 388

12.9.1.1  Show SCPI command settings

Access:

1. Select the parameter.

2. Open the context-sensitive menu.

3. Select "Show SCPI Command".

This function provides the syntax of the remote command with the current setting.
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Setttings:

Copy............................................................................................................................387
Close........................................................................................................................... 387

Copy
Copies the command and the current setting.

Close
Exits the "SCPI Command" dialog.

12.9.1.2  SCPI recording list settings

Access:

1. Select a parameter.

2. Open the context-sensitive menu.

3. Select "Show SCPI Recording List".

The "SCPI Recording List" shows the recorded commands.

Setttings:

SCPI Recording List....................................................................................................387
Remove All..................................................................................................................387
Remove First...............................................................................................................387
Remove Last............................................................................................................... 388
Export..........................................................................................................................388

SCPI Recording List
Lists the automatically or manually recorded SCPI commands.

Remove All
Deletes all entries in the SCPI command list.

Remove First
Deletes the first entry in the SCPI command list.
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Remove Last
Deletes the last entry in the SCPI command list.

Export
Opens the "SCPI Recording Export" dialog for configuring the file parameters for the
SPCI command script file.
See Chapter 12.9.1.3, "SCPI recording export settings", on page 388.

12.9.1.3  SCPI recording export settings

The R&S SFI100A displays recorded remote command lists in the "SCPI Recording
Export" dialog. This dialog opens automatically, when you stop recording. To open the
dialog manually, proceed as described.

Access:

1. Select a parameter.

2. Open the context-sensitive menu.

3. Select "Show SCPI Recording List".

4. Select "Export".

The "SCPI Recording Export" dialog contains all functions required for export of
command lists to a file. It enables you to select the source code format, assign an
individual filename and display the file content.

Setttings:

Format.........................................................................................................................389
Code Template............................................................................................................ 389
File.............................................................................................................................. 389
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Export..........................................................................................................................389
Reload.........................................................................................................................389
File content..................................................................................................................389

Format
Selects the source code format for the command list.
"Plain SCPI" Uses SCPI syntax.
"Predefined Code Generator"

Accesses the predefined templates for common source code genera-
tors that convert the recorded settings in the programming languages
MATLAB or NICVI or Python.

"User Code Generator"
Use this setting to convert a script by a user-specific code generator.

Code Template
Opens a standard file handling dialog for saving or loading predefined or user-defined
code templates.
See "To use the file-select settings" on page 282.

File
Opens a standard file handling dialog for selecting the directory and file name for the
output file.

Export
Saves the remote command list file in the selected directory.

Reload
Reloads a remote command list file.

File content
Displays the content of the remote command list in the selected format and code tem-
plate.

12.9.2  Creating remote command lists

Using the SCPI recorder functions, you can create a SCPI command list directly on the
instrument and then export the list for use on the controller PC. You can also edit or
write a script manually, using a suitable editor on the controller. For manual creation,
you can retrieve the command corresponding to a setting directly on the instrument.

You can create a SCPI list directly on the instrument at any time of operation, in the
following ways:
● Recording settings automatically

The "Start SCPI Recording" function adds the SCPI command of each step that
you perform to the SCPI list. You can start, stop and resume automatic recording,
and also add individual commands manually.
See "To record settings automatically" on page 390.

● Recording settings manually
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The "Add SCPI Command to Recording List" function adds the SCPI command
and settings value of an individual step to the SCPI list.
See "To record settings manually" on page 390.

● Copying and pasting individual SCPI commands manually
"Show SCPI command" enables you to copy the SCPI command and the current
setting and paste it into any suitable editor.
See "To copy and paste SCPI commands" on page 391.

To record settings automatically

1. On the screen, open the context-sensitive menu.

2. Select "Start SCPI recording".

The R&S SFI100A now records all steps you take.

3. To stop SCPI recording, select "Stop SCPI recording" in the context-sensitive
menu.

The "SCPI Recording List" dialog opens.

4. Proceed with "To review a remote command list" on page 392.

To record settings manually

1. Select the parameter or function.

2. Set the parameter.

3. Open the context-sensitive menu.

4. Select "Add SCPI Command to Recording List".

The R&S SFI100A adds the SCPI command of the setting including the value in a
temporary SCPI command list.

Tip: "Context-Sensitive > Show SCPI Recording List" opens the dialog with the
recorded settings.

5. Continue with the next setting accordingly whenever you want to record it.

6. Proceed with "To review a remote command list" on page 392.
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To copy and paste SCPI commands

1. On the instrument, select the parameter or function.

2. Set the parameter.

3. Open the context-sensitive menu.

4. Select "Show SCPI Command".

The R&S SFI100A displays the syntax and the setting value of the SCPI command.

With the "Copy" function, you can copy and paste the SCPI command and setting
value, e.g., in a command script on a PC.

12.9.3  Checking and verifying a remote command list

Before converting a command list to an executable script, we recommend that you
check if the entries are correct and complete. It can be that ...
● a parameter has not assigned a SCPI command or an element of the user inter-

face has not an assigned parameter. In these cases, :SYST:INF:SCPI 'SCPI
command not available' is entered in the list instead.
Such entries are also detected during execution. The instrument recognizes these
incomplete commands and displays an error message.

● a preset has been executed, but several standards then perform some internal set-
tings that are also assigned to the list with "SCPI Export".

● after a preset some settings are still defined, which are then written to the list gen-
erated with "SCPI Export."

To display a remote command list

On the instrument, you have different options to access a remote command list.

1. During automatic or manual recording:

a) Open the context-sensitive menu.
b) Select "Show SCPI Recording List".

2. At the end of automatic recording:

a) Open the context-sensitive menu.
b) Select "Stop SCPI Recording".

3. After exporting a command list to a file.

a) Select "SCPI Recording Export" > "Show file content".

The "SCPI Recording List" opens.
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To review a remote command list

To rework a remote command list, you must transfer it to a computer.

1. Export the list to a PC, using, for example, a USB flash drive.

2. Check the list, e.g. by comparing it with the modified settings in the manual mode.

Tip: To find out your settings, you can use the "Mark all parameters changed from
preset" function.
See Chapter 10.2.2, "Identifying parameters with non-default values", on page 276.

3. Search for missing or incomplete command entries.

a) Add missing commands.
b) Complete missing parts of commands.
c) Remove superfluous entries, e.g. :SYST:INF:SCPI 'SCPI command not

available'.
d) Remove unnecessary content written after a preset.

4. Rearrange the commands to a reasonable order. For example, if you set a STATe
command to the last position in a list, you can avoid intermediate calculations of
the signal.

12.9.4  Converting a remote command list to a script

For conversion of a remote command list into an executable script, a code generator
translates the commands into the source code of a proprietary programming language,
based on a code template. Therefore, each progamming language requires a dedica-
ted code template.

The R&S SFI100A provides the following predefined code templates by default:
● Plain SCPI

Represents SCPI base format, that is ASCII format, saved as text file (*.txt).
● MATLAB

A programming environment, frequently used in signal processing and test and
measurement applications (*.m).
You can directly use this format with MATLAB(c) Toolkit. For comprehensive infor-
mation on this topic, refer to the application note 1GP60.

● NICVI
An ANSI C programming environment designed for measurements and tests (*.c).
You can directly use this format with National Instruments LabWindows CVI.

● Python3
A general-purpose and high-level programming language (*.py).

You can also convert a script to a user-specific format. In this case, you need a code
template with the extension *.expcodetmpl.

When converted, you can save the script in a file with the extension corresponding to
the programming language.
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To configure a plain SCPI script file

1. Select "Show SCPI Recording List" in the context-sensitive menu.

2. Select "Export".
The "SCPI Recording Export" dialog opens.

3. Select the "Format" > "Plain SCPI".

4. Select "File".
A standard file handling dialog opens.

5. Configure filename and directory and confirm with "Ok".

6. In the "SCPI Recording Export" dialog, select "Export".
The R&S SFI100A saves the recorded data in *.txt format. The "File Content"
section shows the SCPI commands of the script file.

To convert the command list to a predefined code template

1. Select "Show SCPI Recording List" in the context-sensitive menu.

2. Select "Export".
The "SCPI Recording Export" dialog opens.

3. In the "SCPI Recording Export" dialog, select "Format" > "Predefined Code Gener-
ator".

The "CodeTemplate" button appears.

4. Select "Code Template".

The "SCPI Recording Export - Select Predefined Code Template" dialog opens.

5. Select a predefined code template, e.g., "MATLAB".

6. Confirm with "Select".

The R&S SFI100A returns to the "SCPI Recording Export" dialog.

7. Select "File".
A standard file handling dialog opens.

8. Configure filename and directory and confirm with "Ok".

9. In the "SCPI Recording Export" dialog, select "Export".
The R&S SFI100A saves the recorded data in the corresponding format. The "File
Content" section shows the content of the script file in the corresponding program-
ming language.

To convert the command list to a user-defined code template

Before creating a script in a user-specific format, make sure that you have saved the
code template with the file extension *.expcodetmpl in the instrument.

1. Select "Show SCPI Recording List" in the context-sensitive menu.

2. In the "SCPI Recording Export" dialog, select "Format" > "Use Code Generator".
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The "CodeTemplate" button appears.

3. Select "Code Template".

The "SCPI Recording Export - Select User Code Template" dialog opens.

4. Select your user-defined code template.

5. Confirm with "Select".

The R&S SFI100A returns to the "SCPI Recording Export" dialog.

6. Select "File".
A standard file handling dialog opens.

7. Configure filename and directory and confirm with "Ok".

8. In the "SCPI Recording Export" dialog, select "Export".
The R&S SFI100A saves the recorded data in the corresponding format. The "File
Content" section shows the content of the script file in the corresponding program-
ming language.

12.9.5  Running a remote command script

An executable script automates measurement tasks on the instrument. Usually control-
led by a remote PC, you can also save and run a script directly in the instrument by
assigning the script to the [★] key.

See Chapter 11.2.4, "How to assign actions to the [★] key", on page 309.

12.10  Setting up remote operation over VNC

VNC accesses the R&S SFI100A over LAN from a remote device using a web browser
or a VNC client. With the screen displayed on the controller, you can control the instru-
ment as if you operate it directly. Establishing the access depends on the used remote
device and VNC client software.

Prerequisites

For remote operation, make sure that you have fullfilled the following prerequisites:
● The instrument and the controller PC are connected in the same network.

See Chapter 3.1.7, "Connecting to LAN", on page 19.
● The instrument and the controller are switched on.
● The LAN interface and VNC LAN service is enabled.

See Chapter 11.4.3, "Configuring LAN services", on page 326.
● A suitable application is running on the remote device.

– Web browser
The R&S SFI100A supports remote operation over VNC with any web browser,
e.g., Windows Internet Explorer, Mozilla Firefox, or an HTML5 web browser.

– VNC client software
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Linux/Unix operating systems include a VNC client software by default.
For remote devices with windows operating system a VNC client software must
be installed manually. Various free-of charge programs such as Ultr@VNC or
similar VNC client programs are available for download on the Internet.

VNC client software
Linux/Unix operating systems include a VNC client software by default.
For remote devices with windows operating system a VNC client software must be
installed manually. Various free-of charge programs such as Ultr@VNC or similar VNC
client programs are available for download on the Internet.

If security is a concern, see:
● Document Instrument Security Procedures.
● Chapter 11.4.5, "Preventing unauthorized access", on page 332.

See Chapter 12.1, "Overview of remote access modes", on page 346.

The following examples descibe how to set up remote operation with remote devices:
● Using a controller PC

– "To operate the instrument from a web browser over VNC" on page 396
– "To operate the instrument from a Linux/Unix client over VNC" on page 396
– "To operate the instrument from a Windows client over VNC" on page 397

● Using a smart device
– "To operate the instrument using a VNC App on a smart device" on page 400
– "To operate the instrument from a web browser over VNC" on page 396
– "To access the instrument with QR code on a smart device" on page 400

To enable VNC service on the R&S SFI100A

1. NOTICE! Enabled VNC service can lead to unauthorized access.
Change the computer name and password of the instrument.
See Chapter 11.4.5, "Preventing unauthorized access", on page 332.

2. Select "System Config > Setup > Security > Security".

3. Select "LAN Services > Common Services".

4. Enable "VNC".

5. Enter the Security Password.

6. Confirm with "Accept".

● Using a controller PC............................................................................................ 396
● Using a smart device.............................................................................................398
● Stopping remote operation....................................................................................401
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12.10.1  Using a controller PC

Prerequisites

For remote operation from a controller PC, make sure that you have fullfilled the follow-
ing prerequisites:
● The instrument and the controller PC are connected in the same network.

See Chapter 3.1.7, "Connecting to LAN", on page 19.
● The instrument and the controller are switched on.
● The LAN interface and VNC LAN service is enabled.

See Chapter 11.4.3, "Configuring LAN services", on page 326.
● A suitable application is running on the remote device.

– Web browser
The R&S SFI100A supports remote operation over VNC with any web browser,
e.g., Windows Internet Explorer, Mozilla Firefox, or an HTML5 web browser.

– VNC client software
Linux/Unix operating systems include a VNC client software by default.
For remote devices with windows operating system a VNC client software must
be installed manually. Various free-of charge programs such as Ultr@VNC or
similar VNC client programs are available for download on the Internet.

VNC client software
Linux/Unix operating systems include a VNC client software by default.
For remote devices with windows operating system a VNC client software must be
installed manually. Various free-of charge programs such as Ultr@VNC or similar VNC
client programs are available for download on the Internet.

To operate the instrument from a web browser over VNC

1. Install the JRE (Java Runtime Environment) on the remote computer.
Note: Skip this step if you are working with an HTML5 web browser.

2. Enter the IP address of the instrument in the address field of the web browser, e.g.
http://10.113.1.151

The VNC authentication screen appears.

3. Enter the user password.
The default password is instrument.

4. Confirm with with "OK".

When the VNC connection is established, the screen of the signal generator
appears and you can operate the instrument from the remote computer.

To operate the instrument from a Linux/Unix client over VNC

1. Start a web browser on the remote computer. Enter the IP address of the instru-
ment.
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2. Enter the following address:
vnc://<IP-address of the instrument>, for example vnc://10.113.1.151.

A dialog opens requesting the password for the remote VNC connection.

3. Enter the user password.
The default password is instrument.

4. Confirm with with "OK".

When the VNC connection is established, the screen of the signal generator
appears and you can operate the instrument from the remote computer.

To operate the instrument from a Windows client over VNC

1. Install the VNC viewer program component on the remote computer.

a) Download a VNC client program from the Internet.
For example the free of charge software Ultr@VNC (vncviewer.exe is avail-
able, see http://www.uvnc.com/download/index.html.

b) Execute the VNC client installation.
c) Select the VNC viewer program component and follow the installation instruc-

tions.

2. Start VNC viewer program component on the PC.

3. Select "VNC Server"

4. Enter the IP address of the instrument.

5. Confirm with "Connect".

An authentication dialog opens.

Setting up remote operation over VNC
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6. Enter the user password for authentication.
The default password is instrument.

7. Confirm with "LogOn".

When the connection is established, the screen of the signal generator appears
and you can operate the instrument from the remote computer.

12.10.2  Using a smart device

The R&S SFI100A supports remote operation over VNC from a smart device (remote
client), like a tablet (tablet computer) or a smartphone. The smart device accesses the
instrument over WLAN, either by a suitable App, or an HTML5 web browser with
embedded javascript.

There are several possibilities to establish a WLAN connection between the smart
device and the R&S SFI100A. This section gives an example of how a network envi-
ronment can be built up, and some essential configuration steps.

For more information, see:
● 1MA216: Remote Operation of Windows Based Instruments with Apple iPad
● 7BM82: Apple iPad Remote Control of Broadcasting T&M Instruments

Setting up remote operation over VNC
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Example: 

Figure 12-8: Example of a network configuration for remote operation with a smart device

As shown in the figure, the R&S SFI100A and the WLAN router are connected to the
LAN router. The smart device accesses the Rohde & Schwarz instrument via the
WLAN router.
The WLAN router as an additional access point enables you to operate the instrument
even from a great distance.

Prerequisites

For the remote operaton, you need the following equipment and configuration:
● Equipment:

– LAN router
– WLAN router (hot spot) for accessing the instrument
– Smart device

● The instrument and the smart device PC are connected in the same network.
● The instrument and the smart device are switched on.
● The LAN interface and VNC LAN service is enabled.

See Chapter 11.4.3, "Configuring LAN services", on page 326.
● A suitable application is running on the smart device.

– Web browser
The R&S SFI100A supports remote operation over VNC with any HTML5 com-
pliant web browser, e.g., Internet Explorer, Firefox, Google Chrome or Safari.

– VNC app
An application that implements the VNC functionality for remote operation. The
VNC App must be suitable to the used smart device.
Refer to the manufacturer's website to find a VNC App supported for your
smart device, and how it is installed.

– QR code
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If your smart device is equipped with a camera and a QR code reader, you can
scan the instrument's IP address or access the instrument with the Safari web
browser.
Refer to the manufacturer's website to find a QR code reader supported for
your smart device, and how it is installed.

We recommend that all components in the network use DHCP, which automatically
assigns the relevant address information.

To operate the instrument using a VNC App on a smart device

1. Set up the network connection as shown in Figure 12-8

2. Configure the WLAN router according to the manufacturer's instructions.

3. Install the required VNC App on your smart device.

4. On the smart device, start the VNC App.
Enter the IP address of the instrument in the address field of VNC App.

The VNC authentication screen appears.

5. Enter the user password.
The default password is instrument.

6. Enter the password to establish the remote access.
The default user name and password is instrument.

When the VNC connection is established, the screen of the signal generator
appears and you can operate the instrument from the smart device.

To operate the instrument from a web browser over VNC

1. Install the JRE (Java Runtime Environment) on the remote computer.
Note: Skip this step if you are working with an HTML5 web browser.

2. Enter the IP address of the instrument in the address field of the web browser, e.g.
http://10.113.1.151

The VNC authentication screen appears.

3. Enter the user password.
The default password is instrument.

4. Confirm with with "OK".

When the VNC connection is established, the screen of the signal generator
appears and you can operate the instrument from the remote computer.

To access the instrument with QR code on a smart device

1. Set up the network connection as shown in Figure 12-8

2. Configure the WLAN router according to the manufacturer's instructions.

3. Install the required QR code reader software on your smart device.

4. On the smart device, start the QR code reader.
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5. On the R&S SFI100A, select "System Config > Remote Access".

6. Select the "QR-Code" tab.

7. Scan the QR code of the instrument with your smart device.

8. On the smart device, decode the scanned QR code and forward it to the web
browser.

The VNC authentication screen appears.

9. Enter the user password.
The default password is instrument.

When the VNC connection is established, the screen of the signal generator
appears and you can operate the instrument from the smart device.

12.10.3  Stopping remote operation

To stop remote operation

To terminate remote operation over VNC depends on the used client:

► Select the action that applies to the used client:

a) On an external Unix/Linux PC, close the Internet browser or the signal genera-
tor window.

b) On an external Windows PC, close the VNC viewer program.
c) On a smart device, close the application.

The connection is terminated but not disabled. It can be established again anytime.

12.11  References

12.11.1  LXI functionality

LAN Extensions for Instrumentation (LXI) is an instrumentation platform for measuring
instruments and test systems that is based on standard Ethernet technology.

The LXI implementation in the R&S SFI100A allows you to change certain LAN set-
tings, to reset the LAN connection, and to identify the instrument.

For information about the LXI standard, refer to the LXI website at https://www.lxistan-
dard.org.
See also "News from Rohde & Schwarz, article 2006/II - 190".

The LXI functionality in the R&S SFI100A is characterized by a common LAN imple-
mentation, including an ICMP ping responder for diagnostics. Using a web browser,
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you can configure the instrument. A LAN Configuration Initialize (LCI) mechanism
resets the LAN configuration. The instrument also supports automatic detection in a
LAN via the VXI-11 discovery protocol and programming by IVI drivers.

In addition, the R&S SFI100A provides the following LXI-related functionality:
● Integrated "LXI Status" dialog for LXI status indication and reset of the LAN config-

uration, see Chapter 12.6, "LXI status settings", on page 366.
● "LXI Browser Interface", as described in Chapter 12.7.1, "LAN configuration",

on page 369.
● "SCPI Remote Trace" utility, see Chapter 12.7.2, "SCPI remote trace",

on page 372.

Firmware update
To enable the full LXI functionality after a firmware update, shut down and restart the
instrument.

12.11.2  Code generator templates

This section describes the main structure of the code generator templates, and shows
the method with the NICVI template.

The code generation is controlled by templates with the following blocks:

Command Function

#EXTENSION_START
#EXTENSION_END

Defines the output file extension.

#INIT_CODE_START
#INIT_CODE_END

Contains initial entries, such as included files and
libraries, buffer size, commands for synchronization,
or creating a VISA session.

All entries between start and end are written once at
the beginning of the output file.

#COMMAND_CODE_START
#COMMAND_CODE_END

Frame for a SCPI command. A command is
accessed with %COMMAND.

#NO_COMMAND_CODE_START
#NO_COMMAND_CODE_END

Frame for a parameter with no SCPI command
available. A parameter is accessed with
%PARAMETER.

#EXIT_CODE_START
#EXIT_CODE_END

Closes the visa session.

All entries between start and end are written once at
the end of the output file.

Templates are created in ASCII format with file extension *.expcodetempl.

Example: 
Example to the code generator template NICVI.expcodetmpl:
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#EXTENSION_START
.c
#EXTENSION_END

#INIT_CODE_START
#include <ansi_c.h>
#include <visa.h>
#include <cvirte.h>

#define MAX_BUFFER_SIZE 200
static ViStatus status;
static ViSession defaultRM, handle;

static void write_command(char *command)
{
  char writeBuffer[MAX_BUFFER_SIZE];
        char readBuffer[MAX_BUFFER_SIZE];
        int length;
        int readCount;
        
        strcpy(writeBuffer, command);
        //append "*OPC?" to sync
        strcat(writeBuffer, ";*OPC?");
        length = strlen (writeBuffer);
        writeBuffer[length]='\n';
        length = length+1;
        viWrite (handle, writeBuffer, length, VI_NULL);
        //read result
        viRead(handle, readBuffer, 100, &readCount);
}     
int main (int argc, char *argv[])
{
  if (InitCVIRTE (0, argv, 0) == 0)
     return -1;    /* out of memory */
        //create a VISA session and return a handle to it
     viOpenDefaultRM (&defaultRM);
        //create a VISA session to the serial port and return a handle to it
        viOpen (defaultRM, (ViRsrc)"TCPIP::localhost::INSTR", VI_NULL, VI_NULL, 
&handle);
#INIT_CODE_END

#COMMAND_CODE_START
  write_command("%COMMAND");
#COMMAND_CODE_END

#NO_COMMAND_CODE_START
  //no SCPI command available for parameter %PARAMETER !
#NO_COMMAND_CODE_END

#EXIT_CODE_START
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  viClose (handle);
        viClose (defaultRM);
        return 0;
}
#EXIT_CODE_END
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13  Remote control commands
In the following, all remote-control commands are presented in detail with their param-
eters and the ranges of numerical values.

For an introduction to remote control and the status registers, see Chapter 12, "Net-
work operation and remote control", on page 346.

● Conventions used in SCPI command descriptions............................................... 405
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● Common commands.............................................................................................406
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● DISPlay subsystem...............................................................................................430
● FORMat subsystem.............................................................................................. 435
● HCOPy subsystem................................................................................................436
● KBOard subsystem............................................................................................... 442
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● SENSe, READ, INITiate and SLISt subsystems................................................... 445
● SCONfiguration subsystem...................................................................................459
● SOURce subsystem..............................................................................................468
● SOURce:BB subsystem........................................................................................529
● STATus subsystem................................................................................................577
● SYSTem subsystem..............................................................................................581
● TEST subsystem...................................................................................................610
● UNIT subsystem....................................................................................................612

13.1  Conventions used in SCPI command descriptions

The following conventions are used in the remote command descriptions:
● Command usage

If not specified otherwise, commands can be used both for setting and for querying
parameters.
If a command can be used for setting or querying only, or if it initiates an event, the
usage is stated explicitly.

● Parameter usage
If not specified otherwise, a parameter can be used to set a value, and it is the
result of a query.
Parameters required only for setting are indicated as Setting parameters.
Parameters required only to refine a query are indicated as Query parameters.
Parameters that are only returned as the result of a query are indicated as Return
values.

● Conformity
Commands that are taken from the SCPI standard are indicated as SCPI con-
firmed. All commands used by the R&S SFI100A follow the SCPI syntax rules.
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● Asynchronous commands
A command which does not automatically finish executing before the next com-
mand starts executing (overlapping command) is indicated as an Asynchronous
command.

● Reset values (*RST)
Default parameter values that are used directly after resetting the instrument (*RST
command) are indicated as *RST values, if available.

● Factory preset values
Default parameter values that are reset only by factory preset.

● Default unit
The default unit is used for numeric values if no other unit is provided with the
parameter.

● Manual operation
If the result of a remote command can also be achieved in manual operation, a link
to the description is inserted.

13.2  Programming examples

The corresponding sections of the same title provide simple programming examples for
the R&S SFI100A. The purpose of these examples is to present all commands for a
given task. Real applications require application-specific sets of commands and config-
urations.

The programming examples have been tested with a software tool which provides an
environment for the development and execution of remote tests. To keep the examples
as simple as possible, only the "clean" SCPI syntax elements are reported. Non-exe-
cutable command lines start with two characters //, for example, comments.

At the beginning of the most remote control program, an instrument preset or reset is
recommended to set the R&S SFI100A to a definite state. The commands *RST and
SYSTem:PRESet are equivalent for this purpose. *CLS also resets the status registers
and clears the output buffer.

In all the examples we assume the following:
● A remote PC is connected to the instrument.
● The remote PC and the instrument are switched on.
● A connection between them is established.
● The security setting "System Config" > "Setup" > "Security" > "SCPI over LAN" is

enabled.

13.3  Common commands

Common commands are described in the IEEE 488.2 (IEC 625-2) standard. These
commands have the same effect and are employed in the same way on different devi-
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ces. The headers of these commands consist of "*" followed by three letters. Many
common commands are related to the Status Reporting System.

Available common commands:

*CLS.............................................................................................................................407
*ESE.............................................................................................................................407
*ESR?...........................................................................................................................407
*IDN?............................................................................................................................408
*IST?............................................................................................................................ 408
*OPC............................................................................................................................408
*OPT?...........................................................................................................................408
*PRE............................................................................................................................ 409
*PSC............................................................................................................................ 409
*RCL.............................................................................................................................409
*RST.............................................................................................................................409
*SAV.............................................................................................................................410
*SRE............................................................................................................................ 410
*STB?...........................................................................................................................410
*TRG............................................................................................................................ 410
*TST?........................................................................................................................... 410
*WAI............................................................................................................................. 411

*CLS

Clear status

Sets the status byte (STB), the standard event register (ESR) and the EVENt part of
the QUEStionable and the OPERation registers to zero. The command does not
alter the mask and transition parts of the registers. It clears the output buffer.

Usage: Setting only

*ESE <Value>

Event status enable

Sets the event status enable register to the specified value. The query returns the con-
tents of the event status enable register in decimal form.

Parameters:
<Value> Range: 0 to 255

*ESR?

Event status read

Returns the contents of the event status register in decimal form and then sets the reg-
ister to zero.

Return values: 
<Contents> Range: 0  to  255
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Usage: Query only

*IDN?

Identification

Returns the instrument identification.

Return values: 
<ID> "Rohde&Schwarz,<device type>,<part number>/<serial num-

ber>,<firmware version>"

Usage: Query only

Manual operation: See "IDN String" on page 363
See "Hardware Options/Software Options" on page 624

*IST?

Individual status query

Returns the contents of the IST flag in decimal form. The IST flag is the status bit
which is sent during a parallel poll.

Return values: 
<ISTflag> 0 | 1

Usage: Query only

*OPC

Operation complete

Sets bit 0 in the event status register when all preceding commands have been execu-
ted. This bit can be used to initiate a service request. The query writes a "1" into the
output buffer when all preceding commands have been executed, which is useful for
command synchronization.

*OPT?

Option identification query

Queries the options included in the instrument. For a list of all available options and
their description, refer to the specifications document.

Return values: 
<Options> The query returns a list of options. The options are returned at

fixed positions in a comma-separated string. A zero is returned
for options that are not installed.

Usage: Query only

Manual operation: See "OPT String" on page 363
See "Hardware Options/Software Options" on page 624
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*PRE <Value>

Parallel poll register enable

Sets parallel poll enable register to the indicated value. The query returns the contents
of the parallel poll enable register in decimal form.

Parameters:
<Value> Range: 0  to  255

*PSC <Action>

Power on status clear

Determines whether the contents of the ENABle registers are preserved or reset when
the instrument is switched on. Thus a service request can be triggered when the instru-
ment is switched on, if the status registers ESE and SRE are suitably configured. The
query reads out the contents of the "power-on-status-clear" flag.

Parameters:
<Action> 0 | 1

0
The contents of the status registers are preserved.
1
Resets the status registers.

*RCL <Number>

Recall

Loads the instrument settings from an intermediate memory identified by the specified
number. The instrument settings can be stored to this memory using the command
*SAV with the associated number.

It also activates the instrument settings which are stored in a file and loaded using the
MMEMory:LOAD <number>, <file_name.extension> command.

Manual operation: See "Recall Immediate x" on page 281

*RST

Reset

Sets the instrument to a defined default status. The default settings are indicated in the
description of commands.

The command is equivalent to SYSTem:PRESet.

Usage: Setting only

Manual operation: See "Preset" on page 275
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*SAV <Number>

Save

Stores the current instrument settings under the specified number in an intermediate
memory. The settings can be recalled using the command *RCL with the associated
number.

To transfer the stored instrument settings in a file, use the command :MMEMory:
STORe:STATe.

Manual operation: See "Save Immediate x" on page 280

*SRE <Contents>

Service request enable

Sets the service request enable register to the indicated value. This command deter-
mines under which conditions a service request is triggered.

Parameters:
<Contents> Contents of the service request enable register in decimal form.

Bit 6 (MSS mask bit) is always 0.
Range: 0  to  255

*STB?

Status byte query

Reads the contents of the status byte in decimal form.

Usage: Query only

*TRG

Trigger

Triggers all actions waiting for a trigger event. In particular, *TRG generates a manual
trigger signal. This common command complements the commands of the TRIGger
subsystem.

*TRG corresponds to the INITiate:IMMediate command.

Usage: Event

*TST?

Self-test query
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Initiates self-tests of the instrument and returns an error code.

Return values: 
<ErrorCode> integer > 0 (in decimal format)

An error occurred.
(For details, see the Service Manual supplied with the instru-
ment).
0
No errors occurred.

Usage: Query only

*WAI

Wait to continue

Prevents servicing of the subsequent commands until all preceding commands have
been executed and all signals have settled (see also command synchronization and
*OPC).

Usage: Event

13.4  Preset commands

The preset commands are not bundled in one subsystem. Therefore, they are listed
separately in this section.

Four presetting actions are available:
● Activating the default state of all internal instrument functions (*RST on page 409).

Functions that concern the integration of the instrument into a measurement setup
are not changed, e.g. reference oscillator source settings.

● Activating the preset state of the parameters related to the selected signal path (:
SOURce<hw>:PRESet on page 412)

● Activating the preset state of all parameters that are not related to the signal path
(:DEVice:PRESet on page 412)

● Activating the original state of delivery (factory reset, :SYSTem:FPReset
on page 412). Only functions that are protected by a password remain unchanged
as well as the passwords themselves.

When resetting, the following deviation between remote and manual control exists:
In contrast to the [Preset] key, the SCPI commands *RST and :SYSTem:PRESet do
not close open dialogs in the GUI.

:DEVice:PRESet............................................................................................................ 412
:SOURce<hw>:PRESet.................................................................................................. 412
:SYSTem:PRESet.......................................................................................................... 412
:SYSTem:FPReset......................................................................................................... 412
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:DEVice:PRESet

Presets all parameters which are not related to the signal path, including the LF gener-
ator.

Example: DEV:PRES
Presets all instruments settings that are not related to the signal
path.

Usage: Event

:SOURce<hw>:PRESet

Presets all parameters which are related to the selected signal path.

Example: SOUR:PRES
Presets all settings that are related to signal path

Usage: Event

:SYSTem:PRESet

Triggers an instrument reset. It has the same effect as:
● The *RST command

Example: SYST:PRES
All instrument settings (also the settings that are not currently
active) are reset to their default values.

Usage: Setting only

:SYSTem:FPReset

Triggers an instrument reset to the original state of delivery.

Example: SYST:FPR
All instrument settings (also the settings that are not currently
active) are reset to the factory values.

Usage: Event

Manual operation: See "Execute Factory Preset" on page 276

13.5  MMEMory subsystem

The MMEMory subsystem (Mass MEMory) contains the commands for managing files
and directories as well as for loading and saving complete instrument settings in files.
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Mass storage location

Both, the user directory /var/user/ on the internal memory or the /usb/ directory
on the memory stick, can be used to preserve user-defined data. Any directory struc-
ture can be created.

The /var/volatile directory serves as a RAM drive and can be used to protect
sensitive information. The data is available temporarily.

Default storage location

The R&S SFI100A stores user data in the user directory.

In the file system, user directory is always indicated as /var/user/.

In manual control, you access this directory via the "File Manager", see Chapter 10.7,
"Using the file manager", on page 284. In remote control, you can query it with the
command :SYSTem:MMEMory:PATH:USER?.

To query and change the default directory used for mass storage, use the command :
MMEMory:CDIRectory.

13.5.1  File naming conventions

To enable files to be used in different file systems, consider the following file naming
conventions:
● The filename can be of any length and is case-sensitive, i.e it is distinguished

between uppercase and lowercase letters.
● All letters and numbers are permitted (numbers are, however, not permitted at the

beginning of the filename).
● Avoid using special characters.
● Do not use slashes "\" and "/". These symbols are used in file paths.
● Avoid using the following filenames: CLOCK$, CON, COM1 to COM4,

LPT1 to LPT3, NUL or PRN
They are reserved by the operating system.

Wildcards

The two characters "*" and "?" function as "wildcards", i.e. they are used for selecting
several files. The "?" character represents exactly one character, while the "*" charac-
ter represents all characters up to the end of the filename. "*.*" therefore represents all
files in a directory.

Filename and file path

When used in remote control commands, the parameter <filename> is specified as a
string parameter with quotation marks. It can contain either the complete path including
the root user directory /var/user and filename, or only the filename. The filename
must include the file extension. The same applies for the directory /var/volatile
and for the parameters <directory_name> and <path>.
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Depending on how much information is provided, the values specified in the parameter
or with the command MMEM:CDIR are used for the path and drive setting in the com-
mands.

13.5.2  Handling files in the default or in a specified directory

For better overview and easy file handling, you may not save all user files in the user
directory /var/user but rather organize them into subdirectories.

The command syntax defines two general ways to access files with user data in a spe-
cific directory:
● Change the current default directory for mass memory storage and then directly

access the files in this default directory, like saved list files, files with user data or
save/recall files.
The subsequent commands for file handling (select, delete, read out files in the
directory, etc.) require only specification of the filename. File extension can be
omitted; after syntax evaluation of the used command, the R&S SFI100A filters out
the relevant files.

● Define the complete file path, including the user directory /var/user, created
subdirectories and filename.
As a rule, whenever an complete file path is determined, it overwrites a previously
specified default directory.

The following example explains this rule as a principle. Exceptions of this general rule
are stated in the description of the corresponding command. The Chapter 13.5.3, "Pro-
gramming examples", on page 414 explains the general working principle with the
commands for mass memory storage.

The same rule applies to the /var/volatile directory, see Example "Working with
files in the volatile memory" on page 416.

13.5.3  Programming examples

Example: Saving and loading current settings
This example shows two ways of how to save the current instrument setting in the file
settings.savrcltxt in the directory /var/user/savrcl.

Before the instrument settings can be saved in a file, they have to be saved in an inter-
mediate memory using common command *SAV <number>. The specified number is
then used in the :MMEMory:STORe:STATe command.
Also, after loading a file with instrument settings with command :MMEMory:LOAD:
STATe, these settings have to be activated with the common command *RCL
<number>.

// Save the current settings in an intermediate memory with number 4
*SAV 4
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// save the settings in a file in a specific directory;
// the complete path has to be specyfied
MMEMory:STORe:STATe 4,"/var/user/savrcl/settings.savrcltxt"

// save the settings in a file in the default directory;
// set the default directory; specify only the file name
MMEMory:CDIRectory  "/var/user/savrcl"
*SAV 4
MMEMory:STORe:STATe 4,"settings.savrcltxt"

// Load the saved settings in the intermediate memory 4 and activate them
MMEMory:LOAD:STATe 4,"/var/user/settings.savrcltxt"
*RCL 4

Example: Working with files and directories
This example shows how to list files in a directory, list the subdirectories, query the
number of files in a directory, create directory, rename and delete files.

// Query the current default directory for mass storage,
// change the directory to the default user directory "/var/user"
// and read out the files in it
MMEMory:CDIRectory?
// "/var/user/temp"
MMEMory:CDIRectory
MMEMory:CDIRectory?
// "/var/user/"
MMEMory:CATalog?
// 1282630,8102817792,".,DIR,4096","..,DIR,4096","Log,DIR,4096",
// "settings.savrcltxt,BIN,16949","temp,DIR,4096","test,DIR,4096",
// "list.lsw,BIN,1245201"
// the directory "/var/user" contains the predefined directory "Log",
// the subdirectories "test" and "temp"
// as well as the files "settings.savrcltxt" and "list.lsw"

// query only the subdirectories of the current or specified directory
MMEMory:DCATalog? "/var/user"
// ".","..","Log","temp","test"

// query only number of subdirectories in the current or specified directory
MMEMory:DCATalog:LENGth? "/var/user"
// 5

// query number of files in the current or specified directory
MMEMory:CATalog:LENGth? "/var/user"
// 7

// Create a new directory for mass memory storage in the specified directory
MMEMory:MDIRectory "/var/user/new"
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// Copy the file "settings.savrcltxt" into the new directory
MMEMory:COPY "/var/user/settings.savrcltxt","/var/user/new/settings.savrcltxt"

// Rename the file "settings.savrcltxt" into the new directory
// and read out the files in this specific directory
MMEMory:CDIRectory  "/var/user/new"
MMEMory:MOVE "settings.savrcltxt","settings_new.savrcltxt"
MMEMory:CATalog? "/var/user/new"
// 25141,8102789120,".,DIR,4096","..,DIR,4096","settings_new.savrcltxt,BIN,16949"

// Delete an empty directory, e.g. the "test" directory 
MMEMory:RDIRectory "/var/user/test"
// Delete the entire directory, including files and subdirectories 
:MMEMory:RDIRectory:RECursive "var/user/test"

Example: Working with files in the volatile memory
This example shows how to work with files in the /var/volatile directory.

// Change the default directory for mass storage,
// read out the files, load and play a file with the ARB 
MMEMory:CDIRectory "/var/volatile"
MMEMory:CDIRectory?
// "/var/volatile"
MMEMory:CATalog?
//13928,525352960,".,DIR,60","..,DIR,4096","list.lst,BIN,9772"

SOURce1:LIST:SELect "/var/volatile/list"
SOURce1:FREQuency:MODE LIST
OUTPut1:STATe 1

13.5.4  Remote control commands
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:MMEMory:CATalog?

Returns the content of a particular directory.

Return values: 
<Catalog> string

String parameter to specify the directory.
If you leave out the path, the command returns the contents of
the directory selected with :MMEMory:CDIRectory.
The path may be relative or absolute.

Usage: Query only

Manual operation: See "Directory, File List and Filename" on page 280

:MMEMory:CATalog:LENGth? [<Path>]

Returns the number of files in the current or in the specified directory.

Query parameters: 
<Path> string

String parameter to specify the directory. If the directory is omit-
ted, the command queries the content of the current directory,
queried with :MMEMory:CDIRectory command.

Return values: 
<FileCount> integer

Number of files.

Usage: Query only

:MMEMory:CDIRectory <Directory>

Changes the default directory for mass memory storage. The directory is used for all
subsequent MMEM commands if no path is specified with them.

Parameters:
<Directory> <directory_name>

String containing the path to another directory. The path can be
relative or absolute.
To change to a higher directory, use two dots '..' .

Manual operation: See "Directory, File List and Filename" on page 280
See "Directory and Filename" on page 285

:MMEMory:COPY <SourceFile>, <DestinationFile>

Copies an existing file to a new file. Instead of just a file, this command can also be
used to copy a complete directory together with all its files.
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Setting parameters: 
<SourceFile> string

String containing the path and file name of the source file

<DestinationFile> string
String containing the path and name of the target file. The path
can be relative or absolute.
If <DestinationFile> is not specified, the <SourceFile> is
copied to the current directory, queried with the :MMEMory:
CDIRectory command.
Note: Existing files with the same name in the destination direc-
tory are overwritten without an error message.

Usage: Setting only

Manual operation: See "Cut, Copy&Paste and Delete" on page 286

:MMEMory:DATA <Filename>, <BinaryData>
:MMEMory:DATA? <Filename>

The setting command writes the block data <BinaryBlock> to the file identified by
<Filename>.

Tip: Use this command to read/transfer stored instrument settings or waveforms
directly from/to the instrument.

Parameters:
<BinaryData>

Setting parameters: 
<Filename> string

String parameter to specify the name of the file.

Query parameters: 
<Filename> #<number><length_entry><data>

#: Hash sign; always comes first in the binary block
<number>: the first digit indicates how many digits the subse-
quent length entry has
<length_entry>: indicates the number of subsequent bytes
<data>: binary block data for the specified length.
For files with a size with more than nine digits (gigabytes), the
instrument allows the syntax #(<Length>), where <Length>
is the file size in decimal format.

Example: MMEMory:DATA '/var/user/test.txt',#15hallo
Writes the block data to the file test.txt.
The digit 1 indicates a length entry of one digit; the digit 5 indi-
cate a length of the binary data (hallo) in bytes.
MMEMory:DATA? '/var/user/test.txt'
Sends the data of the file test.txt from the instrument to the
controller in the form of a binary block.
Response: #15hallo
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:MMEMory:DATA:UNPRotected <Msus>, <Data>

The setting command sends the I/Q data and the marker data to the file defined with
the <Msus> parameter. The required tags are created automatically so that the file
content follows the waveform file format.

The query reads out the I/Q data part or the marker information of the specified file.

Waveform files can also be created with the command [:SOURce<hw>]:BB:
ARBitrary:WAVeform:DATA. In this case, the complete content of the waveform file
must be specified, i.e. not only the I/Q or marker data but all required tags.

(see Chapter 4.3.5, "Tags for waveforms, data and control lists", on page 94).

Parameters:
<Msus> <Identifier>:<file name>

Mass Storage Unit Specifier
A string that specifies whether I/Q data (NVWFM) or marker data
(NVMKR) is transferred and the file name the data is stored in.
If the file with the specified name does not exist, a file is created.
Any existing content in the file is overwritten.
Complete file path and file extension can also be specified. If
omitted, files are stored in the default directory and the exten-
sion *.wv is assigned to the file name.

Setting parameters: 
<Data> block data

I/Q data or marker binary data, where the number of marker ele-
ments has to be equal to the number of I/Q samples
Binary block data follows the syntax:
#<Digits><Length><I0Q0...IxQx...IN-1QN-1> or
#<Digits><Length><M0M1...Mx...MN-1>
#
Indicates the start of the data block
<Digits>
Decimal value
Gives the number of decimal digits used for the <Length>
value
<Length>
Decimal value
Number of bytes the follow in the <Binary data> part
I0Q0...IxQx…IN-1QN-1
Binary data in ASCII format
IxQx represents binary data (16-bit signed integer in 2's com-
plement notation) containing the I and Q component alternately
and starting with the I component. Each I and Q component con-
sists of 2 bytes in MSB format (most significant byte first).
The values of the 2 bytes in an I component and a Q component
are in the range: -32767 to +32767.
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M0M1…Mx…MN-1
Binary data in ASCII format
Mx represents one marker byte, where only the 4 least signifi-
cant bits are used. These 4 bits are assigned to the 4 possible
markers of the instrument, 1 bit per marker: Bit0 = Marker 1 to
Bit3 = Marker 4.
One 4-bit marker element is required for every I/Q sample.

Example: :MMEM:DATA:UNPR "NVWFM:/var/user/wave.wv",#220<I0Q0..IxQx>
// the binary data <I0Q0..IxQx> is added to a file named wave.wv 
// and saved in the selected directory
// <I0Q0..IxQx> contains of 20 bytes, i.e. 5 I/Q samples, 
// 2 bytes for each I and Q component
// <I0Q0..IxQx> is a placeholder; 
// the actual ASCII values are not printable

MMEMory:DATA:UNPRotected? "NVWFM:/var/user/wave.wv"
MMEMory:DATA:UNPRotected "NVMKR:/var/user/wave.wv",#15<M0M1…M5>
// the specified marker data is added to a file named wave.wv
// in the specified directory
// used are printable values; 
// used are only the 4 least significant bits of a byte
MMEMory:DATA:UNPRotected? "NVMKR:/var/user/wave.wv"
// note that, the query returns binary values
SOURce1:BB:ARBitrary:WAVeform:CLOCk "/var/user/wave.wv",1.1E6
SOURce1:BB:ARBitrary:WAVeform:CLOCk? "/var/user/wave.wv"

:MMEMory:DCATalog?

Returns the subdirectories of a particular directory.

Return values: 
<DCatalog> <file_entry>

Names of the subdirectories separated by colons. The first two
strings are related to the parent directory.

Usage: Query only

:MMEMory:DCATalog:LENGth? [<Path>]

Returns the number of subdirectories in the current or specified directory.

Query parameters: 
<Path> string

String parameter to specify the directory. If the directory is omit-
ted, the command queries the contents of the current directory,
to be queried with :MMEMory:CDIRectory command.
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Return values: 
<DirectoryCount> integer

Number of parent and subdirectories.

Usage: Query only

:MMEMory:DELete <Filename>

Removes a file from the specified directory.

Setting parameters: 
<Filename> string

String parameter to specify the name and directory of the file to
be removed.

Usage: Setting only

Manual operation: See "Cut, Copy&Paste and Delete" on page 286

:MMEMory:LOAD:STATe <SavRclStateNumb>, <file_name>

Loads the specified file stored under the specified name in an internal memory.

After the file has been loaded, the instrument setting must be activated using an *RCL
command.

Setting parameters: 
<SavRclStateNumb> Determines to the specific <number> to be used with the *RCL

command, e.g. *RCL 4.

<file_name> String parameter to specify the file name with extension
*.savrcltxt.

Usage: Setting only

Manual operation: See "Recall" on page 281

:MMEMory:MDIRectory <Directory>

Creates a subdirectory for mass memory storage in the specified directory. If no direc-
tory is specified, a subdirectory is created in the default directory. This command can
also be used to create a directory tree.

Setting parameters: 
<Directory> string

String parameter to specify the new directory.

Usage: Setting only

Manual operation: See "Create New Directory" on page 286
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:MMEMory:MOVE <SourceFile>, <DestinationFile>

Moves an existing file to a new location or, if no path is specified, renames an existing
file.

Setting parameters: 
<SourceFile> string

String parameter to specify the name of the file to be moved.

<DestinationFile> string
String parameters to specify the name of the new file.

Usage: Setting only

Manual operation: See "Rename" on page 286

:MMEMory:MSIS <Path>

Defines the drive or network resource (in the case of networks) for instruments with
windows operating system, using msis (MSIS = Mass Storage Identification String).

Note: Instruments with Linux operating system ignore this command, since Linux does
not use drive letter assignment.

:MMEMory:RDIRectory <Directory>

Removes an empty directory from the mass memory storage system. If no directory is
specified, the subdirectory with the specified name is deleted in the default directory.

To remove a directory with contents, use command :MMEMory:RDIRectory:
RECursive on page 422.

Setting parameters: 
<Directory> string

String parameter to specify the directory to be deleted.

Usage: Setting only

:MMEMory:RDIRectory:RECursive <Directory>

Removes the specified directory, including files and subdirectories from the mass
memory storage system. If no directory is specified, the command removes the subdir-
ectories of the default directory.

The command the entire directory without further prompt or notification.

Setting parameters: 
<Directory> string

String parameter to specify the directory to be deleted.

Usage: Setting only
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:MMEMory:STORe:STATe <savrcl_state_nr>, <file_name>

Stores the current instrument setting in the specified file.

The instrument setting must first be stored in an internal memory with the same num-
ber using the common command *SAV.

Setting parameters: 
<savrcl_state_nr> Corresponds to the specific <number> defined with the *SAV

command, e.g. *SAV 4.

<file_name> String parameter to specify the file name with extension
*.savrcltxt.

Usage: Event

Manual operation: See "Save" on page 280

:MEMory:HFRee?

Returns the used and available memory in Kb.

Return values: 
<TotalPhysMemKb> integer

Total physical memory.

<ApplicMemKb> integer
Application memory.

<HeapUsedKb> integer
Used heap memory.

<HeapAvailableKb> integer
Available heap memory.

Usage: Query only

13.6  CALibration subsystem

The CALibration subsystem contains the commands needed for performing internal
adjustments. This procedure is triggered by the query commands.

Common suffixes

The following common suffixes are used in the remote commands:

Suffix Value range Description

CALibration<hw> [1] Optional suffix
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Understanding the query response

● 1: error-free execution of the adjustments
● 0: indicates that an error occurred; the process has been canceled

:CALibration:ALL[:MEASure]?......................................................................................... 424
:CALibration<hw>:ALL:DATE?.........................................................................................424
:CALibration<hw>:ALL:INFormation?............................................................................... 424
:CALibration<hw>:ALL:TEMP?........................................................................................ 425
:CALibration<hw>:ALL:TIME?......................................................................................... 425
:CALibration<hw>:CONTinueonerror................................................................................425
:CALibration:DATA:EXPort.............................................................................................. 426
:CALibration:DATA:FACTory:DATE?.................................................................................426
:CALibration:DELay:MINutes...........................................................................................426
:CALibration:DELay:SHUTdown[:STATe].......................................................................... 426
:CALibration:DELay[:MEASure]?..................................................................................... 427
:CALibration:ROSCillator[:DATA]......................................................................................427

:CALibration:ALL[:MEASure]? [<Force>]

Starts all internal adjustments that do not need external measuring equipment.

Query parameters: 
<Force> string

Return values: 
<Measure> 1 | ON | 0 | OFF

Usage: Query only

Manual operation: See "Adjust All" on page 637

:CALibration<hw>:ALL:DATE?

Queries the date of the most recently executed full adjustment.

Suffix: 
<hw>

.
[1]
Optional suffix

Return values: 
<Date> string

Example: CAL:ALL:DATE?
// "2016-01-01"

Usage: Query only

Manual operation: See "Last Full Adjustment" on page 638

:CALibration<hw>:ALL:INFormation?

Queries the current state of the internal adjustment.
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Return values: 
<CalInfoText> string

Example: CAL:ALL:INF?
"Instrument is calibrated, no adjustment required."
"UNCAL, instrument is warming up."
"UNCAL, Please perform full adjustment after warming up."
"UNCAL, Please perform full adjustment."

Usage: Query only

Manual operation: See "Information" on page 638

:CALibration<hw>:ALL:TEMP?

Queries the temperature deviation compared to the calibration temperature.

Suffix: 
<hw>

.
[1]
Optional suffix

Return values: 
<Temperature> string

Example: CALibration:ALL:TEMP?
// "+12.00 K"

Usage: Query only

Manual operation: See "Temperature Offset" on page 638

:CALibration<hw>:ALL:TIME?

Queries the time elapsed since the last full adjustment.

Return values: 
<Time> string

Example: CAL:ALL:TIME?
// "22 days"

Usage: Query only

Manual operation: See "Time" on page 638

:CALibration<hw>:CONTinueonerror <State>

Continues the calibration even though an error was detected. By default adjustments
are aborted on error.

Suffix: 
<hw>

.
[1]
Optional suffix
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Parameters:
<State> 1 | ON | 0 | OFF

*RST: n.a. (factory preset: 0)

Example: CAL:CONT ON
// Continues calibration after an error

Manual operation: See "Continue Adjustment on Error" on page 638

:CALibration:DATA:EXPort

Collects the internal adjustment data and provides the data for export in a zip file. You
can export the data for service and evaluation purposes.

Example: :CALibration:DATA:EXPort

Usage: Event

:CALibration:DATA:FACTory:DATE?

Queries the date of the last factory calibration.

Return values: 
<Date> string

Example: CAL:DATA:FACT:DATE? 
// "2016-01-01"

Usage: Query only

Manual operation: See "Last Factory Calibration" on page 623

:CALibration:DELay:MINutes <Minutes>

Sets the warm-up time to wait before internal adjustment starts automatically.

Automatic execution starts only, if you have enabled the calibration with command :
CALibration:DELay[:MEASure]? ON.

Parameters:
<Minutes> integer

Range: 30  to  120
*RST: n.a. (no preset. default: 60)

Example: :CALibration:DELay:MINutes 30
// sets the time delay for warm-up of the instrument.

Manual operation: See "Warm Up Time" on page 638

:CALibration:DELay:SHUTdown[:STATe] <Shutdown>

Enables the instrument to shut down automatically after calibration.
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Parameters:
<Shutdown> 1 | ON | 0 | OFF

*RST: 0

Example: :CALibration:DELay:SHUTdown[:STATe] ON|1
// inititates that the instrument shuts down when the adjustments are completed.

Manual operation: See "Shutdown After Adjustment" on page 639

:CALibration:DELay[:MEASure]?

Starts the delayed adjustment process. When the warm-up time has elapsed (see :
CALibration:DELay:MINutes, it executes the internal adjustments.

If you have enabled automatic shutdown, :CALibration:DELay:SHUTdown[:
STATe] ON, the instrument shuts down when the adjustments are completed.

Return values: 
<Error> 1 | ON | 0 | OFF

*RST: n.a. (no preset. default: 0)

Example: :CALibration:DELay[:MEASure] ON|1
// enables the adjustment processs to start after the warm-up time automatically

Usage: Query only

Manual operation: See "Adjust All Delayed" on page 638

:CALibration:ROSCillator[:DATA] <Data>

Sets a user-defined calibration value for the internal reference frequency.

Parameters:
<Data> integer

0 = the factory value is used (i.e. user-defined calibration is dis-
abled)
Value > 0: positive calibration values are used
Value < 0: negative calibration values are used
Range: depends on other values
*RST: 0

Example: See [:SOURce]:ROSCillator[:INTernal]:ADJust[:
STATe] on page 504.

13.7  DIAGnostic subsystem

The DIAGnostic subsystem contains the commands used for instrument diagnosis
and servicing. SCPI does not define any DIAGnostic commands; the commands lis-
ted here are all device-specific. All DIAGnostic commands are query commands
which are not affected by *RST.
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The test functions are intended for services purposes.
They are thus password-protected functions. Unlock the corresponding protection level
to access them, see :SYSTem:PROTect<ch>[:STATe].
For more information, see R&S SFI100A Service Manual.

Common suffixes

The following common suffixes are used in remote commands:

Suffix Value range Description

DIAGnostic<hw> [1] Optional suffix

Example: Programming example
The example lists the commands required to query assemblies and test points for diag-
nosis purposes.
// Query the operating hours and number of power-on so far.
DIAGnostic:INFO:OTIMe?
// 112 h
DIAGnostic:INFO:POCount? 
// 14

Commands

:DIAGnostic<hw>:BGINfo:CATalog?.................................................................................428
:DIAGnostic<hw>:BGINfo?..............................................................................................428
:DIAGnostic:INFO:OTIMe?..............................................................................................429
:DIAGnostic:INFO:POCount?.......................................................................................... 429
:DIAGnostic<hw>:POINt:CATalog?...................................................................................430
:DIAGnostic<hw>[:MEASure]:POINt?...............................................................................430

:DIAGnostic<hw>:BGINfo:CATalog?

Queries the names of the assemblies available in the instrument.

Return values: 
<Catalog> string

List of all assemblies; the values are separated by commas
The length of the list is variable and depends on the instrument
equipment configuration.

Example: See Example "Programming example" on page 428.

Usage: Query only

:DIAGnostic<hw>:BGINfo? [<Board>]

Queries information on the modules available in the instrument, using the variant and
revision state.
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Query parameters: 
<Board> string

Module name, as queried with the command :
DIAGnostic<hw>:BGINfo:CATalog?.
To retrieve a complete list of all modules, omit the parameter.
The length of the list is variable and depends on the instrument
equipment configuration.

Return values: 
<BgInfo> <Module name> <Module stock number incl. variant> <Module

revision> <Module serial number>
List of comma-separated entries, one entry per module.
Each entry for one module consists of four parts that are separa-
ted by space characters.

Example: See Example "Programming example" on page 428.

Usage: Query only

Manual operation: See "Assembly" on page 622

:DIAGnostic:INFO:OTIMe?

Queries the operating hours of the instrument so far.

Return values: 
<OperationTime> integer

Range: 0  to  INT_MAX
*RST: 0

Example: See Example "Programming example" on page 428.

Usage: Query only

Manual operation: See "Operation Time / h" on page 622

:DIAGnostic:INFO:POCount?

Queris how often the instrument has been turned on so far.

Return values: 
<PowerOnCount> integer

Range: 0  to  INT_MAX
*RST: 0

Example: See Example "Programming example" on page 428.

Usage: Query only

Manual operation: See "Power On Count" on page 623
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:DIAGnostic<hw>:POINt:CATalog?

Queries the test points available in the instrument.

For more information, see R&S SFI100A Service Manual.

Return values: 
<Catalog> string

List of comma-separated values, each representing a test point

Example: See Example "Programming example" on page 428.

Usage: Query only

:DIAGnostic<hw>[:MEASure]:POINt? <Name>

Triggers the voltage measurement at the specified test point and returns the measured
voltage.

For more information, see R&S SFI100A Service Manual.

Query parameters: 
<Name> <test point identifier>

Test point name, as queried with the command :
DIAGnostic<hw>:POINt:CATalog?

Return values: 
<Value> <value><unit>

Example: See Example "Programming example" on page 428.

Usage: Query only

13.8  DISPlay subsystem

The DISPlay system contains the commands to set the power-save mode of the
instrument.

Programming Examples

Example: Activating screen saver mode and display update
Use the following commands to switch on the screen saver of your instrument or to
automatic display. These settings are particularly useful when you control the instru-
ment remotely.

// Set the wait time interval and activate the screen saver
DISPlay:PSAVe:HOLDoff 10
DISPlay:PSAVe:STATe ON

// Disable the display of the current frequency and level values in remote control
DISPlay:ANNotation:ALL ON
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// DISPlay:ANNotation:FREQuency "<password>", ON
// DISPlay:ANNotation:AMPLitude "<password>", ON

// Enable automatic update of the display at defined time intervals
DISPlay:UPDate[:STATe] ON

Example: Querying the dialog IDs, opening and closing dialogs
Use the following commands to query the dialog IDs of all currently open dialogs. The
dialog ID is a prerequisite for opening and closing dialogs via the remote control.

The dialog ID is also required to define user key actions.
See Chapter 11.2.4, "How to assign actions to the [★] key", on page 309.

// Query the dialog IDs of all open dialogs
DISPlay:DIALog:ID?
// CEUtraDLGenSetDlg,_,$A DlgKeyRf_Rosc

// Open and close dialogs via remote control
DISPlay:DIALog:OPEN "CEUtraDLGenSetDlg,_,$A"
DISPlay:DIALog:OPEN "DlgKeyRf_Rosc"
DISPlay:DIALog:CLOSe "DlgKeyRf_Rosc"
DISPlay:DIALog:CLOSe:ALL 

:DISPlay:PSAVe:HOLDoff............................................................................................... 431
:DISPlay:PSAVe[:STATe].................................................................................................432
:DISPlay:BRIGhtness..................................................................................................... 432
:DISPlay:BUTTon:BRIGhtness.........................................................................................432
:DISPlay:UPDate[:STATe]............................................................................................... 432
:DISPlay:ANNotation:AMPLitude..................................................................................... 433
:DISPlay:ANNotation:FREQuency....................................................................................433
:DISPlay:ANNotation[:ALL]..............................................................................................433
:DISPlay:DIALog:ID?......................................................................................................434
:DISPlay:DIALog:OPEN..................................................................................................434
:DISPlay:DIALog:CLOSe................................................................................................ 435
:DISPlay:DIALog:CLOSe:ALL..........................................................................................435

:DISPlay:PSAVe:HOLDoff <HoldoffTimeMin>

Sets the wait time for the screen saver mode of the display.

Parameters:
<HoldoffTimeMin> integer

Range: 1  to  60
*RST: n.a. (factory preset: 10)
Default unit: minute

Example: see Example "Activating screen saver mode and display update"
on page 430

Manual operation: See "Wait Time" on page 301
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:DISPlay:PSAVe[:STATe] <State>

Activates the screen saver mode of the display.

We recommend that you use this mode to protect the display, if you operate the instru-
ment in remote control.

To define the wait time, use the command :DISPlay:PSAVe:HOLDoff.

Parameters:
<State> 1 | ON | 0 | OFF

*RST: n.a. (factory preset: 0)

Example: See Example "Activating screen saver mode and display
update" on page 430

Manual operation: See "Screen Saver" on page 301

:DISPlay:BRIGhtness <BRIGhtness>

Sets the brightness of the dispaly.

Parameters:
<BRIGhtness> float

Range: 1.0  to  20.0
Increment: 1.0
*RST: 14.0

Example: DISPlay:BRIGhtness 14

Manual operation: See "Display" on page 301

:DISPlay:BUTTon:BRIGhtness <ButtonBrightnes>

Sets the brightness of the [RF On/Off] key.

Parameters:
<ButtonBrightnes> integer

Range: 1  to  20
*RST: n.a. (no preset. default: 14)

Example: DISPlay:BUTTon:BRIGhtness 15

Manual operation: See "RF Hardkey" on page 301

:DISPlay:UPDate[:STATe] <Update>

Activates the refresh mode of the display.

Parameters:
<Update> 1 | ON | 0 | OFF

*RST: n.a. (factory preset: 1)
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Example: See Example "Activating screen saver mode and display
update" on page 430

Manual operation: See "Display Update is" on page 302

:DISPlay:ANNotation:AMPLitude <SecPassword>, <State>

Indicates asterisks instead of the level values in the status bar.

Parameters:
<SecPassword> string

<State> 1 | ON | 0 | OFF
*RST: n.a. (factory preset: 1)

Example: See Example "Activating screen saver mode and display
update" on page 430

Manual operation: See "Annotation Amplitude" on page 324

:DISPlay:ANNotation:FREQuency <SecPassWord>, <State>

Indicates asterisks instead of the frequency values in the status bar.

Parameters:
<SecPassWord> string

<State> 1 | ON | 0 | OFF
*RST: n.a. (factory preset: 1)

Example: See Example "Activating screen saver mode and display
update" on page 430

Manual operation: See "Annotation Frequency" on page 324

:DISPlay:ANNotation[:ALL] <State>

Displays asterisks instead of the level and frequency values in the status bar of the
instrument.

We recommend that you use this mode if you operate the instrument in remote control.

Parameters:
<State> 1 | ON | 0 | OFF

*RST: 1

Example: See Example "Activating screen saver mode and display
update" on page 430
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:DISPlay:DIALog:ID?

Returns the dialog identifiers of the open dialogs in a string separated by blanks.

Return values: 
<DialogIdList> <DialogID#1>< ><DialogID#2>< > ... < ><DialogID#n>

Dialog identifiers are string without blanks. Blanks are represen-
ted as $$.
Dialog identifiers <DialogID> are composed of two main parts:
<DialogName>[<OptionalParts>]
<DialogName>
Meaningful information, mandatory input parameter for the com-
mands:
:DISPlay:DIALog:OPEN on page 434
:DISPlay:DIALog:CLOSe on page 435
<Optional parts>
String of $<X> values, where <X> is a character, interpreted as
follows:
$q<DialogQualifier>: optional dialog qualifier, usually the
letter A or B, as displayed in the dialog title.
$i<Instances>: comma-separated list of instance indexes,
given in the order h,c,s,d,g,u,0. Default is zero; the termi-
nating ",0" can be omitted.
$t<TabIds>: comma-separated indexes or tab names;
required, if a dialog is composed of several tabs.
$x<Left>$y<Top>$h<Left>$w<Top>: position and size;
superfluous information.

Example: See Example "Querying the dialog IDs, opening and closing dia-
logs" on page 431

Usage: Query only

Manual operation: See "SCPI" on page 308

:DISPlay:DIALog:OPEN <DialogId>

Opens the specified dialog.

Setting parameters: 
<DialogId> string

To find out the dialog identifier, use the query :DISPlay:
DIALog:ID?.
The <DialogName> part of the query result is mandatory.

Example: See Example "Querying the dialog IDs, opening and closing dia-
logs" on page 431

Usage: Setting only

Manual operation: See "SCPI" on page 308
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:DISPlay:DIALog:CLOSe <DialogId>

Closes the specified dialog.

Setting parameters: 
<DialogId> string

To find out the dialog identifier, use the query :DISPlay:
DIALog:ID?.
The <DialogName> part of the query result is sufficient.

Example: See Example "Querying the dialog IDs, opening and closing dia-
logs" on page 431

Usage: Setting only

:DISPlay:DIALog:CLOSe:ALL

Closes all open dialogs.

Example: See Example "Querying the dialog IDs, opening and closing dia-
logs" on page 431

Usage: Event

13.9  FORMat subsystem

The commands in the FORMat subsystem determine the format of data returned by the
R&S SFI100A to the controller. This affects all query commands that return a list of
numerical data or block data, noted in the descriptions of the commands. The set data
format applies to both paths.

:FORMat:BORDer..........................................................................................................435
:FORMat:SREGister.......................................................................................................436
:FORMat[:DATA]............................................................................................................ 436

:FORMat:BORDer <Border>

Determines the sequence of bytes within a binary block. This only affects blocks which
use the IEEE754 format internally.

Parameters:
<Border> NORMal | SWAPped

NORMal
Expects/sends the least significant byte of each IEEE754 float-
ing-point number first and the most significant byte last.
SWAPped
Expects/sends the most significant byte of each IEEE754 float-
ing-point number first and the least significant byte last.
*RST: NORMal
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Example: :FORM:BORD SWAP
transfers the data with the most significant bit first.

:FORMat:SREGister <Format>

Determines the numeric format for responses of the status register.

Parameters:
<Format> ASCii | BINary | HEXadecimal | OCTal

ASCii
Returns the register content as a decimal number.
BINary|HEXadecimal|OCTal
Returns the register content either as a binary, hexadecimal or
octal number. According to the selected format, the number
starts with #B (binary), #H (hexadecimal) or #O (octal).
*RST: ASCii

Example: :FORM:SREG HEX
returns the register content as a hexadecimal number.

:FORMat[:DATA] <Data>

Determines the data format the instrument uses to return data via the IEC/IEEE bus.

The instrument automatically detects the data format used by the controller, and
assigns it accordingly. Data format determined by this SCPI command is in this case
irrelevant.

Parameters:
<Data> ASCii | PACKed

ASCii
Transfers numerical data as plain text separated by commas.
PACKed
Transfers numerical data as binary block data.
The format within the binary data depends on the command.
The various binary data formats are explained in the description
of the parameter types.
*RST: ASCii

Example: :FORM ASC
transfers the data as ASCII data.

13.10  HCOPy subsystem

The HCOPy subsystem contains the commands to generate and save a hard copy of
the display.
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To access a stored hard copy file, use the commands of the MEMM subsystem.

Example: Store a hard copy of the display
The following example lists commands to configure and execute a hard copy to an
automatic named file.

:HCOPy:DEVice:LANGuage PNG
:HCOPy:FILE:NAME:AUTO:STATe 1
// defines the output format
// sets the instrument to automatically create output file names

// ******************************************************************
// Configure hard copy options, set automatic naming rules
// An automatically generated file name consists of:
// <Prefix><YYYY><MM><DD><Number>.<Format>
// ******************************************************************
:HCOPy:DEVice:LANGuage BMP
// defines output format *.bmp
:HCOPy:REGion DIALog    
// selects the region to be copied
:HCOPy:FILE:AUTO:DIR "/usb/HCopy" 
// sets destination directory of automatic named file
:HCOPy:FILE:NAME:AUTO:FILE:PREFix:STATe 1
:HCOPy:FILE:NAME:AUTO:FILE:PREFix:"hardcopy"
:HCOPy:FILE:NAME:AUTO:FILE:YEAR:STATe 1
:HCOPy:FILE:NAME:AUTO:FILE:MONTh:STATe 1
// uses automatic naming prefix
// sets automatic naming prefix to "hardcopy"
// uses automatic naming date parameters year and month

// ******************************************************************
// Execute and transfer the hard copy
// ******************************************************************
:HCOPy:EXECute
:HCOPy:DATA 
// generates a hard copy
// transfers the hard copy to the remote client
:HCOPy:FILE:AUTO:FILE? 
// queries the automatic file name
// "hardcopy1607001.bmp"  
:HCOPy:FILE:AUTO:NUMBer? 
// queries the number in the automatic file name
// "001"  
:HCOPy:FILE:AUTO? 
// queries the path and file name of the automatically generated file
// "/usb/HCopy/hardcopy1607001.bmp"  
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13.10.1  Hard copy settings

With the following commands, you can configure the settings of a hard copy.

:HCOPy:DATA?..............................................................................................................438
:HCOPy:IMAGe:FORMat................................................................................................ 438
:HCOPy:DEVice:LANGuage............................................................................................438
:HCOPy:REGion............................................................................................................ 438
:HCOPy:FILE[:NAME].....................................................................................................438
:HCOPy[:EXECute]........................................................................................................ 439

:HCOPy:DATA?

Transfers the hard copy data directly as a NByte stream to the remote client.

Return values: 
<Data> block data

Example: See Example "Store a hard copy of the display" on page 437

Usage: Query only

:HCOPy:IMAGe:FORMat <Format>
:HCOPy:DEVice:LANGuage <Language>
Selects the graphic format for the hard copy. You can use both commands alterna-
tively.

Parameters:
<Language> BMP | JPG | XPM | PNG

*RST: PNG

Example: See Example "Store a hard copy of the display" on page 437

Manual operation: See "Format" on page 296

:HCOPy:REGion <Region>

Selects the area to be copied.

You can create a snapshot of the screen or an active dialog.

Parameters:
<Region> ALL | DIALog

*RST: ALL

Example: See Example "Store a hard copy of the display" on page 437

Manual operation: See "Region" on page 297

:HCOPy:FILE[:NAME] <Name>

Determines the file name and path to save the hard copy, provided automatic naming
is disabled.
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Note: If you have enabled automatic naming, the instrument automatically generates
the file name and directory, see Chapter 13.10.2, "Automatic naming", on page 439.

Parameters:
<Name> string

Example: See Example "Store a hard copy of the display" on page 437

Manual operation: See "File..." on page 296

:HCOPy[:EXECute]

Generates a hard copy of the current display. The output destination is a file.

Example: See Example "Store a hard copy of the display" on page 437

Usage: Event

Manual operation: See "Save" on page 296

13.10.2  Automatic naming

Use the following commands to automatically assign a file name.

:HCOPy:FILE[:NAME]:AUTO?.........................................................................................439
:HCOPy:FILE[:NAME]:AUTO:DIRectory........................................................................... 439
:HCOPy:FILE[:NAME]:AUTO:DIRectory:CLEar................................................................. 440
:HCOPy:FILE[:NAME]:AUTO:FILE?................................................................................. 440
:HCOPy:FILE[:NAME]:AUTO:STATe.................................................................................440
:HCOPy:FILE[:NAME]:AUTO[:FILE]:DAY:STATe................................................................441
:HCOPy:FILE[:NAME]:AUTO[:FILE]:MONTh:STATe...........................................................441
:HCOPy:FILE[:NAME]:AUTO[:FILE]:YEAR:STATe............................................................. 441
:HCOPy:FILE[:NAME]:AUTO[:FILE]:NUMBer?.................................................................. 441
:HCOPy:FILE[:NAME]:AUTO[:FILE]:PREFix..................................................................... 441
:HCOPy:FILE[:NAME]:AUTO[:FILE]:PREFix:STATe........................................................... 441

:HCOPy:FILE[:NAME]:AUTO?

Queries path and file name of the hardcopy file, if you have enabled Automatic Nam-
ing.

Return values: 
<Auto> string

Example: See Example "Store a hard copy of the display" on page 437

Usage: Query only

:HCOPy:FILE[:NAME]:AUTO:DIRectory <Directory>

Determines the path to save the hard copy, if you have enabled Automatic Naming.
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If the directory does not yet exist, the instrument automatically creates a new directory,
using the instrument name and /var/user/ by default.

Parameters:
<Directory> string

*RST: /var/user/

Example: See Example "Store a hard copy of the display" on page 437

Manual operation: See "Path..." on page 297

:HCOPy:FILE[:NAME]:AUTO:DIRectory:CLEar

Deletes all files with extensions *.bmp, *.jpg, *.png and *.xpm in the directory set
for automatic naming.

Example: See Example "Store a hard copy of the display" on page 437

Usage: Event

Manual operation: See "Clear Path" on page 298

:HCOPy:FILE[:NAME]:AUTO:FILE?

Queries the name of the automatically named hard copy file.

An automatically generated file name consists of:

<Prefix><YYYY><MM><DD><Number>.<Format>.

You can activate each component separately, to individually design the file name.

Return values: 
<File> string

Example: See Example "Store a hard copy of the display" on page 437.

Usage: Query only

:HCOPy:FILE[:NAME]:AUTO:STATe <State>

Activates automatic naming of the hard copy files.

Parameters:
<State> 1 | ON | 0 | OFF

*RST: 1

Example: See Example "Store a hard copy of the display" on page 437

Manual operation: See "Automatic Naming" on page 296
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:HCOPy:FILE[:NAME]:AUTO[:FILE]:DAY:STATe <State>
:HCOPy:FILE[:NAME]:AUTO[:FILE]:MONTh:STATe <State>
:HCOPy:FILE[:NAME]:AUTO[:FILE]:YEAR:STATe <State>
Uses the date parameters (year, month or day) for the automatic naming. You can acti-
vate each of the date parameters separately.

Parameters:
<State> 1 | ON | 0 | OFF

*RST: 1

Example: See Example "Store a hard copy of the display" on page 437

Manual operation: See "Prefix, Year, Month, Day" on page 298

:HCOPy:FILE[:NAME]:AUTO[:FILE]:NUMBer?

Queries the number that is used as part of the file name for the next hard copy in auto-
matic mode.

At the beginning, the count starts at 0. The R&S SFI100A searches the specified out-
put directory for the highest number in the stored files. It increases this number by one
to achieve a unique name for the new file.

The resulting auto number is appended to the resulting file name with at least three
digits.

Return values: 
<Number> integer

Range: 0  to  999999
*RST: 0

Example: See Example "Store a hard copy of the display" on page 437

Usage: Query only

Manual operation: See "Current Auto Number" on page 298

:HCOPy:FILE[:NAME]:AUTO[:FILE]:PREFix <Prefix>
:HCOPy:FILE[:NAME]:AUTO[:FILE]:PREFix:STATe <State>
Uses the prefix for the automatic generation of the file name, provided PREF:STAT is
activated.

Parameters:
<State> 1 | ON | 0 | OFF

*RST: 1

Example: See Example "Store a hard copy of the display" on page 437

Manual operation: See "Prefix, Year, Month, Day" on page 298
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13.11  KBOard subsystem

The KBOard subsystem contains the commands to set a connected keyboard.

:FPANel:KEYBoard:LAYout............................................................................................. 442
:KBOard:LAYout.............................................................................................................442

:FPANel:KEYBoard:LAYout <Layout>

Selects the layout of the front panel keypad.

Parameters:
<Layout> DIGits | LETTers

DIGits
Enables numerical keys only.
LETTers
Enables numerical and alphanumerical keys.
*RST: n.a. (factory preset: DIGits)

Example: :FPANel:KEYBoard:LAYout LETTers
// enables the alphanumerical additional
// and the numerical assignment of the keys.

:KBOard:LAYout <Layout>

Selects the language for an external keyboard and assigns the keys acccordingly.

Parameters:
<Layout> CHINese | DANish | DUTCh | DUTBe | ENGLish | ENGUK |

FINNish | FRENch | FREBe | FRECa | GERMan | ITALian |
JAPanese | KORean | NORWegian | PORTuguese | RUSSian |
SPANish | SWEDish | ENGUS
*RST: n.a. (factory preset: ENGLish)

Example: :KBOard:LAYout US
// activates American keyboard

Manual operation: See "Layout" on page 301

13.12  OUTPut subsystem

In the OUTPut subsystem, you can configure the output signals.

Common suffixes

The following common suffixes are used in remote commands:
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Suffix Value range Description

OUTPut<hw> [1] Optional suffix

:OUTPut:ALL[:STATe]..................................................................................................... 443
:OUTPut<hw>[:STATe]....................................................................................................443
:OUTPut<hw>[:STATe]:PON............................................................................................443
:OUTPut<hw>:IMPedance?.............................................................................................444
:OUTPut<hw>:AFIXed:RANGe:LOWer?........................................................................... 444
:OUTPut<hw>:AFIXed:RANGe:UPPer?............................................................................444
:OUTPut<hw>:PROTection:CLEar................................................................................... 444
:OUTPut<hw>:PROTection:TRIPped?.............................................................................. 444

:OUTPut:ALL[:STATe] <State>

Enables the RF output signal of the instrument.

Parameters:
<State> 1 | ON | 0 | OFF

*RST: n.a. (factory preset: 0)

Example: OUTPut:ALL:STATe 0
Disables the RF output signal.

:OUTPut<hw>[:STATe] <State>

Activates the RF output signal.

Parameters:
<State> 1 | ON | 0 | OFF

*RST: 0

Example: :OUTPut1 ON
Activates the RF output.

Manual operation: See "RF State/RF ON" on page 200

:OUTPut<hw>[:STATe]:PON <Pon>

Defines the state of the RF output signal when the instrument is switched on.

Parameters:
<Pon> OFF | UNCHanged

*RST: n.a. (factory preset: UNCHanged)

Example: :OUTPut1:PON OFF
The RF output is deactivated when the instrument is switched
on.

Manual operation: See "Power-On State" on page 302
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:OUTPut<hw>:IMPedance?

Queries the impedance of the RF outputs.

Return values: 
<Impedance> G1K | G50 | G10K

*RST: G50

Example: :OUTPut1:IMP?
queries the impedance of RF output.
Response: 50
the impedance is 50 ohms

Usage: Query only

Manual operation: See "RF output impedance" on page 200

:OUTPut<hw>:AFIXed:RANGe:LOWer?
:OUTPut<hw>:AFIXed:RANGe:UPPer?
Queries the settable minimum/maximum value in mode :OUTPut:AMODe FIXed, i.e.
when the attenuator is not being adjusted.

Return values: 
<Upper> float

Increment: 0.01
Default unit: dBm

Example: :OUTPut1:AMODe FIXed
:OUTPut1:AFIXed:RANGe:UPPer?
// -27
:OUTPut1:AFIXed:RANGe:LOW?
// -50

Usage: Query only

:OUTPut<hw>:PROTection:CLEar

Resets the protective circuit after it has been tripped.

To define the output state, use the command :OUTPut<hw>[:STATe].

Example: :OUTPut1:PROT:CLE
Resets the protective circuit of the RF output.

Usage: Event

:OUTPut<hw>:PROTection:TRIPped?

Queries the state of the protective circuit.
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Return values: 
<Tripped> 1 | ON | 0 | OFF

*RST: 0

Example: :OUTPut1:PROT:TRIP
queries the state of the protective circuit of the RF output.
Response: 0
the protective circuit has not tripped.

Usage: Query only

13.13  SENSe, READ, INITiate and SLISt subsystems

These subsystems contain the commands for configuring the power measurements
with R&S NRP power sensor connected to the R&S SFI100A.

The local state is set with the INIT command. Switching off the local state enhances
the measurement performance. Measurements results can be retrieved in local state
on or off.
Sensor parameters are set with the SENSe commands.
To start the measurement and retrieve the result, use the :READ<ch>[:POWer]?
command.

Suffix Value range Description

SENSe<ch> [1] to 4 Indicates the sensor

Use the :SLISt commands to change the sensor mapping

READ<ch> [1] to 4 Sensor assignment

INIate<hw> [1] to 4 Sensor assignment

ELEMent<ch> [1] to 25 Sensor-mapping list
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Programming examples

Example: Detecting and assigning a power sensor
SLISt:LIST?
// Response: "NRP33SN-V-900007-USB Legacy","NRP-Z211-900001-USB Legacy"
// Lists all automatically detected sensors.

SLISt:SCAN:STATe 1
// Searches for sensors connected in the LAN or via the USBTMC protocol.

SLISt:SCAN:LSENsor 'NRQ6',101624 // sensor name, serial number
SLISt:SCAN:LSENsor 11.123.1.123, 101624 // IP address, serial number
// Adds sensors to the list, that are connected to LAN.

SLISt:SCAN:USENsor 'NRQ6',101624 //sensor name, serial number
SLISt:SCAN:USENsor #H15b,101624  //device ID (hexadecimal), serial number
SLISt:SCAN:USENsor 347,101624    //device ID (decimal), serial number
// Adds a sensor to the list, that is connected to the USB interface.

SLISt:LIST?
// Response: "NRP33SN-V-900007-USB Legacy","NRP-Z211-900001-USB Legacy",
// "NRP33SN-V-900005-USBTMC","NRP33SN-V-900011-LAN"
// Lists all automatically detected sensors.

SLISt:ELEMent3:MAPPing SENS1
// Maps the third sensor from the list to the first sensor channel.

SLISt:SENSor:MAP "NRPS18S-100654-USB Legacy", SENS3
// Maps the sensor to channel 3.

SLISt:CLEar[ALL]
// Remove all sensors from the list.
SLISt:CLEar:LAN 
// Remove all sensors from the list, that are connected over LAN.
SLISt:CLEar:USB 
// Remove all sensors from the list, that are connected over USB.

Example: Performing a simple power measurement
Prerequisite: The sensor is connected to the instrument and mapped to the first sensor
channel.
INITiate1:CONTinuous ON
// Switches the continous power measurement on.

READ1?
// Triggers the measurement and displays the results.
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Example: Performing a power measurement with a fixed filter
Prerequisite: The sensor is connected to the instrument and mapped to the first sensor
channel.
SENSe1:SOURce RF 
// Sensor measures the power of the RF signal.

SENSe1:FILTer:TYPE NSRatio
// Selects fixed noise filter mode.

SENSe1:FILTer:NSRatio 0.02 DB
// Sets the maximum noise component in the result to 0.02 DB.

SENSe1:FILTer:NSRatio:MTIMe 10
//Limits the settling time to 10 seconds.

SENSe1:APERture:DEFault:STATe 0
// Deactivates the default aperture time of the sensor.

SENSe1:APERture:TIMe 10e-6
// Sets the aperture time to 10 us.

SENSe1:UNIT DBM
// Selects unit dBm for the measured value.

INITiate:CONTinuous ON
// Switches the continous power measurement on.

READ?
// Triggers the measurement and displays the results.

:SLISt[:LIST]?................................................................................................................ 448
:SLISt:SCAN[:STATe]......................................................................................................448
:SLISt:SCAN:LSENsor....................................................................................................448
:SLISt:SCAN:USENsor................................................................................................... 449
:SLISt:CLEar:LAN.......................................................................................................... 449
:SLISt:CLEar:USB..........................................................................................................449
:SLISt:CLEar[:ALL].........................................................................................................450
:SLISt:ELEMent<ch>:MAPPing........................................................................................450
:SLISt:SENSor:MAP.......................................................................................................450
:INITiate<hw>[:POWer]:CONTinuous............................................................................... 450
:READ<ch>[:POWer]?.................................................................................................... 451
:SENSe<ch>:UNIT[:POWer]............................................................................................452
:SENSe<ch>[:POWer]:APERture:DEFault:STATe.............................................................. 452
:SENSe<ch>[:POWer]:APERture:TIMe.............................................................................452
:SENSe<ch>[:POWer]:CORRection:SPDevice:SELect.......................................................453
:SENSe<ch>[:POWer]:CORRection:SPDevice:STATe........................................................453
:SENSe<ch>[:POWer]:CORRection:SPDevice:LIST?.........................................................453
:SENSe<ch>[:POWer]:DISPlay:PERManent:PRIority.........................................................453
:SENSe<ch>[:POWer]:DISPlay:PERManent:STATe........................................................... 454
:SENSe<ch>[:POWer]:FILTer:LENGth:AUTO?.................................................................. 454
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:SENSe<ch>[:POWer]:FILTer:LENGth[:USER].................................................................. 454
:SENSe<ch>[:POWer]:FILTer:NSRatio............................................................................. 455
:SENSe<ch>[:POWer]:FILTer:NSRatio:MTIMe.................................................................. 455
:SENSe<ch>[:POWer]:FILTer:SONCe.............................................................................. 455
:SENSe<ch>[:POWer]:FILTer:TYPE................................................................................. 456
:SENSe<ch>[:POWer]:FREQuency..................................................................................456
:SENSe<ch>[:POWer]:LOGGing:STATe............................................................................457
:SENSe<ch>[:POWer]:OFFSet........................................................................................ 457
:SENSe<ch>[:POWer]:OFFSet:STATe..............................................................................457
:SENSe<ch>[:POWer]:SNUMber?................................................................................... 458
:SENSe<ch>[:POWer]:SOURce.......................................................................................458
:SENSe<ch>[:POWer]:STATus[:DEVice]?......................................................................... 458
:SENSe<ch>[:POWer]:SVERsion?...................................................................................459
:SENSe<ch>[:POWer]:TYPE?......................................................................................... 459
:SENSe<ch>[:POWer]:ZERO.......................................................................................... 459

:SLISt[:LIST]?

Returns a list of all detected sensors in a comma-separated string.

Return values: 
<SensorList> String of comma-separated entries

Each entry contains information on the sensor type, serial num-
ber and interface.
The order of the entries does not correspond to the order the
sensors are displayed in the "NRP Sensor Mapping" dialog.

Example: See Example "Detecting and assigning a power sensor"
on page 446.

Usage: Query only

Manual operation: See "Sensor Mapping List" on page 226

:SLISt:SCAN[:STATe] <State>

Starts the search for R&S NRP power sensors, connected in the LAN or via the
USBTMC protocol.

Parameters:
<State> 1 | ON | 0 | OFF

*RST: 0

Example: See Example "Detecting and assigning a power sensor"
on page 446.

Manual operation: See "Scan" on page 227

:SLISt:SCAN:LSENsor <IP>

Scans for R&S NRP power sensors connected in the LAN.
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Setting parameters: 
<IP> string

*RST: 0

Example: See Example "Detecting and assigning a power sensor"
on page 446.

Usage: Setting only

Manual operation: See "Add LAN Sensor" on page 227

:SLISt:SCAN:USENsor <DeviceID>, <Serial>

Scans for R&S NRP power sensors connected over a USB interface.

Parameters:
<Serial> integer

Range: 0  to  999999

Setting parameters: 
<DeviceID> String or Integer

Range: 0  to  999999
*RST: 0

Example: See Example "Detecting and assigning a power sensor"
on page 446.

Usage: Setting only

Manual operation: See "Add USBTMC Sensor" on page 227

:SLISt:CLEar:LAN

Removes all R&S NRP power sensors connected in the LAN from the list.

Example: See Example "Detecting and assigning a power sensor"
on page 446.

Usage: Event

Manual operation: See "Clear" on page 227

:SLISt:CLEar:USB

Removes all R&S NRP power sensors connected over USB from the list.

Example: See Example "Detecting and assigning a power sensor"
on page 446.

Usage: Event

Manual operation: See "Clear" on page 227
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:SLISt:CLEar[:ALL]

Removes all R&S NRP power sensors from the list.

Example: See Example "Detecting and assigning a power sensor"
on page 446.

Usage: Event

Manual operation: See "Clear" on page 227

:SLISt:ELEMent<ch>:MAPPing <Mapping>

Assigns an entry from the :SLISt[:LIST]? to one of the four sensor channels.

Parameters:
<Mapping> SENS1 | SENSor1 | SENS2 | SENSor2 | SENS3 | SENSor3 |

SENS4 | SENSor4 | UNMapped
Sensor channel.
*RST: UNMapped

Example: See Example "Detecting and assigning a power sensor"
on page 446.

Manual operation: See "Sensor Mapping List" on page 226

:SLISt:SENSor:MAP <SensorId>, <Mapping>

Assigns a sensor directly to one of the sensor channels, using the sensor name and
serial number.

To find out the the sensor name and ID, you can get it from the label of the R&S NRP,
or using the command :SLISt:SCAN[:STATe]. This command detects all R&S NRP
power sensors connected in the LAN or via 'USBTMC protocol.

Setting parameters: 
<SensorId> string

<Mapping> enum

Example: See Example "Detecting and assigning a power sensor"
on page 446.

Usage: Setting only

Manual operation: See "Sensor Mapping List" on page 226

:INITiate<hw>[:POWer]:CONTinuous <Continuous>

Switches the local state of the continuous power measurement by R&S NRP power
sensors on and off. Switching off local state enhances the measurement performance
during remote control.
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The remote measurement is triggered with :READ<ch>[:POWer]?). This command
also returns the measurement results. The local state is not affected, measurement
results can be retrieved with local state on or off.

Parameters:
<Continuous> 1 | ON | 0 | OFF

*RST: 0

Example: INIT1:CONT ON
Switches on the local state of continuous power measurement.

Manual operation: See "State" on page 222

:READ<ch>[:POWer]?

Triggers power measurement and displays the results.

Note: This command does not affect the local state, i.e. you can get results with local
state on or off. For long measurement times, we recommend that you use an SRQ for
command synchronization (MAV bit).

Suffix: 
<ch>

.
1 to 3

Return values: 
<Power> float or float,float

The sensor returns the result in the unit set with command :
SENSe<ch>:UNIT[:POWer]
Certain power sensors, such as the R&S NRP-Z81, return two
values, first the value of the average level and - separated by a
comma - the peak value.

Example: :SENS1:UNIT DBM
Selects unit dBm for presentation of measurement result.
:READ1?
Queries the measurement result of the sensor.
-45.6246576745440230
-45.6 dBm were measured at the given frequency.

Example: R&S NRP-Z81
:READ1?
-55.62403263352178,-22.419472478812476
-55.6 dBm is the measured average level, -22. 4 dBm is the
measured peak level at the given frequency.

Usage: Query only

Manual operation: See "Measured Level" on page 219
See "Level (Peak) / Level (Average)" on page 222

SENSe, READ, INITiate and SLISt subsystems



Remote control commandsR&S®SFI100A

452User Manual 1179.6789.02 ─ 02

:SENSe<ch>:UNIT[:POWer] <Power>

Selects the unit (Watt, dBm or dBμV) of measurement result display, queried with :
READ<ch>[:POWer]?.

Parameters:
<Power> DBM | DBUV | WATT

*RST: DBM

Example: :SENS2:UNIT DBM
Selects dBm as unit for the measured value returned by com-
mand READ.
:READ2?
Response: 7.34
7.34 dBm are measured by sensor 2.

Manual operation: See "Measured Level" on page 219
See "Level (Peak) / Level (Average)" on page 222

:SENSe<ch>[:POWer]:APERture:DEFault:STATe <UseDefAp>

Deactivates the default aperture time of the respective sensor.

To specify a user-defined value, use the command :SENSe<ch>[:POWer]:
APERture:TIMe on page 452.

Parameters:
<UseDefAp> 1 | ON | 0 | OFF

*RST: 1

Example: See Example "Performing a power measurement with a fixed fil-
ter" on page 447.

Manual operation: See "Default Aperture Time" on page 224

:SENSe<ch>[:POWer]:APERture:TIMe <ApTime>

Defines the aperture time (size of the acquisition interval) for the corresponding sensor.

Parameters:
<ApTime> float

Range: depends on connected power sensor
Increment: 1E-9
*RST: depends on connected power sensor

Example: See Example "Performing a power measurement with a fixed fil-
ter" on page 447.

Manual operation: See "Aperture Time" on page 225
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:SENSe<ch>[:POWer]:CORRection:SPDevice:SELect <Select>

Several S-parameter tables can be stored in a sensor. The command selects a loaded
data set for S-parameter correction for the corresponding sensor.

Parameters:
<Select> float

*RST: 0

Manual operation: See "S-Parameter" on page 225

:SENSe<ch>[:POWer]:CORRection:SPDevice:STATe <State>

Activates the use of the S-parameter correction data.

Note: If you use power sensors with attenuator, the instrument automatically activates
the use of S-parameter data.

Parameters:
<State> 1 | ON | 0 | OFF

*RST: 0

Example: :SENSe1:POWer:CORRection:SPDevice:STATe 1
Activates the use of the S-parameters correction data.

Manual operation: See "S-Parameter" on page 225

:SENSe<ch>[:POWer]:CORRection:SPDevice:LIST?

Queries the list of the S-parameter data sets that have been loaded to the power sen-
sor.

Return values: 
<List> string list

*RST: 0

Usage: Query only

Manual operation: See "S-Parameter" on page 225

:SENSe<ch>[:POWer]:DISPlay:PERManent:PRIority <Priority>

Selects average or peak power for permanent display.

Parameters:
<Priority> AVERage | PEAK

*RST: AVERage

Example: :SENS1:DISP:PERM:STAT ON
Turns on the permanent view.
:SENS1:DISP:PERM:PRI AVER
Sets the average power for display.

Manual operation: See "Display" on page 222
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:SENSe<ch>[:POWer]:DISPlay:PERManent:STATe <State>

Activates the permanent display of the measured power level results. The instrument
also indicates the sensor type, the connection, the measurement source and the offset
if set.

Parameters:
<State> 1 | ON | 0 | OFF

*RST: 0

Example: :SENS1:POW:DISP:PERM:STAT ON
Turns on the permanent view.

Manual operation: See "Display Permanent" on page 222

:SENSe<ch>[:POWer]:FILTer:LENGth:AUTO?

Queries the current filter length in filter mode AUTO (:SENSe<ch>[:POWer]:
FILTer:TYPE)

Return values: 
<Auto> float

Range: 1  to  depends on R&S NRP power sensor type

Example: :SENS1:FILT:TYPE AUTO
Selects auto filter.
:SENS1:FILT:LENG:AUTO?
Queries the automatically set filter length.
Response: 1024

Usage: Query only

Manual operation: See "Filter Length" on page 224

:SENSe<ch>[:POWer]:FILTer:LENGth[:USER] <User>

Selects the filter length for SENS:POW:FILT:TYPE USER. As the filter length works as
a multiplier for the time window, a constant filter length results in a constant measure-
ment time (see also "About the measuring principle, averaging filter, filter length, and
achieving stable results" on page 213).

The R&S NRP power sensors provide different resolutions for setting the filter length,
depending on the used sensor type.

For more information, refer to the specifications document.

Parameters:
<User> float

Range: 1  to  depends on R&S NRP power sensor type
*RST: 1
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Example: :SENS1:FILT:TYPE USER
Selects user filter mode.
:SENS1:FILT:LENG 16
Sets a filter length of 16. E.g. using a sensor with 20 ms time
window, the resulting measurement time is 640 ms (2x16x20
ms)

Manual operation: See "Filter Length" on page 224

:SENSe<ch>[:POWer]:FILTer:NSRatio <NSRatio>

Sets an upper limit for the relative noise content in fixed noise filter mode (:
SENSe<ch>[:POWer]:FILTer:TYPE). This value determines the proportion of intrin-
sic noise in the measurement results.

Parameters:
<NSRatio> float

Range: 0.001  to  1
Increment: 0.001
*RST: 0.01

Example: See Example "Performing a power measurement with a fixed fil-
ter" on page 447.

Manual operation: See "Noise/Signal Ratio" on page 224

:SENSe<ch>[:POWer]:FILTer:NSRatio:MTIMe <MTime>

Sets an upper limit for the settling time of the auto-averaging filter and thus limits the
length of the filter.

Parameters:
<MTime> float

Range: 1  to  999.99
Increment: 0.01
*RST: 4

Example: See Example "Performing a power measurement with a fixed fil-
ter" on page 447.

Manual operation: See "Timeout" on page 224

:SENSe<ch>[:POWer]:FILTer:SONCe

Starts searching the optimum filter length for the current measurement conditions. You
can check the result with command :SENS1:POW:FILT:LENG:USER? in filter mode
USER (:SENSe<ch>[:POWer]:FILTer:TYPE).
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Example: SENS1:FILT:TYPE USER
Selects user filter mode.
:SENS1:FILT:SONC
Activates the search for the optimum filter length.
:SENS1:FILT:LENG?
Returns the found optimum filter length.
Response: 128

Usage: Event

Manual operation: See "Auto Once" on page 224

:SENSe<ch>[:POWer]:FILTer:TYPE <Type>

Selects the filter mode. The filter length is the multiplier for the time window and thus
directly affects the measurement time.

Parameters:
<Type> AUTO | USER | NSRatio

AUTO
Automatically selects the filter length, depending on the mea-
sured value. The higher the power, the shorter the filter length,
and vice versa.
Note: To avoid long settling times when the power is low, you
can limit the averaging factor limited with the "timeout" parame-
ter (:SENSe<ch>[:POWer]:FILTer:NSRatio:MTIMe).
USER
Allows you to set the filter length manually. As the filter-length
takes effect as a multiplier of the measurement time, you can
achieve constant measurement times.
NSRatio
Selects the filter length (averaging factor) according to the crite-
rion that the intrinsic noise of the sensor (2 standard deviations)
does not exceed the specified noise content. You can define the
noise content with command :SENSe<ch>[:POWer]:FILTer:
NSRatio.
*RST: AUTO

Example: See Example "Performing a power measurement with a fixed fil-
ter" on page 447.

Manual operation: See "Filter" on page 223

:SENSe<ch>[:POWer]:FREQuency <Frequency>

Sets the RF frequency of the signal, if signal source :SENSe<ch>[:POWer]:SOURce
USER is selected.
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Parameters:
<Frequency> float

*RST: 1 GHz

Example: :SENS1:SOUR USER
Selects user-defined source.
:SENS1:FREQ 2.44GHz
Sets the RF frequency of the source which is 2.44 GHz.

Manual operation: See "Frequency" on page 223

:SENSe<ch>[:POWer]:LOGGing:STATe <State>

Activates the recording of the power values, measured by a connected R&S NRP
power sensor.

Parameters:
<State> 1 | ON | 0 | OFF

*RST: 0

Example: :SENS:LOGG:STAT ON
Activates recording of the power measurement of the first sen-
sor.

Manual operation: See "Enable Logging" on page 225

:SENSe<ch>[:POWer]:OFFSet <Offset>

Sets a level offset which is added to the measured level value after activation with
command :SENSe<ch>[:POWer]:OFFSet:STATe. The level offset allows, e.g. to
consider an attenuator in the signal path.

Parameters:
<Offset> float

Range: -100.0  to  100.0
*RST: 0
Default unit: dB

Example: :SENS1:POW:OFFS 10.0
Sets a level offset of 10 dB

Manual operation: See "Level Offset State,Level Offset" on page 223

:SENSe<ch>[:POWer]:OFFSet:STATe <State>

Activates the addition of the level offset to the measured value. The level offset value is
set with command :SENSe<ch>[:POWer]:OFFSet.

Parameters:
<State> 1 | ON | 0 | OFF

*RST: 0
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Example: :SENS1:POW:OFFS 0.4dB
Sets a level offset of 0.4 dB
:SENS1:POW:OFFS:STAT ON
A level offset of 0.4 dB is added to the measured value.

Manual operation: See "Level Offset State,Level Offset" on page 223

:SENSe<ch>[:POWer]:SNUMber?

Queries the serial number of the sensor.

Return values: 
<SNumber> string

Example: :SENS1:SNUM?
Queries the serial number.

Usage: Query only

Manual operation: See "Sensor type and serial number" on page 222

:SENSe<ch>[:POWer]:SOURce <Source>

Determines the signal to be measured.

Note: When measuring the RF signal, the sensor considers the corresponding correc-
tion factor at that frequency, and uses the level setting of the instrument as reference
level.

Parameters:
<Source> A | USER | RF

*RST: A

Example: See Example "Performing a power measurement with a fixed fil-
ter" on page 447.

Manual operation: See "Use Frequency Of" on page 223

:SENSe<ch>[:POWer]:STATus[:DEVice]?

Queries if a sensor is connected to the instrument.

Return values: 
<Status> 1 | ON | 0 | OFF

*RST: 0

Example: :SENS1:STAT?
Response: 1
A sensor is connected.

Usage: Query only

Manual operation: See "State" on page 222
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:SENSe<ch>[:POWer]:SVERsion?

Queries the software version of the connected R&S NRP power sensor.

Return values: 
<SVersion> string

Example: :SENS1:POW:SVER?
Queries the software version of the power sensor.

Usage: Query only

:SENSe<ch>[:POWer]:TYPE?

Queries the sensor type. The type is automatically detected.

Return values: 
<Type> string

Example: :SENS1:TYPE?
Queries the type of sensor.
Response: NRP-Z21
The R&S NRP-Z21 sensor is used.

Usage: Query only

Manual operation: See "Sensor type and serial number" on page 222

:SENSe<ch>[:POWer]:ZERO

Performs zeroing of the sensor.

Zeroing is required after warm-up, i.e. after connecting the sensor.

Note: Switch off or disconnect the RF power source from the sensor before zeroing.

We recommend that you zero in regular intervals (at least once a day), if:
● The temperature has varied more than about 5 °C.
● The sensor has been replaced.
● You want to measure very low power.

Example: :SENS1:ZERO
Executes zeroing.

Usage: Event

Manual operation: See "Zero" on page 222

13.14  SCONfiguration subsystem

The SCONfiguration subsystem contains the commands to define the system con-
figuration, stream mapping and baseband configuration.
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Required options

Common suffixes

The commands in this chapter use the following common suffixes:

Suffix Suffix
range

Description Required options

RF<ch> [1] One RF output "RF Out", optional suffix Included in base unit

STReam<st> [1] One IQ stream, optional suffix R&S SFI-K17

Example: Distributing the streams to the output connectors
The following example lists the commands necessary to fulfill this task.

// ********************************************************************************
// Map a stream to the output connectors
// ********************************************************************************
SCONfiguration:OUTPut:MAPPing:RF1:STReam1:STATe ON
SCONfiguration:OUTPut:MAPPing:IQOutput:STReam1:STATe?
// Response: "0"
// You can map a stream only to one signal ouptut.

// ********************************************************************************
// Add frequency- or phase offset to stream
// ********************************************************************************
SCONfiguration:OUTPut:MAPPing:STReam1:FOFFset 0.1
SCONfiguration:OUTPut:MAPPing:STReam1:POFFset 0.1

Example: Connecting and configuring external instruments
The following example lists commands to connect and configure external instruments.

// ********************************************************************************
// Scan interfaces and your network for connected instruments.
// ********************************************************************************
SCONfiguration:EXTernal:DISPlay ALL
SCONfiguration:EXTernal:REMote:CLEan
SCONfiguration:EXTernal:REMote:SCAN
SCONfiguration:EXTernal:REMote:SCAN:STATe?
// Response: "0"
// The scanning procedure is finished.

// ********************************************************************************
// Connect an external instrument
// ********************************************************************************
SCONfiguration:EXTernal:REMote:LIST?
// Response: "FE170ST-123456"
SCONfiguration:EXTernal:RF:REMote:ICONnect "FE170ST-123456"
// The external frontend is connected.
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// ********************************************************************************
// Query information on the external instrument
// ********************************************************************************
SCONfiguration:EXTernal:RF:RCONnection:STATe?
//Response: "1"
SCONfiguration:EXTernal:RF:DIRection?
// Response: "OUT"
SCONfiguration:EXTernal:RF:INAMe?
//Response: "FE170ST-123456"
SCONfiguration:EXTernal:RF:REMote:INFO?
// Response: "FE170ST-123456","Frontend Connection","FE170ST-123456","FE170ST-123456","connected"
SCONfiguration:EXTernal:REMote:INITialization:CATalog?
// Response: 
SCONfiguration:EXTernal:REMote:PURGe

Commands:

● I/Q stream mapper commands..............................................................................461
● External RF commands.........................................................................................462

13.14.1  I/Q stream mapper commands

:SCONfiguration:OUTPut:MAPPing:RF:STReam<st>:STATe.............................................. 461
:SCONfiguration:OUTPut:MAPPing:IQOutput<ch>:STReam<st>:STATe.............................. 461
:SCONfiguration:OUTPut:MAPPing:RF<ch>:MODE...........................................................461
:SCONfiguration:OUTPut:MAPPing:IQOutput<ch>:MODE..................................................461
:SCONfiguration:OUTPut:MAPPing:STReam<st>:FOFFset................................................ 462
:SCONfiguration:OUTPut:MAPPing:STReam<st>:POFFset................................................462

:SCONfiguration:OUTPut:MAPPing:RF:STReam<st>:STATe <State>
:SCONfiguration:OUTPut:MAPPing:IQOutput<ch>:STReam<st>:STATe <State>
Maps the I/Q output streams to the output connectors.

Parameters:
<State> 1 | ON | 0 | OFF

*RST: 0

Example: See Example "Distributing the streams to the output connectors"
on page 460.

:SCONfiguration:OUTPut:MAPPing:RF<ch>:MODE <Mode>
:SCONfiguration:OUTPut:MAPPing:IQOutput<ch>:MODE <Mode>
Parameters:
<Mode> SINGle | ADD | MULTiplex

*RST: SINGle
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:SCONfiguration:OUTPut:MAPPing:STReam<st>:FOFFset <SmFreqOffset>

Sets the frequency offset per stream.

This offset implies a shift in the frequency domain for all signals that the stream routes
to a specific output connector. For example, RF or I/Q output connectors. Value ranges
depend on installed options.

For more information, refer to the specifications document.

Parameters:
<SmFreqOffset> float

Range: depends on options
Increment: 0.01
*RST: 0

Example: See Example "Distributing the streams to the output connectors"
on page 460.

Manual operation: See "Frequency Offset" on page 142

:SCONfiguration:OUTPut:MAPPing:STReam<st>:POFFset <SmPhasOffset>

Sets the phase offset per stream.

Parameters:
<SmPhasOffset> float

Range: -999.99  to  999.99
Increment: 0.01
*RST: 0

Example: See Example "Distributing the streams to the output connectors"
on page 460.

Manual operation: See "Phase Offset" on page 142

13.14.2  External RF commands

:SCONfiguration:EXTernal:DISPlay.................................................................................. 463
:SCONfiguration:EXTernal:ACONnect.............................................................................. 463
:SCONfiguration:EXTernal:REMote:CONNect[:ALL]...........................................................463
:SCONfiguration:EXTernal:REMote:DISConnect[:ALL]....................................................... 463
:SCONfiguration:EXTernal:PBEHaviour............................................................................ 463
:SCONfiguration:EXTernal:RF<ch>:DIRection?................................................................. 464
:SCONfiguration:EXTernal:RF<ch>:RCONnection:STATe?................................................. 464
:SCONfiguration:EXTernal:RF<ch>:INAMe?......................................................................464
:SCONfiguration:EXTernal:RF<ch>:RF:STATe...................................................................464
:SCONfiguration:EXTernal:REMote:LIST?........................................................................ 465
:SCONfiguration:EXTernal:REMote:ADD.......................................................................... 465
:SCONfiguration:EXTernal:REMote:REName....................................................................466
:SCONfiguration:EXTernal:RF<ch>:REMote:ISELect......................................................... 466
:SCONfiguration:EXTernal:RF<ch>:REMote:CONNect.......................................................466
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:SCONfiguration:EXTernal:RF<ch>:REMote:ICONnect...................................................... 466
:SCONfiguration:EXTernal:RF<ch>:REMote:INFO?........................................................... 466
:SCONfiguration:EXTernal:RF<ch>:REMote:DISConnect................................................... 467
:SCONfiguration:EXTernal:REMote:INITialization:CATalog?................................................467
:SCONfiguration:EXTernal:RF<ch>:REMote:INITialization:FILE.......................................... 467
:SCONfiguration:EXTernal:REMote:PURGe......................................................................467
:SCONfiguration:EXTernal:REMote:CLEan....................................................................... 468
:SCONfiguration:EXTernal:RF<ch>:REMote:SEND............................................................468

:SCONfiguration:EXTernal:DISPlay <DisplayMode>

Filters the displayed connectors upon the selected criteria.

Parameters:
<DisplayMode> ALL | MAPPed | INPut | OUTPut

*RST: MAPPed

Example: See Example "Connecting and configuring external instruments"
on page 460.

Manual operation: See "Display" on page 143

:SCONfiguration:EXTernal:ACONnect <State>

Enables automatic detection and connection setup of connected external instruments.

Parameters:
<State> 1 | ON | 0 | OFF

*RST: 0

Manual operation: See "Auto Connect" on page 143

:SCONfiguration:EXTernal:REMote:CONNect[:ALL]
:SCONfiguration:EXTernal:REMote:DISConnect[:ALL]
Triggers the instrument to establish the connections to all configured external instru-
ments or to disconnect all existing connections.

Usage: Event

Manual operation: See "Connect/Disconnect All Remote" on page 144

:SCONfiguration:EXTernal:PBEHaviour <State>

If enabled, the connection to the external instruments is retained after preset (*RST) of
the instrument.

Parameters:
<State> 1 | ON | 0 | OFF

*RST: n.a. (factory preset: 0)
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Manual operation: See "Preset behavior: Keep connections to external instru-
ments" on page 144

:SCONfiguration:EXTernal:RF<ch>:DIRection?

Queries the connector direction.

Return values: 
<Direction> NONE | IN | OUT

*RST: IN

Example: See Example "Connecting and configuring external instruments"
on page 460.

Usage: Query only

Manual operation: See "Direction" on page 144

:SCONfiguration:EXTernal:RF<ch>:RCONnection:STATe?

Queries the status of the remote connection.

Return values: 
<State> 1 | ON | 0 | OFF

Example: See Example "Connecting and configuring external instruments"
on page 460.

Usage: Query only

Manual operation: See "Rem Conn" on page 145

:SCONfiguration:EXTernal:RF<ch>:INAMe?

Queries the name of the connected external instrument.

Return values: 
<InstrName> string

Example: See Example "Connecting and configuring external instruments"
on page 460.

Usage: Query only

Manual operation: See "Instrument Name" on page 146

:SCONfiguration:EXTernal:RF<ch>:RF:STATe <RemConnState>

Parameters:
<RemConnState> 1 | ON | 0 | OFF

Manual operation: See "RF State" on page 146
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:SCONfiguration:EXTernal:REMote:LIST?

Lists all available instruments.

Return values: 
<InstrNames> String

String with symbolic names and/or alias names

Example: See Example "Connecting and configuring external instruments"
on page 460

Usage: Query only

Manual operation: See "External Instrument" on page 147

:SCONfiguration:EXTernal:REMote:ADD <InstrName>, <HwChan>,
<TcpIporUsbAddr>[, <RfPathNumber>]

Adds manually an external instrument to the list of available instruments.

Parameters:
<HwChan> String

Hardware channel (USB or LAN) used by the remote channel to
the external instrument
Range: "LAN"  to  "USB"
*RST: "LAN"

<TcpIporUsbAddr> String
IP address or hostname of the connected external instrument

<RfPathNumber> String
Determines the number of RF paths the external instrument is
equipped with
Range: "1"  to  "2"
*RST: "1"

Setting parameters: 
<InstrName> String

Alias name of the instrument

Example: See Example "Connecting and configuring external instruments"
on page 460.

Usage: Setting only

Manual operation: See "External Instrument" on page 147
See "Set Symbolic Name" on page 147
See "Remote Channel" on page 148
See "Hostname or IP Address" on page 148
See "Device ID" on page 148
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:SCONfiguration:EXTernal:REMote:REName

Changes the symbolic name of the instrument.

Usage: Setting only

:SCONfiguration:EXTernal:RF<ch>:REMote:ISELect <InstrName>[, <RfPath>]

Selects an external instrument for the selected connector.

Parameters:
<InstrName> String

Instrument alias name, as retrieved with the command :
SCONfiguration:EXTernal:REMote:LIST?.

<RfPath> String
Determines the used RF output of the external instrument.
For a one-path instrument, the output path is fixed.

Manual operation: See "External Instrument" on page 147
See "Apply" on page 148
See "Apply and Connect" on page 148

:SCONfiguration:EXTernal:RF<ch>:REMote:CONNect

Triggers the connection to the external instrument at the selected connector.

Usage: Event

:SCONfiguration:EXTernal:RF<ch>:REMote:ICONnect <InstrName>, <RfPath>

Selects an external instrument for the selected connector and triggers connection.

Parameters:
<InstrName> string

Instrument alias name, as retrieved with the command :
SCONfiguration:EXTernal:REMote:LIST?.

<RfPath> string
Determines the used RF output of the external instrument.
For a one-path instrument, the output path is fixed to RF1.

Example: See Example "Connecting and configuring external instruments"
on page 460.

Usage: Setting only

Manual operation: See "Apply and Connect" on page 148

:SCONfiguration:EXTernal:RF<ch>:REMote:INFO?

Queries information on the external instrument.
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Example: See Example "Connecting and configuring external instruments"
on page 460.

Usage: Query only

Manual operation: See "Rem Conn" on page 145
See "Instrument Name" on page 146
See "Set Symbolic Name" on page 147
See "Remote Channel" on page 148
See "Hostname or IP Address" on page 148
See "Device ID" on page 148

:SCONfiguration:EXTernal:RF<ch>:REMote:DISConnect

Triggers the disconnection of the external instrument at the selected connector.

Usage: Event

Manual operation: See "Rem Conn" on page 145

:SCONfiguration:EXTernal:REMote:INITialization:CATalog?

Queries the names of the existing initialization files in the default directory.

Per default, the instrument saves user-defined files in the /var/user/ directory. Use
the command :MMEM:CDIRectory to change the default directory to the currently
used one.

Only files with extension *.iec are listed.

Example: See Example "Connecting and configuring external instruments"
on page 460.

Usage: Query only

:SCONfiguration:EXTernal:RF<ch>:REMote:INITialization:FILE <Filename>

Parameters:
<Filename> string

:SCONfiguration:EXTernal:REMote:PURGe

Removes unused instruments from the pool of external instruments.

Example: See Example "Connecting and configuring external instruments"
on page 460.

Usage: Event

Manual operation: See "Clean Unused/Clean All" on page 147
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:SCONfiguration:EXTernal:REMote:CLEan

Removes all instruments from the pool of external instruments.

Example: See Example "Connecting and configuring external instruments"
on page 460.

Usage: Event

Manual operation: See "Clean Unused/Clean All" on page 147

:SCONfiguration:EXTernal:RF<ch>:REMote:SEND <SendScpiCommand>

Setting parameters: 
<SendScpiCommand>string

Usage: Setting only

13.15  SOURce subsystem

● Connector settings................................................................................................ 468
● SOURce:CORRection subsystem.........................................................................472
● SOURce:CORRection:FRES subsystem..............................................................482
● SOURce:FREQuency subsystem......................................................................... 491
● SOURce:INPut subsystem....................................................................................493
● SOURce:IQ subsystem.........................................................................................493
● SOURce:IQ:OUTPut subsystem...........................................................................495
● SOURce:ROSCillator subsystem..........................................................................499
● SOURce:POWer subsystem.................................................................................505
● SOURce:EFRontend subsystem...........................................................................514

13.15.1  Connector settings

This section summarizes the commands of the OUTPut and INPut subsystems to
configure the connectors settings. Listed are the commands for configuring the output
signals and the inputs for trigger, data, and control signals.

The commands that contain the mnemonic :USER<ch>: determine the global trigger
threshold and input impedance values, that affect all trigger and control signal inputs.
The connector settings affect all digital modulations, the generation of waveform sig-
nals and all digital standards.

See also Chapter 4.5, "Configuring global connectors", on page 121.
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Example: Configuring global connectors
// *****************************************************************************
// Check the signal routing for a global connector, for example connector User 1.
// *****************************************************************************
SOURce1:INPut:USER1:DIRection?
// Response: "UNUS"
// User 1 connector is not in use.
SOURce1:INPut:USER1:SIGnal?
// Response: "NONE"
OUTPut1:USER1:SIGnal?
// Response: "NONE"
// User 1 connector expects no input signal and no output signal.

// *****************************************************************************
// Set signal direction and signal type.
// *****************************************************************************
SOURce1:INPut:USER1:DIRection INP
SOURce1:INPut:USER1:SIGNal?
// Response: "TRIG1"
// The input signal at User 1 connector is a global trigger.
SOURce1:INPut:USER2:DIRection OUTP
OUTput1:USER2:SIGNal?
// Response: "LOW"
// The output signal at User 2 connector is always 0.

// *****************************************************************************
// Set input signal charateristics.
// *****************************************************************************
// Settings for User 1 connector below, User 2 connector settings are analogous.
SOURce1:INPut:USER1:LEVel 1.5
// Sets a threshold of 1.5 V at the User 1 connector.
SOURce1:INPut:USER1:LLEVel 3.3
// Sets a logical level of 3.3 V at the User 1 connector.
SOURce1:INPut:USER1:IMPedance G100K
// Sets the impedance of 100 kOhm / GND at the User 1 connector.
SOURce1:INPut:TRIGger:SLOPe POS
// Sets a positive polarity of the active slope for the trigger input signals.

Commands:

[:SOURce]:INPut:USER<ch>:DIRection............................................................................470
:OUTPut:USER<ch>:DIRection....................................................................................... 470
:OUTPut:USER<ch>:SIGNal........................................................................................... 470
[:SOURce]:INPut:USER<ch>:SIGNal............................................................................... 470
[:SOURce]:INPut:USER:TRIGger:LEVel........................................................................... 471
[:SOURce]:INPut:USER<ch>:CLOCk:LLEVel....................................................................471
[:SOURce]:INPut:TRIGger:IMPedance............................................................................. 471
[:SOURce]:INPut:USER:TRIGger:SLOPe......................................................................... 472
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[:SOURce]:INPut:USER<ch>:DIRection <Direction>
:OUTPut:USER<ch>:DIRection <Direction>
Sets the direction of the signal at the connector that can be an input or an output.

Suffix: 
USER<ch>

.
1 to 7
"User" connector number

Parameters:
<Direction> INPut | OUTPut | UNUSed

INPut|OUTPut
Input signal or output signal
UNUSed
No signals present at the connector.

Example: See Example "Configuring global connectors" on page 469.

Manual operation: See "Direction" on page 127

:OUTPut:USER<ch>:SIGNal <Signal>

Sets the control signal at the selected input connector or output connector.

To define the connector direction, use the command [:SOURce]:INPut:USER<ch>:
DIRection.

Suffix: 
USER<ch>

.
1 to 3

Parameters:
<Signal> NONE | TRIG1 | LOW | HIGH | TRIGgered

NONE
No signal
TRIG1
Global trigger input signal
LOW|HIGH
Always 0 or always 1
TRIGgered
Output of the internal trigger signal or output of a received exter-
nal trigger signal.
*RST: MARKA1

Manual operation: See "Signal" on page 127

[:SOURce]:INPut:USER<ch>:SIGNal <Signal>

Sets the control signal at the selected input connector.

To define the connector direction, use the command [:SOURce]:INPut:USER<ch>:
DIRection.
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Suffix: 
USER<ch>

.
1 to 3

Parameters:
<Signal> TRIG1 | | NONE

TRIG1
Global trigger input signal
NONE
No input signal

Example: See Example "Configuring global connectors" on page 469.

[:SOURce]:INPut:USER:TRIGger:LEVel <Level>

Parameters:
<Level> float

Range: 0.1  to  2
Increment: 0.1
*RST: 1

Example: See Example "Configuring global connectors" on page 469.

Manual operation: See "Threshold User 1 Input/Threshold User 2 Input"
on page 128

[:SOURce]:INPut:USER<ch>:CLOCk:LLEVel <ConnGblLogigLev>

Sets the logical level for output signals at the connectors "User 1" and "User 2"

Parameters:
<ConnGblLogigLev> float

Range: 0  to  3.3
Increment: 0.1
*RST: 3.3

Example: See Example "Configuring global connectors" on page 469.

Manual operation: See "Logic Level User 1/Logic Level User 2" on page 129

[:SOURce]:INPut:TRIGger:IMPedance <Impedance>

Selects the input impedance for an external trigger input signal at the connectors "User
1" and "User 2".

Parameters:
<Impedance> G50 | G100K

G50
50 Ω per ground
G100K
100 kΩ per ground
*RST: G1K
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Example: See Example "Configuring global connectors" on page 469.

Manual operation: See "Impedance User 1/Impedance User 2" on page 129

[:SOURce]:INPut:USER:TRIGger:SLOPe <Slope>

Sets the polarity of the active slope of an external trigger signal.

Parameters:
<Slope> NEGative | POSitive

*RST: POSitive

Example: See Example "Configuring global connectors" on page 469.

Manual operation: See "Trigger Input Slope" on page 129

13.15.2  SOURce:CORRection subsystem

The SOURce:CORRection subsystem contains the commands for defining correction
values for external test assemblies.

You can acquire the correction values anytime, regardless of the modulation settings of
the generator. During correction, the R&S SFI100A adds the correction values to the
output level of the respective RF frequency.

Determine the correction values in one of the following ways:
● Measure the RF output level at several frequency points and enter the value pairs

manually in a table
● Connect an R&S NRP to the generator output signal and send the command [:

SOURce<hw>]:CORRection:CSET:DATA[:SENSor<ch>][:POWer]:SONCe to
fill the table automatically.

Save correction values to files with file extension *.uco.

Refer to Chapter 13.5.2, "Handling files in the default or in a specified directory",
on page 414 for general information on file handling in the default and in a specific
directory.

User-defined frequency response corrections

Using user-defined frequency response correction requires option R&S SFI-K544.

See the user manual "R&S SFI-K544 User-Defined Frequency Response Correction".

Programming examples

The examples in this section assume that:
● The files are stored in the default directory.
● *RST does not affect data lists.
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Example: To create RF level correction values
The following example shows a command sequence to create and activate a list for
assigning level correction values to arbitrary RF frequencies. Further hardware settings
are not considered.

// Reset the instrument to start from an initial state
// Query the available user correction list files in the default
// directory. Select a file or create a file.
// ******************************************************************
*RST; *CLS
:SOURce1:CORRection:CSET:CATalog?
// Response: "ucor1"
// Select the file ucor1.uco.
:SOURce1:CORRection:CSET:SELect "/var/user/ucor1"

// Enter the frequency/level value pairs in the table; existing data
// is overwritten. Query the number of frequency/power entries.
:SOURce1:CORRection:CSET:DATA:FREQuency 100MHz,110MHz,120MHz,130MHz,140MHz,150MHz
:SOURce1:CORRection:CSET:DATA:POWer -10,-7.5,-5.0,-2.5,0,2.5 
:SOURce1:CORRection:CSET:DATA:FREQuency:POINts?
// 6
:SOURce1:CORRection:CSET:DATA:POWer:POINTs?
// 6

// Enable user correction mode and RF output
:SOURce1:CORRection:STATe 1
:OUTPut1:STATe ON

// Query the currently used correction value
:SOURce1:CORRection:VALue?
// -2.5

// Delete a user correction file
:SOURce1:CORRection:CSET:DELEte "/var/user/ucor1.uco"

Example: To fill user correction data with a sensor
The following example shows a command sequence to fill a user correction list auto-
matically supported by a connected R&S NRP.

// Fill a user correction list with the level values
// measured by an R&S NRP,
// store the data in a file and enable user correction.

*RST; *CLS

:SOURce1:CORRection:CSET:SELect "/var/user/Ucor1_AutoFill.uco"
:SOURce1:CORRection:CSET:DATA:FREQuency 100MHz,110MHz,120MHz,130MHz,140MHz,150MHz
:SOURce1:CORRection:ZERoing:STATe 1
:SOURce1:CORRection:CSET:DATA:SENSor1:POWer:SONCe
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// Query the number of automatically filled correction level values
:SOURce1:CORRection:CSET:DATA:POWer:POINTs?
// 6
:SOURce1:CORRection:STATe 1

// Query the correction value at a certain frequency
:FREQ 120000000
:SOURce1:CORRection:VALue?
// -52.13

Example: To export user correction lists
The following example shows a command sequence to export a user correction list
(here the list created with the example before) into an ASCII file. Further hardware set-
tings are not considered.

// Select a user correction file for exporting to file in ASCII format
// Set ASCII data parameters
// Set the ASCII file extension, the decimal separator
// and the column separator for the ASCII data
:SOURce1:CORRection:DEXChange:AFILe:CATalog?
// my_ucor
:SOURce1:CORRection:CSET:CATalog?
// ucor1,Ucor1_AutoFill
:SOURce1:CORRection:CSET:SELect "/var/user/Ucor1_AutoFill.uco"
:SOURce1:CORRection:DEXChange:AFILe:EXTension CSV
:SOURce1:CORRection:DEXChange:AFILe:SEParator:DECimal DOT
:SOURce1:CORRection:DEXChange:AFILe:SEParator:COLumn COMMa 

// Select source and destination 
:SOURce1:CORRection:DEXChange:AFILe:SELect "/var/user/ucor2ASCII"

// Export the user correction data into the ASCII file
:SOURce1:CORRection:DEXChange:MODE EXPort
:SOURce1:CORRection:DEXChange:EXECute

// Query the available ASCII files with extension .csv
:SOURce1:CORRection:DEXChange:AFILe:CATalog?
// ucor2ASCII,my_ucor

// Import a user correction ASCII file
:SOURce1:CORRection:DEXChange:MODE IMPort
:SOURce1:CORRection:DEXChange:AFILE:SELect "/var/user/my_ucor" 
:SOURce1:CORRection:DEXChange:EXECute

Commands:

● Correction settings................................................................................................ 475
● Correction data exchange.....................................................................................478
● SOURce:CORRection:OPTimize subsystem........................................................480
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13.15.2.1  Correction settings

[:SOURce<hw>]:CORRection:CSET:DATA:FREQuency <Frequency>

Enters the frequency value in the table selected with [:SOURce<hw>]:CORRection:
CSET[:SELect].

Parameters:
<Frequency> Frequency#1[, Frequency#2, ...]

String of values with default unit Hz.

Example: See Example "To create RF level correction values"
on page 473 .

Manual operation: See "Frequency (Hz)" on page 236

[:SOURce<hw>]:CORRection:CSET:DATA:POWer <Power>

Enters the level values to the table selected with [:SOURce<hw>]:CORRection:
CSET[:SELect].

Parameters:
<Power> Power#1[, Power#2, ...]

String of values with default unit dB.
*RST: 0

Example: See Example "To create RF level correction values"
on page 473 .

Manual operation: See "Correction Value (dB)" on page 236

[:SOURce<hw>]:CORRection:CSET:DATA:FREQuency:POINts?
[:SOURce<hw>]:CORRection:CSET:DATA:POWer:POINts?
Queries the number of frequency/level values in the selected table.

Return values: 
<Points> integer

Range: 0  to  10000
*RST: 0

Example: See Example "To create RF level correction values"
on page 473 .

Usage: Query only

[:SOURce<hw>]:CORRection:CSET:DATA[:SENSor<ch>][:POWer]:SONCe

Fills the selected user correction table with the level values measured by the power
sensor for the given frequencies.

To select the used power sensor set the suffix in key word SENSe.
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Example: See Example "To fill user correction data with a sensor"
on page 473.

Usage: Event

Manual operation: See "Fill User Correction Data with Sensor" on page 238

[:SOURce<hw>]:CORRection:CSET[:SELect] <Filename>

Selects or creates a file for the user correction data.

If the file with the selected name does not exist, a new file is created.

Parameters:
<Filename> string

Filename or complete file path; file extension can be omitted.

Example: See Example "To create RF level correction values"
on page 473 .

Manual operation: See "UCOR Data" on page 232

[:SOURce<hw>]:CORRection:VALue?

Queries the current value for user correction.

Return values: 
<Value> float

Range: -100  to  100
Increment: 0.01
*RST: 0

Example: See Example "To create RF level correction values"
on page 473 .

Usage: Query only

Manual operation: See "User Correction" on page 232

[:SOURce<hw>]:CORRection:ZERoing:STATe <State>

Activates the zeroing procedure before filling the user correction data acquired by a
sensor.

Parameters:
<State> 1 | ON | 0 | OFF

*RST: 1

Example: See Example "To fill user correction data with a sensor"
on page 473.

Manual operation: See "Fill User Correction Data with Sensor" on page 238
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[:SOURce<hw>]:CORRection:CSET:DATA[:SENSor<ch>][:POWer]:SONCe

Fills the selected user correction list with the level values measured by the power sen-
sor for the given frequencies.

Suffix: 
SENSor<ch>

.
Defines the used power sensor, i.e. the sensor whose values are
used.

Example: See Example "To fill user correction data with a sensor"
on page 473.

Usage: Event

[:SOURce<hw>]:CORRection[:STATe] <State>

Activates user correction with the currently selected table.

Parameters:
<State> 1 | ON | 0 | OFF

*RST: 0

Example: See Example "To create RF level correction values"
on page 473 .

Manual operation: See "State" on page 232

[:SOURce]:CORRection:CSET:CATalog?

Queries a list of available user correction tables.

Return values: 
<Catalog> string

List of list filenames, separated by commas

Example: See Example "To create RF level correction values"
on page 473 .

Usage: Query only

Manual operation: See "UCOR Data" on page 232

[:SOURce]:CORRection:CSET:DELete <Filename>

Deletes the specified user correction list file.

Setting parameters: 
<Filename> string

Filename or complete file path; file extension is optional.

Example: See Example "To create RF level correction values"
on page 473 .

Usage: Setting only

SOURce subsystem



Remote control commandsR&S®SFI100A

478User Manual 1179.6789.02 ─ 02

Manual operation: See "UCOR Data" on page 232

[:SOURce<hw>]:CORRection:OPTimize:EVM <OptimizeEvm>

Enables further optimization of preexisting excellent EVM performance of I/Q modula-
ted RF signals.

Enable EVM optimization, if your test setup requires the lowest EVM values. For exam-
ple, if you need to generate 5G NR signals, LTE signals or IEEE 802.11 signals that
require optimal EVM performance.

Parameters:
<OptimizeEvm> 1 | ON | 0 | OFF

*RST: 0

Example: :SOURce1:CORRection:OPTimize:EVM?
// Response: "0"
:SOURce1:CORRection:OPTimize:EVM 1
Enables EVM optimization for the selected path.

Manual operation: See "Optimize EVM" on page 154

13.15.2.2  Correction data exchange

With the following commands, you can configure user correction lists and export or
import them accordingly.

[:SOURce<hw>]:CORRection:DEXChange:AFILe:CATalog?

Queries the available ASCII files for export or import of user correction data in the cur-
rent or specified directory.

Return values: 
<Catalog> string

List of ASCII files *.txt or *.csv, separated by commas.

Example: See Example "To create RF level correction values"
on page 473 .

Usage: Query only

Manual operation: See "Select ASCII Source/Select Destination" on page 234

[:SOURce<hw>]:CORRection:DEXChange:AFILe:EXTension <Extension>

Determines the extension of the ASCII files for file import or export, or to query existing
files.

Parameters:
<Extension> TXT | CSV

*RST: TXT

Example: See Example "To export user correction lists" on page 474 .
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Manual operation: See "ASCII File Settings" on page 234

[:SOURce<hw>]:CORRection:DEXChange:AFILe:SELect <Filename>

Selects the ASCII file to be imported or exported.

Parameters:
<Filename> string

Filename or complete file path; file extension can be omitted.

Example: See Example "To export user correction lists" on page 474 .

Manual operation: See "Select ASCII Source/Select Destination" on page 234

[:SOURce<hw>]:CORRection:DEXChange:AFILe:SEParator:COLumn <Column>

Selects the separator between the frequency and level column of the ASCII table.

Parameters:
<Column> TABulator | SEMicolon | COMMa | SPACe

*RST: COMMa

Example: See Example "To export user correction lists" on page 474 .

Manual operation: See "ASCII File Settings" on page 234

[:SOURce<hw>]:CORRection:DEXChange:AFILe:SEParator:DECimal <Decimal>

Sets the decimal separator used in the ASCII data between '.' (decimal point) and ','
(comma) with floating-point numerals.

Parameters:
<Decimal> DOT | COMMa

*RST: DOT

Example: See Example "To export user correction lists" on page 474 .

Manual operation: See "ASCII File Settings" on page 234

[:SOURce<hw>]:CORRection:DEXChange:EXECute

Executes the import or export of the selected correction list, according to the previously
set transfer direction with command [:SOURce<hw>]:CORRection:DEXChange:
MODE.

Example: See Example "To export user correction lists" on page 474 .

Usage: Event

Manual operation: See "Import / Export" on page 234
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[:SOURce<hw>]:CORRection:DEXChange:MODE <Mode>

Determines import or export of a user correction list.

Specify the source or destination file with the command [:SOURce<hw>]:
CORRection:DEXChange:SELect.

Parameters:
<Mode> IMPort | EXPort

*RST: IMPort

Example: See Example "To export user correction lists" on page 474 .

Manual operation: See "Mode" on page 233

[:SOURce<hw>]:CORRection:DEXChange:SELect <Filename>

Selects the ASCII file for import or export, containing a user correction list.

Parameters:
<Filename> string

Filename or complete file path; file extension can be omitted.

Example: See Example "To export user correction lists" on page 474 .

Manual operation: See "Select Source/Select ASCII Destination" on page 234

13.15.2.3  SOURce:CORRection:OPTimize subsystem

Option:: R&S SFI-K575

The SOURce:CORRection:OPTimize subsystem contains the commands for defin-
ing correction values for predefined digital predistortion to linarize the RF signal.

You can acquire the correction values anytime, regardless of the modulation settings of
the generator. During correction, the R&S SFI100A adds the correction values to the
output level of the respective RF frequency.

Example: Using predefined DPD for RF linearization
*RST

:SOURce1:CORRection:OPTimize:RF:LINearize:ADJust
// Calculates correction data for current level and frequency of the RF signal.
:SOURce1:CORRection:OPTimize:RF:LINearize MANual
// Applies the correction data to adjuast level and frequency of the RF signal.

Commands:

[:SOURce<hw>]:CORRection:OPTimize:RF:CHARacteristics............................................. 481
[:SOURce<hw>]:CORRection:OPTimize:RF:HEADroom.................................................... 481
[:SOURce<hw>]:CORRection:OPTimize:RF:IQModulator...................................................481
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[:SOURce<hw>]:CORRection:OPTimize:RF:IQModulator:ADJust?......................................481
[:SOURce<hw>]:CORRection:OPTimize:RF:LINearize.......................................................481
[:SOURce<hw>]:CORRection:OPTimize:RF:LINearize:ADJust?..........................................482

[:SOURce<hw>]:CORRection:OPTimize:RF:CHARacteristics <Characteristic>

Parameters:
<Characteristic> OFF | EVM | USER

*RST: OFF

[:SOURce<hw>]:CORRection:OPTimize:RF:HEADroom <State>

Parameters:
<State> 1 | ON | 0 | OFF

*RST: 0

[:SOURce<hw>]:CORRection:OPTimize:RF:IQModulator <State>

Enables adjustments of the I/Q modulator after each RF frequency change or RF level
change.

Parameters:
<State> 1 | ON | 0 | OFF

1|ON
Adjusts the I/Q modulator during modulation after each RF fre-
quency change or RF level change.
0|OFF
No adjustments of the I/Q modulator during modulation.
*RST: 0

Example: See Example "Using predefined DPD for RF linearization"
on page 480.

[:SOURce<hw>]:CORRection:OPTimize:RF:IQModulator:ADJust?

Return values: 
<AdjustError> 1 | ON | 0 | OFF

*RST: n.a. (no preset. default: 0)

Usage: Query only

[:SOURce<hw>]:CORRection:OPTimize:RF:LINearize <Linearize>

Selects the mode to apply a predefined AM/AM digital predistortion (DPD) to the non-
linear RF chain to linearize the RF signal.

Parameters:
<Linearize> OFF | AUTO | MANual
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OFF
Disables applying the DPD to the nonlinear RF chain.
AUTO
Requires R&S SFI-K575.
Applies an automatic AM/AM predistortion of the nonlinear RF
chain. This mode requires correction data from "Linearize RF for
current settings".
MANual
Requires R&S SFI-K541.
Applies an AM/AM predistortion of the nonlinear RF chain. This
mode requires correction data from "Linearize RF for current
settings".
To receive the correction data, use the following command
before using the manual mode to linearize the RF signal.
[:SOURce<hw>]:CORRection:OPTimize:RF:LINearize:
ADJust? on page 482
*RST: OFF

Example: See Example "Using predefined DPD for RF linearization"
on page 480.

[:SOURce<hw>]:CORRection:OPTimize:RF:LINearize:ADJust?

Return values: 
<AdjustResult> 1 | ON | 0 | OFF

*RST: n.a. (no preset. default: 0)

Example: See Example "Using predefined DPD for RF linearization"
on page 480.

Usage: Query only

13.15.3  SOURce:CORRection:FRES subsystem

The following commands are required to perform signal generation with the option
R&S SFI-K544 in a remote environment.

Common suffixes

The remote commands use the following common suffixes:

Suffix Value range Description

SLISt<hw> 1 to 10 S-parameter list file number. You can load up to 10 files.

FLISt<hw> 1 to 5 Frequency response (FR) list file number. You can load up to five files.
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Programming examples

Example: To enable high-quality table I/Q modualtion optimizations
SOURce1:CORRection:FRESponse:RF:OPTimization:MODE QHT
SOURce1:CORRection:FRESponse:RF:OPTimization:BANDwidth:MODE AUTO
SOURce1:CORRection:FRESponse:RF:OPTimization:BANDwidth:VALue?
// Response in Hz: 160000000
// Optimization bandwidth is 160 MHz.
SOURce1:CORRection:FRESponse:RF:OPTimization:LOCal
SOURce1:CORRection:FRESponse:RF:OPTimization:HOLD:STATe 1

Example: Applying user-defined FRC
This example illustrates frequency response corrections from S-parameter files
*.s<n>p. We assume that the S-parameter files cable.s1p and combiner.s3p are
available in the user directory /var/user/ of the instrument. These files contain cor-
rections for a cable and a combiner as typical components of a test setup.

// *****************************************************************************
// Load S-parameter files that contain the user-defined corrections.
// *****************************************************************************
// Enable absolute level compensation.
:SOURce1:CORRection:FRESponse:RF:USER:ALEVel:STATe 1
:SOURce1:CORRection:FRESponse:RF:USER:SLISt:CATalog?
// Response: "None,None,None,None,None,None,None,None,None,None"
// The S-parameter list has no files. You can load up to ten files.
// Select available S-parameter files.
:SOURce1:CORRection:FRESponse:RF:USER:SLISt1:SELect "/var/user/cable.s1p"
// The *.s1p file contains a single-port measurement.
:SOURce1:CORRection:FRESponse:RF:USER:SLISt1:PORTs:FROM 1
:SOURce1:CORRection:FRESponse:RF:USER:SLISt1:PORTs:TO 1
:SOURce1:CORRection:FRESponse:RF:USER:SLISt1:STATe 1
// You can also skip rows, for example skip the second row.
:SOURce1:CORRection:FRESponse:RF:USER:SLISt3:SELect "/var/user/combiner.s3p"
:SOURce1:CORRection:FRESponse:RF:USER:SLISt3:STATe 1
:SOURce1:CORRection:FRESponse:RF:USER:SLISt:CATalog?
// Response: "None,None,None,None,None,None,None,None,None,None"
// If you do not apply changes to the S-parameter list, the list remains empty.
:SOURce1:CORRection:FRESponse:RF:USER:APPLy 
:SOURce1:CORRection:FRESponse:RF:USER:SLISt:SIZE?
// Response: "2"
:SOURce1:CORRection:FRESponse:RF:USER:SLISt:CATalog?
// Response: "/var/user/cable.s1p,None,/var/user/combiner.s3p,..."

// *****************************************************************************
// Optionally, exclude S-parameter files from the configuration.
// *****************************************************************************
// Deactivate a file from the list.
:SOURce1:CORRection:FRESponse:RF:USER:SLISt4:STATe 0
// Or, unselect the file.
:SOURce1:CORRection:FRESponse:RF:USER:SLISt4:SELect "None"
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// Apply the changes.
:SOURce1:CORRection:FRESponse:RF:USER:APPLy
:SOURce1:CORRection:FRESponse:RF:USER:SLISt:CATalog?
// "/var/user/cable.s1p,None,/var/user/combiner.s3p,None,None,None,None,None,None,None"
// Optionally, clear the whole S-parameter list to empty the list.
:SOURce1:CORRection:FRESponse:RF:USER:SLISt:CLEar

// *****************************************************************************
// Apply FRC with RF list files with file extensions *.fres or *.uco.
// *****************************************************************************
// For RF list files, measure the channel response, save and load the required
// files. The following example assumes that the files tr_channel.fres and 
// ucor.uco are available in the user directory of the instrument.
:SOURce1:CORRection:FRESponse:RF:USER:FLISt:STATe 1
:SOURce1:CORRection:FRESponse:RF:USER:FLISt1:SELect "/var/user/tr_channel.fres"
:SOURce1:CORRection:FRESponse:RF:USER:FLISt1:MAGNitude:STATe 1
:SOURce1:CORRection:FRESponse:RF:USER:FLISt1:PHASe:STATe 1
:SOURce1:CORRection:FRESponse:RF:USER:FLISt2:SELect "/var/user/ucor.uco"
:SOURce1:CORRection:FRESponse:RF:USER:FLISt:APPLy 
:SOURce1:CORRection:FRESponse:RF:USER:FLISt:CATalog?
// Response: "tr_channel.fres, ucor.uco"
:SOURce1:CORRection:FRESponse:RF:USER:STATe 1
:SOURce1:CORRection:FRESponse:RF:USER:ALEVel:VALUe?
// Response: "0.78"
:SOURce1:CORRection:FRESponse:RF:USER:STORe "/var/user/frc"
:SOURce1:CORRection:FRESponse:RF:USER:PRESet
:SOURce1:CORRection:FRESponse:RF:USER:LOAD "/var/user/frc"

Commands:

● General commands...............................................................................................484
● Common commands.............................................................................................487
● S-parameter list commands.................................................................................. 489
● Frequency response (FR) list commands............................................................. 490

13.15.3.1  General commands

[:SOURce<hw>]:CORRection:FRESponse:RF:OPTimization:MODE................................... 484
[:SOURce<hw>]:CORRection:FRESponse:RF:OPTimization:BANDwidth:MODE..................485
[:SOURce<hw>]:CORRection:FRESponse:RF:OPTimization:BANDwidth[:VALue]................ 485
[:SOURce<hw>]:CORRection:FRESponse:RF:OPTimization:HOLD[:STATe]........................ 486
[:SOURce<hw>]:CORRection:FRESponse:RF:OPTimization:LOCal....................................486

[:SOURce<hw>]:CORRection:FRESponse:RF:OPTimization:MODE
<FreqRespOptMode>

Sets the optimization mode for frequency response correction.

This optimization mode also uses the I/Q modulator and vice versa via the command:

SOURce<hw>:BB:IMPairment:OPTimization:MODE
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See also "Optimization Mode" on page 153.

Parameters:
<FreqRespOptMode> FAST | QHTable

FAST
Fast optimization by compensating for I/Q skew.
QHTable
Improves the frequency response while maintaining setting time.
There is no signal interruption.
*RST: FAST

Example: See Example "Applying user-defined FRC" on page 483.

Manual operation: See "Optimization Mode" on page 170

[:SOURce<hw>]:CORRection:FRESponse:RF:OPTimization:BANDwidth:MODE
<FreqRespOptBwMo>

For high-quality I/Q modulation optimizations, sets the mode to set the signal band-
width

To enable these optimizations, see the following command:

[:SOURce<hw>]:CORRection:FRESponse:RF:OPTimization:MODE
on page 484

Parameters:
<FreqRespOptBwMo>AUTO | MANual

AUTO
Automatic bandwidth settings
MANual
Manual bandwidth setting via the following command:
[:SOURce<hw>]:CORRection:FRESponse:RF:
OPTimization:BANDwidth[:VALue] on page 485
*RST: AUTO

Example: See Example "To enable high-quality table I/Q modualtion opti-
mizations" on page 483.

Manual operation: See "Optimization Bandwidth" on page 170

[:SOURce<hw>]:CORRection:FRESponse:RF:OPTimization:BANDwidth[:VALue]
<FreqRespOptBwVa>

Sets the signal compensation for manual bandwidth mode.

See [:SOURce<hw>]:CORRection:FRESponse:RF:OPTimization:
BANDwidth:MODE on page 485.

For more information, refer to the specifications document.
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Parameters:
<FreqRespOptBwVa> integer

Range: depends on options  to  depends on options
*RST: depends on options

Example: See Example "To enable high-quality table I/Q modualtion opti-
mizations" on page 483.

Manual operation: See "Bandwidth" on page 170

[:SOURce<hw>]:CORRection:FRESponse:RF:OPTimization:HOLD[:STATe]
<FreqRespHoldSta>

For high-quality I/Q modulation optimizations, retains the last calculated correction val-
ues as long as one of the following holds:
● SOURce1:CORRection:FRESponse:RF:OPTimization:HOLD:STATe 0
● SOURce1:CORRection:FRESponse:RF:OPTimization:LOCal
To enable these optimizations, see the following command:

[:SOURce<hw>]:CORRection:FRESponse:RF:OPTimization:MODE
on page 484

Parameters:
<FreqRespHoldSta> 1 | ON | 0 | OFF

*RST: 0

Example: See Example "To enable high-quality table I/Q modualtion opti-
mizations" on page 483.

Manual operation: See "Hold Filter" on page 170

[:SOURce<hw>]:CORRection:FRESponse:RF:OPTimization:LOCal

For high-quality I/Q modulation optimizations, triggers optimization for the current set-
tings.

To enable these optimizations, see the following command:

[:SOURce<hw>]:CORRection:FRESponse:RF:OPTimization:MODE
on page 484

Example: See Example "To enable high-quality table I/Q modualtion opti-
mizations" on page 483.

Usage: Event

Manual operation: See "Optimize for current setting" on page 171
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13.15.3.2  Common commands

[:SOURce<hw>]:CORRection:FRESponse:RF:USER[:STATe]............................................ 487
[:SOURce<hw>]:CORRection:FRESponse:RF:USER:STORe.............................................487
[:SOURce<hw>]:CORRection:FRESponse:RF:USER:PRESet............................................487
[:SOURce<hw>]:CORRection:FRESponse:RF:USER:LOAD...............................................487
[:SOURce<hw>]:CORRection:FRESponse:RF:USER:ALEVel[:STATe].................................488
[:SOURce<hw>]:CORRection:FRESponse:RF:USER:ALEVel:VALue?.................................488
[:SOURce<hw>]:CORRection:FRESponse:RF:USER:FLISt[:STATe]....................................489
[:SOURce<hw>]:CORRection:FRESponse:RF:USER:APPLy..............................................489

[:SOURce<hw>]:CORRection:FRESponse:RF:USER[:STATe] <FreqRespState>

Enables the frequency response correction.

Parameters:
<FreqRespState> 1 | ON | 0 | OFF

*RST: 0

Example: See Example "Applying user-defined FRC" on page 483.

Manual operation: See "State" on page 172

[:SOURce<hw>]:CORRection:FRESponse:RF:USER:STORe <FreqRespRfSave>

Saves the current settings into the selected file; the file extension (*.freqresp) is
assigned automatically.

Parameters:
<FreqRespRfSave> "<filename>"

Filename or complete file path

Example: See Example "Applying user-defined FRC" on page 483.

Manual operation: See "Save/Recall" on page 172

[:SOURce<hw>]:CORRection:FRESponse:RF:USER:PRESet

Sets the parameters to their default values (*RST values specified for the commands).

Not affected is the state set with the command [:SOURce<hw>]:CORRection:
FRESponse:RF:USER[:STATe] on page 487.

Example: See Example "Applying user-defined FRC" on page 483.

Usage: Event

Manual operation: See "Set To Default" on page 172

[:SOURce<hw>]:CORRection:FRESponse:RF:USER:LOAD <FreqRespRfRcl>

Loads the selected file from the default or the specified directory. Loaded are files with
extension *.freqresp.
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Parameters:
<FreqRespRfRcl> "<filename>"

Filename or complete file path; file extension can be omitted.

Example: See Example "Applying user-defined FRC" on page 483.

Manual operation: See "Save/Recall" on page 172

[:SOURce<hw>]:CORRection:FRESponse:RF:USER:ALEVel[:STATe]
<FreqCorrRfAlSta>

Enables absolute level compensation at the current center frequency.

Query the level correction value with the following command:

[:SOURce<hw>]:CORRection:FRESponse:RF:USER:ALEVel:VALue?
on page 488

You cannot enable absolute level compensation and user correction simultaneously.
These functions exclude each other.

See also "About UCOR" on page 229.

Parameters:
<FreqCorrRfAlSta> 1 | ON | 0 | OFF

*RST: 0

Example: See Example "Applying user-defined FRC" on page 483.

Manual operation: See "Compensate Absolute Level" on page 172

[:SOURce<hw>]:CORRection:FRESponse:RF:USER:ALEVel:VALue?

Queries the absolute level correction value. Querying real values requires enabled
absolute level compensation:

SOURce1:CORRection:FRESponse:RF:USER:ALEVel:STATe 1
See also [:SOURce<hw>]:CORRection:FRESponse:RF:USER:ALEVel[:STATe]
on page 488.

Return values: 
<FreqCorRfAbsLVa> float

Range: -100  to  100
Increment: 0.001
*RST: 0
Default unit: dB

Example: See Example "Applying user-defined FRC" on page 483.

Usage: Query only

Manual operation: See "Absolute Level Correction" on page 173
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[:SOURce<hw>]:CORRection:FRESponse:RF:USER:FLISt[:STATe]
<FreqCorrRfFLSta>

Uses FR list files for user-defined corrections.

Load the FR lists, enable them and apply the configuration with the corresponding FR
list commands.

Parameters:
<FreqCorrRfFLSta> 1 | ON | 0 | OFF

*RST: 0

Example: See Example "Applying user-defined FRC" on page 483.

Manual operation: See "Additional FR" on page 173

[:SOURce<hw>]:CORRection:FRESponse:RF:USER:APPLy

Applies the values from all enabled S-parameters correction files.

Example: See Example "Applying user-defined FRC" on page 483.

Usage: Event

Manual operation: See "Apply" on page 175
See "Apply" on page 176

13.15.3.3  S-parameter list commands

[:SOURce<hw>]:CORRection:FRESponse:RF:USER:SLISt<ch>:SELect.............................489
[:SOURce<hw>]:CORRection:FRESponse:RF:USER:SLISt<ch>:PORTs:FROM...................490
[:SOURce<hw>]:CORRection:FRESponse:RF:USER:SLISt<ch>:PORTs:TO........................490
[:SOURce<hw>]:CORRection:FRESponse:RF:USER:SLISt<ch>[:STATe]............................ 490
[:SOURce<hw>]:CORRection:FRESponse:RF:USER:SLISt:CATalog?.................................490
[:SOURce<hw>]:CORRection:FRESponse:RF:USER:SLISt:SIZE?......................................490
[:SOURce<hw>]:CORRection:FRESponse:RF:USER:SLISt:CLEar..................................... 490
[:SOURce<hw>]:CORRection:FRESponse:RF:USER:APPLy..............................................490

[:SOURce<hw>]:CORRection:FRESponse:RF:USER:SLISt<ch>:SELect
<FreqRespRfSlsel>

Selects an existing S-parameter file with file extension *.s<n>p from the default direc-
tory or from a specific directory.

Parameters:
<FreqRespRfSlsel> string

Filename incl. file extension or complete file path
Use "none" to unload a file.

Example: See Example "Applying user-defined FRC" on page 483.

Manual operation: See "S-Parameter Filename" on page 174
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[:SOURce<hw>]:CORRection:FRESponse:RF:USER:SLISt<ch>:PORTs:FROM
<FreqRespSListFr>

[:SOURce<hw>]:CORRection:FRESponse:RF:USER:SLISt<ch>:PORTs:TO
<FreqRespSListFr>

[:SOURce<hw>]:CORRection:FRESponse:RF:USER:SLISt<ch>[:STATe]
<FreqRespSLiStat>

[:SOURce<hw>]:CORRection:FRESponse:RF:USER:SLISt:CATalog?
[:SOURce<hw>]:CORRection:FRESponse:RF:USER:SLISt:SIZE?
[:SOURce<hw>]:CORRection:FRESponse:RF:USER:SLISt:CLEar
[:SOURce<hw>]:CORRection:FRESponse:RF:USER:APPLy
Applies the values from all enabled S-parameters correction files.

Example: See Example "Applying user-defined FRC" on page 483.

Usage: Event

Manual operation: See "Apply" on page 175
See "Apply" on page 176

13.15.3.4  Frequency response (FR) list commands

[:SOURce<hw>]:CORRection:FRESponse:RF:USER:FLISt<ch>:SELect............................. 490
[:SOURce<hw>]:CORRection:FRESponse:RF:USER:FLISt<ch>:PHASe[:STATe]................. 490
[:SOURce<hw>]:CORRection:FRESponse:RF:USER:FLISt<ch>:MAGNitude[:STATe]...........490
[:SOURce<hw>]:CORRection:FRESponse:RF:USER:FLISt:CATalog?.................................490
[:SOURce<hw>]:CORRection:FRESponse:RF:USER:FLISt:SIZE?......................................491
[:SOURce<hw>]:CORRection:FRESponse:RF:USER:FLISt:CLEar......................................491

[:SOURce<hw>]:CORRection:FRESponse:RF:USER:FLISt<ch>:SELect
<FreqCorrRfFlSel>

Selects an existing frequency response list file (*.uco or *.fres) from the default
directory or from the specific directory.

Parameters:
<FreqCorrRfFlSel> string

Filename incl. file extension or complete file path
Use "none" to unload a file.

Example: See Example "Applying user-defined FRC" on page 483.

Manual operation: See "Frequency Response Filename" on page 176

[:SOURce<hw>]:CORRection:FRESponse:RF:USER:FLISt<ch>:PHASe[:STATe]
<FreqCorrRfPhSta>

[:SOURce<hw>]:CORRection:FRESponse:RF:USER:FLISt<ch>:MAGNitude[:
STATe] <FreqCorrRfMagSt>

[:SOURce<hw>]:CORRection:FRESponse:RF:USER:FLISt:CATalog?
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[:SOURce<hw>]:CORRection:FRESponse:RF:USER:FLISt:SIZE?
[:SOURce<hw>]:CORRection:FRESponse:RF:USER:FLISt:CLEar
Deletes all entries in the lists.

Example: See Example "Applying user-defined FRC" on page 483.

Usage: Event

13.15.4  SOURce:FREQuency subsystem

The SOURce:FREQuency subsystem contains the commands used to define the fre-
quency settings for the RF sources and sweeps.

Example: Frequency configuration

SOURce1:FREQuency:CW? 
// Response 16000000000
SOURce1:FREQuency:CW 19500000000
SOURce1:FREQuency:OFFSet?
// Response 0
SOURce1:FREQuency:OFFSet 5000

SOURce1:FREQuency:STEP:MODE?
// Response: DEC
SOURce1:FREQuency:STEP:INCRement 1000000
SOURce1:FREQuency:CW UP

[:SOURce<hw>]:FREQuency[:CW|FIXed].........................................................................491
[:SOURce<hw>]:FREQuency[:CW|FIXed]:RCL................................................................. 492
[:SOURce<hw>]:FREQuency:OFFSet.............................................................................. 492
[:SOURce<hw>]:FREQuency:STEP:MODE...................................................................... 492
[:SOURce<hw>]:FREQuency:STEP[:INCRement]............................................................. 493

[:SOURce<hw>]:FREQuency[:CW|FIXed] <Fixed>

Sets the frequency of the RF output signal in the selected path.

Parameters:
<Fixed> float

The following settings influence the value range:
An offset set with the command [:SOURce<hw>]:FREQuency:
OFFSet
Numerical value
Sets the frequency in CW and sweep mode
UP|DOWN
Varies the frequency step by step in user mode.
The frequency is increased or decreased by the value set with
the command [:SOURce<hw>]:FREQuency:STEP[:
INCRement].
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Range: (RFmin + OFFSet) to (RFmax + OFFSet)
*RST: n.a.

Example: See Example "Frequency configuration" on page 491

Manual operation: See "Frequency" on page 201

[:SOURce<hw>]:FREQuency[:CW|FIXed]:RCL <Rcl>

Set whether the RF frequency value is retained or taken from a loaded instrument con-
figuration, when you recall instrument settings with command *RCL.

Parameters:
<Rcl> INCLude | EXCLude

INCLude
Takes the frequency value of the loaded settings.
EXCLude
Retains the current frequency when an instrument configuration
is loaded.
*RST: INCLude

Example: SOURce1:FREQuency:CW:RCL INCLude
Manual operation: See "Exclude Frequency" on page 281

[:SOURce<hw>]:FREQuency:OFFSet <Offset>

Sets the frequency offset fFREQ:OFFSet of a downstream instrument.

Parameters:
<Offset> float

Increment: 0.01
*RST: 0

Example: See Example "Frequency configuration" on page 491

Manual operation: See "Offset" on page 201

[:SOURce<hw>]:FREQuency:STEP:MODE <Mode>

Defines the type of step size to vary the RF frequency at discrete steps with the com-
mands FREQ UP or FREQ DOWN.

Parameters:
<Mode> DECimal | USER

DECimal
Increases or decreases the level in steps of ten.
*RST: DECimal

Example: See Example "Frequency configuration" on page 491.

Manual operation: See "Variation Active" on page 204
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[:SOURce<hw>]:FREQuency:STEP[:INCRement] <Increment>

Sets the step width.

You can use this value to vary the RF frequency with command FREQ UP or FREQ
DOWN.

Note: This value also applies to the step width of the rotary knob on the instrument
and, in user-defined step mode, increases or decreases the frequency.

Parameters:
<Increment> float

Range: 0 Hz  to  RFmax - 100 kHz
Increment: 0.01 Hz
*RST: 1E6

Example: See Example "Frequency configuration" on page 491

Manual operation: See "Variation Step" on page 204

13.15.5  SOURce:INPut subsystem

The SOURce:INPut subsystem contains the commands for configuring the inputs for
external modulation signals. The instrument trigger setting influences all sweeps and is
effective in the List mode (Instrument Trigger).

13.15.6  SOURce:IQ subsystem

The SOURce:IQ subsystem contains the commands for configuring the I/Q modula-
tion.

Required options

See "Required options" on page 151.

[:SOURce<hw>]:IQ:SOURce...........................................................................................493
[:SOURce<hw>]:IQ:STATe.............................................................................................. 494
[:SOURce<hw>]:BB:IQGain............................................................................................ 494

[:SOURce<hw>]:IQ:SOURce <Source>

Selects the input signal source for the I/Q modulator.

Parameters:
<Source> BASeband

BASeband
Internal baseband signal
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ANALog
External analog wideband I/Q signal
Enabling the I/Q modulator disables an enabled amplitude mod-
ulation of the RF output signal.
Differential
External analog wideband I/Q signal
Enabling the I/Q modulator disables an enabled amplitude mod-
ulation of the RF output signal.
*RST: BASeband

Example: SOURce1:IQ:SOURce BASeband
Sets the internal baseband signal as I/Q modulator source sig-
nal, for example an ARB signal.

Manual operation: See "Source" on page 153

[:SOURce<hw>]:IQ:STATe <State>

Enables the I/Q modulation.

Parameters:
<State> 1 | ON | 0 | OFF

*RST: 0

Example: IQ:STAT ON
Enables the I/Q modulation.

Manual operation: See "State" on page 152

[:SOURce<hw>]:BB:IQGain <IqGain>

Sets the baseband gain for a wide dynamic range.

You can attenuate this level (negative gain) to optimize the I/Q modulation perfor-
mance. The optimization is a trade-off between signal distortion and signal-to-noise
ratio (SNR).

Parameters:
<IqGain> DB0 | DBM3 | DBM6 | DBM9 | DBM12 | AUTO

Dynamic range of 12 dB divided into 3 dB steps.
DBM3|DBM6|DBM9|DBM12
"-12 dB"/"-9 dB"/"-6 dB"/"-3 dB"
Attenuates the baseband signal internally to minimize signal dis-
tortions and optimize the intermodulation characteristics of the
modulated signal. But the SNR decreases, the signal noise
increases.
DB0
0 dB
No changes on the baseband signal, applies no optimization.
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AUTO
The R&S SFI100A automatically sets an optimized gain value.
The configured sample rate, the crest factor and the PEP value
of the modulated signal affect this gain value.
*RST: AUTO

Example: SOURce1:BB:IQGain DBM3
Attenuates the power level of the I/Q modulator source signal by
3 dB.

Manual operation: See "Baseband Gain" on page 153

13.15.7  SOURce:IQ:OUTPut subsystem

Option: R&S SFI-K17

The SOURce:IQ:OUTPut subsystem contains the commands for configuring analog
I/Q output signals.

Example: Enabling and configuring the analog output
SCONfiguration:OUTPut:MAPPing:IQOutput1:STReam1:STATe 1

SOURce1:IQ:OUTPut:ANALog:PRESet
SOURce1:IQ:OUTPut:ANALog:TYPE DIFF
SOURce1:IQ:OUTPut:ANALog:MODE VAR
SOURce1:IQ:OUTPut:LEVel 2
SOURce1:IQ:OUTPut:ANALog:BIAS:COUPling:STATe 1
SOURce1:IQ:OUTPut:ANALog:BIAS:I 1
SOURce1:IQ:OUTPut:ANALog:BIAS:Q?
// 1
SOURce1:IQ:OUTPut:ANALog:OFFSet:I 2
SOURce1:IQ:OUTPut:ANALog:OFFSet:Q 2.5
SOURce1:IQ:OUTPut:ANALog:STATe 1

Commands:

[:SOURce<hw>]:IQ:OUTPut:ANALog:STATe.....................................................................496
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:PRESet.................................................................496
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:SETTing:CATalog?................................................. 496
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:SETTing:STORe.................................................... 496
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:SETTing:LOAD...................................................... 497
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:SETTing:DELete.................................................... 497
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:TYPE....................................................................497
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:MODE...................................................................497
[:SOURce<hw>]:IQ:OUTPut:LEVel...................................................................................497
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:BIAS:COUPling[:STATe]..........................................498
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:BIAS:I................................................................... 498
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:BIAS:Q................................................................. 498
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:OFFSet:I............................................................... 499
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:OFFSet:Q..............................................................499
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[:SOURce<hw>]:IQ:OUTPut:ANALog:STATe <State>

Activates the specified analog I/Q output.

Parameters:
<State> 1 | ON | 0 | OFF

*RST: 0

Example: SOURce:IQ:OUTPut:ANALog:STATe ON
Activates the output of the analog I/Q signal on the [I/Q Out 1]
connectors.

Manual operation: See "State" on page 251

[:SOURce<hw>]:IQ:OUTPut[:ANALog]:PRESet

Sets the default settings (*RST values specified for the commands).

Not affected are:
● The state set with the command [:SOURce<hw>]:IQ:OUTPut:ANALog:STATe.
● If SCONfiguration:EXTernal:PBEHaviour 1, the I/Q ouptput type set with

the command [:SOURce<hw>]:IQ:OUTPut[:ANALog]:TYPE.

Example: See Example "Enabling and configuring the analog output"
on page 495.

Usage: Event

Manual operation: See "Set To Default" on page 251

[:SOURce<hw>]:IQ:OUTPut[:ANALog]:SETTing:CATalog?

Queries the files with I/Q output settings in the default directory. Listed are files with the
file extension *.iqout.

Return values: 
<Catalog> string

Usage: Query only

Manual operation: See "Save/Recall" on page 252

[:SOURce<hw>]:IQ:OUTPut[:ANALog]:SETTing:STORe <Filename>

Stores the current settings into the selected file; the file extension (*.iqout) is
assigned automatically.

Setting parameters: 
<Filename> "<filename>"

Filename or complete file path

Usage: Setting only

SOURce subsystem



Remote control commandsR&S®SFI100A

497User Manual 1179.6789.02 ─ 02

[:SOURce<hw>]:IQ:OUTPut[:ANALog]:SETTing:LOAD <Filename>

Loads the selected file from the default or the specified directory. Loaded are files with
extension *.iqout.

Setting parameters: 
<Filename> "<filename>"

Filename or complete file path

Usage: Setting only

[:SOURce<hw>]:IQ:OUTPut[:ANALog]:SETTing:DELete <Filename>

Deletes the selected file from the default or specified directory. Deleted are files with
the file extension *.iqout.

Setting parameters: 
<Filename> "<filename>"

Filename or complete file path

Usage: Setting only

[:SOURce<hw>]:IQ:OUTPut[:ANALog]:TYPE <Type>

Sets the type of the analog signal.

Example: SOURce1:IQ:OUTPup:ANALog:TYPE DIFFerential
Manual operation: See "I/Q Output Type" on page 252

[:SOURce<hw>]:IQ:OUTPut[:ANALog]:MODE <Mode>

Determines the mode for setting the output parameters.

Parameters:
<Mode> FIXed | VARiable

FIXed
Locks the I/Q output settings
VARiable
Unlocks the settings
*RST: FIXed

Example: See Example "Enabling and configuring the analog output"
on page 495.

Manual operation: See "Mode" on page 252

[:SOURce<hw>]:IQ:OUTPut:LEVel <Level>

Sets the off-load voltage Vp of the analog I/Q signal output.
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To keep the I/Q analog output power levels below the maximum input power level at
your DUT, see "Maximum overall output voltage" on page 245.

Also, the value range depends on instrument settings, for example the modulation sig-
nal type and signal bandwidth.

For more information, refer to the specifications document.

Parameters:
<Level> float

Range: depends on settings
Increment: 1E-4
*RST: 1
Default unit: V

Example: See Example "Enabling and configuring the analog output"
on page 495.

Manual operation: See "I/Q Level Vp (EMF)" on page 253

[:SOURce<hw>]:IQ:OUTPut[:ANALog]:BIAS:COUPling[:STATe] <State>

Couples the bias setting of the I and Q signal components.

Parameters:
<State> 1 | ON | 0 | OFF

*RST: 0

Example: See Example "Enabling and configuring the analog output"
on page 495.

Manual operation: See "Couple I/Q Bias" on page 253

[:SOURce<hw>]:IQ:OUTPut[:ANALog]:BIAS:I <I>
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:BIAS:Q <Q>
Sets the amplifier bias Vbias of the I component or Q component.

To keep the I/Q analog output power levels below the maximum input power level at
your DUT, see "Maximum overall output voltage" on page 245.

The value range depends on the I/Q analog output connectors "DAC", "Diff" or "Sin-
gle".

For more information, refer to the specifications document.

Parameters:
<Q> float

Range: depends on connector
Increment: 1E-4
*RST: 0
Default unit: V

Example: See Example "Enabling and configuring the analog output"
on page 495.
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Manual operation: See "Bias (EMF)" on page 253

[:SOURce<hw>]:IQ:OUTPut[:ANALog]:OFFSet:I <I>
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:OFFSet:Q <Q>
Sets an offset Voffset between the inverting and non-inverting input of the differential
analog I/Q output signal.

To keep the I/Q analog output power levels below the maximum input power level at
your DUT, see "Maximum overall output voltage" on page 245.

The value range depends on the differential I/Q analog output connectors "DAC" or
"Diff".

For more information, refer to the specifications document.

Parameters:
<Q> float

Range: -0.1 V to 0.1 V
Increment: 1E-4
*RST: 0
Default unit: V

Example: See Example "Enabling and configuring the analog output"
on page 495.

Manual operation: See "Offset (EMF)" on page 254

13.15.8  SOURce:ROSCillator subsystem

The SOURce:ROSCillator subsystem contains the commands for setting the exter-
nal and internal reference frequency.

The commands of this subsystem are not affected by an instrument reset (*RST
on page 409).
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Example: Configuring the reference oscillator
// Using 8 GHz external reference source
SOURce:ROSCillator:SOURce EXT
SOURce:ROSCillator:EXTernal:RFOFf:STATe 1
SOURce:ROSCillator:EXTernal:FREQuency 8GHZ
SOURce:ROSCillator:EXTernal:FREQuency?
// Response: 8 GHZ
SOURce:ROSCillator:EXTernal:SBANdwidth WIDE
SOURce:ROSCillator:INTernal:ADJust:STATe 0
// assign the signals to the reference outputs
SOURce:ROSCillator:OUTput:FREQuency:MODE DER100M
SOURce:ROSCillator:OUTput2:FREQuency:MODE LOOP
SOURce:ROSCillator:OUTput:FREQuency:MODE 16G

// Query calibration value
CALibration:ROSCillator?
// 32767
// Set an internal source 
// Activate user-defined adjustment value of 1000
SOURce:ROSCillator:SOURce INT
SOURce:ROSCillator:INTernal:ADJust:STATe 1
SOURce:ROSCillator:INTernal:ADJust:VALue 1000

// to resume calibrated state
SOURce:ROSCillator:INTernal:ADJust:VALue 0
SOURce:ROSCillator:INTernal:ADJust:STATe 0
// or 
// SYSTem:FPRest

[:SOURce]:ROSCillator:EXTernal:FREQuency.................................................................. 500
[:SOURce]:ROSCillator:EXTernal:FREQuency:VARiable.................................................... 501
[:SOURce]:ROSCillator:EXTernal:MLRange?....................................................................501
[:SOURce]:ROSCillator:EXTernal:NSBandwidth?.............................................................. 501
[:SOURce]:ROSCillator:EXTernal:RFOFf[:STATe].............................................................. 502
[:SOURce]:ROSCillator:EXTernal:SBANdwidth..................................................................502
[:SOURce]:ROSCillator:OUTPut:FREQuency:MODE......................................................... 502
[:SOURce]:ROSCillator:OUTPut2:FREQuency:MODE....................................................... 503
[:SOURce]:ROSCillator:OUTPut3:FREQuency:MODE....................................................... 503
[:SOURce]:ROSCillator:PRESet...................................................................................... 503
[:SOURce]:ROSCillator:SOURce..................................................................................... 504
[:SOURce]:ROSCillator[:INTernal]:ADJust[:STATe].............................................................504
[:SOURce]:ROSCillator[:INTernal]:ADJust:VALue.............................................................. 504

[:SOURce]:ROSCillator:EXTernal:FREQuency <Frequency>

Sets the frequency of the external reference.

Parameters:
<Frequency> 10MHZ | VARiable | 1GHZ | 100MHZ | 8GHZ | 640MHZ

*RST: n.a. (factory preset: 10MHZ)
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Example: See Example "Configuring the reference oscillator" on page 500.

Options: R&S SFI-K703, R&S SFI-K704, R&S SFI-K708

Manual operation: See "External Reference Frequency" on page 208

[:SOURce]:ROSCillator:EXTernal:FREQuency:VARiable <Frequency>

Specifies the user-defined external reference frequency.

Parameters:
<Frequency> float

Range: 1E6  to  100E6
Increment: 0.1
*RST: n.a. (factory preset: 1E7)
Default unit: Hz

Example: See Example "Configuring the reference oscillator" on page 500.

Manual operation: See "Variable Reference Frequency" on page 208

[:SOURce]:ROSCillator:EXTernal:MLRange?

Queries the minimum locking range for the selected external reference frequency.

Depending on the RF hardware version, and the installed options, the minimum locking
range vaies.

For more information, refer to the specifications document.

Return values: 
<MinLockRange> string

Example: SOUR:ROSC:EXT:MLR?
Usage: Query only

Manual operation: See "Minimum Locking Range" on page 209

[:SOURce]:ROSCillator:EXTernal:NSBandwidth?

Queries the nominal synchronization bandwidth for the selected external reference fre-
quency and synchronization bandwidth.

Return values: 
<NomBandwidth> string

Example: SOUR:ROSC:EXT:NSB?
Usage: Query only

Manual operation: See "Nominal Synchronization Bandwidth" on page 209
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[:SOURce]:ROSCillator:EXTernal:RFOFf[:STATe] <State>

Determines that the RF output is turned off when the external reference signal is
selected, but missing.

Parameters:
<State> 1 | ON | 0 | OFF

*RST: n.a. (factory preset: 0)

Example: See Example "Configuring the reference oscillator" on page 500.

Manual operation: See "Deactivate RF Output (if external reference is missing)"
on page 208

[:SOURce]:ROSCillator:EXTernal:SBANdwidth <SBandwidth>

Selects the synchronization bandwidth for the external reference signal.

Depending on the RF hardware version and the installed options, the synchronization
bandwidth varies.

For more information, refer to the specifications document.

Parameters:
<SBandwidth> WIDE | NARRow

NARRow
The synchronization bandwidth is a few Hz.
WIDE
Uses the widest possible synchronization bandwidth.
*RST: n.a. (factory preset: WIDE)

Example: See Example "Configuring the reference oscillator" on page 500.

Manual operation: See "Synchronization Bandwidth" on page 209

[:SOURce]:ROSCillator:OUTPut:FREQuency:MODE <OutpFreqMode>

Selects the mode for the reference frequency output 1.

Parameters:
<OutpFreqMode> DER10M | DER100M | OFF | LOOPthrough

OFF
Disables the output.
DER10M|DER100M
Sets the output reference frequency to 10 MHz, or 100 MHz.
The reference frequency is derived from the internal reference
frequency.
LOOPthrough
Forwards the signal from reference input 1 to the reference fre-
quency output.
This setting is not availabe for
ROSCillator:EXTernal:FREQuency 640MHz|1GHZ|8GHz.
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*RST: n.a. (factory preset: DER10M)

Example: See Example "Configuring the reference oscillator" on page 500.

Manual operation: See "Reference Output" on page 210

[:SOURce]:ROSCillator:OUTPut2:FREQuency:MODE <OutpFreqMode>

Selects the mode for the reference frequency output 2.

Parameters:
<OutpFreqMode> OFF | DER1G | LOOPthrough | DER8G

OFF
Disables the output.
DER1G|DER8G
Sets the output reference frequency to 1 GHz, or 8 GHz.
The reference frequency is derived from the internal reference
frequency.
LOOPthrough
Forwards the signal from reference input 2 to the reference fre-
quency output.
Loop through is not availabe for
ROSCillator:EXTernal:FREQuency 10MHz|100M.
*RST: n.a. (factory preset: OFF)

Example: See Example "Configuring the reference oscillator" on page 500.

Manual operation: See "Reference Output" on page 210

[:SOURce]:ROSCillator:OUTPut3:FREQuency:MODE <Rosc16GOutpFreq>

Selects the mode for the reference frequency output 3.

Parameters:
<Rosc16GOutpFreq> OFF | DER16G

OFF
Disables the output.
DER16G
Sets the output reference frequency to 16 GHz.
The reference frequency is derived from the internal reference
frequency.
*RST: n.a. (factory preset: OFF)

Example: See Example "Configuring the reference oscillator" on page 500.

Manual operation: See "Reference Output" on page 210

[:SOURce]:ROSCillator:PRESet

Resets the reference oscillator settings.
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Example: See Example "Configuring the reference oscillator" on page 500.

Usage: Event

Manual operation: See "Set to Default" on page 207

[:SOURce]:ROSCillator:SOURce <Source>

Selects between internal or external reference frequency.

Parameters:
<Source> INTernal | EXTernal

*RST: n.a. (factory preset: INTernal)

Example: See Example "Configuring the reference oscillator" on page 500.

Manual operation: See "Source" on page 207

[:SOURce]:ROSCillator[:INTernal]:ADJust[:STATe] <State>

Determines whether the calibrated (off) or a user-defined (on) adjustment value is
used for fine adjustment of the frequency.

Parameters:
<State> 1 | ON | 0 | OFF

0
Fine adjustment with the calibrated frequency value
1
User-defined adjustment value.
The instrument is no longer in the calibrated state.
The calibration value is, however, not changed. The instrument
resumes the calibrated state if you send
SOURce:ROSCillator:INTernal:ADJust:STATe 0.
*RST: n.a. (factory preset: 0)

Manual operation: See "Adjustment Active" on page 211

[:SOURce]:ROSCillator[:INTernal]:ADJust:VALue <Value>

Specifies the frequency correction value (adjustment value).

Parameters:
<Value> integer

*RST: 0

Example: See [:SOURce]:ROSCillator[:INTernal]:ADJust[:
STATe] on page 504

Manual operation: See "Adjustment Value" on page 211
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13.15.9  SOURce:POWer subsystem

The SOURce:POWer subsystem contains the commands for setting the output level,
level control and level correction of the RF signal.

The default units are dBm. To change the units, perform one of the following:
● Enter the unit after the numerical value

Example: :POW 0.5V
● Set the unit with the command :UNIT:POWer.

Example: Power configuration

SOURce1:POWer;CW? 
// Response -30
SOURce1:POWer:CW -25
SOURce1:POWer:OFFSet?
// Response 0
SOURce1:POWer:OFFSet 2

SOURce1:POWer:STEP:MODE?
// Response: DEC
SOURce1:POWer:STEP:INCRement 2
SOURce1:POWer:CW UP

Example: Configure the settings for NRP power control
The example shows a command sequence to configure the parameters for a closed
loop power control setup. It is assumed that you have set up the measurement with the
amplifier, external coupler, the power sensor and the R&S SFI100A as described in
Chapter 7.5.4, "NRP power control", on page 216.

// Reset the instrument to start from an initial state
*RST; *CLS

// Select the sensor used for nrp power control
// that is e.g., connected to a second USB interface

SOURce1:POWer:SPC:SELect SENS2

// Configure the nrp power control settings 
// use the measured peak power for power control
// set the unit dBm for the target level value
// set the target level, e.g. - 10 dBmM
// use the measured target level as reference level
// select single measurement mode to acquire one level value
// set the capture range for the control loop, e.g.  +/- 15 dB 
// set a time delay between the sensor readings, e.g. 2 ms

SOURce1:POWer:SPC:PEAK ON
SENSe1:UNIT:POWer DMB
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SOURce1:POWer:SPC:TARGet -10
SOURce1:POWer:SPC:MEASure
SOURce1:POWer:SPC:MODE SINGle
SOURce1:POWer:SPC:CRANge 15
SOURce1:POWer:SPC:DELay 2 ms

// Enable NRP power control measurement
// switch on RF output
// start the single measurement manually

Output1:STATe 1
SOURce1:POWer:SPC:STATe ON
SOURce1:POWer:SPC:SINGle

// Query if the power control works properly
:SOURce1:POWer:SPC:WARNing?
// Response: 1 -> power conrol doew not work as expected

[:SOURce<hw>]:POWer:EMF:STATe................................................................................506
[:SOURce<hw>]:POWer:LBEHaviour............................................................................... 507
[:SOURce<hw>]:POWer:LIMit[:AMPLitude].......................................................................507
[:SOURce<hw>]:POWer:MODE.......................................................................................507
[:SOURce<hw>]:POWer:PEP?........................................................................................ 508
[:SOURce<hw>]:POWer:POWer......................................................................................508
[:SOURce<hw>]:POWer:SPC:CRANge............................................................................ 509
[:SOURce<hw>]:POWer:SPC:DELay............................................................................... 509
[:SOURce<hw>]:POWer:SPC:MEASure........................................................................... 509
[:SOURce<hw>]:POWer:SPC:MODE............................................................................... 509
[:SOURce<hw>]:POWer:SPC:PEAK................................................................................ 510
[:SOURce<hw>]:POWer:SPC:SELect.............................................................................. 510
[:SOURce<hw>]:POWer:SPC:SINGle.............................................................................. 510
[:SOURce<hw>]:POWer:SPC:STATe................................................................................510
[:SOURce<hw>]:POWer:SPC:TARGet..............................................................................511
[:SOURce<hw>]:POWer:SPC:WARNing?......................................................................... 511
[:SOURce<hw>]:POWer:STEP:MODE..............................................................................511
[:SOURce<hw>]:POWer:STEP[:INCRement].................................................................... 512
[:SOURce<hw>]:POWer[:LEVel][:IMMediate]:OFFSet........................................................ 512
[:SOURce<hw>]:POWer[:LEVel][:IMMediate]:RCL............................................................. 512
[:SOURce<hw>]:POWer[:LEVel][:IMMediate][:AMPLitude]..................................................513
[:SOURce<hw>]:POWer[:LEVel][:IMMediate]:REFLevel..................................................... 514
[:SOURce<hw>]:POWer:RANGe:LOWer?........................................................................ 514
[:SOURce<hw>]:POWer:RANGe:UPPer?......................................................................... 514
[:SOURce]:POWer:WIGNore...........................................................................................514

[:SOURce<hw>]:POWer:EMF:STATe <State>

Displays the signal level as voltage of the EMF. The displayed value represents the
voltage over a 50 Ohm load.
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Parameters:
<State> 1 | ON | 0 | OFF

*RST: n.a. (factory preset: 0)

Example: POW:EMF:STAT 1
Activates voltage level display.

[:SOURce<hw>]:POWer:LBEHaviour <Behaviour>

Set the RF level behaviour.

Parameters:
<Behaviour> AUTO | UNINterrupted

UNINterrupted
Do not use the uninterrupted level settings in combination with
the high-quality optimization mode (see [:SOURce<hw>]:BB:
IMPairment:OPTimization:MODE on page 576)
*RST: AUTO

Example: SOURce1:POWer:LBEHaviour AUTO

Manual operation: See "Setting Characteristics" on page 204

[:SOURce<hw>]:POWer:LIMit[:AMPLitude] <Amplitude>

Limits the maximum RF output level in CW and sweep mode.

It does not influence the "Level" display or the response to the query [:
SOURce<hw>]:POWer[:LEVel][:IMMediate][:AMPLitude].

Parameters:
<Amplitude> float

Range: depends on the installed options
Increment: 0.01
*RST: n.a. (factory preset: 30)

Example: SOURce1:POWer:LIMit:AMPLitude 10

Manual operation: See "Limit" on page 203

[:SOURce<hw>]:POWer:MODE <Mode>

Selects the operating mode of the instrument to set the output level.
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Parameters:
<Mode> CW | FIXed | SWEep

CW|FIXed
Operates at a constant level.
CW and FIXed are synonyms.
To set the output level value, use the command [:
SOURce<hw>]:POWer[:LEVel][:IMMediate][:
AMPLitude].
*RST: CW

Example: See Example "Power configuration" on page 505.

[:SOURce<hw>]:POWer:PEP?

Queries the PEP "Peak Envelope Power) of digital modulation or digital standards at
the RF output. This value corresponds to the level specification, displayed in the status
bar (header).

Return values: 
<Pep> float

Example: POW:PEP?
Response: "4"
The PEP value of digital modulation is 4 dBm at the RF output.

Usage: Query only

Manual operation: See "PEP" on page 200

[:SOURce<hw>]:POWer:POWer <Power>

Sets the level at the RF output connector.

This value does not consider a specified offset.

The command [:SOURce<hw>]:POWer[:LEVel][:IMMediate][:AMPLitude]
sets the level of the "Level" display, that means the level containing offset.

Parameters:
<Power> float

Level at the RF output, without level offset
Range: See specifications document.
Increment: 0.01
Default unit: dBm

Example: SOURce1:POWer:POWer 15
// sets the level at the RF output.

Manual operation: See "Amplitude" on page 203
See "Generator Settings used for Measurement" on page 239

SOURce subsystem



Remote control commandsR&S®SFI100A

509User Manual 1179.6789.02 ─ 02

[:SOURce<hw>]:POWer:SPC:CRANge <PowCntrlCRange>

Defines the capture range of the power control system.

Within the range:

Target Level +/- Catch Range

the power control locks and tries to achieve the target level. Readings outside the
range are not considered.

Parameters:
<PowCntrlCRange> float

Range: 0  to  50
Increment: 0.01
*RST: 30

Example: See Example "Configure the settings for NRP power control"
on page 505

Manual operation: See "Catch Range +/-" on page 219

[:SOURce<hw>]:POWer:SPC:DELay <PowCntrlDelay>

Sets a waiting time for the generator to adjust the output level. After the delay time has
elapsed, the power sensor measures the next value.

Parameters:
<PowCntrlDelay> integer

Range: 0  to  1000
*RST: 0

Example: See Example "Configure the settings for NRP power control"
on page 505

Manual operation: See "Delay Time" on page 220

[:SOURce<hw>]:POWer:SPC:MEASure

Sets the measured power value as reference level.

Example: See Example "Configure the settings for NRP power control"
on page 505

Usage: Event

Manual operation: See "Take Measurement as Target Level" on page 219

[:SOURce<hw>]:POWer:SPC:MODE <ControlMode>

Selects the measurement mode for the power sensor.

Parameters:
<ControlMode> AUTO | SINGle
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AUTO
Measures the level values continuously.
SINGle
Executes one measurement, triggered by the command [:
SOURce<hw>]:POWer:SPC:SINGle on page 510.
*RST: AUTO

Example: See Example "Configure the settings for NRP power control"
on page 505

Manual operation: See "Mode" on page 219

[:SOURce<hw>]:POWer:SPC:PEAK <PowCntrlPeak>

Activates power control by means of the peak power values, provided the power sen-
sor supports this function.

Parameters:
<PowCntrlPeak> 1 | ON | 0 | OFF

*RST: 0

Example: See Example "Configure the settings for NRP power control"
on page 505

[:SOURce<hw>]:POWer:SPC:SELect <PowCntrlSelect>

Selects the power sensor used for power control.

Parameters:
<PowCntrlSelect> SENS1 | SENS2 | SENS3 | SENS4 | SENSor1 | SENSor2 |

SENSor3 | SENSor4
*RST: SENS1

Example: See Example "Configure the settings for NRP power control"
on page 505

Manual operation: See "Sensor" on page 218

[:SOURce<hw>]:POWer:SPC:SINGle

Triggers the power sensor to measure the power value once.

Usage: Event

Manual operation: See "Execute Single" on page 219

[:SOURce<hw>]:POWer:SPC:STATe <PowCntrlState>

Starts power control using the selected sensor. The control loop periodically adjusts
the output level of the signal generator. After switching off, the running loop is comple-
ted.
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Parameters:
<PowCntrlState> 1 | ON | 0 | OFF

*RST: 0

Example: See Example "Configure the settings for NRP power control"
on page 505

Manual operation: See "State" on page 218

[:SOURce<hw>]:POWer:SPC:TARGet <PowCntrlTarget>

Sets the target level required at the DUT. To define the unit of the power value, use
command :UNIT:POWer on page 613.

Parameters:
<PowCntrlTarget> float

Range: -50  to  30
Increment: 0.01
*RST: -10

Example: See Example "Configure the settings for NRP power control"
on page 505

Manual operation: See "Target Level" on page 219

[:SOURce<hw>]:POWer:SPC:WARNing?

Queries if the activated power control works properly.

If the power control does not work, the query returns warning state 1. On the screen,
the R&S SFI100A indicates a warning icon.

Return values: 
<WarningState> 1 | ON | 0 | OFF

*RST: 0

Example: See Example "Configure the settings for NRP power control"
on page 505.

Usage: Query only

[:SOURce<hw>]:POWer:STEP:MODE <Mode>

Defines the type of step width to vary the RF output power step-by-step with the com-
mands POW UP or POW DOWN.

Parameters:
<Mode> DECimal | USER

DECimal
Increases or decreases the level in steps of ten.
*RST: DECimal

Example: See Example "Power configuration" on page 505.
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Manual operation: See "Variation Active" on page 204

[:SOURce<hw>]:POWer:STEP[:INCRement] <Increment>

Specifies the step width in the appropriate path for POW:STEP:MODE USER.

To adjust the level step-by-step with this increment value, use the command POW UP,
or POW DOWN.

Parameters:
<Increment> float

Range: 0  to  200
Increment: 0.01
*RST: 1
Default unit: dB

Example: See Example "Power configuration" on page 505.

Manual operation: See "Variation Step" on page 204

[:SOURce<hw>]:POWer[:LEVel][:IMMediate]:OFFSet <Offset>

Sets the level offset of a downstream instrument.

The level at the RF output is not changed.

To query the resulting level, as it is at the output of the downstream instrument, use the
command [:SOURce<hw>]:POWer[:LEVel][:IMMediate][:AMPLitude].

Note: The level offset also affects the RF level sweep.

Parameters:
<Offset> float

Range: -200 to 200
Increment: 0.01
*RST: 0
Default unit: dB
Level offset is always expreced in dB; linear units (V, W, etc.) are
not supported

Example: POWer:OFFSet 10
Sets the RF level offset to 10 dB

Manual operation: See "Offset" on page 203
See "Generator Settings used for Measurement" on page 239

[:SOURce<hw>]:POWer[:LEVel][:IMMediate]:RCL <Rcl>

Determines whether the current level is retained or if the stored level setting is adopted
when an instrument configuration is loaded.

Parameters:
<Rcl> INCLude | EXCLude
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INCLude
Takes the current level when an instrument configuration is loa-
ded.
EXCLude
Retains the current level when an instrument configuration is
loaded.
*RST: INCLude

Example: POW:RCL INCL
Takes the level value from an instrument configuration loaded
with command *RCL.

Manual operation: See "Exclude Level" on page 281

[:SOURce<hw>]:POWer[:LEVel][:IMMediate][:AMPLitude] <Amplitude>

Sets the RF level applied to the DUT.

To activate the RF output use command :OUTPut<hw>[:STATe] ("RF On"/"RF Off").

The following applies POWer = RF output level + OFFSet, where:
● POWer is the values set with [:SOURce<hw>]:POWer[:LEVel][:

IMMediate][:AMPLitude]
● RF output level is set with [:SOURce<hw>]:POWer:POWer
● OFFSet is set with [:SOURce<hw>]:POWer[:LEVel][:IMMediate]:OFFSet
Parameters:
<Amplitude> float

The following settings influence the value range:
OFFSet set with the command [:SOURce<hw>]:POWer[:
LEVel][:IMMediate]:OFFSet
Numerical value
Sets the level
UP|DOWN
Varies the level step by step.
The level is increased or decreased by the value set with the
command [:SOURce<hw>]:POWer:STEP[:INCRement].
Range: (Level_min + OFFSet) to (Level_max + OFFStet)
*RST: -30
Default unit: dBm

Example: POWer -30
Sets the RF level

Example: See also [:SOURce<hw>]:POWer:STEP:MODE on page 511.

Manual operation: See "Amplitude" on page 203
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[:SOURce<hw>]:POWer[:LEVel][:IMMediate]:REFLevel <ReferenceLevel>

Queries the reference level of the user correction.

The reference level is the sum of the amplitude and the level offset, set with the com-
mands [:SOURce<hw>]:POWer:POWer [:SOURce<hw>]:POWer[:LEVel][:
IMMediate]:OFFSet.

Parameters:
<ReferenceLevel> float

Range: -245  to  120
Increment: 0.01
*RST: -30

Manual operation: See "Generator Settings used for Measurement" on page 239

[:SOURce<hw>]:POWer:RANGe:LOWer?
[:SOURce<hw>]:POWer:RANGe:UPPer?
Queries the current interruption-free range of the level.

Return values: 
<Upper> float

Increment: 0.01
Default unit: dBm

Example: SOURce1:POWer:RANGe:UPPer?
// -15
SOURce1:POWer:RANGe:LOW?
// -50

Usage: Query only

Manual operation: See "Level Range" on page 204

[:SOURce]:POWer:WIGNore <State>

Ignores level range warnings.

Parameters:
<State> 1 | ON | 0 | OFF

*RST: n.a. (factory preset: 0)

Example: SOURce:POWer:WIGNore 1

13.15.10  SOURce:EFRontend subsystem

The SOURce:EFRontend subsystem contains the commands for configuring settings
of an RF frontend.
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Example: Configuring external frontend connection settings
// Query information about the connected RF frontend.
SOURce1:EFRontend:INFO?
// Response: <SymbolicName> "FE170ST-123456", <RemoteChannel> "Frontend Connection"
// <IpAddress>/<HostName> "FE170ST-123456",<ConnectionState> "connected"
// Query all connected external frontends, including equipped options:
SOURce1:EFRontend:LIST?
// Response: "FE170ST-123456"
SOURce1:EFRontend:IDN?
// Response: "Rohde&Schwarz,FE170ST,1234.5678K00/123456,1.34.6"

// Specify and query frontend connection settings.
SOURce1:EFRontend:RFConnector? 
// Response: "RFA"
SOURce1:EFRontend:CMODe?
// Response: "AUTO"
SOURce1:EFRontend:FREQuency:REFerence:LIST?
// Response: "10 MHz,640 MHz,1 GHz"
SOURce1:EFRontend:FREQuency:REFerence F1G
// Sets 1 GHz reference frequency.

Example: Configuring external frontend frequency bands
// Load a frequency band configuration.
SOURce1:EFRontend:FREQuency:BAND1:CONFig:CATalog?
// Response: "SFI"
// Query the corresponding intermediate frequency at the RF output of the R&S SFI100A.
SOURce1:EFRontend:FREQuency:IFRequency:VALue?
// Response in Hz: "16000000000" (= 16 GHz)

// Query information about operating frequency bands.
SOURce1:EFRontend:FREQuency:BAND:COUNt?
// Response: "1"
// The frontend operates in one frequency band.
// Query the range of the operating frequency band.
SOURce1:EFRontend:FREQuency:BAND1:LOWer?
// Response in Hz: "110000000000" (= 11 GHz)
SOURce1:EFRontend:FREQuency:BAND1:UPPer?
// Response in Hz: "175000000000" (= 17.5 GHz)

Example: Configuring LO settings with multiple external frontends
// Set R&S FE170ST to provide the LO signal  
SOURce1:EFRontend:LOSCillator:MODE INTernal
SOURce1:EFRontend:LOSCillator:OUTPut:STATe 1
// Query the LO out frequency
SOURce1:EFRontend:LOSCillator:OUTPut:FREQuency?
// Response in Hz: "15750000000" 
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Example: Configuring external frontend attenuation
// Configure attenuation settings.
SOURce1:EFRontend:AMODe?
// Response: "AUTO"
SOURce1:EFRontend:AMODe MANual
SOURce1:EFRontend:POWer:ATTenuation 10
// Sets an attenuation of 10 dB.

Example: Configuring external frontend cable correction
// Query available cable correction files.
SOURce1:EFRontend:ALIGnment:FILE:CATalog?
// Response: "CableCorrIF"
// Add cable correction data by loading the file CableCorrIF.s2p.
SOURce1:EFRontend:ALIGnment:FILE:SELect CableCorrIF
// Query upper and lower frequency range of the IF correction data.
SOURce1:EFRontend:ALIGnment:FILE:FREquency:RANGe:LOWer?
// Response in Hz: "11000000000" (11 GHz)
SOURce1:EFRontend:ALIGnment:FILE:FREquency:RANGe:UPPer?
// Response in Hz: "21000000000" (21 GHz)
SOURce1:EFRontend:ALIGnment:STATe 1

Example: Calibrating external frontends
// Start a calibration procedure performing internal adjustments
// at the external frontend.
SOURce1:EFRontend:CAL:ALL
// Query the calibration state.
CALibration1:FREQuency:CONVerter:EXTernal?
// Response: "1"
// The external frontend is calibrated.

Example: Configuring external frontend network parameters
// Search for your external frontend in the network.
SOURce1:EFRontend:INFO?
// Response: <SymbolicName> "FE170ST-123456", <RemoteChannel> "Frontend Connection"
// <IpAddress>/<HostName> "10.123.45.67",<ConnectionState> "not connected"
SOURce1:EFRontend:NETWork?
// Response: <IpAddress> "10.123.45.67",<SubnetMask> "255.255.255.0",<DhcpOn> "1"
// Alternatively, query the IP address directly.
SOURce1:EFRontend:IPADdress?
// Response: "10.123.45.67"
// Switch off DHCP and assign an IP address manually.
SOURce1:EFRontend:NETWork "192.168.0.1","255.255.255.0","0"
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Example: Querying external devices connected to an external frontend
// Refresh the connected external devices.
SOURce1:EFRontend:EXTDevice:REFResh
// Query a list of connected external devices:
SOURce1:EFRontend:EXTDevice:LIST?
// Response:"FE170_Z50,FE170_Z01"
// Query the information regarding External Device 1:
// Query the name of the connected external device:
SOURce1:EFRontend:EXTDevice1:NAME?
// Response: "FE170_Z50"
//Query the type of the connected external device:
SOURce1:EFRontend:EXTDevice1:TYPE?
// Response: AMPL
// Query the frequency range of the connected external device:
SOURce1:EFRontend:EXTDevice1:FREQuency:MINimum?
// Response: 110000000000
SOURce1:EFRontend:EXTDevice1:FREQuency:MAXimum?
// Response: 170000000000
// Since the connected external device is an amplifier, query the gain:
SOURce1:EFRontend:EXTDevice1:GAIN?
// Response: 10

Commands:

[:SOURce<hw>]:EFRontend:ALIGnment:FILE:FREQuency:RANGe:LOWer?....................... 518
[:SOURce<hw>]:EFRontend:ALIGnment:FILE:FREQuency:RANGe:UPPer?........................518
[:SOURce<hw>]:EFRontend:ALIGnment:FILE:CATalog?....................................................518
[:SOURce<hw>]:EFRontend:ALIGnment:FILE[:SELect]..................................................... 518
[:SOURce<hw>]:EFRontend:ALIGnment[:STATe].............................................................. 519
[:SOURce<hw>]:EFRontend:AMODe............................................................................... 519
[:SOURce<hw>]:EFRontend:CAL:ALL..............................................................................519
[:SOURce<hw>]:EFRontend:CONNection:STATe.............................................................. 519
[:SOURce<hw>]:EFRontend:CMODe...............................................................................520
[:SOURce<hw>]:EFRontend:FREQuency:BAND:COUNt?..................................................520
[:SOURce<hw>]:EFRontend:FREQuency:BAND:CONFig:CATalog?....................................520
[:SOURce<hw>]:EFRontend:FREQuency:BAND:CONFig:MODE........................................521
[:SOURce<hw>]:EFRontend:FREQuency:BAND:CONFig:SELect....................................... 521
[:SOURce<hw>]:EFRontend:FREQuency:BAND<ch>:LOWer?........................................... 521
[:SOURce<hw>]:EFRontend:FREQuency:BAND<ch>:UPPer?............................................521
[:SOURce<hw>]:EFRontend:FREQuency:REFerence........................................................522
[:SOURce<hw>]:EFRontend:FREQuency:REFerence:LIST?.............................................. 522
[:SOURce<hw>]:EFRontend:IDN?................................................................................... 522
[:SOURce<hw>]:EFRontend[:FREQuency]:IFRequency[:VALue]?.......................................522
[:SOURce<hw>]:EFRontend:FREQuency:IFRequency:SIDeband?......................................523
[:SOURce<hw>]:EFRontend:INFO?................................................................................. 523
[:SOURce<hw>]:EFRontend:IPADdress?..........................................................................523
[:SOURce<hw>]:EFRontend:LIST?.................................................................................. 523
[:SOURce<hw>]:EFRontend:NETWork.............................................................................524
[:SOURce<hw>]:EFRontend:OPT?.................................................................................. 524
[:SOURce<hw>]:EFRontend:POWer:ATTenuation............................................................. 524
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[:SOURce<hw>]:EFRontend:POWer:OFFSet....................................................................525
[:SOURce<hw>]:EFRontend:RFConnector....................................................................... 525
[:SOURce<hw>]:EFRontend:EXTDevice:REFResh............................................................525
[:SOURce<hw>]:EFRontend:EXTDevice:LIST?.................................................................526
[:SOURce<hw>]:EFRontend:EXTDevice<id>:NAME?........................................................ 526
[:SOURce<hw>]:EFRontend:EXTDevice<id>:TYPE?......................................................... 526
[:SOURce<hw>]:EFRontend:EXTDevice<id>:FREQuency:MINimum?................................. 527
[:SOURce<hw>]:EFRontend:EXTDevice<id>:FREQuency:MAXimum?................................ 527
[:SOURce<hw>]:EFRontend:EXTDevice<id>:GAIN?..........................................................527
[:SOURce<hw>]:EFRontend:EXTDevice:CORRection:STATe............................................. 527
[:SOURce<hw>]:EFRontend:EXTDevice:CORRection:FILE................................................527
[:SOURce<hw>]:EFRontend:LOSCillator:MODE............................................................... 528
[:SOURce<hw>]:EFRontend:LOSCillator:OUTPut:STATe................................................... 528
[:SOURce<hw>]:EFRontend:LOSCillator:INPut:FREQuency?.............................................528
[:SOURce<hw>]:EFRontend:LOSCillator:OUTPut:FREQuency?......................................... 528

[:SOURce<hw>]:EFRontend:ALIGnment:FILE:FREQuency:RANGe:LOWer?
[:SOURce<hw>]:EFRontend:ALIGnment:FILE:FREQuency:RANGe:UPPer?
Queries the upper/lower frequency range of IF values required at the connected exter-
nal frontend.

We recommend that you cover this range in the cable correction *.s2p file.

Return values: 
<CableCorrFreqUp> float

Example: See Example "Configuring external frontend cable correction"
on page 516.

Usage: Query only

Manual operation: See "Recommended Frequency Range" on page 192

[:SOURce<hw>]:EFRontend:ALIGnment:FILE:CATalog?

Queries the cable correction files with settings in the default directory.

Listed are cable correction files with extension *.s2p or *.uco.

Example: See Example "Configuring external frontend cable correction"
on page 516.

Usage: Query only

Manual operation: See "Load Cable Correction File" on page 191

[:SOURce<hw>]:EFRontend:ALIGnment:FILE[:SELect] <CableCorrFileNa>

Selects an existing correction file to compensate for cable losses. Selectable file have
file extension *.s2p.

Parameters:
<Filename> string
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Example: See Example "Configuring external frontend cable correction"
on page 516.

Manual operation: See "Load Cable Correction File" on page 191

[:SOURce<hw>]:EFRontend:ALIGnment[:STATe] <CableCorrState>

Activates correction of the IF signal for different IF signal frequencies.

Parameters:
<CableCorrState> 1 | ON | 0 | OFF

*RST: 0

Example: See Example "Configuring external frontend cable correction"
on page 516.

Manual operation: See "State" on page 191

[:SOURce<hw>]:EFRontend:AMODe <AttenuationMode>

Sets the attenuator mode of the external frontend.

Parameters:
<AttenuationMode> AUTO | MANual | AOFFset

AUTO
Sets the attenuation value automatically to the attenuation value
provided from the connected external frontend.
MANual
Sets an attenuation value manually.
AOFFset
Requires frontend R&S FE170ST or R&S FE110ST.
You can define an offset value which is added to the attenuation
value provided from the connected external frontend.
*RST: AUTO

Example: See Example "Configuring external frontend attenuation"
on page 516.

Manual operation: See "Mode" on page 190

[:SOURce<hw>]:EFRontend:CAL:ALL

Starts all internal calibration routines to adjust the connected external frontend.

Example: See Example "Calibrating external frontends" on page 516

Usage: Event

[:SOURce<hw>]:EFRontend:CONNection:STATe <ConnState>

Queries the state of the connection between R&S SFI100A and external frontend.
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Parameters:
<ConnState> 1 | ON | 0 | OFF

*RST: 0

Example: See Example "Configuring external frontend connection set-
tings" on page 515.

[:SOURce<hw>]:EFRontend:CMODe <FeConnMode>

Sets the mode of the SSL control connection between R&S SFI100A and external fron-
tend.

Parameters:
<FeConnMode> AUTO | LOCK | RXTX

AUTO
The R&S SFI100A locks external frontend, when activating the
RF output at the R&S SFI100A (:OUTPut1 ON ) for output of
the IF signal.
The R&S SFI100A unlocks external frontend, when deactivating
the RF output at the R&S SFI100A (:OUTPut1 OFF).
LOCK
The external frontend is locked permanently. No other instru-
ment can take over control.
RXTX
Not available for R&S SFI100A (grayed out).

Example: See Example "Configuring external frontend connection set-
tings" on page 515

Manual operation: See "Connection Mode" on page 186

[:SOURce<hw>]:EFRontend:FREQuency:BAND:COUNt?

Queries the number of frequency bands available at the connected external frontend.

Return values: 
<FEFreqCount> integer

Example: See Example "Configuring external frontend frequency bands"
on page 515

Usage: Query only

Manual operation: See "Frequency Band x" on page 188

[:SOURce<hw>]:EFRontend:FREQuency:BAND:CONFig:CATalog? <CatalogFiles>

Queries the selectable frequency band configuration modes.
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Parameters:
<CatalogFiles> string

Returns a string of selectable frequency band configuration
modes separated by commas.

Example: See Example "Configuring external frontend frequency bands"
on page 515

Usage: Query only

Manual operation: See "Frequency Band Config" on page 187

[:SOURce<hw>]:EFRontend:FREQuency:BAND:CONFig:MODE <Mode>

Sets the mode for frequency band configuration of the external frontend.

Parameters:
<Mode> AUTO | MANual

AUTO
Configures the frequency band automatically.
MANual
Uses the frequency band configured by [:SOURce<hw>]:
EFRontend:FREQuency:BAND:CONFig:SELect
on page 521.
*RST: AUTO

Manual operation: See "Mode" on page 187

[:SOURce<hw>]:EFRontend:FREQuency:BAND:CONFig:SELect <SelBandConfig>

Selects the frequency band configuration for the connected external frontend.

Parameters:
<SelBandConfig> string

Example: See Example "Configuring external frontend frequency bands"
on page 515

Manual operation: See "Frequency Band Config" on page 187

[:SOURce<hw>]:EFRontend:FREQuency:BAND<ch>:LOWer?
[:SOURce<hw>]:EFRontend:FREQuency:BAND<ch>:UPPer?
Queries the lower/upper limit of the corresponding frequency band.

Return values: 
<FEFreqBandUp> float

Example: See Example "Configuring external frontend frequency bands"
on page 515

Usage: Query only

Manual operation: See "Frequency Band x" on page 188
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[:SOURce<hw>]:EFRontend:FREQuency:REFerence <FERefFreq>

Sets the reference frequency, that is used for RF frequency conversion at the connec-
ted external frontend.

Parameters:
<FERefFreq> FG64 | F1G | F10M

FG64
640 MHz
F1G
1 GHz
F10M
10 MHz

Example: See Example "Configuring external frontend connection set-
tings" on page 515.

Manual operation: See "Reference Frequency" on page 186

[:SOURce<hw>]:EFRontend:FREQuency:REFerence:LIST?

Queries reference frequencies of connected RF frontends in a comma-separated list.

Example: See Example "Configuring external frontend connection set-
tings" on page 515.

Usage: Query only

Manual operation: See "Reference Frequency" on page 186

[:SOURce<hw>]:EFRontend:IDN?

Identification

Returns the IDN string, i.e. the identification of the external frontend.

Return values: 
<IdnString> string

Example: See Example "Configuring external frontend connection set-
tings" on page 515.

Usage: Query only

Manual operation: See "Hardware Config" on page 189

[:SOURce<hw>]:EFRontend[:FREQuency]:IFRequency[:VALue]?

Queries the frequency of the IF signal, that is the frequency at the RF Out connector.

Return values: 
<IntFrequency> float
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Example: See Example "Configuring external frontend frequency bands"
on page 515.

Usage: Query only

Manual operation: See "Intermediate Frequency / Sideband" on page 187

[:SOURce<hw>]:EFRontend:FREQuency:IFRequency:SIDeband?

Queries the currently used sideband for frequency conversion.

Return values: 
<Sideband> string

USB
Upper sideband
LSB
Lower sideband

Usage: Query only

Manual operation: See "Intermediate Frequency / Sideband" on page 187

[:SOURce<hw>]:EFRontend:INFO?

Queries information about the connected external frontend.

Return values: 
<FEInfo> string

Example: See Example "Configuring external frontend connection set-
tings" on page 515.

Usage: Query only

[:SOURce<hw>]:EFRontend:IPADdress?

Queries the IP address of the connected external frontend.

Return values: 
<IPAddress> string

Example: See Example "Configuring external frontend network parame-
ters" on page 516.

Usage: Query only

Manual operation: See "IP Address" on page 193

[:SOURce<hw>]:EFRontend:LIST?

Queries connected external frontends in a comma-separated list.

Return values: 
<Filter> String
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Example: See Example "Configuring external frontend connection set-
tings" on page 515.

Usage: Query only

[:SOURce<hw>]:EFRontend:NETWork <IpAddress>, <SubnetMask>, <DhcpOn>

Sets network parameters of the external frontend.

Parameters:
<IpAddress> string

IP address of the external frontend
*RST: 127.0.0.1

<SubnetMask> string
Bit group of the subnet in the host identifier
*RST: 255.255.255.0

<DhcpOn> integer
DHCP state
Range: 0  to  1
*RST: 1

Example: See Example "Configuring external frontend network parame-
ters" on page 516.

Manual operation: See "Apply" on page 194

[:SOURce<hw>]:EFRontend:OPT?

Option identification query

Queries the options included in the external frontend.

For more information, refer to the specifications document.

Return values: 
<OptString> string

The query returns a list of options. The options are returned at
fixed positions in a comma-separated string. A zero is returned
for options that are not installed.

Usage: Query only

[:SOURce<hw>]:EFRontend:POWer:ATTenuation <Attenuation>

Requires [SOURce<hw>]:EFRontend:AMODe MANual.

Sets the attenuation of the external frontend.
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Parameters:
<Attenuation> float

Range: depends on connected device  to  depends on con-
nected device

Increment: depends on connected device
*RST: 0

Example: Example "Configuring external frontend attenuation"
on page 516

Manual operation: See "Attenuation" on page 190

[:SOURce<hw>]:EFRontend:POWer:OFFSet <Offset>

Requires frontend R&S FE170ST or R&S FE110ST.

Requires [SOURce<hw>]:EFRontend:AMODe AOFFset.

Adds an offset value to the attenuation value provided from the external frontend.

Parameters:
<Offset> float

Range: depends on connected device  to  depends on con-
nected device

Increment: depends on connected device
*RST: 0

Manual operation: See "Offset" on page 190

[:SOURce<hw>]:EFRontend:RFConnector <FEOutpPath>

Queries the active RF output connector at the connected RF frontend.

Parameters:
<FEOutpPath> NONE | RFA | RFB

NONE
No frontend connected.
RFA
Output connector "RF A" is active at the external frontend.
RFB
Output connector "RF B" is active at the external frontend.

Example: See Example "Configuring external frontend connection set-
tings" on page 515.

Manual operation: See "Active RF Connector" on page 187

[:SOURce<hw>]:EFRontend:EXTDevice:REFResh

Updates the external devices connected to the external frontend.
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Use this command before the query
[:SOURce<hw>]:EFRontend:EXTDevice:LIST?.

Example: See Example "Querying external devices connected to an exter-
nal frontend" on page 517.

Usage: Event

Manual operation: See "Refresh External Devices" on page 195

[:SOURce<hw>]:EFRontend:EXTDevice:LIST?

Queries the external devices connected to the external frontend in a comma-separated
list.

Example: See Example "Querying external devices connected to an exter-
nal frontend" on page 517.

Usage: Query only

Manual operation: See "Type" on page 195

[:SOURce<hw>]:EFRontend:EXTDevice<id>:NAME?

Queries the name of the connected external device.

Return values: 
<DeviceName> string

Example: See Example "Querying external devices connected to an exter-
nal frontend" on page 517.

Usage: Query only

Manual operation: See "Connected Device" on page 195

[:SOURce<hw>]:EFRontend:EXTDevice<id>:TYPE?

Queries the type of the connected external device.

Return values: 
<Type> FILTer | AMPLifier | ATTenuator | NONE

FILTer
A filter is connected to the frontend as external device.
AMPLifier
An amplifier is connected to the frontend as external device.
ATTenuator
An attenuator is connected to the frontend as external device.
NONE
No external device is connected to the frontend.

Example: See Example "Querying external devices connected to an exter-
nal frontend" on page 517.
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Usage: Query only

Manual operation: See "Type" on page 195

[:SOURce<hw>]:EFRontend:EXTDevice<id>:FREQuency:MINimum?
[:SOURce<hw>]:EFRontend:EXTDevice<id>:FREQuency:MAXimum?
Queries the maximum value of the frequency of the connected external device.

Example: See Example "Querying external devices connected to an exter-
nal frontend" on page 517.

Usage: Query only

Manual operation: See "Frequency Range" on page 195

[:SOURce<hw>]:EFRontend:EXTDevice<id>:GAIN?

Queries the gain of the amplifier connected as external device.

Return values: 
<Gain> float

*RST: n.a. (factory preset)

Example: See Example "Querying external devices connected to an exter-
nal frontend" on page 517.

Usage: Query only

Manual operation: See "Gain" on page 195

[:SOURce<hw>]:EFRontend:EXTDevice:CORRection:STATe <State>

Activates correction of the RF signal for different RF signal frequencies.

Activation requires loading of a valid correction file.

Parameters:
<State> 1 | ON | 0 | OFF

*RST: 0

Manual operation: See "State" on page 196

[:SOURce<hw>]:EFRontend:EXTDevice:CORRection:FILE <Filename>

Selects an existing correction file, e.g. to compensate for cable losses. Selectable files
have file extension *.s2p.

Parameters:
<Filename> string

Manual operation: See "Load Correction File" on page 196
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[:SOURce<hw>]:EFRontend:LOSCillator:MODE <Mode>

Selects the LO input source for the connected external frontend.

Parameters:
<Mode> INTernal | EXTernal

INTernal
Uses the internally generated LO signal.
EXTernal
Uses an externally supplied LO signal.
*RST: n.a. (factory preset: INTernal)

Example: See Example "Configuring LO settings with multiple external
frontends" on page 515.

Manual operation: See "Mode" on page 196

[:SOURce<hw>]:EFRontend:LOSCillator:OUTPut:STATe <OutState>

Activates or deactivates the LO output of the connected external frontend.

Parameters:
<OutState> 1 | ON | 0 | OFF

*RST: n.a. (factory preset: 0)

Example: See Example "Configuring LO settings with multiple external
frontends" on page 515.

Manual operation: See "Out State" on page 197

[:SOURce<hw>]:EFRontend:LOSCillator:INPut:FREQuency?

Requires [:SOURce<hw>]:EFRontend:LOSCillator:MODE EXTernal.

Queries the required frequency on the "LO In" connector of the connected external
frontend.

Return values: 
<LoInFreq> float

Example: See Example "Configuring LO settings with multiple external
frontends" on page 515.

Usage: Query only

Manual operation: See "Mandatory LO IN Frequency" on page 197

[:SOURce<hw>]:EFRontend:LOSCillator:OUTPut:FREQuency?

Requires [:SOURce<hw>]:EFRontend:LOSCillator:OUTPut:STATe 1.

Queries the current frequency on the "LO Out" connector of the connected external
frontend.
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Return values: 
<OutputFrequency> float

Example: See Example "Configuring LO settings with multiple external
frontends" on page 515.

Usage: Query only

Manual operation: See "LO OUT Frequency" on page 197

13.16  SOURce:BB subsystem

The SOURce:BB subsystem contains all commands for digital signal generation. It pro-
vides the following subsystems and commands.

● General commands...............................................................................................529
● SOURce:BB:ARBitrary subsystem........................................................................531
● SOURce:BB:GRAPhics subsystem...................................................................... 569
● SOURce:BB:IMPairment subsystem.....................................................................572
● SOURce:BB:PROGress subsystem......................................................................577

13.16.1  General commands

This section describes the commands for setting the frequency shift and the phase off-
set for the signal at the output of the "Baseband" block.

Commands:

[:SOURce<hw>]:BB:FOFFset..........................................................................................529
[:SOURce<hw>]:BB:POFFset..........................................................................................530
[:SOURce<hw>]:BB:ROUTe............................................................................................ 530
[:SOURce<hw>]:BB:CFACtor?.........................................................................................530
[:SOURce<hw>]:BB:POWer:PEAK?.................................................................................530
[:SOURce<hw>]:BB:POWer:RMS?.................................................................................. 531

[:SOURce<hw>]:BB:FOFFset <FOffset>

Sets a frequency offset for the internal or external baseband signal. The offset affects
the generated baseband signal.

Parameters:
<FOffset> float

Range: depends on the installed options
Increment: 0.01
*RST: 0
Default unit: Hz

Example: SOURce1:BB:FOFFset 2MHZ

Manual operation: See "Frequency Offset" on page 138
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[:SOURce<hw>]:BB:POFFset <POffset>

Sets the relative phase offset for the selected baseband signal.

Parameters:
<POffset> float

Range: 0  to  359.9
Increment: 0.01
*RST: 0
Default unit: DEG

Example: SOURce1:BB:POFFset 0.5DEG

Manual operation: See "Phase Offset" on page 139

[:SOURce<hw>]:BB:ROUTe <Route>

Selects the signal route for the baseband signal.

Parameters:
<Route> A

Example: SOURce1:BB:ROUTe A

[:SOURce<hw>]:BB:CFACtor?

Queries the crest factor of the baseband signal.

Return values: 
<CFactor> float

Range: 0  to  100
Increment: 0.01
*RST: 0
Default unit: dB

Example: SOURce1:BB:CFACtor?
Queries the crest factor of the baseband signal.

Usage: Query only

[:SOURce<hw>]:BB:POWer:PEAK?

Queries the peak level of the baseband signal relative to full scale of 0.5 V (in terms of
dB full scale).

Return values: 
<Peak> float

Range: -145  to  30
Increment: 0.01
*RST: 0
Default unit: dBfs
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Example: BB:POW:PEAK
Queries the peak level of the baseband signal.

Usage: Query only

[:SOURce<hw>]:BB:POWer:RMS?

Queries the RMS level of the baseband signal relative to full scale of 0.5V (in terms of
dB full scale).

Return values: 
<Rms> float

Range: -145  to  30
Increment: 0.01
*RST: 0
Default unit: dBfs

Example: BB:POW:RMS?
Queries the rms level of the baseband signal.

Usage: Query only

13.16.2  SOURce:BB:ARBitrary subsystem

This section list the commands of the SOURce:BB:ARBitrary subsystem.

Required options

See Chapter 4.3.1, "Required options", on page 64.

Commands:

● Programming examples........................................................................................ 532
● General commands...............................................................................................535
● Test signal commands...........................................................................................535
● Waveform commands........................................................................................... 539
● Multicarrier commands..........................................................................................543
● Trigger commands................................................................................................ 555
● Marker commands................................................................................................ 561
● Clock commands...................................................................................................563
● Crest factor reduction commands......................................................................... 563
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13.16.2.1  Programming examples

Example: To create test signals
This example provides the commands to configure the different test signals.
// *****************************************************************************
// Reset the instrument first.
// *****************************************************************************
*RST; *CLS
:SOURce1:BB:ARBitrary:PRESet

// *****************************************************************************
// Create test signals.
// *****************************************************************************
:SOURce1:BB:ARBitrary:SIGNal:TYPE CIQ
:SOURce1:BB:ARBitrary:TSIGnal:CIQ:I -0.5
:SOURce1:BB:ARBitrary:TSIGnal:CIQ:Q -0.33
:SOURce1:BB:ARBitrary:TSIGnal:CIQ:CREate

:SOURce1:BB:ARBitrary:TSIGnal:SINE:FREQuency 1MHz
:SOURce1:BB:ARBitrary:TSIGnal:SINE:SAMPles 100
:SOURce1:BB:ARBitrary:TSIGnal:SINE:PHASe -90
:SOURce1:BB:ARBitrary:TSIGnal:SINE:CREate:NAMed "/var/user/sine_test"

:SOURce1:BB:ARBitrary:TSIGnal:RECTangle:FREQuency 100kHz
:SOURce1:BB:ARBitrary:TSIGnal:RECTangle:SAMPles 1000
:SOURce1:BB:ARBitrary:TSIGnal:RECTangle:AMPLitude 0.5
:SOURce1:BB:ARBitrary:TSIGnal:RECTangle:OFFSet -0.3
:SOURce1:BB:ARBitrary:TSIGnal:RECTangle:CREate:NAMed "/var/user/rect_test"

:SOURce1:BB:ARBitrary:STATe ON

Example: To manage waveform files
The following example lists the commands provided for handling of waveform files.
// *****************************************************************************
// Reset instrument first
// *****************************************************************************
*RST; *CLS
:SOURce1:BB:ARBitrary:PRESet

// *****************************************************************************
// Set the default directory and list the available waveform files
// *****************************************************************************
MMEM:CDIR "/var/user/ARBtestSigs"
:SOURce1:BB:ARBitrary:WAVeform:CATalog? 
// sineTest,rectTest,ciqTestSignal,waveformTest,test2 
:SOURce1:BB:ARBitrary:WAVeform:CATalog:LENGth?
// Response is the number of files: "5"
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// Optionally query free disk space.
:SOURce1:BB:ARBitrary:WAVeform:FREE?

// *****************************************************************************
// Select a waveform and querry information
// *****************************************************************************
:SOURce1:BB:ARBitrary:WAVeform:DELete "/var/user/ARBtestSigs/test2"
:SOURce1:BB:ARBitrary:WAVeform:SELect "/var/user/ARBtestSigs/wvTest"
:SOURce1:BB:ARBitrary:WAVeform:POINts?
// 100
:SOURce1:BB:ARBitrary:WAVeform:TAG? "TYPE"
// "SMU-WV"
:SOURce1:BB:ARBitrary:WAVeform:TAG? "COMMENT" 
// "Waveform for test purposes"
// alternatively: query the comment tag of the current waveform file
:SOURce1:BB:ARBitrary:WAVeform:DATA?
// Response is the comment: "Waveform for test purposes"
// Query the date tag of a specific waveform file.
:SOURce1:BB:ARBitrary:WAVeform:DATA? "/var/user/ARBtestSigs/waveformTest","date"
// Response: #2192014-04-15;16:19:30

Example: To configure marker signals
This example provides the commands to configure the marker signals.
// *****************************************************************************
// Configure and enable standard marker signals
// *****************************************************************************
SOURce1:BB:ARBitrary:TRIGger:OUTPut1:MODE RESTart
SOURce1:BB:ARBitrary:TRIGger:OUTPut1:MODE RATio
SOURce1:BB:ARBitrary:TRIGger:OUTPut1:ONTime 40
SOURce1:BB:ARBitrary:TRIGger:OUTPut1:OFFTime 20
// *****************************************************************************
// Configure a pulsed marker signal.
// *****************************************************************************
SOURce1:BB:ARBitrary:TRIGger:OUTPut1:MODE PULSe
SOURce1:BB:ARBitrary:TRIGger:OUTPut1:PULSe:DIVider 5
SOURce1:BB:ARBitrary:TRIGger:OUTPut1:PULSe:FREQuency?
// Response in Hz: "20000000"
SOURce1:BB:ARBitrary:TRIGger:OUTPut1:DELay 16
// *****************************************************************************
// Configure a pattern marker signal.
// *****************************************************************************
SOURce1:BB:ARBitrary:TRIGger:OUTPut1:MODE PATTern
SOURce1:BB:ARBitrary:TRIGger:OUTPut1:PATTern #HE0F52,20
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Example: To configure clock settings
This example provides the commands to configure the clock settings.
// *****************************************************************************
// Clock settings
// *****************************************************************************
SOURce1:BB:ARBitrary:CLOCk:SOURce INTernal
SOURce1:BB:ARBitrary:CLOCk?
// Response in Hz: "1000000"
// The clock frequency is 1 MHz. 
// Or alternativelly use the following tag:
SOURce1:BB:ARBitrary:WAVeform:TAG? "CLOCK"

Example: To generate a multicarrier signal
The following example lists the commands to configure and generate an ARB multicar-
rier signal.

// *****************************************************************************
// Enable a multicarrier scenario with 4 carriers and carrier spacing of 5 MHz.
// *****************************************************************************
SOURce1:BB:ARBitrary:MCARrier:CARRier:COUNt 4
SOURce1:BB:ARBitrary:MCARrier:CARRier:SPACing 5 MHz
SOURce1:BB:ARBitrary:MCARrier:CARRier1:STATe ON
SOURce1:BB:ARBitrary:MCARrier:CARRier2:STATe ON
SOURce1:BB:ARBitrary:MCARrier:CARRier3:STATe ON
SOURce1:BB:ARBitrary:MCARrier:CARRier4:STATe ON

// *****************************************************************************
// Select and load a waveform file "3gpp_arb" to all 4 carriers
// *****************************************************************************
// The file "3gpp_arb" is in default directory "/var/user".
SOURce1:BB:ARBitrary:MCARrier:CARRier1:FILE "3gpp_arb"
SOURce1:BB:ARBitrary:MCARrier:CARRier2:FILE "3gpp_arb"
SOURce1:BB:ARBitrary:MCARrier:CARRier3:FILE "3gpp_arb"
SOURce1:BB:ARBitrary:MCARrier:CARRier4:FILE "3gpp_arb"

// *****************************************************************************
// Trigger the signal caulation and load the waveform in the ARB generator
// *****************************************************************************
// Define the file name of the multi carrier output file, e.g. "3gpp_mc"  
SOURce1:BB:ARBitrary:MCARrier:OFILe "3gpp_mc"
// Create and load the multi carrier waveform file in the ARB generator
SOURce1:BB:ARBitrary:MCARrier:CLOad
// Alternatively: create the multi carrier waveform and
// load it subsequently in the ARB generator
// SOURce1:BB:ARBitrary:MCARrier:CREate
// SOURce1:BB:ARBitrary:WAVeform:SELect"3gpp_mc"

// Activate the ARB generator
SOURce1:BB:ARBitrary:STATe ON
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// *****************************************************************************
// Use the save and recall function.
// *****************************************************************************
// Query available settings files in a specified directory
MMEM:CDIR "/var/user/waveform" 
SOURce1:BB:ARBitrary:MCARrier:SETTing:CATalog?
// mcar1, mcar2
// the directory contains the settings files mcar1.arb_multcarr and mcar2.arb_multcarr
SOURce1:BB:ARBitrary:MCARrier:SETTing:STORe "3gpp_mc"

13.16.2.2  General commands

[:SOURce<hw>]:BB:ARBitrary:PRESet

Sets all ARB generator parameters to their default values.

Example: See Example "To create test signals" on page 532.

Usage: Event

Manual operation: See "Set To Default" on page 70

[:SOURce<hw>]:BB:ARBitrary:STATe <State>

Enables the ARB generator.

A waveform must be selected before the ARB generator is activated.

Parameters:
<State> 1 | ON | 0 | OFF

*RST: 0

Example: See Example "To create test signals" on page 532.

Manual operation: See "State" on page 70

13.16.2.3  Test signal commands

[:SOURce<hw>]:BB:ARBitrary:SIGNal:TYPE.................................................................... 536
[:SOURce<hw>]:BB:ARBitrary:TSIGnal:CIQ:I....................................................................536
[:SOURce<hw>]:BB:ARBitrary:TSIGnal:CIQ:Q.................................................................. 536
[:SOURce<hw>]:BB:ARBitrary:TSIGnal:RECTangle:AMPLitude.......................................... 536
[:SOURce<hw>]:BB:ARBitrary:TSIGnal:RECTangle:FREQuency........................................ 536
[:SOURce<hw>]:BB:ARBitrary:TSIGnal:RECTangle:OFFSet...............................................537
[:SOURce<hw>]:BB:ARBitrary:TSIGnal:RECTangle:SAMPles.............................................537
[:SOURce<hw>]:BB:ARBitrary:TSIGnal:SINE:FREQuency................................................. 537
[:SOURce<hw>]:BB:ARBitrary:TSIGnal:SINE:PHASe........................................................ 538
[:SOURce<hw>]:BB:ARBitrary:TSIGnal:SINE:SAMPles..................................................... 538
[:SOURce<hw>]:BB:ARBitrary:TSIGnal:CIQ:CREate:NAMed............................................. 538
[:SOURce<hw>]:BB:ARBitrary:TSIGnal:RECTangle:CREate:NAMed...................................538
[:SOURce<hw>]:BB:ARBitrary:TSIGnal:SINE:CREate:NAMed............................................538
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[:SOURce<hw>]:BB:ARBitrary:TSIGnal:CIQ:CREate......................................................... 539
[:SOURce<hw>]:BB:ARBitrary:TSIGnal:RECTangle:CREate...............................................539
[:SOURce<hw>]:BB:ARBitrary:TSIGnal:SINE:CREate....................................................... 539

[:SOURce<hw>]:BB:ARBitrary:SIGNal:TYPE <ArbSignalType>

Selects the type of test signal.

Parameters:
<ArbSignalType> SINE | RECT | CIQ

*RST: SINE

Example: See Example "To create test signals" on page 532.

Manual operation: See "Test Signal Form" on page 71

[:SOURce<hw>]:BB:ARBitrary:TSIGnal:CIQ:I <I>
[:SOURce<hw>]:BB:ARBitrary:TSIGnal:CIQ:Q <TSig>
Sets the value for the I and Q component of the test signal

Parameters:
<TSig> float

Range: -1  to  1
Increment: 0.001
*RST: 0
Default unit: FS

Example: See Example "To create test signals" on page 532.

Manual operation: See "I ValueIQ Value" on page 76

[:SOURce<hw>]:BB:ARBitrary:TSIGnal:RECTangle:AMPLitude <Amplitude>

Sets the digital amplitude of the rectangular wave.

Parameters:
<Amplitude> float

Range: 0  to  1
Increment: 0.001
*RST: 0.800
Default unit: FS

Example: See Example "To create test signals" on page 532.

Manual operation: See "Amplitude" on page 74

[:SOURce<hw>]:BB:ARBitrary:TSIGnal:RECTangle:FREQuency <Frequency>

Sets the frequency of the test signal.
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Parameters:
<Frequency> float

Range: 100  to  depends on the installed options
Increment: 0.01
*RST: 1000
Default unit: Hz

Example: See Example "To create test signals" on page 532.

Manual operation: See "Frequency" on page 74

[:SOURce<hw>]:BB:ARBitrary:TSIGnal:RECTangle:OFFSet <Offset>

Sets the DC component.

Parameters:
<Offset> float

Range: -1  to  1
Increment: 0.001
*RST: 0
Default unit: FS

Example: See Example "To create test signals" on page 532.

Manual operation: See "Offset DC" on page 75

[:SOURce<hw>]:BB:ARBitrary:TSIGnal:RECTangle:SAMPles <Samples>

Sets the number of sample values required for the rectangular signal per period.

Parameters:
<Samples> integer

Range: 4  to  1000
*RST: 100

Example: See Example "To create test signals" on page 532.

Manual operation: See "Samples per Period" on page 74

[:SOURce<hw>]:BB:ARBitrary:TSIGnal:SINE:FREQuency <Frequency>

Sets the frequency of the simple sinusoidal test signal.

Parameters:
<Frequency> float

Range: 100  to  depends on the installed options
Increment: 0.01
*RST: 1000
Default unit: Hz

Example: See Example "To create test signals" on page 532.

Manual operation: See "Frequency" on page 73
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[:SOURce<hw>]:BB:ARBitrary:TSIGnal:SINE:PHASe <Phase>

Sets the phase offset of the sine wave on the Q channel relative to the sine wave on
the I channel.

Parameters:
<Phase> float

Range: -180  to  180
Increment: 0.01
*RST: 90
Default unit: DEG

Example: See Example "To create test signals" on page 532.

Manual operation: See "Phase Offset Q" on page 73

[:SOURce<hw>]:BB:ARBitrary:TSIGnal:SINE:SAMPles <Samples>

Sets the sample rate for the sine signal in samples per period.

Make sure that the resulting clock rate does not exceed the maximum ARB clock rate.
The maximum value is automatically restricted by reference to the set frequency and
has to fulfill the rule Frequency * Samples <= ARB clock rate.

For more information, refer to the specifications document.

Parameters:
<Samples> integer

Range: 4  to  1000
*RST: 100

Example: See Example "To create test signals" on page 532.

Manual operation: See "Samples per Period" on page 73

[:SOURce<hw>]:BB:ARBitrary:TSIGnal:CIQ:CREate:NAMed <Filename>
[:SOURce<hw>]:BB:ARBitrary:TSIGnal:RECTangle:CREate:NAMed <Filename>
[:SOURce<hw>]:BB:ARBitrary:TSIGnal:SINE:CREate:NAMed <Filename>
Generates a signal and saves it to a waveform file.

Setting parameters: 
<Filename> string

Example: See Example "To create test signals" on page 532.

Usage: Setting only

Manual operation: See "Generate Signal File" on page 73
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[:SOURce<hw>]:BB:ARBitrary:TSIGnal:CIQ:CREate
[:SOURce<hw>]:BB:ARBitrary:TSIGnal:RECTangle:CREate
[:SOURce<hw>]:BB:ARBitrary:TSIGnal:SINE:CREate
Generates a signal and uses it as output straight away.

Example: See Example "To create test signals" on page 532.

Usage: Event

Manual operation: See "Generate Signal RAM" on page 73
See "Generate Signal RAM" on page 75

13.16.2.4  Waveform commands

The following rule applies for all commands described in this section.
By default, the waveform files are saved in the default directory of the instrument that is
the /var/user/ directory or the directory specified with the command :MMEMory:
CDIRectory. To access the waveform files in this default directory, only the filename
is required, without the path and the file extension (*.wv).
However, to access waveform files located in a directory different to the default one,
the complete file path and filename are required.

[:SOURce<hw>]:BB:ARBitrary:WAVeform:CATalog?.......................................................... 539
[:SOURce<hw>]:BB:ARBitrary:WAVeform:CATalog:LENGth?..............................................540
[:SOURce<hw>]:BB:ARBitrary:WAVeform:SELect..............................................................540
[:SOURce<hw>]:BB:ARBitrary:WAVeform:DELete............................................................. 540
[:SOURce<hw>]:BB:ARBitrary:WAVeform:FREE?..............................................................540
[:SOURce<hw>]:BB:ARBitrary:WAVeform:POINts?............................................................541
[:SOURce<hw>]:BB:ARBitrary:WAVeform:DATA................................................................541
[:SOURce<hw>]:BB:ARBitrary:WAVeform:TAG?................................................................542
[:SOURce<hw>]:BB:ARBitrary:CLOCk............................................................................. 542
[:SOURce<hw>]:BB:ARBitrary:WAVeform:CLOCk............................................................. 542

[:SOURce<hw>]:BB:ARBitrary:WAVeform:CATalog?

Reads out the files extension *.wv in the default directory.

Return values: 
<Catalog> string

Returns a list of the file names separated by commas

Example: See Example "To manage waveform files" on page 532.

Usage: Query only
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[:SOURce<hw>]:BB:ARBitrary:WAVeform:CATalog:LENGth?

Reads out the files with extension *.wv in the default directory and returns the number
of waveform files in this directory. The default directory is set using command
MMEM:CDIRectory.

Return values: 
<Length> integer

Number of waveform files in default directory
Range: 0  to  INT_MAX
*RST: 0

Example: See Example "To manage waveform files" on page 532.

Usage: Query only

[:SOURce<hw>]:BB:ARBitrary:WAVeform:SELect <Filename>

Selects an existing waveform file, i.e. file with extension *.wv.

Parameters:
<Filename> string

Example: See Example "To manage waveform files" on page 532.

Manual operation: See "Load Waveform" on page 70

[:SOURce<hw>]:BB:ARBitrary:WAVeform:DELete <Filename>

Deletes the specified waveform file. If the file is not on the default path, the path must
be specified at the same time. The file extension may be omitted. Only files with the file
extension *.wv are deleted.

Setting parameters: 
<Filename> string

Example: See Example "To manage waveform files" on page 532.

Usage: Setting only

[:SOURce<hw>]:BB:ARBitrary:WAVeform:FREE?

Queries the free disk space on the default path of the instrument's hard disk.

Return values: 
<Free> integer

Range: 0  to  INT_MAX
*RST: 1

Example: See Example "To manage waveform files" on page 532.

Usage: Query only
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[:SOURce<hw>]:BB:ARBitrary:WAVeform:POINts?

Queries the number of samples (the number of I/Q values pairs) in the selected wave-
form file.

Return values: 
<Points> <waveform filename>

Range: 0  to  1000
*RST: 1

Example: See Example "To manage waveform files" on page 532.

Usage: Query only

[:SOURce<hw>]:BB:ARBitrary:WAVeform:DATA <Filename>, <Data>
[:SOURce<hw>]:BB:ARBitrary:WAVeform:DATA? <Tag>

The setting command writes the binary block data <data> to the file identified by
<filename>. The complete content of the waveform file (i.e. including all tags) must
be specified; the complete content is transmitted as binary data block.

Tip: To ensure trouble-free data transmission, set the GPIB delimiter to EOI.

The query command retrieves the content of the specified tag of the currently selected
waveform file or the waveform file specified with the <filename>.

See also Chapter 4.3.5, "Tags for waveforms, data and control lists", on page 94.

Parameters:
<Filename> string

Specifies the name of the waveform file in that the binary data is
copied

Setting parameters: 
<Data> block data

Binary block data with the following syntax:
#<Digits><Length><Binary data>
#
Indicates the start of the binary block
<Digits>
Decimal value
Gives the number of decimal digits used for the <Length>
value
<Length>
Decimal value
Number of bytes the follow in the <Binary data> part
<Binary data>
Binary data in ASCII format

Query parameters: 
<Tag> 'comment' | 'copyright' | 'date' | 'lacpfilter' | 'marker name' |

'poweroffset'
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Example: Query
See Example "To manage waveform files" on page 532.

Example: Setting
SOURce:BB:ARB:WAVeform:DATA "/var/user/test1.wv",#220<binary data>
// Writes the binary block data <binary data> to file test1.wv
// <binary data> contains 20 bytes
// <binary data> is a placeholder; 
// the actual ASCII values are not printable

[:SOURce<hw>]:BB:ARBitrary:WAVeform:TAG?

Queries the content of the specified tag of the selected waveform file (see also Chap-
ter 4.3.5, "Tags for waveforms, data and control lists", on page 94).

Return values: 
<Tag> 'comment' | 'copyright' | 'date' | 'lacpfilter' | 'marker name' |

'poweroffset' | 'samples'

Example: See Example "To manage waveform files" on page 532.

Usage: Query only

[:SOURce<hw>]:BB:ARBitrary:CLOCk <Clock>

Sets the clock frequency.

If you load a waveform, the clock rate is determined as defined with the waveform tag
{CLOCK: frequency}. This command subsequently changes the clock rate; see
specifications document for value range.

For more information, refer to the specifications document.

Parameters:
<Clock> float

Range: depends on the installed options
Increment: 0.001
*RST: 1E6
Default unit: Hz

Example: See Example "To manage waveform files" on page 532.

Manual operation: See "Clock Frequency" on page 71

[:SOURce<hw>]:BB:ARBitrary:WAVeform:CLOCk <Filename>, <Clock>

Appends information on the ARB clock rate to the specified waveform file. This file
must contain I/Q or marker data.

Use the following command to create the data:

:MMEMory:DATA:UNPRotected on page 419
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Parameters:
<Filename> string

Complete file path and filename with file extension (*.wv).
If the file is in the default directory, the file path can be omitted.

Setting parameters: 
<Clock> float

Range: 400  to  100E6
Increment: 1E-3
*RST: 1E6

Example: See :MMEMory:DATA:UNPRotected on page 419.

13.16.2.5  Multicarrier commands

Required options

See Chapter 4.4.1, "Required options", on page 104.

Common suffixes

Suffix Value range

CARRier<ch> 1 to 512

[:SOURce<hw>]:BB:ARBitrary:MCARrier:PRESet............................................................. 544
[:SOURce<hw>]:BB:ARBitrary:MCARrier:SETTing:CATalog?..............................................544
[:SOURce<hw>]:BB:ARBitrary:MCARrier:SETTing:LOAD...................................................544
[:SOURce<hw>]:BB:ARBitrary:MCARrier:SETTing:STORe.................................................545
[:SOURce<hw>]:BB:ARBitrary:MCARrier:CARRier:COUNt.................................................545
[:SOURce<hw>]:BB:ARBitrary:MCARrier:CARRier:MODE................................................. 545
[:SOURce<hw>]:BB:ARBitrary:MCARrier:CARRier:SPACing.............................................. 545
[:SOURce<hw>]:BB:ARBitrary:MCARrier:SAMPles?..........................................................546
[:SOURce<hw>]:BB:ARBitrary:MCARrier:TIME................................................................. 546
[:SOURce<hw>]:BB:ARBitrary:MCARrier:CFACtor:MODE..................................................546
[:SOURce<hw>]:BB:ARBitrary:MCARrier:CLIPping:CFACtor.............................................. 547
[:SOURce<hw>]:BB:ARBitrary:MCARrier:CLIPping:CUToff.................................................547
[:SOURce<hw>]:BB:ARBitrary:MCARrier:CLIPping[:STATe]................................................547
[:SOURce<hw>]:BB:ARBitrary:MCARrier:TIME:MODE...................................................... 548
[:SOURce<hw>]:BB:ARBitrary:MCARrier:POWer:REFerence............................................. 548
[:SOURce<hw>]:BB:ARBitrary:MCARrier:OFILe................................................................548
[:SOURce<hw>]:BB:ARBitrary:MCARrier:CLOad...............................................................548
[:SOURce<hw>]:BB:ARBitrary:MCARrier:CLOCk?............................................................ 549
[:SOURce<hw>]:BB:ARBitrary:MCARrier:CREate..............................................................549
[:SOURce<hw>]:BB:ARBitrary:MCARrier:CARRier<ch>:STATe...........................................549
[:SOURce<hw>]:BB:ARBitrary:MCARrier:CARRier<ch>:FREQuency.................................. 550
[:SOURce<hw>]:BB:ARBitrary:MCARrier:CARRier<ch>:PHASe......................................... 550
[:SOURce<hw>]:BB:ARBitrary:MCARrier:CARRier<ch>:POWer......................................... 550
[:SOURce<hw>]:BB:ARBitrary:MCARrier:CARRier<ch>:DELay.......................................... 551
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[:SOURce<hw>]:BB:ARBitrary:MCARrier:CARRier<ch>:FILE............................................. 551
[:SOURce<hw>]:BB:ARBitrary:MCARrier:CARRier<ch>:CONFlict?..................................... 551
[:SOURce<hw>]:BB:ARBitrary:MCARrier:EDIT:CARRier:STATe.......................................... 551
[:SOURce<hw>]:BB:ARBitrary:MCARrier:EDIT:CARRier:STARt..........................................552
[:SOURce<hw>]:BB:ARBitrary:MCARrier:EDIT:CARRier:STOP.......................................... 552
[:SOURce<hw>]:BB:ARBitrary:MCARrier:EDIT:CARRier:POWer:STEP............................... 552
[:SOURce<hw>]:BB:ARBitrary:MCARrier:EDIT:CARRier:POWer[:STARt].............................552
[:SOURce<hw>]:BB:ARBitrary:MCARrier:EDIT:CARRier:PHASe:STEP............................... 553
[:SOURce<hw>]:BB:ARBitrary:MCARrier:EDIT:CARRier:PHASe[:STARt].............................553
[:SOURce<hw>]:BB:ARBitrary:MCARrier:EDIT:CARRier:DELay:STEP................................ 553
[:SOURce<hw>]:BB:ARBitrary:MCARrier:EDIT:CARRier:DELay[:STARt]..............................554
[:SOURce<hw>]:BB:ARBitrary:MCARrier:EDIT:CARRier:FILE............................................ 554
[:SOURce<hw>]:BB:ARBitrary:MCARrier:EDIT:CARRier:EXECute......................................554

[:SOURce<hw>]:BB:ARBitrary:MCARrier:PRESet

Sets all the multicarrier parameters to their default values.

Example: See Example "To generate a multicarrier signal" on page 534.

Usage: Event

Manual operation: See "Set to Default" on page 107

[:SOURce<hw>]:BB:ARBitrary:MCARrier:SETTing:CATalog?

Queries the files with settings in the default directory. Listed are files with the file exten-
sion *.arb_multcarr.

Return values: 
<Catalog> string

Example: See Example "To generate a multicarrier signal" on page 534.

Usage: Query only

Manual operation: See "Save/Recall" on page 108

[:SOURce<hw>]:BB:ARBitrary:MCARrier:SETTing:LOAD <Filename>

Loads the selected file from the default or the specified directory. Loaded are files with
extension *.arb_multcarr.

Setting parameters: 
<Filename> "<filename>"

Filename or complete file path; file extension can be omitted.

Example: See Example "To generate a multicarrier signal" on page 534.

Usage: Setting only

Manual operation: See "Save/Recall" on page 108
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[:SOURce<hw>]:BB:ARBitrary:MCARrier:SETTing:STORe <Filename>

Saves the current settings into the selected file; the file extension (*.arb_multcarr)
is assigned automatically.

Setting parameters: 
<Filename> string

Filename or complete file path

Example: See Example "To generate a multicarrier signal" on page 534.

Usage: Setting only

Manual operation: See "Save/Recall" on page 108

[:SOURce<hw>]:BB:ARBitrary:MCARrier:CARRier:COUNt <Count>

Sets the number of carriers in the ARB multicarrier waveform.

Parameters:
<Count> integer

Range: 1  to  512
*RST: 1

Example: See Example "To generate a multicarrier signal" on page 534.

Manual operation: See "Number of Carriers" on page 108
See "Number of Carriers" on page 114

[:SOURce<hw>]:BB:ARBitrary:MCARrier:CARRier:MODE <Mode>

Sets the carrier frequency mode for the single carriers.

Parameters:
<Mode> EQUidistant | ARBitrary

*RST: EQUidistant

Example: BB:ARB:MCAR:CARR:MODE EQU
Sets an equidistant carrier spacing. The carrier frequency can-
not be set.

Manual operation: See "Mode" on page 108

[:SOURce<hw>]:BB:ARBitrary:MCARrier:CARRier:SPACing <Spacing>

Sets the frequency spacing between adjacent carriers of the multicarrier waveform.

See also Chapter 4.4.2.1, "Defining the carrier frequency", on page 105.
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Parameters:
<Spacing> float

Range: 0.0  to  depends on the installed options, for exam-
ple 120E6

Increment: 0.01
*RST: 0
Default unit: Hz

Example: See Example "To generate a multicarrier signal" on page 534.

Manual operation: See "Carrier Spacing" on page 108

[:SOURce<hw>]:BB:ARBitrary:MCARrier:SAMPles?

Queries the resulting file size.

Return values: 
<Samples> integer

Range: 0  to  INT_MAX
*RST: 0
Default unit: samples

Example: SOURce1:BB:ARBitrary:MCARrier:SAMPles?
Queries the file size of the currently calculated multi-carrier
waveform.

Usage: Query only

Manual operation: See "File Size" on page 113

[:SOURce<hw>]:BB:ARBitrary:MCARrier:TIME <Time>

Sets the user-defined signal period.

Parameters:
<Time> float

Range: 0  to  1E9
Increment: 1E-9
*RST: 0
Default unit: s

Example: SOURce1:BB:ARBitrary:MCARrier:MODE USER
Selects signal period mode user.
SOURce1:BB:ARBitrary:MCARrier:TIME 10
Sets a signal period of 10 seconds

Manual operation: See "Signal Period Mode" on page 110

[:SOURce<hw>]:BB:ARBitrary:MCARrier:CFACtor:MODE <Mode>

Sets the mode for optimizing the crest factor by calculating the carrier phases.
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Parameters:
<Mode> OFF | MIN | MAX

*RST: OFF

Example: SOURce1:BB:ARBitrary:MCARrier:CFACtor:MODE OFF
Switches off automatic crest factor optimization.

Manual operation: See "Crest Factor Mode" on page 109

[:SOURce<hw>]:BB:ARBitrary:MCARrier:CLIPping:CFACtor <CFactor>

Sets the value of the desired crest factor, if baseband clipping is enabled.

A target crest factor above the crest factor of the unclipped multicarrier signal has no
effect.

Parameters:
<CFactor> float

Range: -50  to  50
Increment: 0.01
*RST: 50
Default unit: dB

Example: See [:SOURce<hw>]:BB:ARBitrary:MCARrier:
CLIPping[:STATe] on page 547.

Manual operation: See "Target Crest Factor" on page 109

[:SOURce<hw>]:BB:ARBitrary:MCARrier:CLIPping:CUToff <Cutoff>

Sets the cutoff frequency of the final low pass filter, if baseband clipping is enabled.

Parameters:
<Cutoff> float

Range: 0  to  250E6
Increment: 0.01
*RST: 75E6

Example: See [:SOURce<hw>]:BB:ARBitrary:MCARrier:
CLIPping[:STATe] on page 547.

Manual operation: See "Filter Cut Off Frequency" on page 109

[:SOURce<hw>]:BB:ARBitrary:MCARrier:CLIPping[:STATe] <State>

Switches baseband clipping on and off.

Parameters:
<State> 1 | ON | 0 | OFF

*RST: 0
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Example: SOURce1:BB:ARBitrary:MCARrier:CLIPping:STATe ON
SOURce1:BB:ARBitrary:MCARrier:CLIPping:CFACtor 37
SOURce1:BB:ARBitrary:MCARrier:CLIPping:CUToff 50

Manual operation: See "Clipping" on page 109

[:SOURce<hw>]:BB:ARBitrary:MCARrier:TIME:MODE <Mode>

Selects the mode for calculating the resulting signal period of the multi-carrier wave-
form. The resulting period is always calculated for all carriers in the carrier table irre-
spective of their state (ON/OFF).

Parameters:
<Mode> USER | LONG | SHORt | LCM

*RST: LONG

Example: BB:ARB:MCAR:TIME:MODE LONG
The resulting signal period is defined by the longest I/Q file in
the carrier table. Shorter I/Q files are periodically repeated.

Manual operation: See "Signal Period Mode" on page 110

[:SOURce<hw>]:BB:ARBitrary:MCARrier:POWer:REFerence <Reference>

Defines the way the individual carriers in a composed multi carrier signal are leveled.

Parameters:
<Reference> RMS | PEAK

*RST: RMS

Manual operation: See "Power Reference" on page 110

[:SOURce<hw>]:BB:ARBitrary:MCARrier:OFILe <OFile>

Sets the output filename for the multicarrier waveform (file extension *.wv).

This filename is required to calculate the waveform with the commands [:
SOURce<hw>]:BB:ARBitrary:MCARrier:CLOad or [:SOURce<hw>]:BB:
ARBitrary:MCARrier:CREate.

Parameters:
<OFile> string

Example: See Example "To generate a multicarrier signal" on page 534.

Manual operation: See "Output File" on page 112

[:SOURce<hw>]:BB:ARBitrary:MCARrier:CLOad

Creates a multicarrier waveform using the current entries of the carrier table and ena-
bles the ARB.

SOURce:BB subsystem



Remote control commandsR&S®SFI100A

549User Manual 1179.6789.02 ─ 02

Use the command [:SOURce<hw>]:BB:ARBitrary:MCARrier:OFILe to define
the multicarrier waveform filename. The file extension is *.wv.

Example: See Example "To generate a multicarrier signal" on page 534.

Usage: Event

Manual operation: See "Create/Create and Load" on page 112

[:SOURce<hw>]:BB:ARBitrary:MCARrier:CLOCk?

Queries the resulting sample rate at which the multi-carrier waveform is output by the
arbitrary waveform generator. The output clock rate depends on the number of carriers,
carrier spacing, and input sample rate of the leftmost or rightmost carriers.

Return values: 
<Clock> float

Range: 400  to  Max
Increment: 1E-3

Example: BB:ARB:MCAR:CLOC?
Queries the ARB multi-carrier output clock rate.

Usage: Query only

Manual operation: See "Clock Rate" on page 113

[:SOURce<hw>]:BB:ARBitrary:MCARrier:CREate

Creates a multicarrier waveform using the current settings of the carrier table.

Use the command [:SOURce<hw>]:BB:ARBitrary:MCARrier:OFILe to define
the multicarrier waveform filename. The file extension is *.wv.

Example: See Example "To generate a multicarrier signal" on page 534.

Usage: Event

Manual operation: See "Create/Create and Load" on page 112

[:SOURce<hw>]:BB:ARBitrary:MCARrier:CARRier<ch>:STATe <State>

Enables the selected single carrier of the multicarrier signal.

Parameters:
<State> 1 | ON | 0 | OFF

*RST: 0

Example: See Example "To generate a multicarrier signal" on page 534.

Manual operation: See "State" on page 114
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[:SOURce<hw>]:BB:ARBitrary:MCARrier:CARRier<ch>:FREQuency <Frequency>

Sets or indicates the carrier frequency, depending on the selected carrier frequency
mode.

Parameters:
<Frequency> integer

Range: depends on the installed options
*RST: 0

Example: SOURce1:BB:ARBitrary:MCARrier:CARRier:MODE ARB
SOURce1:BB:ARBitrary:MCARrier:CARRier1:
FREQuency 5.0
Sets 5.0 MHz carrier frequency.

Manual operation: See "Carrier Freq. Offs. (MHz)" on page 114

[:SOURce<hw>]:BB:ARBitrary:MCARrier:CARRier<ch>:PHASe <Phase>

Sets the start phase of the selected carrier.

Parameters:
<Phase> float

Range: 0  to  359.99
Increment: 0.01
*RST: 0
Default unit: DEG

Example: SOURce1:BB:ARBitrary:MCARrier:CARRier19:PHASe
90
Sets a start phase.

Manual operation: See "Phase (deg)" on page 114

[:SOURce<hw>]:BB:ARBitrary:MCARrier:CARRier<ch>:POWer <Power>

Sets the gain of the selected carrier.

Parameters:
<Power> float

Range: -80  to  0
Increment: 0.01
*RST: 0
Default unit: dB

Example: SOURce1:BB:ARBitrary:MCARrier:CARRier15:POWer
-50
Sets the power of carrier 15 to -50 dB.

Manual operation: See "Gain (dB)" on page 114
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[:SOURce<hw>]:BB:ARBitrary:MCARrier:CARRier<ch>:DELay <Delay>

Sets the start delay of the selected carrier.

Parameters:
<Delay> float

Range: 0  to  1
Increment: 1E-9
*RST: 0
Default unit: s

Example: BB:ARB:MCAR:CARR15:DEL 5us
sets a start delay of 50 us for carrier 15.

Manual operation: See "Delay (ns)" on page 115

[:SOURce<hw>]:BB:ARBitrary:MCARrier:CARRier<ch>:FILE <File>

Selects the I/Q data file that contains the I/Q samples for modulation onto the selected
single carrier.

Parameters:
<File> <file name>

Example: See Example "To generate a multicarrier signal" on page 534.

Manual operation: See "File" on page 115

[:SOURce<hw>]:BB:ARBitrary:MCARrier:CARRier<ch>:CONFlict?

Queries carrier conflicts. A conflict arises when the carriers overlap.

Return values: 
<Conflict> 1 | ON | 0 | OFF

0
No conflict
*RST: 0

Example: BB:ARB:MCAR:CARR:CONF?
Usage: Query only

Manual operation: See "!!!" on page 115

[:SOURce<hw>]:BB:ARBitrary:MCARrier:EDIT:CARRier:STATe <State>

Switches all the carriers in the selected carrier range on or off.

Parameters:
<State> 1 | ON | 0 | OFF

*RST: 1

Example: BB:ARB:MCAR:EDIT:CARR:STAT ON
Sets all the carriers in the carrier range to ON.
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Manual operation: See "Carrier State" on page 116

[:SOURce<hw>]:BB:ARBitrary:MCARrier:EDIT:CARRier:STARt <Start>
[:SOURce<hw>]:BB:ARBitrary:MCARrier:EDIT:CARRier:STOP <Stop>
Selects the last carrier in the carrier range to which the settings shall apply.

Parameters:
<Stop> integer

Range: 0  to  511
*RST: 0

Example: BB:ARB:MCAR:EDIT:CARR:STOP 4
The carrier range stops at carrier 4.

Manual operation: See "Carrier Start" on page 116
See "Carrier Stop" on page 117

[:SOURce<hw>]:BB:ARBitrary:MCARrier:EDIT:CARRier:POWer:STEP <Step>

Sets the step width by which the starting power of the carriers in the defined carrier
range is incremented.

Parameters:
<Step> float

Range: -80  to  80
Increment: 0.01
*RST: 0
Default unit: dB

Example: BB:ARB:MCAR:EDIT:CARR:POW -80dB
Sets a power of -80 dB for the carriers in the carrier range.
BB:ARB:MCAR:EDIT:CARR:POW:STEP 1 dB
The power is incremented by 1dB for each carrier.
That is, the first carrier has -80 dB, the second -79 dB, and so
on.

Manual operation: See "Gain Step" on page 117

[:SOURce<hw>]:BB:ARBitrary:MCARrier:EDIT:CARRier:POWer[:STARt] <Start>

Sets the power for the individual carriers in the defined carrier range.

Parameters:
<Start> float

Range: -80  to  0
Increment: 0.01
*RST: 0
Default unit: dB

Example: BB:ARB:MCAR:EDIT:CARR:POW -50 dB
sets the power of the carriers in the carrier range to -50 dB.
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Manual operation: See "Gain Start" on page 117

[:SOURce<hw>]:BB:ARBitrary:MCARrier:EDIT:CARRier:PHASe:STEP <Step>

Sets the step width by which the start phases of the carriers in the defined carrier
range is incremented.

Parameters:
<Step> float

Range: -359.99  to  359.99
Increment: 0.01
*RST: 0
Default unit: DEG

Example: BB:ARB:MCAR:EDIT:CARR:PHAS 90 DEG
Sets a start phase of 90° for the carriers in the carrier range.
BB:ARB:MCAR:EDIT:CARR:PHAS:STEP 1 DEG
The start phase is incremented by 1° for each carrier. That is,
the first carrier has a start phase of 90°, the second a start
phase of 91°, and so on.

Manual operation: See "Phase Step" on page 117

[:SOURce<hw>]:BB:ARBitrary:MCARrier:EDIT:CARRier:PHASe[:STARt] <Start>

Sets the start phase for the individual carriers in the defined carrier range.

Parameters:
<Start> float

Range: 0  to  359.99
Increment: 0.01
*RST: 0
Default unit: DEG

Example: BB:ARB:MCAR:EDIT:CARR:PHAS 90 DEG
sets a start phase of 90° for the carriers in the carrier range.

Manual operation: See "Phase Start" on page 117

[:SOURce<hw>]:BB:ARBitrary:MCARrier:EDIT:CARRier:DELay:STEP <Step>

Sets the step width by which the start delays of the carriers in the defined carrier range
is incremented.

Parameters:
<Step> float

Range: -1  to  1
Increment: 1E-9
*RST: 0
Default unit: s
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Example: BB:ARB:MCAR:EDIT:CARR:DEL 5 us
Sets a start delay of 5 us for the carriers in the carrier range.
BB:ARB:MCAR:EDIT:CARR:DEL:STEP 1 us
The start delay is incremented by 1us for each carrier. That is,
the first carrier has a start delay of 5 us, the second a start delay
of 6 us, and so on.

Manual operation: See "Delay Step" on page 118

[:SOURce<hw>]:BB:ARBitrary:MCARrier:EDIT:CARRier:DELay[:STARt] <Start>

Sets the start delay for the individual carriers in the defined carrier range.

Parameters:
<Start> float

Range: 0  to  1
Increment: 1E-9
*RST: 0
Default unit: s

Example: BB:ARB:MCAR:EDIT:CARR:DEL 5us
Sets a start delay of 5 us for the carriers in the carrier range.

Manual operation: See "Delay Start" on page 117

[:SOURce<hw>]:BB:ARBitrary:MCARrier:EDIT:CARRier:FILE <File>

Selects the input file. The data of the file are modulated onto the carriers in the defined
carrier range.

Parameters:
<File> string

Example: BB:ARB:MCAR:EDIT:CARR:FILE
"/var/user/temp/IQ_wcdma"
selects input file IQ_wcdma.

Manual operation: See "Input Waveform File" on page 118

[:SOURce<hw>]:BB:ARBitrary:MCARrier:EDIT:CARRier:EXECute

Adopts the settings for the selected carrier range.

Example: BB:ARB:MCAR:EDIT:CARR:STAR 4
BB:ARB:MCAR:EDIT:CARR:STOP 20
BB:ARB:MCAR:EDIT:CARR:STAT ON
BB:ARB:MCAR:EDIT:CARR:EXEC

Usage: Event

Manual operation: See "Apply Assistant Settings" on page 118
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13.16.2.6  Trigger commands

This section provides trigger commands for the SOURce:BB:ARBitrary subsystem.

Example: To configure trigger settings
This example provides the commands to configure the trigger settings.
// *****************************************************************************
// Configure for a single trigger event.
// *****************************************************************************
SOURce1:BB:ARBitrary:TRIGger:SEQuence SINGle
SOURce1:BB:ARBitrary:TRIGger:SLUNit SAMPles
SOURce1:BB:ARBitrary:TRIGger:SLENgth 200
// Outputs the first 200 samples of the waveform after the next trigger event.
SOURce1:BB:ARBitrary:TRIGger:SOURce?
// Response: "INTernal"
SOURce1:BB:ARBitrary:STATe ON

// *****************************************************************************
// Configure for an external trigger event.
// *****************************************************************************
SOURce1:BB:ARBitrary:TRIGger:SEQuence ARETrigger
// Sets the armed retrigger mode.
SOURce1:BB:ARBitrary:TRIGger:SOURce EGT1
// Expects an external trigger signal at a USER connector.
SOURce1:BB:ARBitrary:TRIGger:EXTernal:SYNChronize:OUTPut ON
// Synchronizes the baseband signal output to the external trigger event.
// Query the processing time between the input of the external trigger event
// and the output of the baseband signal.
SOURce1:BB:ARBitrary:TRIGger:PTIMe?
// Response: "0.00021"
// The processing time is 210 mircoseconds.
// Optionally, add a trigger delay.
SOURce1:BB:ARBitrary:TRIGger:EXTernal:DELay 200
SOURce1:BB:ARBitrary:TRIGger:EXTernal:INHibit 100
SOURce1:BB:ARBitrary:STATe ON

// *****************************************************************************
// Execute an internal trigger manually.
// *****************************************************************************
SOURce1:BB:ARBitrary:TRIGger:SEQuence AAUTo
SOURce1:BB:ARBitrary:TRIGger:SOURce INTernal
SOURce1:BB:ARBitrary:STATe ON
SOURce1:BB:ARBitrary:TRIGger:EXEC
SOURce1:BB:ARBitrary:TRIGger:RMODe?
// Response: "RUN"

Example: To specify delay and inhibit values in time units
The following example lists the commands to configure trigger delays and trigger inhibit
values. See also "To set delay and inhibit values" on page 58.
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SOURce1:BB:ARBitrary:TRIGger:SEQuence AAUT
SOURce1:BB:ARBitrary:TRIGger:SOURce EGT1
SOURce1:BB:ARBitrary:TRIGger:DELay:UNIT SAMP
SOURce1:BB:ARBitrary:TRIGger:EXTernal:DELay 100
SOURce1:BB:ARBitrary:TRIGger:EXTernal:RDELay?
// Response in samples: 100
SOURce1:BB:ARBitrary:TRIGger:DELay:UNIT TIME
SOURce1:BB:ARBitrary:TRIGger:EXTernal:TDELay 0.00001
SOURce1:BB:ARBitrary:TRIGger:EXTernal:RDELay?
// Response in seconds: 0.00001
// The actual external delay is 10 microseconds. 
SOURce1:BB:ARBitrary:TRIGger:DELay:UNIT SAMP
SOURce1:BB:ARBitrary:TRIGger:EXTernal:DELay 10

Commands:

[:SOURce<hw>]:BB:ARBitrary[:TRIGger]:SEQuence......................................................... 556
[:SOURce<hw>]:BB:ARBitrary:TRIGger:SOURce..............................................................557
[:SOURce<hw>]:BB:ARBitrary:TRIGger:RMODe?............................................................. 557
[:SOURce<hw>]:BB:ARBitrary:TRIGger:SLENgth..............................................................557
[:SOURce<hw>]:BB:ARBitrary:TRIGger:SLUNit................................................................ 558
[:SOURce<hw>]:BB:ARBitrary:TRIGger:ARM:EXECute..................................................... 558
[:SOURce<hw>]:BB:ARBitrary:TRIGger:EXECute............................................................. 558
[:SOURce<hw>]:BB:ARBitrary:TRIGger[:EXTernal]:SYNChronize:OUTPut...........................558
[:SOURce<hw>]:BB:ARBitrary:TRIGger:PTIMe?............................................................... 559
[:SOURce<hw>]:BB:ARBitrary:TRIGger:DELay:UNIT........................................................ 559
[:SOURce<hw>]:BB:ARBitrary:TRIGger[:EXTernal]:DELay................................................. 559
[:SOURce<hw>]:BB:ARBitrary:TRIGger[:EXTernal]:TDELay............................................... 560
[:SOURce<hw>]:BB:ARBitrary:TRIGger[:EXTernal]:RDELay?.............................................560
[:SOURce<hw>]:BB:ARBitrary:TRIGger[:EXTernal]:INHibit................................................. 560

[:SOURce<hw>]:BB:ARBitrary[:TRIGger]:SEQuence <Sequence>

Selects the trigger mode:
● AUTO = auto
● RETRigger = retrigger
● AAUTo = armed auto
● ARETrigger = armed retrigger
● SINGle = single

See also Chapter 4.2.2, "About trigger modes", on page 53.

Parameters:
<Sequence> AUTO | RETRigger | AAUTo | ARETrigger | SINGle

*RST: AUTO

Example: See Example "To configure trigger settings" on page 555.

Manual operation: See "Mode" on page 77
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[:SOURce<hw>]:BB:ARBitrary:TRIGger:SOURce <Source>

Selects the trigger signal source and determines the way the triggering is executed.
Provided are the following trigger sources:
● INTernal: Internal manual triggering of the instrument
● External trigger signal via one of the global connectors:

EGT1: External global trigger
● EXTernal: Setting only

Provided only for backward compatibility with other Rohde & Schwarz signal gener-
ators. The R&S SFI100A accepts this value and maps it automatically as follows:
EXTernal = EGT1

Parameters:
<Source> INTernal|EXTernal

*RST: INTernal

Example: See Example "To configure trigger settings" on page 555.

Manual operation: See "Source" on page 78

[:SOURce<hw>]:BB:ARBitrary:TRIGger:RMODe?

Queries the status of waveform output.

Return values: 
<RMode> STOP | RUN

RUN
Outputs the waveform. A trigger event occurred in the triggered
mode.
STOP
No waveform output. A trigger event did not occur in the trig-
gered modes, or waveform output was stopped/armed.

Example: See Example "To configure trigger settings" on page 555.

Usage: Query only

Manual operation: See "Running/Stopped" on page 78

[:SOURce<hw>]:BB:ARBitrary:TRIGger:SLENgth <SLength>

Sets the length of the signal sequence that is output in the SINGle trigger mode.
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Parameters:
<SLength> integer

The maximum value depends on the selected units [:
SOURce<hw>]:BB:ARBitrary:TRIGger:SLUNit as follows:
SAMPle: Max = 232-1
SEQuence: Max = 1000
Range: 1  to  dynamic
*RST: 1

Example: See Example "To configure trigger settings" on page 555.

Manual operation: See "Signal Duration" on page 78

[:SOURce<hw>]:BB:ARBitrary:TRIGger:SLUNit <SLUnit>

Sets the unit for the entry of the length of the signal sequence to be output in the
Single trigger mode.

Parameters:
<SLUnit> SEQuence | SAMPle

*RST: SEQuence

Example: See Example "To configure trigger settings" on page 555.

Manual operation: See "Signal Duration Unit" on page 78

[:SOURce<hw>]:BB:ARBitrary:TRIGger:ARM:EXECute

Stops the waveform output to arm the trigger.

Example: See Example "To manage waveform files" on page 532.

Usage: Event

Manual operation: See "Arm" on page 78

[:SOURce<hw>]:BB:ARBitrary:TRIGger:EXECute

Triggers signals generation manually for an internal trigger event.

Example: See Example "To configure trigger settings" on page 555.

Usage: Event

Manual operation: See "Execute Trigger" on page 78

[:SOURce<hw>]:BB:ARBitrary:TRIGger[:EXTernal]:SYNChronize:OUTPut
<Output>

Enables signal output synchronous to the trigger event.
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Parameters:
<Output> 1 | ON | 0 | OFF

*RST: 1

Example: See Example "To configure trigger settings" on page 555.

Manual operation: See "Sync. Output to External Trigger/Sync. Output to Trigger"
on page 79

[:SOURce<hw>]:BB:ARBitrary:TRIGger:PTIMe?

Queries the internal processing time.

The processing time is the elapsed time between the input of the external trigger event
and the output of the baseband signal.

Return values: 
<ArbTrigProcTime> string

Example: See Example "To configure trigger settings" on page 555.

Usage: Query only

Manual operation: See "Processing Time" on page 79

[:SOURce<hw>]:BB:ARBitrary:TRIGger:DELay:UNIT <TrigDelUnit>

Sets the unit of the trigger delay.

Parameters:
<TrigDelUnit> SAMPle | TIME

*RST: SAMPle

Example: See Example "To specify delay and inhibit values in time units"
on page 555.

Manual operation: See "(External) Delay Unit" on page 79

[:SOURce<hw>]:BB:ARBitrary:TRIGger[:EXTernal]:DELay <Delay>

Specifies the trigger delay in samples.

Maximum trigger delay and trigger inhibit values depend on the installed options. See
"To set delay and inhibit values" on page 58.

Parameters:
<Delay> float

Range: 0  to  depends on the sample rate
Increment: 0.01
*RST: 0
Default unit: sample

Example: See Example "To specify delay and inhibit values in time units"
on page 555.
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Manual operation: See "(Specified) External Delay/(Specified) Trigger Delay"
on page 79

[:SOURce<hw>]:BB:ARBitrary:TRIGger[:EXTernal]:TDELay <ExtTimeDelay>

Specifies the trigger delay for external triggering. The value affects all external trigger
signals.

Maximum trigger delay and trigger inhibit values depend on the installed options. See
"To set delay and inhibit values" on page 58.

Parameters:
<ExtTimeDelay> float

Range: 0  to  2147483647 / (clock frequency)
Increment: 1E-9
*RST: 0
Default unit: s

Example: See Example "To specify delay and inhibit values in time units"
on page 555.

Manual operation: See "(Specified) External Delay/(Specified) Trigger Delay"
on page 79

[:SOURce<hw>]:BB:ARBitrary:TRIGger[:EXTernal]:RDELay?

Queries the time (in seconds) an external trigger event is delayed for.

Return values: 
<ResTimeDelaySec> float

Range: 0  to  688
Increment: 0.25E-9
*RST: 0

Example: See Example "To specify delay and inhibit values in time units"
on page 555.

Usage: Query only

Manual operation: See "Actual Trigger Delay/Actual External Delay" on page 80

[:SOURce<hw>]:BB:ARBitrary:TRIGger[:EXTernal]:INHibit <Inhibit>

Sets the number of samples that inhibit a restart of the signal generation.

Maximum trigger delay and trigger inhibit values depend on the installed options. See
"To set delay and inhibit values" on page 58.

Parameters:
<Inhibit> integer

Range: 0  to  21.47 * (clock frequency)
*RST: 0
Default unit: samples
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Example: See Example "To specify delay and inhibit values in time units"
on page 555.

Manual operation: See "External Inhibit/Trigger Inhibit" on page 79

13.16.2.7  Marker commands

[:SOURce<hw>]:BB:ARBitrary:TRIGger:OUTPut<ch>:MODE............................................. 561
[:SOURce<hw>]:BB:ARBitrary:TRIGger:OUTPut<ch>:ONTime...........................................561
[:SOURce<hw>]:BB:ARBitrary:TRIGger:OUTPut<ch>:OFFTime......................................... 561
[:SOURce<hw>]:BB:ARBitrary:TRIGger:OUTPut<ch>:PATTern...........................................561
[:SOURce<hw>]:BB:ARBitrary:TRIGger:OUTPut<ch>:PULSe:DIVider.................................562
[:SOURce<hw>]:BB:ARBitrary:TRIGger:OUTPut<ch>:PULSe:FREQuency?........................ 562
[:SOURce<hw>]:BB:ARBitrary:TRIGger:OUTPut<ch>:DELay............................................. 562
[:SOURce<hw>]:BB:ARBitrary:TRIGger:OUTPut<ch>:DINSec?..........................................563

[:SOURce<hw>]:BB:ARBitrary:TRIGger:OUTPut<ch>:MODE <Mode>

Sets the marker mode that is the marker signal for the selected marker output.

See also Chapter 4.2.4.1, "Marker modes", on page 59.

Parameters:
<Mode> UNCHanged | RESTart | PULSe | PATTern | RATio

UNCHanged
A marker signal as defined in the waveform file (tag 'marker
mode x') is generated.
*RST: UNCHanged

Example: See Example "To configure marker signals" on page 533.

Manual operation: See "Mode" on page 81

[:SOURce<hw>]:BB:ARBitrary:TRIGger:OUTPut<ch>:ONTime <OnTime>
[:SOURce<hw>]:BB:ARBitrary:TRIGger:OUTPut<ch>:OFFTime <OffTime>
Sets the number of samples or duration of the marker-on and marker-off periods.

Parameters:
<OffTime> integer

Range: 1  to  14913079
*RST: 1

Example: See Example "To configure marker signals" on page 533.

Manual operation: See "Mode" on page 81

[:SOURce<hw>]:BB:ARBitrary:TRIGger:OUTPut<ch>:PATTern <Pattern>,
<BitCount>

Sets the bit pattern to generate the marker signal.
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Parameters:
<Pattern> numeric

*RST: #H2

<BitCount> integer
0 = marker off, 1 = marker on
Range: 1  to  64
*RST: 2

Example: See Example "To configure marker signals" on page 533.

Manual operation: See "Mode" on page 81

[:SOURce<hw>]:BB:ARBitrary:TRIGger:OUTPut<ch>:PULSe:DIVider <Divider>

Sets the divider for the pulsed marker signal.

Parameters:
<Divider> integer

Range: 2  to  1024
*RST: 2

Example: See Example "To configure marker signals" on page 533.

Manual operation: See "Mode" on page 81

[:SOURce<hw>]:BB:ARBitrary:TRIGger:OUTPut<ch>:PULSe:FREQuency?

Queries the pulse frequency of the pulsed marker signal. The pulse frequency is the
symbol rate divided by the divider.

Return values: 
<Frequency> float

Increment: 0.001

Example: See Example "To configure marker signals" on page 533.

Usage: Query only

Manual operation: See "Mode" on page 81

[:SOURce<hw>]:BB:ARBitrary:TRIGger:OUTPut<ch>:DELay <Delay>

Sets the delay between the signal on the marker outputs and the start of the signal.

Parameters:
<Delay> integer

Range: 0  to  depends on other values
Increment: 0.001
*RST: 0
Default unit: Symbol

Example: See Example "To configure marker signals" on page 533.
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Manual operation: See "Delay" on page 81

[:SOURce<hw>]:BB:ARBitrary:TRIGger:OUTPut<ch>:DINSec?

Queries the marker delay in microseconds.

You can define a marker delay in samples via the following command:

[:SOURce<hw>]:BB:ARBitrary:TRIGger:OUTPut<ch>:DELay on page 562

Return values: 
<DelayInS> float

Range: 0  to  16777215
Increment: 1E-3
*RST: 0

Example: See Example "To configure marker signals" on page 533.

Usage: Query only

Manual operation: See "Delay (Time)" on page 81

13.16.2.8  Clock commands

[:SOURce<hw>]:BB:ARBitrary:CLOCk:SOURce <Source>

Selects the clock source:
● INTernal: Internal clock reference

Parameters:
<Source> INTernal

*RST: INTernal

Example: See Example "To configure clock settings" on page 534.

Manual operation: See "Clock Source" on page 82

13.16.2.9  Crest factor reduction commands

Option: R&S SFI-K548

This section provides commands for the SOURce:BB:ARBitrary:CFR subsystem.

Example: Preparing for CFR
// Load an ARB waveform file, e.g., the file "test.wv".
SOURce1:BB:ARBitrary:LOAD "test"
// Activate ARB.
SOURce1:BB:ARBitrary:STATe 1
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Example: Applying clipping and filtering algorithm
// Set for filter and clipping CFR algorithm.
SOURce1:BB:ARBitrary:CFR:ALGorithm CLFiltering
SOURce1:BB:ARBitrary:CFR:DCFDelta -3
SOURce1:BB:ARBitrary:CFR:ITERations 5

// Configure simple filtering.
SOURce1:BB:ARBitrary:CFR:FILTer SIMPle
SOURce1:BB:ARBitrary:CFR:CSPacing 20E6
SOURce1:BB:ARBitrary:CFR:SBANdwidth 18E6

// Configure enhanced filtering.
SOURce1:BB:ARBitrary:CFR:FILTer ENHanced
SOURce1:BB:ARBitrary:CFR:PFReq 9E6
SOURce1:BB:ARBitrary:CFR:SFReq 11E6
SOURce1:BB:ARBitrary:CFR:FORDer 100

Example: Applying peak cancellation algorithm
// Set for peak cancellation CFR algorithm.
SOURce1:BB:ARBitrary:CFR:ALGorithm PCANcellation
SOURce1:BB:ARBitrary:CFR:DCFDelta -3
// Set a cancellation pulse bandwidth of 800 kHz.
SOURce1:BB:ARBitrary:CFR:CPBandwidth 800000
// Set a transition bandwidth of 10 kHz.
SOURce1:BB:ARBitrary:CFR:TBANdwidth 10000

Example: Activating and monitoring CFR characteristics
SOURce1:BB:ARBitrary:CFR:STATe 1
SOURce1:BB:ARBitrary:CFR:MEASure:STATe?
// Response: "1"
// Query the original crest factor.
SOURce1:BB:ARBitrary:CFR:OCFactor?
// Response: "6"
// Query the resulting crest factor.
SOURce1:BB:ARBitrary:CFR:RCFactor?
// Response: "3"
// Create the waveform file "cfr.wv" with reduced crest factor.
SOURce1:BB:ARBitrary:CFR:CREate "cfr"

Commands:

[:SOURce<hw>]:BB:ARBitrary:CFR[:STATe]..................................................................... 565
[:SOURce<hw>]:BB:ARBitrary:CFR:ALGorithm.................................................................565
[:SOURce<hw>]:BB:ARBitrary:CFR:CPBandwidth.............................................................565
[:SOURce<hw>]:BB:ARBitrary:CFR:CSPacing.................................................................. 566
[:SOURce<hw>]:BB:ARBitrary:CFR:DCFDelta.................................................................. 566
[:SOURce<hw>]:BB:ARBitrary:CFR:FILTer....................................................................... 566
[:SOURce<hw>]:BB:ARBitrary:CFR:FORDer.................................................................... 566
[:SOURce<hw>]:BB:ARBitrary:CFR:ITERations................................................................ 567
[:SOURce<hw>]:BB:ARBitrary:CFR:MEASure[:STATe]?.....................................................567
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[:SOURce<hw>]:BB:ARBitrary:CFR:OCFactor?.................................................................567
[:SOURce<hw>]:BB:ARBitrary:CFR:PFReq...................................................................... 568
[:SOURce<hw>]:BB:ARBitrary:CFR:RCFactor?.................................................................568
[:SOURce<hw>]:BB:ARBitrary:CFR:SBANdwidth.............................................................. 568
[:SOURce<hw>]:BB:ARBitrary:CFR:SFReq...................................................................... 569
[:SOURce<hw>]:BB:ARBitrary:CFR:TBANdwidth.............................................................. 569
[:SOURce<hw>]:BB:ARBitrary:CFR:WAVeform:CREate..................................................... 569

[:SOURce<hw>]:BB:ARBitrary:CFR[:STATe] <ArbCfrState>

Enables the crest factor reduction calculation.

Parameters:
<ArbCfrState> 1 | ON | 0 | OFF

*RST: 0

Manual operation: See "State" on page 133

[:SOURce<hw>]:BB:ARBitrary:CFR:ALGorithm <ArbCfrAlgorithm>

Defines the algorithm for crest factor reduction.

Parameters:
<ArbCfrAlgorithm> CLFiltering | PCANcellation

CLFiltering
Clipping and filtering algorithm. This algorithm performs a hard
clipping of the baseband signal. It is followed by a low pass filter-
ing of the result in an iterative manner until the target crest factor
is reached. You can define the settings of the filter that is used
for the calculation.
PCANcellation
Peak cancelation algorithm. This algorithm subtracts Blackman
windowed sinc pulses from the signal wherever the amplitude is
above a defined threshold.
*RST: CLFiltering

Example: See Example "Applying clipping and filtering algorithm"
on page 564.

Example: See Example "Applying peak cancellation algorithm"
on page 564.

Manual operation: See "Algorithm" on page 133

[:SOURce<hw>]:BB:ARBitrary:CFR:CPBandwidth <ArbCfrCancPulBw>

Sets the cancellation pulse bandwidth for peak cancellation CFR algorithm.
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Parameters:
<ArbCfrCancPulBw> float

Range: 0  to  250E6
Increment: 0.1

Example: See Example "Applying peak cancellation algorithm"
on page 564.

Manual operation: See "Cancellation Pulse Bandwidth" on page 136

[:SOURce<hw>]:BB:ARBitrary:CFR:CSPacing <ArbCfrChanSpac>

Sets the channel spacing, if [:SOURce<hw>]:BB:ARBitrary:CFR:FILTer is set to
SIMPle.

Parameters:
<ArbCfrChanSpac> float

Range: 0  to  depends on the sample rate of the loaded file
Increment: 0.1
*RST: 250E6

Manual operation: See "Channel Spacing" on page 135

[:SOURce<hw>]:BB:ARBitrary:CFR:DCFDelta <ArbCfrDCFDelta>

Sets the value difference by which you want to change your crest factor.

Parameters:
<ArbCfrDCFDelta> float

Range: -20  to  0
Increment: 0.1
*RST: -3

Manual operation: See "Desired Crest Factor Delta" on page 133

[:SOURce<hw>]:BB:ARBitrary:CFR:FILTer <ArbCfrFilterMod>

Selects which filter mode is used for the filtering.

Parameters:
<ArbCfrFilterMod> SIMPle | ENHanced

*RST: SIMPle

Manual operation: See "Filter Mode" on page 134

[:SOURce<hw>]:BB:ARBitrary:CFR:FORDer <ArbCfrMaxFilOrd>

Sets the maximum filter order, if [:SOURce<hw>]:BB:ARBitrary:CFR:FILTer is
set to ENHanced.
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Parameters:
<ArbCfrMaxFilOrd> integer

Range: 0  to  300
*RST: 100

Example: See Example "Applying clipping and filtering algorithm"
on page 564.

Manual operation: See "Maximum Filter Order" on page 136

[:SOURce<hw>]:BB:ARBitrary:CFR:ITERations <ArbCfrMaxIter>

Sets the number of iterations that are used for calculating the resulting crest factor. The
iteration process is stopped when the desired crest factor delta is achieved by 0.1 dB.

Parameters:
<ArbCfrMaxIter> integer

Range: 1  to  10
*RST: 5

Manual operation: See "Max Iterations" on page 133

[:SOURce<hw>]:BB:ARBitrary:CFR:MEASure[:STATe]?

Queries the state of the crest factor reduction calculation.

Return values: 
<MeasureState> 1 | ON | 0 | OFF

ON: the original and resulting crest factors are already calcula-
ted.
*RST: 0

Example: See Example "Activating and monitoring CFR characteristics"
on page 564.

Usage: Query only

[:SOURce<hw>]:BB:ARBitrary:CFR:OCFactor?

Queries the original crest factor of the waveform after the calculation of the resulting
crest factor is completed. The original crest factor is calculated as an average over the
whole waveform, including any idle periods that might be present in TDD waveforms.

Return values: 
<ArbCfrOCrestFac> float

Range: 1  to  100
Increment: 0.01
*RST: 6

Usage: Query only

Manual operation: See "Original Crest Factor" on page 134
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[:SOURce<hw>]:BB:ARBitrary:CFR:PFReq <ArbCfrPassBFreq>

Sets the passband frequency, if [:SOURce<hw>]:BB:ARBitrary:CFR:FILTer is
set to ENHanced. Frequency components lower than the passband frequency are
passed through unfiltered.

Parameters:
<ArbCfrPassBFreq> float

Range: 0  to  depends on the sample rate of the loaded file
Increment: 0.1
*RST: 250E6

Example: See Example "Applying clipping and filtering algorithm"
on page 564.

Manual operation: See "Passband Frequency" on page 135

[:SOURce<hw>]:BB:ARBitrary:CFR:RCFactor?

Queries the resulting crest factor of the waveform after the calculations are completed.
The resulting crest factor is calculated as an average over the whole waveform, includ-
ing any idle periods that might be present in TDD waveforms.

Return values: 
<ArbCfrResCreFac> float

Range: 1  to  100
Increment: 0.1
*RST: 6

Example: See Example "Activating and monitoring CFR characteristics"
on page 564.

Usage: Query only

Manual operation: See "Resulting Crest Factor" on page 134

[:SOURce<hw>]:BB:ARBitrary:CFR:SBANdwidth <ArbCfrSignalBw>

Sets the signal bandwidth, if [:SOURce<hw>]:BB:ARBitrary:CFR:FILTer is set
to SIMPle.

The value of the signal bandwidth should not be higher than the channel spacing ([:
SOURce<hw>]:BB:ARBitrary:CFR:CSPacing).

Parameters:
<ArbCfrSignalBw> float

Range: 0  to  depends on the sample rate of the loaded file
Increment: 0.1
*RST: 250E6

Manual operation: See "Signal Bandwidth" on page 135
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[:SOURce<hw>]:BB:ARBitrary:CFR:SFReq <ArbCfrStopBFreq>

Sets the stopband frequency of the filter, if [:SOURce<hw>]:BB:ARBitrary:CFR:
FILTer is set to ENHanced. Frequency components higher than the stopband fre-
quency are filtered out by the lowpass filter.

Parameters:
<ArbCfrStopBFreq> float

Range: 0  to  depends on the sample rate of the loaded file
Increment: 0.1
*RST: 250E6

Example: See Example "Applying clipping and filtering algorithm"
on page 564.

Manual operation: See "Stopband Frequency" on page 135

[:SOURce<hw>]:BB:ARBitrary:CFR:TBANdwidth <DDArbCfrTranBw>

Sets the transition bandwidth of the cancellation pulse for peak cancellation CFR algo-
rithm.

Parameters:
<DDArbCfrTranBw> float

Range: 0  to  250E6
Increment: 0.1

Example: See Example "Applying peak cancellation algorithm"
on page 564.

Manual operation: See "Transition Bandwidth" on page 136

[:SOURce<hw>]:BB:ARBitrary:CFR:WAVeform:CREate <CreateWvFile>

With enabled signal generation, triggers the instrument to save the current settings in a
waveform file. Waveform files can be further processed.

The filename and the directory it is saved in are user-definable; the predefined file
extension for waveform files is *.wv.

Setting parameters: 
<CreateWvFile> string

Example: See Example "Activating and monitoring CFR characteristics"
on page 564.

Usage: Setting only

Manual operation: See "Generate Waveform" on page 133

13.16.3  SOURce:BB:GRAPhics subsystem

This subsystem contains the commands used to setup the graphical display.
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Required options

See Chapter 9.1, "Required options", on page 255.

[:SOURce<hw>]:BB:GRAPhics:MODE............................................................................. 570
[:SOURce<hw>]:BB:GRAPhics:SRATe:MODE.................................................................. 570
[:SOURce<hw>]:BB:GRAPhics:SRATe:USER................................................................... 570
[:SOURce]:BB:GRAPhics:CLOSe.................................................................................... 571
[:SOURce]:BB:GRAPhics:ADD........................................................................................571
[:SOURce]:BB:GRAPhics:SOURce.................................................................................. 571
[:SOURce]:BB:GRAPhics:FFTLen................................................................................... 572
[:SOURce]:BB:GRAPhics:FFTFscale............................................................................... 572
[:SOURce<hw>]:BB:GRAPhics:TRIGger:SOURce.............................................................572

[:SOURce<hw>]:BB:GRAPhics:MODE <Mode>

Selects the graphics mode of the graphical signal display.

Parameters:
<Mode> IQ | VECTor | CCDF | PSPectrum | CONStellation | EYEI | EYEQ

*RST: IQ

Example: BB:GRAP:MODE VECT
Selects the vector diagram graphics mode.

Manual operation: See "Mode" on page 264

[:SOURce<hw>]:BB:GRAPhics:SRATe:MODE <Mode>

Sets how the time resolution of the signal is determined. Maximum resolution corre-
sponds to a diagram covering the entire signal bandwidth. The higher the resolution is,
the shorter the length of the displayed signal segment will be for the specified record-
ing depth.

Parameters:
<Mode> AUTO | FULL | USER

*RST: AUTO

Example: BB:GRAP:SRAT:MODE FULL
Sets the sample rate mode.

Manual operation: See "Sample Rate Mode" on page 265

[:SOURce<hw>]:BB:GRAPhics:SRATe:USER <User>

(Enabled for BB:GRAPH:SRAT:MODE USER)

Selects the signal bandwidth for the diagram. The setting range moves between the
minimum and maximum bandwidth which is possible for the selected graphical signal
display. The selection is made graphically by moving the pointer.
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Parameters:
<User> float

Range: 0.01  to  100
Increment: 0.01
*RST: 10
Default unit: PCT

Example: BB:GRAP:SRAT:USER 20
sets the sample rate factor.

Example: BB:GRAP:SRAT:MODE USER
sets the sample rate mode.

Manual operation: See "Sample Rate" on page 265

[:SOURce]:BB:GRAPhics:CLOSe

Closes all graphical signal displays.

Usage: Event

Manual operation: See "Remove" on page 266

[:SOURce]:BB:GRAPhics:ADD <Size>

Adds a graphical signal display (according to the current MODE, SOURce, SRATe:* and
TRIGger:* settings).

Setting parameters: 
<Size> MAXimized | MINimized

Usage: Setting only

Manual operation: See "Add" on page 265

[:SOURce]:BB:GRAPhics:SOURce <Source>

Defines the signal acquisition point, that is the location in the signal flow where the dis-
played signal is tapped from.

See Chapter 9.2.2, "Signal acquisition points", on page 260.

Parameters:
<Source> STRA | BBA | RFA | BBIA | DO1 | IQO1

STRA
Stream A; input stream of the "IQ Stream Mapper"
BBA
Baseband signal
BBIA
Digital baseband input signals
RFA
RF signal
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*RST: STRA

Manual operation: See "Source" on page 264

[:SOURce]:BB:GRAPhics:FFTLen <Mode>

Sets the FFT size.

Parameters:
<Mode> LEN256 | LEN512 | LEN1024 | LEN2048 | LEN4096

*RST: LEN2048

Example: SOURce:BB:GRAPhics:FFTLen LEN2048
Manual operation: See "FFT Length" on page 264

[:SOURce]:BB:GRAPhics:FFTFscale <State>

Defines the normalization of the power values in the power spectrum diagram.

Parameters:
<State> 1 | ON | 0 | OFF

1
Normalized power in dBFS
0
Shows power distribution in dB/Hz
*RST: 0

Example: SOURce:BB:GRAPhics:FFTFscale PSPectrum
SOURce:BB:GRAPhics:FFTFscale 1
// the power spectrum shows the normalized power in dBFS

Manual operation: See "Full Scale (dBFS)" on page 264

[:SOURce<hw>]:BB:GRAPhics:TRIGger:SOURce <Source>

Defines the trigger for the starting time of the graphic recording.

Parameters:
<Source> SOFTware | MARKer

*RST: SOFTware

Example: SOURce1:BB:GRAPhics:TRIGger:SOURce MARKer
Sets the trigger source.

Manual operation: See "Trigger Source" on page 264

13.16.4  SOURce:BB:IMPairment subsystem

This subsystem contains the commands for the analog and digital I/Q impairments.
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This subsystem contains the commands for digital I/Q impairments before the I/Q mod-
ulator and at the analog I/Q outputs.

Common suffixes

Suffix Value range Description

RF<ch> 1 Digital impairments for RF connector

IQOutput<ch> 1 Analog I/Q connector

Required options

See Chapter 6.4.1, "Required options", on page 156.

Commands:

[:SOURce]:BB:IMPairment:IQOutput<ch>:STATe...............................................................573
[:SOURce]:BB:IMPairment:RF<ch>:STATe........................................................................573
[:SOURce]:BB:IMPairment:IQOutput<ch>:DELay.............................................................. 574
[:SOURce]:BB:IMPairment:RF<ch>:DELay....................................................................... 574
[:SOURce]:BB:IMPairment:IQOutput<ch>:IQRatio[:MAGNitude]..........................................574
[:SOURce]:BB:IMPairment:RF<ch>:IQRatio[:MAGNitude].................................................. 574
[:SOURce]:BB:IMPairment:IQOutput<ch>:LEAKage:I........................................................ 575
[:SOURce]:BB:IMPairment:IQOutput<ch>:LEAKage:Q.......................................................575
[:SOURce]:BB:IMPairment:RF<ch>:LEAKage:I................................................................. 575
[:SOURce]:BB:IMPairment:RF<ch>:LEAKage:Q................................................................575
[:SOURce]:BB:IMPairment:IQOutput<ch>:QUADrature[:ANGLe].........................................575
[:SOURce]:BB:IMPairment:RF<ch>:QUADrature[:ANGLe]..................................................575
[:SOURce]:BB:IMPairment:IQOutput<ch>:SKEW.............................................................. 575
[:SOURce]:BB:IMPairment:RF<ch>:SKEW....................................................................... 575
[:SOURce]:BB:IMPairment:IQOutput<ch>:POFFset...........................................................576
[:SOURce]:BB:IMPairment:RF<ch>:POFFset....................................................................576
[:SOURce<hw>]:BB:IMPairment:OPTimization:MODE....................................................... 576

[:SOURce]:BB:IMPairment:IQOutput<ch>:STATe <State>
[:SOURce]:BB:IMPairment:RF<ch>:STATe <State>
Activates the impairment or correction values LEAKage, QUADrature and IQRatio
for the corresponding stream.

Parameters:
<State> 1 | ON | 0 | OFF

*RST: 0

Example: SOURce1:BB:IMPairment:RF1:STATe ON
Activates digital impairment.

Manual operation: See "State" on page 159
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[:SOURce]:BB:IMPairment:IQOutput<ch>:DELay <Delay>
[:SOURce]:BB:IMPairment:RF<ch>:DELay <Delay>
Defines the time delay of both I and Q vectors between the marker signal at the marker
outputs relative to the signal generation start.

A positive value means that the I and Q vectors delay relative to the marker/trigger and
vice versa.
Table 13-1: Value range

Output Min /s Max /s Increment

RF<ch> 0 10E-6 1E-12

IQOutput<ch> -500E-9 500E-9 1E-12

 -500E-9 500E-9 1E-12

Parameters:
<Delay> float

Range: 0  to  10E-6
Increment: 1E-12
*RST: 0

Example: SOURce1:BB:IMPairment:RF1:DELay 32.0E-9
Manual operation: See "IQ Delay" on page 160

[:SOURce]:BB:IMPairment:IQOutput<ch>:IQRatio[:MAGNitude] <IqRatio>
[:SOURce]:BB:IMPairment:RF<ch>:IQRatio[:MAGNitude] <IqRatio>
Sets the ratio of I modulation to Q modulation (amplification imbalance) of the corre-
sponding digital channel.
Table 13-2: Value range

Impairments Min /dB Max /dB Increment

Digital -4 4 0.0001

Analog -1 1 0.0001

Parameters:
<IqRatio> float

The setting value can be either in dB or %. An input in percent is
rounded to the closest valid value in dB.
Range: -4  to  4
Increment: 1E-4
*RST: 0
Default unit: dB | PCT (setting command) / dB (result value)

Example: SOURce:BB:IMPairment:RF1:IQRatio:MAGNitude 10 PCT
SOURce:BB:IMPairment:RF1:IQRatio:MAGNitude?
// 0.848
// the value is returned in dB
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Manual operation: See "Gain Imbalance" on page 160

[:SOURce]:BB:IMPairment:IQOutput<ch>:LEAKage:I <I>
[:SOURce]:BB:IMPairment:IQOutput<ch>:LEAKage:Q <Q>
[:SOURce]:BB:IMPairment:RF<ch>:LEAKage:I <I>
[:SOURce]:BB:IMPairment:RF<ch>:LEAKage:Q <Q>
Determines the leakage amplitude of the I or Q signal component of the corresponding
stream

Parameters:
<Q> float

Range: -10  to  10
Increment: 0.01
*RST: 0

Example: SOURce:BB:IMPairment:RF1:LEAKage:Q 4 PCT
Sets the leakage for the Q-component to 4 percent.

Manual operation: See "I Offset/Q Offset" on page 159

[:SOURce]:BB:IMPairment:IQOutput<ch>:QUADrature[:ANGLe] <Angle>
[:SOURce]:BB:IMPairment:RF<ch>:QUADrature[:ANGLe] <Angle>
Sets a quadrature offset (phase angle) between the I and Q vectors deviating from the
ideal 90 degrees.

A positive quadrature offset results in a phase angle greater than 90 degrees.
Table 13-3: Value range

Impairments Min /dB Max /dB Increment

Digital -30 30 0.01

Analog -10 10 0.01

Parameters:
<Angle> float

Range: -30  to  30
Increment: 0.01
*RST: 0
Default unit: DEG

Example: SOURce:BB:IMPairment:RF1:QUADrature:ANGLe -5
Sets the quadrature offset to -5 degrees.

Manual operation: See "Quadrature Offset" on page 160

[:SOURce]:BB:IMPairment:IQOutput<ch>:SKEW <Skew>
[:SOURce]:BB:IMPairment:RF<ch>:SKEW <Skew>
Sets a delay between the Q vector and the I vector of the corresponding stream.
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Parameters:
<Skew> float

Range: -500E-9  to  500E-9
Increment: 1E-12
*RST: 0

Manual operation: See "Skew" on page 160

[:SOURce]:BB:IMPairment:IQOutput<ch>:POFFset <PhaseOffset>
[:SOURce]:BB:IMPairment:RF<ch>:POFFset <PhaseOffset>
Adds an additional phase offset after the stream mapper.

You can shift the phase at the different stages in the signal generation flow, see:
● [:SOURce<hw>]:BB:POFFset on page 530

Parameters:
<PhaseOffset> float

Range: -999.99  to  999.99
Increment: 0.01
*RST: 0

Example: SOURce:BB:IMPairment:RF1:POFFset 0

Manual operation: See "Phase Offset" on page 160

[:SOURce<hw>]:BB:IMPairment:OPTimization:MODE <Mode>

Sets the optimization mode for I/Q modulation.

If equipped with option R&S SFI-K544, the optimization mode applies for the I/Q modu-
lation performance and for the user-defined frequency response corrections.

See the user manual "R&S SFI-K544 User-Defined Frequency Response Correction".

Parameters:
<Mode> FAST | | QHTable

FAST
Fast optimization by compensating for I/Q skew.
QHTable
Improves the frequency response while maintaining setting time,
there is no signal interruption.
*RST: FAST
*RST: QHTable for the R&S SFI100A

Example: :SOURce1:IQ:SOURce?
// Response: "BASeband"
// The I/Q signal source is the internal baseband signal.
:SOURce1:BB:IMPairment:OPTimization:MODE FAST

Manual operation: See "Optimization Mode" on page 153
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13.16.5  SOURce:BB:PROGress subsystem

In the R&S SFI100A, some calculation processes take longer time. While operating the
instrument manually, you can observe the status of an initiated process by the busy
indicator. The following commands fulfill the same task in the remote control operation.

Example: Querying the status of the "Create Waveform"
The following example provides information on the status during the "Create Wave-
form" file processing. You can query progress information of this process.

:SOURce1:BB:PROGress:MCODer?
// 100 (task completed)
:SOURce1:BB:ARB:STATe ON
:SOURce1:BB:PROGress:MCODer?
// 67 (task in progress)

[:SOURce<hw>]:BB:PROGress:MCODer?........................................................................577
[:SOURce<hw>]:BB:PROGress:MCODer:ARBitrary:MCARrier?..........................................577

[:SOURce<hw>]:BB:PROGress:MCODer?
[:SOURce<hw>]:BB:PROGress:MCODer:ARBitrary:MCARrier?
Queries the status of an initiated process, like, for example, the calculation of a multi-
carrier waveform file.

Return values: 
<MCarrier> integer

Indicates the task progress in percent
Range: 0  to  100
*RST: 100

Example: See Example "Querying the status of the "Create Waveform""
on page 577.

Usage: Query only

13.17  STATus subsystem

This system contains the commands for the status reporting system. See also Chap-
ter 12.4, "Status reporting system", on page 354 for detailed information.

*RST on page 409 has no effect on the status registers.

Value ranges

● Queries return the current value of the respective register, which permits a check of
the device status.
Return values: A decimal value in the range 0 to 32767 (=215-1)
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● The configuration commands set the respective register thus determining which
status changes of the R&S SFI100A cause the status registers to be changed.
Setting values: A decimal value in the range 0 to 32767 (=215-1)

:STATus:OPERation:CONDition?.....................................................................................578
:STATus:OPERation:ENABle...........................................................................................578
:STATus:OPERation[:EVENt]...........................................................................................578
:STATus:OPERation:NTRansition.................................................................................... 579
:STATus:OPERation:PTRansition.....................................................................................579
:STATus:PRESet............................................................................................................579
:STATus:QUEStionable:CONDition.................................................................................. 580
:STATus:QUEStionable:ENABle.......................................................................................580
:STATus:QUEStionable[:EVENt]...................................................................................... 580
:STATus:QUEStionable:NTRansition................................................................................ 580
:STATus:QUEStionable:PTRansition................................................................................ 581
:STATus:QUEue[:NEXT]?................................................................................................581

:STATus:OPERation:CONDition?

Quieries the content of the CONDition part of the STATus:OPERation register.

This part contains information on the action currently being performed in the instru-
ment. The content is not deleted after being read out because it indicates the current
hardware status.

Return values: 
<Condition> string

Example: :STATus:OPERation:CONDition?

Usage: Query only

:STATus:OPERation:ENABle <Enable>

Sets the bits of the ENABle part of the STATus:OPERation register. This setting deter-
mines which events of the Status-Event part are forwarded to the sum bit in the status
byte. These events can be used for a service request.

Parameters:
<Enable> string

Example: :STAT:OPER:ENAB 32767
all events are forwarded to the sum bit of the status byte.

:STATus:OPERation[:EVENt] < >

Queries the content of the EVENt part of the STATus:OPERation register. This part
contains information on the actions performed in the instrument since the last readout.
The content of the EVENt part is deleted after being read out.

Parameters:
< > string
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Example: :STAT:OPER:EVEN?
queries the STATus:OPERation:EVENt register.

:STATus:OPERation:NTRansition <Ntransition>

Sets the bits of the NTRansition part of the STATus:OPERation register. If a bit is set, a
transition from 1 to 0 in the condition part causes an entry to be made in the EVENt
part of the register. The disappearance of an event in the hardware is thus registered,
for example the end of an adjustment.

Parameters:
<Ntransition> string

Example: :STAT:OPER:NTR 0
a transition from 1 to 0 in the condition part of the Status:Opera-
tion register does not cause an entry to be made in the EVENt
part.

:STATus:OPERation:PTRansition <Ptransition>

Sets the bits of the PTRansition part of the STATus:OPERation register. If a bit is set, a
transition from 0 to 1 in the condition part causes an entry to be made in the EVENt
part of the register. A new event in the hardware is thus registered, for example the
start of an adjustment.

Parameters:
<Ptransition> string

Example: :STAT:OPER:PTR 32767
all transitions from 0 to 1 in the condition part of the Status:Oper-
ation register cause an entry to be made in the EVENt part.

:STATus:PRESet <Preset>

Resets the status registers. All PTRansition parts are set to FFFFh (32767), i.e. all
transitions from 0 to 1 are detected. All NTRansition parts are set to 0, i.e. a transition
from 1 to 0 in a CONDition bit is not detected. The ENABle parts of STATus:OPERation
and STATus:QUEStionable are set to 0, i.e. all events in these registers are not passed
on.

Parameters:
<Preset> string

Example: STAT:PRES
resets the status registers.
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:STATus:QUEStionable:CONDition <Condition>

Queries the content of the CONDition part of the STATus:QUEStionable register. This
part contains information on the action currently being performed in the instrument.
The content is not deleted after being read out since it indicates the current hardware
status.

Parameters:
<Condition> string

Example: :STATus:QUEStionable:CONDition?
queries the Status:Questionable:Condition register.

:STATus:QUEStionable:ENABle <Enable>

Sets the bits of the ENABle part of the STATus:QUEStionable register. The enable part
determines which events of the STATus:EVENt part are enabled for the summary bit in
the status byte. These events can be used for a service request.

If a bit in the ENABle part is 1, and the correesponding EVENt bit is true, a positive
transition occurs in the summary bit. This transition is reportet to the next higher level.

Parameters:
<Enable> string

Example: STAT:QUES:ENAB 1
Problems when performing an adjustment cause an entry to be
made in the sum bit.

:STATus:QUEStionable[:EVENt] < >

Queries the content of the EVENt part of the STATus:QUEStionable register. This
part contains information on the actions performed in the instrument since the last
readout. The content of the EVENt part is deleted after being read out.

Parameters:
< > string

Example: STAT:QUES:EVEN?
queries the Status:Questionable:Event register.

:STATus:QUEStionable:NTRansition <Ntransition>

Sets the bits of the NTRansition part of the STATus:QUEStionable register. If a bit is
set, a transition from 1 to 0 in the condition part causes an entry to be made in the
EVENt part of the register.

Parameters:
<Ntransition> string
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Example: STAT:QUES:NTR 0
a transition from 1 to 0 in the condition part of the STA-
Tus:QUEStionable register does not cause an entry to be made
in the EVENt part

:STATus:QUEStionable:PTRansition <PTransition>

Sets the bits of the NTRansition part of the STATus:QUEStionable register. If a bit is
set, a transition from 1 to 0 in the condition part causes an entry to be made in the
EVENt part of the register.

Parameters:
<PTransition> string

Example: STAT:QUES:PTR 32767
all transitions from 0 to 1 in the condition part of the STA-
Tus:QUEStionable register cause an entry to be made in the
EVENt part

:STATus:QUEue[:NEXT]?

Queries the oldest entry in the error queue and then deletes it. Positive error numbers
denote device-specific errors, and negative error numbers denote error messages
defined by SCPI. If the error queue is empty, 0 ("No error") is returned.

The command is identical to :SYSTem:ERRor[:NEXT]? on page 588.

Return values: 
<Next> string

Example: :STATus:QUEue?
queries the oldest entry in the error queue.
Response: 0, 'no error'
no errors have occurred since the error queue was last read out

Usage: Query only

13.18  SYSTem subsystem

The SYSTem subsystem contains a series of commands for general functions which do
not directly affect signal generation.

Example: Retrieving instrument specification
Note: The following values are merely an example.
// Retrieve information on data sheet versions.
// Query all data sheet versions saved on the instrument:
SYSTem:SPECification:VERSion:CATalog?
"04.03,04.02,04.01,04.00,03.04,03.03,03.02,03.01,03.00,02.96,02.95,02.94,
02.02,02.01,02.00,01.03,01.02,01.01,01.00"
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// Query the initial data sheet version on delivery
SYSTem:SPECification:VERSion:FACTory?
// Response: "04.00"

// Select a specific data sheet version:
SYSTem:SPECification:VERSion "04.01"

// Retrieve information on parameters that belong to a particular data sheet.
// Query the IDs of all parameters listed in the selected version:
SYSTem:SPECification:VERSion "04.03"
SYSTem:SPECification:IDENtification:CATalog?
"ID_RF_FREQ_SETTING_TIME_ALC_ON_MS,ID_RF_FREQ_SETTING_TIME_MS,..."

// Query data sheet information on a specific parameter by its ID.
SYSTem:SPECification? "ID_RF_FREQ_SETTING_TIME_ALC_ON_MS"
// Returns the specified value of the parameter.

Example: Retrieving information on network-related settings
SYSTem:COMMunicate:NETWork:STATus?
// 1
SYSTem:PROTection1:STATe 0,123456

SYSTem:COMMunicate:NETWork:IPADdress:MODE STAT
SYSTem:COMMunicate:NETWork:IPADdress "10.113.0.104"
SYSTem:COMMunicate:NETWork:IPADdress:DNS "10.0.2.166"
SYSTem:COMMunicate:NETWork:COMMon:HOSTname?
// "SFI100A-102030"
SYSTem:COMMunicate:NETWork:COMMon:WORKgroup "instrument"
SYSTem:COMMunicate:NETWork:COMMon:DOMain "rsint.net"
SYSTem:COMMunicate:NETWork:IPADdress:GATeway "10.113.0.1"
SYSTem:COMMunicate:NETWork:IPADdress:SUBNet:MASK "255.255.252.0"
SYSTem:COMMunicate:NETWork:MACaddress "08 00 27 a3 a1 70"
SYSTem:PROTection1:STATe 1

Example: Restarting the network
SYSTem:COMMunicate:NETWork:RESTart
// terminates the network connection and sets it up again

Example: Finding out VISA resource strings
SYSTem:COMMunicate:NETWork:RESource?
// Response: "TCPIP::10.113.0.104::inst0::INSTR"

SYSTem:COMMunicate:HISLip:RESource?
// Response: "TCPIP::10.113.0.104::hislip0::INSTR"

SYSTem:COMMunicate:SOCKet:RESource?
// Response: "TCPIP::10.113.0.104::5025::SOCKET"
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SYSTem:COMMunicate:USB:RESource?
// "USB::0x0AAD::0x01df::100001::INSTR"

Disabling LAN services

► NOTICE! Risk of loosing access over LAN. Disabling the LAN interface or the com-
mon services "LAN", "SCPI over LAN", "VNC" and "HTTP" locks the remote access
to the instrument.
Use the commands in Example "To disable the LAN interface and LAN services"
on page 583 to disable or enable the LAN interface and LAN interface services
individually.

a) For the first parameter of the command, enter the security password of your
instrument.
The default password is 123456.

b) For the second parameter of the command, enter the state: 1 (ON), 0 (OFF)

Example: To disable the LAN interface and LAN services
// *****************************************************************************
// Disable the LAN interface.
// *****************************************************************************
SYSTem:SECurity:NETWork:STATe "<password>", 0

Example: Querying the error queue
SYSTem:ERRor:STATic?
// Response: -221,"Settings conflict", 153,"Input voltage out of range", ...
// Returns all static errors that are collected in the error queue.

SYSTem:ERRor:HISTory:ClEar
// Deletes the history entries.
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Example: Configuring date and time
// Query the date and time setting of the instrument
// Query the current timezone and setting
SYSTem:DATE?
// Response: 2023,1,16;1
SYSTem:TIME?
// Response: 18,15,17;1
SYStem:TIME:ZONE?
// Response: "";1  //default UTC setting
SYSTem:TIME:PROTocol?
// Response: "OFF";1 // no protocol selected
SYSTem:NTP:STATe?
// Response: 0;1  // NTP is disabled

// Setting the timezone and NTP time protocol
SYSTem:TIME:ZONE:CATalog? 
// Response: "UTC,leap-seconds.list,leapseconds,Africa/Abidjan,..."
SYSTem:TIME:ZONE "Europe/Berlin"  
SYSTem:NTP:HOST "timesource.net"  // sets the NTP server address
SYSTem:NTP:STATe?
// Response: 1  // the NTP time server is enabled

Commands
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:SYSTem:DFPRint..........................................................................................................608
:SYSTem:REBoot...........................................................................................................609
:SYSTem:RESTart..........................................................................................................609
:SYSTem:SHUTdown..................................................................................................... 609
:SYSTem:WAIT..............................................................................................................609

:SYSTem:ERRor:ALL?

Queries the error/event queue for all unread items and removes them from the queue.

Return values: 
<All> string

Error/event_number,"Error/event_description>[;Device-depend-
ent info]"
A comma separated list of error number and a short description
of the error in FIFO order.
If the queue is empty, the response is 0,"No error"
Positive error numbers are instrument-dependent. Negative
error numbers are reserved by the SCPI standard.
Volatile errors are reported once, at the time they appear. Identi-
cal errors are reported repeatedly only if the original error has
already been retrieved from (and hence not any more present in)
the error queue.

Example: SYSTem:ERRor:ALL? 
// queries all entries in the error queue. 
Response: 0, 'no error' 
// no errors have occurred since the error queue was last read out.

Usage: Query only

Manual operation: See "Clear History" on page 618

:SYSTem:ERRor:CODE:ALL?

Queries the error numbers of all entries in the error queue and then deletes them.

Return values: 
<All> string

Returns the error numbers. To retrieve the entire error text, send
the command :SYSTem:ERRor:ALL?.
0
"No error", i.e. the error queue is empty
Positive value
Positive error numbers denote device-specific errors
Negative value
Negative error numbers denote error messages defined by
SCPI.
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Example: SYSTem:ERRor:CODE:ALL? 
// queries all entries in the error queue. 
Response: 0 
// no errors have occurred since the error queue was last read out.

Usage: Query only

:SYSTem:ERRor:CODE[:NEXT]?

Queries the error number of the oldest entry in the error queue and then deletes it.

Return values: 
<Next> string

Returns the error number. To retrieve the entire error text, send
the command :SYSTem:ERRor:ALL?.
0
"No error", i.e. the error queue is empty
Positive value
Positive error numbers denote device-specific errors
Negative value
Negative error numbers denote error messages defined by
SCPI.

Example: SYSTem:ERRor:CODE:NEXT? 
// queries the oldest entry in the error queue. 
Response: 0 
// no errors have occurred since the error queue was last read out.

Usage: Query only

:SYSTem:ERRor:COUNt?

Queries the number of entries in the error queue.

Return values: 
<Count> integer

0
The error queue is empty.

Example: SYSTem:ERRor:COUNt? 
// queries the number of entries in the error queue. 
Response: 1 
// one error has occurred since the error queue was last read out.

Usage: Query only
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:SYSTem:ERRor[:NEXT]?

Queries the error/event queue for the oldest item and removes it from the queue.

Return values: 
<Next> string

Error/event_number,"Error/event_description>[;Device-depend-
ent info]"
Error number and a short description of the error.
If the queue is empty, the response is 0,"No error"
Positive error numbers are instrument-dependent. Negative
error numbers are reserved by the SCPI standard.
Volatile errors are reported once, at the time they appear. Identi-
cal errors are reported repeatedly only if the original error has
already been retrieved from (and hence not any more present in)
the error queue.

Example: SYSTem:ERRor:NEXT? 
// queries the oldest entry in the error queue. 
Response: 0, 'no error' 
// no errors have occurred since the error queue was last read out.

Usage: Query only

Manual operation: See "Static Notifications/History" on page 618

:SYSTem:ERRor:GNEXt?

Similar to :SYSTem:ERRor[:NEXT]?, but queries the next entry from the global per-
sistant error/event queue.

Return values: 
<NextGlobalError> string

Error/event number, "Error/event description> [;Device depend-
ent info]"
An error number and a short description of the error.
Positive error numbers are instrument-dependent. Negative
error numbers are reserved by the SCPI standard.

Example: SYSTem:ERRor:GNEXt?
// queries the next error message from the global error queue.

Usage: Query only

:SYSTem:ERRor:HISTory:CLEar

Clears the error history.

Example: See Example "Querying the error queue" on page 583

Usage: Event

Manual operation: See "Clear History" on page 618
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:SYSTem:ERRor:STATic?

Returns a list of all errors existing at the time when the query is started. This list corre-
sponds to the display on the info page under manual control.

Return values: 
<StaticErrors> string

Example: See Example "Querying the error queue" on page 583

Usage: Query only

Manual operation: See "Static Notifications/History" on page 618

:SYSTem:DLOCk <DispLockStat>

Disables the manual operation over the display, including the front panel keyboard of
the instrument.

Parameters:
<DispLockStat> 1 | ON | 0 | OFF

*RST: n.a. (factory preset: 0)

Example: SYST:DLOC ON
Activates the display lock. The instrument cannot be operated
via the display until it has been enabled with SYST:DLOC OFF.

Manual operation: See "User Interface" on page 325
See "Enabling a locked user interface for manual operation"
on page 326

:SYSTem:KLOCk <State>

Disables the front panel keyboard of the instrument.

Parameters:
<State> 1 | ON | 0 | OFF

*RST: n.a. (factory preset: 0)

Example: SYST:KLOC ON
Locks the front panel and external controls.
To enable the controls, send SYST:KLOC OFF.

Manual operation: See "User Interface" on page 325
See "Enabling a locked user interface for manual operation"
on page 326

:SYSTem:NINFormation?

Queries the oldest information message ("Error History > Level > Info") in the error/
event queue.
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Return values: 
<NextInfo> string

Example: :SYSTem:NINFormation?
Queries the oldest entry in the info message queue.
Response: 90,"Info;=== Instrument startup...
==="
Information message containing error number 90, that states,
that the instrument startup is complete.

Usage: Query only

:SYSTem:ULOCk <SecPassWord>, <Mode>

Locks or unlocks the user interface of the instrument.

Parameters:
<Mode> ENABled | DONLy | DISabled | TOFF | VNConly

ENABled
Unlocks the display, the touchscreen and all controls for the
manual operation.
DONLy
Locks the touchscreen and controls for the manual operation of
the instrument. The display shows the current settings.
VNConly
Locks the touchscreen and controls for the manual operation,
and enables remote operation over VNC. The display shows the
current settings.
TOFF
Locks the touchscreen for the manual operation of the instru-
ment. The display shows the current settings.
DISabled
Locks the display, the touchscreen and all controls for the man-
ual operation.
*RST: n.a. (factory preset: ENABled)

Setting parameters: 
<SecPassWord> string

Example: :SYST:ULOC "<password>", DIS
Activates the user interface lock, including display and controls.

Manual operation: See "User Interface" on page 325
See "Enabling a locked user interface for manual operation"
on page 326

:SYSTem:LOCK:OWNer?

Queries the sessions that have locked the instrument currently.
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If an exclusive lock is set, the query returns the owner of this exclusive lock, otherwise
it returns NONE.

Return values: 
<Owner> string

Example: SYST:LOCK:OWN?
Returns the owner of locking.
Response: NONE
The instrument is not locked.

Usage: Query only

:SYSTem:LOCK:RELease:ALL

Revokes the exclusive access to the instrument.

Usage: Setting only

:SYSTem:LOCK:REQuest[:EXCLusive]?

Queries whether a lock for exclusive access to the instrument via ethernet exists. If
successful, the query returns a 1, otherwise 0.

Return values: 
<Success> integer

Example: SYST:LOCK:REQ?
Queries the state of exclusive locking.
Response: 1
The exclusive locking is active.

Usage: Query only

:SYSTem:SAV <Pathname>

Saves the current R&S SFI100A settings in a file. To deteremine the file name and
storage location, enter the directory and file name with the command. According to the
file type, the R&S SFI100A assigns the extension (*.savrcltxt) automatically.

Setting parameters: 
<Pathname> string

Example: SYSTem:SAV "/var/user/temp/Test" 
// saves the file "Test.savrcltxt" in the directory /var/user/temp/.

Usage: Setting only

:SYSTem:RCL <Pathname>

Selects and uploads a *.savrcltxt file with previously saved R&S SFI100A settings
from the default or a specified directory.
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Setting parameters: 
<Pathname> string

Example: SYSTem:RCL "/var/user/temp/Test" 
// loads the "Test.savrcltxt" file from the directory /var/user/temp/.

Usage: Setting only

:SYSTem:PROTect<ch>[:STATe] <State>[, <Key>]

Activates and deactivates the specified protection level.

Suffix: 
<ch>

.
Indicates the protection level.
See also "Protection" on page 319

Parameters:
<State> 1 | ON | 0 | OFF

*RST: n.a. (factory preset: 1)

Setting parameters: 
<Key> integer

The respective functions are disabled when the protection level
is activated. No password is required for activation of a level.
A password must be entered to deactivate the protection level.
The default password for the first level is 123456.
This protection level is required to unlock internal adjustments
for example.

Example: To activate protection level:
SYSTem:PROTect1:STATe 1
Internal adjustments or hostname cannot be changed.
To unlock protection level 1:
SYSTem:PROTect1:STATe 0,123456
Internal adjustments are accessible.

Manual operation: See "Protection Level/Password" on page 321

:SYSTem:COMMunicate:HISLip:RESource?

Queries the VISA resource string. This string is used for remote control of the instru-
ment with HiSLIP protocol.

Return values: 
<Resource> string

Example: See Example "Finding out VISA resource strings" on page 582.

Usage: Query only

Manual operation: See "HISLIP" on page 361
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:SYSTem:COMMunicate:NETWork:IPADdress <IpAddress>

Sets the IP address.

Parameters:
<IpAddress> string

Range: 0.0.0.0.  to  ff.ff.ff.ff

Example: See Example "Retrieving information on network-related set-
tings" on page 582.

Manual operation: See "IP Address" on page 359

:SYSTem:COMMunicate:NETWork:IPADdress:MODE <Mode>

Selects manual or automatic setting of the IP address.

Parameters:
<Mode> AUTO | STATic

*RST: n.a. (factory preset: AUTO)

Example: See Example "Retrieving information on network-related set-
tings" on page 582.

Manual operation: See "Address Mode" on page 359

:SYSTem:COMMunicate:NETWork:MACaddress <MacAddress>

Queries the MAC address of the network adapter.

This is a password-protected function. Unlock the protection level 1 to access it.

Parameters:
<MacAddress> string

Example: See Example "Retrieving information on network-related set-
tings" on page 582.

Manual operation: See "MAC Address" on page 360

:SYSTem:COMMunicate:NETWork:RESource?

Queries the visa resource string for Ethernet instruments.

Return values: 
<Resource> string

Example: See Example "Finding out VISA resource strings" on page 582.

Usage: Query only

Manual operation: See "VXI11" on page 361
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:SYSTem:COMMunicate:NETWork:RESTart

Restarts the network.

Example: See Example "Restarting the network" on page 582.

Usage: Event

Manual operation: See "Restart Network" on page 358

:SYSTem:COMMunicate:NETWork:STATus?

Queries the network configuration state.

Return values: 
<State> 1 | ON | 0 | OFF

Example: See Example "Retrieving information on network-related set-
tings" on page 582.

Usage: Query only

Manual operation: See "Network Status" on page 358

:SYSTem:COMMunicate:NETWork[:COMMon]:DOMain <Domain>

Determines the primary suffix of the network domain.

Parameters:
<Domain> string

Example: See Example "Retrieving information on network-related set-
tings" on page 582.

Manual operation: See "DNS Suffix" on page 360

:SYSTem:COMMunicate:NETWork[:COMMon]:HOSTname <Hostname>

Sets an individual hostname for the R&S SFI100A.

Note:We recommend that you do not change the hostname to avoid problems with the
network connection. If you change the hostname, be sure to use a unique name.

This is a password-protected function. Unlock the protection level 1 to access it.

Parameters:
<Hostname> string

Example: See Example "Retrieving information on network-related set-
tings" on page 582.

Manual operation: See "Hostname" on page 359
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:SYSTem:COMMunicate:NETWork[:COMMon]:WORKgroup <Workgroup>

Sets an individual workgroup name for the instrument.

Parameters:
<Workgroup> string

Example: See Example "Retrieving information on network-related set-
tings" on page 582.

Manual operation: See "Workgroup" on page 359

:SYSTem:COMMunicate:NETWork[:IPADdress]:DNS <DNS>

Determines or queries the network DNS server to resolve the name.

Parameters:
<DNS> string

Example: See Example "Retrieving information on network-related set-
tings" on page 582.

Manual operation: See "DNS Server" on page 360

:SYSTem:COMMunicate:NETWork[:IPADdress]:GATeway <Gateway>

Sets the IP address of the default gateway.

Parameters:
<Gateway> string

Range: 0.0.0.0  to  ff.ff.ff.ff

Example: See Example "Retrieving information on network-related set-
tings" on page 582.

Manual operation: See "Default Gateway" on page 360

:SYSTem:COMMunicate:NETWork[:IPADdress]:SUBNet:MASK <Mask>

Sets the subnet mask.

Parameters:
<Mask> string

Example: See Example "Retrieving information on network-related set-
tings" on page 582.

Manual operation: See "Subnet Mask" on page 359

:SYSTem:COMMunicate:SOCKet:RESource?

Queries the visa resource string for remote control via LAN interface, using TCP/IP
socket protocol.
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Return values: 
<Resource> string

Example: See Example "Finding out VISA resource strings" on page 582.

Usage: Query only

Manual operation: See "Socket" on page 361

:SYSTem:COMMunicate:USB:RESource?

Queries the visa resource string for remote control via the USB interface.

Return values: 
<Resource> string

Example: See Example "Finding out VISA resource strings" on page 582.

Usage: Query only

:SYSTem:HELP:EXPort

Saves the online help as zip archive in the user directory.

Example: :SYSTem:HELP:EXPort
MMEM:CDIR?
// "/var/user"
MMEM:CAT?
// ..,"Log,DIR,4096","help.tgz,BIN,69836600"
// confirms that help zip archive is saved.

Usage: Event

Manual operation:: "Setup > Help > Export Help to User Path"

:SYSTem:IDENtification <Identification>

Selects the mode to determine the "IDN String" and the "OPT String" for the instru-
ment, selected with command :SYSTem:LANGuage.

Note: While working in an emulation mode, the R&S SFI100A specific command set is
disabled, that is, the SCPI command SYST:IDEN is discarded.

Parameters:
<Identification> AUTO | USER

AUTO
Automatically determines the strings.
USER
User-defined strings can be selected.
*RST: n.a. (factory preset: AUTO)

Example: SYST:IDEN AUTO
Automatically assigns the OPT and IDN strings according to the
selected instrument language.
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Manual operation: See "Mode" on page 363

:SYSTem:IDENtification:PRESet

Sets the *IDN and *OPT strings in user defined mode to default values.

Example: SYST:IDEN USER
SYST:IDEN:PRES

Usage: Event

Manual operation: See "Set to Default" on page 363

:SYSTem:IRESponse <IdnResponse>

Defines the user defined identification string for *IDN.

Note: While working in an emulation mode, the instrument's specific command set is
disabled, i.e. the SCPI command SYST:IRES is discarded.

Parameters:
<IdnResponse> string

Example: SYST:IDEN USER
// Selects a user-defined identification
SYST:IRES "Test Device"
// Defines identification string 'test device'
*IDN?
// Response: 'test device'

Manual operation: See "IDN String" on page 363

:SYSTem:ORESponse <OResponse>

Defines the user defined response string for *OPT.

Note: While working in an emulation mode, the instrument's specific command set is
disabled, i.e. the SCPI command SYST:ORES is discarded.

Parameters:
<OResponse> string

Example: SYST:IDEN USER
// Selects a user-defined identification
SYST:ORES "Test Option"
// Defines the OPT string 'test option'
*OPT?
// Response: 'test option'

Manual operation: See "OPT String" on page 363
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:SYSTem:LANGuage <Language>

Sets the remote control command set.

Parameters:
<Language> string

Example: SYSTem:LANGuage "SCPI"
// selects SCPI command set

Manual operation: See "Language" on page 363

:SYSTem:INFormation:SCPI <InfoString>

Inserts system information in recorded SCPI command lists, for example information
on a missing command.

Parameters:
<InfoString> string

Example: SYST:INF:SCPI "missing command"
enters the information into a recorded SCPI command list.

:SYSTem:SECurity:NETWork:AVAHi[:STATe] <SecPassWord>, <AvahiState>

Disables the Avahi service for automatic configuration of the instrument in a network.

Parameters:
<AvahiState> 1 | ON | 0 | OFF

Setting parameters: 
<SecPassWord> string

Current security password.

Example: See Example "To disable the LAN interface and LAN services"
on page 583.

Manual operation: See "LAN Services" on page 328

:SYSTem:SECurity:NETWork:FTP[:STATe] <SecPassWord>, <FtpState>

Disables FTP protocol for file transfer between the instrument and host.

Parameters:
<FtpState> 1 | ON | 0 | OFF

Setting parameters: 
<SecPassWord> string

Current security password.

Example: See Example "To disable the LAN interface and LAN services"
on page 583.

Manual operation: See "LAN Services" on page 328
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:SYSTem:SECurity:NETWork:HTTP[:STATe] <SecPassWord>, <HttpState>

Disables control of the instrument over HTTP, the protocol for hypermedia information
systems.

Parameters:
<HttpState> 1 | ON | 0 | OFF

Setting parameters: 
<SecPassWord> string

Current security password.

Example: See Example "To disable the LAN interface and LAN services"
on page 583.

Manual operation: See "LAN Services" on page 328

:SYSTem:SECurity:NETWork:RAW[:STATe] <SecPassWord>, <RawState>

Disables the LAN interface for remote control of the instrument over raw socket port.

Parameters:
<RawState> 1 | ON | 0 | OFF

Setting parameters: 
<SecPassWord> string

Current security password.

Example: See Example "To disable the LAN interface and LAN services"
on page 583.

:SYSTem:SECurity:NETWork:REMSupport[:STATe] <NetRemSupport>

Disables communication over SSH (SCP) for service purposes.

Parameters:
<NetRemSupport> 1 | ON | 0 | OFF

*RST: n.a. (factory preset: 1)

Example: See Example "To disable the LAN interface and LAN services"
on page 583.

Manual operation: See "LAN Services" on page 328

:SYSTem:SECurity:NETWork:RPC[:STATe] <SecPassWord>, <RpcState>

Enables the LAN interface for remote control of the instrument via remote procedure
calls (RPC).

Parameters:
<RpcState> 1 | ON | 0 | OFF
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Setting parameters: 
<SecPassWord> string

Current security password.

Example: See Example "To disable the LAN interface and LAN services"
on page 583.

:SYSTem:SECurity:NETWork:SMB[:STATe] <SecPassWord>, <SmbState>

Disables access to the file system, printers and serial ports in a network over SMB.

Parameters:
<SmbState> 1 | ON | 0 | OFF

Setting parameters: 
<SecPassWord> string

Current security password.

Example: See Example "To disable the LAN interface and LAN services"
on page 583.

Manual operation: See "LAN Services" on page 328

:SYSTem:SECurity:NETWork:SOE[:STATe] <SecPassWord>, <SoeState>

Disables control of the instrument over LAN using SCPI commands.

Parameters:
<SoeState> 1 | ON | 0 | OFF

Setting parameters: 
<SecPassWord> string

Current security password.

Example: See Example "To disable the LAN interface and LAN services"
on page 583.

Manual operation: See "LAN Services" on page 328

:SYSTem:SECurity:NETWork:SSH[:STATe] <SecPassWord>, <SshState>

Disables control of the instrument over LAN using the SSH network protocol.

Parameters:
<SshState> 1 | ON | 0 | OFF

Setting parameters: 
<SecPassWord> string

Current security password.

Example: See Example "To disable the LAN interface and LAN services"
on page 583.

Manual operation: See "LAN Services" on page 328
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:SYSTem:SECurity:NETWork:SWUPdate[:STATe] <SecPassWord>,
<SwUpdateState>

Disables software update over LAN.

Parameters:
<SwUpdateState> 1 | ON | 0 | OFF

Setting parameters: 
<SecPassWord> string

Current security password.

Example: See Example "To disable the LAN interface and LAN services"
on page 583.

Manual operation: See "LAN Services" on page 328

:SYSTem:SECurity:NETWork:VNC[:STATe] <SecPassWord>, <VncState>

Disables the VNC interface for remote control of the instrument.

Parameters:
<VncState> 1 | ON | 0 | OFF

Setting parameters: 
<SecPassWord> string

Current security password.

Example: See Example "To disable the LAN interface and LAN services"
on page 583.

Manual operation: See "LAN Services" on page 328

:SYSTem:SECurity:NETWork[:STATe] <SecPassWord>, <LanStorState>

Disables the LAN interface in general, including all services.

Parameters:
<LanStorState> 1 | ON | 0 | OFF

Setting parameters: 
<SecPassWord> string

Current security password.
The default password is 123456.

Example: See Example "To disable the LAN interface and LAN services"
on page 583

Manual operation: See "LAN" on page 328

:SYSTem:SECurity:SANitize[:STATe] <SecPassWord>, <MmemProtState>

Sanitizes the internal memory.
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Parameters:
<MmemProtState> 0 | 1 | OFF | ON

*RST: 0

Setting parameters: 
<SecPassWord> string

Example: SYSTem:SECurity:SANitize[:STATe] 1

Manual operation: See "Sanitize" on page 324

:SYSTem:SECurity:SUPolicy <SecPassWord>, <UpdatePolicy>

Configures the automatic signature verification for firmware installation.

Parameters:
<UpdatePolicy> STRict | CONFirm | IGNore

*RST: n.a. (factory preset: CONFirm)

Setting parameters: 
<SecPassWord> string

Manual operation: See "Secure Update Policy" on page 322

:SYSTem:SECurity:VOLMode[:STATe] <SecPassWord>, <MmemProtState>

Activates volatile mode, so that no user data can be written to the internal memory per-
manently.

To enable volatile mode, reboot the instrument. Otherwise the change has no effect.

Parameters:
<MmemProtState> 0 | 1 | OFF | ON

*RST: 0

Setting parameters: 
<SecPassWord> string

Current security password
The default password is 123456.

Example: SYSTem:SECurity:VOLMode:STATe "123456", 1
SYSTem:REBoot

Manual operation: See "Volatile Mode" on page 323

:SYSTem:SPECification? <Id>

Retrieves data sheet information for a specific parameter.
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Setting parameters: 
<Id> string

Identifies the name of the entry in the data sheet, as queried
with the command :SYSTem:SPECification:
IDENtification:CATalog? on page 603

Return values: 
<ValList> float

Comma-separated list with the specified and, if available, the
typical value of the parameter, as specified in the data sheet.

Example: See Example "Retrieving instrument specification" on page 581.

Usage: Query only

:SYSTem:SPECification:VERSion <Version>

Selects a data sheet version from the data sheets saved on the instrument.

Further queries regarding the data sheet parameters (<Id>) and their values refer to
the selected data sheet.

To query the list of data sheet versions, use the command :SYSTem:
SPECification:VERSion:CATalog? on page 604.

Parameters:
<Version> string

Example: See :SYSTem:SPECification? on page 602.

:SYSTem:SPECification:IDENtification:CATalog?

Queries the parameter identifiers (<Id>) available in the data sheet.

Return values: 
<IdList> string

Comma-separated string of the parameter identifiers (<Id>)

Example: See :SYSTem:SPECification? on page 602.

Usage: Query only

:SYSTem:SPECification:PARameter? <Id>[, <Parameter>]

Retrieves data sheet information for a specific parameter.

Setting parameters: 
<Id> string

Identifies the name of the entry in the data sheet.
Query the data sheet parameters with the command :SYSTem:
SPECification:IDENtification:CATalog?.
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<Parameter> float
An additional value the result (ValList) depends on.

Return values: 
<ValList> float

Comma-separated list with the specified and, if available, the
typical value of the parameter, as specified in the data sheet.

Example: Note: The following values are merely an example. Your instru-
ment may not support the same parameters.
SYST:SPEC:PAR? "ID_RF_FREQ_SETTING_TIME_MS",0.1
SYST:SPEC:PAR? "ID_RF_LEVEL_MAX_GENERAL_DBM",
0.1

Usage: Query only

:SYSTem:SPECification:VERSion:CATalog?

Queries all data sheet versions stored in the instrument.

Return values: 
<VersCatalog> string

Example: See :SYSTem:SPECification? on page 602.

Usage: Query only

:SYSTem:SPECification:VERSion:FACTory?

Queries the data sheet version of the factory setting.

Return values: 
<Version> string

Example: See :SYSTem:SPECification? on page 602.

Usage: Query only

Manual operation: See "Versions" on page 624

:SYSTem:SRData?

Queris the SCPI recording data from the internal file.

This feature enables you to transfer an instrument configuration to other test environ-
ments, as e.g. laboratory virtual instruments.

Return values: 
<FileData> block data
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Example: SYSTem:SRData? 
// #3118:SOURce1:ROSCillator:SOURce EXT
// :SOURce1:FREQuency:CW 4000000000
// :SOURce1:FREQuency:OFFSet 1000000
// :SOURce1:AM1:STATe 1
// :OUTPut1:STATe 1

Usage: Query only

:SYSTem:STARtup:COMPlete?

Queries if the startup of the instrument is completed.

Return values: 
<Complete> 1 | ON | 0 | OFF

*RST: 0

Example: SYSTem:STARtup:COMPlete? 
Response: 1 
// the instrument has started and is ready for operation.

Usage: Query only

:SYSTem:DATE <Year>, <Month>, <Day>

Queries or sets the date for the instrument-internal calendar.

This is a password-protected function. Unlock the protection level 1 to access it.

Parameters:
<Year> integer

<Month> integer
Range: 1  to  12

<Day> integer
Range: 1  to  31

Example: See Example "Configuring date and time" on page 584.

Manual operation: See "Date" on page 631

:SYSTem:NTP:HOSTname <NTPName>

Sets the address of the NTP server. You can enter the IP address, or the hostname of
the time server, or even set up an own vendor zone. See the Internet for more informa-
tion on NTP.

Parameters:
<NTPName> string

Manual operation: See "NTP Address" on page 632
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:SYSTem:NTP:STATe <UseNtpState>

Activates clock synchronization via NTP.

Parameters:
<UseNtpState> 1 | ON | 0 | OFF

*RST: n.a. (factory preset: 0)

Example: See Example "Configuring date and time" on page 584.

Manual operation: See "NTP Address" on page 632

:SYSTem:TIME <Hour>, <Minute>, <Second>

Queries or sets the time for the instrument-internal clock.

This is a password-protected function. Unlock the protection level 1 to access it.

Parameters:
<Hour> integer

Range: 0  to  23

<Minute> integer
Range: 0  to  59

<Second> integer
Range: 0  to  59

Example: See Example "Configuring date and time" on page 584.

Manual operation: See "Time" on page 631

:SYSTem:TIME:ZONE <TimeZone>

Sets the timezone. You can query the list of the available timezones with :SYSTem:
TIME:ZONE:CATalog?.

Parameters:
<TimeZone> string

Example: See Example "Configuring date and time" on page 584.

Manual operation: See "Timezone" on page 632

:SYSTem:TIME:ZONE:CATalog?

Querys the list of available timezones.

Return values: 
<Catalog>

Example: See Example "Configuring date and time" on page 584.

Usage: Query only
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Manual operation: See "Timezone" on page 632

:SYSTem:TIME:PROTocol <TimeProtocol>

Sets the date and time of the operating system.

Parameters:
<TimeProtocol> OFF | NONE | 0 | NTP | ON | 1

NONE
Sets the date and time according to the selected timezone,
see :SYSTem:TIME:ZONE:CATalog? on page 606 and :
SYSTem:TIME:ZONE on page 606.
NTP
Sets the date and time derived from the network time protocol.
To select the NTP time server, use the commands :SYSTem:
NTP:HOSTname on page 605 and :SYSTem:NTP:STATe
on page 606.
*RST: n.a. (factory preset: NONE)

Example: See Example "Configuring date and time" on page 584.

Manual operation: See "Time Protocol" on page 632

:SYSTem:UPTime?

Queries the up time of the operating system.

Return values: 
<UpTime> "<ddd.hh:mm:ss>"

Example: SYSTem:UPTime?
Response: "0.08:11:00"

Usage: Query only

:SYSTem:BIOS:VERSion?

Queries the BIOS version of the instrument.

Return values: 
<Version> string

Example: SYST:BIOS:VERS?
queries the BIOS version.
Response: 123456

Usage: Query only

:SYSTem:VERSion?

Queries the SCPI version the instrument's command set complies with.
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Return values: 
<Version> string

Example: SYSTem:VERSion 
// queries the SCPI version. 
Response: "1996" 
// the instrument complies with the SCPI version from 1996.

Usage: Query only

:SYSTem:OSYStem?

Queries the operating system of the instrument.

Return values: 
<OperSystem> string

Example: SYSTem:OSYStem?
Response: "Linux"

Usage: Query only

:SYSTem:MMEMory:PATH:USER?

Queries the user directory, that means the directory the R&S SFI100A stores user files
on.

Return values: 
<PathUser> string

Example: SYSTem:MMEMory:PATH:USER? 
Response: "'/var/user/"

Usage: Query only

:SYSTem:DFPRint <Directory>

Creates a file with the device footprint of the product.

The content is formatted in machine-readable form, suitable for automatic further pro-
cessing.

The generic file name is composed of
DeviceFootprint_<SerialNumber>_<Date>_<Time>.xml. R&S SFI100A saves
the file in the definable directory. If the directory is not specified, it saves the footprint
file in the internal default directory (/var/lib/Rohde-Schwarz/
DeviceFootprint).

You can download the file by using the SCPI commands of the MMEMory subsystem.

Setting parameters: 
<Directory> string

Path to the directory for saving the device footprint file.
Ensure that you have the permission to write into the directory.

SYSTem subsystem
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Return values: 
<DeviceFootprint> string

Information on the product type, identification and the installed
hardware, software and further service-related information on
the product's configuration.

Example: SYSTem:DFPRint “/var/user/devicefootprint”

SYSTem:DFPRint?
// MMEM:DATA?
// returns the device footprint information saved with SYST:DFPRint

:SYSTem:REBoot

Reboots the instrument including the operating system.

Usage: Event

:SYSTem:RESTart

Restarts the instrument without restarting the operating system.

Usage: Event

:SYSTem:SHUTdown

Shuts down the instrument.

Usage: Event

:SYSTem:WAIT <TimeMs>

Delays the execution of the subsequent remote command by the specified time.

This function is useful, for example to execute an SCPI sequence automatically but
with a defined time delay between some commands.

See Chapter 11.2.4, "How to assign actions to the [★] key", on page 309.

Setting parameters: 
<TimeMs> integer

Wait time in ms
Range: 0  to  10000
*RST: 0

Example: SYSTem:WAIT 10000
// Waits 10s before resetting the instrument.
*RST

Usage: Setting only

SYSTem subsystem
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13.19  TEST subsystem

The TEST subsystem contains the commands for performing test routines directly at
the hardware assemblies.

The selftetst responses with a 0 if the test is performed successfully, otherwise a value
other than 0 is returned. None of the commands of this system has a *RST value.

Example: Testing the screen display

// show the check screen
:TEST:PIXel:WINdow 1
// selct the color for the display, e.g. blue
TEST:PIXel:COLor BLUE
// select the sequence for changing the color automatically
TEST:PIXel:COLor AUTO //(~3s per color)
// select a specific RGB color, e.g. black
TEST:PIXel:RGBA 0,0,0,255
// turn on the gradient
TEST:PIXel:GRADient 1
// switch to text mode
 :TEST:PIXel:TEXT 1
// set the point size of the text
:TEST:PIXel:POINtsize 600 
// exit the check screen 
:TEST:PIXel:WINdow 0

:TEST<hw>:ALL:STARt.................................................................................................. 610
:TEST<hw>:ALL:RESult?................................................................................................610
:TEST:PIXel:COLor.........................................................................................................611
:TEST:PIXel:GRADient....................................................................................................611
:TEST:PIXel:POINtsize....................................................................................................611
:TEST:PIXel:RGBA.........................................................................................................612
:TEST:PIXel:TEXT..........................................................................................................612
:TEST:PIXel:WINDow..................................................................................................... 612

:TEST<hw>:ALL:STARt

Usage: Event

Manual operation: See "Run Module Test" on page 640

Starts the selftest. Use the command :TEST<hw>:ALL:RESult? to query the result.

:TEST<hw>:ALL:RESult?

Queries the result of the performed selftest. Start the selftest with :TEST<hw>:ALL:
STARt.

TEST subsystem
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Return values: 
<Result> 0 | 1 | RUNning | STOPped

*RST: STOPped

Usage: Query only

Manual operation: See "Result" on page 641
See "Last Full Test" on page 641

:TEST:PIXel:COLor <PixTestColor>

Selects the color of the screen.

"AUTO" switches from one color to the next in tme intervals of approximately 3 s per
color.

Setting parameters: 
<PixTestColor> RED | BLUE | WHITe | GREen | AUTO | GR25 | GR50 | GR75 |

BLACk
*RST: RED

Example: See Example "Testing the screen display" on page 610.

Usage: Setting only

Manual operation: See "Check Display Screen" on page 636

:TEST:PIXel:GRADient <PixTestGradStat>

Activates the gradient for display screen test.

Parameters:
<PixTestGradStat> 1 | ON | 0 | OFF

*RST: 0

Example: See Example "Testing the screen display" on page 610.

Manual operation: See "Check Display Screen" on page 636

:TEST:PIXel:POINtsize <PixTestGradStat>

Sets the point size of the test text.

Parameters:
<PixTestGradStat> integer

Range: 0  to  999
*RST: n.a. (no preset. default: 0)

Example: See Example "Testing the screen display" on page 610.

Manual operation: See "Check Display Screen" on page 636

TEST subsystem
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:TEST:PIXel:RGBA

Sets a specific RGBA color for the screen.

Example: See Example "Testing the screen display" on page 610.

Manual operation: See "Check Display Screen" on page 636

:TEST:PIXel:TEXT <PixTestGradStat>

Activats the test text mode.

Parameters:
<PixTestGradStat> 1 | ON | 0 | OFF

*RST: 0

Example: See Example "Testing the screen display" on page 610.

Manual operation: See "Check Display Screen" on page 636

:TEST:PIXel:WINDow <PixTestWindow>

Activates the check display screen.

Setting parameters: 
<PixTestWindow> 1 | ON | 0 | OFF

*RST: 0

Example: See Example "Testing the screen display" on page 610.

Usage: Setting only

Manual operation: See "Check Display Screen" on page 636

13.20  UNIT subsystem

The UNIT subsystem is used to set default units for parameters if no unit is indicated in
a command. These settings are valid for the entire instrument.

Example: Setting default units for remote control
UNIT:POW V
UNIT:ANGL DEG

Sets V (volts) as unit of all power parameters, DEG (degrees) for the phase modulation
angle and KMH for the speed.

:UNIT:ANGLe.................................................................................................................613
:UNIT:POWer.................................................................................................................613

UNIT subsystem
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:UNIT:ANGLe <Angle>

Sets the default unit for phase modulation angle. The command affects no other
parameters, such as RF phase, or the manual control or display.

Parameters:
<Angle> DEGree | DEGRee | RADian

*RST: RADian

:UNIT:POWer <Power>

Sets the default unit for all power parameters. This setting affects the GUI, as well as
all remote control commands that determine power values.

Parameters:
<Power> V | DBUV | DBM

*RST: DBM

UNIT subsystem
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14  Troubleshooting and notifications
Understanding R&S SFI100A notifications

The R&S SFI100A distinguishes between various notifications caused by events or
functions. It displays a notification in the "Info" line on the screen temporarily, and
saves all notifications in a history list. In addition, an event initiates an entry in the
event/error queue of the status reporting system.

14.1  Notifications

Notifications inform about operation states of the instrument, and point out deviations,
deficiencies or erroneous functions that initiate an event in the instrument. The instru-
ment distinguishes the notifications according to the significance of the events by dif-
ferent icons.

Some events require that you eliminate the deviation to make sure that the instrument
operates correctly.

To access the notifications and history list dialog, see Chapter 14.4, "Querying notifica-
tions", on page 617. In remote control mode, you can query the notifications using the
command :SYSTem:ERRor:ALL? on page 586.

14.1.1  Volatile notifications

Volatile notifications report automatic settings in the instrument (e.g. switching off
incompatible types of modulation) or on entries that are not accepted by the instrument
(e.g. range violations).

Volatile notifications do not normally demand user actions and disappear automatically
after a short period of time. They are saved in the history list, however.

Remote command:

:SYSTem:ERRor:ALL? or

:SYSTem:ERRor:CODE[:NEXT]?

14.1.2  Permanent notifications

Permanent notifications are displayed if an error occurs that impairs further instrument
operation, e.g. a hardware fault. The error signaled by a permanent notification must
be eliminated before correct instrument operation can be continued.

The message is displayed until the error is eliminated. It covers the status display in
the info line. After error elimination, the message automatically disappears and is also
recorded in the history.

Notifications
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Remote command:

:SYSTem:ERRor:STATic?

14.2  SCPI notifications

The SCPI notifications are similar for all SCPI instruments. Detailed information and an
overview of all notifications as defined in the SCPI standard can be found in the corre-
sponding documentation.

SCPI notifications have negative codes (numbers). The error text being entered into
the error/event queue or being displayed is printed in bold face on the left together with
the error code. Below the error text, there is an explanation to the respective error.

14.3  Device-specific notifications

The following table contains all error messages specific for the instrument in alphabeti-
cal order and an explanation of the error situation. The positive error codes mark the
errors specific to the instrument.

The device-specific error messages set bit 3 in the ESR register.

The index provides a list of the error messages sorted according to their error codes.

Error
code

Error Description Remedy

50 External reference out of
range or disconnected

The configured reference frequency source is
external but there is no physical external signal or
this signal is out of range.

In the "RF Frequency" > "Reference Fre-
quency" dialog, set the correct reference
signal source.

80 Adjustment missing.
Please run "Adjust All".

Alignment data is not available. Select "System Config" > "Setup" >
"General" > "Internal Adjustments" and
select "Adjust All".

180 Adjustment failed The instrument cannot execute an adjustment. Generate the adjustment data and load
it into the device.

182 Adjustment data missing Adjustment data is missing. Generate the adjustment data and load
it into the device.

183 Adjustment data invalid Adjustment data is invalid. Generate the adjustment data and load
it into the device.

200 Cannot access hardware The data transmission to a hardware module was
unsuccessful.

The hardware module is not installed,
not properly installed or missing.

201 Hardware revision out of
date

You cannot execute a specific function because of
a too old hardware version.

The driver does not support the installed version
of a hardware module.

Consider installing a newer hardware
module or downgrading the driver ver-
sion

Device-specific notifications
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Error
code

Error Description Remedy

202 Cannot access the
EEPROM

An error occurs when writing or reading a
EEPROM.

The EEPROM is possibly defective.
Replace it.

203 Invalid EEPROM data Reading a EEPROM is possible but the data are
inconsistent.

 

204 Driver initialization failed Initialization of a driver fails when booting the
instrument firmware.

The driver is not compatible with the
hardware or software configuration of
the instrument.

241 No current list There is no list file selected to execute the
required operation.

Select a list file with the correct file
extension. If no list files is available, cre-
ate a list file.

242 Unknown list type speci-
fied

The list type selected is not valid for the required
operation.

For example, the file extension for waveform list
files is *.wv. It is not possible to enter another file
extension when selecting a list.

Check the selected list type.

261 Waveform protected You cannot transfer a waveform file to an
Rohde & Schwarz instrument because the file is
encrypted. For example, the simulation software
R&S WinIQSIM2 creates protected waveform
files.

Install the related waveform file software
option or select an unprotected wave-
form file.

300 No tachometer signal
detected on fan #x

Fan number #x is not working. Send the R&S SFI100A to your local
Rohde & Schwarz customer support.

300 Temperature too high The R&S SFI100A overheats, for example, if you
cover the fan openings.

Relocate the R&S SFI100A to cool down
and remove all coverings from the
R&S SFI100A. After cooling down switch
on the R&S SFI100A.

If you still encounter problems, contact
the Rohde & Schwarz customer support.

300 Reference PLL unlocked The configured reference frequency source is
external but there is no physical external signal.

In the "RF Frequency" > "Reference Fre-
quency" dialog, set a valid reference fre-
quency source and frequency:
● Set "Source" > "Internal".
● Set "Source" > "External". Connect

a 10 MHz 100 MHz, 640 MHz,
1 GHz, 8 GHz or a variable fre-
quency reference source at the
connector Ref In.

300 Overload (Reverse
Power) detected

The connected load feeds in a voltage at the RF
output connector RF Out.

You can also trigger the reverse power protection
without a connected DUT, if there is a too high RF
level and an open RF output.

Remove the overload and switch on the
RF output via "RF" > "On".

300 Overtemperature protec-
tion shut-down

The R&S SFI100A overheats, for example, if you
cover the fan openings.

Relocate the R&S SFI100A to cool down
and remove all coverings from the
R&S SFI100A. After cooling down switch
on the R&S SFI100A.

If you still encounter problems, contact
the Rohde & Schwarz customer support.

Device-specific notifications
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Error
code

Error Description Remedy

460 Cannot open file You or the application cannot open the selected
file.

Check the file path and filename.

461 Cannot write file You or the application cannot edit or write the
selected file.

Check if the file is read-only.

462 Cannot read file You or the application cannot read the selected
file.

Check if the file contents are compatible
with the file type.

463 Filename missing You cannot execute a task because the filename
is missing.

Enter a valid filename.

464 Invalid filename extension The file extension is not valid for the required
operation.

Check the file extension.

For example, the file extension for wave-
form list files is *.wv. It is not possible
to enter another file extension when sav-
ing a list.

465 File contains invalid data The file with its file extension contains invalid
data. The file extension is wrong for the expected
data.

For example, if you change the standard file
extension of a waveform file from *.wv to *.txt,
the instrument cannot read the waveform file any-
more.

Check the file extension.

14.4  Querying notifications

The R&S SFI100A monitors the functions performed and automatically detects irregu-
larities. The instrument displays corresponding notifications in the "Info" line and col-
lects all notifications in a history with a detailed description.

Find details to the system notifications in Chapter 14, "Troubleshooting and notifica-
tions", on page 614.

Querying notifications
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To monitor static notifications and history

► In the taskbar, select the "System Config > Info/Notifications".

● The "Static Notifications" dialog lists the recently monitored notifications chro-
nologically and displays additional information on the highlighted message.

● The "History" dialog lists the accumulated messages with a short description.
The software reports volatile notifications once. The "Info" line displays identi-
cal errors repeatedly only if the original error disappeared. Selecting this info
line also opens the "Static Notifications" dialog.

Handling permanent notifications
If any critical error occurs, the R&S SFI100A automatically shows the warning icon in
the taskbar. Select the icon to obtain information on the error and the number of occur-
rences.
The icon is assigned to permanent notifications. The notification and icon are displayed
until the error is eliminated.

Static Notifications/History
Toggles between "Static Notifications" and the "History" tab in the info dialog.
Remote command: 
:SYSTem:ERRor[:NEXT]? on page 588
Each time a SYST:ERR:NEXT? query is sent, the eldest entry in the error queue is
returned and at the same time cleared in the list.
:SYSTem:ERRor:STATic? on page 589
Queries the list of all errors.

Clear History
Clears all messages in the "History" tab.

Querying notifications
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Remote command: 
:SYSTem:ERRor:ALL? on page 586
Each time a SYST:ERR:ALL? query is sent, the error queue is returned and at the
same time cleared.
:SYSTem:ERRor:HISTory:CLEar on page 588
Clears the messages in the "History" view.

14.5  Resolving network connection failures

Several issues may cause failures in the network connection to the instrument. This
section lists the most likely reasons and the recommended solutions.

Common reasons for network connection failures

● Network connecting cables and cable connectors of poor quality
● Incompatibility between the network interface of the R&S SFI100A and certain

switches or routers available on the market
● An invalid IP address assigned to the instrument

Possible solutions to network connection failures

1. NOTICE! Risk of network failure. Connecting to the network can cause network
failure. Errors can affect the entire network.
Consult your network administrator before performing the following tasks:
● Connecting the instrument to the network
● Configuring the network
● Changing IP addresses

2. Try out the following to resolve network connection failures:

● Exchange connecting cables, if obvious damage is visible.
● If a link failure is detected, connect the instrument to a different device port or

to a different network device.
● Check whether the LAN interface and the required LAN services are enabled.
● If the IP address is set manually (no DHCP) or obtained with the Zeroconf

(Avahi) protocol:
– Check whether the IP address of the instrument is within the network's

address range.
– Check whether the IP address is valid.

14.6  Resolving errors during internal adjustments

Internal adjustments can fail for various reasons, e.g. if the adjustment data is invalid
or missing, or if any error causes process to abort.

Resolving errors during internal adjustments
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To resolve a failed adjustment process, you have the following options:
● Abort on error (default setting), see "To resolve aborted internal adjustments"

on page 620
● Continue on error, see "To continue internal adjustments on error" on page 620

To resolve aborted internal adjustments

If an error occurs, the R&S SFI100A displays a notification in the "Information" field
and saves the notification in the history list.

1. Select "System Config > Info / Notifications".

2. Look up the error code of the notification in the overview of device-specific notifica-
tions.
See Chapter 14.3, "Device-specific notifications", on page 615.

The overview provides a brief explanation of all notifications and information on
how to fix an error.

3. To resolve an adjustment failure, generate adjustment data and load it into the
instrument.

4. Restart internal adjustments as described in "Running internal adjustments"
on page 639

If the error persists:
Contact the Rohde & Schwarz customer support, see Chapter 14.9, "Collecting
information for technical support", on page 624.

To continue internal adjustments on error

If the failed internal adjustments has no significant effect on your application, you can
skip it and continue the calibration despite the error message. This function is pass-
word-protected.

1. Select "System Config > Setup > Security > Protection".

2. Unlock protection level 1, see"Protection Level/Password" on page 321.

3. Select "System Config > Setup > Internal Adjustment > Configuration > Continue
Adjustment on Error > On".

4. Proceed as described in "Running internal adjustments" on page 639.

14.7  Measuring USB cable quality

To check the quality of the USB cable, see the service manual of the R&S SFI100A.

Measuring USB cable quality
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14.8  Checking the instrument configuration

The R&S SFI100A uses various hardware and software components. To get an over-
view, you can check the instrument assemblies, hardware options, software options
and the firmware version. The "Hardware Config" and "Versions/Options" dialogs list all
components according to their hardware configuration, software options and connected
Rohde & Schwarz equipment, like R&S NRP power sensors.

Installing software and hardware options

Activate newly purchased software options with a keycode. After purchase, the key-
code is part of the delivery of the software option. See also Chapter 11.3, "Managing
licenses and license keys", on page 310.

For installing newly purchased hardware options, contact Rohde & Schwarz customer
support.

Checking the installed hardware options

To find out the installed options:

1. Select "System Config" > "Setup" > "Instrument Assembly" > "Versions / Options".

2. Select "Hardware Options".

The dialog lists installed hardware options on the R&S SFI100A.

Proceed the same way to get information on the firmware or the installed software
options in the corresponding tab.

Checking the RF hardware assembly

To find out the installed RF hardware:

1. Select "System Config" > "Setup" > "Instrument Assembly" > "Hardware Config".

2. Select "RF Assembly".

The dialog lists the installed RF hardware components installed on the
R&S SFI100A.

Checking the instrument configuration
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Proceed the same way to get information on general or baseband hardware modules
or on the operating times of the R&S SFI100A in the corresponding tab.

14.8.1  Hardware configuration settings

Access:

► Select "System Config" > "Setup" > "Instrument Assembly" > "Hardware Config".

The "Hardware Config" dialog lists all installed assemblies and connected external
instruments with information on their part and serial numbers, and revision states.
Also, it lists the BIOS version. A firmware update does not update the BIOS ver-
sion. The "Counter" tab provides information on the operation time, the number of
times that the instrument was powered on and the last factory calibration of the
instrument.

The remote commands required to query the hardware configuration are described in
Chapter 13.7, "DIAGnostic subsystem", on page 427.

Assembly
The tables in the tabs show characteristics of the installed assemblies.
"Assembly" Assembly designation.
"Part Number" Part number of the assembly.
"Serial Number"

Serial number of the assembly.
"Revision" Revision state of the assembly.
"Slot" Indicates whether the assembly is connected to the serial bus or PCI

bus.
Remote command: 
:DIAGnostic<hw>:BGINfo? on page 428

Counter
Displays information on the operation times of the R&S SFI100A.

Operation Time / h ← Counter
Displays the operation time in hours so far.
Remote command: 
:DIAGnostic:INFO:OTIMe? on page 429

Checking the instrument configuration
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Power On Count ← Counter
Displays the number the instrument has been turned on.
Remote command: 
:DIAGnostic:INFO:POCount? on page 429

Last Factory Calibration ← Counter
Displays the date of the last factory calibration.
Remote command: 
:CALibration:DATA:FACTory:DATE? on page 426

14.8.2  Versions and options settings

Access:

► Select "System Config" > "Setup" > "Instrument Assembly" > "Versions / Options".

The "Versions / Options" dialog shows the version of the installed instrument firm-
ware, the hardware and software options, the data sheet and the software compo-
nents of the firmware. The BIOS version is also listed; firmware updates do not
update the BIOS version.

The remote commands required to query the hardware configuration are described in
Chapter 13.7, "DIAGnostic subsystem", on page 427.

Firmware
Shows the firmware version and the version of the software platform.
Note: Your instrument is delivered with the latest firmware version available.
You can download firmware updates and the "Release Notes" that describe the modifi-
cations and the firmware update procedure.
Remote command: 
n.a.

Checking the instrument configuration
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Downgrade Info
Shows downgrade information, like factory firmware version and minimum firmware
version to that the instrument can be downgraded.
Remote command: 
n.a.

Show Open Source Acknowledgments
Accesses the list of the used open-source software packages and the corresponding
verbatim license texts.

LucasFonts RSCorpid EULA
Accesses copyright information on LucasFonts font type RSCorpid EULA.

Hardware Options/Software Options
The tables in the "Hardware" and "Software" tabs list the installed hardware and soft-
ware options.
"Option" Short name of option
"Designation" Name of option
"Expiration Date"

For regular options, "Permanent" is indicated in this column.
Remote command: 
*OPT? on page 408
*IDN? on page 408

Versions
The "Versions" tab shows the versions of the technical specification of the
R&S SFI100A and of the software components that comprise the firmware.

"Package" Name of the component.
"Version" Current issue of the component.
Remote command: 
:SYSTem:SPECification:VERSion:FACTory? on page 604

14.9  Collecting information for technical support

If you encounter problems that you cannot solve yourself, contact your
Rohde & Schwarz support center at www.rohde-schwarz.com/support. Our support
center staff is optimally trained to assist you in solving problems.

The support center finds solutions more quickly and efficiently if you provide them with
information on the instrument and an error description.
● The following dialog boxes in the "Setup > Instrument Assembly" menu provide

useful information:
– Hardware Configuration: hardware assemblies
– Software and Options: the status of all software and hardware options instal-

led on your instrument

Collecting information for technical support

https://www.rohde-schwarz.com/support
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● System Messages: displayed in the "Info" line and provide information on any
errors that have occurred

● Support file: a special file (*.tar.gz file) with important support information that
can be created automatically.
The support *.tar.gz file has a user-definable name and contains the following
files and information:
– SgErrors.txt: chronological record of errors
– SystemRestaurationSFI100A.savrcltxt: instrument settings at the last

correct shutdown of the instrument
– UndoHistSuppInfo.xml: list of the last user interactions
– DeviceFootprint_<SerialNumber>_<Date>_<Time>.xml: service-rela-

ted information on the instrument's configuration.
– crashlog.txt, coredump: Postmortem debug info
– Several files with information on the last performed adjustment and self-test.

See also the description of error messages Chapter 14.1, "Notifications", on page 614.

To collect error information in a support file

1. Connect a USB device to the R&S SFI100A.

2. Select "System Config > Setup > Maintenance > Create R&S Support Information".

3. In the "Create R&S Support Information" dialog, navigate to the /usb directory.
Enter the support filename, for example RSSupport_DeviceInfo.

The error information and further required data are collected automatically.
The support file RSSupport_DeviceInfo.tar.gz is created and stored in the /
usb directory.
Collect the error information and attach it to an email in which you describe the
problem. Send the email to the customer support address as listed on the Internet
(www.rohde-schwarz.com/support).

Collecting information for technical support

https://www.rohde-schwarz.com/support
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To remove sensitive data

► For information on how to handle or remove the sensitive data from your instru-
ment, refer to the description "R&S SFI100A Instrument Security Procedures".

To pack and transport the instrument

► If you need to transport or ship the instrument, see Chapter 15, "Transporting",
on page 627.

14.10  Contacting customer support

Technical support – where and when you need it

For quick, expert help with any Rohde & Schwarz product, contact our customer sup-
port center. A team of highly qualified engineers provides support and works with you
to find a solution to your query on any aspect of the operation, programming or applica-
tions of Rohde & Schwarz products.

Contact information

Contact our customer support center at www.rohde-schwarz.com/support, or follow this
QR code:

Figure 14-1: QR code to the Rohde & Schwarz support page

Contacting customer support

https://www.rohde-schwarz.com/support
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15  Transporting
Lifting and carrying

For safety information, see:
● "Lifting and carrying the product" on page 10

Packing

Use the original packaging material. It consists of antistatic wrap for electrostatic pro-
tection and packing material designed for the product.

If you do not have the original packaging, use similar materials that provide the same
level of protection. You can also contact your local Rohde & Schwarz service center for
advice.

Securing

When moving the R&S SFI100A in a vehicle or using transporting equipment, make
sure that the R&S SFI100A is properly secured. Only use items intended for securing
objects.

Transport altitude

The maximum transport altitude without pressure compensation is specified in the
specifications document.



Maintenance, storage and disposalR&S®SFI100A

628User Manual 1179.6789.02 ─ 02

16  Maintenance, storage and disposal
The product does not require regular maintenance. It only requires occasional clean-
ing. It is however advisable to check the nominal data from time to time.

● Cleaning................................................................................................................628
● Changing fuses..................................................................................................... 628
● Storage..................................................................................................................629
● Performing maintenance tasks..............................................................................630
● Disposal................................................................................................................ 641

16.1  Cleaning

How to clean the product is described in "Cleaning the product" on page 11.

Do not use any liquids for cleaning. Cleaning agents, solvents, acids and bases can
damage the front panel labeling, plastic parts and display.

16.2  Changing fuses

If the product does not start, it is possible that a blown fuse is the cause. The power
connector of the product is protected by two line fuses F1 and F2 (order number
0020.7630.00). The two line fuses are in the socket of the power supply on the rear
panel.

To check fuse characteristics

► To find out fuse characteristics, check the label to the right of the power switch on
the rear panel. See Figure 16-1.

Figure 16-1: Fuse label

The label lists the characteristics of the fuses. For an explanation of these charac-
teristics, see Table 16-1.
Table 16-1: Fuse characteristics

Label Description

F1/F2 Name of the fuse. The number relates to the location of the fuse in the fuse holder.

IEC60127-2/5 Standard that the fuse complies with.

T Triggering characteristic

Changing fuses
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Label Description

6.3 A Rated current

H Breaking capacity

250 V Rated power level

For more information, refer to the specifications document.

To change the fuses

1. WARNING! The fuse is part of the AC power supply. Handling the fuse while the
power is on can lead to electric shock.
Before changing the fuse:

a) Set the switch on the power supply to position [0] (3 in Figure 16-2).

1 2 3

Figure 16-2: Power supply

1 = Power connector: power outlet with ground contact
2 = Fuse holder
3 = Power switch

b) Disconnect the product from the power source (1).

2. Open the cover of the fuse holder (2) with a screw driver size 1 or similar.

3. Pull out the fuse holder with a screw driver size 3 or similar.

4. Check the condition of the fuse.

5. Replace the blown fuse. Only use a fuse of the specified type.

The fuse type and its characteristics are indicated next to the fuse holder, see
Table 16-1.

6. Insert the fuse holder into the mains power inlet.

7. Close the cover of the fuse holder.

16.3  Storage

Protect the product against dust. Ensure that the environmental conditions, e.g. tem-
perature range and climatic load, meet the values specified in the specifications docu-
ment.

Storage
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16.4  Performing maintenance tasks

The R&S SFI100A is accurate due to integrated adjustment procedures and the follow-
ing additional capabilities that assure correct functioning:
● Internal adjustments

Internal adjustments are integrated self-calibration routines, which you can execute
directly on the instrument.
How to: See Chapter 16.4.4.3, "How to use the internal adjustments",
on page 639.
Self-calibration routines that require additional equipment are performed at an
authorized Rohde & Schwarz service center. For a description, see the
R&S SFI100A service manual.

● Self-test
A self-test is provided for service purposes. We recommend that you perform a
self-test, if the instrument does not respond as expected.

● Test points
If necessary for service purposes, internal test points can be queried. For a
description, see the R&S SFI100A service manual.

● Date and time........................................................................................................630
● Check the front panel............................................................................................633
● Check display screen............................................................................................635
● Internal adjustments..............................................................................................636
● Selftest.................................................................................................................. 640

16.4.1  Date and time

The R&S SFI100A uses an internal real-time clock to determine the date and time. It
adjusts the time and date to the timezone of your location automatically, by providing a
selection list of continents and cities.

The instrument records the time whenever you create or modify files on your instru-
ment or you use timed licenses. By default, the instrument is set to the UTC timezone,
but you can select the timezone according to your location.

Moreover, the instrument supports NTP protocol for synchronizing all connected instru-
ments and computer systems to minimize time delays in the network.

Performing maintenance tasks
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16.4.1.1  Date and time settings

Access:

► Select "System Config" > "Setup" > "Maintenance" > "Date / Time".

The "Date / Time" dialog contains the time and data settings of the operating sys-
tem.
This function is password-protected. Unlock the protection level 1 to access it.
You can also set the time zone for your location, and select a time protocol control-
led by a time server for synchronization.

The required remote commands are described in Chapter 13.18, "SYSTem subsys-
tem", on page 581.

Settings:

Date.............................................................................................................................631
Time............................................................................................................................ 631
Timezone.....................................................................................................................632
Time Protocol.............................................................................................................. 632
NTP Address...............................................................................................................632

Date
Displays the date set in the operating system in the format [yyyy.mm.dd].
Remote command: 
:SYSTem:DATE on page 605

Time
Displays the time set in the operating system in the format [hh.mm.ss].
The time setting corresponds to the selected Timezone.
Remote command: 
:SYSTem:TIME on page 606

Performing maintenance tasks
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Timezone
Selects the timezone in the date and time settings of the operating system.
You can select the timezone according to the major cities on the respective continents.
Tip: By typing the first letter, you can quickly navigate through the lists to find the
desired destination.
Remote command: 
:SYSTem:TIME:ZONE on page 606
:SYSTem:TIME:ZONE:CATalog? on page 606

Time Protocol
Enables the instrument to refer to a network time protocol.
A network time protocol synchronizes the system clocks of all participating devices in a
computer network (Ethernet). A time server in the network provides the time base for
the connected devices that refer to this time to synchronize events.
You can select a high-precision time protocol to achieve high clock accuracy and thus
reduce the impact of varying network delays.
"None" Refers to the selected timezone, see "Timezone" on page 632.
"NTP" Uses the network time protocol (NTP).
Remote command: 
:SYSTem:TIME:PROTocol on page 607

NTP Address
Sets the IP address or host name of the NTP server.
When the server is detected and verified, the instrument enables the connection auto-
matically.
Remote command: 
:SYSTem:NTP:HOSTname on page 605
:SYSTem:NTP:STATe on page 606

16.4.1.2  How to set date and time

To select the timezone

1. Select "Maintenance > Date /Time > Timezone".

2. Select continent and city of your location.
Tip: By typing the first letter, you can quickly navigate through the lists to find the
desired destination.

3. Close the dialogs.

The instrument adjusts the time according to the selected location.

To set the date and time

1. Select "Security > Protection".

Performing maintenance tasks
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2. Enable the "Protection Level 1".
The default password is 123456.

3. Select "Setup > Maintenance > Date / Time".

4. Adjust the settings.

5. Close the dialogs.

The instrument sets the new date and time.

16.4.2  Check the front panel

Within this dialog, you can verify the functionality of the control keys.

How to: Chapter 16.4.2.2, "How to test the front panel", on page 634

16.4.2.1  Check front panel settings

Access:

► Select "System Config > Setup > Maintenance > Check Front Panel".

Reflecting the front panel, the "Check Front Panel" dialog contains all functions to
test the operating elements of the instrument.
In addition, you can check the touch-sensitive functionality by dragging one or
more lines across the screen with your finger.

Performing maintenance tasks
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16.4.2.2  How to test the front panel

Testing the key panel

To perform the key panel test, you operate the keys at the front panel, and check the
response of the instrument in the "Check Front Panel" dialog. To perform this test prop-
erly, check each key of the front panel. The test is only completed, when you have veri-
fied all keys.

During the test, the actual functions of the keys are disabled.

1. Select "Maintenance > Check Front Panel"
The "Check Front Panel" dialog opens.

2. Press a key on the front panel.
Check if the corresponding key in the "Check Front Panel" dialog turns green.

3. Press the same key a second time.
Check that the key in the dialog turns red.
Note: Pressing the same key again has no further effect, except for the [Esc] key.
Pressing this key a third time, terminates the test procedure.

4. Continue with the next key on the front panel and repeat step 2 to  step 4 until all
keys are tested.

The test is completed, when each key is verified successfully, confirmed by a "Test
passed" message.

Testing the touchscreen

► Drag with your finger one or more lines, for example diagonally across the screen.
The test traces the movements of your finger on the screen.

The following results are expected:
● If the lines are uninterrupted, the touchscreen works properly.

● If there are any gaps, the touch-sensitive functionality is damaged.

Performing maintenance tasks
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● To return to the "Check Front Panel" dialog, press [Esc].

Terminating the test

► Press the [Esc] key.

Exits the "Check Front Panel" dialog.

Debugging

► If you detect a malfunction, for example, when you press the front panel key for the
first time, and the color of the button in the dialog turns red (instead of green), the
front panel key has probably stuck.

16.4.3  Check display screen

Using this function, you can verify the color depth and gradient, pixels and the text dis-
play of the screen.

Access:

► Select "System Config > Setup > Maintenance > Check Display Screen".

The R&S SFI100A fades out the current display and indicates the screen in red.
Short instructions on the screen explain how to execute the test.

The remote commands required to define these settings are described in Chap-
ter 13.19, "TEST subsystem", on page 610.

Testing the display screen

To test the screen display on the R&S SFI100A manually, you need a keypad with cur-
sor and numeric keys.

1. Connect an external keyboard to the USB interface.

2. Select "System Config" > "Setup" > "Maintenance" > "Check Display Screen".

3. Test the color and gradient of the display screen:

Performing maintenance tasks
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a) Use the [Help] key to hide the indicated text.
b) To toggle between the provided colors manually, use the [Left/Right] cursor

keys.
The R&S SFI100A provides the colors red, green, blue, white, three levels of
gray shades and black.

c) To switch between the screen colors automatically, use the [Up] key.
d) To toggle the gradient, use the [Down] key.

4. Check if the R&S SFI100A indicates the text correctly:

a) Press [1] on the numeric keypad.
The R&S SFI100A displays a test text over the entire screen.

b) To inspect the text in detail, you can use the rotary knob to zoom it out.

5. To exit the test, press the [Esc] key.

Check Display Screen.................................................................................................636

Check Display Screen
Opens the test window with instructions on how to perform the test.
Remote command: 
:TEST:PIXel:WINDow on page 612
:TEST:PIXel:COLor on page 611
:TEST:PIXel:RGBA on page 612
:TEST:PIXel:GRADient on page 611
:TEST:PIXel:TEXT on page 612
:TEST:PIXel:POINtsize on page 611

16.4.4  Internal adjustments

Using the integrated adjustment procedures, you can start the calibration directly on
the instrument.

Performing maintenance tasks
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16.4.4.1  Internal adjustments settings

Access:

► Select "System Config > Setup > General > Internal Adjustments".

In this dialog, you can perform internal calibration routines, and get information on
the last performed calibration.
The "Temperature Offset" indicates the deviation of the current temperature of the
instrument, compared to the temperature of the last adjustment.

The remote commands required to define these settings are described in Chapter 13.6,
"CALibration subsystem", on page 423.

How to: Chapter 16.4.4.3, "How to use the internal adjustments", on page 639

Settings:

Adjust All..................................................................................................................... 637
Last Full Adjustment....................................................................................................638
Time............................................................................................................................ 638
Temperature Offset......................................................................................................638
Information.................................................................................................................. 638
Continue Adjustment on Error.....................................................................................638

Adjust All
Executes all available internal calibration routines of the instrument.
Note: Before you start the internal adjustment, make sure that you have connected a
termination resistor, if necessary.
Remote command: 
:CALibration:ALL[:MEASure]? on page 424

Performing maintenance tasks
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Last Full Adjustment
Displays the date of the last fully performed adjustment.
Remote command: 
:CALibration<hw>:ALL:DATE? on page 424

Time
Displays the elapsed time since the last full adjustment.
Remote command: 
:CALibration<hw>:ALL:TIME? on page 425

Temperature Offset
Displays the temperature difference, comparing the temperature of the last adjustment
to the current instrument temperature.
A green checkmark indícates that the offset is within the permitted range. If the temper-
ature deviates more than ±5 K, the instrument indicates a warning icon.
Remote command: 
:CALibration<hw>:ALL:TEMP? on page 425

Information
Displays information to the current adjustment state.
Remote command: 
:CALibration<hw>:ALL:INFormation? on page 424

Continue Adjustment on Error
Continues the calibration even though an error was detected. By default adjustments
are aborted on error.
This function is password-protected. Unlock the protection level 1 to access it.
Remote command: 
:CALibration<hw>:CONTinueonerror on page 425

16.4.4.2  Delayed adjustment settings

Adjust All Delayed
Performs all available internal calibration routines of the instrument.
How to: See Starting internal adjustments automatically.
Remote command: 
:CALibration:DELay[:MEASure]? on page 427

Warm Up Time
Sets the time for warming up the instrument before the calibration starts automatically.
How to: See Starting internal adjustments automatically.
Remote command: 
:CALibration:DELay:MINutes on page 426

Performing maintenance tasks
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Shutdown After Adjustment
Enables the automatic shutdown after internal adjustments.
How to: See Starting internal adjustments automatically.
Remote command: 
:CALibration:DELay:SHUTdown[:STATe] on page 426

16.4.4.3  How to use the internal adjustments

Deciding whether to run internal adjustments

1. Select "System Config > Setup > Internal Adjustment".

2. Check the status and color indication in the section "Since Last Full Adjustment".

Green: internal adjustments are not required.
Red: internal adjustments are required. Observe also the indication in the "Informa-
tion" field.

3. We recommend that you run internal adjustments in the following cases:
● Before starting any application that requires a maximum of level accuracy.
● When a long period of time has passed since the last adjustments.
● If the ambient temperature of the instrument significantly differs from the one of

the last adjustments.

4. Proceed as described in "Running internal adjustments" on page 639.

Running internal adjustments

1. After switching on, the R&S SFI100A requires up to 30 minutes to warm up.
Wait until the instrument has reached operating temperature to achieve accurate
adjustments.

2. Select "System Config > Setup > Internal Adjustment > Adjust All".

The adjustment process takes some time depending on the equipment of the
instrument.
If any error occurs, the process aborts. To resolve adjustment issues, see Chap-
ter 14.6, "Resolving errors during internal adjustments", on page 619.

Starting internal adjustments automatically

The delayed adjustment function executes the adjustments automatically. You can set
the warm-up time and shut down after the adjustment process finishes. Using this func-
tion, you can execute adjustments without being on-site and start measurements
directly when back.

1. If necessary, terminate the RF Out output. See "Running internal adjustments"
on page 639.

2. Select "System Config > Setup > General > Internal Adjustment".

3. Select "Delayed Adjustment".

Performing maintenance tasks
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4. Set the "Warm Up Time", e.g. 40 min.

The R&S SFI100A requires a warm-up time of at least 30 min.

5. Enable "Shut Down After Adjustment"

6. Select "Adjust All Delayed".

The process starts with warming up the instrument, indicating the progress in a sta-
tus dialog. In this dialog, you can abort the process again, if necessary.
After warming up, the R&S SFI100A executes the internal adjustments and shuts
down when finished.

16.4.5  Selftest

Self-test is provided for service purposes.

16.4.5.1  Selftest modules settings

Access:

► Select "System Config > Setup > Maintenance > Selftest".

The "Modules" dialog opens.

The dialog contains parameters for testing the baseband and RF hardware mod-
ules of the R&S SFI100A.

The remote commands required to define these settings are described in Chap-
ter 13.19, "TEST subsystem", on page 610.

Run Module Test......................................................................................................... 640
Result.......................................................................................................................... 641
Last Full Test............................................................................................................... 641

Run Module Test
Runs selftests of the hardware modules selected in the test table.
You can run seftests for the "BBCV" baseband module and the "RFCV" RF module.
Also you can execute the tests separately.
Remote command: 
:TEST<hw>:ALL:STARt on page 610

Performing maintenance tasks
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Result
Displays the result of the hardware module selftests.
Remote command: 
:TEST<hw>:ALL:RESult? on page 610

Last Full Test
Displays the result and date of the last hardware module test run including the elapsed
time since the last test run.
For example, "PASS, 4 Jul 20, 10 days ago" implies a successful test on July 04, 2020.
Remote command: 
:TEST<hw>:ALL:RESult? on page 610

16.5  Disposal

Rohde & Schwarz is committed to making careful, ecologically sound use of natural
resources and minimizing the environmental footprint of our products. Help us by dis-
posing of waste in a way that causes minimum environmental impact.

Disposing of electrical and electronic equipment

A product that is labeled as follows cannot be disposed of in normal household waste
after it has come to the end of its life. Even disposal via the municipal collection points
for waste electrical and electronic equipment is not permitted.

Figure 16-3: Labeling in line with EU directive WEEE

Rohde & Schwarz has developed a disposal concept for the eco-friendly disposal or
recycling of waste material. As a manufacturer, Rohde & Schwarz completely fulfills its
obligation to take back and dispose of electrical and electronic waste. Contact your
local service representative to dispose of the product.

Disposal
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Annex
A  Available user files and file extensions

The table Table A-1 lists available file extensions for user files on the instrument. Some
files depend on the installed options.

For more information, refer to the specifications document.
Table A-1: User files and file extensions on the instrument

Context or function Content type File contents File extension

Instrument state Settings Instrument settings *.savrcltxt

User menu Settings User-defined favorite settings *.user_menu

License key License License key *.xml

User correction List User-defined level correction values *.uco

Power sensing Settings R&S NRP settings *.nrp, *.rsu

SCPI command list List Export file containing list of SCPIs *.iec

SCPI command script Command script SCPI script file formats: Plain SCPI, MATLAB, NICVI,
Python3

*.txt, *.m, *.c,
*.py

R&S support information Support file Automatically collected support information *.tar.gz

Tutorials Tutorial files Lists containing SCPIs and explanations *.tut

Frequency response
correction

Settings User-defined baseband frequency response correction file *.frc

ARB Waveform ARB waveforms *.wv

ARB Waveform ARB multicarrier settings *.arb_multcarr

ARB I/Q data files I/Q data *.iq.tar, *.csv,
*.mat
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B  Unit shortcuts
When specifying units or quantities during data entry, the R&S SFI100A provides the
following shortcuts for simplified input.

Shortcut Designation Context Unit

a, A ampere Current A

 atto- Area, surface am2

c, C centi- Distance, length cm

d, D deci- Distance, length dm

  Level, power dB, dBFS, dBm, dBU, dBW

 degree Phase, polar/spherical coordinates deg

e, E exa- Area, surface em2

f, F femto- Area, surface fm2

g, G giga- Area, surface Gm2

  Data rate, sample rate, symbol rate Gbit/s, Gsample/s, Gsymbol/s, Gchip/s

  Frequency GHz

  Impedance, resistance GΩ

h, H hertz Frequency Hz

k, K kilo- Area, surface km2

  Data rate, sample rate, symbol rate kbit/s, ksample/s, ksymbol/s, kchip/s

  Distance, length km

  Frequency kHz

  Impedance, resistance kΩ

  Velocity km/h

m, M milli- Area, surface mm2

  Current mA

  Distance, length mm

  Electromagnetic force, level mV

  Power mW

  Time, period, etc. ms

 mega- Area, surface Mm2

  Data rate, sample rate, symbol rate Mbit/s, Msample/s, Msym/s, Mchip/s

  Frequency MHz

  Impedance, resistance MΩ
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Shortcut Designation Context Unit

n, N nano- Area, surface nm2

  Current nA

  Distance, length nm

  Electromagnetic force, level nV

  Power nW

  Time, period, etc. ns

o, O ohm Impedance, resistance Ω

p, P peta- Area, surface pm2

 percent Level, ratio %

 pico- Area, surface pm2

  Current pA

  Electromagnetic force, level pV

  Power pW

  Time, period, etc. ps

r, R radiant Phase, polar/spherical coordinates rad

s, S second Time, period, etc. s

t, T terra- Area, surface Tm2

  Data rate, sample rate, symbol rate Tbit/s, Tsample/s, Tsym/s, Tchip/s

  Frequency THz

  Impedance, resistance TΩ

u, U micro- Current µA

  Distance, length µm

  Electromagnetic force, level µV

  Power µW

  Time, period, etc. µs

v, V volt Level, voltage V

w, W watt Level, power W
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Glossary: Terms and abbreviations
A

Avahi: A licensed Zeroconf networking feature, including DNS service. The feature
enables a device to self-configure an IP address and subnet mask automatically, when
a DHCP server in the LAN is not available.

B
Base unit: This term describes a R&S SFI100A equipped with the option R&S SFI-
B103.

Baseband: The baseband signal, i.e. the I/Q stream at the output of the "Baseband"
block.
In rear cases, the term Baseband is used as abbreviation of a "Baseband" block itself.

Baseband domain: A common term for signal processing up to the I/Q modulation.
The signal in the baseband domain of the R&S SFI100A is digital.

Baseband signal: Baseband

BS: Base station

C
Channel (digital Input, Digital Output): The signal provided at a digital interface con-
nector or the output stream at the digital output interface can consist of several multi-
plexed channels. Do not mistake the term channel used here with the term signal path.
A digital channel is a part of an I/Q stream.

Clock: A mandatory internal or an external reference clock signal for generating the
timing pulse in the instrument.

Complete file path: The complete file path specifies the root directory and all subdir-
ectories that contain a file or folder.
Synonyms to this expression are "full file path" and "absolute file path".
See also Chapter 13.5.2, "Handling files in the default or in a specified directory",
on page 414.

Computer name: Hostname

Continuous Wave Mode: CW/Mod

CW/Mod: An internally generated control signal that turns off/on digital modulation, i.e.
the signal is generated in unmodulated form.
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D
daisy chain: A connection scheme in which instruments are connected together in
sequence, i.e. an output of the first one is connected to an input of the second one, etc.

DHCP: Dynamic host configuration protocol

DNS: Domain name system server

E
e.g.: For example

External mass memory: External memory, connected to the instrument via USB con-
nector (Type A female). It can hold stored files with user data.
See also System drive

F
File transfer: The transmission of files from or to the instrument by a remote client.
The instrument supports the standard methods FTP and file sharing according to
SAMBA/SMB.

FTP: File transfer protocol

G
Glossary: List of the often used terms and abbreviations

GUI: Graphical user interface

H
Hostname: An unambiguous indication of the instrument in a LAN that uses a DNS
server.
The default hostname follows the syntax SFI100A-<serial number>, e.g.
SFI100A-102030.
See Serial number.
Synonym: Computer name

I
i.e.: That is

I/Q Stream: Stream

L
LF: Low frequency

LSB: Least significant bit
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M
MIMO: Multiple input multiple outputs

MSB: Most significant bit

N
NTP: Network Time Protocol synchronizes all connected instruments and computer
systems to minimize time delays in the network.

P
PC: Personal computer

Power: A term describing the signal level of the RF signal

product page: A designation of the R&S SFI100A product page www.rohde-
schwarz.com/product/SMA100B.html

R
Remote access: Remote operation

Remote control: The operation of the R&S SFI100A by remote control commands or
programs to perform automated tests.
The instrument is connected to a system controller via LAN/VXI-11 using VISA. The
instrument is controlled directly or supported by instrument drivers.

Remote device: External device controls the R&S SFI100A in remote operation mode,
see Remote operation.
Synonyms: External controller, client device

Remote operation: Allows you to operate the R&S SFI100A from a remote device
using VNC.
Both the R&S SFI100A and the remote device are connected in a LAN.
Synonym: Remote access

RF: Radio frequency

S
SAMBA/SMB: Server message protocol

Serial number: Unique instrument identification, provided on the rear panel of the
instrument and required to build the Computer name.
The serial number are the last 6 digits in the string <stock no.>-<serial
number>, e.g. SFI100A-102030

Smart device: A mobile, cordless device, such as a smartphone or tablet, capable of
Internet browsing.

https://www.rohde-schwarz.com/product/SMA100B.html
https://www.rohde-schwarz.com/product/SMA100B.html
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Synonyms: Smartphone, tablet

System drive: The system drive is a built-in internal memory that holds the operating
system, the firmware, and the stored user data.
Throughout this description, the system drive is referred as an internal memory.
See also Removable memory

T
Trigger: Internally generated or externally supplied signal which starts signal genera-
tion at a particular point in time.

Trigger event: A trigger event is caused by the received trigger signal or executed
manual trigger.

U
UE: User equipment

USBTMC: (USB test & measurement class)
A protocol built on top of USB for communication with USB devices. Using VISA library,
it supports service request, triggers, and other specific operations, similar to GPIB.

User directory: Describes the default file storage location for user data.
In the file system, user directory is indicated as /var/user/.
It is physically located on the internal memory or on the removable memory.

V
VISA: Virtual instrument software architecture

VNC: Virtual nework computing

VNC client software: Application on a remote device that enables remote operation of
an instrument over LAN.

Z
Zeroconf: Zero-configuration, see Avahi.
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Glossary: Publications and references
Symbols

1GP60: Rohde & Schwarz application note "MATLAB Toolkit for R&S® Signal Genera-
tors"
www.rohde-schwarz.com/appnote/1GP60

1GP72: Rohde & Schwarz application note "Connectivity of Rohde & Schwarz Signal
Generators"
www.rohde-schwarz.com/appnote/1GP72

1GP141: Rohde & Schwarz application note "Using R&S® Power Sensors with
R&S®Signal Generators"
www.rohde-schwarz.com/appnote/1GP141

1MA074: Rohde & Schwarz application note "RSCommander"
www.rohde-schwarz.com/appnote/1MA074

1MA99: Rohde & Schwarz application note "Guidance on Selecting and Handling
Coaxial RF Connectors used with Rohde & Schwarz Test Equipment"
www.rohde-schwarz.com/appnote/1MA99

1MA100: Rohde & Schwarz application note "Test Port Adapter, R&S Interchangeable
Port Connector"
www.rohde-schwarz.com/appnote/1MA100

1MA208: Rohde & Schwarz application note "Fast Remote Instrument Control with
HiSLIP"
www.rohde-schwarz.com/appnote/1MA208

 

https://www.rohde-schwarz.com/appnote/1GP60
https://www.rohde-schwarz.com/appnote/1GP72
https://www.rohde-schwarz.com/appnote/1GP141
https://www.rohde-schwarz.com/appnote/1MA074
https://www.rohde-schwarz.com/appnote/1MA99
https://www.rohde-schwarz.com/appnote/1MA100
https://www.rohde-schwarz.com/appnote/1MA208
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