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1  Welcome to the R&S SMM-K54x options
The R&S SMM-K540 is a software option that allows you to generate an envelope
tracking signal, that follows the envelope variation of the RF signal.

R&S SMM-K540 key features

● Baseband signal, RF signal, and envelope signal generation out of one instrument
● Envelope signal derived directly and in real time from the baseband signal
● Fully synchronous envelope and RF signal with optional delay compensation for

time alignment of the envelope signal
● Simultaneous output of envelope and inverted envelope signal
● Flexible envelope shaping based on different algorithms incl. a build-in table shap-

ing editor
● Import/export interface for files describing shaping functions
● Real-time display of the characteristics of the envelope signal

The R&S SMM-K541 is a software option that adds functionality to define and apply
AM/AM and AM/PM predistortions.

R&S SMM-K541 key features

● Applying user-defined AM/AM and AM/PM digital predistortions directly on the digi-
tal baseband signal

● Digital predistortions are applied directly and in real time to the baseband signal,
i.e. to any Digital Standard signal or with ARB waveforms

● Separate or superimposed AM/AM or AM/PM predistortion also with variable order
in the processing flow

● Flexible shaping of the predistortion functions based on a polynomial function and
a build-in table editor

● Import/export interface for files describing the predistortion functions, i.e. load of
AM/AM and AM/PM tables directly from characterization software

● Real-time display of the correction functions
● In instruments equipped with the option R&S SMM-K540, digitally predistorted

baseband signal, RF signal, and envelope signal generation out of one instrument

This user manual contains a description of the functionality that the application pro-
vides, including remote control operation.

All functions not discussed in this manual are the same as in the base unit and are
described in the R&S SMM100A user manual. The latest version is available at:

www.rohde-schwarz.com/manual/SMM100A

Installation

You can find detailed installation instructions in the delivery of the option or in the
R&S SMM100A service manual.

https://www.rohde-schwarz.com/manual/smm100a
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1.1  Accessing the required settings

To open the dialog with Envelope Tracking settings

1. In the block diagram of the R&S SMM100A, select the "I/Q OUT" connector to
unfold the "I/Q Analog" block.

A dialog box opens that displays the provided general settings.

2. Select "I/Q Analog > I/Q Analog Outputs > General".

3. Select "RF Envelope > On".

To open the dialog with DPD settings

► In the block diagram of the R&S SMM100A, select "I/Q Mod > Digital Predistortion
> AM/AM AM/PM".

A dialog box opens that displays the provided settings.

The signal generation is not started immediately. To start signal generation with the
default settings, select "State > On".

1.2  What's new

This manual describes firmware version FW 5.30.047.xx and later of the
R&S®SMM100A.

Compared to the previous version there are editorial changes only.

1.3  Documentation overview

This section provides an overview of the R&S SMM100A user documentation. Unless
specified otherwise, you find the documents at:

www.rohde-schwarz.com/manual/smm100a

1.3.1  Getting started manual

Introduces the R&S SMM100A and describes how to set up and start working with the
product. Includes basic operations, typical measurement examples, and general infor-
mation, e.g. safety instructions, etc. A printed version is delivered with the instrument.

Documentation overview

http://www.rohde-schwarz.com/manual/smm100a
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1.3.2  User manuals and help

Separate manuals for the base unit and the software options are provided for down-
load:
● Base unit manual

Contains the description of all instrument modes and functions. It also provides an
introduction to remote control, a complete description of the remote control com-
mands with programming examples, and information on maintenance, instrument
interfaces and error messages. Includes the contents of the getting started manual.

● Software option manual
Contains the description of the specific functions of an option. Basic information on
operating the R&S SMM100A is not included.

The contents of the user manuals are available as help in the R&S SMM100A. The
help offers quick, context-sensitive access to the complete information for the base unit
and the software options.

All user manuals are also available for download or for immediate display on the Inter-
net.

1.3.3  Service manual

Describes the performance test for checking compliance with rated specifications, firm-
ware update, troubleshooting, adjustments, installing options and maintenance.

The service manual is available for registered users on the global Rohde & Schwarz
information system (GLORIS):

https://gloris.rohde-schwarz.com

1.3.4  Instrument security procedures

Deals with security issues when working with the R&S SMM100A in secure areas. It is
available for download on the internet.

1.3.5  Printed safety instructions

Provides safety information in many languages. The printed document is delivered with
the product.

1.3.6  Data sheets and brochures

The data sheet contains the technical specifications of the R&S SMM100A. It also lists
the options and their order numbers and optional accessories.

The brochure provides an overview of the instrument and deals with the specific char-
acteristics.

Documentation overview

https://gloris.rohde-schwarz.com
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See www.rohde-schwarz.com/brochure-datasheet/smm100a

1.3.7  Release notes and open source acknowledgment (OSA)

The release notes list new features, improvements and known issues of the current
firmware version, and describe the firmware installation.

The software makes use of several valuable open source software packages. An open-
source acknowledgment document provides verbatim license texts of the used open
source software.

See www.rohde-schwarz.com/firmware/smm100a

1.3.8  Application notes, application cards, white papers, etc.

These documents deal with special applications or background information on particu-
lar topics.

See www.rohde-schwarz.com/application/smm100a

1.3.9  Videos

Find various videos on Rohde & Schwarz products and test and measurement topics
on YouTube: https://www.youtube.com/@RohdeundSchwarz

On the menu bar, search for your product to find related videos.

Figure 1-1: Product search on YouTube

Documentation overview

http://www.rohde-schwarz.com/brochure-datasheet/smm100a
http://www.rohde-schwarz.com/firmware/smm100a
http://www.rohde-schwarz.com/application/smm100a
https://www.youtube.com/@RohdeundSchwarz
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1.4  Scope

Tasks (in manual or remote operation) that are also performed in the base unit in the
same way are not described here.
In particular, it includes:
● Managing settings and data lists, like saving and loading settings, creating and

accessing data lists, or accessing files in a particular directory.
● Information on regular trigger, marker and clock signals and filter settings, if appro-

priate.
● General instrument configuration, such as checking the system configuration, con-

figuring networks and remote operation
● Using the common status registers

For a description of such tasks, see the R&S SMM100A user manual.

1.5  Notes on screenshots

When describing the functions of the product, we use sample screenshots. These
screenshots are meant to illustrate as many as possible of the provided functions and
possible interdependencies between parameters. The shown values may not represent
realistic usage scenarios.

The screenshots usually show a fully equipped product, that is: with all options instal-
led. Thus, some functions shown in the screenshots may not be available in your par-
ticular product configuration.

Notes on screenshots
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2  Generation of envelope tracking signals
Envelope tracking (ET) is a method used by modern power amplifiers (PA) to improve
their efficiency, especially when amplifying RF signals with a high peak to average
power (PAPR). An envelope tracking detector "tracks" the power variations in the input
signal of the PA. The PA then varies synchronously to this variation the supply voltage
vcc at its end-amplifying stage.

This section introduces the concept of the envelope tracking functionality and the way
that it is implemented in the R&S SMM100A.

Refer to Chapter 4, "How to generate a control signal for power amplifier envelope
tracking tests", on page 69 for step-by-step instruction on how to use the provided
function.

2.1  Required options

The equipment layout for generation and output of envelope tracking signal includes:
● Base unit
● Option differential analog I/Q outputs (R&S SMM-K17)
● Option envelope tracking (R&S SMM-K540)
● Optional option AM/AM AM/PM predistortion (R&S SMM-K541)

For more information, see data sheet.

2.2  About the envelope tracking

The R&S SMM100A allows you to generate an envelope tracking signal, that follows
the envelope variation of the RF signal.

Principle of the envelope tracking

The Figure 2-1 shows a simplified test setup for testing of a PA with an envelope track-
ing. This illustration is intended to explain the principle in general, not all connections
and required equipment are considered.

About the envelope tracking
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Figure 2-1: Simplified test setup for power amplifier envelope tracking tests

The R&S SMM100A in this setup is configured to generate both, an RF signal with
complex modulation scheme and an envelope signal, that follows the envelope varia-
tion of this RF signal. A suitable test signal is, for example, an EUTRA/LTE DL signal.

The R&S SMM100A generates the envelope signal directly from the baseband signal.
The envelope signal is a voltage signal, with voltage level Vout proportional to the
power of the RF signal (√[I(t)2+Q(t)2]) of the corresponding path. If you do not apply a
shaping function, the envelope signal linear dependent follows the variation of the RF
signal's envelope.

The envelope signal is output at the I out and I Bar out rear panel connectors. This
envelope signal is then further fed to an external DC modulator.

The PA receives the RF input signal and the dynamically adapted supply voltage vcc.
Ideally, the PA gain stays constant.

Suitable baseband signal to observe the effect of the envelope tracking settings

To simplify the explanation in the following sections, we use a simple ramp function as
a baseband signal modulated on the RF carrier.

Other suitable baseband signals are signals with relative constant envelope. You find a
choice of predefined signals in the "Baseband > Custom Digital Mod > Set according to
standard" dialog. With the default settings in this dialog, you can observe the gener-
ated envelope signal and the effects of enabled shaping.

2.2.1  Envelope voltage adaptation modes

In the R&S SMM100A, you define the voltage of the generated envelope signal using
one of the following modes:
● Auto Power/Normilized Envelope Voltage Adaptation:

In this mode, you define the desired input characteristics of the power amplifier.
Based on these values and depending on the crest factor of the generated signal,
the R&S SMM100A calculates:
– The voltage on the I out/I Bar out connectors (VoutMin/Max) and a bias (Bias),

– The RMS level of the RF signal

About the envelope tracking



Generation of envelope tracking signalsR&S®SMM-K540/K541, R&S®SMM-K540/K541

12User Manual 1179.1970.02 ─ 06

The auto voltage adaptation mode is a suitable choice, if you have knowledge on
the power amplifier components and characteristics. Common PA characteristics
are the supply voltage Vcc, the input power PEPin required for working in the linear
range and the gain characteristics of the external DC modulator.
You find the required values in the documentation of your power amplifier, for
example in its data sheet.

● Manual Envelope Voltage Adaptation:
In this mode, you can also define the operating range of the power amplifier based
on a pre-gain and a post-gain range. Based on these values, the instrument calcu-
lates the supply voltage Vcc.

All modes support envelope shaping.

2.2.2
 Signal parameters for testing according to the eTrak® specification

In the R&S SMM100A, you can select one of the predefined eTrak® interface types so
that the generated signal is conformed with the MIPI®Alliance specification "Analog
Reference Interface for Envelope Tracking Specification".

Table 2-1: Default parameters per eTrak® Interface Type

Parameter 1.2 Vpp 1.5 Vpp 2 Vpp

I/Q output Type Differential Differential Differential

Bias 500 mV 600 mV 900 mV

Vpp Max 1.2 V 1.5 V 2 V

Vpp Max 1.2 V 1.5 V 2 V

Bipolar Input On On On

2.2.3  Envelope shaping and shaping methods

Envelope shaping is a method that uses functions to describe the relationship between
supply voltage and RF input power. An envelope-shaping function is a trade-off
between effectivity and improved linearity of the PA.

In the R&S SMM100A, you can select the way you define the shaping function. You
can choose between:
● 2 predefined simple linear functions

(see Chapter 2.2.3.1, "About the linear functions", on page 13)
● 3 detroughing functions with a configurable factor

(see Chapter 2.2.3.2, "About the detroughing function", on page 14)
● A polynomial function with up to 10 polynomial coefficients

(see Chapter 2.2.3.3, "About the polynomial function", on page 14)
● A shaping function defined as a shaping table

(see Chapter 2.2.3.4, "About the shaping table", on page 15)
● To set the correction values in raw format with a single remote control command

(see Chapter 2.2.3.5, "Shaping function in raw data format", on page 16)

About the envelope tracking
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The linear, the detroughing and the polynomial shaping functions are mathematical
expressions that are described as function of the variable x, see Table 2-2.
Table 2-2: Definition of the variable x depending on the envelope voltage adaptation mode

"Envelope Voltage Adaptation" x

Auto Power x = Vin - Vin, min

x ≥ 0

Auto Normalized x = Vin/Vin,max

Manual x = VEnv/VEnv,max

The mathematical expressions and further information on the shaping functions are
provided in the corresponding sections.

See also Chapter 2.2.3.6, "Converting shaping functions and understanding the dis-
played values", on page 16.

● About the linear functions........................................................................................13
● About the detroughing function............................................................................... 14
● About the polynomial function.................................................................................14
● About the shaping table.......................................................................................... 15
● Shaping function in raw data format........................................................................16
● Converting shaping functions and understanding the displayed values................. 16

2.2.3.1  About the linear functions

The linear shaping can be used for less demanding applications, simple analysis, and
the first interactions by designing the optimum envelope shape. Because the shaping
gain of the linear function is 0 dB, in "Envelope Voltage Adaptation > Manual" mode
this function is suitable for determining the "Pre-/Post-Gain" values (see Example"Cal-
culating the current VCC in "Manual" mode" on page 20).

Provided are two linear functions, where each of them depends on the "Envelope Volt-
age Adaptation" mode:
● Linear (Voltage)

– f(x) = x in "Auto Normalized/Manual"
– f(x) = b*x + Vcc,min in "Auto Power"

● Linear (Power)
– f(x) = x2 in "Auto Normalized/Manual"
– f(x) = b*x2 + Vcc,min in "Auto Power"

Where:
● The variable x depends on the "Envelope Voltage Adaptation" mode, see

Table 2-2.
● The constant b is calculated as:

b = (Vcc,max - Vcc,min)/(Vin,max - Vin,min)

About the envelope tracking
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See also Chapter 2.2.3.6, "Converting shaping functions and understanding the dis-
played values", on page 16.

2.2.3.2  About the detroughing function

Detroughing functions are well defined mathematical functions that prevent that the
supply voltage Vcc drops down to zero or falls under specified limits. That is, they pre-
vent that the signal is clipped.

Provided are the following functions:
● f(x) = x + d*e-x/d

● f(x) = 1 - (1 - d)*cos(x*pi/2)
● f(x) = d + (1 - d)*xa

Where:
● x is a variable, that depends on the "Envelope Voltage Adaptation" mode, see

Table 2-2
● a is the Exponent (a).
● d is the Detroughing Factor (d), that limits the supply voltage Vcc in the low-power

region and controls the shaping.
The detroughing factor (d) can be set manually or derived from the selected Vcc

value. In the latter case, it is calculated as follows:
d = Vcc,min/Vcc,max

See Couple Detroughing Factor with Vcc.
A "Detroughing Factor = 0" defines a linear function.

See also Chapter 2.2.3.6, "Converting shaping functions and understanding the dis-
played values", on page 16.

2.2.3.3  About the polynomial function

The polynomial function is an analytical method to describe a shaping function. The
polynomial function is defined as follows:

f(x) = a0 + ∑(an*xn), where n ≤10 and:
● Depending on the "Envelope Voltage Adaptation" mode, f(x) is:

– f(x) = Vcc(x) in "Auto Power"

– f(x) = Vcc/Vcc,max(x) in "Auto Normalized/Manual"
● The polynomial order n, the polynomial constant a0, and polynomial coefficients a0

to an are user-definable, see Chapter 2.7, "Polynomial coefficients settings",
on page 43

● x depends on the "Envelope Voltage Adaptation" mode, see Table 2-2

The default polynomial function with n = 1, a0 = 0 and a0 = 1 describes a linear func-
tion.

See also:
● Figure 2-13

About the envelope tracking
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● Chapter 2.2.3.6, "Converting shaping functions and understanding the displayed
values", on page 16.

File format of the polynomial function file

You can store a polynomial function in a file or even define the polynomial coefficients,
store them as a file and load this file into the instrument. The polynomial files are files
with extension *.iq_poly.

The file contains an optional header # Rohde & Schwarz - IQ Output
Envelope Polynomial Coefficients # a0,a1,a2,... and a list of comma-
separated coefficient values.

Example: Polynomial function file content
# Rohde & Schwarz - IQ Output Envelope Shaping Table
# a0,a1,a2,...
0.135,0.91,0.34,-0.59,-0.11

2.2.3.4  About the shaping table

The envelope-shaping table is a widely used method to define the shaping function.
This kind of definition is suitable if you have knowledge on or aim to achieve an exact
relation between supply voltage and RF input power. For example, with suitable set-
tings, the shaping table can precisely describe the transition region of the PA.

You can receive information on suitable envelope-shaping values form the power
amplifier manufacturer.

In the R&S SMM100A, there are two ways to define a shaping table function:
● Externally

Create a shaping table file as a CSV file with Microsoft Excel, with a Notepad or a
similar tool. Save it with the predefined extension, transfer it to and load it into the
instrument.
See also "File format of the shaping table file" on page 15.

● Internally
Use the built-in editor table editor, see Chapter 2.6, "Edit I/Q envelope shape set-
tings", on page 40.

File format of the shaping table file

The shaping table files are files with predefined extension and simple file format, see
Table 2-3.

About the envelope tracking
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Table 2-3: Shaping table files: format and extensions

"Envelope Voltage Adaptation" File extension Header (optional)

Auto Power *.iq_lutpv # Rohde & Schwarz - IQ Output
Envelope Shaping Table
# Power[dBm],Vcc[V]

Auto Normalized/Manual *.iq_lut # Rohde & Schwarz - IQ Output
Envelope Shaping Table
# Vin/Vmax,Vcc/Vmax

The header is optional. The file content is list of up to 4000 comma-separated value
pairs; a new line indicator separates the pairs.

Example: Shaping table file content (*.iq_lut file)
# Rohde & Schwarz - IQ Output Envelope Shaping Table
# Vin/Vmax,Vcc/Vmax
0.3,0.4
0.35,0.45
0.56,0.55
0.4,0.5
0.6,0.65
0,0.135

2.2.3.5  Shaping function in raw data format

The shaping values are defined directly, with a single remote control command. You
define up to 4000 comma-separated value pairs, describing the Vin/Vmax,Vcc/Vmax
or Power[dBm],Vcc[V].

Example: 
SOURce1:OUTPut:ANALog:ENVelope:SHAPing:PV:FILE:DATA 0,0, 0.1,0.2, 1,1

See:
● [:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:SHAPing:FILE:DATA

on page 93
● [:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:SHAPing:PV:FILE:

DATA on page 93
● [:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:SHAPing:FILE:NEW

on page 93
● [:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:SHAPing:PV:FILE:NEW

on page 93

2.2.3.6  Converting shaping functions and understanding the displayed values

If an envelope function is defined, the "Shaping" dialog displays the diagram of the
resulting envelope shape.

See for example Figure 2-7.

About the envelope tracking
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Several parameters influence the displayed information:
● The selected "Envelope Voltage Adaptation" determines whether the x-axis uses

normalized or linear values
● The selected "Graphic Configuration > Scale" sets the x-axis units
● The selected VccMin/Max and PEPinMin/Max values set the borders of the clipping

areas
● The selected "Shaping" function and the parameters influence the envelope shape.

The illustration on Figure 2-2 shows how these parameters influence a linear shaping
function.

Figure 2-2: Understanding the displayed values ("Shaping > Linear (Voltage)")

Shaded area = Area where the signal is clipped and the envelope signal is held constant.
1a, 1b, 2a, 2b = Vcc,min/Vcc,max and PEPinMin/Max values that set the borders of the clipping areas
Shaping = Linear (Voltage)
3a = Linear function (dashed line) in "Auto Power" mode, if Vcc,min = 0 V
3b = Linear function in "Auto Power" mode, if Vcc,min > 0 V
4a = Linear function (dashed line) in "Auto Normalized" mode, if Vcc,min = 0 V
4b = Linear function in "Auto Normalized" mode, if Vcc,min > 0 V
Vin = Operating point
VccNorm = Vcc in "Auto Normalized" mode
VccPow0 = Vcc in "Auto Power" mode and Vcc,min = 0 V
VccPow1 = Vcc in "Auto Power" mode and Vcc,min > 0 V

For information on the provided shaping functions and their formulas, see:
● Chapter 2.2.3.1, "About the linear functions", on page 13
● Chapter 2.2.3.2, "About the detroughing function", on page 14
● Chapter 2.2.3.3, "About the polynomial function", on page 14

About the envelope tracking
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The group of examples in this section uses the same linear shaping function to explain
the representation in the different voltage adaptation modes. The example explains the
displayed values and how they are calculated and converted. The same principle
applies for the other shaping methods.

Common settings

● "Envelope Voltage Adaptation > Auto Power"
● Vcc Max = 1 V
● PEPinMin = -30 dBm corresponds to Vin,min = 0.0071 V
● PEPinMax = 0 dBm corresponds to Vin,max = 0.2236 V
● Pin = -15 dBm corresponds Vin = 0.04 V
● PEP = -3.4 dB
● "Shaping > Linear (Voltage)"

"Graphic Scale > Power" "Graphic Scale > Voltage"

Example: Calculating the current VccPow0 ("Auto Power" mode, Vcc Min = 0 V)
Configuration as described in Common settings and:
● Vcc,min = 0 V
● f(x) = b*x + Vcc,min

(see Chapter 2.2.3.1, "About the linear functions", on page 13)
VccPow0 = [(Vcc,max - Vcc,min)/(Vin,max - Vin,min)] * (Vin - Vin,min) + Vcc,min

VccPow0 = [(1 - 0)/(0.2236 - 0.0071)]*(0.04 - 0.0071) + 0

VccPow0 = 0.151 V

About the envelope tracking
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Example: Calculating the current VccPow1 ("Auto Power" mode, Vcc Min > 0 V)
Configuration as described in Common settings and:
● Vcc,min = 200 mV

VccPow1 = [(Vcc,max - Vcc,min)/(Vin,max - Vin,min)] * (Vin - Vin,min) + Vcc,min

VccPow1 = [(1 - 0.2)/(0.2236 - 0.0071)]*(0.04 - 0.0071) + 0.2

VccPow1 = 0.321 V

Example: Calculating the current VccNorm ("Auto Normalized" mode)
Configuration as described in Common settings and:
● "Envelope Voltage Adaptation > Auto Normalized"
● The x-axis shows the normalized values Vin/Vin,max;

The operating point with Vin = 0.04 V corresponds to
Vin/Vin.max = 0.04 / 0.2236 = 0.178

● f(x) = x, i.e.
VccNorm = Vin/Vin,max

VccNorm = 0.178 V

About the envelope tracking
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If the Vcc,min value is changed (Vcc,min > 0 V), then the following applies:
● If 0 < Vin/Vin,max ≤ Vcc,min, the signal is clipped and VccNorm = Vcc,min

● If Vin/Vin,max > Vcc,min, then VccNorm = Vin/Vin,max

For the previous example, if Vcc,min = 200 mV, that VccNorm = Vcc,min = 0.2 V.

Example: Calculating the current VCC in "Manual" mode
In "Envelope Voltage Adaptation > Manual" mode, set the parameter "Pre-Gain = PEP
= - 3.4 dB".
The displayed shaping function resembles the shaping function in "Auto Normalized"
mode; the same formulas apply, too.

You can also query the VCC values for any specified x in the supported voltage adapta-
tion mode and units.
See [:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:VCC:VALue?
on page 90.

About the envelope tracking
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Additional information

The described principle applies for any shaping function.

Only if linear shaping is used, the VCCNorm can also be directly converted to VCCPow
according to the following formula:

fPow(x) = [fNorm(x) - Vin,min/Vin,max]*[(Vcc,max - Vcc,min)/(1 - Vin,min/Vin,max)]

For example, if fNorm(x) = VCCNorm = 0.178 V, fPow(x) = VccPow0 is:

VccPow0 = [0.178 - 0.0071/0.2236]*[(1 - 0)/(1 - 0.0071/0.2236)]

VccPow0 = 0.151 V

2.3  General RF envelope settings

Access:

1. In the block diagram, select the "I/Q OUT" connector to unfold the "I/Q Analog"
block.

2. Select "I/Q Analog > I/Q Analog Settings > General".

3. Select "RF Envelope > On".

Figure 2-3: RF Envelope Settings (Example)

General RF envelope settings
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1 = Termination and input impedance of the circuit board
2 = Voltage level measured at the circuit board
3 = Signal characteristics of the DC Modulator
4 = Signal characteristics at the inputs of the PA (see the documentation of the PA, for example its data

sheet)

The remote commands required to define these settings are described in Chap-
ter 6.2, "SOURce:IQ:OUTPut:ENVelope commands", on page 81.

Settings:

State..............................................................................................................................22
Set to Default................................................................................................................ 22
Save/Recall................................................................................................................... 23
RF Envelope................................................................................................................. 23
Envelope Voltage Adaptation........................................................................................ 23
eTrak® Interface Type....................................................................................................24
I/Q Output Type.............................................................................................................24
Envelope Voltage Reference.........................................................................................24
VoutMin/Max...................................................................................................................24
Bias............................................................................................................................... 25
DC Modulator characteristics........................................................................................ 25

└ EMF................................................................................................................ 25
└ Rin................................................................................................................... 26
└ Termination..................................................................................................... 26
└ Bipolar Input....................................................................................................26
└ VppMax............................................................................................................ 27
└ Gain................................................................................................................ 27
└ VccOffset..........................................................................................................27

PA characteristics..........................................................................................................28
└ VccMin/Max......................................................................................................28
└ Power Offset................................................................................................... 29
└ PEPinMin/Max................................................................................................. 29

State
Enables/disables the analog I/Q output.
Note: By default, these output connectors are deactivated.
Remote command: 
[:SOURce<hw>]:IQ:OUTPut:ANALog:STATe on page 79

Set to Default
Calls the default settings. The values of the main parameters are listed in the following
table.

Parameter Value

"State" Not affected by the "Set to Default"

"RF Envelope" Off

General RF envelope settings
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Parameter Value

"I/Q Output Type" Depends on "System Configuration > External RF and I/Q > Preset behavior:
Keep connections to external instruments":
● "Off": Single Ended
● "On": Not affected by the "Set to Default"

"I/Q Level Vp (EMF)" 1 V

"Bias (EMF)" 0 mV

Remote command: 
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:PRESet on page 79

Save/Recall
Accesses the "Save/Recall" dialog, that is the standard instrument function for saving
and recalling the complete dialog-related settings in a file. The provided navigation
possibilities in the dialog are self-explanatory.
The settings are saved in a file with predefined extension. You can define the filename
and the directory, in that you want to save the file.
See also, chapter "File and Data Management" in the R&S SMM100A user manual.
Remote command: 
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:SETTing:CATalog? on page 79
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:SETTing:STORe on page 80
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:SETTing:LOAD on page 80
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:SETTing:DELete on page 80

RF Envelope
Enables the output of a control signal that follows the RF envelope. This control signal
is provided for power amplifiers envelope tracking testing. The signal is output at the I
out and I Bar out connectors.
Remote command: 
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:STATe on page 84

Envelope Voltage Adaptation
Defines the way you configure the voltage of the envelope tracking generator (see
Chapter 2.2.1, "Envelope voltage adaptation modes", on page 11).
"Auto Normalized"

Generation based on the physical characteristics of the power ampli-
fier; the power values are normalized based on the selected PEPin
Max value.
This mode enables you to use the complete range of a selected
detroughing function.
See also Shaping settings and compare the values on the X axis on
the graphical display.

"Auto Power" Generation based on the physical characteristics of the power ampli-
fier, where the input power of the PA "PEPin" is defined with its min
and max values.

General RF envelope settings
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"Manual" Generation, in that the operating range of the amplifier is defined
based on a pre-gain and a post-gain range.

Remote command: 
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:ADAPtion on page 84

eTrak® Interface Type
Selects one of the predefined interface types or allows user-defined settings.

See Chapter 2.2.2, "Signal parameters for testing according to the eTrak® specifica-
tion", on page 12.
Remote command: 
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:ETRak on page 85

I/Q Output Type
Selects the type of output signal.
The provided parameters in the "I/Q Analog Outputs" dialog depend on the selected
output mode.
"Single-Ended" ● If "RF Envelope > Off"

Single-ended output at the I/Q connectors.
● If "RF Envelope > On"

The envelope signal E is output at the I connectors.
You can define a bias between the output signal and ground.

"Differential" Option: R&S SMM-K17
● If "RF Envelope > Off"

The analog I/Q signal components are output at the I/Q and I/Q
Bar connectors.

● If "RF Envelope > On"
The inverted envelope signal Ē is output at the I Bar connectors.

Remote command: 
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:TYPE on page 80

Envelope Voltage Reference
Defines whether the envelope voltage Vout is set directly or it is estimated from the
selected supply voltage Vcc.

Remote command: 
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:VREF on page 85

VoutMin/Max
Displays the minimum and maximum values of the peak-to-peak voltage Vout voltage
on the interface between the circuit board and the DC modulator.
For "Envelope Voltage Reference" , sets the value of this parameter.
To measure the Vout voltage:
● Use a suitable probe, i.e. use a differential probe if a "Wire to Wire" termination is

used and a single ended probe otherwise
● Measure at the circuit board after the termination impedance Rin.

General RF envelope settings
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Estimated "VoutMin/Max" values are calculated based on the selected supply voltage
VccMin/Max, enabled Gain and VccOffset in the DC modulator.

Remote command: 
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:VOUT:MIN on page 86
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:VOUT:MAX on page 86

Bias
Sets a DC voltage, superimposed upon the envelope signal E and the inverted enve-
lope signal E Bar.
Use this parameter to define the operating point of a DUT.

"I/Q Output Type" Termination "Bias" defines

"Single Ended" - The bias between the envelope signal E and ground

"Differential" "To Ground" Superimposed DC voltage, where "Bias" is related to
the selected Rin.

See also Table 2-4

 "Wire To Wire" Superimposed DC voltage, where "Bias" is related to
high impedance (1 MΩ).

Table 2-4: Effect of enabled bias

Effect of a positive bias Effect of a negative bias

Remote command: 
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:BIAS on page 86

DC Modulator characteristics
Refer to the product documentation of the external DC modulator for information on its
characteristics.
The following settings are required:

EMF ← DC Modulator characteristics
Activates EMF, which defines whether the EMF or the voltage value is displayed.
An EMF-based calculation assumes an open-end circuit. Disable this parameter for
testing in more realistic conditions, where you define the input impedance of the used
external DC modulator Rin. The R&S SMM100A then calculates the envelope output
voltage VoutMin/Max based on it.

General RF envelope settings
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Remote command: 
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:EMF[:STATe] on page 87

Rin ← DC Modulator characteristics
If "EMF > Off", sets the input impedance Rin of the external DC modulator.

Remote command: 
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:RIN on page 87

Termination ← DC Modulator characteristics
If "I/Q Output Type > Differential" and "EMF > Off", defines the way the inputs of the
DC modulator are terminated.
The termination influences the way an enabled Bias is applied.

"To Ground" "Wire to Wire"

*) Bias = 0 and VccOffset = 0 *) Bias = 0 and VccOffset = 0

Both inputs of the DC modulator are terminated to
ground.

This termination is also referred as a common mode
voltage.

Remote command: 
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:TERMination on page 87

Bipolar Input ← DC Modulator characteristics
If "I/Q Output Type> Differential", enables the instrument to generate a bipolar signal.
The envelope signal E swings above and below the inverted envelope signal E Bar; the
R&S SMM100A calculates and applies a suitable envelope VccOffset automatically.

General RF envelope settings
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Figure 2-4: Effect of a "Bipolar Input > On"

This parameter influences the lower limit of the supply voltage Vcc.

The generated signal is conformed with the MIPI®Alliance specification "Specification
for Analog Reference Interface for Envelope Tracking".
Remote command: 
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:BINPut on page 88

VppMax ← DC Modulator characteristics
Sets the maximum value of the peak-to-peak driving voltage Vpp of the external DC
modulator.
The Vpp limits:
● The value range of the supply voltage VccMin/Max

Vpp ≥ VCCMax
● In "I/Q Output Type > Differential", the voltage of the generated envelope signal

VoutMin/Max as follows:
Vpp ≥ VoutMax[E] - VoutMax[E Bar], where [E] and [E Bar] refer to the envelope sig-
nal and the inverted envelope signal.

Remote command: 
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:VPP[:MAX] on page 87

Gain ← DC Modulator characteristics
Sets the gain of the external DC modulator.
Remote command: 
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:GAIN on page 88

VccOffset ← DC Modulator characteristics
Applies a voltage offset on the supply voltage VccMin/Max, i.e. compensates a possible
offset from the external DC modulator. Reduces the envelope output voltage
VoutMin/Max by this value to maintain the supply voltage Vcc in the defined value range.

General RF envelope settings
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Figure 2-5: Effect of a Vcc offset

Remote command: 
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:VCC:OFFSet on page 88

PA characteristics
Refer to the product documentation of the power amplifier (PA) for information on its
characteristics.
The following settings are required:

VccMin/Max ← PA characteristics
Displays the minimum and maximum values of the supply voltage Vcc, as required by
the power amplifier (PA).
For "Envelope Voltage Reference > Vcc", sets the minimum and maximum values of
the supply voltage Vcc.

The value range of the supply voltage Vcc is determined by the allowed peak-to-peak
driving voltage Vpp of the external DC modulator and the enabled VccOffset.

VccMax ≤ VppMax

The Vcc is calculated as follows:

Vcc = Vout * Gain + Vcc Offset

Example: 
Envelope Voltage Reference = Vcc

VccOffset = 0 mV

VccMax = 1 V = 0 dBV

Gain = 3 dB
VccMax [dBV] - Gain [dB] = VoutMax or

VoutMax = 0 dBV - 3 dB = -3 dBV = 0.708 V

General RF envelope settings
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"Bipolar Input" Value range "VccMin"

"State > On" VccMin = - 0.5*VppMax

Note: Implemented as a VccOffset, see Effect of a "Bipolar
Input > On".

"State > Off" VccMin = 0 to VccMax

Remote command: 
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:VCC:MIN on page 89
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:VCC:MAX on page 89

Power Offset ← PA characteristics
Indicates an enabled power offset, for example to compensate power attenuation
because of cable lengths.
The displayed value is applied as level offset to the generated RF signal and considers
the following settings:
● "RF > RF Level > Level > Offset"
● "RF > RF Level > UCOR"
Remote command: 
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:POWer:OFFSet?
on page 91

PEPinMin/Max ← PA characteristics
Sets the minimum and maximum values of the input power PEPin, as required by the
power amplifier (PA).
The "PEPinMin/Max" parameters define the linear range of the PA. Refer to the product
documentation of the PA for information on the characteristics of the required input sig-
nal.
The value range corresponds to the value range of output level.
Remote command: 
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:PIN:MIN on page 90
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:PIN:MAX on page 90

2.4  Envelope settings

Access:

1. Enable the generation of envelope tracking signal.
See Chapter 2.3, "General RF envelope settings", on page 21.

2. Select "I/Q Analog Settings > Envelope Settings".

Envelope settings
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1 = Enabled Digital Predistortion
2 = Envelope detector, √[I(t)2+Q(t)2]; indication changes, depending on the Envelope Voltage

Adaptation
3a, 3b = (for "Envelope Voltage Adaptation > Manual") Pre-Gain/Post-Gain
4 = Shaping state and shaping function; gray background color = deactivated shaping
5 = Enabled Envelope to RF Delay
6 = Indicates the output connectors, depending on the I/Q Output Type

The dialog displays an interactive overview diagram of the ET processing chain.
The diagram displays information on shaping state, incl. current shaping method
and setting, like gains or delay.

Tip: Hotspots for quick access. The displayed blocks are hotspots. Select one of
them to access the related function.

The remote commands required to define these settings are described in Chapter 6.2,
"SOURce:IQ:OUTPut:ENVelope commands", on page 81.

Settings:

Envelope to RF Delay................................................................................................... 30
Calculate Envelope from Predistorted Signal................................................................31

Envelope to RF Delay
Sets the time delay of the generated envelope signal relative to the corresponding RF
signal. A positive value means that the envelope signal delays relative to the RF signal
and vice versa.

Envelope settings
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1

2a

2b

Figure 2-6: Effect of enabled positive RF delay

1 = RF signal
2a, 2b = Envelope signal E and inverted envelope signal E BAR

Use this parameter to compensate possible timing delays caused by connected cables
and align the input signals at the PA to prevent unwanted effects, like memory effects
or decreased linearity.
Remote command: 
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:DELay on page 85

Calculate Envelope from Predistorted Signal
Option: R&S SMM100A-K541
Enables the calculation of the envelope signal from the original baseband signal or
from the AM/AM and/or AM/FM predistorted signal.
See also Chapter 3, "Applying digital predistortion", on page 46.
Remote command: 
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:FDPD on page 85

2.5  Shaping settings

Access:

1. Enable the generation of envelope tracking signal.

Shaping settings
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See Chapter 2.3, "General RF envelope settings", on page 21.

2. Enable "Envelope Voltage Adaptation > Auto Power/Normalized".

3. Select "I/Q Analog Outputs > Shaping".

Figure 2-7: Understanding the displayed information ("Envelope Voltage Adaptation > Auto
Power", "Shaping > Detroughing")

1a, 1b = Indicates the values of VccMin/Max
2a = Values smaller than PEPinMin are clipped.
2b = Values greater than PEPinMax are clipped.
3 = Operating point; corresponds to the RF RMS power level.
3a = Current RF RMS power level; an enabled "RF Level > Level Offset" is considered.
3b = Current VCC

4 = Crest factor of the generated signal
5a, 5b = The values correspond to the PEP of the generated RF signal and the VCC; shaded area indi-

cates the calculated Pre-Gain.
6 = Current envelope shape, defined by the detroughing function and detroughing factor

The settings allow the configuration of the shape of the RF envelope signal. The
instrument applies the settings and calculates the shaping function. A diagram vis-
ualizes the resulting envelope shape, as function of the selected supply voltage Vcc

and PEPin value limits, the calculated pre-gain and the estimated operating point of
the PA.
See also:
● Chapter 4, "How to generate a control signal for power amplifier envelope

tracking tests", on page 69.
● Chapter 2.2.3.6, "Converting shaping functions and understanding the dis-

played values", on page 16.

Shaping settings
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The remote commands required to define these settings are described in Chapter 6.2,
"SOURce:IQ:OUTPut:ENVelope commands", on page 81.

Settings:

Shaping......................................................................................................................... 33
Detroughing Function....................................................................................................37
Detroughing Factor (d).................................................................................................. 38
Couple Detroughing Factor with Vcc.............................................................................38
Exponent (a)..................................................................................................................38
Pre-Gain........................................................................................................................38
Post-Gain...................................................................................................................... 38
Polynomial Coefficients.................................................................................................39
Shaping Table............................................................................................................... 39
Interpolation.................................................................................................................. 39
Graphic Configuration................................................................................................... 40

└ Scale...............................................................................................................40
└ Diagram.......................................................................................................... 40

Shaping
Enables envelope shaping and selects the method to define the shaping function.
For detailed information on the shaping functions, see:
● Chapter 2.2.3, "Envelope shaping and shaping methods", on page 12
● Chapter 2.2.3.6, "Converting shaping functions and understanding the displayed

values", on page 16.

Shaping settings
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"Off" Envelope shaping is not adopted.
Previously configured values of the parameters Pre-Gain and Post-
Gain are ignored.

1

2a

2b

Figure 2-8: Generated RF, envelope and inverted envelope signal

1 = RF signal (simple ramp function)
2a, 2b = Envelope signal E and inverted envelope signal E Bar

"Linear (Voltage)/Linear (Power)"
The shaping function is a simple linear function.
The linear shaping is not used in practice but can be used for less
demanding applications, simple analysis, and the first interactions by
designing the optimum envelope shape. For "Envelope Voltage Adap-
tion > Manual", this function is suitable to determine the "Pre-/Post-
Gain" values, because the shaping gain of the linear function is 0 dB.

Shaping settings
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"Polynomial" The shaping function is defined by a polynomial with configurable
order and coefficients.
Select Polynomial coefficients settings to access the settings.

1

2a

2b

Figure 2-9: Effect of a polynomial shaping on the envelope and inverted envelope
signal

1 = RF signal (simple ramp function)
2a, 2b = Envelope signal E and inverted envelope signal E Bar

Shaping settings
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"From Table" The shaping function is defined by user-defined value pairs in form of
a shaping table.
This shaping function is suitable if you have knowledge on or aim to
achieve an exact relation between the supply voltage and RF output
power. For example, by describing the transition region of a PA.
Select "Shaping Table" to access the settings.

1

2a

2b

Figure 2-10: Effect of a table shaping on the envelope and inverted envelope sig-
nal

1 = RF signal (simple ramp function)
2a, 2b = Envelope signal E and inverted envelope signal E Bar

Shaping settings
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"Detroughing" The shaping function applies a detroughing to prevent that the supply
voltage Vcc drops down to zero.
Use the "Detroughing Factor" to limit the supply voltage Vcc in the
low-power region.

1

2a

2b

Figure 2-11: Effect of a detroughing function on the envelope and inverted enve-
lope signal

1 = RF signal (simple ramp function)
2a, 2b = Envelope signal E and inverted envelope signal E Bar

Remote command: 
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:SHAPing:MODE on page 91

Detroughing Function
Selects the mathematical function describing the detroughing.
The following functions are available:
● f(x) = x + d*e-x/d

● f(x) = 1 - (1 - d)*cos(x*pi/2)
● f(x) = d + (1 - d)*xa

Where:
● x depends on the "Envelope Voltage Adaptation" mode, see Table 2-2
● d = Detroughing Factor (d)
● a = Exponent (a)
For more information, see Chapter 2.2.3.6, "Converting shaping functions and under-
standing the displayed values", on page 16.
Remote command: 
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:SHAPing:DETRoughing:
FUNCtion on page 94

Shaping settings
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Detroughing Factor (d)
For inactive coupling of the detroughing factor with Vcc, sets a start offset to limit the
supply voltage Vcc in the low-power region.

The detroughing factor also controls the shaping. "Detroughing Factor = 0" defines a
linear function.
See also "Couple Detroughing Factor with Vcc" on page 38.
Remote command: 
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:SHAPing:DETRoughing:
FACTor on page 95

Couple Detroughing Factor with Vcc
Enable this parameter to derive the detroughing factor (d) from the selected Vcc value.
This ensures that the minimum supply voltage Vcc does not drop under the specified
limits and the signal is not clipped.
The detroughing factor is calculated as follows:
d = VccMin/VccMax

Remote command: 
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:SHAPing:DETRoughing:
COUPling on page 95

Exponent (a)
For the third detroughing function, sets the exponent (a), see Detroughing Function.
Remote command: 
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:SHAPing:DETRoughing:
PEXPonent on page 95

Pre-Gain
For "Envelope Voltage Adaptation > Manual", sets a pre-gain (i.e. an attenuation) to
define the operating range of the power amplifier. The pre-gain can be used to define
and test only a specific (required) part of the operating range.
For "Envelope Voltage Adaptation > Auto", calculates the value automatically as follow-
ing:
"Pre-Gain" = "Pin max" - "RF Level" + "Crest Factor"
Remote command: 
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:SHAPing:GAIN:PRE
on page 92

Post-Gain
For "Envelope Voltage Adaption > Manual", sets a post-gain to compensate the attenu-
ation introduced by the pre-gain and the gain of the shaping function.
Remote command: 
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:SHAPing:GAIN:POST
on page 92

Shaping settings
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Polynomial Coefficients
For "Shaping > Polynomial", accesses a dialog to describe the envelope shape as a
polynomials function, see Chapter 2.7, "Polynomial coefficients settings", on page 43.

Shaping Table
For "Shaping > From Table", accesses the standard "Envelope Select" dialog with
functions to define a new shaping table file, select or edit an existing one.
The shaping table files are files with predefined extension and file format, see "File for-
mat of the shaping table file" on page 15.
You can create a shaping table externally or internally.
"Select" Selects and loads an existing file.
"New" Creates a file
"Edit" Access a standard built-in table editor, see Chapter 2.6, "Edit I/Q

envelope shape settings", on page 40.
Remote command: 
For "Envelope Voltage Adaption > Manual":
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:SHAPing:FILE:CATalog?
on page 92
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:SHAPing:FILE[:SELect]
on page 92
For "Envelope Voltage Adaption > Auto":
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:SHAPing:PV:FILE:
CATalog? on page 92
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:SHAPing:PV:FILE[:
SELect] on page 92

Interpolation
For "Shaping > From Table", enables a linear interpolation between limited number of
defined value pairs in the table, to prevent abrupt changes.
Table 2-5: Effect of parameter "Interpolation"

"Interpolation > Off" "Interpolation > Linear Voltage"

Remote command: 
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:SHAPing:INTerp
on page 93

Shaping settings
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Graphic Configuration
Comprises settings to configure the graphical display.

Scale ← Graphic Configuration
Determines the units, "Voltage" or "Power", used on the x and y axis.
Table 2-6: Units on the x axis

"Envelope Voltage Adaption" "Scale > Power" "Scale > Voltage"

Auto Power Pin [dBm] Vin [V] = √Pin

Auto Normalized Pin/Pmax Vin/Vmax

Remote command: 
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:SHAPing:SCALe
on page 91

Diagram ← Graphic Configuration
Visualizes the resulting envelope shape, as function of the selected supply voltage Vcc

and PEPin value limits, the calculated pre-gain and the estimated operating point of the
PA.
See Figure 2-7.
Remote command: 
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:VCC:VALue:LEVel?
on page 89
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:VCC:VALue:PEP?
on page 89
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:VCC:VALue? on page 90

2.6  Edit I/Q envelope shape settings

The envelope shaping table is a method to define the shaping function.

Access:

1. Enable the generation of envelope tracking signal.
See Chapter 2.3, "General RF envelope settings", on page 21.

2. Select "Envelope Voltage Adaptation > Manual".

3. Select "Shaping Settings > Shaping > From Table".

4. Select "Shaping Table > New"

5. Enter the "File Name", e.g. MyLUT

The "Envelope Shaping File" dialog closes.
The "Shaping > Shaping Table" confirms that the newly created file is assigned.

6. Select "Shaping Table > MyLUT > Edit"

Edit I/Q envelope shape settings
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7. Define the value pairs "Vin/Vmax" and "Vcc/Vmax". The order is uncritical.

Figure 2-12: Shaping table in "Envelope Voltage Adaptation > Manual" mode

8. Select "Save".

The instrument loads the configured values automatically and displays the shaping
function.

9. Select "Shaping Settings > Interpolation > Linear (Voltage)".

The display confirms the used interpolation.

The remote commands required to define these settings are described in Chapter 6.2,
"SOURce:IQ:OUTPut:ENVelope commands", on page 81.

Settings:

Vin/Vmax, Vcc/Vmax/Power (dBm), Vcc (V).................................................................42
Fill Table Automatically..................................................................................................42
Goto, Edit, Save As, Save.............................................................................................42

Edit I/Q envelope shape settings



Generation of envelope tracking signalsR&S®SMM-K540/K541, R&S®SMM-K540/K541

42User Manual 1179.1970.02 ─ 06

Vin/Vmax, Vcc/Vmax/Power (dBm), Vcc (V)
Sets the normalized values of the value pairs.
"Vin/Vmax, Vcc/Vmax"

Value pairs in "Envelope Voltage Adaptation > Manual/Auto Normal-
ized" mode.

"Power(dBm), Vcc(V)"
Value pairs in "Envelope Voltage Adaptation > Auto Power" mode.

Remote command: 
n.a.

Fill Table Automatically
Standard function for filling a table automatically with user-defined values.

"From / Range"
Defines the start line and number of the rows to be filled.

"Select Column to Fill"
Selects the respective value, including the unit.

"Start / End Value"
Default values corresponding to the selected column.

"Increment" Determines the step size.
"Fill" Fills the table.

Fill both columns and then save the list. Otherwise the entries are
lost.

Goto, Edit, Save As, Save
Standard functions for editing of data lists.
Changed and unsaved values are displayed on a yellow background.
Remote command: 
n.a.

Edit I/Q envelope shape settings
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2.7  Polynomial coefficients settings

Access:

1. Enable the generation of envelope tracking signal.
See Chapter 2.3, "General RF envelope settings", on page 21.

2. Select "Envelope Voltage Adaptation > Auto Normalized".

3. Select "Shaping Settings > Shaping > Polynomial".

4. Select "Polynomial Coefficients".

Figure 2-13: Polynomial Coefficients: Understanding the displayed information

The polynomial function is an analytical method to describe a shaping function.
With the provided settings, you can define a polynomial function with up to 10th

order to describe the envelope shape.

5. Select "Polynomial Order = 2" (n = 2).

6. Set the constant a0 and the polynomial coefficients a1 and a2.

7. Select "Apply".

The instrument loads the configured values and displays the shaping function.

8. To store the defined shaping function:

a) Select "Save/Recall Polynomial"
b) Navigate throughout the file system.
c) Enter a "File Name", e.g. MyPolynomial_2thOrder
d) Select "OK".

9. Select "Polynomial Coefficients > OK" to close the dialog.

Polynomial coefficients settings
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The remote commands required to define these settings are described in Chapter 6.2,
"SOURce:IQ:OUTPut:ENVelope commands", on page 81.

Settings:

Save/Recall Polynomial................................................................................................ 44
Polynomial Order.......................................................................................................... 44
Polynomial constant and coefficients............................................................................ 44
Apply, OK...................................................................................................................... 44

Save/Recall Polynomial
Accesses the "Save/Recall" dialog, that is the standard instrument function for saving
and recalling the complete dialog-related settings in a file. The provided navigation
possibilities in the dialog are self-explanatory.
The settings are saved in a file with predefined extension. You can define the filename
and the directory, in that you want to save the file.
See also, chapter "File and Data Management" in the R&S SMM100A user manual.
The polynomial files are files with extension *.iq_poly, see "File format of the poly-
nomial function file" on page 15.
Remote command: 
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:SHAPing:COEFficients:
CATalog? on page 94
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:SHAPing:COEFficients:
STORe on page 94
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:SHAPing:COEFficients:
LOAD on page 94

Polynomial Order
Defines the polynomial order n, that is the number of polynomial coefficients (see
Chapter 2.2.3.3, "About the polynomial function", on page 14).
To confirm the settings, select "Apply".
Remote command: 
See [:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:SHAPing:
COEFficients on page 93.

Polynomial constant and coefficients
Sets the polynomial constant a0 and the polynomial coefficients a1 to an.

The polynomial constant and coefficients influence the envelope shape.
Remote command: 
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:SHAPing:COEFficients
on page 93

Apply, OK
Triggers the instrument to adopt the selected function.
Use "OK" to apply the setting and exits the dialog.

Polynomial coefficients settings
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Remote command: 
See [:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:SHAPing:
COEFficients on page 93

Polynomial coefficients settings



Applying digital predistortionR&S®SMM-K540/K541, R&S®SMM-K540/K541

46User Manual 1179.1970.02 ─ 06

3  Applying digital predistortion
Digital predistortion (DPD) is a method to improve the efficiency of RF power amplifi-
ers. In the R&S SMM100A, the generated digital signal can be deliberately AM/AM and
AM/PM predistorted.

3.1  Required options

The equipment layout for digital predistortion includes:
● Base unit
● Option AM/AM AM/PM predistortion (R&S SMM-K541)
● Optional option envelope tracking (R&S SMM-K540)

3.2  About digital predistortion

Power amplifiers are an essential part of any telecommunication systems. While ampli-
fying the transmitted signal, power amplifiers sometimes also distort this signal and
change its amplitude and/or phase characteristics. Such distortions result in undesired
effects like spectrum regrowth, harmonic generation, intermodulation (IM) products, or
increased bit error rate.

The principle of the digital predistortion

To compensate for the distortions caused by the transmission system, the signal is
deliberately digitally predistorted. Digital predistortion (DPD) is a method to apply wan-
ted and well-defined predistortion on the transmitted signal. When this signal is ampli-
fied, the resulting signal features the identical characteristics, as the initial signal before
the predistortion.

Pout

Pin Pin

Pout

Pin Pout

a b c

signal DPD PA

Figure 3-1: Illustration of predistortion principle

DPD = Digital predistortion
PA = Power amplifier
a = Predistortion function
b = Characteristic of the power amplifier, for example the non-linear input power vs. output power

(AM/AM) function
c = Ideal linearized characteristic of the amplified signal

About digital predistortion
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Digital predistortion models

When testing power amplifiers, it is important to measure and analyze signal distor-
tions.

Of several known models, this implementation focuses on the following two types of
distortion:
● The AM/AM (amplitude-to-amplitude) distortion and
● The AM/PM (amplitude-to-phase) distortion.

An AM/AM representation is a standard method that shows the signal power level at
the input of the DUT against the power level at the output of the DUT. The default unit
for both axes is dBm but the AM/AM representation can also be normalized.

An AM/PM curve shows the phase difference in degrees (y-axis) for every input power
level (x-axis).

With option R&S SMM-K541, you can define both, an AM/AM and an AM/PM predistor-
tion and apply them separately or superimposed on each other on the generated digital
baseband signal.

If your instrument is equipped with the option R&S SMM-K540, you can also apply pre-
distortions on the generated envelope signal.

Refer to Chapter 2, "Generation of envelope tracking signals", on page 10 for more
information.

3.2.1  Defining the power level of the generated signal

You can define the level of the generated signal in one of the following ways:
● "Level Reference > Before DPD"

In this mode, the "Level" parameter in the status bar of the instrument defines the
signal level before the DPD is applied.
Signal with selected level is pre-distorted and depending on the selected AM/AM
and AM/PM functions, attenuated or boosted.
See Table 3-1.

● "Level Reference > After DPD"
In this mode, you define the resulting signal level. Based on this value and depend-
ing on current predistortion function, the R&S SMM100A calculates the level of the
signal to be pre-distorted.
The level calculation requires several interaction cycles; the number of iterations is
a trade-off between level accuracy and speed.
See "To perform manual iterations to achieve a desired resulting signal level after
the DPD" on page 74 for explanation of how the interactions are performed.

About digital predistortion
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Table 3-1: Difference between the level reference modes

"Level Reference > Before DPD" "Level Reference > After DPD"

1: "LevelIN = Level = -15 dBm", i.e. signal level before DPD

2: "PEPIN = PEP -3.43 dBm", i.e. PEP of the signal before DPD

3: "LevelOUT = -15.42 dBm", resulting signal level after DPD

4: "PEPOUT = -3.68 dBm", resulting PEP of the signal after DPD

1: "LevelOUT = Level = -15 dBm", i.e. signal level after DPD

2: "PEPOUT = PEP = -3.57 dBm", i.e. PEP of the signal after
DPD

3: "LevelIN = -15.43 dBm", calculated signal level before DPD

4: "PEPIN = -3.86 dBm", calculated of the signal before DPD

5: allowed maximum level error

6: maximum number of iterations used to achieve the required
level error

3.2.2  Defining the correction values

In the R&S SMM100A, you can select the way you define the predistortion function and
choose between:
● A polynomial function with up to 10 polynomial coefficients

(see Chapter 3.2.2.1, "Polynomial function", on page 48)
● A predistortion function defined as a look-up table

(see Chapter 3.2.2.2, "Shaping table", on page 49)
● A normalized data

(see Chapter 3.2.2.3, "Normalized data", on page 50)
● To set the correction values in raw format with a single remote control command

(see Chapter 3.2.2.4, "Predistortion function in raw data format", on page 51).

3.2.2.1  Polynomial function

The polynomial function is an analytical method to describe a predistortion function.
When using the polynomial function, you do not define the correction values (ΔPower
and ΔPhase) directly as it is in the look-up table. You describe the predistortion func-
tion and the R&S SMM100A derives the correction values out of it.

See Chapter 3.3.4, "Polynomial coefficients settings", on page 62.

This implementation uses a polynomial with complex coefficients defined as follows:

PDPD(x) = ∑[(an+j*bn)*xn],

About digital predistortion
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Where:
● n = "Polynomial Order" ≤ 10
● x = Pin/PinMax
● an and bn are user-defined coefficients, defined as Cartesian (polar) or cylindrical

coordinates.
In Cartesian coordinates system, the coefficients bn are expressed in degrees.

The R&S SMM100A calculates the AM/AM and AM/PM predistortion functions as fol-
lows:
● AM/AM(x) = abs[PDPD(x)]
● AM/PM(x) = tan-1{Im[PDPD(x)]/Re[PDPD(x)]}

A dedicated graphical display visualizes the resulting functions, see Figure 3-4.

The R&S SMM100A calculates the correction values (ΔAM/AM and ΔAM/PM func-
tions) as follows:
● ΔAM/AM(x) = AM/AM(x) - x = abs[PDPD(x)] -x
● ΔAM/PM(x) = AM/PM(x) = tan-1{Im[PDPD(x)]/Re[PDPD(x)]}

File format of the polynomial file

You can store a polynomial function in a file or even define the polynomial coefficients,
store them as a file and load this file into the instrument. The polynomial files are files
with the extension *.dpd_poly.

The file contains an optional header # Rohde & Schwarz - Digital
Predistortion Polynomial Coefficients # a0,b0, a1,b1, a2,b2, ...
and a list of comma-separated coefficient value pairs, stored in Cartesian coordinates.

For values above the selected Input Range (PEPin) From/To, the predistortion function
assumes a linear ratio of the input to output power.

Example: Polynomial function file content
# Rohde & Schwarz - Digital Predistortion Polynomial Coefficients
# a0,b0, a1,b1, a2,b2, ...
0,0,-0.25,0.2,0.6,-0.3,0.3,0.3,0.5,-0.4

3.2.2.2  Shaping table

In the R&S SMM100A, there are two ways to define the predistortion function in form of
a shaping table:
● Externally

Create a correction table file as a CSV file with Microsoft Excel, with a Notepad or
a similar tool. Save the file with the predefined extension, transfer and load it into
the instrument.
See also "File format of the correction table file" on page 50.

● Internally
Use the built-in editor table editor, see Chapter 3.3.3, "Edit predistortion table set-
tings", on page 60.

About digital predistortion
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File format of the correction table file

The correction table files are files with predefined extension and simple file format, see
Table 3-2.
Table 3-2: Shaping table files: format and extensions

Predistortion model File extension Header (optional)

AM/AM *.dpd_magn # Rohde & Schwarz - Digital AM/AM
Predistortion 
Table Pin[dBm],deltaPower[dB]

AM/PM *.dpd_phase # Rohde & Schwarz - Digital AM/PM
Predistortion 
Table Pin[dBm],deltaPhase[deg]x

The header is optional. The file content is a list of up to 4000 comma-separated value
pairs, describing the delta values for amplitude or phase related to the absolute input
power Pin. A new line indicator separates the pairs.

For values above the selected Input Range (PEPin) From/To, the predistortion function
assumes a linear ratio of the input to output power.

Example: Shaping table file content (*.dpd_magn file)
# Rohde & Schwarz - Digital AM/AM Predistortion Table
Pin[dBm],deltaPower[dBm]
-30,0.5
3,-0.01

3.2.2.3  Normalized data

In the R&S SMM100A, there are two ways to define the predistortion function as nor-
malized data:
● Externally

We recommend that you calculate the normalized correction data by a connected
R&S®FSW equipped with R&S®FSW-K18 power amplifier and envelope tracking
measurements option.
You can also create the correction table file as a CSV file with Microsoft Excel, with
a Notepad or a similar tool. Save the file with the predefined extension, transfer
and load it into the instrument.
See also "File format of the correction table file" on page 50.

● Internally
Use the built-in editor table editor, see Chapter 3.3.3, "Edit predistortion table set-
tings", on page 60.

File format of the normalized data

The normalized data files are files with predefined extension *.dpd_norm and simple
file format, see "File format of the normalized data" on page 50.

The file contains an optional header # Rohde & Schwarz - Digital
Predistortion Normalized Table Data # PinMax [dBm] # number of

About digital predistortion
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points # Vin/Vmax, deltaV/V, deltaPhase [deg], the values of the PinMax,
the number of the subsequent points and a list of comma-separated groups of three
values.

Example: Normalized data file content
# Rohde & Schwarz - Digital Predistortion Normalized Table Data
# PinMax [dBm]
# number of points
# Vin/Vmax, deltaV/V, deltaPhase [deg] 
10
4096
0,0,0
0.0002442,-0.00018246,0.28052
0.0004884,-0.00036487,0.28041
0.0007326,-0.00054723,0.2803
0.0009768,-0.00072954,0.28019
0.001221,-0.00091181,0.28008
0.0014652,-0.001094,0.27996
...

3.2.2.4  Predistortion function in raw data format

The predistortion values are defined directly, with a single remote control command:
● Define up to 4000 comma-separated value pairs, describing the absolute input

power Pin and the delta values for amplitude or phase (ΔPower and ΔPhase).
Example:
SOURce1:IQ:DPD:SHAPing:TABLe:AMAM:FILE:DATA -30.4,-5.2,
-25.1,-4.5, -18.5,-2.5, -10.5,-1
See:
– [:SOURce<hw>]:IQ:DPD:SHAPing:TABLe:AMAM:FILE:DATA

on page 107
– [:SOURce<hw>]:IQ:DPD:SHAPing:TABLe:AMPM:FILE:DATA

on page 107
– [:SOURce<hw>]:IQ:DPD:SHAPing:TABLe:AMAM:FILE:NEW on page 106
– [:SOURce<hw>]:IQ:DPD:SHAPing:TABLe:AMPM:FILE:NEW on page 106

● Define the absolute maximum input power Pinmax, the number of subsequent
points, and the normalized values Vin/Vmax, ΔV/V, ΔPhase [deg] as binary data.
See [:SOURce<hw>]:IQ:DPD:SHAPing:NORMalized:DATA on page 109.

3.2.3  Finding out the correction values

If you know the properties of the used power amplifier, you can calculate suitable cor-
rection values.

We assume that the characteristics of a power amplifier have been measured and that
the left graphic in the following table shows the AM/AM curve of this amplifier.

About digital predistortion
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Defining correction coefficients for an AM/AM predistortion
(example)

Resulting AM/AM predistortion function (example)

a = ideal characteristic; if the amplifier did not distort the signal,
the normalized magnitude would be a line

b = measured AM/AM curve; the normalized magnitude varies
as a function of input power

a = ideal characteristic

b = measured AM/AM curve

c = resulting AM/AM predistortion function, i.e. correction values
curve

d = ideal predistorted signal

The required correction coefficient ΔPower is the difference between the ideal and the
real normalized amplitude for one particular input power. To compensate for the nonli-
nearity and the deviation from the ideal line: select a negative correction value (-Δ) for
any input power where the real normalized amplitude is greater than the ideal one (1).
Logically, a positive correction value (+Δ) compensates for (i.e. boost) an amplitude
that is smaller than the ideal one (2).

Ideally, a signal predistorted with a suitable function (c) and then amplified by the par-
ticular PA would have a linear characteristic (a).

In the practice, however, you do not calculate the correction coefficients manually but
they are calculated automatically. A suitable solution is the R&S®FS-K130PC software
or the R&S®FSW-K18 power amplifier and envelope tracking measurements option,
see Chapter 5, "How to apply a DPD to improve the efficiency of RF PAs",
on page 73.

3.3  Digital predistortions AM/AM and AM/PM settings

You can add digital predistortion to the generated baseband signal and thus compen-
sate an amplitude and a phase distortion of the DUT, for example of the tested power
amplifier.

Digital predistortions AM/AM and AM/PM settings
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Access:

► Select "I/Q Mod > Digital Predistortion > AM/AM AM/PM".

The dialog covers the settings for digital predistortion, like select and enabling an
AM/AM and/or AM/PM predistortion, select the way the predistortion function is
defined and specify the correction values.

The remote commands required to define these settings are described in Chapter 6.3,
"SOURce:IQ:DPD subsystem", on page 96.

Settings:

3.3.1  General settings

State..............................................................................................................................53
Set to Default................................................................................................................ 54
Save/Recall................................................................................................................... 54
AM/AM First.................................................................................................................. 54
Level Reference............................................................................................................ 54
Maximum Output Level Error........................................................................................ 55
Maximum Number of Iterations..................................................................................... 55
Achieved Output Level Error......................................................................................... 55
Input/Output PEP, Level and Crest Factor.................................................................... 55
AM/AM and AM/PM State............................................................................................. 55

State
Enables/disables the generation of digital predistorted signals.
Remote command: 
[:SOURce<hw>]:IQ:DPD:STATe on page 99

Digital predistortions AM/AM and AM/PM settings
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Set to Default
Calls the default settings. The values of the main parameters are listed in the following
table.

Parameter Value

"State" Not affected by the "Set to Default"

"Level Reference" Before DPD

"AM/AM First" Off

"AM/PM, AM/AM" Off

Remote command: 
[:SOURce<hw>]:IQ:DPD:PRESet on page 99

Save/Recall
Accesses the "Save/Recall" dialog, that is the standard instrument function for saving
and recalling the complete dialog-related settings in a file. The provided navigation
possibilities in the dialog are self-explanatory.
The settings are saved in a file with predefined extension. You can define the filename
and the directory, in that you want to save the file.
See also, chapter "File and Data Management" in the R&S SMM100A user manual.
Remote command: 
[:SOURce<hw>]:IQ:DPD:SETTing:CATalog? on page 99
[:SOURce<hw>]:IQ:DPD:SETTing:STORe on page 100
[:SOURce<hw>]:IQ:DPD:SETTing:LOAD on page 100
[:SOURce]:IQ:DPD:SETTing:DELete on page 99

AM/AM First
Toggles the order the AM/AM and AM/PM predistortions are applied.
Remote command: 
[:SOURce<hw>]:IQ:DPD:AMFirst on page 103

Level Reference
Switches between dynamic and static adaptation of the range the selected DPD is
applied on.
"Before DPD/After DPD"

Selects dynamic range calculation and defines whether the selected
"Level" value corresponds to the signal level before or after the pre-
distortion, see Chapter 3.2.1, "Defining the power level of the gener-
ated signal", on page 47.

"Static DPD" Selects static (constant) range limits. To adjust the range, use the
parameter Pre-Gain.

Remote command: 
[:SOURce<hw>]:IQ:DPD:LREFerence on page 103

Digital predistortions AM/AM and AM/PM settings
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Maximum Output Level Error
For "Level Reference > After DPD", sets the allowed maximum error, see Chap-
ter 3.2.1, "Defining the power level of the generated signal", on page 47.
Remote command: 
[:SOURce<hw>]:IQ:DPD:OUTPut:ERRor:MAX on page 103

Maximum Number of Iterations
For "Level Reference > After DPD", sets the maximum number of performed iterations
to achieving the required Maximum Output Level Error.
See also Chapter 3.2.1, "Defining the power level of the generated signal", on page 47.
Remote command: 
[:SOURce<hw>]:IQ:DPD:OUTPut:ERRor:MAX on page 103

Achieved Output Level Error
Displays the resulting level error, see Chapter 3.2.1, "Defining the power level of the
generated signal", on page 47.
Remote command: 
[:SOURce<hw>]:IQ:DPD:OUTPut:ERRor? on page 103

Input/Output PEP, Level and Crest Factor
Displays the calculated values the before and after the DPD.
A value of -1000 indicates that the calculation is impossible or there are no measure-
ments results available.
Remote command: 
[:SOURce<hw>]:IQ:DPD:INPut:PEP? on page 104
[:SOURce<hw>]:IQ:DPD:INPut:LEVel? on page 104
[:SOURce<hw>]:IQ:DPD:INPut:CFACtor? on page 104
[:SOURce<hw>]:IQ:DPD:OUTPut:PEP? on page 104
[:SOURce<hw>]:IQ:DPD:OUTPut:LEVel? on page 104
[:SOURce<hw>]:IQ:DPD:OUTPut:CFACtor? on page 104

AM/AM and AM/PM State
Enables/disables the AM/AM and AM/PM digital predistortion.
If both predistortions are enabled simultaneously, the instrument applies the AM/AM
predistortion first and compensates the phase error of the PA afterwards.
Compare the displayed signal processing chain.
Remote command: 
[:SOURce<hw>]:IQ:DPD:AMAM:STATe on page 100
[:SOURce<hw>]:IQ:DPD:AMPM:STATe on page 100

3.3.2  Predistortion settings

Access:

1. Select "I/Q Mod > Digital Predistortion > AM/AM AM/PM > Predistortion Settings".

Digital predistortions AM/AM and AM/PM settings
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2. Select a shaping function, for example the shaping file form Example"Shaping
table file content (*.dpd_magn file)" on page 50.

Figure 3-2: Predistortion Settings > From Table: Understanding the displayed information

1a = Normalized value of the current RF RMS power level
2a = Normalized value of the current PEP of the generated RF signal
1b, 2b = Correction values
White dashed line = Ideal zero correction function; no correction is necessary.
Yellow curve = Predistortion function
3a, 3b = Input Range (PEPin) From/To
4 = Positive correction coefficients to compensate values below the ideal ones
5 = Values greater than the PEPin Max are ignored.

The dialog covers the settings for digital predistortion, like select and enabling an
AM/AM and/or AM/PM predistortion, select the way the predistortion function is
defined and specify the correction values.

Settings:

Shaping......................................................................................................................... 57
Interpolation.................................................................................................................. 57
Invert Correction Values................................................................................................57
Input Range (PEPin) From/To........................................................................................58
Pre-Gain........................................................................................................................58
Shaping Table............................................................................................................... 59
Polynomial Coefficients.................................................................................................59
Normalized Data........................................................................................................... 60
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Graphic Configuration................................................................................................... 60
└ Scale...............................................................................................................60
└ AM/AM and AM/PM Diagrams........................................................................60

Shaping
Selects the method to define the correction coefficients.
"From Table" As value pairs in form of a shaping table.

Select "AM/AM or AM/PM Shaping Table" to access the settings, see
Chapter 3.3.3, "Edit predistortion table settings", on page 60.

"Polynomial" By a polynomial with configurable order and coefficients.
Select "Polynomial Coefficients" to access the settings, see Chap-
ter 3.3.4, "Polynomial coefficients settings", on page 62.

"Normalized" As a normalized data.
Select "Normalized Data" to access the settings, see Chapter 3.3.5,
"Normalized data settings", on page 66.

Remote command: 
[:SOURce<hw>]:IQ:DPD:SHAPing:MODE on page 105

Interpolation
For "Shaping > From Table/Normalized", enables a linear interpolation between limited
number of defined value pairs in the table, to prevent abrupt changes.
Table 3-3: Effect of parameter Interpolation

"Interpolation > Off" "Interpolation > Linear (Power)"

Remote command: 
[:SOURce<hw>]:IQ:DPD:SHAPing:TABLe:INTerp on page 107

Invert Correction Values
Inverts the defined correction values.
Applies the exact invert predistortion coefficients without changing the defined predis-
tortion table.
This function is also useful to toggle between predistortions with corrections related to
the input power and to the output power.

Digital predistortions AM/AM and AM/PM settings
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Table 3-4: Effect of parameter Invert correction values

"Invert correction values > Off" "Invert correction values > On"

Remote command: 
[:SOURce<hw>]:IQ:DPD:SHAPing[:TABLe]:INVert on page 107

Input Range (PEPin) From/To
Defines the minimum and maximum input power PEPin.

If you apply digital predistortion on signals used for power amplifier tests with envelope
tracking, set the PEPinMax value to the maximum value of the input power PEPin Max,
as required by the power amplifier (PA).
Remote command: 
[:SOURce<hw>]:IQ:DPD:PIN:MIN on page 105
[:SOURce<hw>]:IQ:DPD:PIN:MAX on page 105

Pre-Gain
For "General > Level Reference > Static DPD", sets a pre-gain (i.e. an attenuation) to
define the range the DPD is applied in. The pre-gain can be used to define and test
only a specific (required) part of the operating range.
For "General > Level Reference > Before/After DPD", the range is limited by the cur-
rent PEP of the signal.
See Figure 3-2.
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1 = Pre-gain limits the effective range of the shaping function
2 = Values above this limit are ignored

Remote command: 
[:SOURce<hw>]:IQ:DPD:GAIN:PRE on page 105

Shaping Table
Accesses the standard "Predistortion Select" dialog with functions to define a new
shaping table file, select, or edit an existing one.
The shaping table files are files with predefined extension and file format, see "File for-
mat of the correction table file" on page 50.
You can create a shaping table externally or internally.
"Select" Selects and loads an existing file.
"New" Creates a file.
"Edit" Access a standard built-in table editor, see Chapter 3.3.3, "Edit pre-

distortion table settings", on page 60.
Remote command: 
For AM/AM distortions:
[:SOURce<hw>]:IQ:DPD:SHAPing:TABLe:AMAM:FILE:CATalog? on page 106
[:SOURce<hw>]:IQ:DPD:SHAPing:TABLe:AMAM:FILE[:SELect] on page 106
For AM/PM distortions:
[:SOURce<hw>]:IQ:DPD:SHAPing:TABLe:AMPM:FILE:CATalog? on page 106
[:SOURce<hw>]:IQ:DPD:SHAPing:TABLe:AMPM:FILE[:SELect] on page 106

Polynomial Coefficients
For "Shaping > Polynomial", accesses a dialog to describe the predistortion function as
a polynomial function, see Chapter 3.3.4, "Polynomial coefficients settings",
on page 62.
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Normalized Data
For "Shaping > Normalized", accesses a dialog to describe the predistortion function
as a normalized data, see Chapter 3.3.5, "Normalized data settings", on page 66.

Graphic Configuration
Comprises setting to configure the graphical display.

Scale ← Graphic Configuration
Determines the unit of the x-axis, "Voltage" or "Power".
Remote command: 
[:SOURce<hw>]:IQ:DPD:SCALe on page 106

AM/AM and AM/PM Diagrams ← Graphic Configuration
Visualize the resulting correction functions, as function of the selected PEPin value lim-
its.
See Figure 3-2.
Remote command: 
[:SOURce<hw>]:IQ:DPD:AMAM:VALue:LEVel? on page 101
[:SOURce<hw>]:IQ:DPD:AMAM:VALue:PEP? on page 101
[:SOURce<hw>]:IQ:DPD:AMAM:VALue? on page 100
[:SOURce<hw>]:IQ:DPD:AMPM:VALue:LEVel? on page 102
[:SOURce<hw>]:IQ:DPD:AMPM:VALue:PEP? on page 102
[:SOURce<hw>]:IQ:DPD:AMPM:VALue? on page 101

3.3.3  Edit predistortion table settings

The predistortion table is an internal editor where you define the correction values,
ΔPower and ΔPhase, in form of a look-up table.

Access:

1. Select "I/Q Mod > Digital Predistortion > AM/AM AM/PM > Predistortion Settings".

2. Select "Shaping > From Table".

3. Select "AM/AM > Shaping Table > Predistortion AM/AM Shaping File > New"

4. Enter the "File Name", e.g. My_DPD_AM-AM

The "Predistortion AM/AM Shaping File" dialog closes.
The "Shaping Table > My_DPD_AM-AM" confirms that the newly created file is
assigned.

5. Select "Shaping Table > Predistortion AM/AM Shaping File > Edit"

6. Define the value pairs "Pin/dBm" and "ΔPower/dB". The order is uncritical.

Digital predistortions AM/AM and AM/PM settings
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Figure 3-3: Example of an AM-AM predistortion table values

7. Select "Save".

The instrument loads the configured values automatically and displays the function
of the delta correction values.

8. Select "Predistortion Settings > Interpolation > Linear".

The display confirms the used interpolation.

Settings:

Pin (dBm), Delta Power (dB)/Pin (dBm), Delta Phase (deg).........................................61
Fill Table Automatically..................................................................................................61
Goto, Edit, Save As, Save.............................................................................................62

Pin (dBm), Delta Power (dB)/Pin (dBm), Delta Phase (deg)
Sets the correction value pairs.
"Pin, ΔPower"

Value pairs for the AM/AM predistortion
"Pin, ΔPhase"

Value pairs for the AM/PM predistortion
Remote command: 
See [:SOURce<hw>]:IQ:DPD:SHAPing:TABLe:AMAM:FILE[:SELect]
on page 106
and [:SOURce<hw>]:IQ:DPD:SHAPing:TABLe:AMPM:FILE[:SELect]
on page 106

Fill Table Automatically
Standard function for filling a table automatically with user-defined values.
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"From / Range"
Defines the start line and number of the rows to be filled.

"Select Column to Fill"
Selects the respective value, including the unit.

"Start / End Value"
Default values corresponding to the selected column.

"Increment" Determines the step size.
"Fill" Fills the table.

Fill both columns and then save the list. Otherwise the entries are
lost.

Goto, Edit, Save As, Save
Standard functions for editing of data lists.
Changed and unsaved values are displayed on a yellow background.
Remote command: 
n.a.

3.3.4  Polynomial coefficients settings

Alternatively to the look-up table, you can define the predistortion functions as a poly-
nomial function. The R&S SMM100A calculates the AM/AM and AM/PM predistortion
functions and the required correction coefficients out of the defined polynomial.

To access the polynomial coefficients setting and define a higher-order polyno-
mial

1. Select "I/Q Mod > Digital Predistortion > AM/AM AM/PM > Predistortion Settings".

2. Select "Shaping > Polynomial".

3. Select "AM/PM > Polynomial Coefficients".

Digital predistortions AM/AM and AM/PM settings
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Figure 3-4: Polynomial Coefficients: Understanding the displayed information

n = Polynomial order
a0, b0, ... = Polynomial coefficients
1 = Ideal AM/AM function (the normalized amplitude is a line).
2 = Resulting AM/AM predistortion function, calculated as AM/AM(x) = abs[PDPD(x)]
3 = Ideal AM/PM function (constant phase at 0 degrees)
4 = Resulting AM/PM predistortion function, calculated as AM/PM(x) = tan-1{Im[PDPD(x)]/

Re[PDPD(x)]}

With the provided settings, you can define a polynomial function with up to 10th

order to describe the predistortion function.
The graphical display updates on-the-fly and visualizes the resulting AM/AM and
AM/PM functions.

4. Select "Polynomial Order = 4" (n = 4).

5. Set the polynomial coefficients a0 to b4.
Use, for example, the values shown on Figure 3-4.

6. Select "Apply".

The instrument loads the configured values, calculates the correction values, and
displays the predistortion functions.

Digital predistortions AM/AM and AM/PM settings
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Figure 3-5: Predistortion Settings > Polynomial: Understanding the displayed information

1a = Current RF RMS power level
2a = Current PEP of the generated RF signal
1b, 2b = Correction values
White dashed line = Ideal zero function; no correction is necessary.
AM/AM yellow curve = AM/AM correction values, calculated as ΔAM/AM(x) = AM/AM(x) - x
AM/PM yellow curve = AM/PM correction values, calculated as ΔAM/PM(x) = AM/PM(x)
3a, 3b = X-axis scale, calculated from the Input Range (PEPin) From/To
4 = Negative correction coefficients
5 = Values greater than the PEPin Max are ignored.

7. To store the defined predistortion function:

a) Select "Save/Recall Polynomial"
b) Navigate throughout the file system.
c) Enter a "File Name", e.g. MyPolynomial_4thOrder
d) Select "OK".

8. Select "Polynomial Coefficients > OK" to close the dialog.

Settings:

Save/Recall Polynomial................................................................................................ 65
System Coordinates......................................................................................................65
Polynomial Order.......................................................................................................... 65
Apply, OK...................................................................................................................... 65
Polynomial coefficients..................................................................................................65
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Save/Recall Polynomial
Accesses the "Save/Recall" dialog, that is the standard instrument function for saving
and recalling the complete dialog-related settings in a file. The provided navigation
possibilities in the dialog are self-explanatory.
The settings are saved in a file with predefined extension. You can define the filename
and the directory, in that you want to save the file.
See also, chapter "File and Data Management" in the R&S SMM100A user manual.
The polynomial files are files with extension *.dpd_poly, see "File format of the poly-
nomial file" on page 49. The polynomial function is stored in Cartesian format.
Remote command: 
[:SOURce<hw>]:IQ:DPD:SHAPing:POLYnomial:COEFficients:CATalog?
on page 108
[:SOURce<hw>]:IQ:DPD:SHAPing:POLYnomial:COEFficients:LOAD
on page 108
[:SOURce<hw>]:IQ:DPD:SHAPing:POLYnomial:COEFficients:STORe
on page 109

System Coordinates
Defines whether the polynomial function is defined in Cylindrical (Polar) or in Cartesian
coordinates.
Remote command: 
n.a.

Polynomial Order
Defines the polynomial order n, that is the number of polynomial coefficients (see
Chapter 3.2.2.1, "Polynomial function", on page 48).
The polynomial order defines the degree, complexity, and the number of terms in the
polynomial function.
Remote command: 
See [:SOURce<hw>]:IQ:DPD:SHAPing:POLYnomial:COEFficients
on page 107.

Apply, OK
Triggers the instrument to adopt the selected function.
Use "OK" to apply the setting and exits the dialog.
Remote command: 
[:SOURce<hw>]:IQ:DPD:SHAPing:POLYnomial:COEFficients on page 107

Polynomial coefficients
Sets the polynomial coefficients a0 to an and b0 to bn.

In "System Coordinates > Cylindrical", the polynomial coefficients b0 to bn are
expressed in degrees.
Select "Apply" to confirm the settings.
Remote command: 
See "Apply, OK" on page 65.

Digital predistortions AM/AM and AM/PM settings



Applying digital predistortionR&S®SMM-K540/K541, R&S®SMM-K540/K541

66User Manual 1179.1970.02 ─ 06

3.3.5  Normalized data settings

The normalized data table is an internal editor where you define the correction values,
Vin/Vmax, ΔV/V and ΔPhase, in form of a table.

To access the internal editor

1. Select "I/Q Mod > Digital Predistortion > AM/AM AM/PM > Predistortion Settings".

2. Select "Shaping > Normalized Data".

3. Select "Normalized Data".

4. Enter the Pinmax.
Note: Enter the correction values in the required order. The value range of the sub-
sequent correction values adjusts automatically.

5. To store the setting in a file, select "Save/Recall Normalized Data > Save".
Enter a "File Name", e.g. My_DPD_Normalized.

Settings:

Save/Recall Normalized Data....................................................................................... 66
PinMax............................................................................................................................ 67
Vin/Vmax, Delta V/V, Delta Phase (deg)....................................................................... 67
Apply, OK...................................................................................................................... 67

Save/Recall Normalized Data
Accesses the "Save/Recall" dialog, that is the standard instrument function for saving
and recalling the complete dialog-related settings in a file. The provided navigation
possibilities in the dialog are self-explanatory.
The settings are saved in a file with predefined extension. You can define the filename
and the directory, in that you want to save the file.
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See also, chapter "File and Data Management" in the R&S SMM100A user manual.
The normalized data files are files with extension *.dpd_norm, see "File format of the
normalized data" on page 50.
Remote command: 
[:SOURce<hw>]:IQ:DPD:SHAPing:NORMalized:DATA:CATalog? on page 110
[:SOURce<hw>]:IQ:DPD:SHAPing:NORMalized:DATA:LOAD on page 110
[:SOURce<hw>]:IQ:DPD:SHAPing:NORMalized:DATA:STORe on page 110

PinMax

Sets the value of the maximum input power level.
Pinmax corresponds to a normalized input power of 1, that is the max. allowed value on
the x-axis.
Select "Apply" to confirm the settings.
Remote command: 
n.a.

Vin/Vmax, Delta V/V, Delta Phase (deg)
Sets the correction as a group of three values.
Select "Apply" to confirm the settings.
Remote command: 
See "Apply, OK" on page 67.

Apply, OK
Triggers the instrument to adopt the normalized data.
Use "OK" to apply the setting and exits the dialog.
Remote command: 
[:SOURce<hw>]:IQ:DPD:SHAPing:NORMalized:DATA on page 109

3.4  Compensating non-linear RF effects

The R&S SMM100A provides a built-in function for compensating of its own non-linear
RF effects caused by the amplifiers. If the function is enabled, the instrument uses the
digital predistortion function and applies automatically calculated AM/AM predistortion
values to the generated baseband signal.

The RF linearization and the "Digital Predistortions, AM/AM and AM/PM" cannot be
used simultaneously; activating the "Linearize RF" parameter disables the "Digital Pre-
distortions, AM/AM and AM/PM" settings.

To access the required settings:

1. Select "I/Q Mod > I/Q Modulator > General > Linearize RF".

Compensating non-linear RF effects
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2. Select "Adjust Linearization Current Frequency".

The R&S SMM100A calculates the required correction values for the selected RF
and the current generated signal.

Settings:

Linearize RF..................................................................................................................68
Adjust Linearization Current Frequency........................................................................68

Linearize RF
Option: R&S SMM-K541
Enables an automatic AM/AM predistortion of the non-linear RF chain.
During RF linearization, disables "Digital Predistortions AM/AM and AM/PM" settings.
Remote command: 
[:SOURce<hw>]:IQ:DPD:LRF:STATe on page 111

Adjust Linearization Current Frequency
Calculates the correction data for the currently selected frequency.
During RF linearization, disables "Digital Predistortions AM/AM and AM/PM" settings.
Remote command: 
[:SOURce<hw>]:IQ:DPD:LRF:ADJust? on page 111

Compensating non-linear RF effects
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4  How to generate a control signal for power
amplifier envelope tracking tests
Refer to Figure 2-1 for an example of a simplified test setup for power amplifier testing
with envelope tracking. The illustration is intended to explain the principle in general,
not all connections and required equipment are considered.

The R&S SMM100A in this setup is configured to generate an LTE RF signal with com-
plex modulation scheme and high peak to average power (PAPR), and the required
envelope signal. A polynomial shaping function is defined. The PA receives the RF
input signal and the dynamically adapted supply voltage. Ideally, the gain of the PA
should stay constant.

Required are the following values:
● Characteristics of the power amplifier: supply voltage VCC, the input power PEPin

● Characteristics of the external DC modulator: gain, peak-to-peak voltage VPP, input
impedance Rin

To configure the R&S SMM100A to generate the RF and RF envelope signal

1. Enable the R&S SMM100A to generate an EUTRA/LTE FDD DL signal.
Select "Baseband > EUTRA/LTE" and enable for example:

a) Select "Link Direction > Downlink"
b) Select "Test Model > E-TM1_1--5MHZ"
c) Enable "State > On"

2. Set "Frequency = 2.143 GHz" and "Level = -15 dB"

3. In the block diagram, select "I/Q Out > I/Q Analog > I/Q Analog Outputs > Gen-
eral":

a) Select "RF Envelope > On".
b) Select "Envelope Voltage Adaptation > Auto Power"
c) Select "I/Q Output Type > Differential"
d) Configure the settings as shown on Figure 2-3.
e) Select "I/Q Analog Outputs > Envelope Settings" and set for example "Enve-

lope to RF Delay = 10 ps"
f) Select "I/Q Analog Outputs > Shaping > Shape > Detroughing".
g) Set "Detroughing Function = 1: f(x) = x + d*e(-x/d)".
h) Set "Detroughing Factor (d) > Coupled with Vcc = On".
i) Select "Graphic Configuration > Scale > Power".
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1a, 1b = VCCmin = 0.5 V, VCCmax = 2.5 V
2a, 2b = Pinmin = -30 dBm, Pinmax = 0 dBm
3 = RF Level = -15 dBm (operating point)
3a, 3b = Current VCC = 0.612 V (operating point)
4 = Crest factor = 11.6 dB
5a = PEP = -3.4 dBm; current Pinmax limit
5b = Current VCC limit

4. Select "I/Q Analog Output > State > On"

5. Enable "RF > State > On".

6. Trigger the signal generation

7. Select "I/Q Out > I/Q Analog > I/Q Analog Outputs > General", enable "Power Off-
set = 1 dB" and compare the operating point.

The level display value in the status bar of the instrument shows "Level = -14 dBm"
and confirms that a "Level Offset = Power Offset = 1 dB" is enabled.

The instrument generates and outputs:
● An RF signal with the specified level and level offset
● An RF envelope signal that follows the power changes of the RF signal.
The envelope signal E is output at the I Out connector; the inverted envelope sig-
nal E BAR at the I Bar Out. The voltage of this envelope signal is automatically
adjusted so that the supply voltage stays within the specified limits.
To observe the impact of baseband signal and its crest factor on the generated
envelope signal, try out the following:
● Select "Baseband > Off" and compare the displayed envelope shape, in partic-

ular the shaded area.
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● Select "Baseband > On", enable "Baseband > EUTRA/LTE > Filter/Clipping/
ARB... > Clipping > State > On" and select "Clipping Level = 75%"

Possible extensions

Consider to extend the test setup as follows:
● To apply digital predistortion (DPD) on the baseband signal and compare the

behavior of the power amplifier (DUT)
See Chapter 5, "How to apply a DPD to improve the efficiency of RF PAs",
on page 73.

● To perform RF analysis, use the R&S®FSW
● To measure and evaluate the AM/AM and AM/PM distortions, use the R&S®FSW-

K18 Power Amplifier and Envelope Tracking Measurements.
● To observe the characteristics of the generated signal, use an oscilloscope, for

example R&S®RTO

How to optimize the signal to improve the linearity and efficiency of the power
amplifier

Refer to Figure 4-1 for an example of a simplified test setup for power amplifier testing
with envelope tracking and digital predistortion. The illustration is intended to explain
the principle in general, not all connections and required equipment are considered.

Figure 4-1: Simplified test setup for power amplifier envelope tracking tests with DPD

Use the following general guidelines:

1. Provide the output signal of the DUT to the R&S®FSW and measure the signal.
Suitable RF measurements are the ACLR and EVM characteristics of the signal.

2. In the R&S SMM100A, select "I/Q Analog Outputs > Envelope Settings" and vary
the "Envelope to RF Delay" to minimize the ACLR and EVM measured with the
R&S®FSW.

3. Change the shaping method and shaping function and measure the power ampli-
fier characteristics.

Did its linearity and efficiency improved?
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4. Use the R&S®FSW-K18 to evaluate the signal, calculate suitable predistortion val-
ues, and store the AM/AM and AM/PM tables.

5. Transfer the predistortion functions to R&S SMM100A and load them (select "I/Q
Mod > AM/AM AM/PM > Predistortion Settings").
See Chapter 5, "How to apply a DPD to improve the efficiency of RF PAs",
on page 73.

6. In the R&S®FSW, measure the power amplifier characteristics.

Did its linearity improved?
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5  How to apply a DPD to improve the effi-
ciency of RF PAs
Refer to Figure 5-1 for an example of a simplified test setup for power amplifier testing
with envelope tracking and digital predistortion. The illustration is intended to explain
the principle in general, not all the connections and required equipment are consid-
ered.

Figure 5-1: Simplified test setup for power amplifier envelope tracking tests with DPD

A real test setup comprises of the following equipment:
● R&S SMM100A to generate the RF signal, and to calculate and apply the DPD.

In test setups for envelope tracking tests, the R&S SMM100A also generates the
envelope tracking signal.

● R&S®FSW equipped with R&S®FSW-K18 Power Amplifier and Envelope Tracking
Measurements to:
– Measure and analyze the AM/AM and AM/PM predistortion
– Calculate the AM/AM and AM/PM correction tables
– Store and export the correction tables

● DUT, that is the power amplifier.
● Optional, R&S®RTO to monitor the generated envelope signal.

General steps for tests to improve the efficiency of RF power amplifiers

Consider the following general steps:

1. Enable the R&S SMM100A to generate a baseband signal. A suitable baseband
signal is a simple ramp function or, to minimize memory effects, a signal with small
bandwidth.

2. Compare the input waveform to the output of the power amplifier and determine
how the amplifier is distorting the signal.
The normalized AM/AM and AM/PM curves show the variation of the magnitude
and phase over the variation of the input power and thus provide a suitable repre-
sentation and good basis for analysis.
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3. A simple straightforward method to retrieve the DPD correction values is to "invert"
the curves, see Chapter 3.2.3, "Finding out the correction values", on page 51.
Use the R&S®FSW-K18 to retrieve the AM/AM and AM/PM correction values auto-
matically.

4. Use the retrieved correction values and define the predistortion functions.

5. Enable the AM/AM and AM/PM predistortion and predistort the original baseband
signal.
See "To configure the R&S SMM100A to predistort the baseband signal"
on page 74

6. Measure the behavior of the power amplifier, for example perform EVM and ACP
measurements or evaluate the AM/AM and AM/PM curves.

Does the output signal of the DUT have a better performance with regards to ACP
and/or EVM?

To configure the R&S SMM100A to predistort the baseband signal

1. Enable the R&S SMM100A to generate an EUTRA/LTE FDD DL signal.

2. Set "Frequency = 2.143 GHz" and "Level = -15 dB".

3. In the block diagram, select "I/Q Mod > Digital Predistortion > AM/AM, AM/PM",
and perform the following:

a) Select "Digital Predistortion AM/AM, AM/PM > Predistortion Settings" and
enable "Shaping > From Table".

b) Select "AM/AM Table > New", enter a file name, and select "AM/AM Table >
Edit".

c) Enter the correction values and select "Save".
See the example on Figure 3-3.

d) Adjust the AM/PM correction values in the same way.
e) Select "Interpolation > Liner (Power)".
f) Select "Digital Predistortion AM/AM, AM/PM > General".
g) Select "Maximum Input Power PEPIN Max > 3 dBm".
h) Select "AM/AM State > On", "AM/PM State > On" and "Predistortion State >

On".
i) Select "Level Reference > After DPD", "Maximum Output Level Error = 0.1 dB"

and "Maximum Number of Iterations = 3".

4. Enable "RF > State > On".

5. Trigger the signal generation

To perform manual iterations to achieve a desired resulting signal level after the
DPD

To explain the iteration principle, we assume that the R&S SMM100A has been config-
ured as described in "To configure the R&S SMM100A to predistort the baseband sig-
nal" on page 74 and the DPD uses an AM/AM predistortion function as shown on Fig-
ure 5-2.
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To achieve a signal level of -15 dB after the DPD, perform the following steps and obey
the rule:

Vary the "Level" with small steps.
Always start with small value and increase the "Level" at the subsequent iterations.

1. Select "Digital Predistortion AM/AM, AM/PM > General > Level reference > Before
DPD".

2. Calculate the ΔP_1.

Figure 5-2: Manual iterations on an example AM/AM predistortion function ("Input Range PEPin =
-17 dBm to -12 dBm"): Step#1

1 = current operating point: PIN = LevelIN_1 = -15 dBm
2 = first iteration with LevelIN_2

a = ΔP_1

b = difference between the correction values at the current and the new operating points

● LevelIN_1 = Level = -15 dBm
● LevelOUT_1 = -15.42 dBm
● ΔP_1 = Level - LevelOUT_1 = -15 + 15.42 = 0.42 dBm
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3. Set the "Level" = Level + ΔP_1 = -15.45 dBm.

The diagram displays the achieved output values; LevelOUT_2 = - 15.02 dBm.

4. Calculate the ΔP_2.

Figure 5-3: Manual iterations on an example AM/AM predistortion function ("Input Range PEPin =
-17 dBm to -12 dBm"): Step#2

1 = initial operating point: PIN = LevelIN_1 = -15 dBm
2 = current operating point: PIN = LevelIN_2 = -15.45 dBm
3 = second iteration with LevelIN_3

a = ΔP_2

b = difference between the correction values at the current and the new operating points

● LevelIN_2 = - 15.55
● LevelOUT_2 = -15.02 dBm
● ΔP_2 = Level - LevelOUT_2 = -15 + 15.02 = - 0.02 dBm

5. Set "Level" = Level + ΔP_2 = -15.43 dBm

The diagram confirms the achieved output value; LevelOUT_3 = - 15 dBm.
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6. Compare the operating point on the AM/AM functions.
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6  Remote-control commands
The following commands are required to perform signal generation in a remote envi-
ronment. We assume that the R&S SMM100A has already been set up for remote
operation in a network as described in the R&S SMM100A user manual. Knowledge
about the remote control operation and the SCPI command syntax is assumed.

Conventions used in SCPI command descriptions
For a description of the conventions used in the remote command descriptions, see
section "Remote Control Commands" in the R&S SMM100A user manual.

Common suffixes

The following common suffixes are used in remote commands:

Suffix Value range Description

SOURce<hw> 1 Available baseband signals

Programming examples

The corresponding sections of the same title provide simple programming examples for
the R&S SMM100A. The purpose of the examples is to present all commands for a
given task. In real applications, one would rather reduce the examples to an appropri-
ate subset of commands.

The programming examples have been tested with a software tool which provides an
environment for the development and execution of remote tests. To keep the examples
as simple as possible, only the "clean" SCPI syntax elements are reported. Non-exe-
cutable command lines (e.g. comments) start with two // characters.

At the beginning of the most remote control program, an instrument (p) reset is recom-
mended to set the R&S SMM100A to a definite state. The commands *RST and
SYSTem:PRESet are equivalent for this purpose. *CLS also resets the status registers
and clears the output buffer.

In all the examples, we assume that a remote PC is connected to the instrument, the
remote PC and the instrument are switched on, a connection between them is estab-
lished. We also assume that the security setting "System Config > Setup > Security >
SCPI over LAN" is enabled.

The following commands specific to the R&S SMM-K540/-K541 options are described
here:

● SOURce:IQ:OUTPut subsystem.............................................................................79
● SOURce:IQ:OUTPut:ENVelope commands............................................................81
● SOURce:IQ:DPD subsystem.................................................................................. 96
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6.1  SOURce:IQ:OUTPut subsystem

This section describes the commands of the output of an analog I/Q signal.

[:SOURce<hw>]:IQ:OUTPut:ANALog:STATe.......................................................................79
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:PRESet...................................................................79
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:SETTing:CATalog?................................................... 79
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:SETTing:STORe...................................................... 80
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:SETTing:LOAD........................................................ 80
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:SETTing:DELete...................................................... 80
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:TYPE......................................................................80

[:SOURce<hw>]:IQ:OUTPut:ANALog:STATe <State>

Activates the specified analog I/Q output.

Note: Interdependencies

The following functions cannot be activated simultaneously. They deactivate each
other.
● The internal baseband generator ([:SOURce<hw>]:BB:<DigStd>:STATe) and

the external digital baseband input ([:SOURce<hw>]:BBIN:STATe)

Parameters:
<State> 1 | ON | 0 | OFF

*RST: 0

Example: SOURce:IQ:OUTPut:ANALog:STATe ON
Activates the output of the analog I/Q signal on the [I/Q Out 1]
connectors.

Manual operation: See "State" on page 22

[:SOURce<hw>]:IQ:OUTPut[:ANALog]:PRESet

Sets the default settings (*RST values specified for the commands).

Not affected are:
● The state set with the command [:SOURce<hw>]:IQ:OUTPut:ANALog:STATe.
● If SCONfiguration:EXTernal:PBEHaviour 1, the I/Q ouptput type set with

the command [:SOURce<hw>]:IQ:OUTPut[:ANALog]:TYPE.

Example: SOURce1:IQ:OUTPut:ANALog:PRESet
Usage: Event

Manual operation: See "Set to Default" on page 22

[:SOURce<hw>]:IQ:OUTPut[:ANALog]:SETTing:CATalog?

Queries the files with I/Q output settings in the default directory. Listed are files with the
file extension *.iqout.

SOURce:IQ:OUTPut subsystem
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Return values: 
<Catalog> string

Usage: Query only

Manual operation: See "Save/Recall" on page 23

[:SOURce<hw>]:IQ:OUTPut[:ANALog]:SETTing:STORe <Filename>

Stores the current settings into the selected file; the file extension (*.iqout) is
assigned automatically.

Setting parameters: 
<Filename> "<filename>"

Filename or complete file path

Usage: Setting only

Manual operation: See "Save/Recall" on page 23

[:SOURce<hw>]:IQ:OUTPut[:ANALog]:SETTing:LOAD <Filename>

Loads the selected file from the default or the specified directory. Loaded are files with
extension *.iqout.

Setting parameters: 
<Filename> "<filename>"

Filename or complete file path

Usage: Setting only

Manual operation: See "Save/Recall" on page 23

[:SOURce<hw>]:IQ:OUTPut[:ANALog]:SETTing:DELete <Filename>

Deletes the selected file from the default or specified directory. Deleted are files with
the file extension *.iqout.

Setting parameters: 
<Filename> "<filename>"

Filename or complete file path

Usage: Setting only

Manual operation: See "Save/Recall" on page 23

[:SOURce<hw>]:IQ:OUTPut[:ANALog]:TYPE <Type>

Sets the type of the analog signal.

Example: SOURce1:IQ:OUTPup:ANALog:TYPE DIFFerential
Options: DIFFerential requires R&S SMM-K17

SOURce:IQ:OUTPut subsystem
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Manual operation: See "I/Q Output Type" on page 24

6.2  SOURce:IQ:OUTPut:ENVelope commands

The following remote control commands require software option R&S SMM100A-K540.

Example: Generating an RF envelope signal and defining the shaping function
// define the RF level and frequency
SOURce1:FREQuency:CW 2143000000
SOURce1:POWer:LEVel:IMMediate:AMPLitude -15
SOURce1:POWer:LEVel:IMMediate:OFFSet 0.5
SOURce1:CORRection:VALue?
// Response: 1

// enable RF envelope generation and define the settings
SOURce1:IQ:OUTPut:ANALog:ENVelope:STATe 1
SOURce1:IQ:OUTPut:ANALog:ENVelope:ADAPtion AUTO
SOURce1:IQ:OUTPut:ANALog:TYPE DIFF
SOURce1:IQ:OUTPut:ANALog:ENVelope:ETRak USER
SOURce1:IQ:OUTPut:ANALog:ENVelope:VREF VCC
SOURce1:IQ:OUTPut:ANALog:ENVelope:POWer:OFFSet?
// Response: 1.5

SOURce1:IQ:OUTPut:ANALog:ENVelope:VPP:MAX 4
SOURce1:IQ:OUTPut:ANALog:ENVelope:GAIN 0
SOURce1:IQ:OUTPut:ANALog:ENVelope:EMF:STATe 1
SOURce1:IQ:OUTPut:ANALog:ENVelope:RIN 50
SOURce1:IQ:OUTPut:ANALog:ENVelope:TERMination GROund
SOURce1:IQ:OUTPut:ANALog:ENVelope:BINPut 1
SOURce1:IQ:OUTPut:ANALog:ENVelope:VCC:OFFSet 2

SOURce1:IQ:OUTPut:ANALog:ENVelope:VCC:MIN 0.5
SOURce1:IQ:OUTPut:ANALog:ENVelope:VCC:MAX 2.5

SOURce1:IQ:OUTPut:ANALog:ENVelope:BIAS 0
SOURce1:IQ:OUTPut:ANALog:ENVelope:OFFSet -2
SOURce1:IQ:OUTPut:ANALog:ENVelope:VOUT:MAX?
// Response: 0.5
SOURce1:IQ:OUTPut:ANALog:ENVelope:VOUT:MIN?
// Response: -1.5

SOURce1:IQ:OUTPut:ANALog:ENVelope:PIN:MIN -30
SOURce1:IQ:OUTPut:ANALog:ENVelope:PIN:MAX 0

SOURce1:IQ:OUTPut:ANALog:ENVelope:DELay 0.00000000001
SOURce1:IQ:OUTPut:ANALog:ENVelope:FDPD OFF

// enable envelope shaping
// SOURce1:IQ:OUTPut:ANALog:ENVelope:SHAPing:MODE DETR

SOURce:IQ:OUTPut:ENVelope commands
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// SOURce1:IQ:OUTPut:ANALog:ENVelope:SHAPing:DETRoughing:FUNCtion F3
// SOURce1:IQ:OUTPut:ANALog:ENVelope:SHAPing:DETRoughing:COUPling OFF
// SOURce1:IQ:OUTPut:ANALog:ENVelope:SHAPing:DETRoughing:FACtor 0.225
// SOURce1:IQ:OUTPut:ANALog:ENVelope:SHAPing:DETRoughing:PEXPonent 1

// quering the oprating point level, current PEP and levels
// SOURce1:IQ:OUTPut:ANALog:ENVelope:ADAPtion?
// Response: Auto
// SOURce1:IQ:OUTPut:ANALog:ENVelope:VCC:VALue:LEVel?
// Response: 0.927
// SOURce1:IQ:OUTPut:ANALog:ENVelope:VCC:VALue:PEP?
// Response: 1.922
// SOURce1:IQ:OUTPut:ANALog:ENVelope:VCC:VALue? 1,NORM,VOLT
// Response: 2.5
// SOURce1:IQ:OUTPut:ANALog:ENVelope:VCC:VALue? 0,NORM,VOLT
// Response: 0.563
// SOURce1:IQ:OUTPut:ANALog:ENVelope:PIN:MAX?
// Response: 0
// SOURce1:IQ:OUTPut:ANALog:ENVelope:PIN:MIN?
// response: -30
// SOURce1:IQ:OUTPut:ANALog:ENVelope:VCC:VALue? 0,DBM,POW
// Response: 2.5
// SOURce1:IQ:OUTPut:ANALog:ENVelope:VCC:VALue? -30,DBM,POW
// Response: 0.563

SOURce1:IQ:OUTPut:ANALog:ENVelope:SHAPing:MODE TABL
SOURce1:IQ:OUTPut:ANALog:ENVelope:SHAPing:PV:FILE:CATalog?
// Response: myLUT_pv
SOURce1:IQ:OUTPut:ANALog:ENVelope:SHAPing:PV:FILE:SELect "/var/user/myLUT_pv.iq_lutpv"
SOURce1:IQ:OUTPut:ANALog:ENVelope:SHAPing:INTerp LIN
SOURce1:IQ:OUTPut:ANALog:ENVelope:SHAPing:SCALe POWer

// change the envelope shaping mode
SOURce1:IQ:OUTPut:ANALog:ENVelope:SHAPing:MODE POLY
// query files with polynomial functions in the default user directory
SOURce1:IQ:OUTPut:ANALog:ENVelope:SHAPing:COEFficients:CATalog?
// Response: env_poly_evm,myPoly
SOURce1:IQ:OUTPut:ANALog:ENVelope:SHAPing:COEFficients:LOAD "myPoly"
SOURce1:IQ:OUTPut:ANALog:ENVelope:SHAPing:COEFficients?
// Response: 0.135,0.82
SOURce1:IQ:OUTPut:ANALog:ENVelope:SHAPing:COEFficients 0.135,0.83
SOURce1:IQ:OUTPut:ANALog:ENVelope:SHAPing:COEFficients:STORe "/var/user/myPoly.iq_poly"

// enable the outputs
SOURce1:IQ:OUTPut:ANALog:STATe 1
OUTPut1:STATe 1

// store the settings
MMEMory:CDIRectory "/var/user/setups"
SOURce1:IQ:OUTPut:ANALog:SETTings:CATalog? 

SOURce:IQ:OUTPut:ENVelope commands
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// Response: etrak_v1-2
SOURce1:IQ:OUTPut:ANALog:SETTings:STORe "my_ET"

SOURce1:IQ:OUTPut:ANALog:PREset
// change the envelope voltage adaptation mode
SOURce1:IQ:OUTPut:ANALog:ENVelope:ADAPtion MAN

SOURce1:IQ:OUTPut:LEVel 4

SOURce1:IQ:OUTPut:ANALog:ENVelope:SHAPing:GAIN:PRE -3
SOURce1:IQ:OUTPut:ANALog:ENVelope:SHAPing:GAIN:POST 2.5

// change the envelope shaping mode
SOURce1:IQ:OUTPut:ANALog:ENVelope:SHAPing:MODE TABL
SOURce1:IQ:OUTPut:ANALog:ENVelope:SHAPing:FILE:CATalog?
// Response: myLUT_vv
SOURce1:IQ:OUTPut:ANALog:ENVelope:SHAPing:FILE:SELect "/var/user/myLUT_vv.iq_lut"

// set the shaping values in raw format
// SOURce1:IQ:OUTPut[:ANALog]:ENVelope:SHAPing:FILE:DATA  0,0, 0.1,0.2, 1,1
// SOURce1:IQ:OUTPut[:ANALog]:ENVelope:SHAPing:FILE:CATalog?
// Response: myLUT_vv
// set the shaping values and store them into a file
// SOURce1:IQ:OUTPut[:ANALog]:ENVelope:SHAPing:FILE:NEW "LUT_vv_raw", 0,0, 0.1,0.2, 1,1.5
// SOURce1:IQ:OUTPut[:ANALog]:ENVelope:SHAPing:FILE:CATalog?
// Response: myLUT_vv, LUT_vv_raw

[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:STATe......................................................84
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:ADAPtion.................................................84
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:ETRak..................................................... 85
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:VREF...................................................... 85
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:DELay..................................................... 85
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:FDPD...................................................... 85
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:VOUT:MIN............................................... 86
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:VOUT:MAX.............................................. 86
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:BIAS........................................................86
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:OFFSet....................................................86
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:VPP[:MAX]...............................................87
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:EMF[:STATe]............................................ 87
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:RIN......................................................... 87
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:TERMination............................................ 87
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:BINPut.....................................................88
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:GAIN....................................................... 88
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:VCC:OFFSet............................................88
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:VCC:MIN................................................. 89
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:VCC:MAX................................................ 89
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:VCC:VALue:PEP?.....................................89
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:VCC:VALue:LEVel?...................................89
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:VCC:VALue?............................................90
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:PIN:MIN...................................................90
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:PIN:MAX..................................................90

SOURce:IQ:OUTPut:ENVelope commands
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[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:POWer:OFFSet?...................................... 91
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:SHAPing:MODE....................................... 91
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:SHAPing:SCALe.......................................91
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:SHAPing:GAIN:PRE................................. 92
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:SHAPing:GAIN:POST............................... 92
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:SHAPing:FILE:CATalog?........................... 92
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:SHAPing:PV:FILE:CATalog?...................... 92
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:SHAPing:FILE[:SELect].............................92
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:SHAPing:PV:FILE[:SELect]........................92
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:SHAPing:FILE:DATA................................. 93
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:SHAPing:PV:FILE:DATA............................93
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:SHAPing:FILE:NEW..................................93
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:SHAPing:PV:FILE:NEW.............................93
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:SHAPing:INTerp....................................... 93
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:SHAPing:COEFficients..............................93
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:SHAPing:COEFficients:CATalog?............... 94
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:SHAPing:COEFficients:STORe.................. 94
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:SHAPing:COEFficients:LOAD.................... 94
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:SHAPing:DETRoughing:FUNCtion............. 94
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:SHAPing:DETRoughing:COUPling............. 95
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:SHAPing:DETRoughing:FACTor.................95
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:SHAPing:DETRoughing:PEXPonent...........95

[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:STATe <State>

Enables the output of a control signal that follows the RF envelope.

Parameters:
<State> 1 | ON | 0 | OFF

*RST: 0

Example: See Example"Generating an RF envelope signal and defining
the shaping function" on page 81

Manual operation: See "RF Envelope" on page 23

[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:ADAPtion <AdaptionMode>

Defines the envelope voltage adaption mode.

Parameters:
<AdaptionMode> AUTO | MANual | POWer

AUTO = Auto Normalized, POWer = Auto Power, MANual = Man-
ual
*RST: AUTO

Example: See Example"Generating an RF envelope signal and defining
the shaping function" on page 81

Manual operation: See "Envelope Voltage Adaptation" on page 23

SOURce:IQ:OUTPut:ENVelope commands
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[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:ETRak <ETrakIfcType>

Selects one of the predefined interface types or allows user-defined settings.

See Table 2-1.

Parameters:
<ETrakIfcType> USER | ET1V2 | ET1V5 | ET2V0

*RST: USER

Example: SOURce1:IQ:OUTPut:ANALog:ENVelope:ETRak ET2V0
Manual operation: See "eTrak® Interface Type" on page 24

[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:VREF <VoltageReferenc>

Defines whether the envelope voltage Vout is set directly or it is estimated from the
selected supply voltage Vcc.

Parameters:
<VoltageReferenc> VCC | VOUT

*RST: VCC

Example: See Example"Generating an RF envelope signal and defining
the shaping function" on page 81

Manual operation: See "Envelope Voltage Reference" on page 24

[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:DELay <Delay>

Enables a time delay of the generated envelope signal relative to the corresponding
RF signal.

Parameters:
<Delay> float

Range: -500E-9  to  500E-9
Increment: 1E-12
*RST: 0

Example: See Example"Generating an RF envelope signal and defining
the shaping function" on page 81

Manual operation: See "Envelope to RF Delay" on page 30

[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:FDPD <CalcFromDpdStat>

Enables calculation of the envelope from predistorted signal.

Parameters:
<CalcFromDpdStat> 1 | ON | 0 | OFF

*RST: 0
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Example: See Example"Generating an RF envelope signal and defining
the shaping function" on page 81

Options: R&S SMM100A-K540/K541

Manual operation: See "Calculate Envelope from Predistorted Signal" on page 31

[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:VOUT:MIN <VoutMin>
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:VOUT:MAX <VoutMax>
Queries the minimum and maximum values of the estimated envelope output voltage
Vout.

Parameters:
<VoutMax> float

Range: 0.04  to  8
Increment: 1E-3
*RST: 1

Example: See Example"Generating an RF envelope signal and defining
the shaping function" on page 81

Manual operation: See "VoutMin/Max" on page 24

[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:BIAS <Bias>

Sets a bias.

Parameters:
<Bias> float

Range: -0.2V to 2.5V
Increment: 1E-4
*RST: 0
Default unit: V

Example: See Example"Generating an RF envelope signal and defining
the shaping function" on page 81.

Manual operation: See "Bias" on page 25

[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:OFFSet <Offset>

Sets an offset between the envelope and the inverted envelope signal.

Parameters:
<Offset> float

Range: -2V to 2V
Increment: 1E-4
*RST: 0
Default unit: V

Example: See Example"Generating an RF envelope signal and defining
the shaping function" on page 81.
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[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:VPP[:MAX] <VppMax>

Set the maximum value of the driving voltage Vpp of the used external DC modulator.

Parameters:
<VppMax> float

Range: -0.02V to 8V
Increment: 1E-3
*RST: 1
Default unit: V

Example: See Example"Generating an RF envelope signal and defining
the shaping function" on page 81.

Manual operation: See "VppMax" on page 27

[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:EMF[:STATe] <EmfState>

Defines whether the EMF or the voltage value is used.

Parameters:
<EmfState> 1 | ON | 0 | OFF

*RST: 1

Example: See Example"Generating an RF envelope signal and defining
the shaping function" on page 81

Manual operation: See "EMF" on page 25

[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:RIN <InputResistance>

Sets the input impedance Rin of the used external DC modulator.

Parameters:
<InputResistance> float

Range: 50|100  to  1E6
Increment: 0.1
*RST: 50

Example: See Example"Generating an RF envelope signal and defining
the shaping function" on page 81

Manual operation: See "Rin" on page 26

[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:TERMination <Termination>

Sets how the inputs of the DC modulator are terminated.

Parameters:
<Termination> GROund | WIRE

*RST: GROund
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Example: See Example"Generating an RF envelope signal and defining
the shaping function" on page 81

Manual operation: See "Termination" on page 26

[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:BINPut <BipolarInput>

Enables the generation of a bipolar signal.

Parameters:
<BipolarInput> 1 | ON | 0 | OFF

*RST: 0

Example: See Example"Generating an RF envelope signal and defining
the shaping function" on page 81

Manual operation: See "Bipolar Input" on page 26

[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:GAIN <Gain>

Sets the gain of the used external DC modulator.

Parameters:
<Gain> float

Range: -50  to  50
Increment: 0.01
*RST: 0

Example: See Example"Generating an RF envelope signal and defining
the shaping function" on page 81

Manual operation: See "Gain" on page 27

[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:VCC:OFFSet <VccOffset>

Applies a voltage offset on the supply voltage Vcc.

Parameters:
<VccOffset> float

Range: 0  to  30
Increment: 1E-3
*RST: 0
Default unit: mV

Example: See Example"Generating an RF envelope signal and defining
the shaping function" on page 81

Manual operation: See "VccOffset" on page 27
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[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:VCC:MIN <VccMin>
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:VCC:MAX <VccMax>
Sets the maximum value of the supply voltage Vcc.

Parameters:
<VccMax> float

Range: 0.04  to  8
Increment: 0.001
*RST: 1

Example: See Example"Generating an RF envelope signal and defining
the shaping function" on page 81

Manual operation: See "VccMin/Max" on page 28

[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:VCC:VALue:PEP?

Queries the Vcc value of the current PEP of the generated RF signal.

Return values: 
<VccForCrtPep> float

Range: 0  to  38
Increment: 1E-3
*RST: 0

Example: See Example"Generating an RF envelope signal and defining
the shaping function" on page 81

Usage: Query only

Manual operation: See "Diagram" on page 40

[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:VCC:VALue:LEVel?

Queries the Vcc value of the current RMS power level (operating point).

Return values: 
<VccForRfLevel> float

Range: 0  to  38
Increment: 1E-3
*RST: 0

Example: See Example"Generating an RF envelope signal and defining
the shaping function" on page 81

Usage: Query only

Manual operation: See "Diagram" on page 40
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[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:VCC:VALue? <xValue>, <xUnit>,
<xScale>

Queries the VCC value for the selected <xValue>.

Query parameters: 
<xValue> float

Value on the x-axis
Value range depends on the selected "Envelope Voltage Adap-
tation" and PEPinMin and PEPinMax values.

<xUnit> NORMalized | DBM | V
*RST: NORMalized

<xScale> VOLTage | POWer
*RST: VOLTage

Return values: 
<VccValue> float

Range: 0  to  38
Increment: 1E-3
*RST: 0

Example: See Example"Generating an RF envelope signal and defining
the shaping function" on page 81

Usage: Query only

Manual operation: See "Diagram" on page 40

[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:PIN:MIN <PinMin>

Sets the minimum value of the input power Pin.

Parameters:
<PinMin> float

Range: -145  to  20
Increment: 0.01
*RST: -30

Example: See Example"Generating an RF envelope signal and defining
the shaping function" on page 81

Manual operation: See "PEPinMin/Max" on page 29

[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:PIN:MAX <PinMax>

Sets the maximum value of the input power Pin.
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Parameters:
<PinMax> float

Range: -145  to  20
Increment: 0.01
*RST: -20

Example: See Example"Generating an RF envelope signal and defining
the shaping function" on page 81

Manual operation: See "PEPinMin/Max" on page 29

[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:POWer:OFFSet?

Queries the current power offset, that is the sum of enabled "RF Level > Offset" and
"User Correction".

Return values: 
<PowerOffset> float

Range: -200  to  200
Increment: 0.01
*RST: 0

Example: See Example"Generating an RF envelope signal and defining
the shaping function" on page 81

Usage: Query only

Manual operation: See "Power Offset" on page 29

[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:SHAPing:MODE <ShapingMode>

Enables envelope shaping and selects the method to define the shaping function.

Parameters:
<ShapingMode> OFF | LINear | TABLe | POLYnomial | DETRoughing | POWer

LINear = Linear (Voltage)
POWer = Linear (Power)
*RST: OFF

Example: See Example"Generating an RF envelope signal and defining
the shaping function" on page 81.

Manual operation: See "Shaping" on page 33

[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:SHAPing:SCALe <Scale>

Determines the units used on the x and y axis.

Parameters:
<Scale> POWer | VOLTage

*RST: VOLTage
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Example: See Example"Generating an RF envelope signal and defining
the shaping function" on page 81

Manual operation: See "Scale" on page 40

[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:SHAPing:GAIN:PRE <PreGain>
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:SHAPing:GAIN:POST

<PostGain>
Sets a post-gain.

Parameters:
<PostGain> float

Range: -3  to  20
Increment: 1E-2
*RST: 0

Example: See Example"Generating an RF envelope signal and defining
the shaping function" on page 81

Manual operation: See "Post-Gain" on page 38

[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:SHAPing:FILE:CATalog?
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:SHAPing:PV:FILE:CATalog?
Queries the available table shaping files in the default directory. Only files with the file
extension *.iq_lut or *.iq_lutpv are listed.

Return values: 
<Catalog> string

Example: See Example"Generating an RF envelope signal and defining
the shaping function" on page 81

Usage: Query only

Manual operation: See "Shaping Table" on page 39

[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:SHAPing:FILE[:SELect]
<Filename>

[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:SHAPing:PV:FILE[:SELect]
<Filename>

Selects an envelope shaping file (extension *.iq_lut or *.iq_lutpv).

Parameters:
<Filename> string

Example: See Example"Generating an RF envelope signal and defining
the shaping function" on page 81

Manual operation: See "Shaping Table" on page 39
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[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:SHAPing:FILE:DATA
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:SHAPing:PV:FILE:DATA
Defines the shaping function in a raw data format.

See also [:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:SHAPing:PV:
FILE:NEW on page 93.

Example: See Example"Generating an RF envelope signal and defining
the shaping function" on page 81

[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:SHAPing:FILE:NEW
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:SHAPing:PV:FILE:NEW
Stores the shaping values into a file with the selected file name and loads it.

The file is stored in the default directory or in the directory specified with the absolute
file path. If the file does not yet exist, a new file is created. The file extension is
assigned automatically.

Example: See Example"Generating an RF envelope signal and defining
the shaping function" on page 81

Usage: Setting only

[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:SHAPing:INTerp <Interpolation>

For envelope shaping with shaping tables, enables linear interpolation.

Parameters:
<Interpolation> OFF | LINear | POWer

LINear = Linear (Voltage)
POWer = Linear (Power)
*RST: OFF

Example: See Example"Generating an RF envelope signal and defining
the shaping function" on page 81

Manual operation: See "Interpolation" on page 39

[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:SHAPing:COEFficients

Sets the polynomial coefficients.

Example: See Example"Generating an RF envelope signal and defining
the shaping function" on page 81

Manual operation: See "Polynomial Order" on page 44
See "Polynomial constant and coefficients" on page 44
See "Apply, OK" on page 44
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[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:SHAPing:COEFficients:
CATalog?

Queries the available polynomial files in the default directory. Only files with the file
extension *.iq_poly are listed.

Return values: 
<Catalog> string

Example: See Example"Generating an RF envelope signal and defining
the shaping function" on page 81

Usage: Query only

Manual operation: See "Save/Recall Polynomial" on page 44

[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:SHAPing:COEFficients:STORe
<Filename>

Saves the polynomial function as polynomial file.

Setting parameters: 
<Filename> string

Example: See Example"Generating an RF envelope signal and defining
the shaping function" on page 81

Usage: Setting only

Manual operation: See "Save/Recall Polynomial" on page 44

[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:SHAPing:COEFficients:LOAD
<Filename>

Loads the selected polynomial file.

Setting parameters: 
<Filename> string

Example: See Example"Generating an RF envelope signal and defining
the shaping function" on page 81

Usage: Setting only

Manual operation: See "Save/Recall Polynomial" on page 44

[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:SHAPing:DETRoughing:
FUNCtion <DetrFunction>

Sets the detroughing function.

Parameters:
<DetrFunction> F1 | F2 | F3

*RST: F1
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Example: See Example"Generating an RF envelope signal and defining
the shaping function" on page 81

Manual operation: See "Detroughing Function" on page 37

[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:SHAPing:DETRoughing:
COUPling <CouplingState>

Enables/disables deriving the detroughing factor (d) from the selected Vcc value.

Parameters:
<CouplingState> 1 | ON | 0 | OFF

*RST: 0

Example: See Example"Generating an RF envelope signal and defining
the shaping function" on page 81

Manual operation: See "Couple Detroughing Factor with Vcc" on page 38

[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:SHAPing:DETRoughing:FACTor
<DetrFactor>

Sets the detroughing factor.

Parameters:
<DetrFactor> float

Range: 0  to  2
Increment: 1E-3
*RST: 0.2

Example: See Example"Generating an RF envelope signal and defining
the shaping function" on page 81

Manual operation: See "Detroughing Factor (d)" on page 38

[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:SHAPing:DETRoughing:
PEXPonent <PowerExponent>

Sets the exponent (a) for the detroughing function F3.

Parameters:
<PowerExponent> float

Range: 1  to  10
Increment: 1E-3
*RST: 2

Example: See Example"Generating an RF envelope signal and defining
the shaping function" on page 81

Manual operation: See "Exponent (a)" on page 38
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6.3  SOURce:IQ:DPD subsystem

The SOURce:IQ:DPD subsystem contains the commands for enabling and configuring
of digital predistortion.

Option: see Chapter 3.1, "Required options", on page 46.

Example: Defining correction coefficients and enabling digital predistortion
*RST

// enable LTE signal
SOURce1:BB:EUTRa:SETTing:TMOD:DL "E-TM1_1__5MHz"
SOURce1:BB:EUTRa:STATe 1

// define the RF level and frequency
SOURce1:FREQuency:CW 2143000000
SOURce1:POWer:LEVel:IMMediate:AMPLitude -15

SOURce1:IQ:DPD:PIN:MIN -35
SOURce1:IQ:DPD:PIN:MAX -2.5

// select look-up table files with correction values
SOURce1:IQ:DPD:SHAPing:MODE TABLe
SOURce1:IQ:DPD:SHAPing:TABLe:AMAM:FILE:CATalog?
// Response: My_DPD_AM-AM,MyDPD_AM-AM
SOURce1:IQ:DPD:SHAPing:TABLe:AMAM:FILE:SELect "My_DPD_AM-AM"
SOURce1:IQ:DPD:SHAPing:TABLe:AMPM:FILE:CATalog?
// Response: My_DPD_AM-PM,MyDPD_AM-PM
SOURce1:IQ:DPD:SHAPing:TABLe:AMPM:FILE:SELect "My_DPD_AM-PM"
SOURce1:IQ:DPD:SHAPing:TABLe:INTerp LINear
SOURce1:IQ:DPD:SHAPing:TABLe:INVert?
// Response: 0

// enable digital predistortion
SOURce1:IQ:DPD:AMPM:AMFirst 1
SOURce1:IQ:DPD:AMAM:STATe 1
SOURce1:IQ:DPD:AMPM:STATe 1
SOURce1:IQ:DPD:LREFerence BDPD
SOURce1:IQ:DPD:STATe 1

// enable the output
SOURce1:IQ:STATe 1
OUTPut1:STATe 1

// query the PEP, level and crest factor values before and after the DPD
SOURce1:IQ:DPD:INPut:PEP?
// Response: -3.43
SOURce1:IQ:DPD:INPut:LEVel?
// Response: -15
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SOURce1:IQ:DPD:INPut:CFACtor?
// Response: 11.57

SOURce1:IQ:DPD:OUTPut:PEP?
SOURce1:IQ:DPD:OUTPut:LEVel?
SOURce1:IQ:DPD:OUTPut:CFACtor?

// change level reference and 
// query the PEP, level and crest factor values before and after the DPD
SOURce1:IQ:DPD:LREFerence ADPD
SOURce1:IQ:DPD:OUTPut:ERRor:MAX 0.1
SOURce1:IQ:DPD:OUTPut:ITERations:MAX 3
SOURce1:IQ:DPD:MEASurement:STATe?
// Response: 1
SOURce1:IQ:DPD:OUTPut:ERRor?
// Response: 0
SOURce1:IQ:DPD:OUTPut:PEP?
// Response: -3.57
SOURce1:IQ:DPD:OUTPut:LEVel?
// Response: -15
SOURce1:IQ:DPD:OUTPut:CFACtor?
// Response: 11.43

// enable static DPD and set the pre-gain
SOURce1:IQ:DPD:LREFerence SDPD
SOURce1:IQ:DPD:GAIN:PRE -18
// set the predistorion values in raw format
SOURce1:IQ:DPD:SHAPing:TABLe:AMAM:FILE:DATA -30.4,-5.2, -25.1,-4.5, -18.5,-2.5, -10.5,-1
SOURce1:IQ:DPD:SHAPing:TABLe:AMPM:FILE:DATA -30.4, -5, -25.1, 5, -10, 0
SOURce1:IQ:DPD:SHAPing:TABLe:AMPM:FILE:CATalog?
// Response: My_DPD_AM-PM,MyDPD_AM-PM
// set the predistorion values and store them into a file
SOURce1:IQ:DPD:SHAPing:TABLe:AMPM:FILE:NEW "DPD_AM-PM_raw", -30.4, -5, -25.1, 5, -10, 0
SOURce1:IQ:DPD:SHAPing:TABLe:AMPM:FILE:CATalog?
// Response: My_DPD_AM-PM,MyDPD_AM-PM,DPD_AM-PM_raw
SOURce1:IQ:DPD:AMPM:VALue:PEP?
// Response: 4.255
SOURce1:IQ:DPD:AMPM:VALue:VALue? -30,DBM
// Response:-4.439

// change the shaping mode
SOURce1:IQ:DPD:SHAPing:MODE POLYnomial
// query files with polynomial functions in the default user directory
SOURce1:IQ:DPD:SHAPing:POLYnomial:COEFficients:CATalog?
// Response: MyDTD_Poly,myDTD_Poly4th
SOURce1:IQ:DPD:SHAPing:POLYnomial:COEFficients:LOAD "MyDTD_Poly4th"
SOURce1:IQ:DPD:SHAPing:POLYnomial:COEFficients?
// Response: 0,0,-0.25,0.2,0.6,-0.3,0.3,0.3,0.5,-0.4
SOURce1:IQ:DPD:SHAPing:POLYnomial:COEFficients:STORe "/var/user/myPoly.dpd_poly"
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Commands:

[:SOURce<hw>]:IQ:DPD:STATe.........................................................................................99
[:SOURce<hw>]:IQ:DPD:PRESet...................................................................................... 99
[:SOURce<hw>]:IQ:DPD:SETTing:CATalog?.......................................................................99
[:SOURce]:IQ:DPD:SETTing:DELete..................................................................................99
[:SOURce<hw>]:IQ:DPD:SETTing:LOAD..........................................................................100
[:SOURce<hw>]:IQ:DPD:SETTing:STORe........................................................................100
[:SOURce<hw>]:IQ:DPD:AMAM:STATe............................................................................ 100
[:SOURce<hw>]:IQ:DPD:AMPM:STATe............................................................................ 100
[:SOURce<hw>]:IQ:DPD:AMAM:VALue?..........................................................................100
[:SOURce<hw>]:IQ:DPD:AMAM:VALue:PEP?...................................................................101
[:SOURce<hw>]:IQ:DPD:AMAM:VALue:LEVel?.................................................................101
[:SOURce<hw>]:IQ:DPD:AMPM:VALue?..........................................................................101
[:SOURce<hw>]:IQ:DPD:AMPM:VALue:PEP?...................................................................102
[:SOURce<hw>]:IQ:DPD:AMPM:VALue:LEVel?.................................................................102
[:SOURce<hw>]:IQ:DPD:AMFirst.....................................................................................103
[:SOURce<hw>]:IQ:DPD:LREFerence..............................................................................103
[:SOURce<hw>]:IQ:DPD:OUTPut:ERRor?........................................................................103
[:SOURce<hw>]:IQ:DPD:OUTPut:ERRor:MAX..................................................................103
[:SOURce<hw>]:IQ:DPD:OUTPut:ITERations:MAX........................................................... 104
[:SOURce<hw>]:IQ:DPD:MEASurement:STATe?...............................................................104
[:SOURce<hw>]:IQ:DPD:INPut:CFACtor?.........................................................................104
[:SOURce<hw>]:IQ:DPD:OUTPut:CFACtor?..................................................................... 104
[:SOURce<hw>]:IQ:DPD:INPut:LEVel?.............................................................................104
[:SOURce<hw>]:IQ:DPD:OUTPut:LEVel?......................................................................... 104
[:SOURce<hw>]:IQ:DPD:INPut:PEP?...............................................................................104
[:SOURce<hw>]:IQ:DPD:OUTPut:PEP?........................................................................... 104
[:SOURce<hw>]:IQ:DPD:PIN:MIN....................................................................................105
[:SOURce<hw>]:IQ:DPD:PIN:MAX...................................................................................105
[:SOURce<hw>]:IQ:DPD:GAIN:PRE................................................................................ 105
[:SOURce<hw>]:IQ:DPD:SHAPing:MODE........................................................................ 105
[:SOURce<hw>]:IQ:DPD:SCALe......................................................................................106
[:SOURce<hw>]:IQ:DPD:SHAPing:TABLe:AMAM:FILE:CATalog?....................................... 106
[:SOURce<hw>]:IQ:DPD:SHAPing:TABLe:AMPM:FILE:CATalog?....................................... 106
[:SOURce<hw>]:IQ:DPD:SHAPing:TABLe:AMAM:FILE[:SELect].........................................106
[:SOURce<hw>]:IQ:DPD:SHAPing:TABLe:AMPM:FILE[:SELect].........................................106
[:SOURce<hw>]:IQ:DPD:SHAPing:TABLe:AMAM:FILE:NEW............................................. 106
[:SOURce<hw>]:IQ:DPD:SHAPing:TABLe:AMPM:FILE:NEW............................................. 106
[:SOURce<hw>]:IQ:DPD:SHAPing:TABLe:AMAM:FILE:DATA.............................................107
[:SOURce<hw>]:IQ:DPD:SHAPing:TABLe:AMPM:FILE:DATA.............................................107
[:SOURce<hw>]:IQ:DPD:SHAPing:TABLe:INTerp..............................................................107
[:SOURce<hw>]:IQ:DPD:SHAPing[:TABLe]:INVert............................................................ 107
[:SOURce<hw>]:IQ:DPD:SHAPing:POLYnomial:COEFficients............................................107
[:SOURce<hw>]:IQ:DPD:SHAPing:POLYnomial:COEFficients:CATalog?............................. 108
[:SOURce<hw>]:IQ:DPD:SHAPing:POLYnomial:COEFficients:LOAD.................................. 108
[:SOURce<hw>]:IQ:DPD:SHAPing:POLYnomial:COEFficients:STORe................................ 109
[:SOURce<hw>]:IQ:DPD:SHAPing:NORMalized:DATA...................................................... 109
[:SOURce<hw>]:IQ:DPD:SHAPing:NORMalized:DATA:CATalog?........................................ 110
[:SOURce<hw>]:IQ:DPD:SHAPing:NORMalized:DATA:LOAD.............................................110
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[:SOURce<hw>]:IQ:DPD:SHAPing:NORMalized:DATA:STORe........................................... 110
[:SOURce<hw>]:IQ:DPD:LRF:STATe................................................................................ 111
[:SOURce<hw>]:IQ:DPD:LRF:ADJust?............................................................................. 111

[:SOURce<hw>]:IQ:DPD:STATe <State>

Enabels/disables the generation of digitally pre-distorted signals.

Parameters:
<State> 1 | ON | 0 | OFF

*RST: 0

Example: See Example"Defining correction coefficients and enabling digi-
tal predistortion" on page 96

Manual operation: See "State" on page 53

[:SOURce<hw>]:IQ:DPD:PRESet

Sets the default DPD settings (*RST values specified for the commands).

Not affected is the state set with the command [:SOURce<hw>]:IQ:DPD:STATe.

Usage: Event

Manual operation: See "Set to Default" on page 54

[:SOURce<hw>]:IQ:DPD:SETTing:CATalog?

Queries the files with digital predistortion setting in the default directory. Listed are files
with the file extension *.dpd.

Return values: 
<Catalog> string

Usage: Query only

Manual operation: See "Save/Recall" on page 54

[:SOURce]:IQ:DPD:SETTing:DELete <Filename>

Deletes the selected file from the default or specified directory. Deleted are files with
the file extension *.dpd.

Setting parameters: 
<Filename> "<filename>"

Filename or complete file path

Usage: Setting only

Manual operation: See "Save/Recall" on page 54
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[:SOURce<hw>]:IQ:DPD:SETTing:LOAD <Filename>

Loads the selected file from the default or the specified directory. Loaded are files with
extension *.dpd.

Setting parameters: 
<Filename> "<filename>"

Filename or complete file path

Usage: Setting only

Manual operation: See "Save/Recall" on page 54

[:SOURce<hw>]:IQ:DPD:SETTing:STORe <Filename>

Stores the current settings into the selected file; the file extension (*.dpd) is assigned
automatically.

Setting parameters: 
<Filename> "<filename>"

Filename or complete file path

Usage: Setting only

Manual operation: See "Save/Recall" on page 54

[:SOURce<hw>]:IQ:DPD:AMAM:STATe <State>
[:SOURce<hw>]:IQ:DPD:AMPM:STATe <State>
Enabels/disables the AM/AM and AM/PM digital predistortion.

Parameters:
<State> 1 | ON | 0 | OFF

*RST: 0

Example: See Example"Defining correction coefficients and enabling digi-
tal predistortion" on page 96

Manual operation: See "AM/AM and AM/PM State" on page 55

[:SOURce<hw>]:IQ:DPD:AMAM:VALue? <XValue>, <XUnit>

Queries the delta power value of the generated RF signal for a selected <XValue>.

Query parameters: 
<XValue> float

Value on the x-axis.
Value range depends on the selected PEPinMin and PEPinMax
values.
Range: -100  to  100
Increment: 0.01

<XUnit> DBM | V
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Return values: 
<DeltaPower> float

Range: -20  to  20
Increment: 0.01
*RST: 0

Example: See Example"Defining correction coefficients and enabling digi-
tal predistortion" on page 96.

Usage: Query only

Manual operation: See "AM/AM and AM/PM Diagrams" on page 60

[:SOURce<hw>]:IQ:DPD:AMAM:VALue:PEP?

Queries the delta power value for the current peak envelope power (PEP) level of the
generated RF signal.

Return values: 
<DeltaPower> float

Range: -20  to  20
Increment: 0.01
*RST: 0

Example: See Example"Defining correction coefficients and enabling digi-
tal predistortion" on page 96.

Usage: Query only

Manual operation: See "AM/AM and AM/PM Diagrams" on page 60

[:SOURce<hw>]:IQ:DPD:AMAM:VALue:LEVel?

Queries the delta power value for the current root mean square (RMS) power level of
the generated RF signal.

Return values: 
<DeltaPower> float

Range: -20  to  20
Increment: 0.01
*RST: 0

Example: See Example"Defining correction coefficients and enabling digi-
tal predistortion" on page 96.

Usage: Query only

Manual operation: See "AM/AM and AM/PM Diagrams" on page 60

[:SOURce<hw>]:IQ:DPD:AMPM:VALue? <XValue>, <XUnit>

Queries the delta phase value of the generated RF signal for a selected <XValue>.
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Query parameters: 
<XValue> float

Value on the x-axis.
Value range depends on the selected PEPinMin and PEPinMax
values.
Range: -100  to  100
Increment: 0.01

<XUnit> DBM | V
*RST: DBM

Return values: 
<DeltaPhase> float

Range: -180  to  180
Increment: 0.01
*RST: 0

Example: See Example"Defining correction coefficients and enabling digi-
tal predistortion" on page 96.

Usage: Query only

Manual operation: See "AM/AM and AM/PM Diagrams" on page 60

[:SOURce<hw>]:IQ:DPD:AMPM:VALue:PEP?

Queries the delta phase value for the current peak envelope power (PEP) level of the
generated RF signal.

Return values: 
<DeltaPhase> float

Range: -180  to  180
Increment: 0.01
*RST: 0

Example: See Example"Defining correction coefficients and enabling digi-
tal predistortion" on page 96.

Usage: Query only

Manual operation: See "AM/AM and AM/PM Diagrams" on page 60

[:SOURce<hw>]:IQ:DPD:AMPM:VALue:LEVel?

Queries the delta phase value for the current root mean square (RMS) power level of
the generated RF signal.

Return values: 
<DeltaPhase> float

Range: -180  to  180
Increment: 0.01
*RST: 0
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Example: See Example"Defining correction coefficients and enabling digi-
tal predistortion" on page 96.

Usage: Query only

Manual operation: See "AM/AM and AM/PM Diagrams" on page 60

[:SOURce<hw>]:IQ:DPD:AMFirst <AmAmFirstState>

Sets that the AM/AM predistortion is applied before the AM/PM.

Parameters:
<AmAmFirstState> 1 | ON | 0 | OFF

*RST: 0

Example: See Example"Defining correction coefficients and enabling digi-
tal predistortion" on page 96

Manual operation: See "AM/AM First" on page 54

[:SOURce<hw>]:IQ:DPD:LREFerence <LevelReference>

Sets whether a dynamic (BDPD|ADPD) or a static (SDPS) adaptation of the range the
selected DPD is applied on.

Parameters:
<LevelReference> BDPD | ADPD | SDPD

*RST: BDPD

Example: See Example"Defining correction coefficients and enabling digi-
tal predistortion" on page 96

Manual operation: See "Level Reference" on page 54

[:SOURce<hw>]:IQ:DPD:OUTPut:ERRor?

Queries the resulting level error.

Return values: 
<AchievedError> float

Example: see Example"Defining correction coefficients and enabling digi-
tal predistortion" on page 96

Usage: Query only

Manual operation: See "Achieved Output Level Error" on page 55

[:SOURce<hw>]:IQ:DPD:OUTPut:ERRor:MAX <MaximumError>

Sets the allowed maximum error.
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Parameters:
<MaximumError> float

Range: 0.01  to  1
Increment: 0.01
*RST: 0.1

Example: see Example"Defining correction coefficients and enabling digi-
tal predistortion" on page 96

Manual operation: See "Maximum Output Level Error" on page 55
See "Maximum Number of Iterations" on page 55

[:SOURce<hw>]:IQ:DPD:OUTPut:ITERations:MAX <MaxIterations>

Sets the maximum number of performed iterations to achieving the required error set
with [:SOURce<hw>]:IQ:DPD:OUTPut:ERRor:MAX.

Parameters:
<MaxIterations> integer

Range: 1  to  10
*RST: 3

Example: See Example"Defining correction coefficients and enabling digi-
tal predistortion" on page 96

[:SOURce<hw>]:IQ:DPD:MEASurement:STATe?

Queries whether the interactions are competed.

Return values: 
<MeasureValidity> 1 | ON | 0 | OFF

*RST: 1

Example: See Example"Defining correction coefficients and enabling digi-
tal predistortion" on page 96

Usage: Query only

[:SOURce<hw>]:IQ:DPD:INPut:CFACtor?
[:SOURce<hw>]:IQ:DPD:OUTPut:CFACtor?
[:SOURce<hw>]:IQ:DPD:INPut:LEVel?
[:SOURce<hw>]:IQ:DPD:OUTPut:LEVel?
[:SOURce<hw>]:IQ:DPD:INPut:PEP?
[:SOURce<hw>]:IQ:DPD:OUTPut:PEP?
Queries the measured values the before and after the enabled digital predistortion.

Return values: 
<PEP> float

The query returns -1000 if the calculation is impossible or there
are no measurements results available.
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Example: see Example"Defining correction coefficients and enabling digi-
tal predistortion" on page 96

Usage: Query only

Manual operation: See "Input/Output PEP, Level and Crest Factor" on page 55

[:SOURce<hw>]:IQ:DPD:PIN:MIN <PepInMin>
[:SOURce<hw>]:IQ:DPD:PIN:MAX <PepInMax>
Sets the value range of the input power.

Parameters:
<PepInMax> float

Range: -145  to  20
Increment: 0.01
*RST: 10

Example: See Example"Defining correction coefficients and enabling digi-
tal predistortion" on page 96

Manual operation: See "Input Range (PEPin) From/To" on page 58

[:SOURce<hw>]:IQ:DPD:GAIN:PRE <PreGain>

Sets a pre-gain (i.e. an attenuation) to define the range the static DPD is applied in.

Parameters:
<PreGain> float

Range: -50  to  20
Increment: 1E-2
*RST: 0

Example: see Example"Defining correction coefficients and enabling digi-
tal predistortion" on page 96

Manual operation: See "Pre-Gain" on page 58

[:SOURce<hw>]:IQ:DPD:SHAPing:MODE <Shaping>

Selects the method to define the correction coefficients.

Parameters:
<Shaping> TABLe | POLYnomial | NORMalized

*RST: TABLe

Example: See Example"Defining correction coefficients and enabling digi-
tal predistortion" on page 96.

Manual operation: See "Shaping" on page 57
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[:SOURce<hw>]:IQ:DPD:SCALe <Scale>

Determines the units used on the x and y-axis.

Parameters:
<Scale> POWer | VOLTage

*RST: POWer

Manual operation: See "Scale" on page 60

[:SOURce<hw>]:IQ:DPD:SHAPing:TABLe:AMAM:FILE:CATalog?
[:SOURce<hw>]:IQ:DPD:SHAPing:TABLe:AMPM:FILE:CATalog?
Queries the available table files in the default directory. Only files with the extension
*.dpd_magn(AM/AM) or *.dpd_phase(AM/PM) are listed.

Return values: 
<Catalog> string

Example: See Example"Defining correction coefficients and enabling digi-
tal predistortion" on page 96

Usage: Query only

Manual operation: See "Shaping Table" on page 59

[:SOURce<hw>]:IQ:DPD:SHAPing:TABLe:AMAM:FILE[:SELect] <Filename>
[:SOURce<hw>]:IQ:DPD:SHAPing:TABLe:AMPM:FILE[:SELect] <Filename>
Selects a file with correction values (extension *.dpd_magn (AM/AM) or
*.dpd_phase(AM/FM)).

Parameters:
<Filename> string

Example: See Example"Defining correction coefficients and enabling digi-
tal predistortion" on page 96

Manual operation: See "Shaping Table" on page 59
See "Pin (dBm), Delta Power (dB)/Pin (dBm), Delta Phase
(deg)" on page 61

[:SOURce<hw>]:IQ:DPD:SHAPing:TABLe:AMAM:FILE:NEW
[:SOURce<hw>]:IQ:DPD:SHAPing:TABLe:AMPM:FILE:NEW
Stores the correction values into a file with the selected file name and loads it.

The file is stored in the default directory or in the directory specified with the absolute
file path. If the file does not yet exist, a new file is created. The file extension is
assigned automatically.

Example: See Example"Defining correction coefficients and enabling digi-
tal predistortion" on page 96

Usage: Setting only
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[:SOURce<hw>]:IQ:DPD:SHAPing:TABLe:AMAM:FILE:DATA
[:SOURce<hw>]:IQ:DPD:SHAPing:TABLe:AMPM:FILE:DATA
Defines the predistortion function in a raw data format.

See also [:SOURce<hw>]:IQ:DPD:SHAPing:TABLe:AMPM:FILE:NEW
on page 106.

Example: See Example"Defining correction coefficients and enabling digi-
tal predistortion" on page 96

[:SOURce<hw>]:IQ:DPD:SHAPing:TABLe:INTerp <Interpolation>

Enables a linear (voltage or power) interpolation between the defined correction val-
ues.

Parameters:
<Interpolation> OFF | POWer | LINear

POWer
Linear power interpolation
LINear
Linear voltage interpolation
*RST: OFF

Example: See Example"Defining correction coefficients and enabling digi-
tal predistortion" on page 96

Manual operation: See "Interpolation" on page 57

[:SOURce<hw>]:IQ:DPD:SHAPing[:TABLe]:INVert <InvertValues>

Inverts the defined correction values.

Parameters:
<InvertValues> 1 | ON | 0 | OFF

*RST: 0

Example: See Example"Defining correction coefficients and enabling digi-
tal predistortion" on page 96

Manual operation: See "Invert Correction Values" on page 57

[:SOURce<hw>]:IQ:DPD:SHAPing:POLYnomial:COEFficients <I0>, <J0>, <J1>,
<J1>

Sets the polynomial coefficients as a list of up to 10 comma separated value pairs.

In Cartesian coordinates system, the coefficients bn are expressed in degrees.
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Parameters:
<I0> float

Range: -1E6  to  1E6
Increment: 1E-3
*RST: 0

<J0> float
Range: -1E6  to  1E6
Increment: 1E-3
*RST: 0

<J1> float
Range: -1E6  to  1E6
Increment: 1E-3
*RST: 0

<J1> float
Range: -1E6  to  1E6
Increment: 1E-3
*RST: 0

Example: See Example"Defining correction coefficients and enabling digi-
tal predistortion" on page 96.

Manual operation: See "Polynomial Order" on page 65
See "Apply, OK" on page 65

[:SOURce<hw>]:IQ:DPD:SHAPing:POLYnomial:COEFficients:CATalog?

Queries the available polynomial files in the default directory. Only files with the file
extension *.dpd_poly are listed.

Return values: 
<Catalog> string

Example: See Example"Defining correction coefficients and enabling digi-
tal predistortion" on page 96

Usage: Query only

Manual operation: See "Save/Recall Polynomial" on page 65

[:SOURce<hw>]:IQ:DPD:SHAPing:POLYnomial:COEFficients:LOAD <Filename>

Loads the selected polynomial file.

Setting parameters: 
<Filename> string

Example: See Example"Defining correction coefficients and enabling digi-
tal predistortion" on page 96

Usage: Setting only
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Manual operation: See "Save/Recall Polynomial" on page 65

[:SOURce<hw>]:IQ:DPD:SHAPing:POLYnomial:COEFficients:STORe <Filename>

Saves the polynomial function as polynomial file.

Setting parameters: 
<Filename> string

Example: See Example"Defining correction coefficients and enabling digi-
tal predistortion" on page 96

Usage: Setting only

Manual operation: See "Save/Recall Polynomial" on page 65

[:SOURce<hw>]:IQ:DPD:SHAPing:NORMalized:DATA <Data>

Defines the normalized predistortion function in a raw data format (binary data).

Parameters:
<Data> <#><LengthNoBytes><NoBytes><NormData>

<#>
The binary data must start with the sign #
<LengthNoBytes>
ASCII format
Sets the length of <NoBytes>, i.e. the number of digits used to
write <NoBytes>
<NoBytes>
An ASCII integer value that specifies the number of bytes that
follow in the <NormData> part
Each of the <NormData> parameters is coded with 8 bytes.
Then the number of bytes <NoBytes> is calculated as:
<NoBytes> = 8 + 8 + n(8+8+8), where n is the number of points
<NoPoints>.
<NormData>
<PinMax><NoPoints>{<VinVmax><DeltaV><DeltaPhase>}
Values in binary format, describing the maximum absolute input
power Pinmax, the number of subsequent points n and the nor-
malized values Vin/Vmax, ΔV/V, ΔPhase [deg].
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Example: SOURce1:IQ:DPD:SHAPing:NORMalized:DATA #240<values>
// the binary <values> are not printable
SOURce1:IQ:DPD:SHAPing:NORMalized:DATA:CATalog?
// norm
SOURce1:IQ:DPD:SHAPing:NORMalized:DATA:STORe "My_DPD_Normalized"
SOURce1:IQ:DPD:SHAPing:NORMalized:DATA:CATalog?
// norm,My_DPD_Normalized
SOURce1:IQ:DPD:SHAPing:NORMalized:DATA:LOAD "norm"
SOURce1:IQ:DPD:SHAPing:NORMalized:DATA?
// #3112
// the binary data <NormData> is 112 bytes long (3 points are defined)
// binary data is machine readable but not printable

Manual operation: See "Apply, OK" on page 67

[:SOURce<hw>]:IQ:DPD:SHAPing:NORMalized:DATA:CATalog?

Queries the available files with normalized data in the default directory. Only files with
the file extension *.dpd_norm are listed.

Return values: 
<Catalog> string

Example: See [:SOURce<hw>]:IQ:DPD:SHAPing:NORMalized:DATA
on page 109.

Usage: Query only

Manual operation: See "Save/Recall Normalized Data" on page 66

[:SOURce<hw>]:IQ:DPD:SHAPing:NORMalized:DATA:LOAD <Filename>

Loads the selected file.

Setting parameters: 
<Filename> string

Example: See [:SOURce<hw>]:IQ:DPD:SHAPing:NORMalized:DATA
on page 109.

Usage: Setting only

Manual operation: See "Save/Recall Normalized Data" on page 66

[:SOURce<hw>]:IQ:DPD:SHAPing:NORMalized:DATA:STORe <Filename>

Saves the normalized data in a file.

Setting parameters: 
<Filename> string

Example: See [:SOURce<hw>]:IQ:DPD:SHAPing:NORMalized:DATA
on page 109.
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Usage: Setting only

Manual operation: See "Save/Recall Normalized Data" on page 66

[:SOURce<hw>]:IQ:DPD:LRF:STATe <LinearizeRf>

Activates linearization of the RF.

Parameters:
<LinearizeRf> 1 | ON | 0 | OFF

*RST: 0

Example: SOURce1:IQ:DPD:LRF:STATe 1
SOURce1:IQ:DPD:LRF:ADJust?
// Response: 0

Manual operation: See "Linearize RF" on page 68

[:SOURce<hw>]:IQ:DPD:LRF:ADJust?

Calculates the predistortion values for the current frequency.

Return values: 
<AdjustResult> 0 | 1 | RUNning | STOPped

*RST: STOPped

Usage: Query only

Manual operation: See "Adjust Linearization Current Frequency" on page 68
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[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:ETRak...............................................................................85
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[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:GAIN.................................................................................88
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[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:SHAPing:COEFficients.....................................................93
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:SHAPing:COEFficients:CATalog?.....................................94
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:SHAPing:COEFficients:LOAD.......................................... 94
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:SHAPing:COEFficients:STORe........................................ 94
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:SHAPing:DETRoughing:COUPling...................................95
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:SHAPing:DETRoughing:FACTor.......................................95
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:SHAPing:DETRoughing:FUNCtion...................................94
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[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:SHAPing:FILE:NEW......................................................... 93
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[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:SHAPing:MODE............................................................... 91
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:SHAPing:PV:FILE:CATalog?.............................................92
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[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:STATe............................................................................... 84
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[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:VCC:MIN...........................................................................89
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:VCC:OFFSet.....................................................................88
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[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:VCC:VALue?.....................................................................90
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:VOUT:MAX....................................................................... 86
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:VOUT:MIN.........................................................................86
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:VPP[:MAX]........................................................................87
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[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:VREF................................................................................ 85
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:PRESet..............................................................................................79
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