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1  Welcome to the T-DMB/DAB option
The R&S SMCVB-K156 is a firmware application that adds functionality to generate
signals in accordance with the T-DMB/DAB digital standard.

The R&S SMCVB-K156 option features:

● T-DMB/DAB signal generation

This user manual contains a description of the functionality that the application pro-
vides, including remote control operation.

All functions not discussed in this manual are the same as in the base unit and are
described in the R&S SMCV100B user manual. The latest version is available at:

www.rohde-schwarz.com/manual/SMCV100B

Installation

You can find detailed installation instructions in the delivery of the option or in the
R&S SMCV100B service manual.

1.1  Accessing the T-DMB/DAB dialog

To open the dialog with T-DMB/DAB settings

► In the block diagram of the R&S SMCV100B, select "Baseband > T-DMB/DAB".

A dialog box opens that displays the provided general settings.

The signal generation is not started immediately. To start signal generation with the
default settings, select "State > On".

1.2  What's new

This manual describes firmware version FW 5.20.043.xx and later of the
R&S®SMCV100B.

Compared to the previous version, it provides information on how to load and play
stream library files. See "To load and play a stream library file" on page 46.

1.3  Documentation overview

This section provides an overview of the R&S SMCV100B user documentation. Unless
specified otherwise, you find the documents at:

Documentation overview

https://www.rohde-schwarz.com/manual/smcv100b
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www.rohde-schwarz.com/manual/smcv100b

1.3.1  Getting started manual

Introduces the R&S SMCV100B and describes how to set up and start working with the
product. Includes basic operations, typical measurement examples, and general infor-
mation, e.g. safety instructions, etc. A printed version is delivered with the instrument.

1.3.2  User manuals and help

Separate manuals for the base unit and the software options are provided for down-
load:
● Base unit manual

Contains the description of all instrument modes and functions. It also provides an
introduction to remote control, a complete description of the remote control com-
mands with programming examples, and information on maintenance, instrument
interfaces and error messages. Includes the contents of the getting started manual.

● Software option manual
Contains the description of the specific functions of an option. Basic information on
operating the R&S SMCV100B is not included.

The contents of the user manuals are available as help in the R&S SMCV100B. The
help offers quick, context-sensitive access to the complete information for the base unit
and the software options.

All user manuals are also available for download or for immediate display on the Inter-
net.

1.3.3  Service manual

Describes the performance test for checking compliance with rated specifications, firm-
ware update, troubleshooting, adjustments, installing options and maintenance.

The service manual is available for registered users on the global Rohde & Schwarz
information system (GLORIS):

https://gloris.rohde-schwarz.com

1.3.4  Instrument security procedures

Deals with security issues when working with the R&S SMCV100B in secure areas. It
is available for download on the internet.

Documentation overview

http://www.rohde-schwarz.com/manual/smcv100b
https://gloris.rohde-schwarz.com
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1.3.5  Printed safety instructions

Provides safety information in many languages. The printed document is delivered with
the product.

1.3.6  Data sheets and brochures

The data sheet contains the technical specifications of the R&S SMCV100B. It also
lists the options and their order numbers and optional accessories.

The brochure provides an overview of the instrument and deals with the specific char-
acteristics.

See www.rohde-schwarz.com/brochure-datasheet/smcv100b

1.3.7  Release notes and open source acknowledgment (OSA)

The release notes list new features, improvements and known issues of the current
firmware version, and describe the firmware installation.

The software makes use of several valuable open source software packages. An open-
source acknowledgment document provides verbatim license texts of the used open
source software.

See www.rohde-schwarz.com/firmware/smcv100b

1.3.8  Application notes, application cards, white papers, etc.

These documents deal with special applications or background information on particu-
lar topics.

See www.rohde-schwarz.com/application/smcv100b

1.3.9  Videos

Find various videos on Rohde & Schwarz products and test and measurement topics
on YouTube: https://www.youtube.com/@RohdeundSchwarz

Documentation overview

http://www.rohde-schwarz.com/brochure-datasheet/smcv100b
http://www.rohde-schwarz.com/firmware/smcv100b
http://www.rohde-schwarz.com/application/smcv100b
https://www.youtube.com/@RohdeundSchwarz
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1.4  Scope

Tasks (in manual or remote operation) that are also performed in the base unit in the
same way are not described here.
In particular, it includes:
● Managing settings and data lists, like saving and loading settings, creating and

accessing data lists, or accessing files in a particular directory.
● Information on regular trigger, marker and clock signals and filter settings, if appro-

priate.
● General instrument configuration, such as checking the system configuration, con-

figuring networks and remote operation
● Using the common status registers

For a description of such tasks, see the R&S SMCV100B user manual.

1.5  Notes on screenshots

When describing the functions of the product, we use sample screenshots. These
screenshots are meant to illustrate as many as possible of the provided functions and
possible interdependencies between parameters. The shown values may not represent
realistic usage scenarios.

The screenshots usually show a fully equipped product, that is: with all options instal-
led. Thus, some functions shown in the screenshots may not be available in your par-
ticular product configuration.

Notes on screenshots
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2  About the T-DMB/DAB option
DAB, DAB+ and T-DMB are OFDM-based terrestrial standards. DAB and DAB+ are
designed for audio broadcasting. DAB+ uses advanced audio compression techniques.
T-DMB is designed for audio and video broadcasting.

The transmission standard complies with specification ETSI EN 300 401 specification.
The input interface complies with specification ETS 300 799.

2.1  Required options

The equipment layout for generating T-DMB/DAB signals includes:
● Base unit
● Option Enable Broadcast Standard (R&S SMCVB-K519)
● Option T-DMB/DAB (R&S SMCVB-K156)

2.2  About DAB/T-DMB

The R&S SMCV100B enables you to generate signals in accordance with the Digital
Audio Broadcasting (DAB)/Terrestrial Digital Multimedia Broadcasting (T-DMB) stan-
dard.

The generated signals are compliant with ETSI EN 300 401 standard. Via the user-
friendly graphical interface of R&S SMCV100B, you can adjust several DAB signal
parameters. You are enabled to generate a signal corresponding to one of the four
standard transport modes, Transmission Mode I, II, III or IV. You can also choose to
enable or disable channel coding, time interleaving and/or pseudo noise scrambling.

The R&S SMCV100B allows you to choose between different data sources. You can
either use some of the predefined data sources (two different pseudo noise sequen-
ces, fixed all “0”, fixed all “1”) or you can use source files that comply with the Ensem-
ble Transport Interface-compliant (ETI) specification. For example, if you are member
of WorldDAB, you can download ETI-compliant source files from the WorldDAB library
available at:

https://www.worlddab.org/resources/worlddab-eti-library

The DAB system is designed for delivery of high-quality digital audio programs and
data services for mobile, portable and fixed reception from terrestrial or satellite trans-
mitters. The system operates in Very High Frequency (VHF)/Ultra High Frequency
(UHF) frequency bands. Also, it is used for distribution through cable networks.

The DAB system is designed to provide spectrum and power efficient techniques in ter-
restrial transmitter network planning, known as the Single Frequency Network (SFN)
and the gap-filling technique. The DAB system is suitable for satellite and hybrid/mixed
terrestrial/satellite broadcasting, using a simple, nearly omni-directional receiving

About DAB/T-DMB

https://www.worlddab.org/resources/worlddab-eti-library
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antenna. The DAB system meets the required sharing criteria with other radio commu-
nication services.

2.2.1  DAB network

The figure bellow illustrates the outline of a DAB network.

Figure 2-1: DAB network

The DAB network has three main parts: the service or service component provider, the
multiplex or ensemble provision and the transmission network provision.

The interfaces between these blocks are scope of ETSI standards. The Service Trans-
port Interface (STI) is defined to provide a standardized way of transporting DAB ser-
vice components, service information and control messages in a DAB collection net-
work.

The Ensemble Transport Interface (ETI) links the multiplexer of the Ensemble Provider
with the transmitters of the Transmission Network Provider.

2.2.2  DAB transmission system

The following block diagram shows the components of the DAB transmission system.

Figure 2-2: Components of the transmission system DAB

About DAB/T-DMB
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The DAB transmission signal is defined as the sum of two signals; the main signal s(t)
and an optional signal sTII(t) as illustrated in the figure above.

2.2.3  Transport mechanisms

The DAB system is designed to carry several digital audio signals together with data
signals. Audio and data signals are considered to be service components which can be
grouped to form services.

The DAB system transmission frame consists of three different channels:
● Main Service Channel (MSC)
● Fast Information Channel (FIC)
● Synchronization Channel

2.2.3.1  Transmission channels

The MSC is a time-interleaved data channel used to carry the audio and data service
components, together with possible supporting and additional data service compo-
nents. The MSC is divided into several subchannels. Each of the subchannels is indi-
vidually convolutionally coded with equal or unequal error protection. Each subchannel
can carry one or more service components.

The FIC is a non time-interleaved data channel with fixed equal error correction. FIC
carries information about the organization of the MSC subchannels, such as informa-
tion on the multiplex structure and, when necessary, its reconfiguration. Optionally FIC
can include service information, conditional access management information and data
service.

The Synchronization Channel provides a phase reference and is used internally for
demodulator functions such as transmission frame synchronization, automatic fre-
quency control, transmitter identification, and channel state estimation.

The Synchronization Channel, the Fast Information Channel and the Main Service
Channel form a transmission frame (see Figure 2-3). The MSC occupies the major part
of the transmission frame.

Figure 2-3: DAB transmission frame

Each transmission frame is divided into a sequence of OFDM symbols, each symbol
consisting of several carriers.

About DAB/T-DMB
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The Fast Information Block (FIB) and the Common Interleaved Frame (CIF) are intro-
duced to provide transmission mode-independent data transport packages associated
with the FIC and MSC respectively.

The data, carried in the MSC, is divided at source into regular 24 ms bursts corre-
sponding to the sub-channel data capacity of each CIF. The CIF contains 55 296 bits,
divided at 864 capacity units, 64 bits each.

The FIB is a data burst of 256 bits. The sequence of FIBs is carried by the Fast Infor-
mation Channel (FIC). The structure of the FIB is common to all transmission modes.

The synchronization channel symbols comprise the null symbol and the phase refer-
ence symbol. The null symbols are also used to allow a limited number of OFDM carri-
ers to convey the Transmitter Identification Information (TII).

2.2.3.2  Transport modes

Transmission mode is specific set of transmission parameters (e.g. number of carriers,
OFDM symbol duration). Four transmission modes (i.e. I, II, III and IV) are defined to
allow the system to be used for different network configurations and a range of operat-
ing frequencies. Depending on the transport mode, the transmission frame has differ-
ent organization and length, i.e. the transmission frame is specific to the four transmis-
sion modes.

The table below gives the transmission frame duration and the number of FIBs and
CIFs which are associated with each transmission frame for the four transport modes.
Table 2-1: Transmission mode characteristics

Transport
mode

Duration of
transmission
frame

Number of
FIBs per trans-
mission frame

Number of
CIFs per trans-
mission frame

Number of car-
riers

Carrier spac-
ing

I 96 ms 12 4 1536 1 KHz

II 24 ms 3 1 384 4 KHz

III 24 ms 4 1 192 8 KHz

IV 48 ms 6 2 768 2 KHz

2.2.4  Pseudo noise scrambling

Before convolution encoding, the transmitted signal can be scrambled by a modulo-2
addition with a PRBS.

The PRBS polynomial is of degree 9 and specified as P(X) =x9+x5+1.

The initialization word is applied so that the first bit of the PRBS is obtained when the
outputs of all shift register stages are set to "1".

About DAB/T-DMB
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2.2.5  Convolutional coding

The process of convolution coding is applied at the output of each PN scrambler. The
channel encoding process is based on punctured convolutional coding, which allows
both equal and unequal error protection. Unequal error protection (UEP) is designed
for audio services, equal error protection (EEP) for audio and data services. The sam-
pling frequency is respectively 48 kHz and 24 kHz.

The convolutional coder is a punctured convolution code, based on a mother convolu-
tional code with constraint length 7 and rate 1/4.

The generator polynomials are G1=(1,0,1,1,0,1,1), G2=(1,1,1,1,0,0,1),
G3=(1,1,0,0,1,0,1) and G4=(1,0,1,1,0,1,1).

To avoid the need for additional signaling overhead, the data in the FIC are encoded
with fixed, equal channel coding, with a constant 1/3 coding rate.

The puncturing procedures applied for the coding in the MSC are a combination of pro-
tection profile and protection level. There are permissible protection profiles defined for
each of the allowed bit rates. Each protection profile is associated with a protection
level. Protection level 1 is the highest level within the same profile.

Error protec-
tion

Protection profile Bit rate Protection Level Code rate

UEP four different pro-
tection profiles

14 different bit rates 1, 2, 3, 4, 5 0.34 to 0.75

(64 different data
rates - protection
level combinations)

EEP A Multiples of 8 kbit/s 1-A 1/4

2-A 3/8

3-A 1/2

4-A 3/4

B Multiples of 32 kbit/s 1-B 4/9

2-B 4/7

3-B 2/3

4-B 4/5

2.2.6  Time interleaving

Time interleaving is applied before block generation at the output of each convolutional
encode contributing to the subchannels in the MSC. It is not applied to the FIC.

The time interleaving process covers 16 CIFs, 24 ms each. This process results in an
overall processing delay of 384 ms.

About DAB/T-DMB
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3  T-DMB/DAB configuration and settings
Access:

► Select "Baseband > T-DMB/DAB".

The remote commands required to define these settings are described in Chapter 5,
"Remote-control commands", on page 48.

Settings:

● General settings......................................................................................................14
● Input signal settings................................................................................................ 15
● Network settings......................................................................................................24
● SFN settings............................................................................................................26
● Special settings.......................................................................................................28
● Global connector settings........................................................................................30
● TS player.................................................................................................................30
● Local IP data network settings................................................................................ 39

3.1  General settings

Access:

► Select "Baseband > T-DMB/DAB".

The tab provides functionality for calling default settings, save and recall settings.

Settings:

State..............................................................................................................................14
Set To Default................................................................................................................15
Save/Recall................................................................................................................... 15

State
Activates the standard and deactivates all the other digital standards and digital modu-
lation modes in the same path.
Remote command: 
[:SOURce<hw>]:BB:TDMB:STATe on page 49

General settings
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Set To Default
Calls the default settings. The values of the main parameters are listed in the following
table.

Parameter Value

State Not affected by the "Set to Default"

Remote command: 
[:SOURce<hw>]:BB:TDMB:PRESet on page 49

Save/Recall
Accesses the "Save/Recall" dialog, that is the standard instrument function for saving
and recalling the complete dialog-related settings in a file. The provided navigation
possibilities in the dialog are self-explanatory.
The settings are saved in a file with predefined extension. You can define the filename
and the directory, in that you want to save the file.
See also, chapter "File and Data Management" in the R&S SMCV100B user manual.
Remote command: 
[:SOURce<hw>]:BB:TDMB:SETTing:CATalog? on page 49
[:SOURce<hw>]:BB:TDMB:SETTing:DELete on page 50
[:SOURce<hw>]:BB:TDMB:SETTing:LOAD on page 50
[:SOURce<hw>]:BB:TDMB:SETTing:STORe on page 50

3.2  Input signal settings

Access:

► Select "Baseband > T-DMB/DAB > Input Signal".

The dialog provides access to settings to configure the input signal.

Input signal tasks

The settings allow you to perform the following tasks:
● Selecting an ETI source (external ETI Input, TS player as ETI player or internal ETI

test signal).
● Displaying information about the selected ETI signal (e.g. MID, NST)

How to: Chapter 4.1, "Configuring the input signal", on page 42 .

An external ETI signal (physical HDB3-coded) can be fed in at the "User 1" connector.

Input signal settings
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Common input signal settings
The setting of the following parameters is used for all broadcast standards.
● "Source"
● "Input"

Settings:

● General settings......................................................................................................16
● Info.......................................................................................................................... 18
● Test signal settings..................................................................................................20
● IP channel x settings...............................................................................................20

3.2.1  General settings

Access:

► Select "Input Signal > General".

The tab provides general settings to configure the input signal.

Settings:

Source...........................................................................................................................16
Input.............................................................................................................................. 17
Input Format..................................................................................................................17
IP ETI Channel..............................................................................................................17
ETI Signal......................................................................................................................18
Number of Streams....................................................................................................... 18
Mode Identity (MID).......................................................................................................18

Source
Sets ETI signal source.

Input signal settings
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"External" Uses the external ETI signal present at the input connector.
Signal requirements:
● ETI (NI), ETI (NA 5592) or ETI (NA 5376) signal
● HDB3-coded
● Nominal voltage level: ±2.37 V
● Internally terminated with a 75 Ω load
● Data rate: 2.048 Mbit/s

"TS Player" Uses an internal transport stream with ETI packet data played from a
file. The player requires no option.
Playing encrypted files with extension _c requires a stream library
option R&S SMCVB-KSx.
See also:
● Chapter 3.7, "TS player", on page 30
● Supported TS player file types
Provide suitable play files, for example, install the stream libraries T-
DMB/DAB streams (R&S SMCVB-KS10) and DAB+ streams
(R&S SMCVB-KS11).

"Test Signal" Requires "Network > Network Mode > MFN".
Uses an internal ETI test signal with audio content.

Remote command: 
[:SOURce<hw>]:BB:TDMB:SOURce on page 52

Input
Requires "Source > External".
Sets the external input interface.
Remote command: 
[:SOURce<hw>]:BB:TDMB:INPut on page 51

Input Format
Requires "Source > External" and "Input > TS IN".
Displays the format of the input signal.
"ETI" Fixed input format.
Remote command: 
[:SOURce<hw>]:BB:TDMB:INPut:FORMat on page 51

IP ETI Channel
Requires "Source > External" and "Input > IP".
Selects the IP ETI channel. You can select one out of two IP ETI channels as input at
the "IP Data" interface.
To configure a particular channel, see Chapter 3.2.4, "IP channel x settings",
on page 20.
Remote command: 
[:SOURce<hw>]:BB:TDMB:INPut:ETIChannel on page 51

Input signal settings
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ETI Signal
Displays, if a valid ETI signal is present and the signal type.
"Invalid" No ETI signals present.
"ETI (NI)" ETI NI signal.
"ETI (NA 5592)"

ETI NA 5592 signal.
"ETI (NA 5376)"

ETI NA 5376 signal.
Remote command: 
[:SOURce<hw>]:BB:TDMB:ETIinput? on page 51

Number of Streams
Displays the number of streams contained in the ETI signal.
The signal can contain up to 64 streams. If the ETI signal is invalid, the number of
streams is "0".
Remote command: 
[:SOURce<hw>]:BB:TDMB:NST? on page 52

Mode Identity (MID)
Displays the DAB mode identity.
The MID information in the ETI data stream determines the transmission mode.
Remote command: 
[:SOURce<hw>]:BB:TDMB:MID? on page 52

3.2.2  Info

Access:

► Select "Input Signal > Info".

The tab displays the STC and SSTC information on the input signal.

Settings:

Info................................................................................................................................ 19

Input signal settings
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└ Subchannel Id (Hex)....................................................................................... 19
└ Protection Profile.............................................................................................19
└ Protection Level.............................................................................................. 19
└ Data Rate / kbit/s............................................................................................ 19

Info
The table displays individual parameters for each subchannel. The subchannels range
from 1 to Number of Streams, see "Number of Streams" on page 18.
STC/SSTC parameters are "Subchannel Id (Hex)", "Protection Profile", "Protection
Level" and "Data Rate / kbit/s".

Subchannel Id (Hex) ← Info
Displays the subchannel identifiers.
Remote command: 
[:SOURce<hw>]:BB:TDMB:SCID<ch> on page 53

Protection Profile ← Info
Displays the protection profile.
"UEP" Unequal error protection
"EEP" Equal error protection
Remote command: 
[:SOURce<hw>]:BB:TDMB:PROTection:PROFile<ch>? on page 53

Protection Level ← Info
Displays the protection level. The level depends on the protection profile.
"1" to "5" Requires "Protection Profile > UEP".
"1A" to "4A" or "1B" to "4B"

Requires "Protection Profile > EEP".
"Undefined" No protection profile detected.
Remote command: 
[:SOURce<hw>]:BB:TDMB:PROTection:LEVel<ch>? on page 53

Data Rate / kbit/s ← Info
Displays the uncoded data rate in kbit/s.
Remote command: 
[:SOURce<hw>]:BB:TDMB:DATarate<ch>? on page 53

Input signal settings
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3.2.3  Test signal settings

Access:

► Select "Input Signal > Test Signal".

The tab provides settings to configure the input test signal.

Settings:

PRBS
Sets the test signal sequence, that is transmitted in the subchannel.
You can select a PRBS 15, PRBS 20 and PRBS 23 sequence as specified by ITU-T
O.151. Also you can define a sequence of zeroes (0x00).
Remote command: 
[:SOURce<hw>]:BB:TDMB:PRBS[:SEQuence] on page 62

3.2.4  IP channel x settings

Access:

1. Select "Input Signal > General".

2. Select "Source > External"

3. Select "Input > IP"

Input signal settings
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4. Select "Input Signal > IP Channel x"

The tab provides settings to configure IP channel x.

You can configure settings for 2 IP channels x = 1 to 2 individually, see also "Input
Signal > General > IP ETI Channel".

IP channel settings affect input IP data of the local IP data network. The settings are
independent from the used broadcast standard configuration.
Saving/recalling a certain IP channel or local IP data network configuration is not possi-
ble via the broadcast standard-specific functionality.
Use the global save/recall functionality instead, see section "Saving and Recalling
Instrument Settings" in the R&S SMCV100B user manual.

The table below shows the availability of the tab in the broadcast standard configura-
tion.
Table 3-1: IP channel configuration support in broadcast standards

Baseband standard "IP Channel x" Baseband standard "IP Channel x"

"ATSC/ATSC-M/H" Yes "DVB-S" Yes

"ATSC 3.0" No "DVB-S2" Yes

"DTMB" Yes "DVB-C" Yes

"DVB-T" Yes "J.83/B" Yes

"DVB-T2" Yes "DRM" No

"ISDB-T" Yes "Audio AM" No

"T-DMB/DAB" Yes "Audio FM" No

See also:
● Chapter 4.1.1, "How to apply an external IP input signal", on page 42
● Chapter 3.8, "Local IP data network settings", on page 39

Input signal settings
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Settings:

Input IP..........................................................................................................................22
Alias.............................................................................................................................. 22
Type.............................................................................................................................. 22
Multicast Address..........................................................................................................22
Port................................................................................................................................22
IGMPv3 Source Address...............................................................................................23
Ping Source Address.................................................................................................... 23
Ping Result....................................................................................................................23
Local IP Data Network.................................................................................................. 23

Input IP
Activates/deactivates the IP input.
Remote command: 
[:SOURce<hw>]:BB:INPut:IP<ch>[:STATe] on page 55

Alias
Sets a unique name for the IP connection.
The definition of a name is optional but facilitates identification in the measurement
views. The name input fits maximum 16 characters in ASCII format.
Remote command: 
[:SOURce<hw>]:BB:INPut:IP<ch>:ALIas on page 55

Type
Sets the input signal type.
"Unicast" Analyzes all unicast IP packets that arrive at the specified "Port".
"Multicast" When an IP address is in the multicast address range, an attempt is

made to join a multicast group using IGMP.
Set "Multicast Address" and "Port".

Remote command: 
[:SOURce<hw>]:BB:INPut:IP<ch>:TYPE on page 56

Multicast Address
Editing requires "Type > Multicast".
Sets the destination IP address (IPv4) of the IP connection.
You can set addresses from "224.0.0.0" to "239.255.255.255".
Remote command: 
[:SOURce<hw>]:BB:INPut:IP<ch>:MULticast:ADDRess on page 56

Port
Sets the destination UDP port.
Due to UDP/RTP autosensing, we recommend that you set a port offset of at least 6
between neighboring IP TS channels.
Remote command: 
[:SOURce<hw>]:BB:INPut:IP<ch>:PORT on page 55

Input signal settings
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IGMPv3 Source Address
Requires "Type > Multicast".
Sets the IGMPv3 source address.
If you need to filter the data sent to the multicast address, specify the source address.
A source address different from "0.0.0.0" accepts only data originating from the speci-
fied IP address.
Remote command: 
[:SOURce<hw>]:BB:INPut:IP<ch>:IGMP[:SOURce]:ADDRess on page 56

Ping Source Address
Clicking "Ping Source Address" triggers pinging of the IGMPv3 source address.
If you set a different value from "IGMPv3 Source Address = 0.0.0.0" and click the but-
ton, the software checks if the address is reachable.
Remote command: 
[:SOURce<hw>]:BB:INPut:IP<ch>:IGMP[:SOURce]:PING on page 56

Ping Result
Displays the result after pinging the source address.
If "Ping Result > Ping: Successful", the source address is available in the network.
If "Ping Result > Ping: Transmit Failed. xxx", the source address is not available in the
network. "xxx" can be, e.g. "General Failure". Try another "IGMPv3 Source Address".
Remote command: 
[:SOURce<hw>]:BB:INPut:IP<ch>:IGMP[:SOURce]:RESult? on page 57

Local IP Data Network
Accesses local IP data network settings, see Chapter 3.8, "Local IP data network set-
tings", on page 39.

Input signal settings
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3.3  Network settings

Access:

► Select "Baseband > T-DMB/DAB > Network".

The tab provides network mode and TII settings.

Settings:

Network Mode............................................................................................................... 24
TII.................................................................................................................................. 25
TII Main ID.....................................................................................................................25
TII Sub ID...................................................................................................................... 25

Network Mode
Sets the network mode.
Note: GPS receiver required.
Correct SFN synchronization requires a GPS receiver:
● Connect the 1PPS output of the GPS receiver to the "User 2" connector of the

R&S SMCV100B.
● Connect the 10 MHz output of the GPS receiver to the "Ref. In" connector of the

R&S SMCV100B.
At the R&S SMCV100B, set "RF > Reference Frequency > Reference Frequency >
Source > External".

Network settings
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"SFN" In an SFN, all transmitters in a network are tuned to the same fre-
quency and have frequency coupling (based on the 10 MHz refer-
ence output of a GPS receiver). In addition, it is necessary in an SFN
network to compensate any signal delays that occur in the program
data supply.
Compensating signal delays involves the use of a GPS receiver, see
also "GPS receiver required" on page 24. Also it involves inserting
time stamps (TIST) into the ETI stream. The maximum delay in the
network is set on the ETI multiplexer. This maximum delay is the sum
of all delays which can occur in the program data supply at the most
remote transmitter in the network.
If a time stamp was received at the SFN transmitter, its modulator
measures the dynamic delay regarding its own received seconds
pulse from the local GPS receiver. The SFN transmitter computes the
local delay. The local delay is the sum of dynamic delay, the process-
ing delay (of the modulator), the RF delay (from modulator to
antenna) and the optional static delay. The transmitted ETI stream is
delayed by the local delay to attain data synchronicity in the network.
Note that it is critical for the incoming ETI stream to be identical for all
the transmitters in the network. That means we recommend you to
keep the setting of the ETI stream. Note also, that the modulator
operates with TIST level 5 at any time.

"MFN" In a MFN, there is no mandatory coupling between an individual
transmitter and the incoming transport stream (based on the seconds
pulse from a GPS receiver). In addition, the transmitters are not
synchronized with one another based on a common reference and
output frequency. You can select the modulation parameters of the
transmitters involved in the network.

Remote command: 
[:SOURce<hw>]:BB:TDMB:NET on page 57

TII
Enables/disables the transmission of the TII signal.
The TII signal is used to identify each individual transmitter.
"On" Transmits a TII signal during the null symbol.
"Off" Transmits no TII signal.
Remote command: 
[:SOURce<hw>]:BB:TDMB:TII:STATe on page 58

TII Main ID
Defines the TII main ID.
Remote command: 
[:SOURce<hw>]:BB:TDMB:TII:MAIN on page 57

TII Sub ID
Defines the TII sub ID.
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Remote command: 
[:SOURce<hw>]:BB:TDMB:TII:SUB on page 58

3.4  SFN settings

Access:

1. Select "Baseband > T-DMB/DAB > Network > Network Mode > SFN".

2. Select "T-DMB/DAB > SFN".

The tab provides settings to configure SFN operation.

Settings

Network Compensation.................................................................................................26
Tx Processing Delay..................................................................................................... 26
Tx Compensation Delay................................................................................................27
Tx Delay........................................................................................................................ 27
Static Delay................................................................................................................... 27
Total Delay.................................................................................................................... 27
Max. Deviation Time......................................................................................................27

Network Compensation
Displays the compensating delay.
If the delay is added to the network path delay, the overall delay is constant and of
known value. The value of the compensating delay is set by examining incoming time-
stamps compared to a local time standard. The value of the compensating delay is
adjusted so that the frame carrying the timestamp is delivered at the correct time.
Remote command: 
[:SOURce<hw>]:BB:TDMB:DELay:NETWork? on page 59

Tx Processing Delay
Displays the minimum signal turnaround time through the transmitter.
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A minimum delay implies "Tx Compensation Delay = 0 µs". The minimum delay is
determined by the signal processing in the COFDM and depends on the DAB mode.
"Tx Processing Delay" = "Tx Delay" - "Tx Compensation Delay"
Remote command: 
[:SOURce<hw>]:BB:TDMB:DELay:PROCess? on page 59

Tx Compensation Delay
Displays the time span by which signal processing is artificially delayed to achieve a
constant "Tx Delay".
"Tx Compensation Delay" = "Tx Delay" - "Tx Processing Delay"
Remote command: 
[:SOURce<hw>]:BB:TDMB:DELay:COMPensation? on page 58

Tx Delay
Sets the signal turnaround time through the transmitter.
You can set a delay of up to one second.
"Tx Delay" = "Tx Compensation Delay" + "Tx Processing Delay"
Remote command: 
[:SOURce<hw>]:BB:TDMB:DELay:DELay on page 58

Static Delay
Sets the delay to shift the time of transmission positively or negatively.
The static delay is also called "user delay offset". You can shift transmission start by up
to one second.
Remote command: 
[:SOURce<hw>]:BB:TDMB:DELay:STATic on page 60

Total Delay
Displays the total cycle time of the signal through the transmitter.
"Total Delay" = "Static Delay" + "Tx Delay" + "Network Compensation"
Remote command: 
[:SOURce<hw>]:BB:TDMB:DELay:TOTal? on page 60

Max. Deviation Time
Sets the maximum permitted deviation of the transmission time relative to the internally
regulated reference frequency.
If the configured value is exceeded, the absolute transmission time is recalculated.
Recalculation causes a brief signal failure (mute), that means the transmit signal is
reset and transmission is restarted.
Remote command: 
[:SOURce<hw>]:BB:TDMB:DELay:DEViation on page 59
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3.5  Special settings

Access:

► Select "Baseband > T-DMB/DAB > Special".

The tab provides settings, that differ from the specification of the broadcast stan-
dard.

Settings different from the broadcast standard can be useful for research and develop-
ment. Applying these settings requires "Special Settings > On".
If you set a parameter different from the specification, the warning icon  is displayed
to the left of the parameter.

If special settings are active, decoding by a DUT is maybe not successful.

Settings:

Special Settings............................................................................................................ 28
Transmission Mode.......................................................................................................28
Select Transmission Mode............................................................................................29
PRBS Test Signal..........................................................................................................29
Test Signal SCID........................................................................................................... 29

Special Settings
Enables/disables special settings.
The setting allows you to switch between standard-compliant and user-defined channel
coding.
Remote command: 
[:SOURce<hw>]:BB:TDMB[:SPECial]:SETTings[:STATe] on page 61

Transmission Mode
Sets the transmission mode.

Special settings
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"MID" Uses the transmission mode corresponding to the MID information in
the ETI signal. Default state.

"Manual" Uses the transmission mode set via "Select Transmission Mode".
Remote command: 
[:SOURce<hw>]:BB:TDMB[:SPECial]:TRANsmission:MODE on page 61

Select Transmission Mode
Requires "Transmission Mode > Manual".
Selects the transmission mode.
Table 3-2 illustrates, how the selected transmission mode affects OFDM and framing
parameters.
Table 3-2: Transmission mode settings

Transmission mode 1 2 3 4

OFDM symbols per transmission frame 76 76 153 76

Number of carriers 1536 384 192 768

Transmission frame duration 96 ms 24 ms 24 ms 48 ms

Null symbol duration 1297 μs 324 μs 168 μs 648 μs

OFDM symbol duration 1246 μs 312 μs 156 μs 623 μs

Carrier spacing 1 kHz 4 kHz 8 kHz 2 kHz

Guard interval 246 μs 62 μs 31 μs 123 μs

Remote command: 
[:SOURce<hw>]:BB:TDMB[:SPECial]:TRANsmission:MODE:SELECT
on page 62

PRBS Test Signal
Activates transfer of a PRBS test signal to a subchannel instead of ETI input data.
By transmitting a PRBS in a subchannel, you can determine the bit error rate of this
subchannel. To select the PRBS, see "PRBS" on page 20.
"On" Transfers a test signal (PRBS) to the subchannel that is set via "Test

Signal SCID" on page 29.
"Off" Standard-conform setting transferring the ETI input data to the sub-

channels (streams).
Remote command: 
[:SOURce<hw>]:BB:TDMB[:SPECial]:TESTsignal[:STATe] on page 63

Test Signal SCID
Sets the ID of a subchannel (stream) that transmits a test signal (PRBS) instead of
data.
The subchannel ID is 6-bit value in hexadecimal representation.
Note: You can transmit the test signal (PRBS) only in the specified subchannel. If the
selected subchannel is not available, no PRBS is transmitted.

Special settings
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Remote command: 
[:SOURce<hw>]:BB:TDMB[:SPECial]:TESTsignal:SCID on page 62

3.6  Global connector settings

The "Input Signal" dialog, the "Trigger/Marker/Clock" dialog and "Trigger In", "Marker"
and "Clock" tabs in "Baseband > ARB/Custom Digital Mod" configuration dialogs pro-
vide quick access to the related connector settings. Click the "Global Connectors" but-
ton to access the settings.

See also chapter "Global connector settings" in the user manual.

3.7  TS player

The "TS Player" application allows you to play stream files for simulation of dedicated
transport stream (TS) scenarios. Also, the R&S SMCV100B offers stream libraries con-
taining stream files with a wide range of ready-made signals for testing systems with
different transmission parameters. For supported file types, see Table 3-3.

Key features

The key features for playing stream files with "TS Player" application are:
● Support of numerous broadcast transmission standards
● Streaming of high-quality video contents
● Streaming of high-quality audio contents
● Efficient use with dedicated streams

Required options

The equipment layout for processing files of waveform libraries includes:
● R&S SMCV100B base unit (64 MSample ARB memory, 60 MHz RF bandwidth)
● Broadcast standard option for the "TS Player" application (R&S SMCVB-Kxxx)
● Enable Broadcast Standards option (R&S SMCVB-K519)
● Stream library option (R&S SMCVB-KSxx)

For more information, see data sheet.

To access and download a stream library file

The steps to access a stream library and to download stream library files is analogous
as for waveform libraries. See chapter "Installation" in the user manual of the stream
library at:

TS player
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www.rohde-schwarz.com/manual/smcv100b/ksxx-kvxx-stream-and-waveform-libraries-
user-manuals-manuals-gb1_78701-972224.html

To access the "TS Player" application

1. Select "Baseband > T-DMB/DAB > Input Signal".

2. Select "Source > TS Player".

3. Select "TS Player" button.

Opens the TS player dialog, where you can load files.

Support in broadcast standard configuration

Various broadcast baseband standards of the R&S SMCV100B support the "TS
Player" application. For an overview, see the table below.

Baseband standard "Source > TS Player" Baseband standard "Source > TS Player"

"ATSC/ATSC-M/H" Yes "DVB-S" Yes

"ATSC 3.0" Yes "DVB-S2" Yes

"DTMB" Yes "DVB-C" Yes

"DVB-T" Yes "J.83/B" Yes

"DVB-T2" Yes "DRM" No

"ISDB-T" Yes "Audio AM" No

"T-DMB/DAB" Yes "Audio FM" No

The remote commands required to define these settings are described in Chapter 5.6,
"TSGen subsystem", on page 63.

Settings:

● TS Player settings...................................................................................................31
● Player output settings..............................................................................................34
● Seamless loop settings........................................................................................... 38

3.7.1  TS Player settings

Access:

1. Follow the steps in "To access the "TS Player" application" on page 31.

TS player
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2. Select "TS Player > TS-Player".

The tab provides settings to configure the general settings of the TS player applica-
tion.

Settings:

Running/Position Player [hh:mm:ss:fff]......................................................................... 32
Select File..................................................................................................................... 32
Start [hh:mm:ss.fff]........................................................................................................ 33
Position Player [hh:mm:ss.fff]........................................................................................34
Stop [hh:mm:ss.fff]........................................................................................................ 34
Reset Window............................................................................................................... 34
Play............................................................................................................................... 34
Pause............................................................................................................................ 34
Stop...............................................................................................................................34

Running/Position Player [hh:mm:ss:fff]
Displays the current position in time, while playing the file.
You can set an individual position via Position Player [hh:mm:ss.fff].
Remote command: 
:TSGen:CONFigure:SEEK:POSition on page 68

Select File
Provides access to the standard "File Select" function of the instrument. The provided
navigation possibilities in the dialog are self-explanatory.
See also, chapter "File and Data Management" in the R&S SMCV100B User Manual.
The dialog allows you to select user-defined, predefined and recent files. Table 3-3 lists
file extensions of supported files.
Table 3-3: Supported TS player file types

File extension Stream libraries Remark Option

*.atsc_c ATSC/ATSC & Mobile DTV Encrypted R&S SMCVB-KS13

*.dab T-DMB/DAB Unencrypted -

TS player
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File extension Stream libraries Remark Option

*.dab_c T-DMB/DAB Encrypted R&S SMCVB-KS10

*.dabp_c DAB+ Encrypted R&S SMCVB-KS11

*.eti T-DMB/DAB Unencrypted -

*.xeti T-DMB/DAB Unencrypted -

*.emc_c EMC Encrypted R&S SMCVB-KS15

*.isdbt_c ISDB-T Encrypted R&S SMCVB-KS12

*.pcap - Captured IPv4 stream for ATSC 3.0
player

-

*.t2mi1) - Unencrypted -

*.t2mi_c DVB-T2 MI Encrypted R&S SMCVB-KS14

*.t2trp_c DVB-T2 MI Encrypted R&S SMCVB-KS14

*.trp - Unencrypted -

*.trp_c - Encrypted

Included in various stream libraries

R&S SMCVB-KS12

R&S SMCVB-KS17

R&S SMCVB-KS18

R&S SMCVB-KS19

R&S SMCVB-KS20

*.bin - Unencrypted -

*.ts - Unencrypted -

*.mpg - Unencrypted -

*.t10 - - -

1) For T2MI stream files, the data rate of a T2MI file is determined automatically, if the
following applies:
● Data rate is not part of the TRP file header information.
● PCR information is not available.
● T2MI TRP file is not encrypted, that means not of type *.t2mi_c.
● TRP file has the *.t2mi file extension.

Remote command: 
:TSGen:CONFigure:PLAYfile on page 66
:TSGen:READ:PLAYfile:LENGth? on page 70
:TSGen:READ:FMEMory on page 70

Start [hh:mm:ss.fff]
Sets the start position in the loaded player file. Data which chronologically precedes
the start position is not replayed by the player.
The entered time stamp must chronologically always precede the entry under Stop.
Remote command: 
:TSGen:CONFigure:SEEK:STARt on page 68

TS player
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Position Player [hh:mm:ss.fff]
Displays the current play position in the file.
Remote command: 
:TSGen:CONFigure:SEEK:POSition on page 68

Stop [hh:mm:ss.fff]
Sets the end position in the player file. Data which chronologically follows the end posi-
tion is not replayed by the player.
When the player reaches the "Stop" position, it returns to the "Start" position (continu-
ous play).
The entered time stamp must chronologically always follow the entry under Play.
Remote command: 
:TSGen:CONFigure:SEEK:STOP on page 68

Reset Window
Resets "Start/Stop/Position Player" parameters.
Remote command: 
:TSGen:CONFigure:SEEK:RESet on page 68

Play
Plays the selected file.
For supported file types, see Table 3-3.
Remote command: 
:TSGen:CONFigure:COMMand on page 65

Pause
Pauses the player.
After pausing, you can resume playing the file by clicking "Play" again.
Remote command: 
:TSGen:CONFigure:COMMand on page 65

Stop
Stops the player and returns to the start position.
Remote command: 
:TSGen:CONFigure:COMMand on page 65

3.7.2  Player output settings

Access:

► Select "TS Player > Player Output".

The tab provides settings to configure the output of the TS player.

TS player



T-DMB/DAB configuration and settingsR&S®SMCVB-K156

35User Manual 1179.1029.02 ─ 06

3.7.2.1  General settings

The tab provides settings to configure general player output properties.

Data Rate...................................................................................................................... 35
Orig. Data Rate............................................................................................................. 35
Packet Length............................................................................................................... 35
Nullpacket Stuffing........................................................................................................ 35
Stop Data...................................................................................................................... 36

Data Rate
Sets the output data rate of the player.
Note: If "Nullpacket Stuffing > Off", we recommend that you set the output data rate
equal to the original data rate.
If you want to use a different data rate, activate "Nullpacket Stuffing". The function
ensures that the data stream is replayed in the same way as it was recorded. The time
references in the tables of the TS stream are also correct during replay.
Remote command: 
:TSGen:CONFigure:TSRate on page 70

Orig. Data Rate
Displays the calculated original TS data rate.
Remote command: 
:TSGen:READ:ORIGtsrate on page 70

Packet Length
Requires a *.trp, *.trp_c, *.emc or *.emc_c file loaded into the "TS Player" dia-
log. *.trp files are previously recorded files.

Displays the packet length of the loaded TS player file.
Remote command: 
:TSGen:CONFigure:PLENgth on page 66

Nullpacket Stuffing
Requires a *.trp, *.trp_c, *.emc or *.emc_c file loaded into the "TS Player" dia-
log. *.trp files are previously recorded files.
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Activates nullpacket stuffing.
By default nullpacket stuffing is deactivated. The output data rate of the TS player
equals the original data rate as defined in the TS player file. Equal rates ensure that
the time references in the tables of the played TS stream are correct during replay.
"On" Activate stuffing, if you need a higher rate than the original data rate.

Null packets are inserted into the data stream.
To ensure correct time references in the stream tables, activate pro-
gram clock reference correction. See "PCR, DTS/PTS" on page 39.

"Off" Deactivate stuffing, if you want to use the same data rate as the origi-
nal data rate.

Remote command: 
:TSGen:CONFigure:STUFfing on page 69

Stop Data
Requires a *.trp, *.trp_c, *.emc or *.emc_c file loaded into the "TS Player" dia-
log. *.trp files are previously recorded files.

Ensures that a standardized TS data stream is always output at the TS output at the
rear of the R&S SMCV100B.
In pause or stop status, the TS generator generates "test packets", which have data
and header parts that can be configured using the Test TS Packet.
Remote command: 
:TSGen:CONFigure:STOPdata on page 69

3.7.2.2  Stuffing settings

The tab provides settings to configure stuffing.
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Settings

Test TS Packet.............................................................................................................. 37
PID Test Packet.............................................................................................................37
PID (Hex)...................................................................................................................... 37
Payload Test/Stuff......................................................................................................... 37
PRBS............................................................................................................................ 38

Test TS Packet
Specifies the structure of the test transport stream packet that is fed to the modulator.
"Head/184 Payload"

A sync byte (0x47) followed by three header bytes and 184 payload
bytes.

"Sync/187 Payload"
A sync byte (0x47) followed by 187 payload bytes.

"Head/200 Payload"
A sync byte (0x47) followed by three header bytes and 200 payload
bytes.

"Sync/203 Payload"
A sync byte (0x47) followed by 203 payload bytes.

"Head/204 Payload"
A sync byte (0x47) followed by three header bytes and 204 payload
bytes.

"Sync/207 Payload"
A sync byte (0x47) followed by 207 payload bytes.

Remote command: 
:TSGen:CONFigure:TSPacket on page 69

PID Test Packet
If a header is present in the test packet ("Test TS Packet > Head/184 Payload"), you
can specify a fixed or variable packet identifier (PID).
"Null" The header of the test transport stream packets has a fixed setting of

null packet header 1FFF (hex).
"Variable" Uses the header value defined with PID (Hex).
Remote command: 
:TSGen:CONFigure:PIDTestpack on page 66

PID (Hex)
Sets the PID.
If "PID Test Packet > Null", "PID (Hex) = 1FFF" is fixed.
If "PID Test Packet > Variable", you can edit the value.
Remote command: 
:TSGen:CONFigure:PID on page 65

Payload Test/Stuff
Defines the payload area content of the TS packet.

TS player



T-DMB/DAB configuration and settingsR&S®SMCVB-K156

38User Manual 1179.1029.02 ─ 06

"PRBS" PRBS data in accordance with ITU-T O.151
See also chapter "Internal Modulation Data" in the R&S SMCV100B
User Manual.

"0x00" Exclusively 00 (hex) data
"0xFF" Exclusively FF (hex) data
Remote command: 
:TSGen:CONFigure:PAYLoad on page 65

PRBS
Sets the length of the PRBS sequence.
You can select a PRBS 15 or a PRBS 23 sequence as specified by ITU-T O.151.
Remote command: 
:TSGen:CONFigure:PRBS[:SEQuence] on page 66

3.7.3  Seamless loop settings

Displaying the tab requires a *.trp, *.trp_c, *.emc or *.emc_c file loaded into the
"TS Player" dialog. *.trp files are previously recorded files.

Access:

► Select "TS Player > Seamless Loop".

The tab provides settings to configure settings for playing the file in a loop.

Settings:

Continuity Counter........................................................................................................ 38
PCR, DTS/PTS............................................................................................................. 39
TDT/TOT....................................................................................................................... 39

Continuity Counter
Activates the correction of the continuity counters in the replayed TS data stream. The
correction allows you to decode the stream without interruption when the play file is
looping.
Remote command: 
:TSGen:CONFigure:SEAMless:CC on page 67

TS player
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PCR, DTS/PTS
Activates the correction of time stamps in the replayed TS data stream. The correction
allows you to decode the stream without interruption when the play file is looping.
If you set "Nullpacket Stuffing = On" and "PCR, DTS/PTS = On", the time stamps in the
streams are corrected when nullpackets are inserted into the stream.
Remote command: 
:TSGen:CONFigure:SEAMless:PCR on page 67

TDT/TOT
Activates the correction of the time and date table in the replayed TS data stream. The
correction allows you to decode the stream without interruption when the play file is
looping.
Remote command: 
:TSGen:CONFigure:SEAMless:TT on page 67

3.8  Local IP data network settings

Access:

1. Select "Input Signal > General > Source > External".

2. Select "Input Signal > General > Input > IP"

3. Select "Input Signal > IP Channel x > Local IP Data Network".

The tab provides access to local IP data settings to configure the board address.

The remote commands to configure local IP data network settings are described in
Chapter 5.7, "BCIP subsystem", on page 71.

How to: Chapter 4.1.1, "How to apply an external IP input signal", on page 42

Local IP data network settings
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Settings:

Network Status..............................................................................................................40
Restart Network............................................................................................................ 40
Hostname......................................................................................................................40
Address Mode............................................................................................................... 40
IP Address.....................................................................................................................41
Protocol......................................................................................................................... 41
Subnet Mask................................................................................................................. 41
Show Connector............................................................................................................41
MAC Address................................................................................................................ 41

Network Status
Indicates that the instrument is connected to the network.
If the instrument is disconnected, try "Restart Network".
Remote command: 
:SYSTem:COMMunicate:BCIP<hw>:NETWork:STATus on page 73

Restart Network
Terminates the network connection of the instrument and sets it up again later. You can
use this function to fix network problems.
Note: This function restarts only the connection of the instrument to the network. It
does not impact the network itself.
Remote command: 
:SYSTem:COMMunicate:BCIP<hw>:NETWork:RESTart on page 73

Hostname
Displays the hostname.
Displayed is the board name, that is the name of the IP data board of the
R&S SMCV100B, e.g. SMCV100B-123456-IP-Data.

Each instrument is delivered with an assigned hostname, a logical name which can be
used instead of the IP address. With the default network settings, the IP address is
allocated by the DHCP server. This address can change each time the instrument is
reconnected. Unlike the IP address, the hostname name does not change.
Note:
This function is password-protected. Unlock the protection level 1 to access it.
We recommend that you do not change the default network settings or the hostname
to avoid problems with the network connection.
Remote command: 
:SYSTem:COMMunicate:BCIP<hw>:NETWork:COMMon:HOSTname on page 72

Address Mode
Selects the mode for assigning the IP address.
"Auto (DHCP)"

Assigns the IP address automatically, provided the network supports
DHCP.

"Static" Enables you to assign the IP address manually.

Local IP data network settings
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Remote command: 
:SYSTem:COMMunicate:BCIP<hw>:NETWork:IPADdress:MODE on page 72

IP Address
Displays the IP address of the instrument in the local IP data network.
By default, the R&S SMCV100B is configured to use dynamic TCP/IP configuration
and to obtain the whole address information automatically.
If the network does not support DHCP or the attempt does not succeed, the instrument
tries to obtain the IP address via Zeroconf (APIPA) protocol. IP addresses assigned via
Zeroconf start with the number blocks 169.254.*.*.

Note: An IP address that is assigned via the Zeroconf protocol although the network
requires an IP address assigned via the DHCP server can cause network connection
failures.
Remote command: 
:SYSTem:COMMunicate:BCIP<hw>:NETWork:IPADdress on page 72

Protocol
Sets the protocol type of the input IP data.
The current firmware supports UDP and UDP/RTP.
Remote command: 
:SYSTem:COMMunicate:BCIP<hw>:NETWork:PROTocol on page 73

Subnet Mask
Displays the bit group of the subnet in the host identifier.
To assign the subnet mask manually, select "Address Mode > Static".
Remote command: 
:SYSTem:COMMunicate:BCIP<hw>:NETWork:IPADdress:SUBNet:MASK
on page 72

Show Connector
Accesses a dialog that displays the physical location of the selected connector on the
front/rear panel of the instrument.

MAC Address
Displays the MAC address, a unique identifier of the network adapter in the
R&S SMCV100B.
Remote command: 
:SYSTem:COMMunicate:BCIP<hw>:NETWork:MACaddress on page 73

Local IP data network settings
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4  Performing T-DMB/DAB signal generation
tasks
This chapter tells you how to configure the R&S SMCV100B to generate signals for
simple receiver tests.

● Configuring the input signal.....................................................................................42

4.1  Configuring the input signal

This chapter provides an overview of the different input signals, that the
R&S SMCV100B uses as modulation data.

● How to apply an external IP input signal.................................................................42
● How to apply an external ETI input signal...............................................................44
● How to generate an internal ETI signal...................................................................46

4.1.1  How to apply an external IP input signal

To connect the R&S SMCV100B to local IP data network

1. Connect the IP source to the "IP Data" connector of the R&S SMCV100B.
See chapter "Connecting to IP Data Interface" in the R&S SMCV100B Getting Star-
ted user manual.

2. Select "Input Signal > General > Source > External".

3. Select "Input Signal > General > Input > IP".

4. In the "IP Channel x" side tab, click "Local IP Data Network".

By default, the R&S SMCV100B assigns the IP address automatically using DHCP
("Address Mode > Auto (DHCP)").

5. If "Network Status > Disconnected", try "Restart Network".

Configuring the input signal
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The R&S SMCV100B is connected to the local IP data network.

6. If DHCP does not assign an IP address, assign the IP address manually.
See chapter "How to Assign the IP Address" in the R&S SMCV100B user manual.

7. Specify the protocol type of the input IP data.
The current firmware supports UDP and UDP/RTP.

To configure an external IP ETI input signal

The R&S SMCV100B is connected to a local IP data network, see "To connect the
R&S SMCV100B to local IP data network" on page 42.

1. Specify general IP input signal properties:

a) Select "Input Signal > General > Source > External".
b) Select "Input > IP".
c) Specify the IP ETI Channel, e.g. "IP ETI Channel > 1".

The "IP Channel 1" side tab appears, where you can configure the IP connection
for channel 1 and channel-independent local IP network settings.

1

1 = IP channel notation: IP ETI Channel

Configuring the input signal
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2. Optionally, activate "Stuffing" to adjust the ETI data rate.

3. Specify the IP ETI channel properties, e.g. for "IP ETI Channel > 1":

a) Define the input type, e.g. "Type > Multicast".
b) Specify the "Multicast Address" that is the destination IPv4 address of the IP

connection.
Note: Use the destination address also in the IP data source, e.g. a stream
program.

c) Specify the port that is the destination port of the IP connection.
Note: Use the destination port also in the IP data source.

d) Specify the IGMPv3 source address that is the source IPv4 address of the IP
connection.
A source address different from "0.0.0.0" accepts only data originating from the
specified IP address.

e) Optionally, to check availability of the "IGMPv3 Source Address", click "Ping
Source Address"
● If "Ping Result > Ping: Successful", the source address is available.
● If "Ping Result > Ping: Transmit Failed. Destination Host Unreachable", try

another address.
f) Optionally, specify a name for the IP connection, e.g. "Alias > Service".
g) To activate the IP channel, select "Input IP > On".

The R&S SMCV100B is prepared for receiving IP ETI data that is input at the "IP
Data" connector.

4.1.2  How to apply an external ETI input signal

To connect to the external ETI input interface

1. Use a double-shielded 75 Ω BNC cable for connection between R&S SMCV100B
and the external MPEG ETI data source.
See also Section "Cable selection and electromagnetic interference (EMI)" in the
R&S SMCV100B Getting Started user manual.

Configuring the input signal
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2. At the R&S SMCV100B, connect the cable to the "User 1" connector.
The connector is on the rear panel of the R&S SMCV100B.
How to: Section "To connect to pluggable connectors" in the R&S SMCV100B Get-
ting Started user manual.

To specify the ETI input interface at the R&S SMCV100B

The R&S SMCV100B is connected to an MPEG ETI data source via the "User 1" con-
nector.

1. Select "Input Signal > General > Source > External".

2. Select "General > Global Connectors".

3. In the "Global Connectors" dialog, configure the "User 1" connector for an ETI input
signal:

a) Select "Direction > Input".
b) Select "Signal > ETI".

To configure an external ETI input signal

The R&S SMCV100B is prepared for receiving an ETI input signal at the "User 1" con-
nector.

► Specify general ETI input signal properties:

a) Select "Input Signal > General > Source > External".
b) Select "Input > TS IN".

The "Input Format > ETI" is fixed.

Configuring the input signal
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The R&S SMCV100B is prepared for receiving ETI data, that is input at the "User
1" connector.

4.1.3  How to generate an internal ETI signal

To play an ETI file with the "TS Player"

1. Select "Input Signal > Source > TS Player".

The "TS Player" button appears below.

2. Click "TS Player".

The "TS Player" dialog for playing ETI data files opens.

3. Click "Play" to play the default file DIVER.trp.
Playing the file requires no option. Alternatively, play files with extension *.dab
and *.eti.

To load and play a stream library file

1. Load the file from its storage location:

● External storage device (HDD, memory stick): Load the file from the /usb/
directory.

● Internal memory (SSD): Load the file from the user directory /var/user/
Note: Library files are encrypted files. Loading the library file at the
R&S SMCV100B requires installation of the corresponding library option. See
"Required options" on page 30.

2. To load the file at the R&S SMCV100B, open the "TS Player" application in digital
broadcast standard ("<Broadcast_Standard>") dialogs:

a) Select "Baseband" > "<Broadcast_Standard>" > "Input Signal".
b) Select "Source" > "TS Player".
c) Select "TS Player" button.
d) Select "Select File".

3. To select the file, navigate to the storage location (1).

4. Select "TS-Player" > "Play".

Configuring the input signal
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The R&S SMCV100B processes the stream file.

5. Select "<Broadcast_Standard>" > "State" > "On", to activate the baseband signal.

6. In the block diagram, select "RF" > "On".

The stream file is modulated onto the RF carrier and output at the "RF 50 Ω" con-
nector.

Configuring the input signal
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5  Remote-control commands
The following commands are required to generate signals with the T-DMB/DAB option
in a remote environment. We assume that the R&S SMCV100B has already been set
up for remote operation in a network as described in the R&S SMCV100B documenta-
tion. A knowledge about the remote control operation and the SCPI command syntax
are assumed.

Conventions used in SCPI command descriptions
For a description of the conventions used in the remote command descriptions, see
section "Remote-Control Commands" in the R&S SMCV100B user manual.

Common suffixes

The following common suffixes are used in the remote commands:

Suffix Value range Description

SOURce<hw> 1 Available baseband signals

Programming examples

This description provides simple programming examples. The purpose of the examples
is to present all commands for a given task. In real applications, one would rather
reduce the examples to an appropriate subset of commands.

The programming examples have been tested with a software tool which provides an
environment for the development and execution of remote tests. To keep the example
as simple as possible, only the "clean" SCPI syntax elements are reported. Non-exe-
cutable command lines (e.g. comments) start with two // characters.

At the beginning of the most remote control program, an instrument preset/reset is rec-
ommended to set the instrument to a definite state. The commands *RST and
SYSTem:PRESet are equivalent for this purpose. *CLS also resets the status registers
and clears the output buffer.

The following commands specific to the T-DMB/DAB are described here:

● General commands.................................................................................................49
● Input commands......................................................................................................51
● Network commands................................................................................................ 57
● SFN delay commands.............................................................................................58
● Special commands..................................................................................................60
● TSGen subsystem...................................................................................................63
● BCIP subsystem......................................................................................................71
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5.1  General commands

Example: Saving the current configuration
SOURce1:BB:TDMB:SETTing:STORe "/var/user/my_TDMB"
// Saves the file "my_TDMB.tdmb" in the directory as above.
*RST
SOURce1:BB:TDMB:SETTing:CATalog?
// Response: "my_TDMB"
SOURce1:BB:TDMB:SETTing:LOAD "/var/user/my_TDMB"

SOURce1:BB:TDMB:STATe 1
SOURce1:BB:TDMB:SETTing:DELete "/var/user/my_TDMB"

Commands

[:SOURce<hw>]:BB:TDMB:PRESet................................................................................... 49
[:SOURce<hw>]:BB:TDMB:STATe..................................................................................... 49
[:SOURce<hw>]:BB:TDMB:SETTing:CATalog?................................................................... 49
[:SOURce<hw>]:BB:TDMB:SETTing:DELete...................................................................... 50
[:SOURce<hw>]:BB:TDMB:SETTing:LOAD........................................................................ 50
[:SOURce<hw>]:BB:TDMB:SETTing:STORe.......................................................................50

[:SOURce<hw>]:BB:TDMB:PRESet

Sets the parameters of the digital standard to their default values (*RST values speci-
fied for the commands).

Not affected is the state set with the command SOURce<hw>:BB:TDMB:STATe.

Example: See Example"Saving the current configuration" on page 49.

Usage: Event

Manual operation: See "Set To Default" on page 15

[:SOURce<hw>]:BB:TDMB:STATe <State>

Activates the standard and deactivates all the other digital standards and digital modu-
lation modes in the same path.

Parameters:
<State> 1 | ON | 0 | OFF

*RST: 0

Manual operation: See "State" on page 14

[:SOURce<hw>]:BB:TDMB:SETTing:CATalog?

Queries the files with settings in the default directory. Listed are files with the file exten-
sion *.tdmb.

General commands
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Return values: 
<FileNames> <filename1>,<filename2>,...

Returns a string of filenames separated by commas.

Example: See Example"Saving the current configuration" on page 49.

Usage: Query only

Manual operation: See "Save/Recall" on page 15

[:SOURce<hw>]:BB:TDMB:SETTing:DELete <Delete>

Deletes the selected file from the default or the specified directory. Deleted are files
with extension *.tdmb.

Parameters:
<Filename> "<filename>"

Filename or complete file path; file extension can be omitted

Example: See Example"Saving the current configuration" on page 49.

Usage: Setting only

Manual operation: See "Save/Recall" on page 15

[:SOURce<hw>]:BB:TDMB:SETTing:LOAD <Recall>

Loads the selected file from the default or the specified directory. Loaded are files with
extension *.tdmb.

Parameters:
<Filename> "<filename>"

Filename or complete file path; file extension can be omitted

Example: See Example"Saving the current configuration" on page 49.

Manual operation: See "Save/Recall" on page 15

[:SOURce<hw>]:BB:TDMB:SETTing:STORe <Save>

Saves the current settings into the selected file; the file extension (*.tdmb) is
assigned automatically.

Parameters:
<Filename> "<filename>"

Filename or complete file path

Example: See Example"Saving the current configuration" on page 49.

Manual operation: See "Save/Recall" on page 15

General commands
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5.2  Input commands

● General commands.................................................................................................51
● Info commands........................................................................................................52
● IP subsystem...........................................................................................................54

5.2.1  General commands

[:SOURce<hw>]:BB:TDMB:ETIinput?.................................................................................51
[:SOURce<hw>]:BB:TDMB:INPut.......................................................................................51
[:SOURce<hw>]:BB:TDMB:INPut:FORMat......................................................................... 51
[:SOURce<hw>]:BB:TDMB:INPut:ETIChannel.....................................................................51
[:SOURce<hw>]:BB:TDMB:MID?.......................................................................................52
[:SOURce<hw>]:BB:TDMB:NST?...................................................................................... 52
[:SOURce<hw>]:BB:TDMB:SOURce..................................................................................52

[:SOURce<hw>]:BB:TDMB:ETIinput?

Displays whether a valid ETI signal is present and the signal type.

Return values: 
<EtISignal> INValid | ENI | E559 | E537

Usage: Query only

Manual operation: See "ETI Signal" on page 18

[:SOURce<hw>]:BB:TDMB:INPut <TdmbInput>

Sets the external input interface.

Parameters:
<TdmbInput> IP | TS

Manual operation: See "Input" on page 17

[:SOURce<hw>]:BB:TDMB:INPut:FORMat <TdmbFormat>

Sets the format of the input signal.

Parameters:
<TdmbFormat> ETI

Manual operation: See "Input Format" on page 17

[:SOURce<hw>]:BB:TDMB:INPut:ETIChannel <ETIChannel>

Selects the ETI channel that is received over the IP interface.

Input commands
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Parameters:
<ETIChannel> 1 | 2

*RST: 1

Manual operation: See "IP ETI Channel" on page 17

[:SOURce<hw>]:BB:TDMB:MID?

Displays the DAB mode identity.

A mode identity of 0 corresponds to an invalid ETI signal.

Return values: 
<ModeIdentity> integer

Range: 0  to  4
*RST: 0

Usage: Query only

Manual operation: See "Mode Identity (MID)" on page 18

[:SOURce<hw>]:BB:TDMB:NST?

Displays the number of streams (NST) contained in the ETI signal.

Return values: 
<NumOfStreams> integer

Range: 0  to  64
*RST: 0

Usage: Query only

Manual operation: See "Number of Streams" on page 18

[:SOURce<hw>]:BB:TDMB:SOURce <TdmbSource>

Sets the modulation source for the input signal.

Parameters:
<TdmbSource> EXTernal | TSPLayer | TESTsignal

*RST: EXTernal

Manual operation: See "Source" on page 16

5.2.2  Info commands

[:SOURce<hw>]:BB:TDMB:DATarate<ch>?........................................................................ 53
[:SOURce<hw>]:BB:TDMB:PROTection:LEVel<ch>?........................................................... 53
[:SOURce<hw>]:BB:TDMB:PROTection:PROFile<ch>?....................................................... 53
[:SOURce<hw>]:BB:TDMB:SCID<ch>................................................................................53

Input commands
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[:SOURce<hw>]:BB:TDMB:DATarate<ch>?

Return values: 
<DataRAte> integer

Range: 0  to  1824
*RST: 0

Usage: Query only

Manual operation: See "Data Rate / kbit/s" on page 19

[:SOURce<hw>]:BB:TDMB:PROTection:LEVel<ch>?

Queries the protection level. The level depends on the protection profile.

Return values: 
<ProtLevel> UNDefined | EP1A | EP2A | EP3A | EP4A | EP1B | EP2B |

EP3B | EP4B | UP1 | UP2 | UP3 | UP4 | UP5
UP1|UP2|UP3|UP4|UP5
Protection level 1 to 5 with UEP protection profile
EP1A|EP2A|EP3A|EP4A
Protection level 1A to 4A with EEP protection profile
EP1B|EP2B|EP3B|EP4B
Protection level 1B to 4B with EEP protection profile
UNDefined
No protection profile detected

Usage: Query only

Manual operation: See "Protection Level" on page 19

[:SOURce<hw>]:BB:TDMB:PROTection:PROFile<ch>?

Queries the protection profile.

Return values: 
<ProtProfile> UEP | EEP

UEP
Unequal error protection
EEP
Equal error protection

Usage: Query only

Manual operation: See "Protection Profile" on page 19

[:SOURce<hw>]:BB:TDMB:SCID<ch> <SubChannelId>

Queries the subchannel identifiers per subchannel.

Input commands
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Parameters:
<SubChannelId> integer

Range: 0  to  63
*RST: 0

Example: See

Manual operation: See "Subchannel Id (Hex)" on page 19

5.2.3  IP subsystem

The SOURce:BB:INPut:IP subsystem contains the commands for configuring input
IP data from a local IP data network.

To configure local IP data network parameters, see Chapter 5.7, "BCIP subsystem",
on page 71.

Common suffixes

The following common suffixes are used in the SOURce:BB:INPut:IP remote com-
mands:

Suffix Value range Description

IP<ch> 1 to 4 IP channel number

Example: Configure IP channel 2 properties
// Use the data from IP channel 2 as input for modulation data.
SOURce1:BB:INPut:IP2:STATe ON
// Specify alias as "Alias 2".
SOURce1:BB:INPut:IP2:ALIas "Alias 2"

//********************************************************************************
// Define Unicast properties.
//********************************************************************************
SOURce1:BB:INPut:IP2:TYPe UNI
// Local IP data interface is configured for Unicast reception
SOURce1:BB:INPut:IP2:PORT 6002

//********************************************************************************
// Define multicast properties.
//********************************************************************************
SOURce1:BB:INPut:IP2:TYPe MULT
// Local IP data interface is configured for Multicast reception
SOURce1:BB:INPut:IP2:MULTicast:ADDRess?
// Response: "226.0.0.0"
SOURce1:BB:INPut:IP2:IGMP:SOURce:ADDRess?
// Response: "0.0.0.0"
SOURce1:BB:INPut:IP2:IGMP:SOURce:ADDRess "192.168.10.1"
SOURce1:BB:INPut:IP2:IGMP:SOURce:PING

Input commands
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SOURce1:BB:INPut:IP2:IGMP:SOURce:RESult?
// Response: "Ping: Successful"

Commands

[:SOURce<hw>]:BB:INPut:IP<ch>[:STATe]..........................................................................55
[:SOURce<hw>]:BB:INPut:IP<ch>:ALIas............................................................................ 55
[:SOURce<hw>]:BB:INPut:IP<ch>:PORT............................................................................55
[:SOURce<hw>]:BB:INPut:IP<ch>:TYPE............................................................................ 56
[:SOURce<hw>]:BB:INPut:IP<ch>:MULticast:ADDRess....................................................... 56
[:SOURce<hw>]:BB:INPut:IP<ch>:IGMP[:SOURce]:ADDRess..............................................56
[:SOURce<hw>]:BB:INPut:IP<ch>:IGMP[:SOURce]:PING.................................................... 56
[:SOURce<hw>]:BB:INPut:IP<ch>:IGMP[:SOURce]:RESult?................................................ 57

[:SOURce<hw>]:BB:INPut:IP<ch>[:STATe] <Alias>

Activates/deactivates the "IP Channel x" as IP input.

Specify the current IP ETI Channel with the command
SOURce1:BB:DigStd:INPut:ETIChannel. DigStd stands for the IP ETI Channel
in the corresponding broadcast standard.

Parameters:
<Alias> 1 | ON | 0 | OFF

*RST: 0

Example: See Example"Configure IP channel 2 properties" on page 54.

Manual operation: See "Input IP" on page 22

[:SOURce<hw>]:BB:INPut:IP<ch>:ALIas <Alias>

Specifies an alias, i.e. name for the IP connection.

Parameters:
<Alias> string

Example: See Example"Configure IP channel 2 properties" on page 54.

Manual operation: See "Alias" on page 22

[:SOURce<hw>]:BB:INPut:IP<ch>:PORT <Port>

Sets the port of the input IP data at the "IP Data" connector.

Parameters:
<Port> integer

Range: 0  to  65535
*RST: 6002

Example: See Example"Configure IP channel 2 properties" on page 54.

Manual operation: See "Port" on page 22

Input commands
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[:SOURce<hw>]:BB:INPut:IP<ch>:TYPE <Type>

Sets the IP input type.

Parameters:
<Type> UNIcast | MULTicast

UNIcast
Analyzes all unicast IP packets that arrive at the specified port.
See [:SOURce<hw>]:BB:INPut:IP<ch>:PORT on page 55.
MULTicast
When an IP address is in the multicast address range, an
attempt is made to join a multicast group using IGMP. Set multi-
cast address and port.
See:
[:SOURce<hw>]:BB:INPut:IP<ch>:MULticast:ADDRess
on page 56
[:SOURce<hw>]:BB:INPut:IP<ch>:PORT on page 55
*RST: UNIcast

Example: See Example"Configure IP channel 2 properties" on page 54.

Manual operation: See "Type" on page 22

[:SOURce<hw>]:BB:INPut:IP<ch>:MULticast:ADDRess

Sets the destination IP address (IPv4) of the IP connection.

Parameters:
<Address> string

Range: 224.0.0.0  to  239.255.255.255

Example: See Example"Configure IP channel 2 properties" on page 54.

Manual operation: See "Multicast Address" on page 22

[:SOURce<hw>]:BB:INPut:IP<ch>:IGMP[:SOURce]:ADDRess

Specifies the IGMP source address of the network.

Parameters:
<Address> string

Example: See Example"Configure IP channel 2 properties" on page 54.

Manual operation: See "IGMPv3 Source Address" on page 23

[:SOURce<hw>]:BB:INPut:IP<ch>:IGMP[:SOURce]:PING

Triggers pinging of the IGMP source address in the local IP data network. Query the
result via [:SOURce<hw>]:BB:INPut:IP<ch>:IGMP[:SOURce]:RESult?
on page 57.
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Example: See Example"Configure IP channel 2 properties" on page 54.

Usage: Event

Manual operation: See "Ping Source Address" on page 23

[:SOURce<hw>]:BB:INPut:IP<ch>:IGMP[:SOURce]:RESult?

Queries the result of pinging the IGMP source address.

See [:SOURce<hw>]:BB:INPut:IP<ch>:IGMP[:SOURce]:PING on page 56.

Return values: 
<PingResult> string

Returns ping messages.

Example: See Example"Configure IP channel 2 properties" on page 54.

Usage: Query only

Manual operation: See "Ping Result" on page 23

5.3  Network commands

[:SOURce<hw>]:BB:TDMB:NET........................................................................................ 57
[:SOURce<hw>]:BB:TDMB:TII:MAIN..................................................................................57
[:SOURce<hw>]:BB:TDMB:TII:STATe.................................................................................58
[:SOURce<hw>]:BB:TDMB:TII:SUB................................................................................... 58

[:SOURce<hw>]:BB:TDMB:NET <NetwMode>

Sets the network mode.

Parameters:
<NetwMode> MFN | SFN

Manual operation: See "Network Mode" on page 24

[:SOURce<hw>]:BB:TDMB:TII:MAIN <TiiMain>

Defines the TII main ID.

Parameters:
<TiiMain> integer

Range: 0  to  69
*RST: 0

Manual operation: See "TII Main ID" on page 25
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[:SOURce<hw>]:BB:TDMB:TII:STATe <TiiState>

Enables/disables the transmission of the TII signal.

Parameters:
<TiiState> 1 | ON | 0 | OFF

Manual operation: See "TII" on page 25

[:SOURce<hw>]:BB:TDMB:TII:SUB <TiiSub>

Defines the TII sub ID.

Parameters:
<TiiSub> integer

Range: 1  to  23
*RST: 1

Manual operation: See "TII Sub ID" on page 25

5.4  SFN delay commands

[:SOURce<hw>]:BB:TDMB:DELay:COMPensation?............................................................ 58
[:SOURce<hw>]:BB:TDMB:DELay:DELay.......................................................................... 58
[:SOURce<hw>]:BB:TDMB:DELay:DEViation......................................................................59
[:SOURce<hw>]:BB:TDMB:DELay:NETWork?.................................................................... 59
[:SOURce<hw>]:BB:TDMB:DELay:PROCess?....................................................................59
[:SOURce<hw>]:BB:TDMB:DELay:STATic.......................................................................... 60
[:SOURce<hw>]:BB:TDMB:DELay:TOTal?..........................................................................60

[:SOURce<hw>]:BB:TDMB:DELay:COMPensation?

Displays the time span by which signal processing is artificially delayed in order to ach-
ieve a constant "TX Delay".

Return values: 
<DelayComp> float

Range: -1.0000000  to  1.0000000
Increment: 0.0000001
*RST: 0
Default unit: s

Usage: Query only

Manual operation: See "Tx Compensation Delay" on page 27

[:SOURce<hw>]:BB:TDMB:DELay:DELay <DelayTx>

Sets the signal turnaround time through the transmitter.
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Parameters:
<DelayTx> float

Range: 0.0000000  to  1.0000000
Increment: 0.0000001
*RST: 0
Default unit: s

Manual operation: See "Tx Delay" on page 27

[:SOURce<hw>]:BB:TDMB:DELay:DEViation <DelayDev>

Sets the maximum permitted deviation of the transmission time relative to the internally
regulated reference frequency.

Parameters:
<DelayDev> integer

Range: 0.000001  to  0.0005000
Increment: 0.0000001
*RST: 0.00001
Default unit: s

Manual operation: See "Max. Deviation Time" on page 27

[:SOURce<hw>]:BB:TDMB:DELay:NETWork?

Queries the compensating delay.

If the delay is added to the network path delay, the overall delay is constant and of
known value.

Return values: 
<NetwDelay> float

Range: 0.0000000  to  1.0000000
Increment: 0.0000001
*RST: 0

Usage: Query only

Manual operation: See "Network Compensation" on page 26

[:SOURce<hw>]:BB:TDMB:DELay:PROCess?

Queries the minimum signal turnaround time through the transmitter.

Return values: 
<DelayProc> float

Range: 0.0000000  to  1.0000000
Increment: 0.0000001
*RST: s

Usage: Query only
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Manual operation: See "Tx Processing Delay" on page 26

[:SOURce<hw>]:BB:TDMB:DELay:STATic <DelayStatic>

Sets the delay in order to shift the time of transmission positively or negatively.

Parameters:
<DelayStatic> float

Range: -1.0000000  to  1.0000000
Increment: 0.0000001
*RST: 0
Default unit: s

Manual operation: See "Static Delay" on page 27

[:SOURce<hw>]:BB:TDMB:DELay:TOTal?

Queries the total cycle time of the signal through the transmitter.

Return values: 
<DelayTotal> float

Range: -1.0000000  to  3.0000000
Increment: 0.0000001
*RST: 0
Default unit: s

Usage: Query only

Manual operation: See "Total Delay" on page 27

5.5  Special commands

The section contains commands to configure settings, that deviate from the broadcast
standard specification.

Example: Configuring special settings
SOURce1:BB:TDMB:SPECial:SETTings:STATe?
// Response: "0"
// Special settings are disabled to conform with the broadcast standard.
// Enable special settings to test deviations from the standard.

// Query standard-conform configuration of special settings.
SOURce1:BB:TDMB:SPECial:TRANsmission:MODE?
// Response: "MID"
SOURce1:BB:TDMB:SPECial:TRANsmission:MODE:SELect?
// Response: "1"
SOURce1:BB:TDMB:SPECial:TESTsignal:STATe?
// Response: "0"
SOURce1:BB:TDMB:SPECial:TESTsignal:SCID?
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// Response: "#H0"
// Subchannel ID is 0x00 in hexadecimal representation.

// Configue non standard-conform special settings.
SOURce1:BB:TDMB:SPECial:TRANsmission:MODE MAN
SOURce1:BB:TDMB:SPECial:TRANsmission:MODE:SELect 2
SOURce1:BB:TDMB:SPECial:TESTsignal:STATe 1
// Specify PRBS test signal.
SOURce1:BB:TDMB:PRBS:SEQuence P20_1
SOURce1:BB:TDMB:SPECial:TESTsignal:SCID #H1
// Subchannel ID is 0x01 in hexadecimal representation.
// Apply special settings.
SOURce1:BB:TDMB:SPECial:SETTings:STATe 1

Commands

[:SOURce<hw>]:BB:TDMB[:SPECial]:SETTings[:STATe]......................................................61
[:SOURce<hw>]:BB:TDMB[:SPECial]:TRANsmission:MODE................................................61
[:SOURce<hw>]:BB:TDMB[:SPECial]:TRANsmission:MODE:SELECT.................................. 62
[:SOURce<hw>]:BB:TDMB:PRBS[:SEQuence]................................................................... 62
[:SOURce<hw>]:BB:TDMB[:SPECial]:TESTsignal:SCID.......................................................62
[:SOURce<hw>]:BB:TDMB[:SPECial]:TESTsignal[:STATe]....................................................63

[:SOURce<hw>]:BB:TDMB[:SPECial]:SETTings[:STATe] <SpecialSett>

Enables/disables special settings.

The setting allows you to switch between standard-compliant and user-defined channel
coding.

Parameters:
<SpecialSett> 1 | ON | 0 | OFF

Example: See Example"Configuring special settings" on page 60.

Manual operation: See "Special Settings" on page 28

[:SOURce<hw>]:BB:TDMB[:SPECial]:TRANsmission:MODE <TransMode>

Sets the transmission mode.

This setting takes effect, if special settings are active:

SOURce1:BB:TDMB:SPECial:SETTings:STATe 1
Parameters:
<TransMode> MID | MANual

Example: See Example"Configuring special settings" on page 60.

Manual operation: See "Transmission Mode" on page 28
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[:SOURce<hw>]:BB:TDMB[:SPECial]:TRANsmission:MODE:SELECT
<ModeSelect>

Selects the transmission mode.

This setting takes effect, if special settings are active:

SOURce1:BB:TDMB:SPECial:SETTings:STATe 1
Parameters:
<ModeSelect> integer

Range: 1  to  4
*RST: 1

Example: See Example"Configuring special settings" on page 60.

Manual operation: See "Select Transmission Mode" on page 29

[:SOURce<hw>]:BB:TDMB:PRBS[:SEQuence] <Prbs>

Sets the test signal sequence, that is transmitted in the subchannel.

You can select a PRBS 15, PRBS 20 and PRBS 23 sequence as specified by ITU-T
O.151. Also you can define a sequence of zeroes (0x00).

This setting takes effect, if special settings are active:

SOURce1:BB:TDMB:SPECial:SETTings:STATe 1
Parameters:
<Prbs> P15_1 | P20_1 | ZERO | P23_1

*RST: ZERO

Example: See Example"Configuring special settings" on page 60.

Manual operation: See "PRBS" on page 20

[:SOURce<hw>]:BB:TDMB[:SPECial]:TESTsignal:SCID <SCID>

Sets the ID of a subchannel (stream) that transmits a test signal (PRBS) instead of
data.

This setting takes effect, if special settings are active:

SOURce1:BB:TDMB:SPECial:SETTings:STATe 1
Parameters:
<SCID> integer

Range: 0  to  64
*RST: 0

Example: See Example"Configuring special settings" on page 60.

Manual operation: See "Test Signal SCID" on page 29
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[:SOURce<hw>]:BB:TDMB[:SPECial]:TESTsignal[:STATe] <PrbsTestSignal>

Activates transfer of a PRBS test signal to a subchannel instead of ETI input data.

This setting takes effect, if special settings are active:

SOURce1:BB:TDMB:SPECial:SETTings:STATe 1
Parameters:
<PrbsTestSignal> 1 | ON | 0 | OFF

*RST: 0

Example: See Example"Configuring special settings" on page 60.

Manual operation: See "PRBS Test Signal" on page 29

5.6  TSGen subsystem

The TSGen subsystem contains the commands for configuring the TS player.

Example: Playing a TS player file
//*********************************************************************************
// Select a file, e.g. a user-defined setting.
//*********************************************************************************
TSGen:CONFigure:PLAYfile "/var/user/my_test_player_test.trp"
// Selects the file "my_test_player_test" with extension *.trp.

//*********************************************************************************
// Within the file, define a section, that you want to play.
// You can set start/stop position for a maximum section length of 10 hours.
//*********************************************************************************
TSGen:CONFigure:SEEK:STARt 60000 // milliseconds
// Section start is after one minute from the original file start.
// The first minute is ignored.
TSGen:CONFigure:SEEK:STOP 120000 // milliseconds
// Section stop is after one minute from the original file start.
// The total section length is one minute.

//*********************************************************************************
// Navigate to a certain position within the file/section of the file.
//*********************************************************************************
TSGen:CONFigure:SEEK:POSition 100000 // milliseconds
// The current player position of file/section of the file is at 1 minute 40 seconds.

//*********************************************************************************
// Reset play-related settings
//*********************************************************************************
TSGen:CONFigure:SEEK:RESet

//*********************************************************************************
// Pause, stop, play the file.

TSGen subsystem



Remote-control commandsR&S®SMCVB-K156

64User Manual 1179.1029.02 ─ 06

//*********************************************************************************
TSGen:CONFigure:COMMand PAUS
// Pauses playing the file.
TSGen:CONFigure:COMMand STOP
// Stops playing the file.
TSGen:CONFigure:COMMand PLAY
// Activates playing the file.

Example: Configuring and monitoring TS player output
//*********************************************************************************
// Configure general and stuffing parameters of the TS player output.
//*********************************************************************************
TSGen:CONFigure:STUFfing ON
TSGen:CONFigure:STOPdata TTSP
TSGen:CONFigure:TSPacket H184
TSGen:CONFigure:PIDTestpacket VAR
TSGen:CONFigure:PID 8100
// Corresponds to a PID = 1FA4 in hexadecimal representation.
TSGen:CONFigure:PAYLoad PRBS
TSGen:CONFigure:PRBS:SEQuence P23_1

//*********************************************************************************
// Monitor TS player output data.
//*********************************************************************************
// You can only change the data rate, if you stop the TS player.
TSGen:CONFigure:COMMand STOP
TSGen:CONFigure:TSRate 350E6
// Corresponds to a net data rate of 350 MBit/s.
TSGen:CONFigure:COMMand PLAY

TSGen:CONFigure:PLENgth?
// Response: "P188"
// Packet length is 188 bytes.
TSGen:READ:ORIGtsrate?
// Response in bit/s: "5018502"

Example: Configuring seamless loop parameters
TSGen:CONFigure:SEAMless:CC ON
TSGen:CONFigure:SEAMless:PCR OFF
TSGen:CONFigure:SEAMless:TT ON

Commands

:TSGen:CONFigure:COMMand......................................................................................... 65
:TSGen:CONFigure:PAYLoad............................................................................................65
:TSGen:CONFigure:PID....................................................................................................65
:TSGen:CONFigure:PIDTestpack.......................................................................................66
:TSGen:CONFigure:PLAYfile.............................................................................................66
:TSGen:CONFigure:PLENgth............................................................................................66
:TSGen:CONFigure:PRBS[:SEQuence]..............................................................................66
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:TSGen:CONFigure:SEAMless:CC.................................................................................... 67
:TSGen:CONFigure:SEAMless:PCR.................................................................................. 67
:TSGen:CONFigure:SEAMless:TT..................................................................................... 67
:TSGen:CONFigure:SEEK:POSition...................................................................................68
:TSGen:CONFigure:SEEK:RESet...................................................................................... 68
:TSGen:CONFigure:SEEK:STARt...................................................................................... 68
:TSGen:CONFigure:SEEK:STOP.......................................................................................68
:TSGen:CONFigure:STOPdata..........................................................................................69
:TSGen:CONFigure:STUFfing........................................................................................... 69
:TSGen:CONFigure:TSPacket...........................................................................................69
:TSGen:CONFigure:TSRate..............................................................................................70
:TSGen:READ:FMEMory.................................................................................................. 70
:TSGen:READ:ORIGtsrate................................................................................................70
:TSGen:READ:PLAYfile:LENGth?......................................................................................70

:TSGen:CONFigure:COMMand <PlayerStatus>

Triggers playing, pausing and stopping of the TS player file selected with :TSGen:
CONFigure:PLAYfile.

Parameters:
<PlayerStatus> STOP | PAUSe | PLAY | RESet

*RST: STOP

Example: See Example"Playing a TS player file" on page 63.

Manual operation: See "Play" on page 34
See "Pause" on page 34
See "Stop" on page 34

:TSGen:CONFigure:PAYLoad <PayLoad>

Determines the payload of the test packet. Also influences the payload of the gener-
ated stuffing packets while the TS player is running.

Parameters:
<PayLoad> HFF | H00 | PRBS

*RST: PRBS

Example: See Example"Configuring and monitoring TS player output"
on page 64.

Manual operation: See "Payload Test/Stuff" on page 37

:TSGen:CONFigure:PID <PID>

The available values depend on the settings of :TSGen:CONFigure:PIDTestpack.

If :TSGen:CONFigure:PIDTestpack is set to NULL,
then :TSGen:CONFigure:PID is 1FFF(hex).

Otherwise the values are variable.
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Parameters:
<PID> integer

Range: 0  to  8191
*RST: 8191

Example: See Example"Configuring and monitoring TS player output"
on page 64.

Manual operation: See "PID (Hex)" on page 37

:TSGen:CONFigure:PIDTestpack <PIDTestpack>

Sets the PID, if :TSGen:CONFigure:TSPacket is H184|H200|H204.

Parameters:
<PIDTestpack> VARiable | NULL

*RST: NULL

Example: See Example"Configuring and monitoring TS player output"
on page 64.

Manual operation: See "PID Test Packet" on page 37

:TSGen:CONFigure:PLAYfile <PlayFile>

Specifies the file path and filename of the TS player file.

Parameters:
<PlayFile> string

Example: See Example"Playing a TS player file" on page 63.

Manual operation: See "Select File" on page 32

:TSGen:CONFigure:PLENgth <PLength>

Queries the packet length of the loaded file.

Parameters:
<PLength> P188 | P204 | P208 | INV

*RST: INV

Example: See Example"Configuring and monitoring TS player output"
on page 64.

Manual operation: See "Packet Length" on page 35

:TSGen:CONFigure:PRBS[:SEQuence] <PRBS>

Sets the length of the PRBS sequence.

TSGen subsystem



Remote-control commandsR&S®SMCVB-K156

67User Manual 1179.1029.02 ─ 06

Parameters:
<PRBS> P15_1 | P23_1

*RST: P23_1

Example: See Example"Configuring and monitoring TS player output"
on page 64.

Manual operation: See "PRBS" on page 38

:TSGen:CONFigure:SEAMless:CC <CC>

Activates the correction of the continuity counters in the replayed TS data stream. The
correction allows you to decode the stream without interruption when the play file is
looping.

Parameters:
<CC> 1 | ON | 0 | OFF

*RST: 0

Example: See Example"Configuring seamless loop parameters"
on page 64.

Manual operation: See "Continuity Counter" on page 38

:TSGen:CONFigure:SEAMless:PCR <PCR>

Activates the correction of time stamps in the replayed TS data stream. The correction
allows you to decode the stream without interruption when the play file is looping.

Parameters:
<PCR> 1 | ON | 0 | OFF

*RST: 0

Example: See Example"Configuring seamless loop parameters"
on page 64.

Manual operation: See "PCR, DTS/PTS" on page 39

:TSGen:CONFigure:SEAMless:TT <TT>

Activates the correction of the time and date table in the replayed TS data stream. The
correction allows you to decode the stream without interruption when the play file is
looping.

Parameters:
<TT> 1 | ON | 0 | OFF

*RST: 0

Example: See Example"Configuring seamless loop parameters"
on page 64.

Manual operation: See "TDT/TOT" on page 39
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:TSGen:CONFigure:SEEK:POSition <Position>

Sets the position, that is the current playing time position.

You can select a value in a 10-hour range.

Parameters:
<Position> float

Range: 0  to  36000000
Increment: 0.1
*RST: 0

Example: See Example"Playing a TS player file" on page 63.

Manual operation: See "Running/Position Player [hh:mm:ss:fff]" on page 32
See "Position Player [hh:mm:ss.fff]" on page 34

:TSGen:CONFigure:SEEK:RESet

Resets the following parameters to their default state:
● :TSGen:CONFigure:SEEK:STARt on page 68
● :TSGen:CONFigure:SEEK:STOP on page 68

Example: See Example"Playing a TS player file" on page 63.

Usage: Event

Manual operation: See "Reset Window" on page 34

:TSGen:CONFigure:SEEK:STARt <Start>

Sets an individual start time.

You can select a value in a 10-hour range.

Parameters:
<Start> float

Range: 0  to  36000000
Increment: 0.1
*RST: 0

Example: See Example"Playing a TS player file" on page 63.

Manual operation: See "Start [hh:mm:ss.fff]" on page 33

:TSGen:CONFigure:SEEK:STOP <Stop>

Sets an individual stop time.

You can select a value in a 10-hour range.
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Parameters:
<Stop> float

Range: 0  to  36000000
Increment: 0.1
*RST: 23040.2

Example: See Example"Playing a TS player file" on page 63.

Manual operation: See "Stop [hh:mm:ss.fff]" on page 34

:TSGen:CONFigure:STOPdata <StopData>

Ensures that a standardized TS data stream is always output at the TS output at the
rear of the R&S SMCV100B.

Parameters:
<StopData> TTSP | NONE

*RST: NONE

Example: See Example"Configuring and monitoring TS player output"
on page 64.

Manual operation: See "Stop Data" on page 36

:TSGen:CONFigure:STUFfing <Stuffing>

Activates nullpacket stuffing.

Parameters:
<Stuffing> 1 | ON | 0 | OFF

*RST: 0

Example: See Example"Configuring and monitoring TS player output"
on page 64.

Manual operation: See "Nullpacket Stuffing" on page 35

:TSGen:CONFigure:TSPacket <TSPaket>

Sets the structure of the generated test packets in pause or stop status.

Parameters:
<TSPaket> H184 | H200 | H204 | S187 | S203 | S207

S187|S203|S207
A sync byte (0x47) followed by 187/203/207 payload bytes.
H184|H200|H204
A sync byte (0x47) followed by three header bytes and
184/200/204 payload bytes.
*RST: H184

Example: See Example"Configuring and monitoring TS player output"
on page 64.

TSGen subsystem



Remote-control commandsR&S®SMCVB-K156

70User Manual 1179.1029.02 ─ 06

Manual operation: See "Test TS Packet" on page 37

:TSGen:CONFigure:TSRate <TSRate>

Sets the output data rate of the player.

Parameters:
<TSRate> integer

Range: 1  to  35E7
*RST: 5018502

Example: See Example"Configuring and monitoring TS player output"
on page 64.

Manual operation: See "Data Rate" on page 35

:TSGen:READ:FMEMory <FMemory>

Queries the file size of the TS player file.

Parameters:
<FMemory> integer

Range: 0  to  10
*RST: 0

Example: See Example"Configuring and monitoring TS player output"
on page 64.

Manual operation: See "Select File" on page 32

:TSGen:READ:ORIGtsrate <ORIGtsrate>

Displays the calculated original TS data rate.

Parameters:
<ORIGtsrate> integer

Range: 1  to  350000000
*RST: 5018502

Example: See Example"Configuring and monitoring TS player output"
on page 64.

Manual operation: See "Orig. Data Rate" on page 35

:TSGen:READ:PLAYfile:LENGth?

Queries calculated original loop time.

Return values: 
<Length> integer

Range: 0  to  100
*RST: 0
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Example: See Example"Configuring and monitoring TS player output"
on page 64.

Usage: Query only

Manual operation: See "Select File" on page 32

5.7  BCIP subsystem

The SYSTem:COMMunicate:BCIP subsystem contains the commands for configuring
local IP data network parameters.

Common suffixes

The following common suffixes are used in the remote commands:

Suffix Value range Description

BCIP<hw> 1 Available local IP LAN interfaces

Example: Retrieving information on local network-related settings
//********************************************************************************
// Monitor IP interface 1 local network status.
//********************************************************************************
SYSTem:COMMunicate:BCIP1:NETWork:STATus?
// Response: "0"
// The instrument is diconnected from the local IP network.
SYSTem:COMMunicate:BCIP1:NETWork:RESTart
SYSTem:COMMunicate:BCIP1:NETWork:STATus?
// Response: "1"

//********************************************************************************
// Query local IP data network properties.
//********************************************************************************
SYSTem:COMMunicate:BCIP1:NETWork:COMMon:HOSTname?
// Response: "SMCV100B-123456-IP-Data"
SYSTem:COMMunicate:BCIP1:NETWork:IPADdress:MODE STAT
SYSTem:COMMunicate:BCIP1:NETWork:IPADdress "10.113.0.104"
SYSTem:COMMunicate:BCIP1:NETWork:IPADdress:SUBNet:MASK "255.255.252.0"
SYSTem:COMMunicate:BCIP1:NETWork:MACaddress?
// Response: "00 90 B8 21 89 F8"
SYSTem:COMMunicate:BCIP1:NETWork:PROTocol?
// Response: "UDP"

Commands

:SYSTem:COMMunicate:BCIP<hw>:NETWork:COMMon:HOSTname................................... 72
:SYSTem:COMMunicate:BCIP<hw>:NETWork:IPADdress....................................................72
:SYSTem:COMMunicate:BCIP<hw>:NETWork:IPADdress:MODE......................................... 72
:SYSTem:COMMunicate:BCIP<hw>:NETWork:IPADdress:SUBNet:MASK............................. 72
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:SYSTem:COMMunicate:BCIP<hw>:NETWork:MACaddress................................................ 73
:SYSTem:COMMunicate:BCIP<hw>:NETWork:PROTocol.................................................... 73
:SYSTem:COMMunicate:BCIP<hw>:NETWork:RESTart.......................................................73
:SYSTem:COMMunicate:BCIP<hw>:NETWork:STATus........................................................73

:SYSTem:COMMunicate:BCIP<hw>:NETWork:COMMon:HOSTname <Hostname>

Sets an individual hostname for the vector signal generator.

Note:We recommend that you do not change the hostname to avoid problems with the
network connection. If you change the hostname, be sure to use a unique name.

Parameters:
<Hostname> string

Example: See Example"Retrieving information on local network-related
settings" on page 71.

Manual operation: See "Hostname" on page 40

:SYSTem:COMMunicate:BCIP<hw>:NETWork:IPADdress

Sets the IP address.

Example: See Example"Retrieving information on local network-related
settings" on page 71.

Manual operation: See "IP Address" on page 41

:SYSTem:COMMunicate:BCIP<hw>:NETWork:IPADdress:MODE <IPMode>

Selects manual or automatic setting of the IP address.

Parameters:
<IPMode> AUTO | STATic

*RST: AUTO

Example: See Example"Retrieving information on local network-related
settings" on page 71.

Manual operation: See "Address Mode" on page 40

:SYSTem:COMMunicate:BCIP<hw>:NETWork:IPADdress:SUBNet:MASK

Sets the subnet mask.

Example: See Example"Retrieving information on local network-related
settings" on page 71.

Manual operation: See "Subnet Mask" on page 41

BCIP subsystem
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:SYSTem:COMMunicate:BCIP<hw>:NETWork:MACaddress <MACAddress>

Queries the MAC address of the network adapter.

Parameters:
<MACAddress> string

Range: 00:00:00:00:00:00  to  ff:ff:ff:ff:ff:ff

Example: See Example"Retrieving information on local network-related
settings" on page 71.

Manual operation: See "MAC Address" on page 41

:SYSTem:COMMunicate:BCIP<hw>:NETWork:PROTocol <Protocol>

Specifies the network protocol.

Parameters:
<Protocol> UDP

*RST: UDP

Example: See Example"Retrieving information on local network-related
settings" on page 71.

Manual operation: See "Protocol" on page 41

:SYSTem:COMMunicate:BCIP<hw>:NETWork:RESTart

Triggers a restart of the network.

Example: See Example"Retrieving information on local network-related
settings" on page 71.

Usage: Event

Manual operation: See "Restart Network" on page 40

:SYSTem:COMMunicate:BCIP<hw>:NETWork:STATus <NetworkStatus>

Queries the network connection state.

Parameters:
<NetworkStatus> 1 | ON | 0 | OFF

*RST: n.a. (no preset. default: 0)

Example: See Example"Retrieving information on local network-related
settings" on page 71.

Manual operation: See "Network Status" on page 40

BCIP subsystem
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Glossary: Abbreviations
A

ASI: Asynchronous Serial Interface

C
COFDM: Coded Orthogonal Frequency Division Multiplex

D
DAB: Digital Audio Broadcasting

DHCP: Dynamic Host Configuration Protocol

E
EEP: Equal Error Protection

ETI: Ensemble Transport Interface

H
HDB3: High Density Bipolar code of order 3

I
IGMP: Internet Group Management Protocol

IGMPv3: Internet Group Management Protocol version 3

M
MAC: Media Access Control

MFN: Multi-frequency Network

MID: Mode Identity

MPEG: Moving Picture Experts Group
https://mpeg.chiariglione.org/

N
NA: Network Adapted
More: See ITU-T G.704.

NI: Network Independent
More: See ITU-T G.703.

NST: Number of Streams

 

https://mpeg.chiariglione.org/
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O
OFDM: Orthogonal Frequency Division Multiplex

P
PID: Packet Identifier

PRBS: Pseudo-Random Bit Sequence

R
RTP: Real-time Transport Protocol

S
SFN: Single-frequency Network

SMPTE: Society of Motion Picture and Television Engineers
https://www.smpte.org/

SSTC: Sub-channel Stream Characteristics

STC: Stream Characteristics

T
TCP: Transmission Control Protocol

TII: Transmitter Identification Information

TS: Transport Stream

U
UDP: User Datagram Protocol

UEP: Unequal Error Protection

https://www.smpte.org/
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Glossary: Specifications
E

ETS 300 799: Digital Audio Broadcasting (DAB); Distribution interfaces; Ensemble
Transport Interface (ETI)
https://www.etsi.org/deliver/etsi_i_ets/300700_300799/300799/

ETSI EN 300 401: Radio Broadcasting Systems; Digital Audio Broadcasting (DAB) to
mobile, portable and fixed receivers
https://www.etsi.org/deliver/etsi_en/300400_300499/300401/

I
ITU-T G.703: ITU-T Recommendation G.703
Physical/electrical characteristics of hierarchical digital interfaces
https://www.itu.int/rec/T-REC-G.703/en

ITU-T G.704: ITU-T Recommendation G.704
Synchronous frame structures used at 1544, 6312, 2048, 8448 and 44 736 kbit/s hier-
archical levels
https://www.itu.int/rec/T-REC-G.704/en

ITU-T O.151: ITU-T Recommendation O.151
https://www.itu.int/rec/T-REC-O.151-199210-I/en

 

https://www.etsi.org/deliver/etsi_i_ets/300700_300799/300799/
https://www.etsi.org/deliver/etsi_en/300400_300499/300401/
https://www.itu.int/rec/T-REC-G.703/en
https://www.itu.int/rec/T-REC-G.704/en
https://www.itu.int/rec/T-REC-O.151-199210-I/en
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