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1  Welcome to the IEEE 802.16 WiMAX digital
standard
The R&S SMW-K49 is a firmware application that adds functionality to generate sig-
nals in accordance with the IEEE 802.16 standard WiMAX.

The R&S SMW-K49 key features

The R&S SMW simulates IEEE 802.16 WiMAX at the physical level. The IEEE 802.16
WiMAX signals are generated in the arbitrary waveform mode; the signal is first calcu-
lated and then output. The following list gives an overview of the main functions:
● Support of IEEE 802.16TM-2004/Cor1/D5 and IEEE 802.16e-2005
● Physical layer modes: OFDM, OFDMA, OFDMA/WiBro
● Forward and reverse link, FDD and TDD duplexing
● Burst types: FCH, DL-MAP, UL-MAP, DCD, UCD, HARQ; ranging, fast feedback,

data
● Multiple zones and segments (PUSC, FUSC, AMC, sounding)
● Diversity and MIMO coding (DL, UL)

This user manual contains a description of the functionality that the application pro-
vides, including remote control operation.

All functions not discussed in this manual are the same as in the base unit and are
described in the R&S SMW user manual. The latest version is available at:

www.rohde-schwarz.com/manual/SMW200A

Installation

You can find detailed installation instructions in the delivery of the option or in the
R&S SMW service manual.

1.1  Accessing the IEEE 802.16 WiMAX dialog

To open the dialog with IEEE 802.16 WiMAX settings

► In the block diagram of the R&S SMW, select "Baseband > IEEE 802.16 WiMAX".

A dialog box opens that display the provided general settings.

The signal generation is not started immediately. To start signal generation with the
default settings, select "State > On".

Accessing the IEEE 802.16 WiMAX dialog

https://www.rohde-schwarz.com/manual/smw200a
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1.2  What's new

This manual describes firmware version FW 5.30.047.xx and later of the
R&S®SMW200A.

Compared to the previous version, it provides the new features listed below:
● Time-based triggering, see "Time Based Trigger" on page 23 and "Trigger Time"

on page 24.
● Editorial changes

1.3  Documentation overview

This section provides an overview of the R&S SMW user documentation. Unless speci-
fied otherwise, you find the documents at:

www.rohde-schwarz.com/manual/smw200a

1.3.1  Getting started manual

Introduces the R&S SMW and describes how to set up and start working with the prod-
uct. Includes basic operations, typical measurement examples, and general informa-
tion, e.g. safety instructions, etc. A printed version is delivered with the instrument.

1.3.2  User manuals and help

Separate manuals for the base unit and the software options are provided for down-
load:
● Base unit manual

Contains the description of all instrument modes and functions. It also provides an
introduction to remote control, a complete description of the remote control com-
mands with programming examples, and information on maintenance, instrument
interfaces and error messages. Includes the contents of the getting started manual.

● Software option manual
Contains the description of the specific functions of an option. Basic information on
operating the R&S SMW is not included.

The contents of the user manuals are available as help in the R&S SMW. The help
offers quick, context-sensitive access to the complete information for the base unit and
the software options.

All user manuals are also available for download or for immediate display on the Inter-
net.

Documentation overview

http://www.rohde-schwarz.com/manual/smw200a


Welcome to the IEEE 802.16 WiMAX digital standardR&S®SMW-K49

9User Manual 1175.6732.02 ─ 19

1.3.3  Tutorials

The R&S SMW provides interactive examples and demonstrations on operating the
instrument in form of tutorials. A set of tutorials is available directly on the instrument.

1.3.4  Service manual

Describes the performance test for checking compliance with rated specifications, firm-
ware update, troubleshooting, adjustments, installing options and maintenance.

The service manual is available for registered users on the global Rohde & Schwarz
information system (GLORIS):

https://gloris.rohde-schwarz.com

1.3.5  Instrument security procedures

Deals with security issues when working with the R&S SMW in secure areas. It is avail-
able for download on the internet.

1.3.6  Printed safety instructions

Provides safety information in many languages. The printed document is delivered with
the product.

1.3.7  Data sheets and brochures

The data sheet contains the technical specifications of the R&S SMW. It also lists the
options and their order numbers and optional accessories.

The brochure provides an overview of the instrument and deals with the specific char-
acteristics.

See www.rohde-schwarz.com/brochure-datasheet/smw200a

1.3.8  Release notes and open source acknowledgment (OSA)

The release notes list new features, improvements and known issues of the current
firmware version, and describe the firmware installation.

The software makes use of several valuable open source software packages. An open-
source acknowledgment document provides verbatim license texts of the used open
source software.

See www.rohde-schwarz.com/firmware/smw200a

Documentation overview

https://gloris.rohde-schwarz.com
http://www.rohde-schwarz.com/brochure-datasheet/smw200a
http://www.rohde-schwarz.com/firmware/smw200a
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1.3.9  Application notes, application cards, white papers, etc.

These documents deal with special applications or background information on particu-
lar topics.

See www.rohde-schwarz.com/application/smw200a and www.rohde-schwarz.com/
manual/smw200a

1.3.10  Videos

Find various videos on Rohde & Schwarz products and test and measurement topics
on YouTube: https://www.youtube.com/@RohdeundSchwarz

On the menu bar, search for your product to find related videos.

Figure 1-1: Product search on YouTube

1.4  Scope

Tasks (in manual or remote operation) that are also performed in the base unit in the
same way are not described here.
In particular, it includes:
● Managing settings and data lists, like saving and loading settings, creating and

accessing data lists, or accessing files in a particular directory.
● Information on regular trigger, marker and clock signals and filter settings, if appro-

priate.
● General instrument configuration, such as checking the system configuration, con-

figuring networks and remote operation
● Using the common status registers

For a description of such tasks, see the R&S SMW user manual.

1.5  Notes on screenshots

When describing the functions of the product, we use sample screenshots. These
screenshots are meant to illustrate as many as possible of the provided functions and
possible interdependencies between parameters. The shown values may not represent
realistic usage scenarios.

Notes on screenshots

http://www.rohde-schwarz.com/application/smw200a
http://www.rohde-schwarz.com/manual/smw200a
http://www.rohde-schwarz.com/manual/smw200a
https://www.youtube.com/@RohdeundSchwarz
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The screenshots usually show a fully equipped product, that is: with all options instal-
led. Thus, some functions shown in the screenshots may not be available in your par-
ticular product configuration.

Notes on screenshots
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2  About the IEEE 802.16 WiMAX option
This section lists required options and provides an overview of the supported features
in more details.

2.1  Required options

The basic equipment layout for generating WiMAX signals includes the:
● Standard baseband generator (R&S SMW-B10)
● Baseband main module (R&S SMW-B13)
● Frequency option (e.g. R&S SMW-B1003)
● Digital standard WiMAX IEEE 802.16 (R&S SMW-K49)

You can generate signals via play-back of waveform files at the signal generator. To
create the waveform file using R&S WinIQSIM2, you do not need a specific option.

To play back the waveform file at the signal generator, you have two options:
● Install the R&S WinIQSIM2 option of the digital standard, e.g. R&S SMW-K255 for

playing LTE waveforms
● If supported, install the real-time option of the digital standard, e.g. R&S SMW-K55

for playing LTE waveforms

For more information, see data sheet.

2.2  WiMAX modulation system

The option R&S SMW-K49 supports the following WiMAX modulation features:
● Configuration of OFDM (orthogonal frequency division multiplexing) and OFDMA

(orthogonal frequency division multiple access) physical layer mode.
● Downlink and Uplink mode.
● Pre-defined settings for receiver tests.
● All frame duration settings defined by the standard, including a "User" mode with

freely configurable frame duration, and a "continuous" mode. In "continuous" mode,
gaps between bursts/subframes are eliminated.

● Sequence length of up to 511 frames.
● Up to 64 bursts per frame/zone with independent power setting.
● Channel bandwidth and sampling rate settings according to the ETSI, MMDS,

WCS, U-NII or WiBro bands, or alternatively arbitrary settings in "User" mode.
● Full RS/CC, CC and CTC channel coding.
● BPSK, QPSK, 16-QAM or 64-QAM modulation, independently configurable for any

of the 64 bursts.

WiMAX modulation system
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● FCH, DL-MAP and UL-MAP burst generation in "automatic" mode (using user-
defined signal configuration parameters) or in "user" mode, with arbitrary data.

● Ranging bursts in uplink
● Up to eight zones per frame in OFDMA mode
● Predefined data sources such as PN9, PN11 and others, or arbitrary user data.
● Optional generic MAC headers and CRC for each burst.
● Subchannelization modes.
● Clipping for reducing the crest factor.
Table 2-1: Parameters of the modulation system IEEE 802.16 WiMAX

Digital standard 802.16-2004 Meets IEEE 802.16™-2004/Cor2/D4 and
802.16e-2005

Physical layer modes OFDM, OFDMA, OFDMA – WiBro

Link direction forward link and reverse link

Frame durations 2, 2.5, 4, 5, 8, 10, 12.5, 20 ms, continuous, user-
definable

Sequence length 1 to 511 frames (depending on frame duration)

Clipping Vector or scalar clipping, applied before filtering

Marker modes Restart, frame start, frame active part, pulse, pat-
tern, on/off ratio

Parameters in OFDM mode  

Duplexing TDD, FDD

Predefined frames Short, mid and long length test messages for testing
receivers with all modulation types and RS-CC rates

Level reference FCH/Burst or preamble level

Frequency bands ETSI, MMDS, WCS, U-NII, User

Channel bandwidth 1.25 MHz to 30 MHz, depending on selected fre-
quency band

Sampling rate 1.5 MHz to 32 MHz, depending on channel band-
width

Tg / Tb settings 1/4, 1/8, 1/16, 1/32

FFT size 256 (fixed)

Number of possible subchannels in subchanneliza-
tion mode

1, 2, 4, 8, 16 (all)

Number of bursts per frame 0 – 64

Preamble / midamble modes Burst preamble / midambles off, burst preamble in
downlink, midamble repetition 5, 9 or 17 in uplink

Modulation & RS-CC rates BPSK ½, QPSK ½, QPSK ¾, 16-QAM ½, 16-QAM
¾, 64-QAM 2/3, 64-QAM ¾

Data all 0 , all 1, pattern (up to 64 bit), PN 9 to PN 23,
data lists

WiMAX modulation system
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Digital standard 802.16-2004 Meets IEEE 802.16™-2004/Cor2/D4 and
802.16e-2005

Burst power range -80 dB - +10 dB

MAC functions One generic MAC header + CRC available per burst

Parameters in OFDMA mode  

Duplexing TDD

Level reference Subframe RMS power or preamble level (downlink
only)

Frequency bands ETSI, MMDS, WCS, U-NII, WiBro, User

Channel bandwidth 1.25 MHz to 30 MHz, depending on selected fre-
quency band

Sampling rate 1.5 MHz to 32 MHz, depending on channel band-
width

Tg / Tb settings ¼, 1/8, 1/16, 1/32

FFT size 128, 512, 1024 or 2048

Subcarrier permutation PUSC, FUSC (downlink only), AMC 2x3, sounding
(uplink only)

Number of bursts per frame 0 – 64

Modulation & CC rates QPSK ½, QPSK ¾, 16-QAM ½, 16-QAM ¾, 64-
QAM ½, 64-QAM 2/3, 64-QAM ¾, 64-QAM 5/6

Data all 0 , all 1, pattern (up to 64 bit), PN 9 to PN 23,
data lists

Burst power range -80 dB - +10 dB

MAC functions One generic MAC header + CRC available per burst

Parameters in OFDMA - WiBro mode
(identical to OFDMA)

 

Duplexing TDD

Level reference Subframe RMS power or preamble level (downlink
only)

Frequency bands ETSI, MMDS, WCS, U-NII, WiBro, User

Channel bandwidth 1.25 MHz to 30 MHz, depending on selected fre-
quency band

Sampling rate 1.5 MHz to 32 MHz, depending on channel band-
width

Tg / Tb settings ¼, 1/8, 1/16, 1/32

FFT size 128, 512, 1024 or 2048

Subcarrier permutation PUSC, FUSC (downlink only), AMC 2x3, sounding
(uplink only)

Number of bursts per frame 0 – 64

WiMAX modulation system
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Digital standard 802.16-2004 Meets IEEE 802.16™-2004/Cor2/D4 and
802.16e-2005

Modulation & CC rates QPSK ½, QPSK ¾, 16-QAM ½, 16-QAM ¾, 64-
QAM ½, 64-QAM 2/3, 64-QAM ¾, 64-QAM 5/6

Data all 0 , all 1, pattern (up to 64 bit), PN 9 to PN 23,
data lists

Burst power range -80 dB - +10 dB

MAC functions One generic MAC header + CRC available per burst

WiMAX modulation system
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3  WiMAX configuration and settings
Access:

► Select "Baseband" > "IEEE 802.16 WiMAX".

The remote commands required to define these settings are described in Chapter 4,
"Remote-control commands", on page 128.

● General settings for WiMAX signals........................................................................16
● Trigger settings....................................................................................................... 21
● Marker settings........................................................................................................26
● Clock settings..........................................................................................................29
● Local and global connectors settings......................................................................30
● Frame configuration general settings......................................................................30
● Frame configuration OFDM.....................................................................................33
● FCH configuration downlink OFDM.........................................................................43
● Generate UL-MAP uplink OFDM.............................................................................46
● DL-MAP configuration downlink OFDM.................................................................. 48
● UL-MAP configuration downlink OFDM.................................................................. 50
● More parameters uplink OFDM...............................................................................52
● MAC header configuration OFDM...........................................................................53
● Frame configuration OFDMA.................................................................................. 55
● Zone configuration OFDMA.................................................................................... 62
● Sounding zone configuration OFDMA.....................................................................72
● CSTD OFDMA........................................................................................................ 79
● Data configuration OFDMA.....................................................................................81
● FCH configuration downlink OFDMA...................................................................... 89
● DL-MAP configuration downlink OFDMA................................................................91
● UL-MAP configuration downlink OFDMA................................................................96
● Generate UL-MAP uplink OFDMA........................................................................ 101
● Ranging uplink OFDMA........................................................................................ 103
● HARQ configuration OFDMA................................................................................ 105
● Fast feedback configuration OFDMA.................................................................... 112
● SUB-DL-UL-MAP configuration OFDMA...............................................................114
● MAC header configuration OFDMA.......................................................................116
● PDU MAC configuration OFDMA.......................................................................... 119
● Filter / clipping settings..........................................................................................121

3.1  General settings for WiMAX signals

In this dialog, IEEE 802.16 WiMAX digital standard is enabled and reset and all the
settings for the signal in both transmission directions are made.

Access:

► Select "Baseband > IEEE 802.16 WiMAX > General".

General settings for WiMAX signals
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This tab contains the standard general settings, valid for the signal in both trans-
mission directions.

Settings:

State..............................................................................................................................17
Set to Default................................................................................................................ 17
Save/Recall................................................................................................................... 19
Generate Waveform File…............................................................................................19
Physical Layer Mode.....................................................................................................19
Version.......................................................................................................................... 20
Duplexing...................................................................................................................... 20
Link Direction................................................................................................................ 21
Filter / Clipping.............................................................................................................. 21

State
Activates the standard and deactivates all the other digital standards and digital modu-
lation modes in the same path.
Remote command: 
[:SOURce<hw>]:BB:WIMax:STATe on page 133

Set to Default
Calls the default settings. The values of the main parameters are listed in the following
table.

Parameter Value

General Settings  

State Not affected by "Set to default"

Physical Layer Mode OFDM

Version 802.16-2004/Cor1-2005 and 802.16e-2005

General settings for WiMAX signals
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Parameter Value

Duplexing TDD

Link Direction Downlink

Frame Duration 10 ms

Sequence Length 1 frame

Predefined Frames User

Level Reference FCH/Burst

Clipping Off

OFDM mode  

Frequency Band ETSI

Channel Bandwidth 1.75 MHz

Sampling Rate 2.00 MHz

BSID (4 LSBs) 0

Tg/Tb 1/4

Number of used subchannels 16 (all)

Frame Preamble Long

FCH Configuration On, "Auto" mode, F"rame Number Offset = 0" and
"Configuration Change Count = 0"

Nr. of Bursts 1

OFDMA mode  

Frequency Band ETSI

Channel Bandwidth 1.75 MHz

Sampling Rate 2.00 MHz

n = 8/7

Tg/Tb 1/4

FFT Size 2048

Subcarrier Permutation PUSC

Subchannel 0 to 59 State On

OFDMA - WiBro mode  

Frequency Band WiBro

Channel Bandwidth 8.75 MHz

Sampling Rate 10 MHz

n = 8/7

Tg/Tb 1/8

FFT Size 1024

General settings for WiMAX signals
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Parameter Value

Subcarrier Permutation PUSC

Subchannel 0 to 59 State On

Frame Duration 5 ms

Remote command: 
[:SOURce<hw>]:BB:WIMax:PRESet on page 131

Save/Recall
Accesses the "Save/Recall" dialog, that is the standard instrument function for saving
and recalling the complete dialog-related settings in a file. The provided navigation
possibilities in the dialog are self-explanatory.
The settings are saved in a file with predefined extension. You can define the filename
and the directory, in that you want to save the file.
See also, chapter "File and Data Management" in the R&S SMW user manual.
Remote command: 
[:SOURce<hw>]:BB:WIMax:SETTing:CATalog? on page 132
[:SOURce<hw>]:BB:WIMax:SETTing:LOAD on page 132
[:SOURce<hw>]:BB:WIMax:SETTing:STORe on page 133
[:SOURce<hw>]:BB:WIMax:SETTing:DELete on page 132

Generate Waveform File…
With enabled signal generation, triggers the instrument to save the current settings of
an arbitrary waveform signal in a waveform file with predefined extension *.wv. You
can define the filename and the directory, in that you want to save the file.
Using the ARB modulation source, you can play back waveform files and/or process
the file to generate multi-carrier or multi-segment signals.
Remote command: 
[:SOURce<hw>]:BB:WIMax:WAVeform:CREate on page 134

Physical Layer Mode
Selects the physical layer mode.
The settings of the frame are provided in the subdialog "Frame Configuration" (see
Frame configuration OFDM ,Frame configuration OFDMA ) in accordance with the
selection.
"OFDM" The OFDM mode supports signal generation according to IEEE

802.16-2004 section 8.3 with a fixed FFT size of 256.
"OFDMA" Orthogonal Frequency Division Multiple Access (OFDMA) groups

multiple subcarriers of the OFDM into subchannels. A single client or
subscriber station can transmit using all of the subchannels within the
carrier space. Multiple clients can transmit with each using a portion
of the total number of subchannels simultaneously. OFDMA thus ena-
bles a more flexible use of resources. It can support nomadic and
mobile operation.

General settings for WiMAX signals
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"OFDMA - WiBro"
The OFDMA – WiBro (Wireless Broadband) mode groups multiple
subcarriers of the OFDM into subchannels. A single client or sub-
scriber station can transmit using all of the subchannels within the
carrier space. Multiple clients can transmit with each using a portion
of the total number of subchannels simultaneously. OFDMA thus ena-
bles a more flexible use of resources. It can support nomadic and
mobile operation.
The OFDMA – WiBro mode is identical to the OFDMA mode. When
selecting OFDMA – WiBro, these parameters are set to their WiBro
defaults (see Set to Default):
● "Frame Duration = 5ms"
● "Frequency Band = WiBro"
● "Channel Bandwidth = 8.75 MHz"
● "Sampling Rate = 10 MHz"
● "Tg/Tb = 1/8"
● "FFT Size = 1024"

Remote command: 
[:SOURce<hw>]:BB:WIMax:MODE on page 131

Version
Selects the version of the standard to use.
"802.16 Rev2/D3"

Selecting "802.16 Rev2/D3" make sure that all signal parameters are
in line with the latest revision 2 version of the standard.
Using this mode is recommended.

"802.16-2004/Cor1-2005 and 802.16e-2005"
Selecting 802.16-2004/Cor1-2005 and 802.16e-2005 provides back-
ward compatibility for devices that do not yet comply with the latest
release 2 version.

Remote command: 
[:SOURce<hw>][:BB]:WIMax:SVERsion on page 134

Duplexing
Selects the duplexing. The duplexing mode determines how the uplink and downlink
signals are separated.
"TDD" In TDD mode, the same frequency is used for both directions of

transmission (uplink and downlink). With one baseband, either down-
link or uplink frames can be generated.

"FDD" (OFDM only)
In FDD mode, different frequencies are used for downlink and uplink
directions. If only one link direction is considered at once, the IEEE
802.16 standard defines no differences between TDD and FDD sig-
nals on the physical layer.
The FDD mode has been provided for convenience, it completely fills
the defined frame with bursts to simulate a continuous transmission
environment. Use TDD mode instead if FDD devices are to be tested
with frames including transmission gaps.

General settings for WiMAX signals
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Remote command: 
[:SOURce<hw>]:BB:WIMax:DUPLexing on page 129

Link Direction
Selects the transmission direction.
"Downlink" The transmission direction selected is base station to subscriber sta-

tion. The signal corresponds to that of a base station.
"Uplink" The transmission direction selected is subscriber station to base sta-

tion. The signal corresponds to that of a subscriber station.
Remote command: 
[:SOURce<hw>]:BB:WIMax:LINK on page 131

Filter / Clipping...
Access to the dialog for setting baseband filtering, clipping and the sequence length of
the arbitrary waveform component, see Chapter 3.29, "Filter / clipping settings",
on page 121 .

3.2  Trigger settings

Access:

► Select "Baseband" > "IEEE 802.16 WiMAX" > "Trigger In".

This tab provides settings to select and configure the trigger, like trigger source,
trigger mode and trigger delays, and to arm or trigger an internal trigger manually.
The header of the tab displays the status of the trigger signal and trigger mode. As
in the tabs "Marker" and "Clock", this tab provides also access to the settings of the
related connectors.

Routing and activating a trigger signal

1. Define the effect of a trigger event and the trigger signal source.

a) Select "Trigger In" > "Mode".
b) Select "Trigger In" > "Source".

2. For external trigger signals, define the connector for signal input. See Chapter 3.5,
"Local and global connectors settings", on page 30.
You can map trigger signals to one or more USER x or T/M connectors.

Local and global connectors settings allow you to configure the signal mapping, the
polarity, the trigger threshold and the input impedance of the input connectors.

Trigger settings



WiMAX configuration and settingsR&S®SMW-K49

22User Manual 1175.6732.02 ─ 19

3. Activate baseband signal generation. In the block diagram, set "Baseband" > "On".

The R&S SMW starts baseband signal generation after the configured trigger
event.

About baseband trigger signals

This section focuses on the available settings.

For information on how these settings affect the signal, refer to section "Basics on ..."
in the R&S SMW user manual.

Settings:

Trigger settings common to all basebands....................................................................22
Mode............................................................................................................................. 22
Signal Duration Unit...................................................................................................... 23
Signal Duration..............................................................................................................23
Running/Stopped.......................................................................................................... 23
Time Based Trigger.......................................................................................................23
Trigger Time.................................................................................................................. 24
Arm................................................................................................................................24
Execute Trigger.............................................................................................................24
Source...........................................................................................................................24
Sync. Output to External Trigger/Sync. Output to Trigger.............................................25
External Inhibit/Trigger Inhibit........................................................................................25
External Delay/Trigger Delay........................................................................................ 26

Trigger settings common to all basebands
To enable simultaneous signal generation in all basebands, the R&S SMW couples the
trigger settings in the available basebands in any instrument's configuration involving
signal routing with signal addition. For example, in MIMO configuration, routing and
summing of basebands or of streams.
The icon  indicates that common trigger settings are applied.
You can access and configure the common trigger source and trigger mode settings in
any of the basebands. An arm or a restart trigger event applies to all basebands, too.
You can still apply different delay to each of the triggers individually.

Mode
Selects trigger mode, i.e. determines the effect of a trigger event on the signal genera-
tion.
For more information, refer to chapter "Basics" in the R&S SMW user manual.
● "Auto"

The signal is generated continuously.
● "Retrigger"

The signal is generated continuously. A trigger event (internal or external) causes a
restart.

● "Armed Auto"
The signal is generated only when a trigger event occurs. Then the signal is gener-
ated continuously.

Trigger settings
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An "Arm" stops the signal generation. A subsequent trigger event (internal or exter-
nal) causes a restart.

● "Armed Retrigger"
The signal is generated only when a trigger event occurs. Then the signal is gener-
ated continuously. Every subsequent trigger event causes a restart.
An "Arm" stops signal generation. A subsequent trigger event (internal or external)
causes a restart.

● "Single"
The signal is generated only when a trigger event occurs. Then the signal is gener-
ated once to the length specified at "Signal Duration".
Every subsequent trigger event (internal or external) causes a restart.

Remote command: 
[:SOURce<hw>]:BB:WIMax[:TRIGger]:SEQuence on page 141

Signal Duration Unit
Defines the unit for describing the length of the signal sequence to be output in the
"Single" trigger mode.
Remote command: 
[:SOURce<hw>]:BB:WIMax:TRIGger:SLUNit on page 145

Signal Duration
Requires trigger "Mode" > "Single".
Enters the length of the trigger signal sequence.
Use this parameter, for example, for the following applications:
● To output the trigger signal partly.
● To output a predefined sequence of the trigger signal.
Remote command: 
[:SOURce<hw>]:BB:WIMax:TRIGger:SLENgth on page 145

Running/Stopped
With enabled modulation, displays the status of signal generation for all trigger modes.
● "Running"

The signal is generated; a trigger was (internally or externally) initiated in triggered
mode.

● "Stopped"
The signal is not generated and the instrument waits for a trigger event.

Remote command: 
[:SOURce<hw>]:BB:WIMax:TRIGger:RMODe? on page 143

Time Based Trigger
Requires trigger "Mode" > "Armed Auto"/"Single".
Activates time-based triggering with a fixed time reference.
The R&S SMW triggers signal generation when its operating system time ("Current
Time") matches a specified time trigger ("Trigger Time"). As trigger source, you can
use an internal trigger or an external global trigger.
How to: Chapter "Time-based triggering" in the R&S SMW user manual.

Trigger settings



WiMAX configuration and settingsR&S®SMW-K49

24User Manual 1175.6732.02 ─ 19

Remote command: 
[:SOURce<hw>]:BB:WIMax:TRIGger:TIME[:STATe] on page 145

Trigger Time
Requires trigger "Mode" > "Armed Auto"/"Single".
Sets date and time for a time-based trigger signal.
Set a trigger time that is later than the "Current Time". The current time is the operating
system time of the R&S SMW. If you set an earlier trigger time than the current time,
time-based triggering is not possible.
How to: Chapter "Time-based triggering" in the R&S SMW user manual.

"Date" Sets the date of the time-based trigger in format YYYY-MM-DD.
Remote command: 
[:SOURce<hw>]:BB:WIMax:TRIGger:TIME:DATE on page 144

"Time" Sets the time of the time-based trigger in format hh:mm:ss.
Remote command: 
[:SOURce<hw>]:BB:WIMax:TRIGger:TIME:TIME on page 144

Arm
Stops the signal generation until subsequent trigger event occurs.
Remote command: 
[:SOURce<hw>]:BB:WIMax:TRIGger:ARM:EXECute on page 142

Execute Trigger
For internal trigger source, executes trigger manually.
Remote command: 
[:SOURce<hw>]:BB:WIMax:TRIGger:EXECute on page 142

Source
Selects the trigger source.
The following sources of the trigger signal are available:
● "Internal"

The trigger event is executed manually by the "Execute Trigger".
● "Internal (Baseband A/B)"

The trigger event is provided by the trigger signal from the other basebands.
If common trigger settings are applied, this trigger source is disabled.

● "External Global Trigger"
The trigger event is the active edge of an external trigger signal provided and con-
figured at the USER x connectors.

● "External Local Trigger"
The trigger event is the active edge of an external trigger signal provided and con-
figured at the local T/M/C connector.
With coupled trigger settings, the signal has to be provided at the T/M/C1/2/3 con-
nectors.

● "External Local Clock"
The trigger event is the active edge of an external local clock signal provided and
configured at the local T/M/C connector.

Trigger settings
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With coupled trigger settings, the signal has to be provided at the T/M/C1 connec-
tor.

How to: "Routing and activating a trigger signal" on page 21
Remote command: 
[:SOURce<hw>]:BB:WIMax:TRIGger:SOURce on page 141

Sync. Output to External Trigger/Sync. Output to Trigger
Enables signal output synchronous to the trigger event.
● "On"

Corresponds to the default state of this parameter.
The signal calculation starts simultaneously with the trigger event. Because of the
processing time of the instrument, the first samples are cut off and no signal is out-
put. After elapsing of the internal processing time, the output signal is synchronous
to the trigger event.

● "Off"
The signal output begins after elapsing of the processing time. Signal output starts
with sample 0. The complete signal is output.
This mode is recommended for triggering of short signal sequences. Short sequen-
ces are sequences with signal duration comparable with the processing time of the
instrument.

Remote command: 
[:SOURce<hw>]:BB:WIMax:TRIGger:EXTernal:SYNChronize:OUTPut
on page 142

External Inhibit/Trigger Inhibit
Applies for external trigger signal or trigger signal from the other path.

Trigger settings
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Sets the duration with that any following trigger event is suppressed. In "Retrigger"
mode, for example, a new trigger event does not cause a restart of the signal genera-
tion until the specified inhibit duration does not expire.
For more information, see chapter "Basics" in the R&S SMW user manual.
Remote command: 
[:SOURce<hw>]:BB:WIMax:TRIGger[:EXTernal]:INHibit on page 146
[:SOURce<hw>]:BB:WIMax:TRIGger:OBASeband:INHibit on page 143

External Delay/Trigger Delay
Delays the trigger event of the signal from:
● The external trigger source
● The other path
● The other basebands (internal trigger), if common trigger settings are used.
Use this setting to:
● Synchronize the instrument with the device under test (DUT) or other external devi-

ces
● Postpone the signal generation start in the basebands compared to each other
For more information, see chapter "Basics on ..." in the R&S SMW user manual.
Remote command: 
[:SOURce<hw>]:BB:WIMax:TRIGger[:EXTernal]:DELay on page 146
[:SOURce<hw>]:BB:WIMax:TRIGger:OBASeband:DELay on page 143

3.3  Marker settings

Access:

► Select "Baseband" > "IEEE 802.16 WiMAX" > "Marker".

This tab provides settings to select and configure the marker output signal includ-
ing marker mode and marker delay.

Routing and activating a marker signal

1. To define the signal shape of an individual marker signal "x", select "Marker" >
"Marker x" > "Mode".

Marker settings



WiMAX configuration and settingsR&S®SMW-K49

27User Manual 1175.6732.02 ─ 19

2. Optionally, define the connector for signal output. See Chapter 3.5, "Local and
global connectors settings", on page 30.
You can map marker signals to one or more USER x or T/M connectors.

3. Activate baseband signal generation. In the block diagram, set "Baseband" > "On".

The R&S SMW adds the marker signal to the baseband signal. Also, R&S SMW
outputs this signal at the configured USER x connector.

About marker output signals

This section focuses on the available settings.

For information on how these settings affect the signal, refer to section "Basics on ..."
in the R&S SMW user manual.

Settings:

Mode............................................................................................................................. 27
Rise Offset/Fall Offset................................................................................................... 28
Delay............................................................................................................................. 28

Mode
Marker configuration for up to 3 markers. The settings are used to select the marker
mode defining the shape and periodicity of the markers. The contents of the dialog
change with the selected marker mode.
How to: "Routing and activating a marker signal" on page 26
"Restart" A marker signal is generated at the start of each ARB sequence.
"Frame" A marker signal is generated at the start of each frame.
"Frame Active
Part"

The marker signal is high whenever a burst is active and low during
inactive signal parts.
(Such as the gaps between bursts in uplink mode or the uplink sub-
frame in downlink TDD mode).
This marker can be used to decrease the carrier leakage during inac-
tive signal parts by feeding it into the pulse modulator.

"Pulse" A regular marker signal is generated.
Remote command: 
[:SOURce<hw>]:BB:WIMax:TRIGger:OUTPut<ch>:PULSe:
DIVider on page 150
[:SOURce<hw>]:BB:WIMax:TRIGger:OUTPut<ch>:PULSe:
FREQuency? on page 150

"Pattern" The marker signal defined as a bit pattern with a maximum length of
32 bits.
Remote command: 
[:SOURce<hw>]:BB:WIMax:TRIGger:OUTPut<ch>:PATTern
on page 149

Marker settings
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"On/Off Ratio" A regular marker signal that is defined by an on/off ratio is generated.
A period lasts one on and off cycle.

Remote command: 
[:SOURce<hw>]:BB:WIMax:TRIGger:OUTPut<ch>:ONTime
on page 149
[:SOURce<hw>]:BB:WIMax:TRIGger:OUTPut<ch>:OFFTime
on page 149

Remote command: 
[:SOURce<hw>]:BB:WIMax:TRIGger:OUTPut<ch>:MODE on page 148

Rise Offset/Fall Offset
Sets the value for the rise/fall offset.
The ramps of the marker signal are shifted by the specified number of samples. Posi-
tive values delay the rising ramp; negative values - shift it back.

1 = Positive rise offset
2 = Positive fall offset

Remote command: 
[:SOURce<hw>]:BB:WIMax:TRIGger:OUTPut<ch>:ROFFset on page 149
[:SOURce<hw>]:BB:WIMax:TRIGger:OUTPut<ch>:FOFFset on page 149

Delay
Delays the marker signal at the marker output relative to the signal generation start.
Variation of the parameter "Marker x" > "Delay" causes signal recalculation.
Remote command: 
[:SOURce<hw>]:BB:WIMax:TRIGger:OUTPut<ch>:DELay on page 150

Marker settings
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3.4  Clock settings

Access:

► Select "Baseband" > "IEEE 802.16 WiMAX" > "Clock".

This tab provides settings to select and configure the clock signal, like the clock
source and clock mode.

Defining the clock

1. Select "Clock" > "Source" to define the source of clock signal.

2. For external clock signals, define the connector for signal input. See Chapter 3.5,
"Local and global connectors settings", on page 30.
You can map clock signals to one or more USER x or T/M connectors.

Local and global connectors settings allow you to configure the signal mapping, the
polarity, the trigger threshold and the input impedance of the input connectors.

3. Activate baseband signal generation. In the block diagram, set "Baseband" > "On".

The R&S SMW starts baseband signal generation with a symbol rate that equals
the clock rate.

About clock signals

This section focuses on the available settings.

For information on how these settings affect the signal, refer to section "Basics on ..."
in the R&S SMW user manual.

Settings:

Clock Source.................................................................................................................29
Clock Mode................................................................................................................... 30
Measured External Clock.............................................................................................. 30

Clock Source
Selects the clock source.
● "Internal"

The instrument uses its internal clock reference.
● "External Local Clock"

Option: R&S SMW-B10
The instrument expects an external clock reference at the local T/M/C connector.

Clock settings
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Remote command: 
[:SOURce<hw>]:BB:WIMax:CLOCk:SOURce on page 151

Clock Mode
Sets the type of externally supplied clock.
How to: "Defining the clock" on page 29
Remote command: 
[:SOURce<hw>]:BB:WIMax:CLOCk:MODE on page 151

Measured External Clock
Provided for permanent monitoring of the enabled and externally supplied clock signal.
Remote command: 
CLOCk:INPut:FREQuency?

3.5  Local and global connectors settings

Accesses a dialog to configure local connectors or global connectors.

The button is available in the following dialogs or tabs:
● "Trigger / Marker / Clock" dialog that is accessible via the "TMC" block in the block

diagram.
● "Trigger In", "Marker" and "Clock" tabs that are accessible via the "Baseband"

block in the block diagram.

See also chapter "Local and global connectors settings" in the user manual.

3.6  Frame configuration general settings

Access:

► Select "Baseband > IEEE 802.16 WiMAX > Frame Configuration".

Frame configuration general settings
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This dialog contains the general parameters required for frame configuration.

Settings:

Frame Duration............................................................................................................. 31
User Frame Duration.....................................................................................................31
Downlink Subframe Duration........................................................................................ 31
Initial Delay of Burst 1................................................................................................... 32
Sequence Length.......................................................................................................... 32
Predefined Frames........................................................................................................32
Power Reference.......................................................................................................... 32
Frame Configuration..................................................................................................... 33

Frame Duration
Selects the frame duration.
Only distinct values are allowed in the standard. For test reasons, continuous genera-
tion or generation for a freely selectable duration (User) are available. In continuous
mode, the frame duration equals the sum of the burst durations in OFDM mode or the
subframe duration in OFDMA mode.
Remote command: 
[:SOURce<hw>]:BB:WIMax:FRAMe:TIME on page 130

User Frame Duration
(available for Frame Duration set to User)
Sets the frame duration for selection User. The values are freely selectable.
Remote command: 
[:SOURce<hw>]:BB:WIMax:FRAMe:TIME:USER on page 131

Downlink Subframe Duration
(available for uplink direction in TDD mode)
Delays the first uplink burst by the set time duration.

Frame configuration general settings
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Remote command: 
[:SOURce<hw>]:BB:WIMax:SUBFrame:TIME on page 134

Initial Delay of Burst 1
(available for the uplink direction in FDD mode with physical layer mode OFDM)
Delays the first uplink burst by the set time duration.
In FDD mode, this parameter is provided for convenience to enable a constant delay of
the signal with respect to an internal or external frame trigger.
Remote command: 
[:SOURce<hw>]:BB:WIMax:FRAMe:BURSt:DELay on page 130

Sequence Length
Sets the sequence length of the signal in number of frames. The signal is calculated in
advance and output in the arbitrary waveform generator. Burst data sources are contin-
uously read over the whole sequence length.
Remote command: 
[:SOURce<hw>]:BB:WIMax:SLENgth on page 133

Predefined Frames
Selects the frame type.
"Test Message BPSK 1/2 Short, Test Message BPSK 1/2 Mid,…(OFDM only)"

Predefined setups for receiver test messages according to IEEE
802.16-2004 section 8.3.11

"Downlink/Uplink 35MHz QPSK 1/2, Downlink/Uplink 35MHz QPSK 3/4,…(OFDMA/
OFDMA-WiBro only)"

Predefined setups for receiver test messages. The available prede-
fined frames depend on the selected link direction.

"User" The settings for the frame can be defined.
Remote command: 
[:SOURce<hw>]:BB:WIMax:OFDM:FRAMe:PREDefined on page 228
[:SOURce<hw>]:BB:WIMax:AOFDm:FRAMe:PREDefined on page 156

Power Reference
Selects the power reference.
"FCH / Burst
(OFDM only)"

The instrument's level setting refers to the mean power of FCH
(Frame Control Header) or bursts with a burst power setting of 0 dB.
To obtain the absolute burst power value, the burst power value has
to be added to the level value.

"Preamble (OFDM uplink and downlink OFDMA/OFDMA - WiBro downlink only)"
The instrument's level setting refers to the preamble, which is
FCH / Burst power + 3dB in OFDM mode.

"Subframe RMS Power (OFDMA/OFDMA - WiBro only)"
The instrument's level setting refers to the rms power of the sub-
frame. This includes the preamble and all symbols with allocated car-
riers in downlink or the whole uplink subframe in uplink.

Frame configuration general settings



WiMAX configuration and settingsR&S®SMW-K49

33User Manual 1175.6732.02 ─ 19

"Subframe RMS Power w/o Preamble (OFDMA/OFDMA - WiBro only)"
The instrument's level setting refers to the rms power of the sub-
frame, excluding the preamble. This includes all symbols with alloca-
ted carriers in downlink or the whole uplink subframe in uplink.

Remote command: 
[:SOURce<hw>]:BB:WIMax:OFDM:POWer:REFerence on page 229
[:SOURce<hw>]:BB:WIMax:AOFDm:POWer:REFerence on page 158

Frame Configuration
Accesses the dialog for configuration of the frame.
The dialog depends on the selected physical layer mode, see Chapter 3.7, "Frame
configuration OFDM", on page 33 and Chapter 3.14, "Frame configuration OFDMA",
on page 55.
Remote command: 
n.a.

3.7  Frame configuration OFDM

This dialog provides all parameters to configure frames in OFDM mode. The selected
link direction determines the available parameters.

Access:

1. Select "General > Physical Layer Mode > OFDM".

2. Select "Frame Configuration (OFDM) > Frame Configuration"

3.7.1  Frame configuration common settings

► Select "Common".

Frame configuration OFDM
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This dialog contains the common parameters required for frame configuration in
OFDM mode.

Settings:

Frequency Band OFDM................................................................................................ 34
Channel Bandwidth OFDM........................................................................................... 35
Sampling Ratio n OFDM............................................................................................... 35
Sampling Rate OFDM................................................................................................... 35
BSID OFDM.................................................................................................................. 36
No. of Bursts OFDM......................................................................................................36
Tg/Tb Ratio OFDM........................................................................................................36
No. of Used Subchannels OFDM..................................................................................36
Subchannel Index OFDM..............................................................................................36
Frame Preamble OFDM................................................................................................36
Frame Number OFDM.................................................................................................. 37
Configure FCH OFDM...................................................................................................37
Generate UL-MAP......................................................................................................... 37

Frequency Band OFDM
Selects the frequency band for the carrier frequencies. The available ranges for setting
the channel bandwidth and the sampling rate depend on the selection here.
"ETSI" The frequency band as defined by the ETSI applies.

The range is 1.75 MHz to 28 MHz for the channel bandwidth and 2
MHz to 32 MHz for the sampling rate.

"MMDS" The frequency band as defined by the" Multichannel Multipoint Distri-
bution Service" applies. The RF frequency range is 2500 MHz to
2686 MHz.
The range is 1.50 MHz to 24 MHz for the channel bandwidth and 1.72
MHz to 27.52 MHz for the sampling rate.

Frame configuration OFDM



WiMAX configuration and settingsR&S®SMW-K49

35User Manual 1175.6732.02 ─ 19

"WCS" The frequency band as defined by the "Wireless Communication Ser-
vice" applies. It is in the 2.3 GHz band of the electromagnetic spec-
trum from 2305 MHz to 2320 MHz and 2345 MHz to 2360 MHz.
The range is 2.5 MHz to 15 MHz for the channel bandwidth and 2.88
MHz to 17.28 MHz for the sampling rate.

"U-NII" The frequency band as defined by the "Unlicensed National Informa-
tion Infrastructure" applies. It is in the 5 GHz band of the electromag-
netic spectrum from 5150 GHz to 5350 GHz and 5750 GHz to 5825
GHz.
The range is 10 MHz to 20 MHz for the channel bandwidth and 11.52
MHz to 23.04 MHz for the sampling rate.

"User" This mode is provided for choosing any other channel bandwidth /
sampling rate combination.
The range is 1.25 MHz to 28 MHz for the channel bandwidth and 1.44
MHz to 32 MHz for the sampling rate.

Remote command: 
[:SOURce<hw>]:BB:WIMax:OFDM:FBANd on page 224

Channel Bandwidth OFDM
Sets the channel bandwidth. The range is 1.25 MHz to 28 MHz.
The selected channel bandwidth has to be a multiple of 1.25, 1.5, 1.75, 2.0 MHz or
2.75 MHz. The channel bandwidth determines the parameter n (see Sampling Ratio n
OFDM):
● For channel bandwidths:

– A multiple of 1.75 MHz then n = 8/7
– A multiple of 1.5 MHz then n = 86/75
– A multiple of 1.25 MHz then n = 144/125
– A multiple of 2.75 MHz then n = 316/275
– A multiple of 2.0 MHz then n = 57/50

● Else for channel bandwidths not otherwise specified then n = 8/7
The sampling rate is derived from the channel bandwidth as follows:
SamplingRate = floor(n * ChannelBandwidth / 8000) * 8000

Remote command: 
[:SOURce<hw>]:BB:WIMax:OFDM:BW on page 224

Sampling Ratio n OFDM
Indicates the sampling ratio. The sampling ratio is determined by the channel band-
width (see Channel Bandwidth OFDM).
Remote command: 
[:SOURce<hw>]:BB:WIMax:OFDM:N? on page 229

Sampling Rate OFDM
Sets the sampling rate. The possible settings depend on the selected frequency band.
The full range in "User" mode is 1.44 MHz to 32 MHz.
The sampling rate is related to the channel bandwidth by the parameter n:
SamplingRate = floor(n * ChannelBandwidth / 8000) * 8000

Frame configuration OFDM
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Remote command: 
[:SOURce<hw>]:BB:WIMax:OFDM:SRATe on page 230

BSID OFDM
Sets the 4 LSBs of the Base Station ID.
The BSID is transmitted in the FCH (when set to "Auto" mode), and it is used to initial-
ize the randomizer.
Remote command: 
[:SOURce<hw>]:BB:WIMax:OFDM:BSID on page 215

No. of Bursts OFDM
Sets the number of active bursts in one frame.
With number of bursts = 0, a preamble only or a preamble with an FCH burst is gener-
ated.
Remote command: 
[:SOURce<hw>]:BB:WIMax:OFDM:BURSt[:COUNt] on page 224

Tg/Tb Ratio OFDM
Selects the ratio of guard period to symbol period.
This value sets the length of the cyclic prefix in fractions of the symbol period.
Remote command: 
[:SOURce<hw>]:BB:WIMax:OFDM:TGTB on page 231

No. of Used Subchannels OFDM
Selects the number of used subchannels.
Selection 16 (all) deactivates subchannelization and activates all possible carriers. The
values 1, 2, 4 and 8 activate only a part of the available subcarriers, unused carriers
are blanked.
Remote command: 
[:SOURce<hw>]:BB:WIMax:OFDM:SUBChannel[:COUNt] on page 231

Subchannel Index OFDM
Selects the subchannel index in subchannelization mode.
The subchannel index determines the set of used subcarriers according to IEEE
802.16-2004.
Remote command: 
[:SOURce<hw>]:BB:WIMax:OFDM:SUBChannel:INDex on page 230

Frame Preamble OFDM
Activates the generation of a frame preamble. Either a long preamble or a short pream-
ble can be activated.
The 802.16 standard requires a long preamble as frame start.
Remote command: 
[:SOURce<hw>]:BB:WIMax:OFDM:PREamble:MODE on page 229

Frame configuration OFDM
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Frame Number OFDM
Selects the frame number of the uplink frame in which the UL map that specifies the
uplink burst was transmitted.
Remote command: 
[:SOURce<hw>]:BB:WIMax:OFDM:FRAMe[:NUMBer] on page 228

Configure FCH OFDM
Accesses the dialog for configuring FCH mode and parameters (see Chapter 3.8,
"FCH configuration downlink OFDM", on page 43).
Remote command: 
n.a.

Generate UL-MAP...
Accesses the dialog for generating the UL-Map, see Chapter 3.11, "UL-MAP configura-
tion downlink OFDM", on page 50.
Remote command: 
n.a.

3.7.2  Burst table

► To access this dialog, select "Burst Table".

The dialog contains the parameters of the individual bursts.

Up to 64 bursts can be configured per frame. Each table row defines the settings of
one specific burst, where the first row defines the first burst of the frame and the last
row defines the last burst.

For both transmission directions, different modulations and channel coding rates are
available for each burst. A generic MAC header with encrypted payload and checksum
determination can be activated.

Frame configuration OFDM
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Some setting parameters vary depending on the transmission direction.

Burst Index OFDM
Displays the consecutive burst index from 0 to 63.
All the rows are always displayed, even if the bursts are inactive. They are switched on
and off by the selection of "No. of Bursts" above the table. The active bursts are high-
lighted.
Remote command: 
n.a.
(selected via the suffix to the keyword BURSt<n>)

Preamble OFDM
Enables generation of the burst preamble.
If activated, a preamble is placed before the burst. Long or short preambles are availa-
ble. The preamble has the same power as the burst. If subchannelization is used, a
subchannelization preamble is generated accordingly.
Remote command: 
[:SOURce<hw>]:BB:WIMax:OFDM:BURSt<ch0>:PREamble:MODE on page 222

Midamble Repetition OFDM
Activates midamble repetition.
If midamble repetition is switched on, midambles are placed into the burst with the
specified interval, i.e. if 5 is selected, every 5th symbol of the burst is a midamble.
A short preamble is used as midamble when subchannelization is off or a subchanneli-
zation preamble is used in subchannelization mode. The power of the midambles is
identical to the burst power.
Remote command: 
[:SOURce<hw>]:BB:WIMax:OFDM:BURSt<ch0>:MIDamble on page 221

Modulation and RS-CC Rate OFDM
Selects the modulation and channel coding rate. Channel coding includes randomiza-
tion, Reed-Solomon coding, convolutional coding and interleaving.
For a given modulation type and channel coding rate, the data length determines the
number of symbols and vice versa.
Remote command: 
[:SOURce<hw>]:BB:WIMax:OFDM:BURSt<ch0>:FORMat on page 219

Channel Coding OFDM
Switches channel coding on or off.
If channel coding is switched off, the bits read from the data source are directly modu-
lated onto the carriers. Due to randomization missing, this could result in high crest fac-
tors of the signal.
Remote command: 
[:SOURce<hw>]:BB:WIMax:OFDM:BURSt<ch0>:CCODing:STATe on page 215
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Data Length OFDM
Determines the data length in bytes.
The given number of bytes is read from the data source. The total number of data
bytes in the burst (before channel coding) is determined as follows:
TotalDataBytes = DataLength + MACHeaderBytes + CRCBytes + TailByte

The tail byte is only added when channel coding is switched on. The same is the case
for the MAC header and CRC, they are not added when switched off. Additionally pad-
ding with 0xFF bytes is applied at the end of the data sequence to reach an integer
number of OFDM symbols.
The data length determines the number of symbols and vice versa. The maximum data
length of 10000 bytes defines the maximum number of symbols for a given modulation
type and channel coding rate.
Remote command: 
[:SOURce<hw>]:BB:WIMax:OFDM:BURSt<ch0>:DLENgth on page 217

Number of Symbols OFDM
Enters the number of symbols for the selected burst. If the number of symbols is
changed, the data length is adjusted to fill the specified number of symbols with data
so that no padding has to be applied.
The maximum data length of 10 000 bytes defines the maximum number of symbols
for a given modulation type and channel coding rate.
Remote command: 
[:SOURce<hw>]:BB:WIMax:OFDM:BURSt<ch0>:SYMBol[:COUNt] on page 222

Data Source OFDM
Selects data source for the selected bursts.
The following standard data sources are available:
● "All 0, All 1"

An internally generated sequence containing 0 data or 1 data.
● "PNxx"

An internally generated pseudo-random noise sequence.
● "Pattern"

An internally generated sequence according to a bit pattern.
Use the "Pattern" box to define the bit pattern.

● "Data List/Select DList"
A binary data from a data list, internally or externally generated.
Select "Select DList" to access the standard "Select List" dialog.
– Select the "Select Data List > navigate to the list file *.dm_iqd > Select" to

select an existing data list.
– Use the "New" and "Edit" functions to create internally new data list or to edit

an existing one.
– Use the standard "File Manager" function to transfer external data lists to the

instrument.
See also:
● Section "Modulation Data" in the R&S SMW user manual.
● Section "File and Data Management" in the R&S SMW user manual.
● Section "Data List Editor" in the R&S SMW user manual
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Remote command: 
[:SOURce<hw>]:BB:WIMax:OFDM:BURSt<ch0>:DATA on page 215
[:SOURce<hw>]:BB:WIMax:OFDM:BURSt<ch0>:DATA:PATTern on page 216
[:SOURce<hw>]:BB:WIMax:OFDM:BURSt<ch0>:DATA:DSELect on page 216

DIUC OFDM
Sets the specific interval usage code.
The code is used to initialize the randomizer.
Remote command: 
[:SOURce<hw>]:BB:WIMax:OFDM:BURSt<ch0>:DIUC on page 217

Boost OFDM
Sets the burst power in dB.
To set the absolute power of a burst correctly, level reference "FCH / Burst" must be
selected. In this mode, the output power of a burst is calculated as the sum of the
"Level" and the burst power.
In downlink, the preamble is transmitted with +3 dB and the FCH is transmitted with 0
dB.
In uplink, the power of the first burst is fixed to 0 dB.
Remote command: 
[:SOURce<hw>]:BB:WIMax:OFDM:BURSt<ch0>:POWer on page 221

MAC Header OFDM
Calls the dialog for configuring the generic MAC (Media Access Control) header of the
selected burst and for activating the checksum determination.
Remote command: 
n.a.

Burst Type OFDM
Select the burst type.
"Date" Regular bursts are called "Data" bursts. All data sources are available

for this type of burst.
"DL-MAP" A DL-MAP is generated, considering all active bursts.

The DL-MAP fields are filled with the following parameters:
● [DCD Count]
● Set to "Configuration Change Count" from the FCH panel
● "Base Station ID"

Set to BSID from the Frame Configuration panel
● "CID"

Set to CID from the MAC header panel for each burst
● "DIUC"

Set to DIUC from the burst table for each burst
● "Preamble present"

Set to 1 if a burst preamble is present
● "Start Time"

Set to burst start time in OFDM symbols, relative to frame start

Frame configuration OFDM
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"UL-MAP" A UL-MAP is generated using the specified data list, including addi-
tional parameters from the "More Param" panel. SeeGenerate UL-
MAP... for more information on how to create UL-MAP bursts.

"Ranging" An uplink ranging burst is composed of a long preamble following two
subchannelized preambles using one active subchannel. The sub-
channel index for the two preambles is read from the configured data
source. For each frame, 4 bits are read from the data source (called
"data"), which define the subchannel index as follows:
Index = data * 2 + 1

Remote command: 
[:SOURce<hw>]:BB:WIMax:OFDM:BURSt<ch0>:TYPE on page 222

More Parameter OFDM – WiMAX
Accesses the dialog for configuring additional parameters for the bursts, see Chap-
ter 3.12, "More parameters uplink OFDM", on page 52.
Remote command: 
n.a.

Gap OFDM
Sets the length of the gap between the selected burst and the next burst in µs. The
setting is only available for transmission direction uplink.
Remote command: 
[:SOURce<hw>]:BB:WIMax:OFDM:BURSt<ch0>:GAP on page 219

3.7.3  Frame burst graph OFDM

► To access this dialog, select "Burst Graph".

Frame configuration OFDM
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The frame graph indicates the configuration of one frame. The scaling of the X-axis is
always adapted to the set frame duration. The preamble length, FCH length and the
burst length are drawn to scale. The height of the bar represents the relative power.
The power of the preamble is always +3 dB and of the FCH always 0 dB relative to the
power of the other bursts.

The shown frame configuration is repeated over the whole sequence length.

● In downlink direction, the frame preamble is sent at the beginning of the frame.
● In uplink direction, each burst starts with a preamble. The first gap at the beginning

of the frame is determined by the Downlink Subframe Duration. The following gaps
are defined by the gap value specified for the associated burst in the burst table.

3.7.4  Active carrier graph OFDM

► To access this dialog, select "Carrier Graph".

Frame configuration OFDM
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The graph shows used pilots and carriers of the current subchannelization mode. If
subchannelization is activated with "No. of used Subchannels" different than 16,
the graph shows the used and blanked carriers according to the setting of "Sub-
channel Index".

3.8  FCH configuration downlink OFDM

Access:

1. Select "General > Physical Layer Mode > OFDM".

2. Select "Link Direction > Downlink".

3. Select "Frame Configuration (OFDM) > Frame Configuration > Common".

4. Select "Configure FCH".

FCH configuration downlink OFDM
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This dialog comprises the settings required for configuring FCH.

Provided are the following settings:

Settings:

FCH State..................................................................................................................... 44
FCH Mode.....................................................................................................................44
Frame Number Offset....................................................................................................45
Configuration Change Count.........................................................................................45
Data Source.................................................................................................................. 46

FCH State
Activates the FCH.
Remote command: 
[:SOURce<hw>]:BB:WIMax:OFDM:FCH:STATe on page 227

FCH Mode
Selects the mode for generating the FCH.
Channel Coding of the FCH is performed both in "Auto" and "User" mode.

FCH configuration downlink OFDM



WiMAX configuration and settingsR&S®SMW-K49

45User Manual 1175.6732.02 ─ 19

"Auto" In "Auto" mode, the DLFP (Downlink Frame Prefix) fields, which form
the FCH, are filled automatically with parameters specified at different
locations.
The following list shows the mapping that applies in "Auto" mode:
● Base_Station_ID

Set to the BSID value specified in the frame configuration dialog
● Frame_Number

Set to the current frame number modulo 16. The first frame of the
generated sequence has the number specified with the parameter
Frame Number Offset. For the following frames, this number
increases by 1 per frame

● Configuration_Change_Count
Set to the value specified below

● Rate_ID
The rate ID parameter of the first burst is set according to its mod-
ulation setting

● DIUC
The DIUC value for the 2nd, 3rd and 4th burst is taken from the
DIUC value in the burst table

● Preamble present
Set to 1 when the burst preamble is activated for the correspond-
ing burst

● Length
Set to the calculated number of symbols of the corresponding
burst

● HCS
The header check sequence is automatically calculated

"User" In "User" mode, the FCH is filled with data specified with the parame-
ter Data Source. This enables any arbitrary data to be sent with the
FCH burst.

Remote command: 
[:SOURce<hw>]:BB:WIMax:OFDM:FCH:MODE on page 227

Frame Number Offset
Sets the frame number offset.
This value is added to the current frame number of the sequence. After modulo 16 divi-
sion, the result is used as Frame_Number in the FCH (in "Auto" mode) and is also
used to initialize the randomizers.
Remote command: 
[:SOURce<hw>]:BB:WIMax:OFDM:FCH:FNOFfset on page 226

Configuration Change Count
Sets the configuration change count value.
This value is used for the corresponding FCH field in "Auto" mode.
Remote command: 
[:SOURce<hw>]:BB:WIMax:OFDM:FCH:CCC on page 225

FCH configuration downlink OFDM
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Data Source
Specifies the data source in User mode.
The FCH contents are filled from the selected data source.
The following standard data sources are available:
● "All 0, All 1"

An internally generated sequence containing 0 data or 1 data.
● "PNxx"

An internally generated pseudo-random noise sequence.
● "Pattern"

An internally generated sequence according to a bit pattern.
Use the "Pattern" box to define the bit pattern.

● "Data List/Select DList"
A binary data from a data list, internally or externally generated.
Select "Select DList" to access the standard "Select List" dialog.
– Select the "Select Data List > navigate to the list file *.dm_iqd > Select" to

select an existing data list.
– Use the "New" and "Edit" functions to create internally new data list or to edit

an existing one.
– Use the standard "File Manager" function to transfer external data lists to the

instrument.
See also:
● Section "Modulation Data" in the R&S SMW user manual.
● Section "File and Data Management" in the R&S SMW user manual.
● Section "Data List Editor" in the R&S SMW user manual
Remote command: 
[:SOURce<hw>]:BB:WIMax:OFDM:FCH:DATA on page 225
[:SOURce<hw>]:BB:WIMax:OFDM:FCH:DATA:PATTern on page 226
[:SOURce<hw>]:BB:WIMax:OFDM:FCH:DATA:DSELect on page 225

3.9  Generate UL-MAP uplink OFDM

Access:

1. Select "General > Physical Layer Mode > OFDM".

2. Select "Link Direction > Uplink".

3. Select "Frame Configuration (OFDM) > Frame Configuration > Common".

4. Select "Generate UL-MAP".

Generate UL-MAP uplink OFDM
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This dialog contains the parameters required for generating an UL-MAP.

Settings:

UCD Count OFDM........................................................................................................ 47
Save UL-MAP Data OFDM........................................................................................... 47

UCD Count OFDM
Sets the value for the UCD count.
Remote command: 
[:SOURce<hw>]:BB:WIMax:OFDM:UCD on page 231

Save UL-MAP Data OFDM
Opens the "File Select" dialog for saving the current UL-MAP.
The name of the file is specified in the "Filename" entry field, the directory selected in
the save into field. The file is saved by pressing the "Save" button.
The file is stored with the predefined file extension *.dm_iqd. The filename and the
directory it is stored in are user-definable.
The saved *.dm_iqd file is in the data list format and contains a UL-MAP that
describes the current uplink subframe.
The following is a list of the UL-MAP parameters:
● UCD Count

Set to UCD Count specified above
● "Allocation Start Time"

Set to 0. Can be modified later when loading the UL-MAP in downlink mode
● CID

CID from the "More Param" panel for each burst
● Start Time

Burst start in OFDM symbols for each burst
● "Subchannel Index"

Subchannel index set in the Frame Configuration panel
● UIUC

UIUC from the "More Param" panel for each burst
● Duration

Burst duration in symbols
● Midamble repetition interval

Midamble repetition for each burst
Generating a valid UL-MAP

Generate UL-MAP uplink OFDM



WiMAX configuration and settingsR&S®SMW-K49

48User Manual 1175.6732.02 ─ 19

The following steps are required to generate a valid UL-MAP
● Switch to uplink mode
● Define the layout of the uplink subframe by setting a number of bursts and specify-

ing the parameters above for each burst
● Select "Generate UL-MAP" and save the UL-MAP to a file
● Switch to downlink mode
● Set one downlink burst to "Burst Type UL-MAP"
● Open the "More Params" panel
● Select "UL-MAP File" and load the file created before.
The downlink frame is then transmitting a UL-MAP that specifies the uplink structure
defined in uplink mode before.
Remote command: 
[:SOURce<hw>]:BB:WIMax:OFDM:ULMap:CREate on page 232

3.10  DL-MAP configuration downlink OFDM

Access:

1. Select "General > Physical Layer Mode > OFDM".

2. Select "Link Direction > Downlink".

3. Select "Frame Configuration (OFDM) > Frame Configuration > Burst Table".

4. Select "Burst Type > DL-MAP".

5. Select "More Parameter > Configure".

DL-MAP configuration downlink OFDM
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This dialog contains the parameters required for configuring DL-MAP.

Settings:

Append DCD OFDM..................................................................................................... 49
Append UL-Map OFDM................................................................................................ 49
Allocation Start Timebase OFDM..................................................................................50
Allocation Start Time OFDM..........................................................................................50
UL-MAP File OFDM...................................................................................................... 50
Append UCD OFDM..................................................................................................... 50

Append DCD OFDM
If activated, a DCD is appended to the DL-MAP. The DCD message carries its own
MAC header and CRC, but is included within the DL-MAP burst.
Remote command: 
[:SOURce<hw>]:BB:WIMax:OFDM:BURSt<ch0>:DLMap:DCD:STATe on page 218

Append UL-Map OFDM
If activated, a UL-Map is appended to the DL-Map.
Remote command: 
[:SOURce<hw>]:BB:WIMax:OFDM:BURSt<ch0>:DLMap:ULM:STATe on page 218

DL-MAP configuration downlink OFDM
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Allocation Start Timebase OFDM
Selects the allocation start timebase, required for the UL-Map appended to the DL-
Map. The "Allocation Start Time" field of the UL-Map specifies the start of the uplink
subframe.
If "Start Timebase = DL Subframe End", the "Allocation Start Time" of the UL-Map is
set to the end of the downlink subframe+ the value set with the parameter Allocation
Start Time OFDM.
When "Start Timebase = Frame Start", the allocation start Time of the UL-Map is set to
the beginning of the frame+ the value set with the parameter Allocation Start Time
OFDM.
Remote command: 
[:SOURce<hw>]:BB:WIMax:OFDM:BURSt<ch0>:DLMap:AMODe on page 217

Allocation Start Time OFDM
Sets the "Allocation Start Time" in the UL-Map, appended to the DL-Map.
Remote command: 
[:SOURce<hw>]:BB:WIMax:OFDM:BURSt<ch0>:DLMap:ATIMe on page 217

UL-MAP File OFDM
Opens the dialog for selecting the UL-Map file.
Remote command: 
n.a.

Append UCD OFDM
If activated, the UCD is appended to the DL-MAP. The UCD message is transmitted
with its own MAC header and CRC, included in the same burst allocation used by the
DL-MAP.
Remote command: 
[:SOURce<hw>]:BB:WIMax:OFDM:BURSt<ch0>:DLMap:UCD:STATe on page 218

3.11  UL-MAP configuration downlink OFDM

Access:

1. Select "General > Physical Layer Mode > OFDM".

2. Select "Link Direction > Downlink".

3. Select "Frame Configuration (OFDM) > Frame Configuration > Burst Table".

4. Select "Burst Type > UL-MAP".

5. Select "More Parameter > Configure".

UL-MAP configuration downlink OFDM
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This dialog comprises the settings required for configuring UL-MAP.

Settings:

Allocation Start Timebase............................................................................................. 51
Allocation Start Time..................................................................................................... 51
UL-MAP File..................................................................................................................51

Allocation Start Timebase
Selects the allocation start timebase. The allocation start time field of the UL-MAP
specifies the start of the uplink subframe.
If "Start Timebase = DL Subframe End", the "Allocation Start Time" of the UL-Map is
set to the end of the downlink subframe+ the value set with the parameter Allocation
Start Time.
When "Start Timebase = Frame Start", the allocation start Time of the UL-Map is set to
the beginning of the frame+ the value set with the parameter Allocation Start Time.
Remote command: 
[:SOURce<hw>]:BB:WIMax:OFDM:BURSt<ch0>:ULMap:AMODe on page 223

Allocation Start Time
Sets the allocation start time in the UL-MAP.
Remote command: 
[:SOURce<hw>]:BB:WIMax:OFDM:BURSt<ch0>:ULMap:ATIMe on page 223

UL-MAP File
Calls the dialog for selecting the UL-map file.
Remote command: 
n.a.
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3.12  More parameters uplink OFDM

Access:

1. Select "General > Physical Layer Mode > OFDM".

2. Select "Link Direction > Uplink".

3. Select "Frame Configuration (OFDM) > Frame Configuration > Burst Table".

4. Select "Burst Type > Data".

5. Select "More Parameter > Configure".

This dialog contains the parameters that can be configured when "Burst Type >
Data" is selected.

Settings:

Configure MAC..............................................................................................................53
UIUC OFDM..................................................................................................................53
MAC CID....................................................................................................................... 53
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Configure MAC
Accesses the dialog for configuring the MAC header panel for the selected burst. This
dialog is described in Chapter 3.13, "MAC header configuration OFDM", on page 53
Remote command: 
n.a.

UIUC OFDM
Sets the specific UIUC.
Remote command: 
[:SOURce<hw>]:BB:WIMax:OFDM:BURSt<ch0>:UIUC on page 223

MAC CID
Sets the connection control identifier (CID) of the medium access control layer (MAC).
The CID identifies a connection to equivalent peers in the MAC of the base station and
subscriber station.
This parameter is identical to the CID set in the MAC Header settings.
Remote command: 
[:SOURce<hw>]:BB:WIMax:OFDM:BURSt<ch0>:MAC:CID on page 219

3.13  MAC header configuration OFDM

Access:

1. Select "General > Physical Layer Mode > OFDM".

2. Select "Link Direction > Uplink".

3. Select "Frame Configuration (OFDM) > Frame Configuration > Burst Table".

4. Select "Burst Type > Data".

5. Select "More Parameter > Configure > Configure MAC".

MAC header configuration OFDM
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This dialog contains the parameters to configure a generic MAC header, which is
placed at the beginning of the burst when activated.
In addition CRC (cyclic redundancy check) can be activated, which is added at the
end of the burst. It covers MAC header and all data.

Settings:

CRC State..................................................................................................................... 54
MAC Header State........................................................................................................ 55
MAC CID....................................................................................................................... 55
Payload encrypted........................................................................................................ 55
EKS............................................................................................................................... 55
Mac Type.......................................................................................................................55

CRC State
Activates/deactivates the checksum determination. The state of the CRC can be set
independently of the state of MAC header generation.
Remote command: 
[:SOURce<hw>]:BB:WIMax:OFDM:BURSt<ch0>:MAC:CRC:STATe on page 220

MAC header configuration OFDM
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MAC Header State
Activates the generation of the generic MAC header.
Remote command: 
[:SOURce<hw>]:BB:WIMax:OFDM:BURSt<ch0>:MAC:STATe on page 220

MAC CID
Sets the connection control identifier (CID) of the medium access control layer (MAC).
The CID identifies a connection to equivalent peers in the MAC of the base station and
subscriber station.
This parameter is identical to the CID set in the MAC Header settings.
Remote command: 
[:SOURce<hw>]:BB:WIMax:OFDM:BURSt<ch0>:MAC:CID on page 219

Payload encrypted
Activates/deactivates payload encryption.
If activated, the EC (encryption control) field is set to 1 and the EKS (encryption key
sequence) field can be set.
Remote command: 
[:SOURce<hw>]:BB:WIMax:OFDM:BURSt<ch0>:MAC:ENCRypted:STATe
on page 220

EKS
Sets the EKS (encryption key sequence) value in the MAC header. The payload
encryption itself is not performed by the signal generator.
Remote command: 
[:SOURce<hw>]:BB:WIMax:OFDM:BURSt<ch0>:MAC:EKS on page 220

Mac Type
Specifies the MAC type.
The value of the 6-bit type field is set which indicates the payload type, including the
presence of subheaders.
Remote command: 
[:SOURce<hw>]:BB:WIMax:OFDM:BURSt<ch0>:MAC:TYPE on page 221

3.14  Frame configuration OFDMA

Access:

1. Select "General > Physical Layer Mode > OFDMA".

2. Select "Frame Configuration (OFDMA) > Frame Configuration".

Frame configuration OFDMA
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3.14.1  Frame configuration common settings

► Select "Common".

This dialog contains the parameters required for frame configuration in OFDMA
mode.

Settings:

Frequency Band OFDMA..............................................................................................56
Channel Bandwidth OFDMA......................................................................................... 57
Sampling Ratio n OFDMA.............................................................................................57
Sampling Rate OFDMA.................................................................................................57
Number of Zones/Segments OFDMA........................................................................... 58
Preamble Mode OFDMA...............................................................................................58
Preamble Index OFDMA............................................................................................... 58
Tg/Tb Ratio OFDMA..................................................................................................... 58
FFT Size OFDMA..........................................................................................................58
IDCell OFDMA.............................................................................................................. 58

Frequency Band OFDMA
Selects the frequency band for the carrier frequencies. The available ranges for setting
the channel bandwidth and the sampling rate depend on the selection here.
"ETSI" The frequency band as defined by the ETSI applies.

The range is 1.75 MHz to 28 MHz for the channel bandwidth and 2
MHz to 32 MHz for the sampling rate.

"MMDS" The frequency band as defined by the "Multichannel Multipoint Distri-
bution Service" applies. The RF frequency range is 2500 MHz to
2686 MHz.
The range is 1.50 MHz to 24 MHz for the channel bandwidth and 1.68
MHz to 26.88 MHz for the sampling rate.

Frame configuration OFDMA
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"WCS" The frequency band as defined by the "Wireless Communication Ser-
vice" applies. It is in the 2.3 GHz band of the electromagnetic spec-
trum from 2305 MHz to 2320 MHz and 2345 MHz to 2360 MHz.
The range is 2.5 MHz to 15 MHz for the channel bandwidth and 2.8
MHz to 16.8 MHz for the sampling rate.

"U-NII" The frequency band as defined by the "Unlicensed National Informa-
tion Infrastructure" applies. It is in the 5 GHz band of the electromag-
netic spectrum from 5150 GHz to 5350 GHz and 5750 GHz to 5825
GHz.
The range is 10 MHz to 20 MHz for the channel bandwidth and 11.2
MHz to 22 MHz for the sampling rate.

"WiBro" The frequency band as defined by the Telecommunications Technol-
ogy Association of Korea. It is in the 2.3 GHz band of the electromag-
netic spectrum.

"User" This mode is provided for choosing any other channel bandwidth /
sampling rate combination.
The range is 1.25 MHz to 28 MHz for the channel bandwidth and 1.4
MHz to 32 MHz for the sampling rate.

Remote command: 
[:SOURce<hw>]:BB:WIMax:AOFDm:FBANd on page 156

Channel Bandwidth OFDMA
Sets the channel bandwidth. The range is 1.25 MHz to 28 MHz.
The selected channel bandwidth has to be a multiple of 1.25, 1.5, 1.75, 2.0 MHz or
2.75 MHz. The channel bandwidth determines the parameter n (see Sampling Ratio n
OFDMA).
● For channel bandwidth

– A multiple of 1.75 MHz then n = 8/7
– A multiple of 1.5 MHz then n = 28/25
– Aa multiple of 1.25 MHz then n = 28/25
– A multiple of 2.75 MHz then n = 28/25
– A multiple of 2.0 MHz then n = 28/25

● Else for channel bandwidth not otherwise specified then n = 8/7
The sampling rate is derived from the channel bandwidth as follows:
SamplingRate = floor (n * ChannelBandwidth / 8000) * 8000

Remote command: 
[:SOURce<hw>]:BB:WIMax:AOFDm:BW on page 155

Sampling Ratio n OFDMA
Indicates the sampling ratio. The sampling ratio is determined by the channel band-
width (see Channel Bandwidth OFDMA).
Remote command: 
[:SOURce<hw>]:BB:WIMax:AOFDm:N? on page 158

Sampling Rate OFDMA
Sets the sampling rate. The possible settings depend on the selected frequency band.
The full range in User mode is 1.44 MHz to 32 MHz.
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The sampling rate is related to the channel bandwidth by the parameter n:
SamplingRate = floor (n * ChannelBandwidth / 8000) * 8000

Remote command: 
[:SOURce<hw>]:BB:WIMax:AOFDm:SRATe on page 159

Number of Zones/Segments OFDMA
Sets the number of active zones/segments in one frame.
Remote command: 
[:SOURce<hw>]:BB:WIMax:AOFDm:ZONE:COUNt on page 160

Preamble Mode OFDMA
Selects the mode for selecting the preamble index.
"Auto" The preamble index value is automatically derived from the segments

used in the first zone and the cell ID parameter. The "Preamble
Index" field below shows the used preamble index. If more than one
segment is active in the first zone, the preamble index shows -1. In
this case, a multi-segment preamble is generated.

"User" Sets the preamble index to one of the available indices from 1 to 113
specified in the "Preamble Index" field.

Remote command: 
[:SOURce<hw>]:BB:WIMax:AOFDm:PREamble:INDex:MODE on page 159

Preamble Index OFDMA
Sets the preamble index to one of the available indices from 1 to 113 in preamble
mode "user".
Remote command: 
[:SOURce<hw>]:BB:WIMax:AOFDm:PREamble:INDex on page 159

Tg/Tb Ratio OFDMA
Selects the ratio of guard period to symbol period.
This value sets the length of the cyclic prefix in fractions of the symbol period.
Remote command: 
[:SOURce<hw>]:BB:WIMax:AOFDm:TGTB on page 160

FFT Size OFDMA
Selects the FFT size.
Remote command: 
[:SOURce<hw>]:BB:WIMax:AOFDm:FFT on page 156

IDCell OFDMA
Sets the cell ID. The value is used in the preamble and for the permutation equations
in the first downlink zone. It partly sets the subcarrier randomizer initialization vector in
the first downlink zone.
Remote command: 
[:SOURce<hw>]:BB:WIMax:AOFDm:IDCell on page 157
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3.14.2  Zone table

Access:

► Select "Zone Table".

This dialog contains the parameters to configure the individual zone settings.

Settings:

Zone Index OFDMA...................................................................................................... 59
Zone Number OFDMA.................................................................................................. 59
Zone Type OFDMA....................................................................................................... 60
Segment OFDMA..........................................................................................................60
No. Of Symbols OFDMA............................................................................................... 60
Auto OFDMA.................................................................................................................60
Offset Symbol OFDMA..................................................................................................60
PermBase OFDMA....................................................................................................... 60
PRBS_ID OFDMA.........................................................................................................60
Configure Zone OFDMA............................................................................................... 60

Zone Index OFDMA
Displays the consecutive zone index from 0 to 7.
Remote command: 
n.a.

Zone Number OFDMA
Sets the zone number of the zone. The value range is 0 to 7. Zones are generated in
the order of zone number, the lowest zone number is generated first. If the same zone
number is applied to more than one row, different segments can be used within one
zone. In this case, the segment numbers must differ and the activated subchannels of
the segments must not overlap.
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Remote command: 
[:SOURce<hw>]:BB:WIMax:AOFDm:ZONE<st0>:NUMBer on page 164

Zone Type OFDMA
Selects the type of subcarrier permutation for the zone.
Remote command: 
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:TYPE on page 212

Segment OFDMA
Selects the segment of the zone index. Multiple segments within one zone can be con-
figured by setting the same zone number and configuring different segment numbers
for each zone index. The activated subchannels must not overlap between the seg-
ments of one zone.
Remote command: 
[:SOURce<hw>]:BB:WIMax:AOFDm:ZONE<st0>:SEGMent on page 165

No. Of Symbols OFDMA
Sets the zone length in number of symbols. Zones with identical zone number have the
same length, as they overlap in time.
Remote command: 
[:SOURce<hw>]:BB:WIMax:AOFDm:ZONE<st0>:SYMBol:COUNt on page 174

Auto OFDMA
Activates or deactivates automatic zone length. The number of symbols in the zone is
derived from the configured bursts such that all bursts fit into the zone, except if the
frame duration is exceeded.
Remote command: 
[:SOURce<hw>]:BB:WIMax:AOFDm:ZONE<st0>:SYMBol:COUNt:AUTO
on page 174

Offset Symbol OFDMA
Displays the symbol offset of the zone.
Remote command: 
[:SOURce<hw>]:BB:WIMax:AOFDm:ZONE<st0>:SYMBol:OFFSet? on page 174

PermBase OFDMA
Selects the PermBase of the zone.
Remote command: 
[:SOURce<hw>]:BB:WIMax:AOFDm:ZONE<st0>:PERMbase on page 164

PRBS_ID OFDMA
Selects the PRBS_ID of the zone.
Remote command: 
[:SOURce<hw>]:BB:WIMax:AOFDm:ZONE<st0>:PRBSid on page 164

Configure Zone OFDMA
Calls the dialog for configuring the parameters of the zone.
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Remote command: 
n.a.

3.14.3  Time plan

► To access this dialog, select "Time Plan".

This dialog shows the time plan.

The time plan indicates the assignment of the active bursts. The x-axis shows the
OFDMA symbol number relative to frame/zone start on the top and the time in ms rela-
tive to frame/zone start on the bottom of the diagram. The vertical line on the right side
shows the frame boundary. The y-axis indicates the physical/logical subchannel num-
bers.

The bursts are numbered with "Zone Index".

Time Plan View Mode OFDMA
Selects the display range.
Remote-control command: n.a.
"Total Frame" The display range extends to all zones including the gap to the frame

duration. The y-axis shows the physical subchannels. All logical sub-
channels are mapped to physical before display. In uplink mode, the
data subchannel rotation is not displayed.

"Subframe" The display range is zoomed to the subframe of the corresponding
link direction.

"Zone" The display range is zoomed to the selected zone index. The y-axis
shows the logical subchannels of the zone/segment.

Remote command: 
n.a.
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Time Plan Zone Index OFDMA
Selects the zone index to be displayed.
This feature is only available, if "Zone" is selected in the "View Mode" field.
Remote command: 
n.a.

3.15  Zone configuration OFDMA

Access:

1. Select "General > Physical Layer Mode > OFDMA".

2. Select "Frame Configuration (OFDMA) > Frame Configuration > Zone Table".

3. Select "Configure Zone > Config...".

Content

● OFDMA common zone settings.............................................................................. 62
● Burst table...............................................................................................................67
● Time plan OFDMA.................................................................................................. 72

3.15.1  OFDMA common zone settings

Access:

► Select "Common".

This dialog contains the common parameters required for zone configuration.
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Settings:

Subcarrier Randomization OFDMA
Activates or deactivates the subcarrier randomization. Subcarrier randomization is per-
formed after PUSC/FUSC/AMC permutation and before IFFT conversion.
Remote command: 
[:SOURce<hw>]:BB:WIMax:AOFDm:ZONE<st0>:SCARrier:RANDomizer
on page 165

Subchannel Rotation OFDMA
(Available for zone type PUSC in link direction uplink only)
Activates or deactivates the subchannel rotation.
Remote command: 
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:SUBChannel:ROTation
on page 212

CSTD..
(Available for STC Mode CSTD only)
Calls the dialog for configuring the cyclic shift transmit diversity (seeChapter 3.17,
"CSTD OFDMA", on page 79 ).
Remote command: 
n.a.

Configure Band AMC
(Available for zone type AMC2x3 only)
Accesses the dialog for configuring band AMC mode.

Use Physical Bands Bitmap ← Configure Band AMC
Activates/deactivates band AMC mode.
If activated, the "Physical Bands Bitmap" parameter specifies the active physical
bands.
If deactivated, all available physical bands are used.
Remote command: 
[:SOURce<hw>]:BB:WIMax:AOFDm:ZONE<st0>:AMC:BITMap[:STATe]
on page 161

Physical Bands Bitmap ← Configure Band AMC
Sets the AMC physical bands bitmap pattern in hexadecimal input format.
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The LSB (right most bit) corresponds to physical band 0 (the lowest frequency OFDMA
subcarriers). Deactivated bits in this pattern deactivate the corresponding bands, i.e.
they are not used for allocating bursts.
Remote command: 
[:SOURce<hw>]:BB:WIMax:AOFDm:ZONE<st0>:AMC:BITMap:PATTern
on page 161

Configure active Subchannels OFDMA
Calls the dialog for activating/deactivating subchannels.

Use All Subchannels ← Configure active Subchannels OFDMA
Activates the generation of all subchannels.
Remote command: 
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:SUBChannel:MODE
on page 211

Use Subchannels x...y (downlink PUSC only) ← Configure active Subchannels
OFDMA
Activates the generation of the selected groups of subchannels.
Remote command: 
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:SUBChannel<ch>:MAP
on page 212
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Allocated Subchannels Bitmap (uplink only) ← Configure active Subchannels
OFDMA
In uplink mode, each physical subchannel can be individually activated or deactivated.
Activation is realized with a 9 byte field identical to the UL allocated subchannels bit-
map in the UCD message. The bytes of the bitmap are read from left to right and spec-
ify the physical subchannels in LSB first order. The LSB of the first (most left) byte
selects the physical subchannel 0.
The same order applies for all FFT sizes. Subchannel bitmap bits that are not needed
in modes with less than 70 physical subchannels are discarded.
Remote command: 
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:SUBChannel:PATTern
on page 211

No of Bursts OFDMA
Sets the number of active bursts in the zone/segment.
Remote command: 
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt[:COUNt] on page 206

Space-Time Coding Mode OFDMA
Sets the space-time coding mode or switches diversity off.
"Off" Deactivates diversity.
"2 Antennas, Matrix A/ 2 Antennas, Matrix B"

Sets the space-time coding mode to 2 Antennas and Matrix A or
Matrix B encoding respectively.

"4 Antennas, Matrix A/ 4 Antennas, Matrix B/ 4 Antennas, Matrix C"
Sets the space-time coding mode to four Antennas with Matrix A,
Matrix B or Matrix C encoding respectively.

"Burst Defined" Enables mixing Matrix A and Matrix B encoding on burst level.
The used matrix can be defined in the "More Parameter" dialog box of
each burst.
See also Data configuration OFDMA and UL-MAP configuration
downlink OFDM.

"Collaborative Multiplexing"
Enables uplink collaborative spatial multiplexing.

"CSTD" Enables cyclic shift transmit diversity.
The CSTD parameters are set in the CSTD dialog (see CSTD
OFDMA).

Remote command: 
[:SOURce<hw>]:BB:WIMax:AOFDm:ZONE<st0>:STC:MODE on page 173

Space-Time Coding Antenna OFDMA
Sets the antenna for the space-time coding modes.
Remote command: 
[:SOURce<hw>]:BB:WIMax:AOFDm:ZONE<st0>:STC:ANTenna on page 173
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Generate UL-MAP
(Available for link direction uplink only)
Accesses the dialog for generating a UL-MAP.
Remote command: 
n.a.

Dedicated Pilots OFDMA
(This feature is available only for zone type AMC and PUSC with link direction Down-
link).
When activated, pilot symbols are generated for subchannels with allocated bursts
only. When deactivated, pilot symbols are generated for all subchannels allocated to
the current segment, whether bursts are active on these subchannels.
Remote command: 
[:SOURce<hw>]:BB:WIMax:AOFDm:ZONE<st0>:PILDedicated on page 164

Data List Management…
Opens the "Data List Management" dialog. This dialog is used to create and edit a data
list.
All data lists are stored as files with the predefined file extension *.dm_iqd. The file-
name and the directory they are stored in are user-definable.
The data lists must be selected as a data source from the subdialogs under the individ-
ual function, e.g. in the channel table of the cells.
Note: All data lists are generated and edited by means of the SOURce:BB:DM subsys-
tem commands. Files containing data lists usually end with *.dm_iqd. The data lists are
selected as a data source for a specific function in the individual subsystems of the dig-
ital standard.

Example: Creating and editing the data list
SOUR:BB:DM:DLIS:SEL "d_list1"
SOUR:BB:DM:DLIS:DATA #B1111010101000001111....
SOUR:BB:DM:DLIS:DATA:APP #B1111010101000001111....

Remote command: 
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:DATA
on page 176
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:DATA:DSELect
on page 177
[:SOURce<hw>]:BB:WIMax:OFDM:BURSt<ch0>:DATA on page 215
[:SOURce<hw>]:BB:WIMax:OFDM:BURSt<ch0>:DATA:DSELect on page 216
[:SOURce<hw>]:BB:WIMax:OFDM:FCH:DATA on page 225
[:SOURce<hw>]:BB:WIMax:OFDM:FCH:DATA:DSELect on page 225

Pilot Pattern OFDMA
Sets the pilot pattern in uplink collaborative multiplexing mode.
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Remote command: 
[:SOURce<hw>]:BB:WIMax:AOFDm:ZONE<st0>:STC:PILotpattern
on page 173

Zone Boosting OFDMA
Sets an additional zone boosting in dB.
The zone boosting is applied to both the data and pilot carriers.
Remote command: 
[:SOURce<hw>]:BB:WIMax:AOFDm:ZONE<st0>:BOOSt on page 161

3.15.2  Burst table

Access:

► Select "Burst Table".

This dialog contains the individual burst parameters.

Each frame supports up to 64 bursts with individual parameters. For both transmission
directions, different modulations and channel coding rates are available. For each
burst, an optional generic MAC header and CRC are provided.

Settings:

Burst Index OFDMA
Displays the consecutive burst index from 0 to 63.
All the rows are always displayed, even if the bursts are inactive. They are switched on
and off by the selection of "No. of Bursts" above the table. The active bursts are high-
lighted.
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Remote command: 
n.a.

Modulation and Coding Rate OFDMA
Selects the modulation and channel coding rate. Channel coding includes randomiza-
tion, convolutional/turbo coding and interleaving.
Remote command: 
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:FORMat
on page 181

Channel Coding OFDMA
Selects the channel coding mode. Available modes are CC (convolutional coding),
CTC (convolutional turbo coding) or Off. In Off mode, channel coding is switched off
completely.
Remote command: 
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:CCODing:MODE
on page 175

Data Length OFDMA
Determines the data length in bytes.
The given number of bytes is read from the data source. The total number of data
bytes in the burst (before channel coding) is determined as follows:
TotalDataBytes = DataLength + MACHeaderBytes + CRCBytes

Additionally, padding with 0xFF bytes is applied at the end of the data sequence to fill
up the allocated slots. The allocated slots are specified by "No. of Subch" and "No. of
Symb" in downlink mode and by the "Duration [Slots]" in uplink mode. Thus, the "Data
Length" can be lower than the burst's allocated number of bytes.
Up to 10 000 data bytes can be set for each burst.
Remote command: 
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:DATA:LENGth
on page 177

Number of Subchannels OFDMA
Enters the number of subchannels for the selected burst.
If the number of subchannels is changed, the data length is adjusted to fill the allocated
space with data so that no padding has to be applied. The allocated space is defined
by "No. of Subch" and "No. of Symb".
The data length can be lowered afterwards if data bytes less than the allocated number
are read from the data source.
Remote command: 
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:SUBChannel[:
COUNt] on page 201

Number of Symbols OFDMA
Enters the number of symbols for the selected burst.

Zone configuration OFDMA



WiMAX configuration and settingsR&S®SMW-K49

69User Manual 1175.6732.02 ─ 19

If the number of subchannels is changed, the data length is adjusted to fill the allocated
space with data so that no padding has to be applied. The allocated space is defined
by "No. of Subch" and "No. of Symb".
The data length can be decreased afterwards if data bytes less than the allocated
number are read from the data source. The entered number of symbols is automati-
cally adjusted to a multiple of the number of symbols per slot for the set subcarrier per-
mutation.
Remote command: 
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:SYMBol[:
COUNt] on page 201

Duration-Slots OFDMA
Enters the number of slots for the selected burst. If the number of slots is changed, the
data length is adjusted to fill the specified number of slots with data so that no padding
has to be applied.
Remote command: 
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:SLOT:COUNt
on page 200

Offset Subchannel OFDMA
Indicates the subchannel offset for the selected burst. This value can be modified after
"Auto Offset" is deactivated.
It is possible that bursts overlap in manual offset mode. The "Conflict" column indicates
overlapping bursts.
Remote command: 
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:OFFSet:
SUBChannel on page 192

Offset Symbol OFDMA
Indicates the symbol offset for the selected burst. The symbol offset is specified rela-
tive to zone start. In the first downlink zone, symbol offset 0 refers to the first symbol
after the preamble.
This value can be modified after "Auto Offset" is deactivated.
The set symbol offset is rounded to a multiple of the number of symbols per slot
defined by the set subcarrier permutation.
It is possible that bursts overlap in manual offset mode. The "Conflict" column indicates
overlapping bursts.
Remote command: 
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:OFFSet:
SYMBol on page 193

Auto OFDMA
Activates/deactivates the "Auto Offset" mode. In auto mode, "Offset Subchannel" and
"Offset Symbol" are set such that bursts are not overlapping in the subchannel/symbol
space.
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Remote command: 
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:OFFSet:MODE
on page 192

Data Source OFDMA
Selects data source for the selected bursts.
The following standard data sources are available:
● "All 0, All 1"

An internally generated sequence containing 0 data or 1 data.
● "PNxx"

An internally generated pseudo-random noise sequence.
● "Pattern"

An internally generated sequence according to a bit pattern.
Use the "Pattern" box to define the bit pattern.

● "Data List/Select DList"
A binary data from a data list, internally or externally generated.
Select "Select DList" to access the standard "Select List" dialog.
– Select the "Select Data List > navigate to the list file *.dm_iqd > Select" to

select an existing data list.
– Use the "New" and "Edit" functions to create internally new data list or to edit

an existing one.
– Use the standard "File Manager" function to transfer external data lists to the

instrument.
See also:
● Section "Modulation Data" in the R&S SMW user manual.
● Section "File and Data Management" in the R&S SMW user manual.
● Section "Data List Editor" in the R&S SMW user manual
Remote command: 
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:DATA
on page 176
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:DATA:PATTern
on page 178
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:DATA:DSELect
on page 177

Boost OFDMA
Sets the burst power in dB. This setting affects the data tones only in downlink mode,
the pilot power is fixed. In uplink, the setting affects both data and pilot tones.
Remote command: 
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:POWer
on page 199

Burst Type OFDMA
Selects the burst type from data, FCH, DL-MAP, UL-MAP, Ranging, HARQ, fast feed-
back or SUB-MAP.
"DATA" Regular bursts are called "Data" bursts. All data sources are available

for this type of burst.
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"FCH" An FCH is generated at subchannel and symbol offset 0. See FCH
configuration downlink OFDMA on the FCH contents.

"DL-MAP" A DL-MAP is generated, considering all active bursts of all zones.
SeeDL-MAP configuration downlink OFDMA on the DL-MAP con-
tents.

"UL-MAP" A UL-MAP is generated using the specified data list, including addi-
tional parameters from the "More Param" dialog. See UL-MAP config-
uration downlink OFDMA for more information on how to create UL-
MAP bursts.

"Ranging" An uplink ranging allocation is configured, which can be used for ini-
tial ranging, periodic ranging, or bandwidth request transmissions.
See Ranging uplink OFDMA for more information on how to create
ranging channels. The burst type Ranging requires a PUSC zone.

"HARQ" A HARQ burst is generated. See HARQ configuration OFDMA for
more information on how to create HARQ bursts.

"Fast Feedback"
A fast feedback burst is generated. See Fast feedback configuration
OFDMA for more information on how to create fast feedback bursts.
The burst type fast feedback requires a PUSC zone.

"DCD" A regular data burst containing a DCD message is generated. The
DCD message specifies a downlink burst profile for each DIUC value
that is being used in the zone configuration.

"UCD" A regular data burst containing a UCD message is generated. The
UCD message specifies an uplink burst profile for each UIUC value
that is being used in the zone configuration.

"SUB-MAP" A SUB-DL-UL-MAP message is generated.
Altogether up to three SUB-DL-UL-MAP messages can be enabled
for all zones.
The SUB-DL-UL-MAP message additional parameters can be config-
ured in the SUB-DL-UL-MAP configuration OFDMA dialog reached
from the "More Param" panel.
For each data, UL-MAP, HARQ, DCD or UCD burst inclusion into one
of the three available "SUB-DL-UL-MAPs" can be activated. In this
case, the corresponding map carries a DL-MAP IE specifying the
position of the included burst.

Remote command: 
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:TYPE
on page 201

More Parameter OFDMA
Accesses the dialog for configuring additional parameters for the bursts.
The dialog depends on the selected burst type.
Remote command: 
n.a.
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Conflict OFDMA
Indicates a conflict between the settings of the bursts.
Conflicts can occur if subchannel and symbol offsets are set manually and two or more
bursts overlap. Bursts can also overlap with the FCH or DL-MAP. The position of FCH
and DL-MAP is fixed and cannot be changed. In uplink mode, a conflict is also indica-
ted for bursts that do not fit into the available zone space and are therefore omitted.
Remote command: 
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:CONFlict[:
STATe]? on page 176

3.15.3  Time plan OFDMA

Access:

► Select "Time Plan".

The dialog is a graphical display of the OFDMA Time Plan.

3.16  Sounding zone configuration OFDMA

Access:

1. Select "General > Physical Layer Mode > OFDMA".

2. Select "Frame Configuration (OFDMA) > Frame Configuration > Zone Table".

3. Select "Zone Type > Sounding".

4. Select "Configure Zone > Config...".

Sounding zone configuration OFDMA
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Settings:

● OFDMA sounding zone settings............................................................................. 73
● Sounding table........................................................................................................ 76

3.16.1  OFDMA sounding zone settings

Access:

► Select "Sounding Configuration".

This dialog contains the parameters required for sounding zone configuration in
OFDMA mode.

Settings:

Sounding Type OFDMA
Selects either sounding type A or B.
Remote command: 
[:SOURce<hw>]:BB:WIMax:AOFDm:ZONE<st0>:SOUNding:TYPE on page 172

Sounding Relevance Flag OFDMA
Selects whether sounding is relevant individually for each CID or for all CIDs.
Remote command: 
[:SOURce<hw>]:BB:WIMax:AOFDm:ZONE<st0>:SOUNding:RELevance:FLAG
on page 171

Separability Type OFDMA
(only for sounding type A)
Selects the sounding separability type.
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Remote command: 
[:SOURce<hw>]:BB:WIMax:AOFDm:ZONE<st0>:SOUNding:SEParability
on page 172

Total Number Of CIDs OFDMA
Sets the total number of CIDs.
Remote command: 
[:SOURce<hw>]:BB:WIMax:AOFDm:ZONE<st0>:SOUNding:CID:COUNt
on page 166

Zone Boosting OFDMA
Sets an additional zone boosting in dB.
The zone boosting is applied to both the data and pilot carriers.
Remote command: 
[:SOURce<hw>]:BB:WIMax:AOFDm:ZONE<st0>:BOOSt on page 161

Allocation Mode OFDMA
(only for sounding type A)
Selects the frequency allocation mode for sounding CIDs.
"Normal" The used sounding allocations are specified with "Number Of Freq.

Bands" and "Start Freq. Band".
"Band AMC" A "Band Bitmap" pattern determines the frequencies to be sent.
Remote command: 
[:SOURce<hw>]:BB:WIMax:AOFDm:ZONE<st0>:SOUNding:AMODe on page 165

No. Of Symbols OFDMA
Sets the zone length in number of symbols. Zones with identical zone number have the
same length, as they overlap in time.
Remote command: 
[:SOURce<hw>]:BB:WIMax:AOFDm:ZONE<st0>:SYMBol:COUNt on page 174

Sounding Relevance OFDMA
(only if sounding relevance flag is set to "Same For All CIDs")
Selects the sounding relevance mode.
Remote command: 
[:SOURce<hw>]:BB:WIMax:AOFDm:ZONE<st0>:SOUNding:RELevance:MODE
on page 172

Max Cyclic Shift Index OFDMA
(only for sounding type A and separability type cyclic shift)
Sets the value for the maximum cyclic shift index.
Remote command: 
[:SOURce<hw>]:BB:WIMax:AOFDm:ZONE<st0>:SOUNding:CMAXimum
on page 170

Sounding zone configuration OFDMA
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Permutation OFDMA
(only for sounding type B)
Indicates the permutation used for this sounding zone.
Remote command: 
[:SOURce<hw>]:BB:WIMax:AOFDm:ZONE<st0>:SOUNding:PERMutation?
on page 171

DL PermBase OFDMA
(only for sounding type B)
Sets the value for the "DL Perm Base".
Remote command: 
[:SOURce<hw>]:BB:WIMax:AOFDm:ZONE<st0>:SOUNding:DLPermbase
on page 171

Decimation Value OFDMA
(only for sounding type A and separability Type decimated subcarriers)
Sets the value for the decimation.
Remote command: 
[:SOURce<hw>]:BB:WIMax:AOFDm:ZONE<st0>:SOUNding:DECimation:VALue
on page 170

Decimation Offset Randomization OFDMA
(only for sounding type A and separability type decimated subcarriers)
Activates/deactivates the decimation offset randomization.
Remote command: 
[:SOURce<hw>]:BB:WIMax:AOFDm:ZONE<st0>:SOUNding:DECimation:
RANDomization[:STATe] on page 170

Shift Value U OFDMA
(only for sounding type A)
Sets the shift value (u) used for decimation offset and cyclic shift index.
Remote command: 
[:SOURce<hw>]:BB:WIMax:AOFDm:ZONE<st0>:SOUNding:UVAL on page 172

Sounding zone configuration OFDMA
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3.16.2  Sounding table

Access:

► Select "Sounding table".

This dialog contains the individual sounding parameters for each CID.

Settings:

Sounding Index OFDMA............................................................................................... 76
Sounding Symbol OFDMA............................................................................................ 77
CID OFDMA.................................................................................................................. 77
Power Boost OFDMA....................................................................................................77
No. Of Freq. Bands OFDMA......................................................................................... 77
Start Freq. Band OFDMA..............................................................................................77
Band Bitmap OFDMA....................................................................................................77
Sounding Relevance..................................................................................................... 77
Cyclic Shift Index OFDMA.............................................................................................78
Decimation Offset OFDMA............................................................................................78
Periodicity......................................................................................................................78
No. Of Subch.................................................................................................................78
Offset Subch..................................................................................................................78

Sounding Index OFDMA
Displays the consecutive CID index from 0 to 15.
All the rows are always displayed, even if the CIDs are inactive. They are switched on
and off by the selection of "Total Number Of CIDs" above the table. The active CIDs
are highlighted.
Remote command: 
n.a.

Sounding zone configuration OFDMA
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Sounding Symbol OFDMA
Sets the symbol used for this CID from the available symbols of the zone. Each sound-
ing CID occupies one symbol only.
Remote command: 
[:SOURce<hw>]:BB:WIMax:AOFDm:ZONE<st0>:SOUNding:CID<ch0>:SYMBol
on page 169

CID OFDMA
Sets the CID (connection control identifier).
Remote command: 
[:SOURce<hw>]:BB:WIMax:AOFDm:ZONE<st0>:SOUNding:CID<ch0>:CID
on page 166

Power Boost OFDMA
Activates/deactivates the power boost.
Remote command: 
[:SOURce<hw>]:BB:WIMax:AOFDm:ZONE<st0>:SOUNding:CID<ch0>:POWer[:
STATe] on page 168

No. Of Freq. Bands OFDMA
(only for sounding type A and normal allocation mode)
Sets the number of frequency bands used by the corresponding CID.
Remote command: 
[:SOURce<hw>]:BB:WIMax:AOFDm:ZONE<st0>:SOUNding:CID<ch0>:FBANd[:
COUNt] on page 168

Start Freq. Band OFDMA
(only for sounding type A and normal allocation mode)
Sets the start frequency band.
Remote command: 
[:SOURce<hw>]:BB:WIMax:AOFDm:ZONE<st0>:SOUNding:CID<ch0>:FBANd:
STARt on page 167

Band Bitmap OFDMA
(only for sounding type A and allocation mode set to "Band AMC")
Sets the logical band bitmap of the corresponding CID.
A "1" enables sounding transmission in the corresponding logical band, a "0" disables
it.
The right-most bit (LSB) corresponds to logical band 0 (the lowest frequency subcarri-
ers).
Remote command: 
[:SOURce<hw>]:BB:WIMax:AOFDm:ZONE<st0>:SOUNding:CID<ch0>:BBITmap
on page 166

Sounding Relevance
Activates/deactivates the sounding relevance.

Sounding zone configuration OFDMA
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Remote command: 
[:SOURce<hw>]:BB:WIMax:AOFDm:ZONE<st0>:SOUNding:CID<ch0>:
RELevance[:STATe] on page 168

Cyclic Shift Index OFDMA
(only for sounding type A)
Sets the value for the cyclic shift index. If the "Separability Type" is set to "Decimated
Subcarriers", the cyclic shift index is not used.
Remote command: 
[:SOURce<hw>]:BB:WIMax:AOFDm:ZONE<st0>:SOUNding:CID<ch0>:CINDex
on page 167

Decimation Offset OFDMA
(only for sounding type A)
Sets the value for the decimation offset. If the "Separability Type" is set to "Cyclic
Shift", the decimation offset is not used.
Remote command: 
[:SOURce<hw>]:BB:WIMax:AOFDm:ZONE<st0>:SOUNding:CID<ch0>:
DECoffset on page 167

Periodicity
Sets the value for the periodicity.
A value of 0 transmits this sounding CID only once at the beginning of the signal
sequence.
A value of 1 activates continuous transmission of the sounding CID with each frame.
Larger values specify the period in frames that active sounding CIDs occur.
Remote command: 
[:SOURce<hw>]:BB:WIMax:AOFDm:ZONE<st0>:SOUNding:CID<ch0>:
PERiodicity on page 168

No. Of Subch
(only for sounding type B)
Sets the number of subchannels.
Remote command: 
[:SOURce<hw>]:BB:WIMax:AOFDm:ZONE<st0>:SOUNding:CID<ch0>:
SUBChannel[:COUNt] on page 169

Offset Subch
(only for sounding type B)
Sets the subchannel offset.
Remote command: 
[:SOURce<hw>]:BB:WIMax:AOFDm:ZONE<st0>:SOUNding:CID<ch0>:
SUBChannel:OFFSet on page 169

Sounding zone configuration OFDMA
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3.17  CSTD OFDMA

Access:

1. Select "General > Physical Layer Mode > OFDMA".

2. Select "Link Direction > Downlink".

3. Select "Frame Configuration (OFDMA) > Frame Configuration > Zone Table".

4. Select "Configure Zone > Config...".

5. Select "Common > Space-Time Coding Mode > CSTD".

6. Select "CSTD".

This dialog contains the parameters required to configure the CSTD options in
OFDMA mode.

A zone with activated CSTD is encoded like a regular SISO zone (STC off). After, the
IFFT a multi-tap delay line is applied to the time-domain signal. Each tap can be weigh-
ted with a different linear factor before summation of all taps. The cyclic prefix is
applied on the sum output. Different cyclic-delay filters can be applied to every
antenna.

CSTD OFDMA
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The following describes the CSTD options in OFDMA mode.

Settings:

Number Of Antennas OFDMA
Sets the number of antennas used for cyclic shift transmit diversity (CSTD).
One baseband is only generating one antenna at a time.
Remote command: 
[:SOURce<hw>]:BB:WIMax:AOFDm:ZONE<st0>:CSTD:ANTCount on page 162

Show Configuration For OFDMA
Selects the antenna for which the configuration is made.
To set the antenna generated by the current baseband, set the parameter "Zone Con-
figuration > Space-Time Coding Antenna".
Remote command: 
[:SOURce<hw>]:BB:WIMax:AOFDm:ZONE<st0>:CSTD:ANTShow on page 162

Number Of Taps OFDMA
Sets the number of samples by which the OFDM symbols are cyclically shifted on the
given tap.
Remote command: 
[:SOURce<hw>]:BB:WIMax:AOFDm:ZONE<st0>:CSTD<ch0>:TAPCount
on page 163

Cyclic Delay (Samples) OFDMA
Sets the cyclic delay with that the OFDM symbols of the selected antenna are cyclically
shifted.
With CSTD, each antenna sends a circularly shifted version of the same OFDM sym-
bol. I. e. the antenna selected with the parameter "Show Configuration For" sends the
same OFDM symbol as the other antennas. However, the OFDM symbol is circularly
shifted by the samples set with the parameter "Cyclic Delay".

CSTD OFDMA
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Positive values remove the specified number of samples from the end of the symbol
and prepend them to the start of the symbol.
Remote command: 
[:SOURce<hw>]:BB:WIMax:AOFDm:ZONE<st0>:CSTD<ch0>:CDELay<dir0>
on page 162

Liner Gain OFDMA
Sets a linear gain factor for the corresponding tap.
The gain factors are applied to the symbols before summation fo all taps.
Remote command: 
[:SOURce<hw>]:BB:WIMax:AOFDm:ZONE<st0>:CSTD<ch0>:GAIN<dir0>
on page 162

3.18  Data configuration OFDMA

This dialog provides all parameters to configure the data in OFDMA mode.

To access the data configuration settings

Access:

1. Select "General > Physical Layer Mode > OFDMA".

2. Select "Frame Configuration (OFDMA) > Frame Configuration > Zone Table".

3. Select "Configure Zone > Config...".

4. Select "Burst Table > Burst Type > Data".

5. Select "More Parameters > Config...".

Content:

● OFDMA data configuration settings........................................................................ 82
● PDU table................................................................................................................86

Data configuration OFDMA
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3.18.1  OFDMA data configuration settings

Access:

► Proceed as described in "To access the data configuration settings" on page 81.

This dialog contains the parameters required to configure the data options in
OFDMA mode.

Settings:

DIUC OFDMA............................................................................................................... 83
UIUC OFDMA............................................................................................................... 83
Multiple PDUs OFDMA................................................................................................. 83
No. Of PDUs OFDMA................................................................................................... 83
MAC CID....................................................................................................................... 83
Configure MAC..............................................................................................................84
Channel Coding Randomizer........................................................................................ 84
FEC............................................................................................................................... 84
Interleaver..................................................................................................................... 84

Data configuration OFDMA



WiMAX configuration and settingsR&S®SMW-K49

83User Manual 1175.6732.02 ─ 19

Repetition Coding..........................................................................................................84
Space-Time Coding Mode.............................................................................................84
Include In SUB-DL-UL-MAP..........................................................................................85
Ranging Backoff Start................................................................................................... 85
Ranging Backoff End.....................................................................................................85
Request Backoff Start................................................................................................... 85
Request Backoff End.....................................................................................................85
Burst Profile Mapping....................................................................................................85

└ FEC & Modulation Type..................................................................................86

DIUC OFDMA
Sets the specific DIUC.
In DL-MAP mode "Auto", the DIUC of each burst is included in the DL-MAP.
Remote command: 
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:DIUC
on page 178

UIUC OFDMA
( available in uplink direction)
Sets the specific UIUC. The UIUC is used for the UL-MAP, if generated.
Remote command: 
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:UIUC
on page 203

Multiple PDUs OFDMA
Enables/disables configuration of multiple PDUs. If this parameter is enabled, multiple
PDUs each with own MAC header and CRC are available within one burst (see PDU
table ).
Remote command: 
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:PDU:STATe
on page 193

No. Of PDUs OFDMA
Available for enabled parameter "Multiple PDUs" only
Sets the number of PDUs in the burst.
Remote command: 
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:PDU:COUNt
on page 193

MAC CID
The command sets the CID (connection control identifier) of the medium access con-
trol layer (MAC). The CID identifies a connection to equivalent peers in the MAC of the
base station and subscriber station.
This parameter is identical to the CID set in the MAC Header settings.

Data configuration OFDMA
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Remote command: 
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:MAC:CID
on page 190
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:HARQ<dir0>:
MAC:CID on page 186

Configure MAC
Available for disabled parameter "Multiple PDUs" only
Accesses the dialog for configuring the MAC header panel for the selected burst (see
MAC header configuration OFDMA).
Remote command: 
n.a.

Channel Coding Randomizer
Activates or deactivates the randomizer applied before channel coding.
Remote command: 
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:CCODing:
RANDomizer on page 175

FEC
Activates or deactivates the FEC.
Remote command: 
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:CCODing:FEC
on page 174

Interleaver
Activates or deactivates the interleaver state.
Remote command: 
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:CCODing:
INTerleaver on page 175

Repetition Coding
Activates repetition coding by specifying any value other than 0.
Remote command: 
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:CCODing:
REPCoding on page 176

Space-Time Coding Mode
Selects the space time coding mode for the specified burst.
This parameter is available only, if the "Space-Time Coding Mode" is set to "Burst
Defined".
Remote command: 
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:STC:MODE
on page 200

Data configuration OFDMA
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Include In SUB-DL-UL-MAP
Selects whether a DL-MAP IE is included in the specified SUB-DL-UL-MAP message
for this burst.
The default value of this parameter is off. One of the three available SUB-DL-UL-MAPs
can be selected to carry the DL-MAP IE for this burst.
Remote command: 
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:DLUL:INCLude
on page 179

Ranging Backoff Start
(only for burst type UCD)
Sets the start value for the ranging backoff.
Remote command: 
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:UCD:RANGing:
BOSTart on page 202

Ranging Backoff End
(only for burst type UCD)
Sets the end value for the ranging backoff.
Remote command: 
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:UCD:RANGing:
BOENd on page 202

Request Backoff Start
(only for burst type UCD)
Sets the start value for the request backoff.
Remote command: 
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:UCD:REQuest:
BOSTart on page 203

Request Backoff End
(only for burst type UCD)
Sets the end value for the request backoff.
Remote command: 
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:UCD:REQuest:
BOENd on page 202

Burst Profile Mapping
(only for burst type UCD and DCD)
Determines whether the burst profile mapping is performed automatically or manually.
In manual configuration, the mapping to the UIUCs/DUICs is user-definable.

Data configuration OFDMA
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Remote command: 
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:PMAP
on page 197

FEC & Modulation Type ← Burst Profile Mapping
(only for burst type UCD and DCD and manual Burst Profile Mapping)
Sets the FEC and the modulation for the selected UIUC/DUIC.
Remote command: 
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:PMAP:
DMODulation<dir0> on page 198
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:PMAP:
UMODulation<dir0> on page 198

3.18.2  PDU table

Access:

1. Proceed as described in "To access the data configuration settings" on page 81.

Data configuration OFDMA
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2. Activate "Multiple PDUs."

This dialog contains the parameters required to configure multiple PDU data in
OFDMA mode.

Each burst supports up to 16 PDUs with individual parameters. For each PDU, the
data length, the data source, the CID and the MAC can be individually configured.

Settings:

Data Length PDU OFDMA............................................................................................ 87
Data Source PDU OFDMA............................................................................................88
MAC CID (PDU)............................................................................................................ 88
MAC Config… PDU OFDMA.........................................................................................88

Data Length PDU OFDMA
Available for enabled parameter "Multiple PDUs" only
Sets the data length for the selected PDU in the burst.

Data configuration OFDMA



WiMAX configuration and settingsR&S®SMW-K49

88User Manual 1175.6732.02 ─ 19

Remote command: 
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:PDU<dir0>:
DLENgth on page 195

Data Source PDU OFDMA
Available for enabled parameter "Multiple PDUs" only
Sets the PDU data source.
The following standard data sources are available:
● "All 0, All 1"

An internally generated sequence containing 0 data or 1 data.
● "PNxx"

An internally generated pseudo-random noise sequence.
● "Pattern"

An internally generated sequence according to a bit pattern.
Use the "Pattern" box to define the bit pattern.

● "Data List/Select DList"
A binary data from a data list, internally or externally generated.
Select "Select DList" to access the standard "Select List" dialog.
– Select the "Select Data List > navigate to the list file *.dm_iqd > Select" to

select an existing data list.
– Use the "New" and "Edit" functions to create internally new data list or to edit

an existing one.
– Use the standard "File Manager" function to transfer external data lists to the

instrument.
See also:
● Section "Modulation Data" in the R&S SMW user manual.
● Section "File and Data Management" in the R&S SMW user manual.
● Section "Data List Editor" in the R&S SMW user manual
Remote command: 
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:PDU<dir0>:
DATA on page 194
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:PDU<dir0>:
DATA:DSELect on page 194
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:PDU<dir0>:
DATA:PATTern on page 195

MAC CID (PDU)
The command sets the CID (Connection Control Identifier) of the medium access con-
trol layer (MAC). The CID identifies a connection to equivalent peers in the MAC of the
base station and subscriber station.
Remote command: 
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:PDU<dir0>[:
MAC]:CID on page 197

MAC Config… PDU OFDMA
Accesses the dialog for configuring the MAC header panel for the selected PDU
(seePDU MAC configuration OFDMA).

Data configuration OFDMA
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Remote command: 
n.a.

3.19  FCH configuration downlink OFDMA

Access:

1. Select "General > Physical Layer Mode > OFDMA".

2. Select "Link Direction > Downlink".

3. Select "Frame Configuration (OFDMA) > Frame Configuration > Zone Table".

4. Select "Configure Zone > Config...".

5. Select "Burst Table > Burst Type > FCH".

6. Select "More Parameters > Config...".

This dialog contains the parameters required to configure the FCH options in
OFDMA mode.

Settings:

FCH Mode OFDMA.......................................................................................................89
Data Source OFDMA.................................................................................................... 90

FCH Mode OFDMA
Selects the mode for generating the FCH.
The Channel Coding of the FCH is performed both in "Auto" and "User" mode.

FCH configuration downlink OFDMA
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"Auto" In "Auto" mode, the DLFP (Downlink Frame Prefix) fields, which form
the FCH, are filled automatically with parameters specified at different
locations.
The following mapping applies in auto mode:
● Used subchannel bitmap

Set to the bitmap specified in the "Configure active Subchannels"
panel.

● Repetition_Coding_Indication
Specifies the DL-MAP repetition coding set in the "Configure DL-
MAP" panel.

● Coding_Indication
Specifies channel coding of the DL-MAP (CC or CTC)

● DL-Map_Length
Set to the number of slots allocated for the DL-MAP.

The FCH is transmitted with QPSK ½ and repetition coding of 4. For
FFT size 128, a reduced FCH is transmitted in one slot.

"User" In "User" mode, the FCH is filled with data specified under "Data
Source". It enables any arbitrary data to be sent with the FCH burst.
24 bits are read from the data source, these bits are repeated once to
form 48 bits. The FCH is transmitted with QPSK ½ and repetition cod-
ing of 4. For FFT size 128, a reduced FCH of size 12 bits is transmit-
ted in one slot.

Remote command: 
[:SOURce<hw>]:BB:WIMax:AOFDm:ZONE<st0>:FCH:MODE on page 163

Data Source OFDMA
Selects data source for the selected bursts.
The following standard data sources are available:
● "All 0, All 1"

An internally generated sequence containing 0 data or 1 data.
● "PNxx"

An internally generated pseudo-random noise sequence.
● "Pattern"

An internally generated sequence according to a bit pattern.
Use the "Pattern" box to define the bit pattern.

● "Data List/Select DList"
A binary data from a data list, internally or externally generated.
Select "Select DList" to access the standard "Select List" dialog.
– Select the "Select Data List > navigate to the list file *.dm_iqd > Select" to

select an existing data list.
– Use the "New" and "Edit" functions to create internally new data list or to edit

an existing one.
– Use the standard "File Manager" function to transfer external data lists to the

instrument.
See also:
● Section "Modulation Data" in the R&S SMW user manual.
● Section "File and Data Management" in the R&S SMW user manual.
● Section "Data List Editor" in the R&S SMW user manual

FCH configuration downlink OFDMA
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Remote command: 
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:DATA
on page 176
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:DATA:PATTern
on page 178
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:DATA:DSELect
on page 177

3.20  DL-MAP configuration downlink OFDMA

Access:

1. Select "General > Physical Layer Mode > OFDMA".

2. Select "Link Direction > Downlink".

3. Select "Frame Configuration (OFDMA) > Frame Configuration > Zone Table".

4. Select "Configure Zone > Config...".

5. Select "Burst Table > Burst Type > DL-MAP".

DL-MAP configuration downlink OFDMA
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6. Select "More Parameters > Config...".

This dialog contains the parameters required to configure the DL-MAP options in
OFDMA mode.

Settings:

DL-MAP Mode OFDMA.................................................................................................92
DL-MAP Repetition Coding OFDMA............................................................................. 94
Frame Number Offset DL-MAP OFDMA.......................................................................94
DCD Count DL-MAP OFDMA....................................................................................... 94
Base Station ID OFDMA............................................................................................... 94
Configure MAC OFDMA................................................................................................94
Include CID-Switch_IE() OFDMA..................................................................................94
Append DCD OFDMA................................................................................................... 94
DCD CID OFDMA......................................................................................................... 95
Compressed Map OFDMA............................................................................................95
Append Compressed UL-Map OFDMA.........................................................................95
Allocation Start Timebase OFDMA............................................................................... 95
Allocation Start Time OFDMA....................................................................................... 95
UL-MAP File OFDMA....................................................................................................96

DL-MAP Mode OFDMA
Selects the mode for generating the DL-MAP.

DL-MAP configuration downlink OFDMA
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Channel Coding of the DL-MAP is performed both in "Auto" and "User" mode.
"Auto" In "Auto" mode, the DL-MAP is filled automatically with parameters

specified at different locations.
The following mapping applies in auto mode:
● Frame duration code

Specified by the frame duration set in the WiMAX main panel.
● Frame number

Starts with the value specified by "Frame Number Offset" in the
first generated frame and advances by 1 in every following frame.

● DCD Count
Directly set by the "DCD Count" field.

● Base Station ID
48 bits specified by the "Base Station ID" field.

● No. OFDMA symbols
Set to the total number of OFDMA symbols in all downlink zones

For each burst:
● DIUC

Set to the "DIUC" field in the "More Param" Panel.
● CID

Set to the "CID" field in the" More Param" panel. This field is only
included if "Include CID-SWITCH_IE()" is active.

● OFDMA Symbol offset
Set to "Offset Symb" +1 for the first zone and to the absolute sym-
bol offset in all other zones.

● Subchannel offset
Set to "Offset Subch" of the burst table.

● Boosting
Depends on the "Boost" setting of the corresponding burst.
The following mapping applies:
000: 0dB
001: +6dB
010: -6dB
011: +9dB
100: +3dB
101: -3dB
110: -9dB
111: -12dB
000 is set if any other value is specified for "Boost".

● No. OFDMA Symbols
Set to "No. of Symb" of the burst table.

● No. Subchannels
Set to "No. of Subch" of the burst table.

● Repetition coding Indication
Set to repetition coding in the "More Param" panel.

"User" In "User" mode, the DL-MAP is filled with data specified under "Data
Source". It enables any arbitrary data to be sent with the DL-MAP
burst.

DL-MAP configuration downlink OFDMA
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Remote command: 
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:DLMap:MODE on page 210

DL-MAP Repetition Coding OFDMA
Repetition coding can be activated for the DL-MAP by specifying any value other than
0.
Remote command: 
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:DLMap:REPCoding
on page 210

Frame Number Offset DL-MAP OFDMA
Sets the frame number offset.
This value is added to the current frame number of the sequence. The result is used as
frame number in the DL-MAP (in "Auto" mode).
Remote command: 
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:DLMap:FNOFfset
on page 209

DCD Count DL-MAP OFDMA
Sets the DCD count value.
This value is used for the corresponding DL-MAP field (in "Auto" mode).
Remote command: 
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:DLMap:DATA:DCD[:COUNt]
on page 208

Base Station ID OFDMA
Sets the Base Station ID.
This value is used for the corresponding DL-MAP field in ("Auto" mode).
Remote command: 
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:DLMap:BSID on page 207

Configure MAC OFDMA
Calls the dialog for configuring the Mac header panel for the DL-MAP (refer to Chap-
ter 3.27, "MAC header configuration OFDMA", on page 116)
Remote command: 
n.a.

Include CID-Switch_IE() OFDMA
Includes/excludes the CID-Switch_IE().
Remote command: 
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:DLMap:IIE:STATe
on page 210

Append DCD OFDMA
If activated, the DCD is appended to the DL-MAP. The DCD message carries its own
MAC header and CRC, but is included within the DL-MAP burst.

DL-MAP configuration downlink OFDMA
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Remote command: 
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:DLMap:DCD:STATe
on page 209

DCD CID OFDMA
(only if "Append DCD > On")
Enters the value for the DCD CID.
This CID (connection control identifier) is independent from the DL-Map CID and is
only used for the DCD message.
Remote command: 
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:DLMap:DCD:CID on page 209

Compressed Map OFDMA
If activated, a compressed map is generated instead of a normal map.
Remote command: 
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:DLMap:COMPressed:STATe
on page 208

Append Compressed UL-Map OFDMA
(only if "Compressed Map > On")
If activated, a compressed UL-Map is appended to the DL-Map.
Remote command: 
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:DLMap:COMPressed:ULMap:
STATe on page 208

Allocation Start Timebase OFDMA
Selects the allocation start timebase, required for the UL-Map appended to the DL-
Map. The "Allocation Start Time" field of the UL-Map specifies the start of the uplink
subframe.
If "Start Timebase = DL Subframe End", the "Allocation Start Time" of the UL-Map is
set to the end of the downlink subframe+ the value set with the parameter Allocation
Start Time OFDMA.
When "Start Timebase = Frame Start", the allocation start Time of the UL-Map is set to
the beginning of the frame+ the value set with the parameter Allocation Start Time
OFDMA.
Remote command: 
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:DLMap:COMPressed:AMODe
on page 207

Allocation Start Time OFDMA
Sets the allocation start time in the UL-Map, appended to the DL-Map.
Remote command: 
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:DLMap:COMPressed:ATIMe
on page 207
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UL-MAP File OFDMA
Access the dialog for selecting the UL-MAP file.
Remote command: 
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:DLMap:COMPressed:ULMap:
DSELect on page 208

3.21  UL-MAP configuration downlink OFDMA

Access:

1. Select "General > Physical Layer Mode > OFDMA".

2. Select "Link Direction > Downlink".

3. Select "Frame Configuration (OFDMA) > Frame Configuration > Zone Table".

4. Select "Configure Zone > Config...".

5. Select "Burst Table > Burst Type > UL-MAP".

6. Select "More Parameters > Config...".

UL-MAP configuration downlink OFDMA
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This dialog provides the parameters required to configure the UL-MAP options in
OFDMA mode.

Settings:

DIUC OFDMA............................................................................................................... 97
MAC CID....................................................................................................................... 98
Configure MAC..............................................................................................................98
Channel Coding Randomizer........................................................................................ 98
FEC............................................................................................................................... 98
Interleaver..................................................................................................................... 98
Repetition Coding..........................................................................................................98
Include In SUB-DL-UL-MAP..........................................................................................98
Allocation Start Timebase............................................................................................. 99
Allocation Start Time..................................................................................................... 99
UL-MAP File..................................................................................................................99
Append DCD OFDMA................................................................................................... 99
DCD CID OFDMA......................................................................................................... 99
Append UCD OFDMA................................................................................................. 100
UCD CID OFDMA....................................................................................................... 100
Ranging Backoff Start................................................................................................. 100
Ranging Backoff End...................................................................................................100
Request Backoff Start................................................................................................. 100
Request Backoff End...................................................................................................100

DIUC OFDMA
Sets the specific DIUC.
In DL-MAP mode "Auto", the DIUC of each burst is included in the DL-MAP.
Remote command: 
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:DIUC
on page 178
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MAC CID
The command sets the CID (connection control identifier) of the medium access con-
trol layer (MAC). The CID identifies a connection to equivalent peers in the MAC of the
base station and subscriber station.
This parameter is identical to the CID set in the MAC Header settings.
Remote command: 
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:MAC:CID
on page 190
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:HARQ<dir0>:
MAC:CID on page 186

Configure MAC
Accesses the dialog for configuring the MAC header panel for the selected burst.
(Refer to Chapter 3.27, "MAC header configuration OFDMA", on page 116.)
Remote command: 
n.a.

Channel Coding Randomizer
Activates or deactivates the randomizer applied before channel coding.
Remote command: 
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:CCODing:
RANDomizer on page 175

FEC
Activates or deactivates the FEC.
Remote command: 
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:CCODing:FEC
on page 174

Interleaver
Activates or deactivates the interleaver state.
Remote command: 
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:CCODing:
INTerleaver on page 175

Repetition Coding
Activates repetition coding by specifying any value other than 0.
Remote command: 
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:CCODing:
REPCoding on page 176

Include In SUB-DL-UL-MAP
Selects whether a DL-MAP IE is included in the specified SUB-DL-UL-MAP message
for this burst.
The default value of this parameter is off. One of the three available SUB-DL-UL-MAPs
can be selected to carry the DL-MAP IE for this burst.

UL-MAP configuration downlink OFDMA
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Remote command: 
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:DLUL:INCLude
on page 179

Allocation Start Timebase
Selects the allocation start timebase. The "Allocation Start Time" field of the UL-MAP
specifies the start of the uplink subframe.
If "Start Timebase = DL Subframe End", the "Allocation Start Time" of the UL-Map is
set to the end of the downlink subframe+ the value set with the parameter Allocation
Start Time.
When "Start Timebase = Frame Start", the allocation start Time of the UL-Map is set to
the beginning of the frame+ the value set with the parameter Allocation Start Time.
Remote command: 
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:ULMap:AMODe
on page 203

Allocation Start Time
Sets the allocation start time in the UL-MAP.
Remote command: 
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:ULMap:ATIMe
on page 204

UL-MAP File
Accesses the dialog for selecting the UL-MAP file.
Remote command: 
n.a.

Append DCD OFDMA
If activated, the DCD is appended to the UL-MAP. The DCD message is transmitted
with its own MAC header and CRC, included in the same burst allocation used by the
UL-MAP.
Remote command: 
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:ULMap:DCD:
STATe on page 204

DCD CID OFDMA
("Append DCD > On")
Enters the value for the DCD CID.
This CID (connection control identifier) is independent from the UL-Map CID and only
used for the DCD.
Remote command: 
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:ULMap:DCD:
CID on page 204
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Append UCD OFDMA
If activated, the UCD is appended to the UL-MAP. The UCD message is transmitted
with its own MAC header and CRC, included in the same burst allocation used by the
UL-MAP.
Remote command: 
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:ULMap:UCD:
STATe on page 206

UCD CID OFDMA
("Append DCD > On")
Enters the value for the UCD CID.
This CID (connection control identifier) is independent from the DL-Map CID and only
used for the UCD.
Remote command: 
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:ULMap:UCD:
CID on page 206

Ranging Backoff Start
Sets the start value for the ranging backoff.
Remote command: 
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:ULMap:
RANGing:BOSTart on page 205

Ranging Backoff End
Sets the end value for the ranging backoff.
Remote command: 
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:ULMap:
RANGing:BOENd on page 205

Request Backoff Start
Sets the start value for the request backoff.
Remote command: 
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:ULMap:
REQuest:BOSTart on page 205

Request Backoff End
Sets the end value for the request backoff.
Remote command: 
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:ULMap:
REQuest:BOENd on page 205
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3.22  Generate UL-MAP uplink OFDMA

Access:

1. Select "General > Physical Layer Mode > OFDMA".

2. Select "Link Direction > Uplink".

3. Select "Frame Configuration (OFDMA) > Frame Configuration > Zone Table".

4. Select "Configure Zone > Config...".

5. Select "Common > Generate UL-MAP".

This dialog contains the parameters required for generating an UL-MAP.

Settings:

UCD Count OFDMA....................................................................................................101
Save UL-MAP Data OFDMA.......................................................................................102

UCD Count OFDMA
Sets the value for the UCD count.

Generate UL-MAP uplink OFDMA
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Remote command: 
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:UCD on page 213

Save UL-MAP Data OFDMA
Accesses the "File Select" window for saving the current UL-map.
The name of the file is specified in the "Filename" entry field, the directory selected in
the "save into" field. The file is saved by pressing the "Save" button.
The file is stored with the predefined file extension *.dm_iqd. The filename and the
directory it is stored in are user-definable.
The saved *.dm_iqd file is in data list format and contains a UL-MAP that describes
the current uplink zone.
The following list shows the parameters of the UL-MAP:
● UCD Count

Set to UCD Count specified above
● Allocation start time

Set to 0. Can be modified later when loading the UL-MAP in downlink mode
● No. OFDMA Symbols

Total number of OFDMA symbols in the uplink subframe.
● CID

CID from the "More Param" panel for each burst
● UIUC

UIUC from the "More Param" panel for each burst or 12 for ranging.
For ranging bursts:
● OFDMA Symbol offset

Symbol offset relative to allocation start time
● Subchannel offset

Lowest subchannel used for ranging allocation
● No. OFDMA symbols

Symbols in ranging allocation
● No. Subchannels

Subchannels in ranging allocation
● Ranging method

Defined by the "Opportunity Size" in the "Ranging" panel.
For data bursts:
● Duration

Burst duration in slots
● Repetition coding indication

Repetition coding from the "More Param" panel for each burst
Generating a valid UL-MAP
The following steps are required to generate a valid UL-MAP:
● Switch to uplink mode
● Define the layout of the uplink zone by setting a number of bursts and specifying

the parameters above for each burst
● Select "Generate UL-MAP" and save the UL-MAP to a file.
● Switch to downlink mode
● Set one of the downlinks bursts to "Burst Type UL-MAP"
● Open the "More Param" panel

Generate UL-MAP uplink OFDMA
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● Select "UL-MAP File" and load the file created before.
The downlink zone is then transmitting a UL-MAP that specifies the uplink structure
defined in uplink mode before.
Remote command: 
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:ULMap:CREate on page 213

3.23  Ranging uplink OFDMA

Access:

1. Select "General > Physical Layer Mode > OFDMA".

2. Select "Link Direction > Uplink".

3. Select "Frame Configuration (OFDMA) > Frame Configuration > Zone Table".

4. Select "Configure Zone > Config...".

5. Select "Burst Table > Burst Type > Ranging".

6. Select "More Parameters > Config...".

Ranging uplink OFDMA
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This dialog contains the parameters required to configure the Ranging options in
OFDMA mode.

Burst type Ranging offers ranging allocations which can be used for initial / periodic
ranging or bandwidth request transmissions. For each ranging / bandwidth request
slot, 8 bits are read from the data source. These 8 bits select the used code. The
codes are numbered from 0 to 255. For opportunity size 4, 8 bits are read once per
slot. The first code is specified by the 8 bits and the second consecutive code is the
first code advanced by one. For opportunity size 3, the same method is applied. The
second code is the first code + 1, the third code is the first code + 2.

Settings:

Opportunity Size..........................................................................................................104
No. Of Opportunity Slots............................................................................................. 104
No. Of Subchannel Groups......................................................................................... 104
No. Of Allocated Codes...............................................................................................105

Opportunity Size
Sets the ranging opportunity size. The opportunity size specifies the number of sym-
bols required to transmit one CDMA ranging code.
For initial ranging transmissions, values of 2 or 4 are used. With opportunity size 2, one
CDMA code is transmitted in two symbols. With opportunity size 4, two consecutive
ranging codes are transmitted in four symbols.
For periodic ranging and bandwidth request transmissions, values of 1 or 3 are used.
With opportunity size 1, one CDMA code is transmitted in one symbol. With opportunity
size 3, three consecutive ranging codes are transmitted in three symbols.
Remote command: 
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:RANGing:
OPPortunity:SIZE on page 199

No. Of Opportunity Slots
The number of opportunity slots defines the length of the ranging allocation:
Length of Ranging Allocation = OpportunitySize * NoOfOpportunitySlots OFDMA sym-
bols.
Remote command: 
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:RANGing:
OPPortunity:SLOTcount on page 200

No. Of Subchannel Groups
Sets the number of subchannel groups used in the ranging allocation. In PUSC mode,
six subchannels form one subchannel group.
Remote command: 
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:RANGing:
SCGCount on page 200

Ranging uplink OFDMA
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No. Of Allocated Codes
Displays the number of allocated codes. The number of codes is "NoOfOpportunity-
Slots" * "NoOfSubchannelGroups".
Consecutive codes of opportunity sizes 3 and 4 are not accounted.
Remote command: 
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:RANGing:
ACODe? on page 199

3.24  HARQ configuration OFDMA

This dialog provides all parameters to configure the HARQ options in OFDMA mode.
The selected HARQ mode determines the parameters available in the HARQ-sub burst
table.

To access this dialog

Access:

1. Select "General > Physical Layer Mode > OFDMA".

2. Select "Frame Configuration (OFDMA) > Frame Configuration > Zone Table".

3. Select "Configure Zone > Config...".

4. Select "Burst Table > Burst Type > HARQ".

5. Select "More Parameters > Config...".

Content

● OFDMA HARQ settings........................................................................................ 106
● HARQ sub-burst table...........................................................................................108

HARQ configuration OFDMA
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3.24.1  OFDMA HARQ settings

Access:

► Proceed as described in To access this dialog.

This dialog contains the parameters to configure the HARQ options in OFDMA
mode. HARQ bursts are only available with CTC channel coding.

Settings:

HARQ Mode................................................................................................................106
No. Of Sub-Bursts....................................................................................................... 106
Moving Start Offset Mode............................................................................................107
No. Of Slots Available In Burst....................................................................................108
Include In SUB-DL-UL-MAP........................................................................................108

HARQ Mode
Selects the mode of the HARQ burst.
"Chase" Selects chase combining HARQ. For each subburst, only one version

of the packet is generated.
"IR" Selects incremental redundancy HARQ. For each subburst, several

versions of encoded subpackets can be generated. They are identi-
fied by a subpacket ID (SPID).

Remote command: 
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:HARQ:MODE
on page 182

No. Of Sub-Bursts
Sets the number of subbursts in the HARQ bust. Each HARQ burst allocated in the
"Zone Configuration" panel can be divided into up to 15 subbursts. The length of each
subburst is set by the "Duration [Slots]" parameter.

HARQ configuration OFDMA
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Remote command: 
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:HARQ:COUNt
on page 182

Moving Start Offset Mode
(for HARQ Mode Chase only)
Enables/disables moving of start offset mode.
If enabled, the subburst structure resembles the specified structure required for MRCT
test 9.1.24.4, according to "WiMAX ForumTM Mobile Radio Conformance Test".

To use this mode according to the WiMAX MRCT specification, perform following con-
figuration:
● Configure exactly 3 HARQ subbursts.

The first and third subbursts are dummy bursts with QPSK modulation.
The second subburst is the desired subburst (with usually two FEC blocks).

● Configure the length of the first subburst such that it fills at least the first 4 symbols
(e.g. 64 slots in 1024 FFT mode).
This burst can be slightly longer than the slots available in the first four symbols.

● Configure the second subburst to the desired length.
● Configure the length of the third subburst such that it fills the remaining space.
● Enable "Moving Start Offset Mode".
● Select a desired number of frames (longer than one frame).
● Result:

The instrument modifies the length of the first and third subbursts so that the sec-
ond one moves it's start position with every frame. This behavior is as of the MRCT
requirement (mod(frame_index, N_subch)).
The dummy bursts are automatically cut off or enlarged as required.
The DL-MAP is updated with every frame to reflect the changed conditions.

HARQ configuration OFDMA
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Remote command: 
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:HARQ:
MSTart[:STATe] on page 182

No. Of Slots Available In Burst
Displays the remaining number of slots available for the burst. The number of slots is
defined in the zone configuration panel with "No. of Subch" and "No. of Symb" in the
downlink and "Duration [Slots]" in the uplink.
Remote command: 
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:HARQ:SLFRee?
on page 183

Include In SUB-DL-UL-MAP
Selects whether a DL-MAP IE is included in the specified SUB-DL-UL-MAP message
for this burst.
The default value of this parameter is off. One of the three available SUB-DL-UL-MAPs
can be selected to carry the DL-MAP IE for this burst.
Remote command: 
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:DLUL:INCLude
on page 179

3.24.2  HARQ sub-burst table

The parameters in the HARQ subburst table depend on the selected HARQ mode.
● HARQ Chase Mode

● "HARQ IR Mode"

HARQ configuration OFDMA
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Settings:

Sub-Burst Index.......................................................................................................... 109
Modulation & Coding Rate.......................................................................................... 109
Packet Size [Bits]........................................................................................................ 109
Duration [Slots]............................................................................................................110
Modulation...................................................................................................................110
Rate.............................................................................................................................110
Data Length.................................................................................................................110
Data Source.................................................................................................................110
DIUC............................................................................................................................111
MAC CID......................................................................................................................111
ACID............................................................................................................................ 111
SPID Sequence........................................................................................................... 111
ACK Disable................................................................................................................ 112
MAC.............................................................................................................................112

Sub-Burst Index
Displays the consecutive subburst index from 0 to 14.
All the rows are always displayed, even if the subbursts are inactive. They are
switched on and off by the selection of "No. of Sub-Bursts" above the table. The active
subbursts are highlighted.
Remote command: 
n.a.

Modulation & Coding Rate
(for "HARQ Chase Mode")
Sets the subburst modulation and coding rate.
Remote command: 
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:HARQ<dir0>:
MODRate on page 188

Packet Size [Bits]
(for "HARQ IR Mode")
Sets the HARQ subburst packet size (in bits).

HARQ configuration OFDMA
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Remote command: 
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:HARQ<dir0>:
PSIZe on page 189

Duration [Slots]
Sets the duration of the subbursts in slots. The duration range is dynamic and depends
on the selected link direction and packet size.
Remote command: 
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:HARQ<dir0>:
SLOTcount on page 189

Modulation
(for "HARQ IR Mode")
Displays the subburst modulation.
The modulation is determined by the parameters "Packet Size" and "Duration" and
cannot be altered directly.
Remote command: 
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:HARQ<dir0>:
FORMat? on page 186

Rate
(for "HARQ IR Mode")
Displays the subburst code rate. The code rate is determined by the parameters
"Packet Size" and "Duration" and cannot be altered directly
Remote command: 
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:HARQ<dir0>:
RATE? on page 189

Data Length
Sets the data length of the subburst. The data length range is dynamic and depends
on the packet size and the MAC header state.
Remote command: 
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:HARQ<dir0>:
DLENgth on page 186

Data Source
Selects data source for the selected subbursts.
The following standard data sources are available:
● "All 0, All 1"

An internally generated sequence containing 0 data or 1 data.
● "PNxx"

An internally generated pseudo-random noise sequence.
● "Pattern"

An internally generated sequence according to a bit pattern.
Use the "Pattern" box to define the bit pattern.

● "Data List/Select DList"
A binary data from a data list, internally or externally generated.
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Select "Select DList" to access the standard "Select List" dialog.
– Select the "Select Data List > navigate to the list file *.dm_iqd > Select" to

select an existing data list.
– Use the "New" and "Edit" functions to create internally new data list or to edit

an existing one.
– Use the standard "File Manager" function to transfer external data lists to the

instrument.
See also:
● Section "Modulation Data" in the R&S SMW user manual.
● Section "File and Data Management" in the R&S SMW user manual.
● Section "Data List Editor" in the R&S SMW user manual
Remote command: 
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:HARQ<dir0>:
DATA on page 184
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:HARQ<dir0>:
DATA:PATTern on page 185
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:HARQ<dir0>:
DATA:DSELect on page 185

DIUC
(for HARQ Chase Mode only)
Sets the DIUC ("Downlink Interval User Code") for the specified subburst.
Remote command: 
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:HARQ<dir0>:
DIUC on page 185

MAC CID
The command sets the CID (connection control identifier) of the medium access con-
trol layer (MAC). The CID identifies a connection to equivalent peers in the MAC of the
base station and subscriber station.
This parameter is identical to the CID set in the MAC Header settings.
Remote command: 
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:MAC:CID
on page 190
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:HARQ<dir0>:
MAC:CID on page 186

ACID
Sets the HARQ channel identifier for the specified subburst.
Remote command: 
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:HARQ<dir0>:
ACID on page 183

SPID Sequence
(for "HARQ IR Mode")

HARQ configuration OFDMA
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Sets the subpacket ID sequence which is used to select the generated subpacket out
of the four possible subpackets for each frame. Each SPID is identified by a number
from 0 to 3. Up to eight numbers can be entered, separated by colons.
During signal generation, one SPID out of the sequence is used to generate the
encoder packet for each frame. The index in the SPID sequence is advanced frame by
frame and starts again from the beginning after all entered numbers have been used.

Example: 
"SPID sequence = 0, 1, 2"
"Sequence Length = 10 frames"
The following sequence is output: 0, 1, 2, 0, 1, 2, 0, 1, 2, 0

Remote command: 
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:HARQ<dir0>:
SPID on page 190

ACK Disable
Disables ACK, i.e. the allocated subburst does not require an ACK to be transmitted .
Remote command: 
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:HARQ<dir0>:
ACKD on page 184

MAC
Accesses the dialog for configuring the generic MAC (Media Access Control) header of
the selected subburst and for activating the checksum determination.
Remote command: 
n.a.

3.25  Fast feedback configuration OFDMA

Access:

1. Select "General > Physical Layer Mode > OFDMA".

2. Select "Link Direction > Uplink".

3. Select "Frame Configuration (OFDMA) > Frame Configuration > Zone Table".

4. Select "Configure Zone > Config...".

5. Select "Burst Table > Burst Type > FastFb".

6. Select "More Parameters > Config...".

Fast feedback configuration OFDMA
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This dialog contains the parameters to configure fast feedback in OFDMA mode.

Settings:

Fast Feedback Mode...................................................................................................113
Codeword Size............................................................................................................ 113
No. Of Subchannels.................................................................................................... 114
No. Of Symbols........................................................................................................... 114
MAC CID..................................................................................................................... 114

Fast Feedback Mode
Selects the fast feedback mode.
Remote command: 
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:FFB:MODE
on page 180

Codeword Size
Displays the codeword size. The codeword size depends on the selected "Fast Feed-
back Mode". In "Normal" mode, 4 bits are read out of the data source and are mapped
to one fast feedback slot. In "Enhanced" mode, 6 bits are mapped to one slot.

Fast feedback configuration OFDMA
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The enhanced (MIMO) and ACK modes use two codewords per slot. In enhanced
(MIMO) mode, two times 3 bits are read out of the data source and are mapped to one
slot. The first 3 bits are mapped to tiles 0, 2, and 4; the second 3 bits are mapped to
tile 1, 3, and 5. For the ACK mode, the procedure is similar. Here, the first bit is map-
ped to the first half slot and the second bit is mapped to the second half slot.
The data source is read out continuously over the configured frames, MSB first. Read-
ing the data source is restarted from the beginning if the data source is smaller than on
of the following:
● Number of bits required by the codeword size
● Number of slots in the allocation
● Configured sequence length
Remote command: 
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:FFB:CWSize?
on page 180

No. Of Subchannels
Sets the number of subchannels. The number of slots in the fast feedback allocation is
subchannels * symbols / 3.
Remote command: 
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:FFB:SUBC
on page 181

No. Of Symbols
Sets the number of symbols. The number of slots in the fast feedback allocation is sub-
channels * symbols / 3.
Remote command: 
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:FFB:SYMB
on page 181

MAC CID
Sets the connection control identifier (CID) of the medium access control layer (MAC).
The CID identifies a connection to equivalent peers in the MAC of the base station and
subscriber station.
This parameter is identical to the CID set in the MAC Header settings.
Remote command: 
[:SOURce<hw>]:BB:WIMax:OFDM:BURSt<ch0>:MAC:CID on page 219

3.26  SUB-DL-UL-MAP configuration OFDMA

Access:

1. Select "General > Physical Layer Mode > OFDMA".

2. Select "Link Direction > Downlink".

3. Select "Frame Configuration (OFDMA) > Frame Configuration > Zone Table".

SUB-DL-UL-MAP configuration OFDMA
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4. Select "Configure Zone > Config...".

5. Select "Burst Table > Burst Type > SUB-MAP".

6. Select "More Parameters > Config...".

This dialog contains the parameters to configure the SUB-MAP options in OFDMA
mode.

Settings:

SUB-DL-UL-MAP Index...............................................................................................115
DIUC OFDMA..............................................................................................................116
HARQ ACK Offset Indicator........................................................................................ 116
DL HARQ ACK Offset..................................................................................................116

└ UL HARQ ACK Offset................................................................................... 116
ACK Region Index.......................................................................................................116

SUB-DL-UL-MAP Index
Displays the number of the SUB-DL-UL-MAP message.
Altogether up to three SUB-DL-UL-MAP messages can be enabled for all zones. The
"SUB-DL-UL-MAP Index" is a consecutive number that is assigned for each configured
SUB-DL-UL-MAP message.

SUB-DL-UL-MAP configuration OFDMA
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Remote command: 
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:DLUL:MPIX?
on page 180

DIUC OFDMA
Sets the specific DIUC.
In DL-MAP mode "Auto", the DIUC of each burst is included in the DL-MAP.
Remote command: 
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:DIUC
on page 178

HARQ ACK Offset Indicator
Enables/disables the inclusion of HARQ offsets.
Remote command: 
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:DLUL:HARQ:
ACKoffset:INDicator on page 179

DL HARQ ACK Offset
Sets the ACK channel that corresponds to the first HARQ-enabled DL burst specified
in this map message.
Remote command: 
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:DLUL:HARQ:
ACKoffset:DL on page 178

UL HARQ ACK Offset ← DL HARQ ACK Offset
Sets the ACK bit index in the DL HARQ ACK that corresponds to the first HARQ-
enabled UL burst specified in this map message.
Remote command: 
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:DLUL:HARQ:
ACKoffset:UL on page 179

ACK Region Index
Selects whether ACK region 0 or 1 is used.
Remote command: 
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:DLUL:ARIX
on page 178

3.27  MAC header configuration OFDMA

Access:

1. Select "General > Physical Layer Mode > OFDMA".

2. Select "Frame Configuration (OFDMA) > Frame Configuration > Zone Table".

3. Select "Configure Zone > Config...".

MAC header configuration OFDMA



WiMAX configuration and settingsR&S®SMW-K49

117User Manual 1175.6732.02 ─ 19

4. Select "Burst Table > More Parameters > Config...".

5. Select "MAC > Config...".

This dialog contains the settings for a generic MAC header of the corresponding
zone and burst. The MAC header is placed at the beginning of the burst when acti-
vated.

In addition CRC (Cyclic Redundancy Check) can be activated, which is added at the
end of the burst. It covers MAC header and all data.

Settings:

CRC State................................................................................................................... 117
MAC Header State...................................................................................................... 118
MAC CID..................................................................................................................... 118
Payload encrypted.......................................................................................................118
EKS............................................................................................................................. 118
Mac Type.....................................................................................................................118

CRC State
Activates/deactivates the checksum determination. The state of the CRC can be set
independently of the state of MAC header generation.

MAC header configuration OFDMA
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Remote command: 
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:MAC:CRC:
STATe on page 190
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:HARQ<dir0>:
MAC:CRC:STATe on page 187

MAC Header State
Activates the generation of the generic MAC header.
Remote command: 
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:MAC:STATe
on page 191
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:HARQ<dir0>:
MAC:STATe on page 188

MAC CID
The command sets the CID (connection control identifier) of the medium access con-
trol layer (MAC). The CID identifies a connection to equivalent peers in the MAC of the
base station and subscriber station.
This parameter is identical to the CID set in the MAC Header settings.
Remote command: 
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:MAC:CID
on page 190
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:HARQ<dir0>:
MAC:CID on page 186

Payload encrypted
Activates/deactivates payload encryption.
If activated, the EC (Encryption Control) field is set to 1 and the EKS ("Encryption Key
Sequence") field can be set.
Remote command: 
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:MAC:
ENCRypted:STATe on page 191
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:HARQ<dir0>:
MAC:ENCRypted:STATe on page 187

EKS
Sets the EKS ("Encryption Key Sequence") value in the MAC header. The payload
encryption itself is not performed by the signal generator.
Remote command: 
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:MAC:EKS
on page 191
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:HARQ<dir0>:
MAC:EKS on page 187

Mac Type
Specifies the MAC type.

MAC header configuration OFDMA
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The value of the 6-bit type field is set which indicates the payload type, including the
presence of subheaders.
Remote command: 
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:MAC:TYPE
on page 192
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:HARQ<dir0>:
MAC:TYPE on page 188

3.28  PDU MAC configuration OFDMA

Access:

1. Select "General > Physical Layer Mode > OFDMA".

2. Select "Frame Configuration (OFDMA) > Frame Configuration > Zone Table".

3. Select "Configure Zone > Config...".

4. Select "Burst Table > Burst Type > Data".

5. Select "More Parameters > Config...".

6. Select "Multiple PDUS > On > MAC > Config...".

PDU MAC configuration OFDMA
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This dialog contains the settings for the generic PDU MAC header of the corre-
sponding zone, burst and PDU combination. The MAC header is placed at the
beginning of the PDU when activated.

In addition CRC (Cyclic Redundancy Check) can be activated, which is added at the
end of the PDU. It covers MAC header and all data.

Settings:

CRC State (PDU)........................................................................................................ 120
MAC Header State (PDU)........................................................................................... 121
MAC CID (PDU).......................................................................................................... 121
Payload encrypted (PDU)........................................................................................... 121
EKS (PDU).................................................................................................................. 121
Mac Type (PDU)..........................................................................................................121

CRC State (PDU)
Activates/deactivates the checksum determination. The state of the CRC can be set
independently of the state of MAC header generation.
Remote command: 
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:PDU<dir0>:
MAC:CRC:STATe on page 195

PDU MAC configuration OFDMA
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MAC Header State (PDU)
Activates the generation of the generic MAC header.
Remote command: 
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:PDU<dir0>:
MAC:STATe on page 196

MAC CID (PDU)
The command sets the CID (Connection Control Identifier) of the medium access con-
trol layer (MAC). The CID identifies a connection to equivalent peers in the MAC of the
base station and subscriber station.
Remote command: 
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:PDU<dir0>[:
MAC]:CID on page 197

Payload encrypted (PDU)
Activates/deactivates payload encryption.
If activated, the EC (Encryption Control) field is set to 1 and the EKS ("Encryption Key
Sequence) "field can be set.
Remote command: 
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:PDU<dir0>:
MAC:ENCRypted:STATe on page 196

EKS (PDU)
Sets the EKS ("Encryption Key Sequence") value in the MAC header. The payload
encryption itself is not performed by the signal generator.
Remote command: 
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:PDU<dir0>:
MAC:EKS on page 196

Mac Type (PDU)
Specifies the MAC type.
The value of the 6-bit type field is set which indicates the payload type, including the
presence of subheaders.
Remote command: 
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:PDU<dir0>:
MAC:TYPE on page 197

3.29  Filter / clipping settings

Access:

► Select "Baseband > IEEE 802.16 WiMAX > General > Filter/Clipping...".

The dialog contains the settings required to configure the baseband filter and to
enable clipping.

Filter / clipping settings
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Settings:

3.29.1  Filter settings

Access:

► Select "Filter".

This dialog contains the parameters for configuring the baseband filter.

Settings:

Filter............................................................................................................................ 122
Rolloff Factor or BxT................................................................................................... 123
Cutoff Frequency Shift.................................................................................................123
Cutoff Frequency Factor..............................................................................................124
Filter Mode.................................................................................................................. 124
Sample Rate Variation.................................................................................................124

Filter
Selects the baseband filter.

Filter / clipping settings
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Remote command: 
[:SOURce<hw>]:BB:WIMax:FILTer:TYPE on page 137

Rolloff Factor or BxT
Sets the filter parameter.
The filter parameter ("Roll off Factor" or "BxT") depends on the currently selected filter
type. This parameter is preset to the default for each of the predefined filters.

Figure 3-1: Example of the frequency response of a filter with different rolloff factors

For the default cosine filter, a rolloff factor of 0.07 is used.
Remote command: 
[:SOURce<hw>]:BB:WIMax:FILTer:PARameter:APCO25 on page 137
[:SOURce<hw>]:BB:WIMax:FILTer:PARameter:COSine on page 137
[:SOURce<hw>]:BB:WIMax:FILTer:PARameter:GAUSs on page 138
[:SOURce<hw>]:BB:WIMax:FILTer:PARameter:PGAuss on page 139
[:SOURce<hw>]:BB:WIMax:FILTer:PARameter:RCOSine on page 139
[:SOURce<hw>]:BB:WIMax:FILTer:PARameter:SPHase on page 140

Cutoff Frequency Shift
(for filter parameter "Cosine")
The cutoff frequency is a filter characteristic that defines the frequency at the 3 dB
down point. The "Cut Off Frequency Shift" affects this frequency in the way that the fil-
ter flanks are "moved" and the transition band increases by "Cut Off Frequency
Shift"*"Sample Rate".
● A "Cut Off Frequency Shift" = -1 results in a very narrow-band filter
● Increasing the value up to 1 makes the filter more broad-band
● By "Cut Off Frequency Shift" = 0, the -3 dB point is at the frequency determined by

the half of the selected "Sample Rate".
Tip: Use this parameter to adjust the cutoff frequency and reach spectrum mask
requirements.

Filter / clipping settings
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Figure 3-2: Example of the frequency response of a filter with different cutoff frequency shift

Remote command: 
[:SOURce<hw>]:BB:WIMax:FILTer:PARameter:COSine:COFS on page 138

Cutoff Frequency Factor
Sets the value for the cutoff frequency factor. The cutoff frequency of the filter can be
adjusted to reach spectrum mask requirements.
Remote command: 
[:SOURce<hw>]:BB:WIMax:FILTer:PARameter:LPASs on page 138
[:SOURce<hw>]:BB:WIMax:FILTer:PARameter:LPASSEVM on page 139

Filter Mode
Selects whether to apply the filter in real time mode or offline mode.
"Realtime" The filter is applied to the signal in real-time mode.
"Offline" The filter is applied to the signal in offline mode.

This option increases the calculation time and reduces the maximum
number of generated frames that can be fit into the ARB memory. It
can be useful to filter the signal in offline mode if steeper filter edges
are required. In offline mode, more taps are used for the filters; there-
fore the roll of factor can be further decreased.

Remote command: 
[:SOURce<hw>]:BB:WIMax:FILTer:MODE on page 137

Sample Rate Variation
Sets the sample rate of the signal.
A variation of this parameter only affects the ARB clock rate; all other signal parame-
ters remain unchanged. If the sampling rate in the frame configuration dialog is
changed, this parameter is reset to the chosen sampling rate.
Remote command: 
[:SOURce<hw>]:BB:WIMax:SRATe:VARiation on page 140

Filter / clipping settings
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3.29.2  Clipping settings

Access:

► Select "Clipping".

This dialog comprises the settings for clipping.

Settings:

Clipping State..............................................................................................................125
Clipping Level..............................................................................................................126
Clipping Mode............................................................................................................. 126

Clipping State
Switches baseband clipping on and off.
Baseband clipping is a simple and effective way of reducing the crest factor of the sig-
nal. Since clipping is done before to filtering, the procedure does not influence the
spectrum. The EVM however increases.
Remote command: 
[:SOURce<hw>]:BB:WIMax:CLIPping:STATe on page 136

Filter / clipping settings
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Clipping Level
Sets the limit for clipping.
This value indicates at what point the signal is clipped. It is specified as a percentage,
relative to the highest level. 100% indicates that clipping does not take place.
Remote command: 
[:SOURce<hw>]:BB:WIMax:CLIPping:LEVel on page 135

Clipping Mode
Selects the clipping method. The dialog displays a graphical illustration on how this two
methods work.
● "Vector | i + jq |"

The limit is related to the amplitude | i + q |. The I and Q components are mapped
together, the angle is retained.

● "Scalar | i | , | q |"
The limit is related to the absolute maximum of all the I and Q values | i | + | q |.
The I and Q components are mapped separately, the angle changes.

Remote command: 
[:SOURce<hw>]:BB:WIMax:CLIPping:MODE on page 136

3.29.3  Data dump

► To access this dialog, select "Data Dump".

Filter / clipping settings
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This dialog contains the parameters to configure data dump.

Provided are the following settings:

Dump Input Data for Bursts to Files
Activates burst input data dump.
The data that is fed into the channel coding of each burst. It is output into files named
data_frameXXXX_zoneY_burstZZ.dat, where XXXX specifies the frame number,
Y the zone index and ZZ the burst index. The files contain all data including MAC
header and CRC in ASCII hex format, MSB left. Read the files from left to right.
Remote command: 
[:SOURce<hw>]:BB:WIMax:BDUMp:STATe on page 135

Output directory for Dump Files
Defines the directory the instrument stores the dumped burst data files in.
If the field is empty, the firmware directory is used (such
as ..\Program Files\Rohde&Schwarz\SMx\Firmware).

Remote command: 
[:SOURce<hw>]:BB:WIMax:BDUMp:DIRectory on page 135

Filter / clipping settings
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4  Remote-control commands
The following commands are required to perform signal generation with the IEEE
802.16 WiMAX options in a remote environment. We assume that the R&S SMW has
already been set up for remote operation in a network as described in the R&S SMW
documentation. Knowledge about the remote control operation and the SCPI command
syntax is assumed.

Conventions used in SCPI command descriptions
For a description of the conventions used in the remote command descriptions, see
section "Remote Control Commands" in the R&S SMW user manual.

The SOURce:BB:WIMax subsystem contains commands for the primary and general
settings of the IEEE 802.16 WiMAX standard. These settings concern activation and
deactivation of the standard, setting the transmission direction, filter, clock, trigger and
clipping settings, defining the frame duration and the sequence length, as well as the
preset setting.

The commands for defining the frame configuration for physical layer modes OFDM
and OFDMA are described in the next section. The commands are divided up in this
way to make the comprehensive SOURce:BB:WIMax subsystem clearer.

Common suffixes

The following common suffixes are used in remote commands:

Suffix Value range Description

ENTity<ch> 1 .. 4 entity in a multiple entity configuration with separate base-
band sources

ENTity3|4 require option R&S SMW-K76

SOURce<hw> [1] to 4 available baseband signals

only SOURce1 possible, if the keyword ENTity is used

OUTPut<ch> 1 to 3 available markers

BURSt<ch0> 0...63 available bursts

CID<ch0> 0...15 available connection control identifiers (CIDs) for "Physical
Layer Mode > OFDMA"

HARQ<dir0> 0...14 available subbursts in the 2D region for "Physical Layer
Mode > OFDMA"

PDU<dir0> 0...16 available PDUs in the burst for "Physical Layer Mode >
OFDMA"

ZONE<st0> 0...7 available zones for "Physical Layer Mode > OFDMA"
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Using SCPI command aliases for advanced mode with multiple entities
You can address multiple entities configurations by using the SCPI commands starting
with the keyword SOURce or the alias commands starting with the keyword ENTity.
Note that the meaning of the keyword SOURce<hw> changes in the second case.
For details, see section "SCPI Command Aliases for Advanced Mode with Multiple
Entities" in the R&S SMW user manual.

The following commands specific to the IEEE 802.16 WiMAX standard are described
here:

4.1 General commands...................................................................................................129

4.2 Filter and clipping commands................................................................................. 135

4.3 Trigger commands.................................................................................................... 140

4.4 Marker commands.................................................................................................... 148

4.5 Clock commands...................................................................................................... 150

4.6 OFDMA physical layer commands.......................................................................... 151

4.7 OFDM physical layer commands.............................................................................213

4.1  General commands

[:SOURce<hw>]:BB:WIMax:DUPLexing........................................................................... 129
[:SOURce<hw>]:BB:WIMax:FRAMe:BURSt:DELay........................................................... 130
[:SOURce<hw>]:BB:WIMax:FRAMe:TIME........................................................................ 130
[:SOURce<hw>]:BB:WIMax:FRAMe:TIME:USER.............................................................. 131
[:SOURce<hw>]:BB:WIMax:LINK.....................................................................................131
[:SOURce<hw>]:BB:WIMax:MODE.................................................................................. 131
[:SOURce<hw>]:BB:WIMax:PRESet................................................................................ 131
[:SOURce<hw>]:BB:WIMax:SETTing:CATalog?.................................................................132
[:SOURce<hw>]:BB:WIMax:SETTing:DELete....................................................................132
[:SOURce<hw>]:BB:WIMax:SETTing:LOAD......................................................................132
[:SOURce<hw>]:BB:WIMax:SETTing:STORe....................................................................133
[:SOURce<hw>]:BB:WIMax:SLENgth...............................................................................133
[:SOURce<hw>]:BB:WIMax:STATe...................................................................................133
[:SOURce<hw>]:BB:WIMax:SUBFrame:TIME................................................................... 134
[:SOURce<hw>]:BB:WIMax:WAVeform:CREate................................................................ 134
[:SOURce<hw>][:BB]:WIMax:SVERsion........................................................................... 134

[:SOURce<hw>]:BB:WIMax:DUPLexing <Duplexing>

Selects the duplexing. The duplexing mode determines how the uplink and downlink
signal are separated.

General commands
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Parameters:
<Duplexing> TDD | FDD

*RST: TDD

Example: BB:WIM:DUPL FDD
selects frequency division duplexing.

Manual operation: See "Duplexing" on page 20

[:SOURce<hw>]:BB:WIMax:FRAMe:BURSt:DELay <Delay>

The command sets the delay for the first uplink burst.

The command is only available for physical layer mode OFDM in uplink and for FDD
duplexing.

Parameters:
<Delay> float

Range: 0 s  to  1E6 s>
Increment: 1 µs
*RST: 0 s

Example: BB:WIM:MODE OFDM
selects physical layer mode OFDM.
BB:WIM:LINK UP
selects transmission direction uplink.
BB:WIM:DUP FDD
selects FDD duplexing.
BB:WIM:FRAM:BURS:DEL 0.004
selects a delay of 4 ms for the first burst.

Manual operation: See "Initial Delay of Burst 1" on page 32

[:SOURce<hw>]:BB:WIMax:FRAMe:TIME <Time>

The command selects the frame duration. Only distinct values are allowed in the stan-
dard. For test reasons, continuous generation or generation for a freely selectable
duration (USER) are available. The user duration is set with command
SOUR:BB:WIM:FRAM:TIME:USER. In continuous mode, the frame duration equals the
sum of the burst durations.

Parameters:
<Time> MS2 | MS2D5 | MS4 | MS5 | MS8 | MS10 | MS12D5 | MS20 |

CONTinuous | USER
*RST: MS10

Example: BB:WIM:FRAM:TIME MS12D5
selects a frame length of 12.5 ms.

Manual operation: See "Frame Duration" on page 31
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[:SOURce<hw>]:BB:WIMax:FRAMe:TIME:USER <User>

The command sets the frame duration to a freely selectable value.

Parameters:
<User> float

Range: 0 s  to  0.1 s
Increment: 1E-6 s
*RST: 0.01s

Manual operation: See "User Frame Duration" on page 31

[:SOURce<hw>]:BB:WIMax:LINK <Link>

The command defines the transmission direction. The signal either corresponds to that
of a base station (FORWard | DOWN) or that of a subscriber station (REVerse | UP).

Parameters:
<Link> FORWard | REVerse | UP | DOWN

*RST: FORWard

Example: BB:WIM:LINK DOWN
the transmission direction selected is base station to subscriber
station. The signal corresponds to that of a base station.

Manual operation: See "Link Direction" on page 21

[:SOURce<hw>]:BB:WIMax:MODE <Mode>

Selects the Physical Layer Mode.

Parameters:
<Mode> OFDM | AOFDm | WIBRo | AAI

AOFDm
Orthogonal Frequency Division Multiple Access (OFDMA)
*RST: OFDM

Example: BB:WIM:MODE OFDM
Selects physical layer mode OFDM.

Manual operation: See "Physical Layer Mode" on page 19

[:SOURce<hw>]:BB:WIMax:PRESet

Sets the parameters of the digital standard to their default values (*RST values speci-
fied for the commands).

Not affected is the state set with the command SOURce<hw>:BB:WIMax:STATe.

Example: SOURce1:BB:WIMax:PRESet
Usage: Event
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Manual operation: See "Set to Default" on page 17

[:SOURce<hw>]:BB:WIMax:SETTing:CATalog?

This command reads out the files with IEEE 802.16 settings in the default directory.
The default directory is set using command MMEM:CDIRectory. Only files with the file
extension *.wimax are listed.

Return values: 
<Catalog> string

Example: MMEM:CDIR "/var/user/temp/wimax"
Sets the default directory to /var/user/temp/wimax.
BB:WIM:SETT:CAT?
Reads out all the files with IEEE 802.16 settings in the default
directory.
Response: "ofdm","fbpsk"
The files ofdm and fbpsk are available.

Usage: Query only

Manual operation: See "Save/Recall" on page 19

[:SOURce<hw>]:BB:WIMax:SETTing:DELete <Filename>

This command deletes the selected file with IEEE 802.16 WiMAX settings. The direc-
tory is set using command MMEM:CDIRectory. A path can also be specified, in which
case the files in the specified directory are read. The file extension can be omitted.
Only files with the file extension *.wimax are deleted.

Setting parameters: 
<Filename> string

Example: BB:WIM:SETT:DEL 'ofdm'
Deletes file ofdm.

Usage: Setting only

Manual operation: See "Save/Recall" on page 19

[:SOURce<hw>]:BB:WIMax:SETTing:LOAD <Filename>

This command loads the selected file with IEEE 802.16 WiMAX settings. The directory
is set using command MMEM:CDIRectory. A path can also be specified, in which
case the files in the specified directory are read. The file extension can be omitted.
Only files with the file extension *.wimax are loaded.

Setting parameters: 
<Filename> string

Example: BB:WIM:SETT:LOAD 'ofdm'
Loads file ofdm.
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Usage: Setting only

Manual operation: See "Save/Recall" on page 19

[:SOURce<hw>]:BB:WIMax:SETTing:STORe <Filename>

This command stores the current IEE 802.16 WIMAX settings into the
selected file. The directory is set using command MMEM:CDIRec-
tory. A path can also be specified, in which case the files in the specified directory are
read. Enter only the file name. IEE 802.16 WIMAX settings are stored as files with the
specific file extensions *.wimax.

Setting parameters: 
<Filename> string

Example: BB:WIM:SETT:STOR 'ofdm_tdd'
Stores the current settings into file ofdm_tdd.

Usage: Setting only

Manual operation: See "Save/Recall" on page 19

[:SOURce<hw>]:BB:WIMax:SLENgth <SLength>

Sets the number of frames. The maximum number of frames depends on the sampling
rate, the set frame length (2 x sampling rate x frame length / command
BB:WIM:FRAM:TIM) and the supplied ARB memory size.

Parameters:
<SLength> integer

Range: 1  to  MAX
*RST: 1

Example: BB:WIM:SLEN 4
selects the generation of 4 frames.

Manual operation: See "Sequence Length" on page 32

[:SOURce<hw>]:BB:WIMax:STATe <State>

Activates the standard and deactivates all the other digital standards and digital modu-
lation modes in the same path.

Parameters:
<State> 1 | ON | 0 | OFF

*RST: 0

Example: SOURce1:BB:WIMax:STATe ON
Manual operation: See "State" on page 17
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[:SOURce<hw>]:BB:WIMax:SUBFrame:TIME <Time>

The command set the duration of the downlink subframe.

The command is only available for uplink direction and when TDD is selected (in case
of two-path instruments, on the same path.

Parameters:
<Time> float

Range: 0 ms  to  20 ms
Increment: 0.001ms
*RST: 0 ms

Example: BB:WIM:LINK UP
selects uplink transmission.
BB:WIM:DUPL TDD
selects time division duplexing.
BB:WIM:SUBF:TIME 2ms
sets a subframe duration of 2 ms.

Manual operation: See "Downlink Subframe Duration" on page 31

[:SOURce<hw>]:BB:WIMax:WAVeform:CREate <Filename>

This command creates a waveform using the current settings of the "WiMAX" menu.
The file name is entered with the command. The file is stored with the predefined file
extension *.wv. The file name and the directory it is stored in are user-definable.

Setting parameters: 
<Filename> string

Example: MMEM:CDIR "/var/user/temp/waveform"
sets the default directory to /var/user/temp/waveform.
BB:WIM:WAV:CRE "wimax_1"
creates the waveform file wimax_1.wv in the default directory.

Usage: Setting only

Manual operation: See "Generate Waveform File…" on page 19

[:SOURce<hw>][:BB]:WIMax:SVERsion <SVersion>

Selects the version of the standard to use.

Parameters:
<SVersion> VC1 | VC2D4 | VC3

*RST: VC1

Manual operation: See "Version" on page 20
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4.2  Filter and clipping commands

[:SOURce<hw>]:BB:WIMax:BDUMp:DIRectory................................................................. 135
[:SOURce<hw>]:BB:WIMax:BDUMp:STATe...................................................................... 135
[:SOURce<hw>]:BB:WIMax:CLIPping:LEVel..................................................................... 135
[:SOURce<hw>]:BB:WIMax:CLIPping:MODE....................................................................136
[:SOURce<hw>]:BB:WIMax:CLIPping:STATe.................................................................... 136
[:SOURce<hw>]:BB:WIMax:FILTer:TYPE......................................................................... 137
[:SOURce<hw>]:BB:WIMax:FILTer:MODE........................................................................ 137
[:SOURce<hw>]:BB:WIMax:FILTer:PARameter:APCO25....................................................137
[:SOURce<hw>]:BB:WIMax:FILTer:PARameter:COSine..................................................... 137
[:SOURce<hw>]:BB:WIMax:FILTer:PARameter:COSine:COFS........................................... 138
[:SOURce<hw>]:BB:WIMax:FILTer:PARameter:GAUSs......................................................138
[:SOURce<hw>]:BB:WIMax:FILTer:PARameter:LPASs.......................................................138
[:SOURce<hw>]:BB:WIMax:FILTer:PARameter:LPASSEVM............................................... 139
[:SOURce<hw>]:BB:WIMax:FILTer:PARameter:PGAuss.....................................................139
[:SOURce<hw>]:BB:WIMax:FILTer:PARameter:RCOSine...................................................139
[:SOURce<hw>]:BB:WIMax:FILTer:PARameter:SPHase.....................................................140
[:SOURce<hw>]:BB:WIMax:SRATe:VARiation...................................................................140

[:SOURce<hw>]:BB:WIMax:BDUMp:DIRectory <Directory>

Defines the directory the dumped burst date files are to be stored in.

If no directory is specified, the dumped files are stored in the firmware directory.

Parameters:
<Directory> string

Example: see [:SOURce<hw>]:BB:WIMax:BDUMp:STATe on page 135

Manual operation: See "Output directory for Dump Files" on page 127

[:SOURce<hw>]:BB:WIMax:BDUMp:STATe <State>

Activates burst input data dump.

Parameters:
<State> 1 | ON | 0 | OFF

*RST: 0

Example: SOURce1:BB:WIMax:BDUMp:DIRirectory
"/var/user/temp/dump"
sets the directory for OFDMA burst input dump.
SOURce1:BB:WIMax:BDUMp:STATe ON
activates burst input data dump.

Manual operation: See "Dump Input Data for Bursts to Files" on page 127

[:SOURce<hw>]:BB:WIMax:CLIPping:LEVel <Level>

Sets the limit for level clipping.
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Parameters:
<Level> integer

Range: 1  to  100
*RST: 100

Example: BB:WIM:CLIP:LEV 80PCT
sets the limit for level clipping to 80% of the maximum level.
BB:WIM:CLIP:STAT ON
activates level clipping.

Manual operation: See "Clipping Level" on page 126

[:SOURce<hw>]:BB:WIMax:CLIPping:MODE <Mode>

The command sets the method for level clipping (Clipping).

Parameters:
<Mode> VECTor | SCALar

VECTor
The reference level is the amplitude | i+jq |.
SCALar
The reference level is the absolute maximum of the I and Q val-
ues.
*RST: VECTor

Example: BB:WIM:CLIP:MODE SCAL
selects the absolute maximum of all the I and Q values as the
reference level.
BB:WIM:CLIP:LEV 80PCT
sets the limit for level clipping to 80% of this maximum level.
BB:WIM:CLIP:STAT ON
activates level clipping.

Manual operation: See "Clipping Mode" on page 126

[:SOURce<hw>]:BB:WIMax:CLIPping:STATe <State>

The command activates level clipping (Clipping). The value is defined with the com-
mand [SOURce:]BB:WIMax:CLIPping:LEVel, the mode of calculation with the
command [SOURce:]BB:WIMax:CLIPping:MODE.

Parameters:
<State> 1 | ON | 0 | OFF

*RST: OFF

Example: BB:WIM:CLIP:STAT ON
activates level clipping.

Manual operation: See "Clipping State" on page 125
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[:SOURce<hw>]:BB:WIMax:FILTer:TYPE <Type>

The command selects the filter type.

Parameters:
<Type> RCOSine | COSine | GAUSs | LGAuss | CONE | COF705 |

COEQualizer | COFequalizer | C2K3x | APCO25 | SPHase |
RECTangle | PGAuss | LPASs | DIRac | ENPShape |
EWPShape | LPASSEVM
*RST: GAUSs

Example: BB:WIM:FILT:TYPE RCOS
sets the filter type root cosine.

Manual operation: See "Filter" on page 122

[:SOURce<hw>]:BB:WIMax:FILTer:MODE <Mode>

Sets the filter mode.

Parameters:
<Mode> REALtime | OFFLine

REALtime
The filter is applied to a signal in real-time mode.
OFFLine
The filter is applied to a signal in offline mode.
*RST: REALtime

Example: BB:WIM:FILT:MODE REAL
the filter is applied to a signal in real-time mode.

Manual operation: See "Filter Mode" on page 124

[:SOURce<hw>]:BB:WIMax:FILTer:PARameter:APCO25 <Apco25>

The command sets the roll-off factor for the APCO25 filter type.

Parameters:
<Apco25> float

Range: 0.05  to  0.99
Increment: 0.01
*RST: 0.20

Example: BB:WIM:FILT:PAR:APCO25 0.04
the roll-off factor is set to 0.04.

Manual operation: See "Rolloff Factor or BxT" on page 123

[:SOURce<hw>]:BB:WIMax:FILTer:PARameter:COSine <Cosine>

The command sets the roll-off factor for the Cosine filter type.
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Parameters:
<Cosine> float

Range: 0.00  to  1.0
Increment: 0.01
*RST: OFDM: 0.1; OFDMA: 0.1 (sampling frequency

below 20 MHz); OFDMA: 0.07 (sampling frequency
20 MHz and above)

Example: BB:WIM:FILT:PAR:COS 0.04
the roll-off factor is set to 0.04.

Manual operation: See "Rolloff Factor or BxT" on page 123

[:SOURce<hw>]:BB:WIMax:FILTer:PARameter:COSine:COFS <Cofs>

The command sets the "cut of frequency shift" value for the Cosine filter type. The
default value gets set when switching between OFDM and OFDMA.

Parameters:
<Cofs> float

Range: -1  to  1
Increment: 0.01
*RST: OFDM: -0.1; OFDMA: 0.0 (sampling frequency

below 20 MHz); OFDMA:- 0.08 (sampling frequency
20 MHz and above)

Example: BB:WIM:FILT:PAR:COS:COFS 0.04
the "cut of frequency shift" value is set to 0.04.

Manual operation: See "Cutoff Frequency Shift" on page 123

[:SOURce<hw>]:BB:WIMax:FILTer:PARameter:GAUSs <Gauss>

The command sets the BxT for the Gauss filter type (FSK).

Parameters:
<Gauss> float

Range: 0.15  to  2.5
Increment: 0.01
*RST: 0.50

Example: BB:WIM:FILT:PAR:GAUS 0.5
'the BxT is set to 0.5.

Manual operation: See "Rolloff Factor or BxT" on page 123

[:SOURce<hw>]:BB:WIMax:FILTer:PARameter:LPASs <LPass>

The command sets the cutoff frequency factor for the Lowpass (ACP optimization) filter
type. The value range depends on the set symbol rate.

0.05 x symbol rate … 2 x symbol rate
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Parameters:
<LPass> float

Range: 0.05  to  2.0
Increment: 0.01
*RST: 0.50

Example: BB:WIM:FILT:PAR:LPAS 0.5
The cut of frequency factor is set to 0.5.

Manual operation: See "Cutoff Frequency Factor" on page 124

[:SOURce<hw>]:BB:WIMax:FILTer:PARameter:LPASSEVM <LPassEvm>

The command sets the cutoff frequency factor for the Lowpass (EVM optimization) fil-
ter type. The value range depends on the set symbol rate.

0.05 x symbol rate … 2 x symbol rate

Parameters:
<LPassEvm> float

Range: 0.05  to  2.0
Increment: 0.01
*RST: 0.5

Example: BB:WIM:FILT:PAR:LPASSEVM 0.5
The cut of frequency factor is set to 0.5.

Manual operation: See "Cutoff Frequency Factor" on page 124

[:SOURce<hw>]:BB:WIMax:FILTer:PARameter:PGAuss <PGauss>

The command sets the BxT for the Gauss filter type (pure).

Parameters:
<PGauss> float

Range: 0.00  to  2.5
Increment: 0.01
*RST: 0.50

Example: BB:WIM:FILT:PAR:PGA 0.5
the BxT is set to 0.5.

Manual operation: See "Rolloff Factor or BxT" on page 123

[:SOURce<hw>]:BB:WIMax:FILTer:PARameter:RCOSine <RCosine>

The command sets the roll-off factor for the Root Cosine filter type.
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Parameters:
<RCosine> float

Range: 0  to  1.0
Increment: 0.01
*RST: 0.22

Example: BB:WIM:FILT:PAR:RCOS 0.4
the roll-off factor is set to 0.4.

Manual operation: See "Rolloff Factor or BxT" on page 123

[:SOURce<hw>]:BB:WIMax:FILTer:PARameter:SPHase <SPhase>

The command sets the BxT for the Split Phase filter type.

Parameters:
<SPhase> float

Range: 0.15  to  2.5
Increment: 0.01
*RST: 2.00

Example: BB:WIM:FILT:PAR:SPH 2
the BxT is set to 2.0.

Manual operation: See "Rolloff Factor or BxT" on page 123

[:SOURce<hw>]:BB:WIMax:SRATe:VARiation <Variation>

The command enters the output sample rate.

A variation of this parameter only affects the ARB clock rate, all other signal parame-
ters remain unchanged. If the sampling rate in the frame configuration menu is
changed, this parameter is reset to the chosen sampling rate.

Parameters:
<Variation> float

Range: 400 Hz  to  10 MHz
Increment: 0.001 Hz
*RST: 2 MHz
Default unit: Hz (c/s)

Example: BB:WIM:SRAT:VAR 4000000
sets the output sample rate to 4 Mcps.

Manual operation: See "Sample Rate Variation" on page 124

4.3  Trigger commands

[:SOURce<hw>]:BB:WIMax[:TRIGger]:SEQuence.............................................................141
[:SOURce<hw>]:BB:WIMax:TRIGger:SOURce..................................................................141
[:SOURce<hw>]:BB:WIMax:TRIGger:ARM:EXECute......................................................... 142
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[:SOURce<hw>]:BB:WIMax:TRIGger:EXECute................................................................. 142
[:SOURce<hw>]:BB:WIMax:TRIGger:EXTernal:SYNChronize:OUTPut................................ 142
[:SOURce<hw>]:BB:WIMax:TRIGger:OBASeband:DELay..................................................143
[:SOURce<hw>]:BB:WIMax:TRIGger:OBASeband:INHibit..................................................143
[:SOURce<hw>]:BB:WIMax:TRIGger:RMODe?.................................................................143
[:SOURce<hw>]:BB:WIMax:TRIGger:TIME:DATE............................................................. 144
[:SOURce<hw>]:BB:WIMax:TRIGger:TIME:TIME.............................................................. 144
[:SOURce<hw>]:BB:WIMax:TRIGger:TIME[:STATe]...........................................................145
[:SOURce<hw>]:BB:WIMax:TRIGger:SLENgth................................................................. 145
[:SOURce<hw>]:BB:WIMax:TRIGger:SLUNit.................................................................... 145
[:SOURce<hw>]:BB:WIMax:TRIGger[:EXTernal]:DELay.....................................................146
[:SOURce<hw>]:BB:WIMax:TRIGger[:EXTernal]:INHibit.....................................................146
[:SOURce<hw>]:BB:WIMax:TRIGger:TIME:DATE............................................................. 146
[:SOURce<hw>]:BB:WIMax:TRIGger:TIME:TIME.............................................................. 147
[:SOURce<hw>]:BB:WIMax:TRIGger:TIME[:STATe]...........................................................147

[:SOURce<hw>]:BB:WIMax[:TRIGger]:SEQuence <Sequence>

Selects the trigger mode.

Parameters:
<Sequence> AUTO | RETRigger | AAUTo | ARETrigger | SINGle

*RST: AUTO

Example: SOURce1:BB:WIMax:TRIGger:SEQuence AAUT
sets the armed auto trigger mode

Manual operation: See "Mode" on page 22

[:SOURce<hw>]:BB:WIMax:TRIGger:SOURce <Source>

Selects the trigger signal source and determines the way the triggering is executed.
Provided are:
● Internal triggering by a command (INTernal)
● External trigger signal via one of the local or global connectors

– EGT1|EGT2: External global trigger
– EGC1|EGC2: External global clock
– ELTRigger: External local trigger
– ELCLock: External local clock

● Internal triggering by a signal from the other basebands (INTA|INTB)
● OBASeband|BEXTernal|EXTernal: Setting only

Provided only for backward compatibility with other Rohde & Schwarz signal gener-
ators.
The R&S SMW accepts these values and maps them automatically as follows:
EXTernal = EGT1, BEXTernal = EGT2, OBASeband = INTA or INTB
(depending on the current baseband)
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Parameters:
<Source> INTB | INTernal | OBASeband | EGT1 | EGT2 | EGC1 | EGC2 |

ELTRigger | INTA | ELCLock | BEXTernal | EXTernal | BBSY
*RST: INTernal

Example: SOURce1:BB:WIMax:TRIGger:SEQuence ARET
SOURce1:BB:WIMax:TRIGger:SOURce EGT1
SOURce1:BB:WIMax:TRIGger:EXTernal:SYNChronize:OUTPut 1
SOURce1:BB:WIMax:TRIGger:EXTernal:INHibit 100
SOURce1:BB:WIMax:TRIGger:EXTernal:DELay 10

Manual operation: See "Source" on page 24

[:SOURce<hw>]:BB:WIMax:TRIGger:ARM:EXECute

Stops signal generation; a subsequent trigger event restarts signal generation.

Example: SOURce1:BB:WIMax:TRIGger:SOURce INT
SOURce1:BB:WIMax:TRIGger:SEQuence ARETrigger
SOURce1:BB:WIMax:TRIGger:EXEcute
// executes a trigger, signal generation starts
SOURce1:BB:WIMax:TRIGger:ARM:EXECute
// signal generation stops
SOURce1:BB:WIMax:TRIGger:EXEcute
// executes a trigger, signal generation starts again

Usage: Event

Manual operation: See "Arm" on page 24

[:SOURce<hw>]:BB:WIMax:TRIGger:EXECute

Executes a trigger.

Example: See [:SOURce<hw>]:BB:WIMax:TRIGger:ARM:EXECute
on page 142

Usage: Event

Manual operation: See "Execute Trigger" on page 24

[:SOURce<hw>]:BB:WIMax:TRIGger:EXTernal:SYNChronize:OUTPut <Output>

Enables/disables output of the signal synchronous to the external trigger event.

Parameters:
<Output> 1 | ON | 0 | OFF

*RST: 1

Example: SOURce1:BB:WIMax:TRIGger:SOURce EXTernal
SOURce1:BB:WIMax:TRIGger:EXTernal:SYNChronize:OUTPut ON
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Manual operation: See "Sync. Output to External Trigger/Sync. Output to Trigger"
on page 25

[:SOURce<hw>]:BB:WIMax:TRIGger:OBASeband:DELay <Delay>

When triggering via the other basebands, delays the trigger event compared to the one
in the other baseband.

Parameters:
<Delay> float

Range: 0  to  2147483647
Increment: 0.01
*RST: 0

Example: SOURce1:BB:WIMax:TRIGger:SOURce INTB
SOURce1:BB:WIMax:TRIGger:OBASeband:DELay 100

Manual operation: See "External Delay/Trigger Delay" on page 26

[:SOURce<hw>]:BB:WIMax:TRIGger:OBASeband:INHibit <Inhibit>

For triggering via the other path, specifies the duration by which a restart is inhibited.

Parameters:
<Inhibit> integer

Range: 0  to  67108863
*RST: 0

Example: SOURce1:BB:WIMax:TRIGger:SEQuence ARET
SOURce1:BB:WIMax:TRIGger:SOURce INTB
SOURce1:BB:WIMax:TRIGger:OBASeband:INHibit 100
SOURce1:BB:WIMax:TRIGger:OBASeband:DELay 10

Manual operation: See "External Inhibit/Trigger Inhibit" on page 25

[:SOURce<hw>]:BB:WIMax:TRIGger:RMODe?

Queries the signal generation status.

Return values: 
<RMode> STOP | RUN

*RST: STOP

Example: SOURce1:BB:WIMax:TRIGger:RMODe?
Usage: Query only

Manual operation: See "Running/Stopped" on page 23
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[:SOURce<hw>]:BB:WIMax:TRIGger:TIME:DATE <Year>, <Month>, <Day>

Sets the date for a time-based trigger signal. For trigger modes single or armed auto,
you can activate triggering at this date via the following command:

SOURce<hw>:BB:<DigStd>:TRIGger:TIME:STATe
<DigStd> is the mnemonic for the digital standard, for example, ARB. Time-based trig-
gering behaves analogously for all digital standards that support this feature.

Parameters:
<Year> integer

Range: 1980  to  9999

<Month> integer
Range: 1  to  12

<Day> integer
Range: 1  to  31

Example: See example "Configure a time-based trigger signal" in the sub-
chapter "Trigger Commands" of the chapter "SOURce:BB:ARB
subsystem" in the R&S SMW user manual.

Manual operation: See "Trigger Time" on page 24

[:SOURce<hw>]:BB:WIMax:TRIGger:TIME:TIME <Hour>, <Minute>, <Second>

Sets the time for a time-based trigger signal. For trigger modes single or armed auto,
you can activate triggering at this time via the following command:

SOURce<hw>:BB:<DigStd>:TRIGger:TIME:STATe
<DigStd> is the mnemonic for the digital standard, for example, ARB. Time-based trig-
gering behaves analogously for all digital standards that support this feature.

Parameters:
<Hour> integer

Range: 0  to  23

<Minute> integer
Range: 0  to  59

<Second> integer
Range: 0  to  59

Example: See example "Configure a time-based trigger signal" in the sub-
chapter "Trigger Commands" of the chapter "SOURce:BB:ARB
subsystem" in the R&S SMW user manual.

Manual operation: See "Trigger Time" on page 24
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[:SOURce<hw>]:BB:WIMax:TRIGger:TIME[:STATe] <State>

Activates time-based triggering with a fixed time reference. If activated, the R&S SMW
triggers signal generation when its operating system time matches a specified time.

Specify the trigger date and trigger time with the following commands:

SOURce<hw>:BB:<DigStd>:TRIGger:TIME:DATE
SOURce<hw>:BB:<DigStd>:TRIGger:TIME:TIME
<DigStd> is the mnemonic for the digital standard, for example, ARB. Time-based trig-
gering behaves analogously for all digital standards that support this feature.

Parameters:
<State> 1 | ON | 0 | OFF

*RST: 0

Example: See example "Configure a time-based trigger signal" in the sub-
chapter "Trigger Commands" of the chapter "SOURce:BB:ARB
subsystem" in the R&S SMW user manual.

Manual operation: See "Time Based Trigger" on page 23

[:SOURce<hw>]:BB:WIMax:TRIGger:SLENgth <SLength>

Defines the length of the signal sequence that is output in the SINGle trigger mode.

Parameters:
<SLength> integer

Range: 1  to  INT_MAX
*RST: 1

Example: SOURce1:BB:WIMax:TRIGger:SEQuence SING
SOURce1:BB:WIMax:TRIGger:SLUNit CHIP
SOURce1:BB:WIMax:TRIGger:SLENgth 200

Manual operation: See "Signal Duration" on page 23

[:SOURce<hw>]:BB:WIMax:TRIGger:SLUNit <SlUnit>

Defines the unit for the entry of the signal sequence length.

Parameters:
<SlUnit> FRAMe | CHIP | SEQuence

FRAMe
Unit Frame. A single frame is generated after a trigger event.
CHIP
Unit Chip. A single chip is generated after a trigger event.
SEQuence
Unit Sequence Length. A single sequence is generated after a
trigger event.
*RST: SEQuence
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Example: See [:SOURce<hw>]:BB:WIMax:TRIGger:SLENgth
on page 145

Manual operation: See "Signal Duration Unit" on page 23

[:SOURce<hw>]:BB:WIMax:TRIGger[:EXTernal]:DELay <Delay>

Sets the trigger delay.

Parameters:
<Delay> float

Range: 0  to  2147483647
Increment: 0.01
*RST: 0
Default unit: samples

Example: See [:SOURce<hw>]:BB:WIMax:TRIGger:SOURce
on page 141

Manual operation: See "External Delay/Trigger Delay" on page 26

[:SOURce<hw>]:BB:WIMax:TRIGger[:EXTernal]:INHibit <Inhibit>

Specifies the duration by which a restart is inhibited.

Parameters:
<Inhibit> integer

Range: 0  to  21.47*sampRate
*RST: 0

Example: See [:SOURce<hw>]:BB:WIMax:TRIGger:SOURce
on page 141

Manual operation: See "External Inhibit/Trigger Inhibit" on page 25

[:SOURce<hw>]:BB:WIMax:TRIGger:TIME:DATE <Year>, <Month>, <Day>

Sets the date for a time-based trigger signal. For trigger modes single or armed auto,
you can activate triggering at this date via the following command:

SOURce<hw>:BB:<DigStd>:TRIGger:TIME:STATe
<DigStd> is the mnemonic for the digital standard, for example, ARB. Time-based trig-
gering behaves analogously for all digital standards that support this feature.

Parameters:
<Year> integer

Range: 1980  to  9999

<Month> integer
Range: 1  to  12
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<Day> integer
Range: 1  to  31

Example: See example "Configure a time-based trigger signal" in the sub-
chapter "Trigger Commands" of the chapter "SOURce:BB:ARB
subsystem" in the R&S SMW user manual.

Manual operation: See "Trigger Time" on page 24

[:SOURce<hw>]:BB:WIMax:TRIGger:TIME:TIME <Hour>, <Minute>, <Second>

Sets the time for a time-based trigger signal. For trigger modes single or armed auto,
you can activate triggering at this time via the following command:

SOURce<hw>:BB:<DigStd>:TRIGger:TIME:STATe
<DigStd> is the mnemonic for the digital standard, for example, ARB. Time-based trig-
gering behaves analogously for all digital standards that support this feature.

Parameters:
<Hour> integer

Range: 0  to  23

<Minute> integer
Range: 0  to  59

<Second> integer
Range: 0  to  59

Example: See example "Configure a time-based trigger signal" in the sub-
chapter "Trigger Commands" of the chapter "SOURce:BB:ARB
subsystem" in the R&S SMW user manual.

Manual operation: See "Trigger Time" on page 24

[:SOURce<hw>]:BB:WIMax:TRIGger:TIME[:STATe] <State>

Activates time-based triggering with a fixed time reference. If activated, the R&S SMW
triggers signal generation when its operating system time matches a specified time.

Specify the trigger date and trigger time with the following commands:

SOURce<hw>:BB:<DigStd>:TRIGger:TIME:DATE
SOURce<hw>:BB:<DigStd>:TRIGger:TIME:TIME
<DigStd> is the mnemonic for the digital standard, for example, ARB. Time-based trig-
gering behaves analogously for all digital standards that support this feature.

Parameters:
<State> 1 | ON | 0 | OFF

*RST: 0
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Example: See example "Configure a time-based trigger signal" in the sub-
chapter "Trigger Commands" of the chapter "SOURce:BB:ARB
subsystem" in the R&S SMW user manual.

Manual operation: See "Time Based Trigger" on page 23

4.4  Marker commands

Example: Conguring a marker signal
SOURce1:BB:WIMax:TRIGger:OUTPut1:MODE PULS
// sets a pulse marker
SOURce1:BB:WIMax:TRIGger:OUTPut1:PULSe:DIVider 2
SOURce1:BB:WIMax:TRIGger:OUTPut1:PULSe:FREQuency?
// 33000

SOURce1:BB:WIMax:TRIGger:OUTPut1:MODE PATTern
// sets a bit pattern marker
SOURce1:BB:WIMax:TRIGger:OUTPut1:PATTern #H2,2

SOURce1:BB:WIMax:TRIGger:OUTPut1:MODE RAT
SOURce1:BB:WIMax:TRIGger:OUTPut1:ONTime 1
SOURce1:BB:WIMax:TRIGger:OUTPut1:OFFTime 1
// defines the on/off ratio

SOURce1:BB:WIMax:TRIGger:OUTPut3:MODE REST
SOURce1:BB:WIMax:TRIGger:OUTPut3:FOFFset 0
SOURce1:BB:WIMax:TRIGger:OUTPut3:ROFFset 100

// Configure marker 2 delay.
SOURce1:BB:WIMax:TRIGger:OUTPut2:DELay 160

Commands:

[:SOURce<hw>]:BB:WIMax:TRIGger:OUTPut<ch>:MODE.................................................148
[:SOURce<hw>]:BB:WIMax:TRIGger:OUTPut<ch>:ONTime...............................................149
[:SOURce<hw>]:BB:WIMax:TRIGger:OUTPut<ch>:OFFTime............................................. 149
[:SOURce<hw>]:BB:WIMax:TRIGger:OUTPut<ch>:ROFFset............................................. 149
[:SOURce<hw>]:BB:WIMax:TRIGger:OUTPut<ch>:FOFFset..............................................149
[:SOURce<hw>]:BB:WIMax:TRIGger:OUTPut<ch>:PATTern...............................................149
[:SOURce<hw>]:BB:WIMax:TRIGger:OUTPut<ch>:PULSe:DIVider.....................................150
[:SOURce<hw>]:BB:WIMax:TRIGger:OUTPut<ch>:PULSe:FREQuency?............................ 150
[:SOURce<hw>]:BB:WIMax:TRIGger:OUTPut<ch>:DELay.................................................150

[:SOURce<hw>]:BB:WIMax:TRIGger:OUTPut<ch>:MODE <Mode>

Sets the marker mode.
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Parameters:
<Mode> RESTart | FRAMe | FACTive | PULSe | PATTern | RATio

*RST: RESTart

Example: See Example"Conguring a marker signal" on page 148

Manual operation: See "Mode" on page 27

[:SOURce<hw>]:BB:WIMax:TRIGger:OUTPut<ch>:ONTime <Ontime>
[:SOURce<hw>]:BB:WIMax:TRIGger:OUTPut<ch>:OFFTime <Offtime>
Sets the number of samples during which the marker output is on or off.

Parameters:
<Offtime> integer

Range: 1  to  16777215
*RST: 1

Example: See Example"Conguring a marker signal" on page 148

Manual operation: See "Mode" on page 27

[:SOURce<hw>]:BB:WIMax:TRIGger:OUTPut<ch>:ROFFset <ROffset>
[:SOURce<hw>]:BB:WIMax:TRIGger:OUTPut<ch>:FOFFset <FOffset>
Sets the fall offset in number of samples.

Parameters:
<FOffset> integer

Range: -640000  to  640000
*RST: 0

Example: See Example"Conguring a marker signal" on page 148

Manual operation: See "Rise Offset/Fall Offset" on page 28

[:SOURce<hw>]:BB:WIMax:TRIGger:OUTPut<ch>:PATTern <Pattern>, <BitCount>

Defines the bit pattern used to generate the marker signal.

Parameters:
<Pattern> numeric

0 = marker off, 1 = marker on
*RST: #B10

<BitCount> integer
Range: 1  to  64
*RST: 2

Example: See Example"Conguring a marker signal" on page 148.

Manual operation: See "Mode" on page 27
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[:SOURce<hw>]:BB:WIMax:TRIGger:OUTPut<ch>:PULSe:DIVider <Divider>

Sets the divider for Pulse marker mode (PULSe).

Parameters:
<Divider> integer

Range: 2  to  1024
*RST: 2

Example: See Example"Conguring a marker signal" on page 148

Manual operation: See "Mode" on page 27

[:SOURce<hw>]:BB:WIMax:TRIGger:OUTPut<ch>:PULSe:FREQuency?

Queries the pulse frequency of the pulsed marker signal PULSe.

Return values: 
<Frequency> float

Range: 2  to  1024
Increment: 1E-3
*RST: 2

Example: See Example"Conguring a marker signal" on page 148

Usage: Query only

Manual operation: See "Mode" on page 27

[:SOURce<hw>]:BB:WIMax:TRIGger:OUTPut<ch>:DELay <Delay>

Defines the delay between the signal on the marker outputs and the start of the sig-
nals.

Parameters:
<Delay> float

Range: 0  to  16777215
Increment: 1E-3
*RST: 0

Example: See Example"Conguring a marker signal" on page 148

Manual operation: See "Delay" on page 28

4.5  Clock commands

[:SOURce<hw>]:BB:WIMax:CLOCk:MODE.......................................................................151
[:SOURce<hw>]:BB:WIMax:CLOCk:SOURce................................................................... 151
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[:SOURce<hw>]:BB:WIMax:CLOCk:MODE <Mode>

Sets the type of externally supplied clock.

Parameters:
<Mode> SAMPle

*RST: SAMP

Example: SOURce1:BB:WIMax:CLOCk:MODE SAMP
Manual operation: See "Clock Mode" on page 30

[:SOURce<hw>]:BB:WIMax:CLOCk:SOURce <Source>

Selects the clock source:
● INTernal: Internal clock reference
● ELCLock: External local clock
● EXTernal = ELCLock: Setting only

Provided for backward compatibility with other Rohde & Schwarz signal generators

Parameters:
<Source> INTernal | ELCLock | EXTernal

*RST: INTernal

Example: SOURce1:BB:WIMax:CLOCk:SOURce INT
Manual operation: See "Clock Source" on page 29

4.6  OFDMA physical layer commands

The SOURce:BB:WIMax:AOFDm systems contain commands for setting the character-
istics of signals with OFDMA and OFDMA-WiBro physical layer.

The commands of this system only take effect if the OFDMA physical layer mode is
selected:
● SOURce:BB:WIMax:MODE AOFDMa or
● SOURce:BB:WIMax:MODE WIBRo

In case of remote control, suffix counting for bursts corresponds to the suffix counting
with WiMAX starting with burst 0. SCPI prescribes that suffix 1 is the default state and
used when no specific suffix is specified. Therefore, burst 1 (and not burst 0) is
selected when no suffix is specified.

[:SOURce<hw>]:BB:WIMax:AOFDm:BW..........................................................................155
[:SOURce<hw>]:BB:WIMax:AOFDm:FBANd.....................................................................156
[:SOURce<hw>]:BB:WIMax:AOFDm:FFT......................................................................... 156
[:SOURce<hw>]:BB:WIMax:AOFDm:FRAMe:PREDefined................................................. 156
[:SOURce<hw>]:BB:WIMax:AOFDm:IDCell...................................................................... 157
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[:SOURce<hw>]:BB:WIMax:AOFDm:N?........................................................................... 158
[:SOURce<hw>]:BB:WIMax:AOFDm:POWer:REFerence................................................... 158
[:SOURce<hw>]:BB:WIMax:AOFDm:PREamble:INDex......................................................159
[:SOURce<hw>]:BB:WIMax:AOFDm:PREamble:INDex:MODE........................................... 159
[:SOURce<hw>]:BB:WIMax:AOFDm:SRATe..................................................................... 159
[:SOURce<hw>]:BB:WIMax:AOFDm:TGTB.......................................................................160
[:SOURce<hw>]:BB:WIMax:AOFDm:ZONE:COUNt...........................................................160
[:SOURce<hw>]:BB:WIMax:AOFDm:ZONE<st0>:AMC:BITMap:PATTern.............................161
[:SOURce<hw>]:BB:WIMax:AOFDm:ZONE<st0>:AMC:BITMap[:STATe]..............................161
[:SOURce<hw>]:BB:WIMax:AOFDm:ZONE<st0>:BOOSt...................................................161
[:SOURce<hw>]:BB:WIMax:AOFDm:ZONE<st0>:CSTD:ANTCount.................................... 162
[:SOURce<hw>]:BB:WIMax:AOFDm:ZONE<st0>:CSTD:ANTShow.....................................162
[:SOURce<hw>]:BB:WIMax:AOFDm:ZONE<st0>:CSTD<ch0>:CDELay<dir0>..................... 162
[:SOURce<hw>]:BB:WIMax:AOFDm:ZONE<st0>:CSTD<ch0>:GAIN<dir0>......................... 162
[:SOURce<hw>]:BB:WIMax:AOFDm:ZONE<st0>:CSTD<ch0>:TAPCount............................163
[:SOURce<hw>]:BB:WIMax:AOFDm:ZONE<st0>:FCH:MODE............................................163
[:SOURce<hw>]:BB:WIMax:AOFDm:ZONE<st0>:NUMBer.................................................164
[:SOURce<hw>]:BB:WIMax:AOFDm:ZONE<st0>:PERMbase.............................................164
[:SOURce<hw>]:BB:WIMax:AOFDm:ZONE<st0>:PILDedicated..........................................164
[:SOURce<hw>]:BB:WIMax:AOFDm:ZONE<st0>:PRBSid..................................................164
[:SOURce<hw>]:BB:WIMax:AOFDm:ZONE<st0>:SCARrier:RANDomizer............................165
[:SOURce<hw>]:BB:WIMax:AOFDm:ZONE<st0>:SEGMent............................................... 165
[:SOURce<hw>]:BB:WIMax:AOFDm:ZONE<st0>:SOUNding:AMODe................................. 165
[:SOURce<hw>]:BB:WIMax:AOFDm:ZONE<st0>:SOUNding:CID:COUNt............................166
[:SOURce<hw>]:BB:WIMax:AOFDm:ZONE<st0>:SOUNding:CID<ch0>:BBITmap................166
[:SOURce<hw>]:BB:WIMax:AOFDm:ZONE<st0>:SOUNding:CID<ch0>:CID........................166
[:SOURce<hw>]:BB:WIMax:AOFDm:ZONE<st0>:SOUNding:CID<ch0>:CINDex..................167
[:SOURce<hw>]:BB:WIMax:AOFDm:ZONE<st0>:SOUNding:CID<ch0>:DECoffset...............167
[:SOURce<hw>]:BB:WIMax:AOFDm:ZONE<st0>:SOUNding:CID<ch0>:FBANd:STARt.........167
[:SOURce<hw>]:BB:WIMax:AOFDm:ZONE<st0>:SOUNding:CID<ch0>:FBANd[:COUNt]......168
[:SOURce<hw>]:BB:WIMax:AOFDm:ZONE<st0>:SOUNding:CID<ch0>:PERiodicity.............168
[:SOURce<hw>]:BB:WIMax:AOFDm:ZONE<st0>:SOUNding:CID<ch0>:POWer[:STATe].......168
[:SOURce<hw>]:BB:WIMax:AOFDm:ZONE<st0>:SOUNding:CID<ch0>:RELevance[:STATe].168
[:SOURce<hw>]:BB:WIMax:AOFDm:ZONE<st0>:SOUNding:CID<ch0>:SUBChannel:

OFFSet...............................................................................................................169
[:SOURce<hw>]:BB:WIMax:AOFDm:ZONE<st0>:SOUNding:CID<ch0>:SUBChannel[:

COUNt]...............................................................................................................169
[:SOURce<hw>]:BB:WIMax:AOFDm:ZONE<st0>:SOUNding:CID<ch0>:SYMBol..................169
[:SOURce<hw>]:BB:WIMax:AOFDm:ZONE<st0>:SOUNding:CMAXimum........................... 170
[:SOURce<hw>]:BB:WIMax:AOFDm:ZONE<st0>:SOUNding:DECimation:

RANDomization[:STATe]....................................................................................... 170
[:SOURce<hw>]:BB:WIMax:AOFDm:ZONE<st0>:SOUNding:DECimation:VALue................. 170
[:SOURce<hw>]:BB:WIMax:AOFDm:ZONE<st0>:SOUNding:DLPermbase..........................171
[:SOURce<hw>]:BB:WIMax:AOFDm:ZONE<st0>:SOUNding:PERMutation?........................171
[:SOURce<hw>]:BB:WIMax:AOFDm:ZONE<st0>:SOUNding:RELevance:FLAG...................171
[:SOURce<hw>]:BB:WIMax:AOFDm:ZONE<st0>:SOUNding:RELevance:MODE................. 172
[:SOURce<hw>]:BB:WIMax:AOFDm:ZONE<st0>:SOUNding:SEParability........................... 172
[:SOURce<hw>]:BB:WIMax:AOFDm:ZONE<st0>:SOUNding:TYPE.................................... 172
[:SOURce<hw>]:BB:WIMax:AOFDm:ZONE<st0>:SOUNding:UVAL.....................................172
[:SOURce<hw>]:BB:WIMax:AOFDm:ZONE<st0>:STC:ANTenna........................................ 173
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[:SOURce<hw>]:BB:WIMax:AOFDm:ZONE<st0>:STC:MODE............................................ 173
[:SOURce<hw>]:BB:WIMax:AOFDm:ZONE<st0>:STC:PILotpattern.................................... 173
[:SOURce<hw>]:BB:WIMax:AOFDm:ZONE<st0>:SYMBol:COUNt...................................... 174
[:SOURce<hw>]:BB:WIMax:AOFDm:ZONE<st0>:SYMBol:COUNt:AUTO............................ 174
[:SOURce<hw>]:BB:WIMax:AOFDm:ZONE<st0>:SYMBol:OFFSet?................................... 174
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:CCODing:FEC.................. 174
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:CCODing:INTerleaver........ 175
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:CCODing:MODE............... 175
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:CCODing:RANDomizer......175
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:CCODing:REPCoding........176
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:CONFlict[:STATe]?.............176
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:DATA............................... 176
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:DATA:DSELect..................177
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:DATA:LENGth...................177
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:DATA:PATTern.................. 178
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:DIUC................................178
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:DLUL:ARIX.......................178
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:DLUL:HARQ:ACKoffset:DL.178
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:DLUL:HARQ:

ACKoffset:INDicator............................................................................................. 179
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:DLUL:HARQ:ACKoffset:UL.179
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:DLUL:INCLude..................179
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:DLUL:MPIX?.....................180
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:FFB:CWSize?................... 180
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:FFB:MODE.......................180
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:FFB:SUBC........................181
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:FFB:SYMB....................... 181
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:FORMat........................... 181
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:HARQ:COUNt...................182
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:HARQ:MODE....................182
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:HARQ:MSTart[:STATe]....... 182
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:HARQ:SLFRee?................183
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:HARQ<dir0>:ACID............ 183
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:HARQ<dir0>:ACKD........... 184
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:HARQ<dir0>:DATA............184
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:HARQ<dir0>:DATA:

DSELect............................................................................................................. 185
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:HARQ<dir0>:DATA:

PATTern..............................................................................................................185
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:HARQ<dir0>:DIUC............ 185
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:HARQ<dir0>:DLENgth.......186
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:HARQ<dir0>:FORMat?...... 186
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:HARQ<dir0>:MAC:CID...... 186
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:HARQ<dir0>:MAC:

CRC:STATe.........................................................................................................187
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:HARQ<dir0>:MAC:EKS......187
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:HARQ<dir0>:MAC:

ENCRypted:STATe...............................................................................................187
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:HARQ<dir0>:MAC:STATe...188
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:HARQ<dir0>:MAC:TYPE....188

OFDMA physical layer commands



Remote-control commandsR&S®SMW-K49

154User Manual 1175.6732.02 ─ 19

[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:HARQ<dir0>:MODRate......188
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[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:MAC:ENCRypted:STATe.... 191
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:MAC:STATe...................... 191
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:MAC:TYPE....................... 192
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:OFFSet:MODE..................192
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:OFFSet:SUBChannel.........192
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:OFFSet:SYMBol................193
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:PDU:COUNt..................... 193
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:PDU:STATe.......................193
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:PDU<dir0>:DATA.............. 194
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:PDU<dir0>:DATA:DSELect.194
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:PDU<dir0>:DATA:PATTern. 195
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:PDU<dir0>:DLENgth......... 195
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:PDU<dir0>:MAC:CRC:

STATe.................................................................................................................195
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:PDU<dir0>:MAC:EKS........ 196
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:PDU<dir0>:MAC:

ENCRypted:STATe...............................................................................................196
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:PDU<dir0>:MAC:STATe..... 196
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:PDU<dir0>:MAC:TYPE...... 197
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:PDU<dir0>[:MAC]:CID....... 197
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:PMAP.............................. 197
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:PMAP:DMODulation<dir0>.198
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:PMAP:UMODulation<dir0>.198
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:POWer............................. 199
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:RANGing:ACODe?............ 199
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:RANGing:OPPortunity:

SIZE...................................................................................................................199
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:RANGing:OPPortunity:

SLOTcount.......................................................................................................... 200
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:RANGing:SCGCount......... 200
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:SLOT:COUNt.................... 200
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:STC:MODE...................... 200
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:SUBChannel[:COUNt]........201
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:SYMBol[:COUNt]...............201
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:TYPE............................... 201
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:UCD:RANGing:BOENd...... 202
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:UCD:RANGing:BOSTart.....202
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:UCD:REQuest:BOENd.......202
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:UCD:REQuest:BOSTart..... 203
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:UIUC................................203
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:ULMap:AMODe.................203
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:ULMap:ATIMe...................204
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[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:ULMap:DCD:CID...............204
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:ULMap:DCD:STATe........... 204
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:ULMap:RANGing:BOENd...205
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:ULMap:RANGing:BOSTart. 205
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:ULMap:REQuest:BOENd... 205
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:ULMap:REQuest:BOSTart..205
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:ULMap:UCD:CID...............206
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:ULMap:UCD:STATe........... 206
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt[:COUNt].................................... 206
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:DLMap:BSID........................................ 207
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:DLMap:COMPressed:AMODe................ 207
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:DLMap:COMPressed:ATIMe.................. 207
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:DLMap:COMPressed:STATe.................. 208
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:DLMap:COMPressed:ULMap:DSELect....208
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:DLMap:COMPressed:ULMap:STATe....... 208
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:DLMap:DATA:DCD[:COUNt]...................208
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:DLMap:DCD:CID...................................209
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:DLMap:DCD:STATe...............................209
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:DLMap:FNOFfset..................................209
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:DLMap:IIE:STATe..................................210
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:DLMap:MODE...................................... 210
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:DLMap:REPCoding............................... 210
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:DLMap:SLOTcount?.............................. 211
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:SCARrier:PERMutation..........................211
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:SUBChannel:MODE.............................. 211
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:SUBChannel:PATTern............................211
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:SUBChannel:ROTation.......................... 212
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:SUBChannel<ch>:MAP......................... 212
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:TYPE...................................................212
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:UCD.................................................... 213
[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:ULMap:CREate.....................................213

[:SOURce<hw>]:BB:WIMax:AOFDm:BW <Bw>

Sets the channel bandwidth.

Parameters:
<Bw> float

DL: the allowed values depend on the selected frequency band
([:SOURce<hw>]:BB:WIMax:AOFDm:FBANd)
UL: the full range between 1.25 MHz and 28 MHz is available
Only discrete sets of values are available. If a new value is not
allowed, the next allowed value in the direction of change is set.
Range: 1.25E6  to  28E6
Increment: 0.05E6
*RST: 1.75E6
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Example: BB:WIM:AOFD:FBAN ETSI
Selects frequency band according to ETSI specifications.
BB:WIM:AOFD:BW 15E6
Sets the channel bandwidth to 28 MHz.

Manual operation: See "Channel Bandwidth OFDMA" on page 57

[:SOURce<hw>]:BB:WIMax:AOFDm:FBANd <FBand>

The command selects the available frequency band for the carrier frequencies.

Parameters:
<FBand> ETSI | MMDS | WCS | UNII | USER | WIBRo

ETSI
European Telecommunications Standards Institute
MMDS
Multichannel Multipoint Distribution Service
WCS
Wireless Communication Service
UNII
Unlicensed National Information Infrastructure
WIBRo
Telecommunications Technology Association of Korea
*RST: ETSI

Example: BB:WIM:AOFD:FBAN ETSI
selects frequency band according to ETSI specifications.

Manual operation: See "Frequency Band OFDMA" on page 56

[:SOURce<hw>]:BB:WIMax:AOFDm:FFT <Fft>

The command sets the size of the fast fourier transform. For OFDM channels, the size
is fixed to 256. For OFDMA configuration, the possible configurations of the subchan-
nel map depend on the selected FFT size.

Parameters:
<Fft> FFT128 | FFT512 | FFT1024 | FFT2048

*RST: FFT2048

Example: BB:WIM:AOFD:FFT FFT2048
sets the FFT size to 2048.

Manual operation: See "FFT Size OFDMA" on page 58

[:SOURce<hw>]:BB:WIMax:AOFDm:FRAMe:PREDefined <Predefined>

The command selects predefined setting for the frames.
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All commands concerning the frame configuration are preset

Parameters:
<Predefined> USER | DL3M21SQPSK12 | DL3M21SQPSK34 |

DL3M21S16QAM12 | DL3M21S16QAM34 |
DL3M21S64QAM12 | DL3M21S64QAM23 |
DL3M21S64QAM34 | DL3M21S64QAM56 | DL5M29SQPSK12 |
DL5M29SQPSK34 | DL5M29S16QAM12 | DL5M29S16QAM34 |
DL5M29S64QAM12 | DL5M29S64QAM23 |
DL5M29S64QAM34 | DL5M29S64QAM56 | DL7M21SQPSK12 |
DL7M21SQPSK34 | DL7M21S16QAM12 | DL7M21S16QAM34 |
DL7M21S64QAM12 | DL7M21S64QAM23 |
DL7M21S64QAM34 | DL7M21S64QAM56 | DL8M27SQPSK12 |
DL8M27SQPSK34 | DL8M27S16QAM12 | DL8M27S16QAM34 |
DL8M27S64QAM12 | DL8M27S64QAM23 |
DL8M27S64QAM34 | DL8M27S64QAM56 |
DL10M29SQPSK12 | DL10M29SQPSK34 |
DL10M29S16QAM12 | DL10M29S16QAM34 |
DL10M29S64QAM12 | DL10M29S64QAM23 |
DL10M29S64QAM34 | DL10M29S64QAM56 |
UL3M12SQPSK12 | UL3M12SQPSK34 | UL3M12S16QAM12 |
UL3M12S16QAM34 | UL5M18SQPSK12 | UL5M18SQPSK34 |
UL5M18S16QAM12 | UL5M18S16QAM34 | UL7M12SQPSK12 |
UL7M12SQPSK34 | UL7M12S16QAM12 | UL7M12S16QAM34 |
UL8M15SQPSK12 | UL8M15SQPSK34 | UL8M15S16QAM12 |
UL8M15S16QAM34 | UL10M18SQPSK12 |
UL10M18SQPSK34 | UL10M18S16QAM12 |
UL10M18S16QAM34
USER
The settings for the frame can be defined by the user.
DL.../UL…
Predefined settings for receiver testing are selected. The param-
eter includes the link direction, the bandwidth, the modulation
and the channel coding rate.
*RST: USER

Example: BB:WIM:LINK UP
selects transmission direction uplink.
BB:WIM:AFDM:FRAM:PRED UL3M12SQPSK12
selects predefined test message with 3MHz, QPSK modulation
and channel coding rate 1/2.

Manual operation: See "Predefined Frames" on page 32

[:SOURce<hw>]:BB:WIMax:AOFDm:IDCell <Idcell>

Sets the cell ID.
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Parameters:
<Idcell> integer

Range: 0  to  31
*RST: 0

Example: BB:WIM:AOFD:IDC 4
Sets ID cell 4.

Manual operation: See "IDCell OFDMA" on page 58

[:SOURce<hw>]:BB:WIMax:AOFDm:N?

The command queries the factor n (sampling ratio). The sampling ratio is determined
by the channel bandwidth (see "Channel Bandwidth OFDMA" on page 57).

Return values: 
<N> N8D7 | N86D75 | N144D125 | N316D275 | N57D50 | N28D25

*RST: N8D7

Example: BB:WIM:AOFD:N?
queries the factor n.
Response: N8D7
the factor n is 8/7.

Usage: Query only

Manual operation: See "Sampling Ratio n OFDMA" on page 57

[:SOURce<hw>]:BB:WIMax:AOFDm:POWer:REFerence <Reference>

The command selects the level reference.

Parameters:
<Reference> RMS | PREamble | WOPRamble | STCZones

RMS
The instrument's level setting refers to the mean power of the
subframe.
PREamble
The instrument's level setting refers to the preamble, which is
FCH / Burst power + 3dB (downlink only).
WOPReamble
The instrument's level setting refers to the rms power of the sub-
frame, excluding the preamble. This includes all symbols with
allocated carriers in downlink or the whole uplink subframe in
uplink (downlink only).
*RST: PREamble
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Example: BB:WIM:MODE AOFD
selects physical layer mode OFDMA.
BB:WIM:LINK DOWN
select transmission direction downlink.
BB:WIM:AOFD:POW:REF PRE
the instrument's level setting refers to the preamble.

Manual operation: See "Power Reference" on page 32

[:SOURce<hw>]:BB:WIMax:AOFDm:PREamble:INDex <Index>

In downlink and in User mode, selects the preamble index for the generation of a
downlink frame preamble.

Parameters:
<Index> integer

Range: 0  to  113
*RST: 0

Example: BB:WIM:LINK DOWN
selects downlink transmission.
BB:WIM:AOFD:PRE:IND 10
selects preamble 10.

Manual operation: See "Preamble Index OFDMA" on page 58

[:SOURce<hw>]:BB:WIMax:AOFDm:PREamble:INDex:MODE <Mode>

The command selects the mode for selecting the preamble index.

This command is available only in downlink and in "User" mode
(SOURce:BB:WIMax:AOFD :PRE:IND:MODE USER).

Parameters:
<Mode> AUTO | USER

*RST: AUTO

Example: BB:WIM:LINK DOWN
selects downlink transmission.
BB:WIM:AOFD:PRE:IND:MODE AUTO
the preamble index for the generation of a downlink frame pre-
amble is set automatically.

Manual operation: See "Preamble Mode OFDMA" on page 58

[:SOURce<hw>]:BB:WIMax:AOFDm:SRATe <SRate>

The command sets the sampling rate. The sampling rate is related to the channel
bandwidth by the parameter n:

SamplingRate = floor(n * ChannelBandwidth / 8000) * 8000

Downlink:
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The value range depends on the selected frequency band (command
SOUR:BB:WIMax:AOFD:FBAN). Only discrete sets of values are available. If a new
value is not allowed, the next allowed value in the direction of change is set.

Uplink:

The full range between 1.44 MHz and 32 MHz is available. Only discrete sets of values
are available. If a new value is not allowed, the next allowed value in the direction of
change is set.

Example: 16 MHz and 32 MHz are allowed, the current value is 16 MHz. If a new
value of 17 MHz is entered, it is changed to 32 MHz.

Parameters:
<SRate> float

Range: 1.44E6  to  32E6
Increment: 1E3
*RST: 2E6

Example: BB:WIM:AOFD:SRAT 2E6
Sets a sampling rate of 2 MHz.

Manual operation: See "Sampling Rate OFDMA" on page 57

[:SOURce<hw>]:BB:WIMax:AOFDm:TGTB <Tgtb>

The command selects the ratio of guard period to symbol period. This value sets the
length of the cyclic prefix in fractions of the symbol period.

Parameters:
<Tgtb> TGTB1D4 | TGTB1D8 | TGTB1D16 | TGTB1D32

*RST: TGTB1D4

Example: BB:WIM:AOFD:TGTB TGTB1D8
sets a ratio of 1 to 8.

Manual operation: See "Tg/Tb Ratio OFDMA" on page 58

[:SOURce<hw>]:BB:WIMax:AOFDm:ZONE:COUNt <Count>

The command sets the number of active zones in one frame. The burst configuration is
performed for each zone separately.

Parameters:
<Count> integer

Range: 1  to  8
*RST: 1

Example: BB:WIM:AOFD:ZONE:COUN 2
two zones are defined.

Manual operation: See "Number of Zones/Segments OFDMA" on page 58
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[:SOURce<hw>]:BB:WIMax:AOFDm:ZONE<st0>:AMC:BITMap:PATTern <Pattern>,
<BitCount>

Sets the AMC physical bands bitmap pattern in hexadecimal input format.

The LSB (right most bit) corresponds to physical band 0 (the lowest frequency OFDMA
subcarriers). Deactivated bits in this pattern deactivate the corresponding bands, they
are not used for allocating bursts.

Parameters:
<Pattern> numeric

Range: #H000000000000  to  #HFFFFFFFFFFFF
*RST: #HFFFFFFFFFFFF

<BitCount> integer
Range: 48  to  48
*RST: 48

Example: BB:WIM:AOFD:ZONE0:AMC:BITM:STAT ON
Enables Band AMC mode
SOUR:BB:WIM:AOFD:ZONE0:AMC:BITM:PATT
#H0F10FFFF0000,48
Sets the AMC physical bands bitmap pattern

Manual operation: See "Physical Bands Bitmap" on page 63

[:SOURce<hw>]:BB:WIMax:AOFDm:ZONE<st0>:AMC:BITMap[:STATe] <State>

Activates/deactivates Band AMC mode.

If activated, the command SOUR:BB:WIM:AOFD:ZONE0:AMC:BITM:PATT specifies
the active physical bands. If deactivated, all available physical bands are used.

Parameters:
<State> 1 | ON | 0 | OFF

*RST: OFF

Example: BB:WIM:AOFD:ZONE0:AMC:BITM:STAT ON
enables Band AMC mode

Manual operation: See "Use Physical Bands Bitmap" on page 63

[:SOURce<hw>]:BB:WIMax:AOFDm:ZONE<st0>:BOOSt <Boost>

Sets an additional zone boosting in dB. The zone boosting is applied to both the data
and pilot carriers.

Parameters:
<Boost> float

Range: -80  to  20
Increment: 0.01
*RST: 0
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Example: BB:WIM:AOFD:ZONE0:BOOS -33
Sets th zone boost to - 33dB.

Manual operation: See "Zone Boosting OFDMA" on page 67

[:SOURce<hw>]:BB:WIMax:AOFDm:ZONE<st0>:CSTD:ANTCount <AntCount>

Sets the number of antennas used for cyclic shift transmit diversity (CSTD). One base-
band is only generating one antenna at a time.

Parameters:
<AntCount> A1 | A2 | A4

*RST: A1

Example: BB:WIM:AOFD:ZONE0:CSTD:ANTC A2
Two antennas are selected for CSTD.

Manual operation: See "Number Of Antennas OFDMA" on page 80

[:SOURce<hw>]:BB:WIMax:AOFDm:ZONE<st0>:CSTD:ANTShow <AntennaGui>

Selects the antenna for which the configuration is made.

Parameters:
<AntennaGui> ANT0 | ANT1 | ANT2 | ANT3

*RST: ANT0

Example: SOURce1:BB:WIMax:AOFDm:ZONE1:CSTD:ANTShow ANT0

Manual operation: See "Show Configuration For OFDMA" on page 80

[:SOURce<hw>]:BB:WIMax:AOFDm:ZONE<st0>:CSTD<ch0>:CDELay<dir0>
<CDelay>

Sets the number of samples by which the OFDM symbols are cyclically shifted on the
given tap.

Parameters:
<CDelay> integer

Range: -2048  to  2048
*RST: 0

Example: BB:WIM:AOFD:ZONE0:CSTD1:CDEL1 256
The cyclic delay applied to antenna 1 in the tap 1 is set to 256.

Manual operation: See "Cyclic Delay (Samples) OFDMA" on page 80

[:SOURce<hw>]:BB:WIMax:AOFDm:ZONE<st0>:CSTD<ch0>:GAIN<dir0> <Gain>

Sets a linear gain factor for the corresponding tap. The gain factors are applied to the
symbols before summation fo all taps.
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The antenna, for which the configuration is made, is distinguished with the numerical
suffix at CSTD.

The tap, for which the configuration is made, is distinguished with the numerical suffix
at GAIN.

Parameters:
<Gain> float

Range: 0.00  to  2.00
Increment: 1E-5
*RST: 0.00

Example: BB:WIM:AOFD:ZONE0:CSTD1:GAIN1 0.2
the linear gain of antenna 1 in the tap 1 is set to 0.2

Manual operation: See "Liner Gain OFDMA" on page 81

[:SOURce<hw>]:BB:WIMax:AOFDm:ZONE<st0>:CSTD<ch0>:TAPCount
<TapCount>

Sets the number of taps available for the selected antenna.

The antenna, for which the configuration is made, is distinguished with the numerical
suffix at CSTD.

Parameters:
<TapCount> integer

Range: 1  to  5
*RST: 1

Example: BB:WIM:AOFD:ZONE0:CSTD1:TAPC 3
selects 3 taps for configuration

Manual operation: See "Number Of Taps OFDMA" on page 80

[:SOURce<hw>]:BB:WIMax:AOFDm:ZONE<st0>:FCH:MODE <Mode>

Selects the mode for generating the FCH.

Parameters:
<Mode> AUTO | USER

AUTO
The DLFP fields, which form the FCH, are filled automatically
with parameters specified at different locations.
USER
the FCH is filled with data specified under Data Source. This
enables any arbitrary data to be sent with the FCH burst.
*RST: AUTO

Example: BB:WIM:AOFD:ZONE0:FCH:MODE AUTO
selects FCH mode AUTO.

Manual operation: See "FCH Mode OFDMA" on page 89
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[:SOURce<hw>]:BB:WIMax:AOFDm:ZONE<st0>:NUMBer <Number>

Selects the zone number.

Parameters:
<Number> integer

Range: 0  to  7
*RST: 0

Example: BB:WIM:AOFD:ZONE0:NUMB 4
assigns number 4 to zone 1.

Manual operation: See "Zone Number OFDMA" on page 59

[:SOURce<hw>]:BB:WIMax:AOFDm:ZONE<st0>:PERMbase <PermBase>

Selects the PermBase of the zone.

Parameters:
<PermBase> integer

Range: 0  to  69
*RST: 0

Example: BB:WIM:AOFD:ZONE0:PERM 5
Manual operation: See "PermBase OFDMA" on page 60

[:SOURce<hw>]:BB:WIMax:AOFDm:ZONE<st0>:PILDedicated <PilDedicated>

The command activates/deactivates dedicated pilots. If deactivated, the pilot symbols
are broadcast.

Note: This feature is available only for zone type AMC and PUSC with link direction
Downlink.

Parameters:
<PilDedicated> 1 | ON | 0 | OFF

*RST: OFF

Example: BB:WIM:AOFD:ZONE0:PILD ON
Activates dedicated pilot symbols for the specified zone.

Manual operation: See "Dedicated Pilots OFDMA" on page 66

[:SOURce<hw>]:BB:WIMax:AOFDm:ZONE<st0>:PRBSid <Prbsid>

Selects the PRBS_ID of the zone.

Parameters:
<Prbsid> integer

Range: 0  to  3
*RST: 0

Example: BB:WIM:AOFD:ZONE0:PRBS 2
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Manual operation: See "PRBS_ID OFDMA" on page 60

[:SOURce<hw>]:BB:WIMax:AOFDm:ZONE<st0>:SCARrier:RANDomizer
<Randomizer>

The command activates / deactivates the subcarrier randomization for OFDMA config-
urations.

Parameters:
<Randomizer> 1 | ON | 0 | OFF

*RST: ON

Example: BB:WIM:AOFD:ZONE0:SCAR:RAND OFF
Deactivates the subcarrier randomization.

Manual operation: See "Subcarrier Randomization OFDMA" on page 63

[:SOURce<hw>]:BB:WIMax:AOFDm:ZONE<st0>:SEGMent <Segment>

Selects the zone segment for OFDMA configurations.

Parameters:
<Segment> integer

Range: 0  to  2
*RST: 0

Example: BB:WIM:AOFD:ZONE:SEGM 1
selects one segment for zone 1.

Manual operation: See "Segment OFDMA" on page 60

[:SOURce<hw>]:BB:WIMax:AOFDm:ZONE<st0>:SOUNding:AMODe <AMode>

"(only for Sounding Type A)"

Selects the frequency allocation mode for sounding CIDs.

Parameters:
<AMode> NORMal | AMC

NORMal
NORMalThe used sounding allocations are specified with th
commands
SOUR:BB:WIM:AOFD:ZONE:SOUN:CID:FBAN:COUN and
SOUR:BB:WIM:AOFD:ZONE:SOUN:CID:FBAN:STAR.
AMC
AMCA Band Bitmap pattern (set with the command
SOUR:BB:WIM:AOFD:ZONE:SOUN:CID:BBIT) determines the
frequencies to be sent.
*RST: NORMal

Example: BB:WIM:AOFD:ZONE:SOUN:AMOD AMC
sets AMC allocation mode
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Manual operation: See "Allocation Mode OFDMA" on page 74

[:SOURce<hw>]:BB:WIMax:AOFDm:ZONE<st0>:SOUNding:CID:COUNt <Count>

The command sets the total number of CIDs.

Parameters:
<Count> integer

Range: 1  to  16
*RST: 1

Example: BB:WIM:AOFD:ZONE:SOUN:CID5:COUN 1
sets the number of total CIDs to 1.

Manual operation: See "Total Number Of CIDs OFDMA" on page 74

[:SOURce<hw>]:BB:WIMax:AOFDm:ZONE<st0>:SOUNding:CID<ch0>:BBITmap
<BBitmap>

"(only for Sounding Type A and Band AMC Allocation Mode)"

Sets the logical band bitmap of the corresponding CID.

A "1" enables sounding transmission in the corresponding logical band, a "0" disables
it. The right-most bit (LSB) corresponds to logical band 0 (the lowest frequency subcar-
riers).

Parameters:
<BBitmap> integer

*RST: 0

Example: BB:WIM:AOFD:ZONE:SOUN:CID5:BBIT #HFFE,12
sets band bitmap for CID15.

Manual operation: See "Band Bitmap OFDMA" on page 77

[:SOURce<hw>]:BB:WIMax:AOFDm:ZONE<st0>:SOUNding:CID<ch0>:CID <Cid>

Sets the CID (connection control identifier).

Parameters:
<Cid> integer

Range: 0  to  #HFFFF
*RST: 0

Example: BB:WIM:AOFD:ZONE:SOUN:CID5:CID FFFF
sets the connection control identifier to #HFFFF.

Manual operation: See "CID OFDMA" on page 77
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[:SOURce<hw>]:BB:WIMax:AOFDm:ZONE<st0>:SOUNding:CID<ch0>:CINDex
<CIndex>

(only for Sounding Type A)

Sets the value for the cyclic shift index.

Parameters:
<CIndex> integer

The maximum value depends on the setting for the maximum
cyclic shift index
(SOUR:BB:WIM:AOFD:ZONE<0...7>:SOUN:CMAX).
Range: 0  to  31
*RST: 0

Example: BB:WIM:AOFD:ZONE:SOUN:CID5:CIND 3
sets the value for the cyclic shift index to 3.

Manual operation: See "Cyclic Shift Index OFDMA" on page 78

[:SOURce<hw>]:BB:WIMax:AOFDm:ZONE<st0>:SOUNding:CID<ch0>:DECoffset
<DecOffset>

(only for Sounding Type A)

Sets the decimation offset.

Parameters:
<DecOffset> integer

The maximum value depends on the setting for the decimation
value (SOUR:BB:WIM:AOFD:ZONE<0...7>:SOUN:DEC:VAL).
Range: 0  to  127
*RST: 0

Example: BB:WIM:AOFD:ZONE:SOUN:CID5:DEC 10
sets the decimation offset to 10..

Manual operation: See "Decimation Offset OFDMA" on page 78

[:SOURce<hw>]:BB:WIMax:AOFDm:ZONE<st0>:SOUNding:CID<ch0>:FBANd:
STARt <Start>

(only for Sounding Type A)

Sets the start frequency band.

Parameters:
<Start> integer

Range: 0  to  1E9
*RST: 0

Example: BB:WIM:AOFD:ZONE:SOUN:CID5:FBAN:STAR 1
sets the value for the start frequency band to 1.
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Manual operation: See "Start Freq. Band OFDMA" on page 77

[:SOURce<hw>]:BB:WIMax:AOFDm:ZONE<st0>:SOUNding:CID<ch0>:FBANd[:
COUNt] <Count>

(only for Sounding Type A)

Sets the number of frequency bands.

Parameters:
<Count> integer

Range: 1  to  1E9
*RST: 1

Example: BB:WIM:AOFD:ZONE:SOUN:CID5:FBAN:COUN 2
sets the number of frequency band to 2.

Manual operation: See "No. Of Freq. Bands OFDMA" on page 77

[:SOURce<hw>]:BB:WIMax:AOFDm:ZONE<st0>:SOUNding:CID<ch0>:
PERiodicity <Periodicity>

The command sets the value for the periodicity.

Parameters:
<Periodicity> PER0 | PER1 | PER2 | PER4 | PER8 | PER16 | PER32 | PER64

*RST: PER0

Example: BB:WIM:AOFD:ZONE:SOUN:CID5:PER2
sets the value for the periodicity to 2.

Manual operation: See "Periodicity" on page 78

[:SOURce<hw>]:BB:WIMax:AOFDm:ZONE<st0>:SOUNding:CID<ch0>:POWer[:
STATe] <State>

The command activates/deactivates the power boost.

Parameters:
<State> 1 | ON | 0 | OFF

*RST: OFF

Example: BB:WIM:AOFD:ZONE:SOUN:CID5:POW:STAT ON
activates the power boost.

Manual operation: See "Power Boost OFDMA" on page 77

[:SOURce<hw>]:BB:WIMax:AOFDm:ZONE<st0>:SOUNding:CID<ch0>:
RELevance[:STATe] <State>

Activates/deactivates the sounding relevance.
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Parameters:
<State> 1 | ON | 0 | OFF

*RST: 1

Example: BB:WIM:AOFD:ZONE:SOUN:CID5:REL:STAT ON
activates the sounding relevance.

Manual operation: See "Sounding Relevance" on page 77

[:SOURce<hw>]:BB:WIMax:AOFDm:ZONE<st0>:SOUNding:CID<ch0>:
SUBChannel:OFFSet <Offset>

(only for Sounding Type B)

Sets the subchannel offset.

Parameters:
<Offset> integer

Range: 0  to  1E9
*RST: 0

Example: BB:WIM:AOFD:ZONE:SOUN:CID5:SUBC:OFFS 3
sets the subchannel offset to 3.

Manual operation: See "Offset Subch" on page 78

[:SOURce<hw>]:BB:WIMax:AOFDm:ZONE<st0>:SOUNding:CID<ch0>:
SUBChannel[:COUNt] <Count>

(only for Sounding Type B)

Sets the number of subchannels.

Parameters:
<Count> integer

Range: 1  to  1E9
*RST: 1

Example: BB:WIM:AOFD:ZONE:SOUN:CID5:SUBC:COUN 3
sets the number of subchannels to 3.

Manual operation: See "No. Of Subch" on page 78

[:SOURce<hw>]:BB:WIMax:AOFDm:ZONE<st0>:SOUNding:CID<ch0>:SYMBol
<Symbol>

Sets the symbol used for this CID from the available symbols of the zone. Each sound-
ing CID occupies one symbol only.

The maximum value depends on the setting for the number of symbols (command:
SOUR:BB:WIM:AOFD:ZONE<0...7>:SYMB:COUN)
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Parameters:
<Symbol> integer

Range: 1  to  10000
*RST: 1

Example: BB:WIM:AOFD:ZONE:SOUN:CID5:SYMB 5
sets the number of sounding symbols to 5.

Manual operation: See "Sounding Symbol OFDMA" on page 77

[:SOURce<hw>]:BB:WIMax:AOFDm:ZONE<st0>:SOUNding:CMAXimum
<CMaximum>

"(only for Sounding Type A and Separability Type Cyclic Shift)"

The command sets the value for the maximum cyclic shift index.

Parameters:
<CMaximum> MC4 | MC8 | MC16 | MC32 | MC9 | MC18

*RST: MC4

Example: BB:WIM:AOFD:ZONE:SOUN:CMAX MC4
sets the value for the maximum cyclic shift to 4.

Manual operation: See "Max Cyclic Shift Index OFDMA" on page 74

[:SOURce<hw>]:BB:WIMax:AOFDm:ZONE<st0>:SOUNding:DECimation:
RANDomization[:STATe] <State>

"(only for Sounding Type A and Separability Type Decimated Subcarriers)"

The command activates/deactivates the decimation offset randomization.

Parameters:
<State> 1 | ON | 0 | OFF

*RST: OFF

Example: BB:WIM:AOFD:ZONE:SOUN:DEC:RAND STAT ON
activates decimation offset randomization.

Manual operation: See "Decimation Offset Randomization OFDMA" on page 75

[:SOURce<hw>]:BB:WIMax:AOFDm:ZONE<st0>:SOUNding:DECimation:VALue
<Value>

"(only for Sounding Type A and Separability Type Decimated Subcarriers)"

The command sets the value for the decimation.

Parameters:
<Value> DEC2 | DEC4 | DEC5 | DEC8 | DEC16 | DEC32 | DEC64 |

DEC128
*RST: DEC2
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Example: BB:WIM:AOFD:ZONE:SOUN:DEC:VAL DEC16
sets the value for the decimation to 16.

Manual operation: See "Decimation Value OFDMA" on page 75

[:SOURce<hw>]:BB:WIMax:AOFDm:ZONE<st0>:SOUNding:DLPermbase
<DlPermBase>

(only for Sounding Type B)

The command sets the value for the DL PermBase.

Parameters:
<DlPermBase> integer

Range: 0  to  63
*RST: 0

Example: BB:WIM:AOFD:ZONE:SOUN:DLP 16
sets the value for the decimation to 16.

Manual operation: See "DL PermBase OFDMA" on page 75

[:SOURce<hw>]:BB:WIMax:AOFDm:ZONE<st0>:SOUNding:PERMutation?

"(only for Sounding Type B)"

The command queries the permutation used for the selected sounding zone.

Return values: 
<Permutation> PUSC

*RST: PUSC

Example: BB:WIM:AOFD:ZONE:SOUN:PERM?
queries the permutation

Usage: Query only

Manual operation: See "Permutation OFDMA" on page 75

[:SOURce<hw>]:BB:WIMax:AOFDm:ZONE<st0>:SOUNding:RELevance:FLAG
<Flag>

The command selects whether sounding is relevant individually for each CID or for all
CIDs.

Parameters:
<Flag> SAME | INDividual

*RST: SAME

Example: BB:WIM:AOFD:ZONE:SOUN:REL:FLAG SAME
sounding is relevant for all CIDs.

Manual operation: See "Sounding Relevance Flag OFDMA" on page 73
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[:SOURce<hw>]:BB:WIMax:AOFDm:ZONE<st0>:SOUNding:RELevance:MODE
<Mode>

"(only if Sounding Relevance Flag is set to Same For All CIDs)"

The command selects the sounding relevance mode.

Parameters:
<Mode> THIS | NEXT

*RST: THIS

Example: BB:WIM:AOFD:ZONE:SOUN:REL:MODE THIS
selects the sounding relevance mode THIS.

Manual operation: See "Sounding Relevance OFDMA" on page 74

[:SOURce<hw>]:BB:WIMax:AOFDm:ZONE<st0>:SOUNding:SEParability
<Separability>

"(only for Sounding Type A)"

The command selects the sounding separability type.

Parameters:
<Separability> CYCLic | DECimated

*RST: CYCLic

Example: BB:WIM:AOFD:ZONE:SOUN:SEP CYCL
selects the separability mode cyclic.

Manual operation: See "Separability Type OFDMA" on page 73

[:SOURce<hw>]:BB:WIMax:AOFDm:ZONE<st0>:SOUNding:TYPE <Type>

The command selects either sounding type A or B.

Parameters:
<Type> A | B

*RST: A

Example: BB:WIM:AOFD:ZONE:SOUN:TYPE A
selects sounding type A.

Manual operation: See "Sounding Type OFDMA" on page 73

[:SOURce<hw>]:BB:WIMax:AOFDm:ZONE<st0>:SOUNding:UVAL <UVal>

"(only for Sounding Type A)"

Sets the shift value (u) used for decimation offset and cyclic shift index.
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Parameters:
<UVal> integer

Range: 0  to  127
*RST: 0

Example: BB:WIM:AOFD:ZONE:SOUN:UVAL 3
sets the shift parameter U

Manual operation: See "Shift Value U OFDMA" on page 75

[:SOURce<hw>]:BB:WIMax:AOFDm:ZONE<st0>:STC:ANTenna <Antenna>

The command selects the antenna for the space-time coding modes.

Parameters:
<Antenna> ANT0 | ANT1 | ANT2 | ANT3

*RST: ANT0

Example: BB:WIM:AOFD:ZONE:STC:ANT ANT4
Selects antenna 4 for space time coding.

Manual operation: See "Space-Time Coding Antenna OFDMA" on page 65

[:SOURce<hw>]:BB:WIMax:AOFDm:ZONE<st0>:STC:MODE <Mode>

The command sets the space-timing coding mode (2 antennas, matrix A or B; 4 anten-
nas, matrix A, B or C; Collaborative Multiplexing or CSTD) or switches diversity off.

Parameters:
<Mode> OFF | MA2antenna | MB2antenna | BURSt | COLLaborative |

CSTD | MA4antenna | MB4antenna | MC4antenna
*RST: OFF

Example: BB:WIM:AOFD:ZONE:STC:MODE MA2
selects space time coding mode with two antennas and matrix A
in zone 1.

Manual operation: See "Space-Time Coding Mode OFDMA" on page 65

[:SOURce<hw>]:BB:WIMax:AOFDm:ZONE<st0>:STC:PILotpattern <PilotPattern>

(only for Space-Time Coding Mode Collaborative Multiplexing)

Sets the pilot pattern in uplink Collaborative Multiplexing mode.

Parameters:
<PilotPattern> A | B

*RST: A

Example: BB:WIM:AOFD:ZONE:STC:PIL A
sets the pilot pattern to A.

Manual operation: See "Pilot Pattern OFDMA" on page 66
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[:SOURce<hw>]:BB:WIMax:AOFDm:ZONE<st0>:SYMBol:COUNt <Count>

Selects the number of symbols in UL zone for OFDMA configurations. The duration of
uplink bursts cannot exceed the specified number of symbols.

Parameters:
<Count> integer

Range: 1  to  10000
*RST: 2

Example: BB:WIM:AOFD:ZONE:SYMB:COUN 3
Selects three symbols for zone 1.

Manual operation: See "No. Of Symbols OFDMA" on page 60

[:SOURce<hw>]:BB:WIMax:AOFDm:ZONE<st0>:SYMBol:COUNt:AUTO <Auto>

The command activates or deactivates automatic zone length. In auto mode, the num-
ber of symbols in the zone is derived from the configured bursts such that all bursts fit
into the zone, except if the frame duration is exceeded.

This command is available in downlink only.

Parameters:
<Auto> 1 | ON | 0 | OFF

*RST: OFF

Example: BB:WIM:AOFD:ZONE:SYMB:AUTO ON
activates automatic symbol count for zone 1.

Manual operation: See "Auto OFDMA" on page 60

[:SOURce<hw>]:BB:WIMax:AOFDm:ZONE<st0>:SYMBol:OFFSet?

Queries the symbol offset of the zone.

Return values: 
<Offset> integer

Range: 0  to  1E9
*RST: 0

Example: BB:WIM:AOFD:ZONE:SYMB:OFFS?
queries the symbol count offset in zone 1.

Usage: Query only

Manual operation: See "Offset Symbol OFDMA" on page 60

[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:CCODing:FEC
<Fec>

The command switches channel coding FEC parameter on or off.
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Parameters:
<Fec> 1 | ON | 0 | OFF

*RST: ON

Example: BB:WIM:AOFD:ZONE0:BURS:CCOD:FEC ON
activates channel coding FEC parameter for burst 1.

Manual operation: See "FEC" on page 84

[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:CCODing:
INTerleaver <Interleaver>

The command switches channel coding interleaver on or off.

Parameters:
<Interleaver> 1 | ON | 0 | OFF

*RST: ON

Example: BB:WIM:AOFD:ZONE:BURS:CCOD:INT ON
activates channel coding interleaver for burst 1.

Manual operation: See "Interleaver" on page 84

[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:CCODing:MODE
<Mode>

The command activates/deactivates channel coding and selects channel coding mode.
If channel coding is switched off, the bits read from the data source are directly modu-
lated onto the carriers. Due to randomization missing, this could result in high crest fac-
tors of the signal.

Parameters:
<Mode> OFF | CC | CTC

*RST: CC

Example: BB:WIM:AOFD:ZONE0:BURS2:CCOD:MODE OFF
Deactivates channel coding for burst 1.

Manual operation: See "Channel Coding OFDMA" on page 68

[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:CCODing:
RANDomizer <Randomizer>

The command switches channel coding randomizer on or off.

Parameters:
<Randomizer> 1 | ON | 0 | OFF

*RST: ON

Example: BB:WIM:AOFD:ZONE:BURS:CCOD:RAND ON
activates channel coding randomizer for burst 1.

Manual operation: See "Channel Coding Randomizer" on page 84
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[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:CCODing:
REPCoding <Repcoding>

The command selects the channel coding repetition coding.

Parameters:
<Repcoding> REP0 | REP2 | REP4 | REP6

*RST: REP0

Example: BB:WIM:AOFD:ZONE0:BURS:CCOD:REPC REP0
deactivates repetition coding.

Manual operation: See "Repetition Coding" on page 84

[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:CONFlict[:
STATe]?

The command indicates a conflict between two bursts.

Conflicts can occur if subchannel and symbol offsets are set manually and two or more
bursts overlap. Bursts can also overlap with the FCH or DL-MAP. The position of FCH
and DL-MAP is fixed and cannot be changed.

Return values: 
<State> 1 | ON | 0 | OFF

*RST: OFF

Example: BB:WIM:AOFD:ZONE0:BURS2:CONF?
Queries if there exists a conflict between the activated OFDMA
bursts.
Response: 0
There exists not conflict between the activated OFDMA bursts.

Usage: Query only

Manual operation: See "Conflict OFDMA" on page 72

[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:DATA <Data>

The command determines the data source for the specified bursts.

Parameters:
<Data> PN9 | PN11 | PN15 | PN16 | PN20 | PN21 | PN23 | DLISt |

ZERO | ONE | PATTern
PNxx
The pseudo-random sequence generator is used as the data
source. Different random sequence lengths can be selected.
DLISt
A data list is used. The data list is selected with the com-
mand :BB:WIMax:AOFD:BURS:DATA:DSELect.
ZERO|ONE
Internal 0 and 1 data is used.
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PATTern
Internal data is used. The bit pattern for the data is defined by
the command :BB:WIMax:AOFD:BURS:DATA:PATTern.
*RST: PN9

Example: BB:WIM:AOFD:ZONE:BURS:DATA PATT
Selects as the data source for the data fields of burst 1, the bit
pattern defined with the following command.
BB:WIM:AOFD:BURS:DATA:PATT #H3F,8
Defines the bit pattern.

Manual operation: See "Data List Management…" on page 66
See "Data Source OFDMA" on page 70

[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:DATA:DSELect
<DSelect>

The command selects the data list for the DLISt data source selection.

The lists are stored as files with the fixed file extensions *.dm_iqd in a directory of the
user's choice. The directory applicable to the following commands is defined with the
command MMEMory:CDIR. To access the files in this directory, you only have to give
the file name, without the path and the file extension.

Parameters:
<DSelect> string

Example: BB:WIM:AOFD:ZONE0:BURS:DATA DLIS
selects the Data Lists data source.
MMEM:CDIR "/var/user/temp/Lists"
selects the directory for the data lists.
BB:WIM:AOFD:ZONE:BURS:DATA:DLIS "wimax_list1"
selects file 'wimax_list1' as the data source. This file must be in
the directory and must have the file extension *.dm_iqd

Manual operation: See "Data List Management…" on page 66
See "Data Source OFDMA" on page 70

[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:DATA:LENGth
<Length>

Sets the data length in bytes.

Parameters:
<Length> integer

Range: 0  to  3E4
*RST: 6

Example: BB:WIM:AOFD:ZONE0:BURS0:DATA:LENG 256
sets a data length of 256.

Manual operation: See "Data Length OFDMA" on page 68
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[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:DATA:PATTern
<Pattern>, <BitCount>

Sets the bit pattern.

Parameters:
<Pattern> numeric

*RST: #B0

<BitCount> integer
Range: 1  to  64
*RST: 1

Example: BB:WIM:AOFD:ZONE0:BURS:DATA:PATT #H3F,8
Manual operation: See "Data Source OFDMA" on page 70

[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:DIUC <Diuc>

Sets the specific interval usage code. The code is used to initialize the randomizer and
is transmitted in the FCH.

Parameters:
<Diuc> integer

Range: 0  to  15
*RST: 0

Example: BB:WIM:AOFD:ZONE:BURS2:DIUC 12
sets Interval Usage Code12 for burst 2.

Manual operation: See "DIUC OFDMA" on page 83

[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:DLUL:ARIX
<Arix>

Selects whether ACK region 0 or 1 is used.

Parameters:
<Arix> IX0 | IX1

*RST: IX0

Example: BB:WIM:AOFD:ZONE1:BURS2:DLUL:ARIX IX1
Sets ARQ Region Index 1.

Manual operation: See "ACK Region Index" on page 116

[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:DLUL:HARQ:
ACKoffset:DL <Dl>

Sets the ACK channel that corresponds to the first HARQ-enabled DL burst specified
in this map message.
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Parameters:
<Dl> integer

Range: 0  to  255
*RST: 0

Example: BB:WIM:AOFD:ZONE1:BURS2:DLUL:HARQ:ACK:DL 10
sets the DL HARQ ACK offset.

Manual operation: See "DL HARQ ACK Offset" on page 116

[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:DLUL:HARQ:
ACKoffset:INDicator <Indicator>

Enables/disables the inclusion of HARQ ACK offsets.

Parameters:
<Indicator> 1 | ON | 0 | OFF

*RST: ON

Example: BB:WIM:AOFD:ZONE1:BURS2:DLUL:HARQ:ACK:IND ON
sets the HARQ ACK offset indicator.

Manual operation: See "HARQ ACK Offset Indicator" on page 116

[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:DLUL:HARQ:
ACKoffset:UL <Ul>

Sets the ACK bit index in the DL HARQ ACK that corresponds to the first HARQ-
enabled UL burst specified in this map message.

Parameters:
<Ul> integer

Range: 0  to  255
*RST: 0

Example: BB:WIM:AOFD:ZONE1:BURS2:DLUL:HARQ:ACK:UL 10
sets the UL HARQ ACK offset.

Manual operation: See "UL HARQ ACK Offset" on page 116

[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:DLUL:INCLude
<Include>

Selects whether a DL-MAP IE is included in the specified SUB-DL-UL-MAP message
for this burst.

The default value of this parameter is off. One of the three available SUB-DL-UL-MAPs
can be selected to carry the DL-MAP IE for this burst.

Parameters:
<Include> OFF | INC1 | INC2 | INC3

*RST: OFF

OFDMA physical layer commands



Remote-control commandsR&S®SMW-K49

180User Manual 1175.6732.02 ─ 19

Example: BB:WIM:AOFD:ZONE1:BURS2:DLUL:INCL INC2
The DL-MAP IE is included in the second SUB-DL-UL-MAP
message.

Manual operation: See "Include In SUB-DL-UL-MAP" on page 85

[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:DLUL:MPIX?

Queries the number of the SUB-DL-UL-MAP message.

Altogether up to three SUB-DL-UL-MAP messages can be enabled for all zones. The
SUB-DL-UL-MAP Index is a consecutive number that is assigned for each configured
SUB-DL-UL-MAP message.

Return values: 
<MpIndex> integer

Range: 1  to  3
*RST: 1

Example: BB:WIM:AOFD:ZONE1:BURS2:DLUL:MPIX?
queries the consecutive number of the SUB-DL-UL-MAP mes-
sage.
Response: 2

Usage: Query only

Manual operation: See "SUB-DL-UL-MAP Index" on page 115

[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:FFB:CWSize?

Queries the codeword size.

Return values: 
<CwSize> integer

Range: 0  to  DBL_MAX
*RST: 0

Example: BB:WIM:AOFD:ZONE0:BURS2:FFB:CWS?
queries the codeword size.

Usage: Query only

Manual operation: See "Codeword Size" on page 113

[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:FFB:MODE
<Mode>

The command selects the fast feedback mode.

Parameters:
<Mode> NORMal | ENHanced | ENHMimo | ACK

*RST: NORMal
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Example: BB:WIM:AOFD:ZONE0:BURS2:FFB:MODE NORM
selects the fast feedback mode "normal".

Manual operation: See "Fast Feedback Mode" on page 113

[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:FFB:SUBC
<Subc>

Sets the number of subchannels.

Parameters:
<Subc> integer

Range: 1  to  DBL_MAX
*RST: 1

Example: BB:WIM:AOFD:ZONE0:BURS2:FFB:SUBC 25
sets the number of subchannels to 25.

Manual operation: See "No. Of Subchannels" on page 114

[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:FFB:SYMB
<Symb>

The command sets the number of symbols.

Parameters:
<Symb> float

Range: 3  to  MAX
Increment: 3
*RST: 3

Example: BB:WIM:AOFD:ZONE0:BURS2:FFB:SYMB 6
sets the number of symbols to 6.

Manual operation: See "No. Of Symbols" on page 114

[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:FORMat <Format>

Selects the modulation and channel coding rate. Channel coding includes randomiza-
tion, Reed-Solomon coding, convolutional coding and interleaving.

For a given modulation type and channel coding rate, the data length determines the
number of symbols and vice versa.

QAM5D6X64 is only available for Channel Coding CTC.

Parameters:
<Format> QPSK1D2 | QPSK3D4 | QAM1D2X16 | QAM3D4X16 |

QAM1D2X64 | QAM2D3X64 | QAM3D4X64 | QAM5D6X64
*RST: AOFDm: QPSK1D2
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Example: BB:WIM:AOFD:ZONE0:BURS:FORM QAM3D4X64
Selects modulation type 64QAM and a channel coding rate of
3.4 Msample for burst 1.

Manual operation: See "Modulation and Coding Rate OFDMA" on page 68

[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:HARQ:COUNt
<Count>

Sets the number of subbursts in the 2D region.

Parameters:
<Count> integer

Range: 0  to  15
*RST: 0

Example: BB:WIM:AOFD:ZONE0:BURS2:HARQ:COUN 10
Sets the number of subbursts to 10.

Manual operation: See "No. Of Sub-Bursts" on page 106

[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:HARQ:MODE
<Mode>

The command selects the mode of the HARQ burst.

Parameters:
<Mode> CHASe | IR

*RST: CHASe

Example: BB:WIM:AOFD:ZONE0:BURS2:HARQ:MODE CHAS
sets the HARQ mode to chase.

Manual operation: See "HARQ Mode" on page 106

[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:HARQ:MSTart[:
STATe] <State>

Enables/disables Moving Start Offset Mode.

If enabled, the subburst structure resembles the specified structure required for RCT
test 9.1.24.4.

Parameters:
<State> 1 | ON | 0 | OFF

*RST: OFF
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Example: SOUR:BB:WIM:MODE:AOFD
SOUR:BB:WIM:AOFD:FBAN USER
SOUR:BB:WIM:AOFD:BW 10MHz
SOUR:BB:WIM:AOFD:FFT FFT1024
SOUR:BB:WIM:AOFD:ZONE:COUN 2
SOUR:BB:WIM:AOFD:ZONE1:NUMB 1
SOUR:BB:WIM:AOFD:ZONE1:STC:MODE MA2
SOUR:BB:WIM:AOFD:ZONE1:BURS0:TYPE HARQ
SOUR:BB:WIM:AOFD:ZONE1:BURS0:SUBC:COUN 30
SOUR:BB:WIM:AOFD:ZONE1:BURS0:SYMB:COUN 8
SOUR:BB:WIM:AOFD:TONE1:BURS0:HARQ:MODE CHAS
SOUR:BB:WIM:AOFD:ZONE1:BURS0:HARQ:COUN 3
SOUR:BB:WIM:AOFD:ZONE1:BURS0:HARQ0:SLOT 64
SOUR:BB:WIM:AOFD:ZONE1:BURS0:HARQ0:DLEN 382
SOUR:BB:WIM:AOFD:ZONE1:BURS0:HARQ1:SLOT 20
SOUR:BB:WIM:AOFD:ZONE1:BURS0:HARQ1:DLEN 118
SOUR:BB:WIM:AOFD:ZONE1:BURS0:HARQ2:SLOT 32
SOUR:BB:WIM:AOFD:ZONE1:BURS0:HARQ3:DLEN 166
SOUR:BB:WIM:AOFD:ZONE0:BURS0:HARQ:MST:STAT ON
SOUR:BB:WIM:SLEN 10
SOUR:BB:WIM:STAT ON
enables moving of start offset mode.

Manual operation: See "Moving Start Offset Mode" on page 107

[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:HARQ:SLFRee?

The command queries the remaining number of slots available for the burst.

Return values: 
<SlFree> integer

Range: 0  to  DBL_MAX
*RST: 0

Example: BB:WIM:AOFD:ZONE0:BURS2:HARQ:SLFR?
queries the remaining number of slots available for the burst.

Usage: Query only

Manual operation: See "No. Of Slots Available In Burst" on page 108

[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:HARQ<dir0>:
ACID <Acid>

Sets the HARQ channel identifier for the specified subburst.

Parameters:
<Acid> integer

Range: 0  to  15
*RST: 0
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Example: BB:WIM:AOFD:ZONE0:BURS2:HARQ5:ACID 12
Sets the subburst ACID to 12.

Manual operation: See "ACID" on page 111

[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:HARQ<dir0>:
ACKD <Ackd>

Disables ACK, i.e. the allocated subburst does not require an ACK to be transmitted .

Parameters:
<Ackd> 1 | ON | 0 | OFF

*RST: ON

Example: BB:WIM:AOFD:ZONE0:BURS2:HARQ5:ACKD ON
disables ACK.

Manual operation: See "ACK Disable" on page 112

[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:HARQ<dir0>:
DATA <Data>

The command sets the data source for the specified subburst.

Parameters:
<Data> PN9 | PN11 | PN15 | PN16 | PN20 | PN21 | PN23 | DLISt |

ZERO | ONE | PATTern
PNxx
The pseudo-random sequence generator is used as the data
source. Different random sequence lengths can be selected.
DLISt
A data list is used. The data list is selected with the com-
mand :BB:WIMax:AOFD:ZONE:BURS:HARQ:DATA:DSELect.
ZERO|ONE
Internal 0 and 1 data is used.
PATTern
Internal data is used. The bit pattern for the data is defined by
the com-
mand :BB:WIMax:AOFD:ZONE:BURS:DATA:PATTern.
*RST: PN9

Example: BB:WIM:AOFD:ZONE0:BURS2:HARQ6:DATA PATT
Selects as the data source the bit pattern defined with the follow-
ing command.
BB:WIM:AOFD:ZONE0:BURS2:HARQ6:DATA:PATT #H3F,8
Defines the bit pattern.

Manual operation: See "Data Source" on page 110
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[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:HARQ<dir0>:
DATA:DSELect <DSelect>

Selects the data list for the DLISt data source selection.

The lists are stored as files with the fixed file extensions *.dm_iqd in a directory of the
user's choice. The directory applicable to the following commands is defined with the
command MMEMory:CDIR. To access the files in this directory, you only have to give
the file name, without the path and the file extension.

Parameters:
<DSelect> string

Example: BB:WIM:AOFD:ZONE0:BURS2:HARQ6:DATA DLIS
selects the Data Lists data source.
MMEM:CDIR "/var/user/temp/Lists"
selects the directory for the data lists.
BB:WIM:AOFD:ZONE0:BURS2:HARQ6:DATA:DSEL
"wimax_list1"
selects file wimax_list1 as the data source. This file must be
in the directory and must have the file extension *.dm_iqd

Manual operation: See "Data Source" on page 110

[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:HARQ<dir0>:
DATA:PATTern <Pattern>, <BitCount>

Sets the bit pattern.

Parameters:
<Pattern> numeric

*RST: #H0

<BitCount> integer
Range: 1  to  64
*RST: 1

Example: BB:WIM:AOFD:ZONE0:BURS2:HARQ6:DATA:PATT #B0,1
Manual operation: See "Data Source" on page 110

[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:HARQ<dir0>:
DIUC <Diuc>

(for HARQ Chase Mode only)

Sets the DIUC (Downlink Interval User Code) for the specified subburst. The code is
used to initialize the randomizer and is transmitted in the FCH.

Parameters:
<Diuc> integer

Range: 0  to  15
*RST: 0
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Example: BB:WIM:AOFD:ZONE0:BURS2:HARQ:MODE CHAS
Sets the HARQ mode to chase.
BB:WIM:AOFD:ZONE0:BURS2:HARQ6:DIUC5
Sets the Interval Usage Code 5 for subburst 6.

Manual operation: See "DIUC" on page 111

[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:HARQ<dir0>:
DLENgth <DLength>

Sets the data length of the subburst. The data length range is dynamic and depends
on the packet size and the MAC header state.

Parameters:
<DLength> integer

Range: 0  to  1E9
*RST: 16

Example: BB:WIM:AOFD:ZONE0:BURS2:HARQ4:DLEN 10
Sets the data length of the subburst to 10.

Manual operation: See "Data Length" on page 110

[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:HARQ<dir0>:
FORMat?

(for HARQ IR Mode only)

Queries the subburst modulation.

Return values: 
<Format> NONE | QPSK | QAM16 | QAM64

*RST: QPSK

Example: BB:WIM:AOFD:ZONE0:BURS2:HARQ:MODE IR
Sets the HARQ mode to IR.
BB:WIM:AOFD:ZONE0:BURS2:HARQ5:FORM?
Queries the subburst modulation.

Usage: Query only

Manual operation: See "Modulation" on page 110

[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:HARQ<dir0>:
MAC:CID <Cid>

Sets the CID (Connection Control Identifier) of the medium access control layer (MAC).
The CID identifies a connection to equivalent peers in the MAC of the base station and
subscriber station.
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Parameters:
<Cid> integer

Range: 0  to  #HFFFF
*RST: 0

Example: BB:WIM:AOFD:ZONE0:BURS2:HARQ5:MAC:CID #H33
Sets the CID for subburst 5 to 33.

Manual operation: See "MAC CID" on page 83

[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:HARQ<dir0>:
MAC:CRC:STATe <State>

The command activates/deactivates the checksum determination. The state of the
CRC can be set independently of the state of MAC header generation.

Parameters:
<State> 1 | ON | 0 | OFF

*RST: 0

Example: BB:WIM:AOFD:BURS2:HARQ5:MAC:CRC:STAT ON
Activates the checksum determination for the specified subburst.

Manual operation: See "CRC State" on page 117

[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:HARQ<dir0>:
MAC:EKS <Eks>

Sets the EKS (Encryption Key Sequence) value in the MAC header. The payload
encryption itself is not performed by the signal generator.

Parameters:
<Eks> integer

Range: 0  to  3
*RST: 0

Example: BB:WIM:AOFD:BURS2:HARQ5:MAC:ENCR:STAT ON
enables payload encryption.
BB:WIM:AOFD:BURS2:HARQ5:MAC:EKS 2
sets the EKS for burst 2.

Manual operation: See "EKS" on page 118

[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:HARQ<dir0>:
MAC:ENCRypted:STATe <State>

The command activates/deactivates payload encryption. If activated, the EC (encryp-
tion control) field is set to 1 and the EKS (encryption key sequence) field can be set.

Parameters:
<State> 1 | ON | 0 | OFF

*RST: 0
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Example: BB:WIM:AOFD:BURS2:HARQ5:MAC:ENCR:STAT ON
Enables payload encryption for subburst 5.
BB:WIM:AOFD:BURS2:HARQ5:MAC:EKS 2
Sets the EKS.

Manual operation: See "Payload encrypted" on page 118

[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:HARQ<dir0>:
MAC:STATe <State>

The command activates/deactivates the checksum determination. The state of the
CRC can be set independently of the state of MAC header generation.

Parameters:
<State> 1 | ON | 0 | OFF

*RST: OFF

Example: BB:WIM:AOFD:BURS2:HARQ5:MAC:STAT ON
Enables generation of the generic MAC header for subburst 5.

Manual operation: See "MAC Header State" on page 118

[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:HARQ<dir0>:
MAC:TYPE <Type>

Specifies the MAC type. The value of the 6-bit type field is set which indicates the pay-
load type, including the presence of subheaders.

Parameters:
<Type> integer

Range: 0  to  #H3F
*RST: 0

Example: BB:WIM:AOFD:BURS2:HARQ5:MAC:TYPE #H3F
Sets the type field of the MAC header of subburst 5.

Manual operation: See "Mac Type" on page 118

[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:HARQ<dir0>:
MODRate <ModRate>

(for HARQ Chase Mode only)

Sets the subburst modulation and coding rate.

Parameters:
<ModRate> QPSK_12 | QPSK_34 | QAM16_12 | QAM16_34 | QAM64_12 |

QAM64_23 | QAM64_34 | QAM64_56
*RST: QPSK_12
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Example: BB:WIM:AOFD:ZONE0:BURS2:HARQ:MODE CHAS
Sets the HARQ mode to chase.
BB:WIM:AOFD:ZONE0:BURS2:HARQ:MODR QPSK_34
Sets the modulation and coding rate.

Manual operation: See "Modulation & Coding Rate" on page 109

[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:HARQ<dir0>:
PSIZe <PSize>

(for HARQ IR Mode only)

The command sets the HARQ subburst packet size (in bits).

Parameters:
<PSize> PS48 | PS96 | PS144 | PS192 | PS288 | PS384 | PS480 |

PS960 | PS1K92 | PS2K88 | PS3K84 | PS4K8 | PS9K6 |
PS14K4 | PS19K2 | PS24K
*RST: PS144

Example: BB:WIM:AOFD:ZONE0:BURS2:HARQ:MODE IR
Sets the HARQ mode to IR.
BB:WIM:AOFD:ZONE0:BURS2:HARQ5:PSIZ PS144
Sets the packet size to 144 bit.

Manual operation: See "Packet Size [Bits]" on page 109

[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:HARQ<dir0>:
RATE?

(for HARQ IR Mode only)

Queries the subburst code rate.

Return values: 
<Rate> string

Example: BB:WIM:AOFD:ZONE0:BURS2:HARQ:MODE IR
Sets the HARQ mode to IR.
BB:WIM:AOFD:ZONE0:BURS2:HARQ5:RATE?
Queries the subburst rate.

Usage: Query only

Manual operation: See "Rate" on page 110

[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:HARQ<dir0>:
SLOTcount <SlotCount>

Sets the duration of the subbursts in slots. The duration range is dynamic and depends
on the selected link direction and packet size.
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Parameters:
<SlotCount> integer

Range: 1  to  1E9
*RST: 2

Example: BB:WIM:AOFD:ZONE0:BURS2:HARQ5:SLOT 1
Sets the duration of subburst 5 to one slot.

Manual operation: See "Duration [Slots]" on page 110

[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:HARQ<dir0>:
SPID <Spid>

(for HARQ IR Mode only)

The command sets the subpacket ID, which is used to identify the four subpackets
generated from an encoder packet.

Parameters:
<Spid> string

*RST: 0

Example: BB:WIM:AOFD:ZONE0:BURS2:HARQ:MODE IR
Sets the HARQ mode to incremental redundancy.
BB:WIM:AOFD:ZONE0:BURS2:HARQ5:SPID 1,2,3
Sets the SPID sequence.

Manual operation: See "SPID Sequence" on page 111

[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:MAC:CID <Cid>

Sets the CID (Connection Control Identifier) of the medium access control layer (MAC).

Parameters:
<Cid> integer

Range: 0  to  #HFFFF
*RST: 0

Example: BB:WIM:AOFD:ZONE0:BURS2:MAC:CID #HE7
sets the CID for burst 2 to 231.

Manual operation: See "MAC CID" on page 83

[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:MAC:CRC:STATe
<State>

The command activates/deactivates the checksum determination. The state of the
CRC can be set independently of the state of MAC header generation.

Parameters:
<State> 1 | ON | 0 | OFF

*RST: OFF
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Example: BB:WIM:AOFD:BURS2:MAC:CRC:STAT ON
activates the checksum determination for burst 2.

Manual operation: See "CRC State" on page 117

[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:MAC:EKS <Eks>

Sets the EKS (Encryption Key Sequence) value in the MAC header.

The payload encryption itself is not performed by the signal generator.

Parameters:
<Eks> integer

Range: 0  to  3
*RST: 0

Example: BB:WIM:AOFD:BURS2:MAC:ENCR:STAT ON
enables payload encryption.
BB:WIM:AOFD:BURS2:MAC:EKS 2
sets the EKS for burst 2.

Manual operation: See "EKS" on page 118

[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:MAC:ENCRypted:
STATe <State>

The command activates/disactivates payload encryption. If activated, the EC (Encryp-
tion Control) field is set to 1 and the EKS (Encryption Key Sequence) field can be set.

Parameters:
<State> 1 | ON | 0 | OFF

*RST: OFF

Example: BB:WIM:AOFD:BURS2:MAC:ENCR:STAT ON
enables payload encryption for burst 2.
BB:WIM:AOFD:BURS2:MAC:EKS 2
sets the EKS.

Manual operation: See "Payload encrypted" on page 118

[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:MAC:STATe
<State>

The command enables/disables generation of the generic MAC header for the selected
burst.

Parameters:
<State> 1 | ON | 0 | OFF

*RST: OFF

Example: BB:WIM:AOFD:BURS2:MAC:STAT ON
enables generation of the generic MAC header for burst 2.
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Manual operation: See "MAC Header State" on page 118

[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:MAC:TYPE
<Type>

Specifies the MAC type.

Parameters:
<Type> integer

Range: 0  to  #H3F
*RST: 0

Example: BB:WIM:AOFD:BURS2:MAC:TYPE #H3F
sets the type field of the MAC header of burst 2.

Manual operation: See "Mac Type" on page 118

[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:OFFSet:MODE
<Mode>

The command selects the offset mode for the selected burst. The offset mode deter-
mines if the subchannel offset and the symbol offset of each burst are set automatically
or manually.

Parameters:
<Mode> USER | AUTO

*RST: AUTO

Example: BB:WIM:AOFD:ZONE0:BURS2:OFFS:MODE USER
sets the manual offset mode. The start subchannel and symbol
of the burst are set manually with commands
BB:WIM:ZONE0:AOFD:BURS2:OFFS:SUBChannel and
BB:WIM:AOFD:ZONE0:BURS2:OFFS:SYMBol.

Manual operation: See "Auto OFDMA" on page 69

[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:OFFSet:
SUBChannel <SubChannel>

Sets the subchannel offset for the selected burst.

This command is only available for offset mode user
(BB:WIM:AOFD:ZONE0:BURS2:OFFS:MODE USER).

Parameters:
<SubChannel> integer

Range: 0  to  1E9
*RST: Burst0: 7; All other bursts: 0
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Example: BB:WIM:AOFD:ZONE0:BURS2:OFFS:MODE USER
sets the manual offset mode.
BB:WIM:AOFD:ZONE0:BURS2:OFFS:SUBC 8
selects subchannel 8 as start subchannel for burst 2.

Manual operation: See "Offset Subchannel OFDMA" on page 69

[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:OFFSet:SYMBol
<Symbol>

Sets the symbol offset for the selected burst.

This command is only available for offset mode user
(BB:WIM:AOFD:ZONE0:BURS2:OFFS:MODE USER).

Parameters:
<Symbol> integer

Range: 0  to  10000
*RST: 0

Example: BB:WIM:AOFD:ZONE0:BURS2:OFFS:MODE USER
sets the manual offset mode.
BB:WIM:AOFD:ZONE0:BURS2:OFFS:SYMB 2
selects symbol 2 as start symbol for burst 2.

Manual operation: See "Offset Symbol OFDMA" on page 69

[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:PDU:COUNt
<Count>

Sets the number of PDUs in the burst.

This command is only available for enabled multiple PDUS
(BB:WIM:AOFD:ZONE<0..7>:BURS<0..63>:PDU:STAT ON).

Parameters:
<Count> integer

Range: 0  to  16
*RST: 1

Example: BB:WIM:AOFD:ZONE0:BURS2:PDU:STAT ON
activates multiple PDUs.
BB:WIM:AOFD:ZONE0:BURS2:PDU:COUN 5
selects 5 PDUs to be configured.

Manual operation: See "No. Of PDUs OFDMA" on page 83

[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:PDU:STATe
<State>

Enables/disables configuration of multiple PDUs. If this parameter is enabled, multiple
PDUs each with own MAC header and CRC are available within one burst.
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Parameters:
<State> 1 | ON | 0 | OFF

*RST: OFF

Example: BB:WIM:AOFD:ZONE0:BURS2:PDU:STAT ON
activates multiple PDUs.

Manual operation: See "Multiple PDUs OFDMA" on page 83

[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:PDU<dir0>:DATA
<Data>

The command sets the data source for the specified PDU.

Parameters:
<Data> PN9 | PN11 | PN15 | PN16 | PN20 | PN21 | PN23 | DLISt |

ZERO | ONE | PATTern
PNxx
The pseudo-random sequence generator is used as the data
source. Different random sequence lengths can be selected.
DLISt
A data list is used. The data list is selected with the com-
mand :BB:WIMax:AOFD:ZONE:BURS:PDU:DATA:DSELect.
ZERO|ONE
Internal 0 and 1 data is used.
PATTern
Internal data is used. The bit pattern for the data is defined by
the com-
mand :BB:WIMax:AOFD:ZONE:BURS:PDU:DATA:PATTern.
*RST: PN9

Example: BB:WIM:AOFD:ZONE0:BURS2:PDU6:DATA PATT
Selects as the data source the bit pattern defined with the follow-
ing command.
BB:WIM:AOFD:ZONE0:BURS2:PDU6:DATA:PATT #H3F,8
Defines the bit pattern.

Manual operation: See "Data Source PDU OFDMA" on page 88

[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:PDU<dir0>:DATA:
DSELect <DSelect>

The command selects the data list for the DLISt data source selection.

The lists are stored as files with the fixed file extensions *.dm_iqd in a directory of the
user's choice. The directory applicable to the following commands is defined with the
command MMEMory:CDIR. To access the files in this directory, you only have to give
the file name, without the path and the file extension.

Parameters:
<DSelect> string
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Example: BB:WIM:AOFD:ZONE0:BURS2:PDU6:DATA DLIS
selects the Data Lists data source.
MMEM:CDIR "/var/user/temp/Lists"
selects the directory for the data lists.
BB:WIM:AOFD:ZONE0:BURS2:PDU6:DATA:DSEL
"pdu6_wimax"
selects file pdu6_wimax as the data source. This file must be in
the directory and must have the file extension *.dm_iqd.

Manual operation: See "Data Source PDU OFDMA" on page 88

[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:PDU<dir0>:DATA:
PATTern <Pattern>, <BitCount>

Sets the bit pattern.

Parameters:
<Pattern> numeric

*RST: #H0

<BitCount> integer
Range: 1  to  64
*RST: 1

Example: BB:WIM:AOFD:ZONE0:BURS2:PDUQ6:DATA:PATT #B0,1
Manual operation: See "Data Source PDU OFDMA" on page 88

[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:PDU<dir0>:
DLENgth <DLength>

Sets the data length of the PDU. The data length range is dynamic and depends on the
packet size and the MAC header state.

Parameters:
<DLength> integer

Range: 0  to  3E4
*RST: 16

Example: BB:WIM:AOFD:ZONE0:BURS2:HARQ4:DLEN 10
Sets the data length of the subburst to 10.

Manual operation: See "Data Length PDU OFDMA" on page 87

[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:PDU<dir0>:MAC:
CRC:STATe <State>

The command activates/deactivates the checksum determination. The state of the
CRC can be set independently of the state of MAC header generation.
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Parameters:
<State> 1 | ON | 0 | OFF

*RST: 0

Example: BB:WIM:AOFD:BURS2:PDU5:MAC:CRC:STAT ON
activates the checksum determination for the specified PDU.

Manual operation: See "CRC State (PDU)" on page 120

[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:PDU<dir0>:MAC:
EKS <Eks>

Sets the EKS (Encryption Key Sequence) value in the MAC header. The payload
encryption itself is not performed by the signal generator.

Parameters:
<Eks> integer

Range: 0  to  3
*RST: 0

Example: BB:WIM:AOFD:BURS2:PDU5:MAC:ENCR:STAT ON
enables payload encryption.
BB:WIM:AOFD:BURS2:PDU5:MAC:EKS 2
sets the EKS for burst 2.

Manual operation: See "EKS (PDU)" on page 121

[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:PDU<dir0>:MAC:
ENCRypted:STATe <State>

The command activates/deactivates payload encryption. If activated, the EC (encryp-
tion control) field is set to 1 and the EKS (encryption key sequence) field can be set.

Parameters:
<State> 1 | ON | 0 | OFF

*RST: 0

Example: BB:WIM:AOFD:BURS2:PDU5:MAC:ENCR:STAT ON
enables payload encryption for PDU5.
BB:WIM:AOFD:BURS2:PDU5:MAC:EKS 2
sets the EKS.

Manual operation: See "Payload encrypted (PDU)" on page 121

[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:PDU<dir0>:MAC:
STATe <State>

The command activates/deactivates the checksum determination. The state of the
CRC can be set independently of the state of MAC header generation.
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Parameters:
<State> 1 | ON | 0 | OFF

*RST: OFF

Example: BB:WIM:AOFD:BURS2:PDU5:MAC:STAT ON
enables generation of the generic MAC header for PDU5.

Manual operation: See "MAC Header State (PDU)" on page 121

[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:PDU<dir0>:MAC:
TYPE <Type>

Specifies the MAC type.

Parameters:
<Type> integer

Range: 0  to  0x3F
*RST: 0

Example: BB:WIM:AOFD:BURS2:PDU5:MAC:TYPE #H3F
sets the type field of the MAC header of PDU5.

Manual operation: See "Mac Type (PDU)" on page 121

[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:PDU<dir0>[:
MAC]:CID <Cid>

Sets the CID (Connection Control Identifier) of the medium access control layer (MAC).

Parameters:
<Cid> integer

Range: 0  to  #HFFFF
*RST: 0

Example: BB:WIM:AOFD:ZONE0:BURS2:PDU5:MAC:CID #H33
sets the CID for PDU5 to 33.

Manual operation: See "MAC CID (PDU)" on page 88

[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:PMAP <PMap>

(only for burst type UCD and DCD)

Determines whether the burst profile mapping is performed automatically or manually.
In manual configuration, the mapping of the FEC & Modulation Type to the UIUCs/
DUICs is defined by the user.

Parameters:
<PMap> AUTO | MANual

*RST: AUTO

Example: BB:WIM:AOFD:ZONE0:BURS2:PMAP MAN
enables manual mapping
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Manual operation: See "Burst Profile Mapping" on page 85

[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:PMAP:
DMODulation<dir0> <DModulation>

(only for burst type DCD and manual Burst Profile Mapping)

Sets the FEC and the modulation for the selected DUIC.

Parameters:
<DModulation> MQPSKCC12 | MQPSKCC34 | M16QAMCC12 |

M16QAMCC34 | M64QAMCC12 | M64QAMCC23 |
M64QAMCC34 | MQPSKCTC12 | MQPSKCTC34 |
M16QAMCTC12 | M16QAMCTC34 | M64QAMCTC12 |
M64QAMCTC23 | M64QAMCTC34 | M64QAMCTC56
*RST: MQPSKCC12

Example: BB:WIM:AOFD:ZONE0:BURS2:PMAP MAN
enables manual mapping
BB:WIM:AOFD:ZONE0:BURS2:PMAP:DMOD0 MQPSKCC12
selects QPSK (CC) 1/2 modulation and coding scheme for
DUIC#0

Manual operation: See "FEC & Modulation Type" on page 86

[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:PMAP:
UMODulation<dir0> <UModulation>

(only for burst type UCD and manual Burst Profile Mapping)

Sets the FEC and the modulation for the selected UUIC.

Parameters:
<UModulation> MQPSKCC12 | MQPSKCC34 | M16QAMCC12 |

M16QAMCC34 | M64QAMCC12 | M64QAMCC23 |
M64QAMCC34 | MQPSKCTC12 | MQPSKCTC34 |
M16QAMCTC12 | M16QAMCTC34 | M64QAMCTC12 |
M64QAMCTC23 | M64QAMCTC34 | M64QAMCTC56
*RST: MQPSKCC12

Example: BB:WIM:AOFD:ZONE0:BURS2:PMAP MAN
enables manual mapping
BB:WIM:AOFD:ZONE0:BURS2:PMAP:UMOD1 MQPSKCC12
selects QPSK (CC) 1/2 modulation and coding scheme for
UUIC#1

Manual operation: See "FEC & Modulation Type" on page 86
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[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:POWer <Power>

The command sets the power for the selected burst in dB. To set the absolute power of
a burst correctly, level reference "FCH "/ "Burst" must be selected. In this mode, the
output power of a burst equals Level + BurstPower.

In downlink, the preamble is transmitted with +3 dB and the FCH is transmitted with 0
dB.

In uplink, the power of the first burst is fixed to 0 dB.

Parameters:
<Power> float

Range: -80.0 dB  to  10.0 dB
Increment: 0.01 dB
*RST: 0.0 dB

Example: BB:WIM:AOFD:ZONE0:BURS2:POW -2dB
sets the burst power to -2 dB.

Manual operation: See "Boost OFDMA" on page 70

[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:RANGing:
ACODe?

Queries the number of allocated codes for OFDMA ranging.

Burst Type Ranging is available in uplink only.

Return values: 
<ACode> integer

Range: 0  to  DBL_MAX
*RST: 1

Example: BB:WIM:AOFD:ZONE0:BURS2:RANG:ACOD
Queries the number of allocated codes.

Usage: Query only

Manual operation: See "No. Of Allocated Codes" on page 105

[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:RANGing:
OPPortunity:SIZE <Size>

Sets the ranging opportunity size.

Parameters:
<Size> integer

Range: 1  to  4
*RST: 2

Example: BB:WIM:AOFD:ZONE0:BURS2:RANG:OPP:SIZE 2
Sets an opportunity size of 2.

Manual operation: See "Opportunity Size" on page 104
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[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:RANGing:
OPPortunity:SLOTcount <SlotCount>

Sets the number of ranging opportunity slots.

Parameters:
<SlotCount> integer

Range: 1  to  1E9
*RST: 1

Example: BB:WIM:AOFD:ZONE0:BURS2:RANG:OPP:SLOT 2
sets a number of 2 opportunity slots.

Manual operation: See "No. Of Opportunity Slots" on page 104

[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:RANGing:
SCGCount <ScgCount>

Sets the number of ranging sub channel groups.

Burst Type Ranging is available in uplink only.

Parameters:
<ScgCount> integer

Range: 1  to  10
*RST: 1

Example: BB:WIM:AOFD:ZONE0:BURS2:RANG:SCGC 2
sets a number of 2 opportunity subchannel groups.

Manual operation: See "No. Of Subchannel Groups" on page 104

[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:SLOT:COUNt
<Count>

Sets the number of slots for the selected burst.

Parameters:
<Count> integer

Range: 1  to  1000
*RST: 1

Example: BB:WIM:AOFD:ZONE0:BURS2:SLOT:COUN 12
sets 2 slots for burst 2.

Manual operation: See "Duration-Slots OFDMA" on page 69

[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:STC:MODE
<Mode>

The command sets the space-timing coding mode.
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Parameters:
<Mode> MA2antenna | MB2antenna

*RST: MA2antenna

Example: BB:WIM:AOFD:ZONE:BURS3:STC:MODE MA2
selects space time coding mode with two antennas and matrix A
in zone 1.

Manual operation: See "Space-Time Coding Mode" on page 84

[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:SUBChannel[:
COUNt] <Count>

Sets the number of subchannels for the selected burst.

Parameters:
<Count> integer

Range: 1  to  1E9
*RST: 1

Example: BB:WIM:AOFD:ZONE0:BURS2:SUBC:COUN 16
sets 16 subchannels for burst 2.

Manual operation: See "Number of Subchannels OFDMA" on page 68

[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:SYMBol[:COUNt]
<Count>

Sets the number of symbols for the selected burst. If the number of symbols is
changed, the data length is adjusted to fill the specified number of symbols with data
so that no padding has to be applied.

The maximum data length of 10 000 bytes defines the maximum number of symbols
for a given modulation type and channel coding rate.

Parameters:
<Count> integer

Range: 1  to  1000
*RST: 2

Example: BB:WIM:AOFD:ZONE0:BURS2:SYMB:COUN 12
sets 12 symbols for burst 2.

Manual operation: See "Number of Symbols OFDMA" on page 68

[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:TYPE <Type>

The command selects the burst type.

Available burst types for downlink: DATA | FCH | DLMap | ULMap | HARQ | DCD |
UCD | SUBMap

Available burst types for uplink: DATA | RANGing | HARQ | FASTfeedback
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Parameters:
<Type> DATA | FCH | DLMap | RANGing | ULMap | HARQ |

FASTfeedback | DCD | UCD | SUBMap
*RST: DATA

Example: BB:WIM:AOFD:ZONE0:BURS2:TYPE DATA
selects burst type DATA.

Manual operation: See "Burst Type OFDMA" on page 70

[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:UCD:RANGing:
BOENd <BoEnd>

(only for burst type UCD)

Sets the end value for the ranging backoff.

Parameters:
<BoEnd> integer

Range: 0  to  15
*RST: 5

Example: BB:WIM:AOFD:ZONE0:BURS2:UCD:RANG:BOEN 10
sets the end value for the ranging backoff to 10.

Manual operation: See "Ranging Backoff End" on page 85

[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:UCD:RANGing:
BOSTart <BoStart>

(only for burst type UCD)

Sets the start value for the ranging backoff.

Parameters:
<BoStart> integer

Range: 0  to  15
*RST: 0

Example: BB:WIM:AOFD:ZONE0:BURS2:UCD:RANG:BOST 10
sets the start value for the ranging backoff to 10.

Manual operation: See "Ranging Backoff Start" on page 85

[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:UCD:REQuest:
BOENd <BoEnd>

(only for burst type UCD)

Sets the end value for the request backoff.
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Parameters:
<BoEnd> integer

Range: 0  to  15
*RST: 5

Example: BB:WIM:AOFD:ZONE0:BURS2:UCD:REQ:BOEN 10
sets the end value for the request backoff to 10.

Manual operation: See "Request Backoff End" on page 85

[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:UCD:REQuest:
BOSTart <BoStart>

(only for burst type UCD)

Sets the start value for the request backoff.

Parameters:
<BoStart> integer

Range: 0  to  15
*RST: 0

Example: BB:WIM:AOFD:ZONE0:BURS2:UCD:REQ:BOST 10
sets the start value for the request backoff to 10.

Manual operation: See "Request Backoff Start" on page 85

[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:UIUC <Uiuc>

Sets uplink interval usage code. The UIUC is used for the UL-MAP, if generated.

Parameters:
<Uiuc> integer

Range: 0  to  15
*RST: 1

Example: BB:WIM:AOFD:ZONE0:BURS2:UIUC 2
sets uplink interval usage code 2.

Manual operation: See "UIUC OFDMA" on page 83

[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:ULMap:AMODe
<AMode>

The command sets the UL-MAP Allocation Start Time Base. Allocation Start Time field
of the UL-MAP specifies the start of the uplink subframe.

This command is available for link direction downlink only.

Parameters:
<AMode> DLSFend | FRAMestart

*RST: DLSFend
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Example: BB:WIM:AOFD:ZONE0:BURS2:ULM:AMOD DLSF
sets the allocation start time base to DL subframe end.

Manual operation: See "Allocation Start Timebase" on page 99

[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:ULMap:ATIMe
<ATime>

The command sets the UL-MAP Allocation Start Time.

This command is available for link direction downlink only.

Parameters:
<ATime> float

Range: 0  to  frame duration
Increment: 1E-6
*RST: 0

Example: BB:WIM:AOFD:ZONE0:BURS2:ULM:ATIM 4
sets the allocation start time to 2.

Manual operation: See "Allocation Start Time" on page 99

[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:ULMap:DCD:CID
<Cid>

Sets the value for the DCD CID.

Parameters:
<Cid> integer

Range: 0  to  #HFFFF
*RST: #HFFFF

Example: BB:WIM:AOFD:ZONE0:BURS2:ULM:DCD:CID #H456
enters the value for the DCD CID.

Manual operation: See "DCD CID OFDMA" on page 99

[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:ULMap:DCD:
STATe <State>

The command activates/deactivates that the DCD is appended to the UL-MAP. The
DCD message is transmitted with its own MAC header and CRC, included in the same
burst allocation used by the UL-MAP.

Parameters:
<State> 1 | ON | 0 | OFF

*RST: OFF

Example: BB:WIM:AOFD:ZONE0:BURS2:ULM:DCD:STAT ON
appends the DCD to the UL-Map.

Manual operation: See "Append DCD OFDMA" on page 99
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[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:ULMap:RANGing:
BOENd <BoEnd>

Sets the end value for the ranging backoff.

Parameters:
<BoEnd> integer

Range: 0  to  15
*RST: 5

Example: BB:WIM:AOFD:ZONE0:BURS2:ULM:RANG:BOEN 10
sets the end value for the ranging backoff to 10.

Manual operation: See "Ranging Backoff End" on page 100

[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:ULMap:RANGing:
BOSTart <BoStart>

Sets the start value for the ranging backoff.

Parameters:
<BoStart> integer

Range: 0  to  15
*RST: 0

Example: BB:WIM:AOFD:ZONE0:BURS2:ULM:RANG:BOST 10
sets the start value for the ranging backoff to 10.

Manual operation: See "Ranging Backoff Start" on page 100

[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:ULMap:REQuest:
BOENd <BoEnd>

Sets the end value for the request backoff.

Parameters:
<BoEnd> integer

Range: 0  to  15
*RST: 5

Example: BB:WIM:AOFD:ZONE0:BURS2:ULM:REQ:BOEN 10
sets the end value for the request backoff to 10.

Manual operation: See "Request Backoff End" on page 100

[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:ULMap:REQuest:
BOSTart <BoStart>

Sets the start value for the request backoff.
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Parameters:
<BoStart> integer

Range: 0  to  15
*RST: 0

Example: BB:WIM:AOFD:ZONE0:BURS2:ULM:REQ:BOST 10
sets the start value for the request backoff to 10.

Manual operation: See "Request Backoff Start" on page 100

[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:ULMap:UCD:CID
<Cid>

Sets the value for the UCD CID.

Parameters:
<Cid> integer

Range: 0  to  #HFFFF
*RST: #HFFFF

Example: BB:WIM:AOFD:ZONE0:BURS2:ULM:UCD:CID #H456
enters the value for the UCD CID.

Manual operation: See "UCD CID OFDMA" on page 100

[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt<ch0>:ULMap:UCD:
STATe <State>

The command activates/deactivates that the UCD is appended to the UL-MAP. The
UCD message is transmitted with its own MAC header and CRC, included in the same
burst allocation used by the UL-MAP.

Parameters:
<State> 1 | ON | 0 | OFF

*RST: OFF

Example: BB:WIM:AOFD:ZONE0:BURS2:ULM:UCD:STAT ON
appends the DCD to the UL-Map.

Manual operation: See "Append UCD OFDMA" on page 100

[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:BURSt[:COUNt] <Count>

Sets the number of active bursts in the zone/segment).

Parameters:
<Count> integer

Range: 0  to  64
*RST: 1

Example: BB:WIM:AOFD:ZONE0:BURS2:COUN 2
two bursts are sent in one frame.
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Manual operation: See "No of Bursts OFDMA" on page 65

[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:DLMap:BSID <Bsid>

The command sets the 4 LSBs of the Base Station ID. Only the four least significant
bits are given. The BSID is transmitted in the FCH (when set to "Auto" mode), and it is
used to initialize the randomizer.

This command is available in downlink only and for DL-MAP Mode Auto
(BB:WIM:AOFD:ZONE0:DLM:MODE AUTO).

Parameters:
<Bsid> integer

Range: #H000000000000,48  to  #HFFFFFFFFFFFF,48
*RST: #H000000000000,48

Example: BB:WIM:AOFD:ZONE0:DLM:BSID 2
the base station id is 2.

Manual operation: See "Base Station ID OFDMA" on page 94

[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:DLMap:COMPressed:AMODe
<AMode>

Selects the Allocation Start Time base.

Parameters:
<AMode> DLSFend | FRAMestart

*RST: DLSFend

Example: BB:WIM:AOFD:ZONE0:DLM:COMP:AMOD DLSF
sets the start time base to DL Subframe End.

Manual operation: See "Allocation Start Timebase OFDMA" on page 95

[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:DLMap:COMPressed:ATIMe
<ATime>

The command sets the Allocation Start Time in the DL-Map.

Parameters:
<ATime> float

Range: 0  to  frame duration
Increment: 1E-6
*RST: 0
Default unit: s

Example: BB:WIM:AOFD:ZONE0:DLM:COMP:ATIM 2
sets the Allocation Start Time to 2 s.

Manual operation: See "Allocation Start Time OFDMA" on page 95
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[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:DLMap:COMPressed:STATe
<State>

The command activates/deactivates that a compressed map is generated instead of a
normal map.

Parameters:
<State> 1 | ON | 0 | OFF

*RST: OFF
Default unit: s

Example: BB:WIM:AOFD:ZONE0:DLM:COMP:STAT ON
generates a compressed map.

Manual operation: See "Compressed Map OFDMA" on page 95

[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:DLMap:COMPressed:ULMap:
DSELect <DSelect>

The command selects the UL-Map file.

Parameters:
<DSelect> string

Default unit: s

Example: BB:WIM:AOFD:ZONE0:DLM:COMP:ULM:DSEL
'ul-map_zone_1'
selects the UL-Map file ul-map_zone_1.

Manual operation: See "UL-MAP File OFDMA" on page 96

[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:DLMap:COMPressed:ULMap:
STATe <State>

The command activates/deactivates that a compressed UL-Map is appended to the
DL-Map.

Parameters:
<State> 1 | ON | 0 | OFF

*RST: OFF
Default unit: s

Example: BB:WIM:AOFD:ZONE0:DLM:COMP:ULM:STAT ON
appends the compressed map to the DL-Map.

Manual operation: See "Append Compressed UL-Map OFDMA" on page 95

[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:DLMap:DATA:DCD[:COUNt]
<Count>

The command sets the DCD Count. This value is used for the corresponding DL-MAP
field in Auto mode.
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This command is available in downlink only and for DL-MAP Mode Auto
(BB:WIM:AOFD:ZONE:DLM:MODE AUTO).

Parameters:
<Count> integer

Range: 0  to  255
*RST: 0

Example: BB:WIM:ZONE:AOFD:DLM:DCD 2
sets the DCD count to 2.

Manual operation: See "DCD Count DL-MAP OFDMA" on page 94

[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:DLMap:DCD:CID <Cid>

The command enters the value for the DCD CID. This CID (connection control identi-
fier) is independent from the DL-Map CID and is only used for the DCD message.

Parameters:
<Cid> integer

Range: 0  to  #HFFFF
*RST: #HFFFF
Default unit: s

Example: BB:WIM:AOFD:ZONE0:DLM:DCD:CID #H456
enters the value for the DCD CID.

Manual operation: See "DCD CID OFDMA" on page 95

[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:DLMap:DCD:STATe <State>

The command activates/deactivates that the DCD is appended to the DL-MAP. The
DCD message carries its own MAC header and CRC, but is included within the DL-
MAP burst.

Parameters:
<State> 1 | ON | 0 | OFF

*RST: OFF

Example: BB:WIM:AOFD:ZONE0:DLM:DCD:STAT ON
appends the DCD to the DL-Map.

Manual operation: See "Append DCD OFDMA" on page 94

[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:DLMap:FNOFfset <FnOffset>

Sets the frame number offset of the DL-MAP. This value is added to the current frame
number of the sequence. The result is used as Frame Number in the DL-MAP (in Auto
mode).
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Parameters:
<FnOffset> integer

Range: 0  to  16777215
*RST: 0

Example: BB:WIM:AOFD:ZONE0:DLM:FNOF 12
sets a frame number offset of 2 frames.

Manual operation: See "Frame Number Offset DL-MAP OFDMA" on page 94

[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:DLMap:IIE:STATe <State>

The command includes/excludes the CID-Switch_IE().

Parameters:
<State> 1 | ON | 0 | OFF

*RST: ON

Example: BB:WIM:AOFD:ZONE0:DLM:IIE:STAT ON
includes the CID-Switch_IE() to the DL-Map.

Manual operation: See "Include CID-Switch_IE() OFDMA" on page 94

[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:DLMap:MODE <Mode>

The command selects the mode for configuration of the DL map. Depending on this
setting, the above commands are available.

This command is available in downlink only.

Parameters:
<Mode> AUTO | USER

AUTO
The DL-MAP is filled automatically with parameters specified at
different locations.
USER
The DL-MAP is filled with data specified under Data Source.
This enables any arbitrary data to be sent with the DL-MAP
burst.
*RST: AUTO

Example: BB:WIM:AOFD:ZONE0:DLM:MODE AUTO
The DL-MAP is filled automatically.

Manual operation: See "DL-MAP Mode OFDMA" on page 92

[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:DLMap:REPCoding
<RepCoding>

The command activates/deactivates repetition coding. Setting RCO deactivates, all
other settings activate repetition coding.
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Parameters:
<RepCoding> RC0 | RC2 | RC4 | RC6

*RST: RC0

Example: BB:WIM:AOFD:ZONE0:DLM:REPC RC2
activates repetition coding.

Manual operation: See "DL-MAP Repetition Coding OFDMA" on page 94

[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:DLMap:SLOTcount?

Return values: 
<SlotCount> integer

Range: 0  to  INT_MAX
*RST: 0

Usage: Query only

[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:SCARrier:PERMutation
<Permutation>

Parameters:
<Permutation> FUSC | PUSC | AMC2X3 | SOUNding

*RST: PUSC

[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:SUBChannel:MODE <Mode>

The command determines if all or selected sets of subchannels are activated. The sets
of subchannel to be activated are selected with command
SOUR:BB:WIM:AOFD:ZONE0:SUBC2:MAP.

Parameters:
<Mode> USER | ALL

*RST: ALL

Example: BB:WIM:AOFD:ZONE0:SUBC:MODE USER
selects user mode for selecting the activated subchannels.
BB:WIM:AOFD:ZONE0:SUBC2:MAP ON
activates generation of set subchannels 20 to 31.

Manual operation: See "Use All Subchannels" on page 64

[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:SUBChannel:PATTern
<Pattern>, <BitCount>

In uplink, sets the 'allocated subchannel bitmap'.
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Parameters:
<Pattern> numeric

Range: #H0000 0000 0000 0000 00  to  #HFFFF FFFF
FFFF FFFF FF

*RST: #HFFFF FFFF FFFF FFFF 3F

<BitCount> integer
Range: 72  to  72
*RST: 72

Example: BB:WIM:AOFD:ZONE0:SUBC:PATT
#HFFFFFFFFFFFFFFFF3F,72

Manual operation: See "Allocated Subchannels Bitmap (uplink only)" on page 65

[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:SUBChannel:ROTation
<Rotation>

The command activates or deactivates the subchannel rotation.

This command is available for zone type PUSC in uplink only.

Parameters:
<Rotation> 1 | ON | 0 | OFF

*RST: ON

Example: SOUR:BB:WIM:AOFD:ZONE0:SUBC:ROT ON
activates the subchannel rotation.

Manual operation: See "Subchannel Rotation OFDMA" on page 63

[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:SUBChannel<ch>:MAP <Map>

The command activates /deactivates the selected set of subchannels. There are 6 sets
of subchannels available 0 = 0...5; 1 = 6...9; 2 =10-15; 3 = 16 - 19; 4 = 20 ...25; 5 =
26 ... 29).

This command is available only in uplink and for subchannel mode user
(BB:WIM:AOFD:ZONE0:SUBC:MODE USER).

Parameters:
<Map> 1 | ON | 0 | OFF

*RST: ON

Example: BB:WIM:AOFD:ZONE0:SUBC2:MAP ON
activates subchannel set 2 (i.e. subchannels 6 ... 9

Manual operation: See "Use Subchannels x...y (downlink PUSC only)" on page 64

[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:TYPE <Type>

The command queries the symbol offset of the zone.
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Parameters:
<Type> FUSC | PUSC | AMC2X3 | SOUNding

*RST: PUSC

Example: BB:WIM:AOFD:ZONE:SYMB:OFFS
queries the symbol count offset in zone 1.

Manual operation: See "Zone Type OFDMA" on page 60

[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:UCD <Ucd>

Sets the value for the UCD count.

Parameters:
<Ucd> integer

Range: 0  to  255
*RST: 0

Example: BB:WIM:AOFD:ZONE0:UCD 255
sets the value for the UCD count to 255.

Manual operation: See "UCD Count OFDMA" on page 101

[:SOURce<hw>]:BB:WIMax:AOFDm[:ZONE<st0>]:ULMap:CREate <Filename>

The command saves the current UL-map. The default directory is set using command
MMEM:CDIRectory. A path can also be specified, in which case the UL-map files in
the specified directory are read. The files are stored with the extension *.dm_iqd.

This command is available in uplink only.

Setting parameters: 
<Filename> string

Example: BB:WIM:AOFD:ZONE1:ULM:CRE 'ul-map_zone1'
Save the current UL-map to the file ul-map_zone1

Usage: Setting only

Manual operation: See "Save UL-MAP Data OFDMA" on page 102

4.7  OFDM physical layer commands

The SOURce:BB:WIMax:OFDM system contains commands for setting the characteris-
tics of signals with OFDM physical layer.

The commands of this system only take effect if the OFDM physical layer mode is
selected:
● SOURce:BB:WIMax:MODE OFDM
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In case of remote control, suffix counting for bursts corresponds to the suffix counting
with WiMAX starting with burst 0. SCPI prescribes that suffix 1 is the default state and
used when no specific suffix is specified. Therefore, burst 1 (and not burst 0) is
selected when no suffix is specified.

[:SOURce<hw>]:BB:WIMax:OFDM:BSID..........................................................................215
[:SOURce<hw>]:BB:WIMax:OFDM:BURSt<ch0>:CCODing:STATe......................................215
[:SOURce<hw>]:BB:WIMax:OFDM:BURSt<ch0>:DATA..................................................... 215
[:SOURce<hw>]:BB:WIMax:OFDM:BURSt<ch0>:DATA:DSELect........................................216
[:SOURce<hw>]:BB:WIMax:OFDM:BURSt<ch0>:DATA:PATTern........................................ 216
[:SOURce<hw>]:BB:WIMax:OFDM:BURSt<ch0>:DIUC......................................................217
[:SOURce<hw>]:BB:WIMax:OFDM:BURSt<ch0>:DLENgth................................................ 217
[:SOURce<hw>]:BB:WIMax:OFDM:BURSt<ch0>:DLMap:AMODe.......................................217
[:SOURce<hw>]:BB:WIMax:OFDM:BURSt<ch0>:DLMap:ATIMe.........................................217
[:SOURce<hw>]:BB:WIMax:OFDM:BURSt<ch0>:DLMap:DCD:STATe................................. 218
[:SOURce<hw>]:BB:WIMax:OFDM:BURSt<ch0>:DLMap:UCD:STATe................................. 218
[:SOURce<hw>]:BB:WIMax:OFDM:BURSt<ch0>:DLMap:ULM:STATe................................. 218
[:SOURce<hw>]:BB:WIMax:OFDM:BURSt<ch0>:FORMat................................................. 219
[:SOURce<hw>]:BB:WIMax:OFDM:BURSt<ch0>:GAP.......................................................219
[:SOURce<hw>]:BB:WIMax:OFDM:BURSt<ch0>:MAC:CID................................................219
[:SOURce<hw>]:BB:WIMax:OFDM:BURSt<ch0>:MAC:CRC:STATe.................................... 220
[:SOURce<hw>]:BB:WIMax:OFDM:BURSt<ch0>:MAC:EKS...............................................220
[:SOURce<hw>]:BB:WIMax:OFDM:BURSt<ch0>:MAC:ENCRypted:STATe.......................... 220
[:SOURce<hw>]:BB:WIMax:OFDM:BURSt<ch0>:MAC:STATe............................................ 220
[:SOURce<hw>]:BB:WIMax:OFDM:BURSt<ch0>:MAC:TYPE.............................................221
[:SOURce<hw>]:BB:WIMax:OFDM:BURSt<ch0>:MIDamble...............................................221
[:SOURce<hw>]:BB:WIMax:OFDM:BURSt<ch0>:MODE....................................................221
[:SOURce<hw>]:BB:WIMax:OFDM:BURSt<ch0>:POWer...................................................221
[:SOURce<hw>]:BB:WIMax:OFDM:BURSt<ch0>:PREamble:MODE................................... 222
[:SOURce<hw>]:BB:WIMax:OFDM:BURSt<ch0>:SYMBol[:COUNt].....................................222
[:SOURce<hw>]:BB:WIMax:OFDM:BURSt<ch0>:TYPE..................................................... 222
[:SOURce<hw>]:BB:WIMax:OFDM:BURSt<ch0>:UIUC......................................................223
[:SOURce<hw>]:BB:WIMax:OFDM:BURSt<ch0>:ULMap:AMODe.......................................223
[:SOURce<hw>]:BB:WIMax:OFDM:BURSt<ch0>:ULMap:ATIMe.........................................223
[:SOURce<hw>]:BB:WIMax:OFDM:BURSt[:COUNt].......................................................... 224
[:SOURce<hw>]:BB:WIMax:OFDM:BW............................................................................ 224
[:SOURce<hw>]:BB:WIMax:OFDM:FBANd.......................................................................224
[:SOURce<hw>]:BB:WIMax:OFDM:FCH:CCC...................................................................225
[:SOURce<hw>]:BB:WIMax:OFDM:FCH:DATA..................................................................225
[:SOURce<hw>]:BB:WIMax:OFDM:FCH:DATA:DSELect....................................................225
[:SOURce<hw>]:BB:WIMax:OFDM:FCH:DATA:PATTern.....................................................226
[:SOURce<hw>]:BB:WIMax:OFDM:FCH:FNOFfset............................................................226
[:SOURce<hw>]:BB:WIMax:OFDM:FCH:MODE................................................................ 227
[:SOURce<hw>]:BB:WIMax:OFDM:FCH:STATe.................................................................227
[:SOURce<hw>]:BB:WIMax:OFDM:FFT?..........................................................................227
[:SOURce<hw>]:BB:WIMax:OFDM:FRAMe:PREDefined....................................................228
[:SOURce<hw>]:BB:WIMax:OFDM:FRAMe[:NUMBer]....................................................... 228
[:SOURce<hw>]:BB:WIMax:OFDM:N?............................................................................. 229
[:SOURce<hw>]:BB:WIMax:OFDM:POWer:REFerence..................................................... 229
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[:SOURce<hw>]:BB:WIMax:OFDM:PREamble:MODE....................................................... 229
[:SOURce<hw>]:BB:WIMax:OFDM:SRATe....................................................................... 230
[:SOURce<hw>]:BB:WIMax:OFDM:SUBChannel:INDex.....................................................230
[:SOURce<hw>]:BB:WIMax:OFDM:SUBChannel[:COUNt]................................................. 231
[:SOURce<hw>]:BB:WIMax:OFDM:TGTB.........................................................................231
[:SOURce<hw>]:BB:WIMax:OFDM:UCD.......................................................................... 231
[:SOURce<hw>]:BB:WIMax:OFDM:ULMap:CREate...........................................................232

[:SOURce<hw>]:BB:WIMax:OFDM:BSID <Bsid>

Sets the 4 LSBs of the Base Station ID. Only the four least significant bits are given.
The BSID is transmitted in the FCH (when set to Auto mode), and it is used to initialize
the randomizer.

Parameters:
<Bsid> integer

Range: 0  to  15
*RST: 0

Example: BB:WIM:OFDM:BSID 2
the base station id is 2.

Manual operation: See "BSID OFDM" on page 36

[:SOURce<hw>]:BB:WIMax:OFDM:BURSt<ch0>:CCODing:STATe <State>

The command switches channel coding on or off. If channel coding is switched off, the
bits read from the data source are directly modulated onto the carriers. Due to random-
ization missing, this could result in high crest factors of the signal.

Parameters:
<State> 1 | ON | 0 | OFF

*RST: ON

Example: BB:WIM:OFDM:BURS:CCOD:STAT ON
Activates channel coding for burst 1.

Manual operation: See "Channel Coding OFDM" on page 38

[:SOURce<hw>]:BB:WIMax:OFDM:BURSt<ch0>:DATA <Data>

The command determines the data source for the specified bursts.

Parameters:
<Data> PN9 | PN11 | PN15 | PN16 | PN20 | PN21 | PN23 | DLISt |

ZERO | ONE | PATTern
PNxx
The pseudo-random sequence generator is used as the data
source. Different random sequence lengths can be selected.
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DLISt
A data list is used. The data list is selected with the com-
mand :BB:WIMax:OFDM:BURS:DATA:DSELect.
ZERO | ONE
Internal 0 and 1 data is used.
PATTern
Internal data is used. The bit pattern for the data is defined by
the command :BB:WIMax:OFDM:BURS:DATA:PATTern.
*RST: PN9

Example: BB:WIM:OFDM:BURS:DATA PATT
Selects as the data source for the data fields of burst 1, the bit
pattern defined with the following command.
BB:WIM:OFDM:BURS:DATA:PATT #H3F,8
Defines the bit pattern.

Manual operation: See "Data Source OFDM" on page 39
See "Data List Management…" on page 66

[:SOURce<hw>]:BB:WIMax:OFDM:BURSt<ch0>:DATA:DSELect <DSelect>

The command selects the data list for the DLISt data source selection.

The lists are stored as files with the fixed file extensions *.dm_iqd in a directory of the
user's choice. The directory applicable to the following commands is defined with the
command MMEMory:CDIR. To access the files in this directory, you only have to give
the file name, without the path and the file extension.

Parameters:
<DSelect> string

Example: BB:WIM:OFDM:BURS:DATA DLIS
selects the Data Lists data source.
MMEM:CDIR "/var/user/temp/Lists"
selects the directory for the data lists.
BB:WIM:OFDM:BURS:DATA:DLIS "wimax_list1"
selects file wimax_list1 as the data source. This file must be
in the directory and must have the file extension *.dm_iqd.

Manual operation: See "Data Source OFDM" on page 39
See "Data List Management…" on page 66

[:SOURce<hw>]:BB:WIMax:OFDM:BURSt<ch0>:DATA:PATTern <Pattern>,
<BitCount>

Sets the bit pattern.

Parameters:
<Pattern> numeric

*RST: #B0

OFDM physical layer commands



Remote-control commandsR&S®SMW-K49

217User Manual 1175.6732.02 ─ 19

<BitCount> integer
Range: 1  to  64
*RST: 1

Example: BB:WIM:OFDM:BURS:DATA:PATT #H3F,8
Manual operation: See "Data Source OFDM" on page 39

[:SOURce<hw>]:BB:WIMax:OFDM:BURSt<ch0>:DIUC <Diuc>

Sets the specific interval usage code.

Parameters:
<Diuc> integer

Range: 0  to  15
*RST: 0

Example: BB:WIM:OFDM:BURS2:DIUC 12
sets Interval Usage Code12 for burst 2.

Manual operation: See "DIUC OFDM" on page 40

[:SOURce<hw>]:BB:WIMax:OFDM:BURSt<ch0>:DLENgth <DLength>

The command sets the data length in bytes.

Parameters:
<DLength> integer

Range: 0  to  3E4
*RST: 100

Example: BB:WIM:OFDM:BURS:DLEN 256
sets a data length of 256.

Manual operation: See "Data Length OFDM" on page 39

[:SOURce<hw>]:BB:WIMax:OFDM:BURSt<ch0>:DLMap:AMODe <AMode>

Selects the Allocation Start Time base.

Parameters:
<AMode> DLSFend | FRAMestart

*RST: DLSFend

Example: BB:WIM:OFDM:BURS1:DLM:AMOD DLSF
sets the start time base to DL Subframe End.

Manual operation: See "Allocation Start Timebase OFDM" on page 50

[:SOURce<hw>]:BB:WIMax:OFDM:BURSt<ch0>:DLMap:ATIMe <ATime>

Sets the Allocation Start Time in the DL-Map.
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Parameters:
<ATime> float

Range: 0  to  dynamic
Increment: 1E-6
*RST: 0

Example: BB:WIM:OFDM:BURS1:DLM:ATIM 2
sets the Allocation Start Time to 2 s.

Manual operation: See "Allocation Start Time OFDM" on page 50

[:SOURce<hw>]:BB:WIMax:OFDM:BURSt<ch0>:DLMap:DCD:STATe <State>

The command activates/deactivates that the DCD is appended to the DL-MAP. The
DCD message carries its own MAC header and CRC, but is included within the DL-
MAP burst.

Parameters:
<State> 1 | ON | 0 | OFF

*RST: OFF

Example: BB:WIM:OFDM:BURS1:DLM:DCD:STAT ON
appends the DCD to the DL-Map.

Manual operation: See "Append DCD OFDM" on page 49

[:SOURce<hw>]:BB:WIMax:OFDM:BURSt<ch0>:DLMap:UCD:STATe <State>

The command activates/deactivates that the UCD is appended to the DL-MAP. The
UCD message is transmitted with its own MAC header and CRC, included in the same
burst allocation used by the DL-MAP.

Parameters:
<State> 1 | ON | 0 | OFF

*RST: OFF

Example: BB:WIM:OFDM:BURS2:DLM:UCD:STAT ON
appends the UCD to the DL-Map.

Manual operation: See "Append UCD OFDM" on page 50

[:SOURce<hw>]:BB:WIMax:OFDM:BURSt<ch0>:DLMap:ULM:STATe <State>

The command activates/deactivates that a UL-Map is appended to the DL-Map.

Parameters:
<State> 1 | ON | 0 | OFF

*RST: OFF

Example: BB:WIM:OFDM:BURS1:DLM:ULM:STAT ON
appends the UL-Map to the DL-Map.

Manual operation: See "Append UL-Map OFDM" on page 49
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[:SOURce<hw>]:BB:WIMax:OFDM:BURSt<ch0>:FORMat <Format>

Selects the modulation and channel coding rate. Channel coding includes randomiza-
tion, Reed-Solomon coding, convolutional coding and interleaving.

For a given modulation type and channel coding rate, the data length determines the
number of symbols and vice versa.

Parameters:
<Format> BPSK1D2 | QPSK1D2 | QPSK3D4 | QAM1D2X16 |

QAM3D4X16 | QAM2D3X64 | QAM3D4X64
*RST: QPSK3D4

Example: BB:WIM:OFDM:BURS:FORM QAM3D4X64
Selects modulation type 64QAM and a channel coding rate of
3.4 Msample for burst 1.

Manual operation: See "Modulation and RS-CC Rate OFDM" on page 38

[:SOURce<hw>]:BB:WIMax:OFDM:BURSt<ch0>:GAP <Gap>

The command sets the length of the gap between the selected burst and the next burst
in µs. The setting is only available for transmission direction uplink.

Parameters:
<Gap> float

Range: 0 µs  to  1 000 000 µs
Increment: 1 µs
*RST: 1000 µs
Default unit: s

Example: BB:WIM:LINK UP
Sets transmission direction uplink.
BB:WIM:OFDM:BURS2:GAP 0.003
Sets the gap between burst 2 ms and 3 ms to 3 ms.

Manual operation: See "Gap OFDM" on page 41

[:SOURce<hw>]:BB:WIMax:OFDM:BURSt<ch0>:MAC:CID <Cid>

Sets the CID (connection control identifier) of the medium access control layer (MAC).

Parameters:
<Cid> integer

Range: 0  to  #HFFFF
*RST: 0

Example: BB:WIM:OFDM:BURS2:MAC:CID #HE7
sets the CID for burst 2 to 231.

Manual operation: See "MAC CID" on page 53
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[:SOURce<hw>]:BB:WIMax:OFDM:BURSt<ch0>:MAC:CRC:STATe <State>

The command activates/deactivates the checksum determination. The state of the
CRC can be set independently of the state of MAC header generation.

Parameters:
<State> 1 | ON | 0 | OFF

*RST: OFF

Example: BB:WIM:OFDM:BURS2:MAC:CRC:STAT ON
activates the checksum determination for burst 2.

Manual operation: See "CRC State" on page 54

[:SOURce<hw>]:BB:WIMax:OFDM:BURSt<ch0>:MAC:EKS <Eks>

Sets the EKS (encryption key sequence) value in the MAC header. The payload
encryption itself is not performed by the signal generator.

Parameters:
<Eks> integer

Range: 0  to  3
*RST: 0

Example: BB:WIM:OFDM:BURS2:MAC:ENCR:STAT ON
enables payload encryption.
BB:WIM:OFDM:BURS2:MAC:EKS 2
sets the EKS for burst 2.

Manual operation: See "EKS" on page 55

[:SOURce<hw>]:BB:WIMax:OFDM:BURSt<ch0>:MAC:ENCRypted:STATe <State>

The command activates/disactivates payload encryption. If activated, the EC (Encryp-
tion Control) field is set to 1 and the EKS (Encryption Key Sequence) field can be set.

Parameters:
<State> 1 | ON | 0 | OFF

*RST: OFF

Example: BB:WIM:OFDM:BURS2:MAC:ENCR:STAT ON
enables payload encryption for burst 2.
BB:WIM:OFDM:BURS2:MAC:EKS 2
sets the EKS.

Manual operation: See "Payload encrypted" on page 55

[:SOURce<hw>]:BB:WIMax:OFDM:BURSt<ch0>:MAC:STATe <State>

The command enables/disables generation of the generic MAC header for the selected
burst.
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Parameters:
<State> 1 | ON | 0 | OFF

*RST: OFF

Example: BB:WIM:OFDM:BURS2:MAC:STAT ON
enables generation of the generic MAC header for burst 2.

Manual operation: See "MAC Header State" on page 55

[:SOURce<hw>]:BB:WIMax:OFDM:BURSt<ch0>:MAC:TYPE <Type>

Specifies the MAC type.

Parameters:
<Type> integer

Range: 0  to  #H3F
*RST: 0

Example: BB:WIM:OFDM:BURS2:MAC:TYPE #H3F
sets the type field of the MAC header of burst 2.

Manual operation: See "Mac Type" on page 55

[:SOURce<hw>]:BB:WIMax:OFDM:BURSt<ch0>:MIDamble <MidAmble>

Activates/deactivates midamble repetition.

Parameters:
<MidAmble> OFF | REP5 | REP9 | REP17

*RST: OFF

Example: BB:WIM:LINK UP
selects transmission direction uplink.
BB:WIM:OFDM:BURS2:MID REP9
the midamble is repeated each 9th symbol of burst 2.

Manual operation: See "Midamble Repetition OFDM" on page 38

[:SOURce<hw>]:BB:WIMax:OFDM:BURSt<ch0>:MODE <Mode>

Parameters:
<Mode> NORM | DLMap | ULMap

*RST: NORM

[:SOURce<hw>]:BB:WIMax:OFDM:BURSt<ch0>:POWer <Power>

The command sets the power for the selected burst in dB. To set the absolute power of
a burst correctly, level reference FCH / Burst must be selected. In this mode, the output
power of a burst equals Level + BurstPower.

In downlink, the preamble is transmitted with +3 dB and the FCH is transmitted with
0dB.
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In uplink, the power of the first burst is fixed to 0dB.

Parameters:
<Power> float

Range: -80.0 dB  to  10.0 dB
Increment: 0.01 dB
*RST: 0.0 dB

Example: BB:WIM:OFDM:BURS2:POW -2 dB
sets the burst power to -2 dB.

Manual operation: See "Boost OFDM" on page 40

[:SOURce<hw>]:BB:WIMax:OFDM:BURSt<ch0>:PREamble:MODE <Mode>

The command enables/disables generation of the preamble for the selected burst and
selects the mode for generating the preamble. Either a long preamble or a short pre-
amble can be activated.

The 802.16 standard requires a long preamble as frame start.

Parameters:
<Mode> OFF | LONG | SHORt

*RST: OFF

Example: BB:WIM:OFDM:BURS2:PRE:MODE LONG
enables generation of the long preamble for burst 2.

Manual operation: See "Preamble OFDM" on page 38

[:SOURce<hw>]:BB:WIMax:OFDM:BURSt<ch0>:SYMBol[:COUNt] <Count>

Sets the number of symbols for the selected burst.

Parameters:
<Count> integer

Range: 1  to  1E9
*RST: 3

Example: BB:WIM:OFDM:BURS2:SYMB:COUN 12
sets 12 symbols for burst 2.

Manual operation: See "Number of Symbols OFDM" on page 39

[:SOURce<hw>]:BB:WIMax:OFDM:BURSt<ch0>:TYPE <Type>

The command selects the burst type.

Available burst types for downlink: DATA | ULMap | DLMap

Available burst types for uplink: DATA | RANGing
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Parameters:
<Type> DLMap | ULMap | RANGing | DATA

*RST: DATA

Example: BB:WIM:OFDM:BURS2:TYPE DATA
selects burst type DATA.

Manual operation: See "Burst Type OFDM" on page 40

[:SOURce<hw>]:BB:WIMax:OFDM:BURSt<ch0>:UIUC <Uiuc>

Sets uplink interval usage code.

Parameters:
<Uiuc> integer

Range: 0  to  15
*RST: 0

Example: BB:WIM:OFDM:BURS2:UIUC 2
sets uplink interval usage code 2.

Manual operation: See "UIUC OFDM" on page 53

[:SOURce<hw>]:BB:WIMax:OFDM:BURSt<ch0>:ULMap:AMODe <Amode>

The command sets the UL-MAP Allocation Start Time Base. The start time is set either
relative to the DL subframe end (DLSFend) or the frame start (FRAMestart).

This command is available for link direction downlink only.

Parameters:
<Amode> DLSFend | FRAMestart

*RST: 0

Example: BB:WIM:OFDM:BURS2:ULM:AMOD DLSF
sets the start time base to DL Subframe End.

Manual operation: See "Allocation Start Timebase" on page 51

[:SOURce<hw>]:BB:WIMax:OFDM:BURSt<ch0>:ULMap:ATIMe <ATime>

Sets the UL-MAP Allocation Start Time.

This command is available for link direction downlink only.

Parameters:
<ATime> float

Range: 0  to  max
Increment: 1E-6
*RST: 0

Example: BB:WIM:OFDM:BURS2:ULM:ATIM 4
sets the allocation start time to 2.
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Manual operation: See "Allocation Start Time" on page 51

[:SOURce<hw>]:BB:WIMax:OFDM:BURSt[:COUNt] <Count>

Sets the number of active bursts in one frame. With number of bursts = 0, a preamble
only or a preamble with an FCH burst is generated.

Parameters:
<Count> integer

Range: 0  to  64
*RST: 1

Example: BB:WIM:OFDM:BURS:COUN 2
two bursts are sent in one frame.

Manual operation: See "No. of Bursts OFDM" on page 36

[:SOURce<hw>]:BB:WIMax:OFDM:BW <Bw>

Sets the channel bandwidth.

Parameters:
<Bw> float

See [:SOURce<hw>]:BB:WIMax:AOFDm:BW on page 155
Range: 1.25E6  to  28E6
Increment: 0.05E6
*RST: 1.75E6

Example: BB:WIM:OFDM:FBAN ETSI
selects frequency band according to ETSI specifications.
BB:WIM:OFDM:BW 7E6
sets the channel bandwidth to 7 MHz.

Manual operation: See "Channel Bandwidth OFDM" on page 35

[:SOURce<hw>]:BB:WIMax:OFDM:FBANd <FBand>

Selects the available frequency band for the carrier frequencies.

Parameters:
<FBand> ETSI | MMDS | WCS | UNII | USER

see [:SOURce<hw>]:BB:WIMax:AOFDm:FBANd on page 156
*RST: ETSI

Example: BB:WIM:OFDM:FBAN ETSI
selects frequency band according to ETSI specifications.

Manual operation: See "Frequency Band OFDM" on page 34
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[:SOURce<hw>]:BB:WIMax:OFDM:FCH:CCC <Ccc>

Sets the configuration change count value. This value is used for the corresponding
FCH field in "Auto" mode (SOURce:BB:WIMax:OFDM:FCH:MODE AUTO).

Parameters:
<Ccc> integer

Range: 0  to  255
*RST: 0

Example: BB:WIM:OFDM:FCH:CCC 4
sets configuration change count value to 4.

Manual operation: See "Configuration Change Count" on page 45

[:SOURce<hw>]:BB:WIMax:OFDM:FCH:DATA <Data>

The command specifies the data source in "User" mode
(SOURce:BB:WIMax:OFDM:FCH:MODE AUTO). The FCH contents are filled from the
selected data source.

Parameters:
<Data> PN9 | PN11 | PN15 | PN16 | PN20 | PN21 | PN23 | DLISt |

ZERO | ONE | PATTern
PNxx
The pseudo-random sequence generator is used as the data
source. Different random sequence lengths can be selected.
DLISt
A data list is used. The data list is selected with the com-
mand :BB:WIMax:OFDM:FCH:DATA:DSELect.
ZERO | ONE
Internal 0 and 1 data is used.
PATTern
Internal data is used. The bit pattern for the data is defined by
the command :BB:WIMax:OFDM:FCH:DATA:PATTern.
*RST: PN9

Example: BB:WIM:OFDM:FCH:DATA PATT
Selects as the data source for the data fields of FCH, the bit pat-
tern defined with the following command.
BB:WIM:OFDM:FCH:DATA:PATT #H3F,8
Defines the bit pattern.

Manual operation: See "Data Source" on page 46
See "Data List Management…" on page 66

[:SOURce<hw>]:BB:WIMax:OFDM:FCH:DATA:DSELect <DSelect>

The command selects the data list for the DLISt data source selection.
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The lists are stored as files with the fixed file extensions *.dm_iqd in a directory of the
user's choice. The directory applicable to the following commands is defined with the
command MMEMory:CDIR. To access the files in this directory, you only have to give
the file name, without the path and the file extension.

This command is available only in "User" mode
(SOURce:BB:WIMax:OFDM:FCH:MODE AUTO).

Parameters:
<DSelect> string

Example: BB:WIM:OFDM:FCH:DATA DLIS
selects the Data Lists data source.
MMEM:CDIR "/var/user/temp/Lists"
selects the directory for the data lists.
BB:WIM:OFDM:FCH:DATA:DLIS "wimax_list1"
selects file wimax_list1 as the data source. This file must be in
the directory and must have the file extension *.dm_iqd.

Manual operation: See "Data Source" on page 46
See "Data List Management…" on page 66

[:SOURce<hw>]:BB:WIMax:OFDM:FCH:DATA:PATTern <Pattern>, <BitCount>

Sets the bit pattern.

Parameters:
<Pattern> numeric

*RST: #B0

<BitCount> integer
Range: 1  to  64
*RST: 1

Example: SOURce:BB:WIMax:OFDM:FCH:MODE AUTO
BB:WIM:OFDM:BURS:DATA:PATT #H3F,8

Manual operation: See "Data Source" on page 46

[:SOURce<hw>]:BB:WIMax:OFDM:FCH:FNOFfset <FnOffset>

Sets the frame number offset. This value is added to the current frame number of the
sequence. After modulo 16 division, the result is used as Frame_Number in the FCH
(in Auto mode) and is also used to initialize the randomizers.

Parameters:
<FnOffset> integer

Range: 0  to  15
*RST: 0

Example: BB:WIM:OFDM:FCH:FNOF 4
sets a frame number offset of 4.
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Manual operation: See "Frame Number Offset" on page 45

[:SOURce<hw>]:BB:WIMax:OFDM:FCH:MODE <Mode>

Selects the mode for generating the FCH.

Parameters:
<Mode> AUTO | USER

AUTO
The DLFP fields, which form the FCH, are filled automatically
with parameters specified at different locations.
USER
The FCH is filled with data specified under Data Source. This
enables any arbitrary data to be sent with the FCH burst.
*RST: AUTO

Example: BB:WIM:OFDM:FCH:MODE AUTO
Selects FCH mode AUTO.

Manual operation: See "FCH Mode" on page 44

[:SOURce<hw>]:BB:WIMax:OFDM:FCH:STATe <State>

The command switches the FCH on or off.

Parameters:
<State> 1 | ON | 0 | OFF

*RST: ON

Example: BB:WIM:OFDM:FCH:STAT OFF
switches off generation of FCH.

Manual operation: See "FCH State" on page 44

[:SOURce<hw>]:BB:WIMax:OFDM:FFT?

The command queries the size of the fast fourier transform. For OFDM channels, the
size is fixed to 256. For OFDMA configuration, the possible configurations of the sub-
channel map depend on the selected FFT size.

Return values: 
<Fft> FFT256

*RST: OFDMA FFT2048; OFDM: FFT256

Example: BB:WIM:OFDM:FFT
queries the FFT size.
Response: FFT256
the FFT size is 256.

Usage: Query only
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[:SOURce<hw>]:BB:WIMax:OFDM:FRAMe:PREDefined <Predefined>

The command selects predefined setting for the frames.

All commands concerning the frame configuration are preset

Parameters:
<Predefined> USER | FBPSK12SHORT | FBPSK12MID | FBPSK12LONG |

FQPSK12SHORT | FQPSK12MID | FQPSK12LONG |
FQPSK34SHORT | FQPSK34MID | FQPSK34LONG |
F16QAM12SHORT | F16QAM12MID | F16QAM12LONG |
F16QAM34SHORT | F16QAM34MID | F16QAM34LONG |
F64QAM23SHORT | F64QAM23MID | F64QAM23LONG |
F64QAM34SHORT | F64QAM34MID | F64QAM34LONG
USER
The settings for the frame can be defined by the user.
F...
Predefined settings for receiver testing are selected. The param-
eter includes the modulation, the channel coding rate and the
test message type (long, short or middle). See IEEE
802.16-2004, section 8.3.11 for details.
*RST: USER

Example: BB:WIM:LINK UP
selects transmission direction uplink.
BB:WIM:OFDM:FRAM:PRED FBPSK12LONG
selects predefined settings with BPSK modulation, channel cod-
ing 1 / 2 and long test message.

Manual operation: See "Predefined Frames" on page 32

[:SOURce<hw>]:BB:WIMax:OFDM:FRAMe[:NUMBer] <Number>

Selects the frame number of the uplink frame in which the UL map that specifies the
uplink burst was transmitted.

This command is available in uplink only.

Parameters:
<Number> integer

Range: 0  to  15
*RST: 0

Example: BB:WIM:LINK UP
selects transmission direction uplink.
BB:WIM:MODE OFDM
selects OFDM physical layer mode.
BB:WIM:OFDM:FRAM 15
selects frame number 15.

Manual operation: See "Frame Number OFDM" on page 37
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[:SOURce<hw>]:BB:WIMax:OFDM:N?

The command queries the factor n (sampling ratio). The sampling ratio is determined
by the channel bandwidth (see parameter "Channel Bandwidth").

Return values: 
<N> N8D7 | N86D75 | N144D125 | N316D275 | N57D50 | N28D25

*RST: N8D7

Example: BB:WIM:OFDM:N
queries the factor n.
Response: "N8D7"
the factor n is 8/7.

Usage: Query only

Manual operation: See "Sampling Ratio n OFDM" on page 35

[:SOURce<hw>]:BB:WIMax:OFDM:POWer:REFerence <Reference>

The command selects the level reference.

Parameters:
<Reference> BURSt | PREamble

BURSt
The instrument's level setting refers to the mean power of FCH
or bursts with a burst power setting of 0 dB. To obtain the abso-
lute burst power value, the burst power value has to be added to
the level value.
PREamble
The instrument's level setting refers to the preamble, which is
FCH / Burst power + 3dB.
*RST: BURSt

Example: BB:WIM:OFDM:POW:REF BURS
the instruments level setting refers to the mean power of FCH or
bursts with a burst power setting of 0 dB.

Manual operation: See "Power Reference" on page 32

[:SOURce<hw>]:BB:WIMax:OFDM:PREamble:MODE <Mode>

The command activates/deactivates the generation of a frame preamble. Either a long
preamble or a short preamble can be activated. The 802.16 standard requires a long
preamble as frame start in the downlink.

Parameters:
<Mode> OFF | LONG | SHORt

*RST: LONG

Example: BB:WIM:OFDM:PRE:MODE SHOR
enables generation of a short preamble for the frame.
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Manual operation: See "Frame Preamble OFDM" on page 36

[:SOURce<hw>]:BB:WIMax:OFDM:SRATe <SRate>

The command sets the sampling rate. The sampling rate is related to the channel
bandwidth by the parameter n:

SamplingRate = floor (n * ChannelBandwidth / 8000) * 8000

Downlink:

The value range depends on the selected frequency band (command [:
SOURce<hw>]:BB:WIMax:OFDM:FBANd). Only discrete sets of values are available.
If a new value is not allowed, the next allowed value in the direction of change is set.

Uplink:

The full range between 1.44 MHz and 32 MHz is available. Only discrete sets of values
are available. If a new value is not allowed, the next allowed value in the direction of
change is set.

Example:

16 MHz and 32 MHz are allowed, the current value is 16 MHz. If a new value of 17
MHz is entered, it is changed to 32 MHz.

Parameters:
<SRate> float

Range: 1.44E6  to  32E6
Increment: 0.001E6
*RST: 2E6

Example: BB:WIM:OFDM:SRAT 2E6
Sets a sampling rate of 2 MHz.

Manual operation: See "Sampling Rate OFDM" on page 35

[:SOURce<hw>]:BB:WIMax:OFDM:SUBChannel:INDex <Index>

The command selects the subchannel index in subchannelization mode. The subchan-
nel index determines the set of used subcarriers according to table 213 of IEEE
802.16-2004 standard.

Parameters:
<Index> SUBC1 | SUBC2 | SUBC3 | SUBC4 | SUBC5 | SUBC6 |

SUBC7 | SUBC8 | SUBC9 | SUBC10 | SUBC11 | SUBC12 |
SUBC13 | SUBC14 | SUBC15 | SUBC16 | SUBC17 | SUBC18 |
SUBC19 | SUBC20 | SUBC21 | SUBC22 | SUBC23 | SUBC24 |
SUBC25 | SUBC26 | SUBC27 | SUBC28 | SUBC29 | SUBC30 |
SUBC31
*RST: SUBC16

Example: BB:WIM:OFDM:SUBC:IND SUBC4
selects subchannel set 4 to be used.
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Manual operation: See "Subchannel Index OFDM" on page 36

[:SOURce<hw>]:BB:WIMax:OFDM:SUBChannel[:COUNt] <Count>

The command selects the number of subchannels for OFDM configurations.

Selection 16 (all) deactivates subchannelization and activates all possible carriers. The
values 1, 2, 4 and 8 activate only a part of the available subcarriers, unused carriers
are blanked.

Parameters:
<Count> SC1 | SC2 | SC4 | SC8 | SC16

*RST: SC16

Example: BB:WIM:OFDM:SUBC:COUN SC4
Selects four subchannels to be used.

Manual operation: See "No. of Used Subchannels OFDM" on page 36

[:SOURce<hw>]:BB:WIMax:OFDM:TGTB <Tgtb>

The command selects the ratio of guard period to symbol period. This value sets the
length of the cyclic prefix in fractions of the symbol period.

Parameters:
<Tgtb> TGTB1D4 | TGTB1D8 | TGTB1D16 | TGTB1D32

*RST: TGTB1D4

Example: BB:WIM:OFDM:TGTB TGTB1D8
sets a ratio of 1 to 8.

Manual operation: See "Tg/Tb Ratio OFDM" on page 36

[:SOURce<hw>]:BB:WIMax:OFDM:UCD <Ucd>

Sets the value for the UCD count.

This command is available in uplink only.

Parameters:
<Ucd> integer

Range: 0  to  255
*RST: 0

Example: BB:WIM:OFDM:UCD 255
sets the value for the UCD count to 255.

Manual operation: See "UCD Count OFDM" on page 47
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[:SOURce<hw>]:BB:WIMax:OFDM:ULMap:CREate <Filename>

The command saves the current UL-map.The default directory is set using command
MMEM:CDIRectory. A path can also be specified, in which case the UL-map files in
the specified directory are read. The files are stored with the extension *.dm_iqd.

This command is available in uplink only.

Setting parameters: 
<Filename> string

Example: BB:WIM:OFDM:ULM:CRE 'ul-map_zone1'
Saves the current UL-map to the file ul-map_zone1.

Usage: Setting only

Manual operation: See "Save UL-MAP Data OFDM" on page 47
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