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1  Safety and regulatory information
The product documentation helps you use the product safely and efficiently. Fol-
low the instructions provided here and in the following chapters.

Intended use

The product is intended for the development, production and verification of elec-
tronic components and devices in industrial, administrative, and laboratory envi-
ronments. Use the product only for its designated purpose. Observe the operating
conditions and performance limits stated in the data sheet.

Where do I find safety information?

Safety information is part of the product documentation. It warns you of potential
dangers and gives instructions on how to prevent personal injury or damage
caused by dangerous situations. Safety information is provided as follows:
● In Chapter 1.1, "Safety instructions", on page 5. The same information is

provided in many languages as printed "Safety Instructions". The printed
"Safety Instructions" are delivered with the product.

● Throughout the documentation, safety instructions are provided when you
need to take care during setup or operation.

1.1  Safety instructions

Products from the Rohde & Schwarz group of companies are manufactured
according to the highest technical standards. To use the products safely, follow
the instructions provided here and in the product documentation. Keep the prod-
uct documentation nearby and offer it to other users.

Use the product only for its intended use and within its performance limits. Inten-
ded use and limits are described in the product documentation such as the data
sheet, manuals and the printed "Safety Instructions". If you are unsure about the
appropriate use, contact Rohde & Schwarz customer service.

Using the product requires specialists or specially trained personnel. These users
also need sound knowledge of at least one of the languages in which the user
interfaces and the product documentation are available.

Safety instructions
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Never open the casing of the product. Only service personnel authorized by
Rohde & Schwarz are allowed to repair the product. If any part of the product is
damaged or broken, stop using the product. Contact Rohde & Schwarz customer
service at http://www.customersupport.rohde-schwarz.com.

Lifting and carrying the product

The maximum weight of the product is provided in the data sheet. To move the
product safely, you can use lifting or transporting equipment such as lift trucks
and forklifts. Follow the instructions provided by the equipment manufacturer.

The product is heavy. Do not move or carry the product by yourself. A single per-
son can only carry a maximum of 18 kg safely depending on age, gender and
physical condition. Look up the maximum weight in the data sheet. Use the prod-
uct handles to move or carry the product. Do not lift by the accessories mounted
on the product. Accessories are not designed to carry the weight of the product.

To move the product safely, you can use lifting or transporting equipment such as
lift trucks and forklifts. Follow the instructions provided by the equipment manu-
facturer.

Choosing the operating site

Only use the product indoors. The product casing is not waterproof. Water that
enters can electrically connect the casing with live parts, which can lead to elec-
tric shock, serious personal injury or death if you touch the casing. If
Rohde & Schwarz provides accessories designed for your product, e.g. a carrying
bag, you can use the product outdoors.

Unless otherwise specified, you can operate the product up to an altitude of
2000 m above sea level. The product is suitable for pollution degree 2 environ-
ments where nonconductive contamination can occur. For more information on
environmental conditions such as ambient temperature and humidity, see the
data sheet.

Setting up the product

Always place the product on a stable, flat and level surface with the bottom of the
product facing down. If the product is designed for different positions, secure the
product so that it cannot fall over.

If the product has foldable feet, always fold the feet completely in or out to ensure
stability. The feet can collapse if they are not folded out completely or if the prod-

Safety instructions

http://www.customersupport.rohde-schwarz.com
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uct is moved without lifting it. The foldable feet are designed to carry the weight of
the product, but not an extra load.

If stacking is possible, keep in mind that a stack of products can fall over and
cause injury.

If you mount products in a rack, ensure that the rack has sufficient load capacity
and stability. Observe the specifications of the rack manufacturer. Always install
the products from the bottom shelf to the top shelf so that the rack stands
securely. Secure the product so that it cannot fall off the rack.

Connecting to power

The product is an overvoltage category II product. Connect the product to a fixed
installation used to supply energy-consuming equipment such as household
appliances and similar loads. Keep in mind that electrically powered products
have risks, such as electric shock, fire, personal injury or even death.

Take the following measures for your safety:
● Before switching on the product, ensure that the voltage and frequency indica-

ted on the product match the available power source. If the power adapter
does not adjust automatically, set the correct value and check the rating of the
fuse.

● If a product has an exchangeable fuse, its type and characteristics are indica-
ted next to the fuse holder. Before changing the fuse, switch off the product
and disconnect it from the power source. How to change the fuse is described
in the product documentation.

● Only use the power cable delivered with the product. It complies with country-
specific safety requirements. Only insert the plug into an outlet with protective
conductor terminal.

● Only use intact cables and route them carefully so that they cannot be dam-
aged. Check the power cables regularly to ensure that they are undamaged.
Also ensure that nobody can trip over loose cables.

● If the product needs an external power supply, use the power supply that is
delivered with the product or that is recommended in the product documenta-
tion or a power supply that conforms to the country-specific regulations.

● Only connect the product to a power source with a fuse protection of maxi-
mum 20 A.

● Ensure that you can disconnect the product from the power source at any
time. Pull the power plug to disconnect the product. The power plug must be
easily accessible. If the product is integrated into a system that does not meet

Safety instructions
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these requirements, provide an easily accessible circuit breaker at the system
level.

Using laser products

Lasers are classified according to their potential risk. If exposure to the laser
beam is possible, the product is labeled as shown in the table explaining the
safety labels.

Class 1M lasers

Safe for the naked eye. If you look into the laser beam with optical instruments
such as binoculars or eye loupes, you risk damaging your eyes.

Class 2 lasers

If you stare into the beam, you risk damaging your eyes.

Handling batteries safely

The product contains exchangeable or built-in lithium polymer or lithium ion cells
or batteries. The use of the word battery in the following always means all types.
Only the battery contents are potentially hazardous. As long as a battery is
undamaged and the seals remain intact, there is no danger.

Impact, shock or heat can cause damage such as dents, punctures and other
deformations. A damaged battery poses a risk of personal injury. Handle a dam-
aged or leaking battery with extreme care. Immediately ventilate the area since
the battery releases harmful gases. If you come into contact with the battery fluid,
immediately remove all contaminated clothing. Irritation can occur if the battery
fluid comes in contact with your skin or eyes. Immediately and thoroughly rinse
your skin or eyes with water and seek medical aid.

For safe handling, follow these rules:
● Do not short-circuit the battery.
● Do not mechanically damage the battery. Do not open or disassemble the bat-

tery.
● Do not expose the battery to high temperatures such as open flames, hot sur-

faces and sunlight.
● Only use the battery with the designated Rohde & Schwarz product.

Safety instructions
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● Only use the appropriate Rohde & Schwarz charger to charge the batteries. If
the batteries are improperly charged, there is a risk of explosion. For charging
and discharging temperature ranges, see the product documentation.

● Replace exchangeable batteries only with the same battery type.
● Store the battery in the product or use the product packaging.
● Dispose of exchangeable batteries separately from normal household waste

as specified by the local waste disposal agency.

If you disregard these rules, you risk serious personal injury or even death due to
explosion, fire or hazardous chemical substances. The product documentation
provides further details.

If exchangeable batteries or products with built-in batteries are defective, contact
the Rohde & Schwarz customer service. Rohde & Schwarz classifies the severity
of the defect. When returning batteries or Rohde & Schwarz products containing
batteries, use a carrier qualified to transport dangerous goods and notify the car-
rier of this classification. Follow the carrier’s transport stipulations in line with
IATA-DGR, IMDG-Code, ADR or RID.

Using headphones

Take the following measures to prevent hearing damage. Before using head-
phones, check the volume and reduce it if necessary. If you monitor varying sig-
nal levels, take off the headphones and wait until the signal has settled. Then
adjust the volume.

Cleaning the product

Use a dry, lint-free cloth to clean the product. When cleaning, keep in mind that
the casing is not waterproof. Do not use liquid cleaning agents.

Meaning of safety labels

Safety labels on the product warn against potential hazards.

Potential hazard
Read the product documentation to avoid personal injury or product damage.

Heavy product
Be careful when lifting, moving or carrying the product. Carrying the product requires
a sufficient number of persons or transport equipment.

Safety instructions
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Electrical hazard
Indicates live parts. Risk of electric shock, fire, personal injury or even death.

Hot surface
Do not touch. Risk of skin burns. Risk of fire.

Protective conductor terminal
Connect this terminal to a grounded external conductor or to protective ground. This
connection protects you against electric shock if an electric problem occurs.

Warning: laser beam
The product contains a laser.

Avoid exposure to direct or reflected laser beam.

1.2  Labels on R&S SGU

Labels on the casing inform about:
● Personal safety, see "Connecting to power" on page 7.
● Product and environment safety, see Table 1-1.
● Identification of the product, see the serial number on the rear panel.
Table 1-1: Labels regarding R&S SGU and environment safety

Labeling in line with EN 50419 for disposal of electrical and electronic equipment after
the product has come to the end of its service life. For more information, see the prod-
uct user manual, chapter "Disposal".

Labeling in line with directive 2006/66/EC for disposal of batteries after they have come
to the end of their service life. For more information, see the product user manual,
chapter "Disposal".

1.3  Warning messages in the documentation

A warning message points out a risk or danger that you need to be aware of. The
signal word indicates the severity of the safety hazard and how likely it will occur
if you do not follow the safety precautions.

Warning messages in the documentation
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WARNING

Potentially hazardous situation. Could result in death or serious injury if not avoi-
ded.

CAUTION

Potentially hazardous situation. Could result in minor or moderate injury if not
avoided.

NOTICE

Potential risks of damage. Could result in damage to the supported product or to
other property.

1.4  Korea certification class B

이 기기는 가정용(B급) 전자파 적합기기로서 주로 가정에서 사용하는 것을 목적으
로 하며, 모든 지역에서 사용할 수 있습니다.

Korea certification class B
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2  Key features
The key features of the R&S SGU include the following:

● Compact size and low power consumption
● Remote connection via PCI Express, minimizing the setup time

Alternatively, LAN or USB connections available
● Coherent LO input and output connectors, also usable as MIMO input/output

and phase coherent I/Q demodulation
● Linux operating system
● Graphical user interface R&S SGMA-GUI to set up and control one or more

R&S SGU instruments simultaneously from one remote computer, available
for Windows and Linux systems
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3  Documentation overview
This section provides an overview of the R&S SGU user documentation. Unless
specified otherwise, you find the documents on the R&S SGU product page at:

www.rohde-schwarz.com/manual/sgu100a

3.1  Getting started manual

Introduces the R&S SGU and describes how to set up and start working with the
product. Includes basic operations, typical measurement examples, and general
information, e.g. safety instructions, etc. A printed version is delivered with the
instrument.

3.2  User manual and help

Contains the description of all instrument modes and functions. It also provides
an introduction to remote control, a complete description of the remote control
commands with programming examples, and information on maintenance, instru-
ment interfaces and error messages. Includes the contents of the getting started
manual.

The contents of the user manuals are available as help in the R&S SGU. The
help offers quick, context-sensitive access to the complete information.

All user manuals are also available for download or for immediate display on the
Internet.

3.3  Service manual

Describes the performance test for checking the rated specifications, module
replacement and repair, firmware update, troubleshooting and fault elimination,
and contains mechanical drawings and spare part lists.

Service manual

http://www.rohde-schwarz.com/manual/sgu100a
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The service manual is available for registered users on the global
Rohde & Schwarz information system (GLORIS, https://gloris.rohde-
schwarz.com).

3.4  Instrument security procedures

Deals with security issues when working with the R&S SGU in secure areas. It is
available for download on the Internet.

3.5  Basic safety instructions

Contains safety instructions, operating conditions and further important informa-
tion. The printed document is delivered with the instrument.

3.6  Data sheets and brochures

The data sheet contains the technical specifications of the R&S SGU. It also lists
the options and their order numbers and optional accessories.

The brochure provides an overview of the instrument and deals with the specific
characteristics.

See www.rohde-schwarz.com/brochure-datasheet/sgu100a

3.7  Release notes and open source acknowledg-
ment (OSA)

The release notes list new features, improvements and known issues of the cur-
rent firmware version, and describe the firmware installation.

The open source acknowledgment document provides verbatim license texts of
the used open source software.

See www.rohde-schwarz.com/firmware/sgu100a

Release notes and open source acknowledgment (OSA)

https://gloris.rohde-schwarz.com
https://gloris.rohde-schwarz.com
http://www.rohde-schwarz.com/brochure-datasheet/sgu100a
http://www.rohde-schwarz.com/firmware/sgu100a
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3.8  Application notes, application cards, white
papers, etc.

These documents deal with special applications or background information on
particular topics.

See www.rohde-schwarz.com/application/sgu100a.

Application notes, application cards, white papers, etc.

http://www.rohde-schwarz.com/application/sgu100a
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4  Preparing for use
Here, you can find basic information about setting up the product for the first time.

4.1  Lifting and carrying

See also "Lifting and carrying the product" on page 6.

► Use the carrying handles at the side for lifting and carrying the R&S SGU.
The handles at the front are only for pushing and pulling the instrument when
mounting in a rack, see Chapter 4.4.2, "Mounting the R&S SGU in a rack",
on page 18.

4.2  Unpacking and checking

1. Unpack the R&S SGU carefully.

2. Retain the original packing material. Use it to protect the control elements and
connectors when transporting or shipping the R&S SGU later.
See also chapter "Transporting" in the user manual.

3. Using the delivery notes, check the equipment for completeness.

4. Check the equipment for damage.

If the delivery is incomplete or equipment is damaged, contact
Rohde & Schwarz.

4.3  Choosing the operating site

Specific operating conditions ensure proper operation and avoid damage to the
product and connected devices. For information on environmental conditions
such as ambient temperature and humidity, see the data sheet.

See also "Choosing the operating site" on page 6.

Choosing the operating site
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Electromagnetic compatibility classes

The electromagnetic compatibility (EMC) class indicates where you can operate
the product. The EMC class of the product is given in the data sheet.
● Class B equipment is suitable for use in:

– Residential environments
– Environments that are directly connected to a low-voltage supply network

that supplies residential buildings
● Class A equipment is intended for use in industrial environments. It can cause

radio disturbances in residential environments due to possible conducted and
radiated disturbances. It is therefore not suitable for class B environments.
If class A equipment causes radio disturbances, take appropriate measures to
eliminate them.

4.4  Setting up the R&S SGU

See also:
● "Setting up the product" on page 6
● "Intended use" on page 5

4.4.1  Placing the R&S SGU on a bench top

To place the product on a bench top

1. Place the product on a stable, flat and level surface. Ensure that the surface
can support the weight of the product. For information on the weight, see the
data sheet.

2. WARNING! A stack of products can fall over and cause injury. Never stack
more than three products on top of each other. Instead, mount them in a rack.
Stack as follows:
● If the products have foldable feet, fold them in completely.
● It is best if all products have the same dimensions (width and length). If the

products have different dimensions, stack according to size and place the
smallest product on top.

Setting up the R&S SGU
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● Do not exceed the permissible total load placed on the product at the bot-
tom of the stack:
– 50 kg when stacking products of identical dimensions (left figure).
– 25 kg when stacking smaller products on top (middle figure).

Left = Stacked correctly, same dimensions
Middle = Stacked correctly, different dimensions
Right = Stacked incorrectly, too many products

3. NOTICE! Overheating can damage the product.
Prevent overheating as follows:
● Keep a minimum distance of 10 cm between the fan openings of the prod-

uct and any object in the vicinity.
● Do not place the product next to heat-generating equipment such as radia-

tors or other products.

4.4.2  Mounting the R&S SGU in a rack

To prepare the rack

1. Observe the requirements and instructions in "Setting up the product"
on page 6.

2. NOTICE! Insufficient airflow can cause overheating and damage the product.
Design and implement an efficient ventilation concept for the rack.

To mount the R&S SGU in a rack

1. Use an adapter kit that fits the dimensions of the R&S SGU to prepare the
instrument for rack mounting.
a) Order the rack adapter kit designed for the R&S SGU. For the order num-

ber, see data sheet.

Setting up the R&S SGU
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b) Mount the adapter kit. Follow the assembly instructions provided with the
adapter kit.

2. Push the R&S SGU onto the shelf until the rack brackets fit closely to the rack.

3. Tighten all screws at the rack brackets with a tightening torque of 1.2 Nm to
secure the R&S SGU in the rack.

To unmount the R&S SGU from a rack

1. Loosen the screws at the rack brackets.

2. Remove the R&S SGU from the rack.

3. If placing the R&S SGU on a bench top again, unmount the adapter kit from
the R&S SGU. Follow the instructions provided with the adapter kit.

4.5  Considerations for test setup

Cable selection and electromagnetic interference (EMI)

Electromagnetic interference (EMI) can affect the measurement results.

To suppress electromagnetic radiation during operation:
● Use high-quality shielded cables, especially for the following connector types:

– SMA/SMB
Double-shielded SMA/SMB cables.
How to: Chapter 4.8, "Connecting to RF 50Ω", on page 21

– USB
Double-shielded USB cables.
How to: Chapter 4.13.4, "Connecting a controller via USB", on page 33.

– LAN
At least CAT6 STP cables.
How to: Chapter 4.7, "Connecting to LAN", on page 20

● Always terminate open cable ends.
● Ensure that connected external devices comply with EMC regulations.

Considerations for test setup
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Signal input and output levels

Information on signal levels is provided in the data sheet. Keep the signal levels
within the specified ranges to avoid damage to the R&S SGU and connected
devices.

Preventing electrostatic discharge (ESD)

Electrostatic discharge is most likely to occur when you connect or disconnect a
DUT.

► NOTICE! Electrostatic discharge can damage the electronic components of
the product and the device under test (DUT).
Ground yourself to prevent electrostatic discharge damage:
a) Use a wrist strap and cord to connect yourself to ground.
b) Use a conductive floor mat and heel strap combination.

4.6  Connecting to power

For safety information, see "Connecting to power" on page 7.

1. Plug the AC power cable into the AC power connector on the rear panel of the
instrument. Only use the AC power cable delivered with the R&S SGU.

2. Plug the AC power cable into a power outlet with ground contact.
The required ratings are listed next to the AC power connector and in the data
sheet.

There is no need to set the voltage manually or change fuses.

4.7  Connecting to LAN

Network environment

Before connecting the product to a local area network (LAN), consider the follow-
ing:
● Install the latest firmware to reduce security risks.

Connecting to LAN
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● For internet or remote access, use secured connections if applicable.
● Ensure that the network settings comply with the security policies of your com-

pany. Contact your local system administrator or IT department before con-
necting your product to your company LAN.

● When connected to the LAN, the product may potentially be accessed from
the internet, which may be a security risk. For example, attackers might mis-
use or damage the product.

To connect to LAN

The connector is on the rear panel.

► Connect the LAN socket via an RJ-45 cable to the LAN.

By default, the R&S SGU is configured to use DHCP (dynamic host configuration
protocol) and no static IP address is configured.

4.8  Connecting to RF 50Ω

The connector is on the rear panel.

To prepare for connecting to RF 50Ω

1. NOTICE! Damaged or not clean connections can lead to RF insertion loss
and mismatch, and even premature wear of the connectors.
Before connecting to the port, inspect the RF connector visually to check that
it is clean, undamaged and mechanically compatible.
See the application note 1MA99 for information on how to handle and main-
tain the RF port, to minimize measurement deviations and ensure its longevity.

2. NOTICE! Risk of instrument damage. Excessive reverse power or DC voltage
at the RF 50Ω connector can damage the instrument.
Make sure that the values do not exceed the reverse power and DC limits as
given in the data sheet.

3. If switched-on, deactivate the RF output of the R&S SGU, before connecting
an RF cable to the RF 50Ω connector.
On the front panel, press the [RF ON] key.

Connecting to RF 50Ω

https://www.rohde-schwarz.com/appnote/1MA99
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To connect to screwable connectors

Additional to the RF 50Ω connector, the following procedure holds for all screwa-
ble connectors of the R&S SGU. Screwable connectors include connector types
as listed in Table 4-1.

1. Use a high-quality cable that matches the connector type.
See "Cable selection and electromagnetic interference (EMI)" on page 19.

2. NOTICE! Risk of instrument damage and connector damage. Excessive tight-
ening can damage the cables and the connectors. However, if you do not
tighten the connectors enough, the measurement results can be inaccurate.
To connect the cable with the connector, proceed as follows:
a) Carefully align the connector of the cable and the connector along a com-

mon axis.
b) Mate the connectors along the common axis until the male pin of the inner

connector engages with the female socket of the outer connector.
c) Turn the nut of the outer connector until the connectors are firmly coupled.
d) Torque the nut to the specified limit using a calibrated torque wrench. Hold

the opposite connector part stationary with a spanner.
For torque limits of the most relevant connector types, see Table 4-1. For
more information, see chapter "Handling" of the application note 1MA99.

3. Torque the nut to the specified limit using a calibrated torque wrench. Hold the
opposite connector part stationary with a spanner.

Table 4-1: Connector types and torque limits

Type Torque limit Nut opening

 lb-Inch Nm Inch mm

SMA, SMB 5 0.56 5/16 8

K, 2.92 mm 8 0.9 5/16 8

To prevent RF output switch-off

► NOTICE! If you set a too high output level without a load connected to the
instrument, the reverse power can exceed a limit forcing the R&S SGU to
switch off the RF output.
Connect a load with sufficient return loss.

Connecting to RF 50Ω

https://www.rohde-schwarz.com/appnote/1MA99
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4.9  Connecting to non-screwable connectors

Non-screwable connectors of the R&S SGU are BNC type connectors on the rear
panel.

► To connect the RF cable with the RF 50Ω connector, proceed as follows:
a) Carefully align the connector of the cable and the RF 50Ω connector along

a common axis.
b) Mate the connectors along the common axis until the male pin of the con-

nector of the cable engages with the female socket of the RF 50Ω connec-
tor.

4.10  Switching on or off

The following table provides an overview of power states, LEDs and power switch
positions.
Table 4-2: Overview of power states

State LED Position of power switch

Off  gray [0]

Standby  orange [I]

Ready  green [I]

To switch on the R&S SGU

The R&S SGU is off but connected to power. See Chapter 4.6, "Connecting to
power", on page 20.

1. Set the switch on the power supply to position [I].
The switch is on the rear panel.
The LED of the [POWER ON/STANDBY] key is orange.

2. Press the [POWER ON/STANDBY] key.
Key and LED are on the front panel.

Switching on or off
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The LED changes to green. The R&S SGU boots.

When starting for the first time, the R&S SGU starts with the default settings.
When restarting the instrument, the settings depend on the instrument config-
uration before shut-down.
See the chapter "File Menu" in the user manual.

To perform functional checks

When the instrument is switched on, it automatically monitors main functions. You
can query erroneous functions.

See chapter "Error Messages and Troubleshooting" in the user manual.

To switch between standby and ready state

► Press the [POWER ON/STANDBY] key briefly to switch the instrument from
the standby to ready state or vice versa.

In ready state, the button is green. The instrument is ready for operation. All
modules are power-supplied and the R&S SGU initiates its startup procedure.
In standby state, the button is orange. The standby power mode keeps the
power switch circuits and the remote control system active.

To start up and boot

The instrument boots the operating system and starts the instrument firmware.
During the booting process, the green [POWER ON/STANDBY] key blinks. If the
previous session was terminated regularly, the instrument uses the last setup with
the relevant instrument settings.

Once the startup procedure has been terminated, the instrument is ready for
operation.

In the R&S SGMA-GUI, select "Instrument > Preset" function to return the
instrument to its defined reset/preset state, if the current setup is no longer
relevant.

To customize the start settings, use the "SGMA-GUI > File > Save As/Open" func-
tion.

Switching on or off
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To shut down the product

The product is in the ready state.

► Press the [POWER ON/STANDBY] key.
The operating system shuts down. The LED changes to orange.

In standby state, the power switch circuits are active. To deactivate them, discon-
nect the instrument from the power supply.

To disconnect from power

The R&S SGU is in the standby state.

1. NOTICE! Risk of data loss. If you disconnect the product from power when it
is in the ready state, you can lose settings and data. Shut it down first.
Set the toggle switch on the power supply to position [0].
The LED of the [POWER ON/STANDBY] key is switched off.

2. Disconnect the R&S SGU from the power source.

4.11  Checking default settings

When the instrument is switched on, it is not the preset state that is active, but
rather the instrument state that was set before the instrument was switched off. It
is recommended that you use the "SGMA-GUI > Instrument > Preset" function to
return the instrument to its defined preset state every time a new configuration is
required or the current setup is no longer relevant.

The R&S SGU offers a two-stage preset concept:
● Preset the instrument to a predefined state.

The "SGMA-GUI > Instrument Name > Preset" function calls up a defined
instrument setup. All parameters and switching states are preset. The default
instrument settings provide a reproducible initial basis for all other settings.
However, functions that concern the integration of the instrument into a mea-
surement setup are not changed.

● Preset the instrument to its factory settings.
The instrument can also be forced to load its default factory settings. To
access the corresponding dialog box, select the "SGMA-GUI > Instrument
Name > Setup > Factory Preset" function.

Checking default settings
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For more information and an overview of the settings affected by the factory
preset function, see section "Factory Preset" in the R&S SGU user manual.

User-defined instrument states can be stored and called up using the func-
tions "SGMA-GUI > File > Save As/Open".

4.12  Working with Linux operating system

The instrument uses an embedded Linux operating system, optimally adapted to
the instrument.

Accessing the operating system
No access to the operating system is required for normal operation.
All necessary system settings can be made in the "Setup" dialog.

4.13  Connecting an external PC and devices

For control and operation, the R&S SGU requires a connection to an external
device. The external device, e.g. an external PC, controls the R&S SGU via
remote control or manual operation via the R&S SGMA-GUI software installed on
the external PC.

Both the remote control and the manual operation of the instrument require an
external controller. For the prerequisites and the instructions on how to configure
an external controller for remote control, refer to the user manual. A brief intro-
duction to the remote control capabilities is provided in Chapter 7.2, "Network
operation and remote control", on page 53.

This section gives an introduction on how to configure the external PC for manual
operation. See Chapter 4.13.1, "Installing the R&S SGMA-GUI software",
on page 27.

In addition to connecting an external controller, you can connect other external
devices, e.g. a memory stick. The following interfaces are on the rear panel of the
R&S SGU:

● "LAN": Chapter 4.13.2, "Connecting a remote PC via LAN", on page 29

Connecting an external PC and devices
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● "PCIe": Chapter 4.13.3, "Connecting a controller via PCI Express",
on page 33

● "USB In": Chapter 4.13.4, "Connecting a controller via USB", on page 33

4.13.1  Installing the R&S SGMA-GUI software

The R&S SGMA-GUI software is a graphical user interface program for one or
more instruments. It runs on a remote PC.

The R&S SGMA-GUI software is provided as separate installation package for
the different operating systems. The latest version of the software together with
the release notes is available for download at:

http://www.rohde-schwarz.com/product/SGU100A.html > "Downloads" > "Soft-
ware"

This page always offers the latest information on your R&S SGMA-GUI.

The R&S SGMA-GUI installation package for Windows 64-bit operating system
consists of the file SGMA-GUI_<version_number>.exe. The version number
within the file name (<version_number>=v.vv.vvv.vv) varies with each
update.

To install the R&S SGMA-GUI, check that you PC and drivers fulfill the following
hardware and software requirements.
Table 4-3: Hardware and software requirements

Requirement Remark

Operating system:
Windows 10, 1607 "Anni-
versary Edition" and later

Install R&S SGMA-GUI on one of the supported operating systems.
Also, make sure that Microsoft offers support for the version of the
operating system.
Note: Any other Windows version or other operating systems are
not supported. During installation, the operation system is checked.
The installation is terminated if this requirement is not fulfilled.

System type:
● 64-bit operating sys-

tem
● x64-based or x86-

based processor

You can only run the latest software on a 64-bit operating system.

R&S VISA VISA drivers can be obtained on the Rohde & Schwarz website:
http://www.rohde-schwarz.com/rsvisa

Connecting an external PC and devices
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Requirement Remark

CPU At least Pentium or compatible, as from 1 GHz (recommended).

VGA color display resolu-
tion

At least 800*600 pixels

Installing a new software version

1. Download the R&S SGMA-GUI software.

2. In Windows Explorer, navigate to the download folder of the installation file
SGMA-GUI_V.VV.VVV.VV.exe (<version_number>=v.vv.vvv.vv).

3. Open the installation file using administrator rights.

4. Follow the instructions in the installation wizard.

After the installation of the R&S SGMA-GUI software, two icons will be shown in
your Windows menu: one is the standard version and one for which the remote
command of the software through SCPIs is disabled. The SCPI disabled version
allows you to install and use the R&S SGMA-GUI on other instruments, without
interfering with the remote control of the host instrument.

Start the version that is required for your application.

Upgrading to firmware versions 5.00.vvv.vv and later

For upgrading the R&S SGU to firmware versions 5.00.vvv.vv and later, proceed
as follows:

1. Download the *.rsu file for R&S SGU firmware version 4.30.046.300.

2. Install this firmware version before installing a firmware version 5.00.vvv.vv
and later.
Follow the step-by-step description in the release notes document, see Chap-
ter 3.7, "Release notes and open source acknowledgment (OSA)",
on page 14.
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3. Download and install a firmware version 5.00.vvv.vv and later.
Follow the step-by-step description in the release notes document, see Chap-
ter 3.7, "Release notes and open source acknowledgment (OSA)",
on page 14.

Uninstalling an old software version

You can uninstall a previous version of the software before the installing a new
software version, but this step is not mandatory.

1. To uninstall this version, go to "Start > Settings > Control Panel > Add/
Remove Programs".

2. Select the entry SGMA-GUI_V.VV.VVV.VV.

The script file identifies and removes all currently installed R&S SGMA-GUI
software items.

4.13.2  Connecting a remote PC via LAN

The R&S SGU is equipped with a network interface and can be connected to an
Ethernet LAN (local area network). The interface can be used, for example:

● To connect an external computer for manual control of the instrument by the
R&S SGMA-GUI software.

● To operate the device by a remote control program.
See Chapter 7.2, "Network operation and remote control", on page 53.

This section describes how to configure the LAN interface. It covers the following
topics:

● Connecting to the network.............................................................................. 29
● Assigning the IP address................................................................................ 31
● Adding instruments to R&S SGMA-GUI..........................................................32

4.13.2.1  Connecting to the network

There are two methods to establish a LAN connection to the instrument:

● A non-dedicated network (Ethernet) connection from the instrument to an
existing network.

● A dedicated network connection (Point-to-point connection) between the
instrument and a single computer.

Connecting an external PC and devices
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In both cases, an IP address has to be assigned to the instrument and the com-
puter, see Chapter 4.13.2.2, "Assigning the IP address", on page 31.

Setting up a non-dedicated network (LAN) connection

► See Chapter 4.7, "Connecting to LAN", on page 20.

Setting up a dedicated network connection

If your network does not support DHCP, set a dedicated network connection
between a stand-alone PC and a R&S SGU.

Prerequisite: The external PC and the R&S SGU are turned on and running.

1. Start the R&S SGMA-GUI.

2. NOTICE! Risk of network failure.
Consult your network administrator before performing the following tasks:
● Connecting the instrument to the network
● Configuring the network
● Changing IP addresses
Errors can affect the entire network.
Connect the computer and the R&S SGU with a LAN network cable.

3. Wait for about one minute for the automatic assignment of IP addresses to
complete.

4. R&S SGMA-GUI main panel, select "Setup > Instruments".

5. In the "Configure Instruments" dialog, click "Scan".
The new instrument appears with a Zeroconf IP address 169.254.xx.yy.

6. To assign a static IP address to the instrument, see "Assigning a static IP
address to the R&S SGU" on page 31.

7. To assign a static IP address to the PC, see "Assigning a static IP address to
your Windows-PC network card" on page 31.

8. To edit the instrument settings, open the "Edit Instrument" dialog ("SGMA-GUI
> Setup > Instruments > Instrument> Edit").
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4.13.2.2  Assigning the IP address

Depending on the network capacities, the TCP/IP address information for the
instrument can be obtained in different ways.
● If the network supports dynamic TCP/IP configuration using the Dynamic Host

Configuration Protocol (DHCP), all address information can be assigned auto-
matically.

● If the network does not support DHCP, the instrument tries to obtain the IP
address via Zeroconf (APIPA) protocol. If this attempt does not succeed or if
the instrument is set to use, alternate TCP/IP configuration, the addresses
must be set manually, see "Setting up a dedicated network connection"
on page 30.

The R&S SGU uses the Zeroconf IP addresses 169.254.xxx.yyy, where xxx
takes values between 1...254 and yyy the values in the value range 1...255;
the subnet mask is always 255.255.0.0. The IP address of the host must be
within the same address area for Zeroconf.

Assigning a static IP address to the R&S SGU

Prerequisites: A connection is established between the R&S SGU and the con-
troller with installed SGMA-GUI.

For how to set up a LAN connection, see Chapter 4.13.2.1, "Connecting to the
network", on page 29.

For how to set up a USB connection, see "Setting up a USB connection from a
PC to the R&S SGU" on page 33.

1. Open "SGMA-GUI > Instrument > Setup > Network Settings" dialog.

2. Set the "Address Mode" to "Static".

3. Enter the "IP Address", for example 192.168.0.1..

4. Enter the "Subnet mask", for example 255.255.255.0.

5. Enter the "Default Gateway", for example 192.168.0.1.

Assigning a static IP address to your Windows-PC network card

1. Obtain the IP address and subnet mask for the R&S SGU and the IP address
for the local default gateway from your network administrator. If necessary,
also obtain the name of your DNS domain and the IP addresses of the DNS
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and WINS servers on your network. If you use more than one LAN connector,
you need separate address information for each connector.

2. Press the "Windows" key to access the operating system.

3. Open the "Control Panel" by selecting "Start > Settings > Control Panel".

4. Select "Network and Sharing Center".

5. In the left panel, click "Change adapter settings".

6. Select the network adapter that you want to change. Click "Change settings of
this connection".

7. On the "Networking" tab, click "Internet Protocol Version 4 (TCP/IPv4)". Select
"Properties".

8. Select "Use the following IP address".

9. Enter the address information as obtained from the network administrator.

10. If necessary, you can also select "Use the following DNS server addresses"
and enter your own DNS addresses.

For more information, refer to your Windows system help.

4.13.2.3  Adding instruments to R&S SGMA-GUI

For information on how to install the R&S SGMA-GUI software, refer to
Chapter 4.13.1, "Installing the R&S SGMA-GUI software", on page 27.

1. For each new instrument perform the following steps:
a) Connect the instrument to the network.
b) Press the [POWER ON/STANDBY] key to switch on the instrument.
c) Wait until the [POWER ON/STANDBY] LED is green and not blinking.
d) Press the [ID] key on the front panel of the instrument.

2. Start the SGMA-GUI on a computer connected to the same network.

3. Open the "Instruments" dialog.

4. Select "Scan".

Connecting an external PC and devices



Preparing for useR&S®SGU100A

33Getting Started 1418.2070.02 ─ 09

Note: This step is performed automatically on the first start and can also be
omitted for instruments with a direct LAN connection to the computer.

All instruments are added automatically to the main panel of the SIGMA-GUI.

4.13.3  Connecting a controller via PCI Express

Using the "PCIe" interface for remote control of the R&S SGU requires extended
knowledge. See section "Advanced Remote Control Using PCIe" in the user man-
ual.

4.13.4  Connecting a controller via USB

The USB interface on the rear panel of the R&S SGU allows you to connect either
a USB device or use the R&S SGU as a device and connect it to a controller.

Connecting a controller (host PC or compatible signal generator)

If you connect a controller (host PC or compatible signal generator) to the
R&S SGU, the R&S SGU acts as a USB device.

To connect the controller to the USB interface of the R&S SGU, always connect
the USB type Micro-B connector to the R&S SGU. Refer to the documentation of
the controller to find out which USB connector type you can connect to the con-
troller.

The Figure 4-1 illustrates schematically the required connector type to emphasize
on the different connector shape.

Figure 4-1: USB type Micro-B connectors

An external PC with installed R&S SGMA-GUI is required for manual operation of
the R&S SGU.

Setting up a USB connection from a PC to the R&S SGU

If your network does not support DHCP, you can set a USB connection between a
PC and a R&S SGU.

Connecting an external PC and devices
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Prerequisite: the computer and the R&S SGU are turned on and running.

1. Start the R&S SGMA-GUI.

2. Connect the computer and the R&S SGU with a USB cable.
In the "Setup > Instruments > Configure Instruments" table, the new instru-
ment appears automatically.
If it does not appear, open the "Setup > Instruments > Configure Instruments"
dialog and select "Scan".

3. If your network does not support DHCP, you can now set a static IP address to
your computer.
a) To assign a static IP address to the instrument, see "Assigning a static IP

address to the R&S SGU" on page 31.
b) To assign a static IP address to the PC, see "Assigning a static IP address

to your Windows-PC network card" on page 31.
c) To edit the instrument settings, open the "Edit Instrument" dialog ("SGMA-

GUI > Setup > Instruments > Instrument> Edit").

Connecting a USB device

If you connect a USB device (memory stick, CD-ROM, an instrument) to the
R&S SGU, the R&S SGU acts as a host.

To connect a USB device to the interface of the R&S SGU, always connect the
USB type Micro-A connector to the R&S SGU. Refer to the documentation of the
USB device to find out which USB connector type you can connect to the USB
device.

The Figure 4-2 illustrates schematically the required connector type to emphasize
on the different connector shape.

Figure 4-2: USB type Micro-A connectors

If you connect an R&S SGS to an R&S SGU via a USB cable, perform the steps
as described in chapter "Setups for Connecting an R&S SGS and an R&S SGU"
of the user manual.

Connecting an external PC and devices
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Using a USB adapter
You can use a USB adapter to customize the connectors of a USB cable to
the requirements of the instrument.
For example, use a Type-A / Micro-A adapter to customize a standard USB
cable. The customized cable connects type A and type Micro-B connectors
for the connection of an R&S SGS (acting as a host) to an R&S SGU (acting
as a USB device).
Also, you can use a Type-A / Micro-B adapter to establish a connection to
the instrument. To check, whether the adapter you have is suitable or not
you can connect a USB stick with an LED through the adapter to the instru-
ment. If the LED of the USB stick lights up after a connection to the instru-
ment then you can use this adapter for further applications with the instru-
ment.

Connecting an external PC and devices
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5  Instrument tour
This chapter explains the control elements and the connectors of the R&S SGU.
The views of the front panel and the rear panel help you to get familiar with the
instrument and to perform first steps. For specifications of the interfaces, see the
data sheet.

The meanings of the labels on the R&S SGU are described in Chapter 1.2,
"Labels on R&S SGU", on page 10.

5.1  Front panel tour

This section provides an overview of control elements on the front panel of the
R&S SGU. The front panel contains LEDs to inform you about the status of the
instrument, in particular for remote control of the R&S SGU.

The connectors of the R&S SGU are on the rear panel.

1 2 3 4 5 6

Figure 5-1: R&S SGU front panel controls

1 = [POWER ON/STANDBY]
2 = [RF ON]
3 = [LO IN]
4 = [ERROR / WARNING]
5 = [LAN]
6 = [ID]

[POWER ON/STANDBY]
The [POWER ON/STANDBY] key switches the instrument from the standby to the
ready state or vice versa.
The LED above the [POWER ON/STANDBY] key indicates the instrument state,
see Table 4-2.
How to:
● Chapter 4.10, "Switching on or off", on page 23

Front panel tour
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● "To switch between standby and ready state" on page 24

[RF ON]
The [RF ON] key switches the RF signal on or off. If activated, the key is green.
Table 5-1: Overview of RF signal states

[RF ON] state LED Remark

On  green RF signal output at the RF 50Ω connector.

Off  gray No RF signal output.

How to: Chapter 4.8, "Connecting to RF 50Ω", on page 21

[LO IN]
The [LO IN] LED indicates the compatibility of the level of the local oscillator (LO)
input signal with the correct operation of the R&S SGU.
Table 5-2: Overview of local oscillator input signal states

[LO IN] state LED Remark

Correct LO input  green The level of the LO input signal is in the range of cor-
rect operation.

Error  red The level of the LO input signal is too high or too low.

Off  gray The R&S SGU is in a bypass mode.

[ERROR / WARNING]
The [ERROR / WARNING] LED indicates the status of the R&S SGU.
Table 5-3: Overview of [ERROR / WARNING] key states

[ERROR /
WARNING]
state

LED Remark

Error  red Error occurred, e.g. temperature exceeded or power
failure.

Running process  blinking orange Indicates a running process (e.g calibration, self-test).

No error  gray No errors or warnings occurred.

See also section "Error Messages and Troubleshooting" in the R&S SGU user
manual.

[LAN]
The [LAN] key indicates the LAN connection state.

Front panel tour
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Pressing the [LAN] key resets the network settings, e.g., "IP Adress Mode" is
reset to "DHCP".
Table 5-4: Overview of LAN connection states

[LAN] state LED Remark

Connected  green Connected to the network.

Running process  blinking orange Resets the network settings, applies the default set-
tings.

Error  red Network error occurred.

Off  gray The internal reference signal is used.

How to:
● Chapter 4.7, "Connecting to LAN", on page 20
● Chapter 4.13.2, "Connecting a remote PC via LAN", on page 29

[ID]
The [ID] key allows you to identify your R&S SGU, e.g. in complex test setups
with more instruments.
The following applies if the R&S SGU is connected to a remote controller with
R&S SGMA-GUI installed:
● Press the [ID] key identify your R&S SGU on the remote controller. In the dia-

log "SGMA-GUI > Setup > Instruments > Configure Instruments > Edit Instru-
ment", the R&S SGU is active.

● Set "Edit Instrument > Device Identify > On" to identify your R&S SGU from
the remote controller. The LED of the [ID] key is orange and blinking.

Table 5-5: Overview of [ID] key states

[ID] state LED Remark

Identification  blinking orange Identification of the R&S SGU.

Off/Inactive  gray No identification.

5.2  Rear panel tour

This section provides an overview of the connectors on the rear panel of the
instrument. For technical data of the connectors, refer to the data sheet.

Rear panel tour
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1 2 3 4 5

78 6

Figure 5-2: R&S SGU rear panel controls and connectors

1 = AC power supply connector and power switch
2 = PCIe
3 = USB In
4 = LAN
5 = RF 50Ω
6 = TRIG
7 = LO IN, LO OUT
8 = I/Q

AC power supply connector and power switch
Mains power switch for performing the following tasks:
● Connecting the internal power supply to the power source
● Disconnecting the internal power supply from the power source
How to: Chapter 4.6, "Connecting to power", on page 20

LAN
RJ-45 connector to connect the R&S SGU to a LAN for remote control.
How to:
● Chapter 4.7, "Connecting to LAN", on page 20
● Chapter 4.13.2, "Connecting a remote PC via LAN", on page 29
If the instrument acts as an extension to a signal generator, to an R&S SGS for
instance, the LAN interface can also be used for remote control of the R&S SGU.

PCIe
PCIe (Peripheral Component Interconnect Express) single lane interface for
remote control with optimized speed.
How to: "Connecting the Controller and the Instrument" in the R&S SGU user
manual.

USB In
USB (universal serial bus) type Micro-B connector for remote control via various
external devices.
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How to: Chapter 4.13.4, "Connecting a controller via USB", on page 33

RF 50Ω
K-type female connector for output of the RF signal.
How to: Chapter 4.8, "Connecting to RF 50Ω", on page 21

LO IN, LO OUT
SMA type connectors for local oscillator input and output signals and alternatively
also in MIMO setups.
Local oscillator input and output:
● "LO IN": Input for external LO signals
● "LO OUT": Output of internal LO signals.
How to: "To connect to screwable connectors" on page 22

TRIG
SMA female multipurpose connector for input and output signals, e.g., for the fol-
lowing signals: "Trigger", "Marker 1/2", "Clock In/Out", "Sync In/Out".
Also, use the "TRIG" connector for input of an external pulse modulator signal.
How to: "To connect to screwable connectors" on page 22

I/Q
Requires R&S SGU-B120V/-B140V.
SMA female type connectors for input and output of I/Q signals.
"I/Q In" connectors are for input of external analog I/Q signals. The signals are
fed directly into the I/Q modulator.
"I/Q Out" connectors are for direct output of analog I/Q signals.
How to: "To connect to screwable connectors" on page 22
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6  Trying out the Instrument
If an R&S SGU is connected to a signal generator, the instrument acts as an
extension to the signal generator extending its frequency range.

This section provides an example on how to configure the instrument to convert a
continuous wave (CW) signal.

6.1  Extending R&S SGS with the R&S SGU

If you connect the R&S SGU to a compatible Rohde & Schwarz signal generator,
you need a controller. This controller talks to the signal generator and configures
the R&S SGU.

In the following example, the instrument the R&S SGMA-GUI software controls an
R&S SGS and an R&S SGU. The R&S SGU is equipped with the frequency
option R&S SGU-B120.

Configuring the R&S SGU

This step-by-step instruction describes how to configure the R&S SGU to upcon-
vert a CW signal. An R&S SGS generates the CW signal. As a prerequisite for
this example the R&S SGMA-GUI software has to be installed on a remote PC.

Figure 6-1: Example of a test setup for upconverting a CW signal generated by the
R&S SGS

Extending R&S SGS with the R&S SGU
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For higher setting/ measuring speeds, use a PCIe switch and PCIe connec-
tions.

1. Connect the test equipment as shown on Figure 6-1:
a) Connect the R&S SGS, R&S SGU and the controller to a LAN switch.
b) Connect the "RF 50Ω" of the R&S SGS to the "LO IN" of the R&S SGU.
c) Connect the "TRIG" connectors of the R&S SGS and the R&S SGU.
d) Connect the "RF 50Ω" of the R&S SGU to the RF input connector of the

signal analyzer.

2. Switch on the R&S SGS and the R&S SGU.
Wait until the [POWER ON/STANDBY] keys are green and not blinking.

3. If connected in a company network, press the [ID] keys on the front panels of
the R&S SGS and the R&S SGU.

4. On the connected remote PC, start the R&S SGMA-GUI software application.
The main panel of the application and the configure instruments dialog open.
Both instruments are added automatically to the instruments list and to the
main panel of the R&S SGMA-GUI software.
The main panel provides a quick access to the main settings of the configured
and activated instruments. The display shows one row per instrument with the
instrument-specific settings. The rows comprise the instrument, the connec-
tion state, the used frequency and power level and the state of the RF output
and the modulator.

Extending R&S SGS with the R&S SGU
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In the R&S SGMA-GUI main panel, the green indicator indicates a connection
between the instrument and the remote PC. It also indicates that the software
recognizes the instrument.

5. To restore the default configuration of this instrument, select "Instrument
Name > Preset".

6. Select "SGMA-GUI main panel > R&S SGS > Extension".
The "Extension" dialog opens.

Tip: Instrument does not appear in the extension dialog. If the R&S SGU is
not automatically shown in this dialog, press "Scan > Start" to find the instru-
ment.

7. Select the R&S SGU from the list.

Extending R&S SGS with the R&S SGU
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8. Set "Available Instruments > Select > On" to enable it as an extension.
A green status indicator "Connected" indicates the successfully established
remote connection between the R&S SGS ant the R&S SGU. The
R&S SGMA-GUI indicates the extended frequency range of the R&S SGS and
the activated extension mode.

9. Select "Test Signal Connections > Test" to trigger a check of all required signal
connections.

Extending R&S SGS with the R&S SGU
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The diagram displays the connection state of the tested connections.

10.Select "SGMA-GUI > R&S SGS > Freq = 40 GHz", "Lev = -30 dBm".

11. Select "SGMA-GUI > R&S SGS > RF > State > On" to enable the output of
the CW signal.

The extension adopts these values and states automatically. Also, it generates
a CW signal with RF = 40 GHz and Level = -20 dBm.

The signal is output at the "RF 50Ω" connector on the rear panel of the
R&S SGU.

Extending R&S SGS with the R&S SGU
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Identifying a specific instrument
If several instruments are active in the R&S SGMA-GUI, use one of the
device identification functions to identify a specific device:
● Select "SGMA-GUI > Instrument Name > Setup > Remote > Remote

Channels > Device Identify". On the front panel, the LED of the [LAN]
key is green and blinks.

● Press the [ID] key on the instrument's front panel. The "Edit Instrument"
dialog of the respective instrument opens.

6.2  R&S SGU as a Standalone Upconverter

This section provides an example on how to configure the instrument to convert a
continuous wave (CW) signal. The signal in this example is provided by an incom-
patible signal generator (local oscillator).

In the following example, the instrument is manually operated via the R&S
SGMA-GUI software. The R&S SGU in this example is a base unit equipped with
the frequency option R&S SGU-B120.

Configuring the R&S SGU to convert a CW signal

As a prerequisite for this example, the R&S SGMA-GUI software has to be instal-
led on a remote PC and the local oscillator has to be prepared for use.

R&S SGU as a Standalone Upconverter
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Figure 6-2: Example of a setup of the R&S SGU as an upconverter

1. Connect the test equipment as shown in Figure 6-2. Additional connections
may be needed to fulfill the requirements of the connected local oscillator. To
find out what connections are needed refer to its user manual.

2. Switch on the R&S SGU.
The [POWER ON/STANDBY] key has to be green and not blinking.

3. Press the [ID] key on the front panel the R&S SGU (only required if the com-
ponents are connected via a company network).

4. On the connected remote PC, start the R&S SGMA-GUI software application.
The main panel of the application and the configure instruments dialog open.
The R&S SGU is added automatically to the instruments list and to the main
panel of the R&S SGMA-GUI software.
The main panel provides a quick access to the main settings of the configured
and activated instruments. The display shows one row per instrument with the
instrument specific settings. The rows comprise the instrument, the connec-
tion state, the used frequency and power level and the state of the RF output
and the modulator.

R&S SGU as a Standalone Upconverter
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5. In the R&S SGMA-GUI main panel, the green indicator in front of the instru-
ment's name confirms that there is a connection between the instrument and
the remote PC and that the instrument is recognized by the software.

6. In the R&S SGMA-GUI main panel, select the row corresponding to the instru-
ment to be configured and select "Instrument Name > Preset" to restore the
predefined instrument's settings.

7. Select "SGMA-GUI > R&S SGU > Freq = 15 GHz", "Lev = -10 dBm", "RF >
On".

8. Select "SGMA-GUI > Instrument Name >Ext. Local Oscillator". Read the
required frequency and level values for the LO.

R&S SGU as a Standalone Upconverter
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9. Change the settings of the LO to the required values.

10.Select "SGMA-GUI > Instrument Name > Ext. Local Oscillator > Confirm
External LO Settings" to apply the changes.

The 15 GHz signal is output at the "REF OUT" connector at the rear panel of
the R&S SGU.

Identifying a specific instrument
If several instruments are active in the R&S SGMA-GUI, use one of the
device identification functions to identify a specific device:
● Select "SGMA-GUI > Instrument Name > Setup > Remote > Remote

Channels > Device Identify". The green [LAN] LED on the front panel of
the instrument blinks.

● Press the [ID] key on the instrument's front panel. The "Edit Instrument"
dialog of the respective instrument opens.

R&S SGU as a Standalone Upconverter
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7  Instrument control
As a rule, the R&S SGU is operated exclusively via programmatic remote control
from a connected PC. For service and diagnostic tasks, and for manual configura-
tion, a graphical user interface (R&S SGMA-GUI) is provided which runs on the
remote PC.

Also, some basic functionality is provided via the keys on the front panel of the
instrument (see Chapter 5.1, "Front panel tour", on page 36).

7.1  Manual operation via R&S SGMA-GUI

The R&S SGMA-GUI software application can be installed on a PC with Windows
or Linux operating system. This program allows you to control several devices of
the SGMA product family at the same time and to monitor the device status dur-
ing remote control. R&S SGMA-GUI requires one of the external interfaces
described in Chapter 4.13, "Connecting an external PC and devices", on page 26.

7.1.1  Introduction to the user interface

After the start of R&S SGMA-GUI, the main dialog of the application is displayed.

The main dialog with an overview of the configured instruments is the operating
and control interface for the whole program. From here, all program functions are
accessible.

The menus and dialogs are built using elements like selection lists, check boxes,
and entry fields. A blue frame indicates that the selected item is active. Entries
can be made in the highlighted element.

Manual operation via R&S SGMA-GUI
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The main dialog comprises two main areas:
● On the top of the main panel, there are bars: the menu bar, the tool bar and

the info bar with the corresponding "Info" button.
The menu bar provides access to the functions related to the software appli-
cation itself, like saving current configurations, retrieving information about the
installed software version or configuring the connected instruments.
The messages displayed in the info line indicate information, warnings, and
errors. They are displayed in different colors depending on their importance
and display duration. Use the "Info" button to open a dialog with information
on the messages in greater detail.

● The central part of the R&S SGMA-GUI main dialog is the main panel that
shows the list of all active instruments.
The main panel is the core element for the manual operation and provides
quick access to the main settings of the configured instruments. The display
shows one row per active instrument. Each row comprises the instrument's
name and state, the used frequency and level, the state of the RF output and
the modulator and the kind of used frequency reference.
The buttons with the instrument's symbolic name on it provides access to
menus and dialogs for further instrument configuration. Refer to the user man-
ual for a detailed description of all parameters and functions provided for con-
figuration.

A detailed description of the R&S SGMA-GUI, in-depth information on how
to work with the application and on how to operate the R&S SGU is provided
in the user manual.

7.1.2  How to use the help system

The R&S SGMA-GUI is equipped with a context-sensitive help function. A help
page is available for each parameter and can be called anytime during instrument
operation.

Calling context-sensitive and general help

► To display the general help dialog box, select the "SGMA-GUI > Help > Con-
tents" or use the F1 key.
The help dialog is displayed. A topic containing information about the current
menu or the currently opened dialog box and its function is displayed.
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Contents of the help dialog box

The help dialog box contains two main areas:
● "Contents" - contains a table of help contents
● "Topic" - contains a specific help topic

The help system also provides an "Index", "Find" and "Zoom" functions that are
accessed with the corresponding buttons.

Navigating in the table of contents and in the help topics

1. To move through the displayed contents entries, use the mouse or the [Up/
Down] keys. Entries that contain further entries are marked with a plus sign.

2. To display a help topic, double click on the topic name or press the [ENTER]
key.

3. To jump to the linked topic, press the link text.

4. Use the "Previous" or "Next" links to jump to the corresponding topic.

5. Use the "Scroll Right" or "Scroll Left" buttons to shift the indicated area of the
navigation window to the left or right.

Using the index

1. Select "SGMA-GUI > Help > Index" or use the "Go to Index" button in the
"Help" display.
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2. Enter the first characters of the topic that you are interested in. The entries
starting with these characters are displayed.

3. Press the [ENTER] key to display the help topic.

The corresponding help topic is displayed.

7.2  Network operation and remote control

As an alternative to operating the R&S SGU interactively via the R&S SGMA-GUI,
you can operate the R&S SGU also from a remote location.

Information on network operation and remote control
The following descriptions provide information required for operating the
R&S SGU remotely. The information applies to all applications and operat-
ing modes supported by the instrument. Definitions specified in the SCPI
standard are not provided.
For basic knowledge on remote control operation and additional information,
see the following documents, available on the Rohde & Schwarz website:
● Remote control via SCPI
● 1GP72: Connectivity of Rohde&Schwarz Signal Generators
● 1MA208: Fast Remote Instrument Control with HiSLIP

● Remote control interfaces and protocols.........................................................53
● Remote control over LAN using VXI-11 protocol.............................................60

7.2.1  Remote control interfaces and protocols

The instrument supports several interfaces for remote control. The following table
gives an overview.

Network operation and remote control
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Table 7-1: Remote control interfaces and protocols

Interface Protocols Remarks

Local
Area Net-
work
(LAN)

● HiSLIP High-Speed LAN Instrument Proto-
col (IVI-6.1)

● VXI-11
● socket communication (Raw Ethernet,

simple Telnet)

A LAN connector is located on the
rear panel of the instrument.
The interface is based on TCP/IP
and supports various protocols.
For details, see Chapter 7.2.1.1,
"LAN interface", on page 54

USB USBTMC A USB connector is located on the
rear panel of the instrument.
For details, see Chapter 7.2.1.2,
"USB interface", on page 58

PCIe Proprietary A PCIe connector is located on
the rear panel of the instrument.
For details, see Chapter 7.2.1.3,
"PCI Express interface",
on page 58

GPIB
(IEC/
IEEE Bus
Interface)

– The instrument is not equipped
with GPIB bus interfaces. Use a
GPIB-to-LAN or GPIB-to-USB
adapter instead.
For details, see Chapter 7.2.1.4,
"GPIB interface (IEC/IEEE bus
interface)", on page 59

SCPI (Standard Commands for Programmable Instruments)

SCPI commands are used for remote control. Commands that are not taken from
the SCPI standard follow the SCPI syntax rules. The instrument supports the
SCPI version 1999. The SCPI standard is based on standard IEEE 488.2 and
aims at the standardization of device-specific commands, error handling and the
status registers. The tutorial "Automatic Measurement Control - A tutorial on SCPI
and IEEE 488.2" from John M. Pieper (R&S order number 0002.3536.00) offers
detailed information on concepts and definitions of SCPI.

7.2.1.1  LAN interface

To be integrated in a LAN, the instrument is equipped with a LAN interface, con-
sisting of a connector, a network interface card and protocols.

For remote control via a network, the PC and the instrument must be connected
via the LAN interface to a common network with TCP/IP network protocol. They
are connected using an RJ45 cable (shielded or unshielded twisted-pair category
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5). The TCP/IP network protocol and the associated network services are precon-
figured on the instrument. Software for instrument control and (for specified proto-
cols only) the VISA program library must be installed on the controller.

Identifying instruments in a network
If several instruments are connected to the network, each instrument has its
own IP address and associated resource string. The controller identifies
these instruments by the resource string.

VISA resource strings

The VISA resource string is required to establish a communication session
between the controller and the instrument in a LAN. The resource string is a
unique identifier, composed of the specific IP address of the instrument and some
network and VISA-specific keywords.

TCPIP::host address[::LAN device name][::INSTR]
● TCPIP designates the network protocol used
● Host address is the IP address or host name of the device
● [::LAN device name] defines the protocol and the instance number of a sub-

instrument:
● [::INSTR] indicates the instrument resource class (optional)

The IP address (host address/computer name) is used by the programs to iden-
tify and control the instrument. It is automatically assigned by the DHCP server
the first time that the device is registered on the network. Alternatively, you can
also assign its LAN device name.

You can find the IP address in the "SGMA-GUI > Instrument Name > Setup >
Remote" dialog, and also adjust it manually, if necessary.

See below the characteristics of the VISA resource strings for the corresponding
interface protocols. The highlighted characters are crucial.

HiSLIP
TCPIP::host address::hislip0[::INSTR]
● hislip0 HiSLIP device name, designates that the interface protocol HiSLIP is

used (mandatory).
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hislip0 is composed of [::HiSLIP device name[,HiSLIP port]] and must be
assigned.

For details of the HiSLIP protocol, refer to "HiSLIP protocol" on page 56.

VXI-11
TCPIP::host address[::inst0][::INSTR]
● [::inst0] LAN device name, indicates that the VXI-11 protocol is used

(optional).

inst0 currently selects the VXI-11 protocol by default and can be omitted.

For details of the VXI-11 protocol, refer to "VXI-11 protocol" on page 57.

Socket communication
TCPIP::host address::port::SOCKET
● Port determines the used port number
● SOCKET indicates the raw network socket resource class

Socket communication requires the specification of the port (commonly referred
to as port number) and of "SOCKET" to complete the VISA resource string with
the associated protocol used.

The registered port for socket communication is port 5025.

See also "Socket communication" on page 57.

Example: 
● Instrument has the IP address 10.113.11.91; the valid resource string using

VXI-11 protocol is:
TCPIP::10.113.11.91::INSTR

● The DNS host name is rssgu100a100021; the valid resource string is:
TCPIP::rssgu100a100021::hislip0 (HiSLIP)
TCPIP::rssgu100a100021::inst0 (VXI-11)

● A raw socket connection can be established using:
TCPIP::10.113.11.91::5025::SOCKET

HiSLIP protocol

The High Speed LAN Instrument Protocol (HiSLIP) is the successor protocol for
VXI-11 for TCP-based instruments specified by the IVI foundation. The protocol
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uses two TCP sockets for a single connection - one for fast data transfer, the
other for non-sequential control commands (e.g. Device Clear or SRQ).

HiSLIP has the following characteristics:

● High performance as with raw socket network connections
● Compatible IEEE 488.2 support for Message Exchange Protocol, Device

Clear, Serial Poll, Remote/Local, Trigger, and Service Request
● Uses a single IANA registered port (4880), which simplifies the configuration

of firewalls
● Supports simultaneous access of multiple users by providing versatile locking

mechanisms
● Usable for IPv6 or IPv4 networks

Using VXI-11, each operation is blocked until a VXI-11 instrument hand-
shake returns. However, using HiSLIP, data is sent to the instrument using
the "fire and forget" method with immediate return. Thus, a successful return
of a VISA operation such as viWrite() guarantees only that the command
is delivered to the instrument's TCP/IP buffers. There is no confirmation,
that the instrument has started or finished the requested command.

For more information see also the application note:

1MA208: Fast Remote Instrument Control with HiSLIP

VXI-11 protocol

The VXI-11 standard is based on the ONC RPC (Open Network Computing
Remote Procedure Call) protocol which in turn relies on TCP/IP as the network/
transport layer. The TCP/IP network protocol and the associated network services
are preconfigured. TCP/IP ensures connection-oriented communication, where
the order of the exchanged messages is adhered to and interrupted links are
identified. With this protocol, messages cannot be lost.

Socket communication

An alternative way for remote control of the software is to establish a simple net-
work communication using sockets. The socket communication, also referred to
as “Raw Ethernet communication”, does not require a VISA installation on the
remote controller side.

Network operation and remote control
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The simplest way to establish socket communication is to use the built-in telnet
program. The telnet program is part of every operating system and supports com-
munication with the software on a command-by-command basis.

Socket connections are established on a specially defined port. The socket
address is a combination of the IP address or the host name of the instrument
and the number of the port configured for remote-control. All instruments use port
number 5025 for this purpose. The port is configured for communication on a
command-to-command basis and for remote control from a program running on a
connected PC.

7.2.1.2  USB interface

For remote control via USB connection, the PC and the instrument must be con-
nected via the USB interface. A USB connection requires the VISA library to be
installed. VISA detects and configures the R&S instrument automatically when
the USB connection is established. You do not have to install a separate driver.

You can retrieve the USB resource string from the "SGMA-GUI > Instrument
Name > Setup > Remote" dialog.

Example: 
USB::0x0AAD::0x00ce::100021::INSTR
0x0AAD is the vendor ID for Rohde & Schwarz.
0x00ce is the product ID for the R&S SGU.
100021 is the serial number of the particular instrument.

7.2.1.3  PCI Express interface

A PCI Express (PCIe) connector is provided on the rear panel of the instrument.

Refer to chapter "Advanced Remote Control via PCIe" of the user manual for a
description of how to set up a remote control connection via PCIe and the permit-
ted cables.

Via PCI Express some commands can be sent to the instrument with optimized
speed (memory-mapped remote control), e.g. frequency or level settings. Speed
optimization allows minimum setup time.

You can retrieve the PCIe resource string from the "SGMA-GUI > Instrument
Name > Setup > Remote" dialog.
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Example: 
PCIe::0x162f::0x132e::100021::INSTR
0x162f is the vendor ID for Rohde & Schwarz.
0x132e is the product ID for the R&S SGU.
100021 is the serial number of the particular instrument.

Using the PCIe interface for remote control of the instrument requires exten-
ded knowledge and is described in section "Advanced Remote Control via
PCIe" in the user manual.

7.2.1.4  GPIB interface (IEC/IEEE bus interface)

The R&S SGU is not equipped with an IEC/IEEE bus interface.

To be able to control the instrument via the GPIB bus:

1. Connect a GPIB-to-LAN or a GPIB-to-USB adapter to the instrument.

2. Use a GPIB bus cable to connect the instrument and the controller.

3. Provide the GPIB bus card, the card drivers and the program libraries for the
programming language in the controller.

4. In the "SGMA-GUI > Setup > Instruments > instrument name > Remote Con-
trol", set the "GPIB Address".

5. If the controller has several GPIB bus cards, define the used "Board Number".

GPIB address

The controller must address the instrument with the GPIB bus channel. GPIB pro-
vides channel addresses from 0 to 30.

The GPIB resource string is GPIB::<address>[::INSTR], where:
● GPIB denotes the used interface.
● <address> indicates the used channel.
● [::INSTR] indicates the instrument resource class (optional).

Note: If the VISA implementation supports the GPIB interface, you can optionally
define the VISA instrument control resource (INSTR). It is used to define the
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basic operations and attributes for a device, such as reading, writing, or trigger-
ing.

Any connected IEC bus cable must be terminated by an instrument or con-
troller.

7.2.2  Remote control over LAN using VXI-11 protocol

In the following example, the program "Measurement & Automation Explorer"
from National Instruments is used on a Windows operating system to set up a
LAN remote control link and to start a remote control session. The remote control
program "Measurement & Automation Explorer" opens the connection to the
instrument (using VISA functionality) and then sends commands to and receives
device responses from the instrument.

A remote control connection requires a VISA installation but no additional hard-
ware on the controller PC. The LAN I/O channel is selected at initialization time
using the VISA resource string (also referred to as "address string"). A VISA alias
(short name) is used to replace the complete resource string. The host address is
either the R&S SGU's computer name or its IP address.

Proceed as described in Chapter 4.13.2.2, "Assigning the IP address",
on page 31 to determine the relevant address information.

In this example, it is assumed that:
● A LAN remote control link between the controller and the R&S SGU is

already set up.
For information on setting up the link, see Chapter 4.13.2, "Connecting a
remote PC via LAN", on page 29.

● A VISA and the "Measurement & Automation Explorer" program are
installed on the remote PC.
For detailed information, refer to section "Remote Control Basics" in the
user manual or to the online help of the "Measurement & Automation
Explorer" program.
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To configure the controller

The instrument is preconfigured for networks using DHCP (dynamic host
configuration protocol). If you use this configuration, enter the computer
name in the position of the IP address.

To enable the external controller to communicate with the software via TCP/IP
protocol, set up a remote control link as follows:

1. Connect the controller and the instrument to the network (network cable).
Switch them on.

2. Start the 'Measurement & Automation Control' program on the controller.

3. Select "Devices and Interfaces > Create New".

4. Select "VISA TCP/IP Resource" and confirm with "Next".

5. Choose the type of TCP/IP resource, that you wish to add and select "Next".
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6. Enter the IP address or the host name of the R&S SGU.

7. Select "Next".

8. Enter the alias name, if necessary.
Do not mistake the alias name with the computer name. Only use the alias
name for instrument identification within the program. The menu displays the
alias name as an option, if there is an Ethernet link.

9. Confirm the settings with "Finish".
The instrument is configured and the settings are displayed in the "TCP/IP
Settings" tab.

10.To test the connection, select "Validate".
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A message indicates whether you can set up the link to the instrument or not.
If a connection cannot be set up, check whether the controller and the instru-
ment are connected to the network (network cable) and are switched on.
Check that the spelling of the IP address or the computer name is correct.
For further error location, inform the network administrator. Operation in large
networks can require additional addresses for link setup, e.g. gateway and
subnet mask. Contact your network administrator.

The instrument is now registered in the program and can be addressed via the
resource string or alias name.

To start a remote control session over LAN (using VXI-11)

1. Start the "Measurement & Automation Explorer" on the controller.

2. In the "Configuration" window, select "Device and Interfaces > VISA TCP/IP
Resources", select the required instrument and select "Open VISA Test
Panel".

3. In the "viWrite" tab, write the command to be sent to the instrument and select
"Execute".
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Instrument responses are displayed on the "viRead" tab.
Tip: For further program operation, refer to the online help of the program.

Network operation and remote control
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8  Contacting customer support
Technical support – where and when you need it

For quick, expert help with any Rohde & Schwarz product, contact our customer
support center. A team of highly qualified engineers provides support and works
with you to find a solution to your query on any aspect of the operation, program-
ming or applications of Rohde & Schwarz products.

Contact information

Contact our customer support center at www.rohde-schwarz.com/support, or fol-
low this QR code:

Figure 8-1: QR code to the Rohde & Schwarz support page

https://www.rohde-schwarz.com/support
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